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1 General 

1.1 Startup tips 

1.1.1 What are the PC requirements? 
If WinMLS is to be used for post-processing measurements, at least a 400 MHz PC with 64 Mb RAM is 
recommended. This is because a slower PC will give a slower performance on plotting large amounts of data and 
for computing room acoustics parameters. However, the speed of the plotting can effectively be increased, see 
the chapter How to speed up the plotting. 

1.1.2 What is the easiest way of performing a measurement? 
This is done by first loading a setup that contains the wanted settings (see the chapter below for more details).  
 



Start the measurement by clicking on the  button (or from Measurement->Start Measurement). If you 
want to cancel the measurement before it is finished, click the red stop sign (alternatively Esc or  Measurement-
>Cancel Measurement). 
You can test the output level from Measurement->Test Current Levels. 

1.1.3 What is a setup and how to use it? 
All the settings in WinMLS are saved in setups. There are two setups, one for measurement settings and one for 
post-processing settings (e.g. plot settings, such as x-axis type). Some setups have been made for you, but you 
can modify these and save your own setups.  
 
Setups can be loaded and saved from the Setups Toolbar (can be turned on/off from the View menu). Note that 
the icon to the right of the setup name turns red if a setting has been changed. The changes can be saved by 
clicking on the icon that turned red. 
When you load a measurement setup, the post-processing setup associated with this setup will be loaded. 
It is also a link toggle. If this is turned on, you will always save the post-proc. setup whenever the measurement 
setup is saved. 
 
Measurement setups can also be loaded and saved under Measurement-> Measurement Setup. Post-processing 
setup can be loaded and saved under Plot-> Post-processing Setup. 

1.2 Standard Windows 
The software has a standard windows interface and is written in Visual C++. 

1.2.1 What does “->” mean? 
The symbol -> is used for menus, e.g. File->Insert in Active Group..., means that you are to select the item 
Insert in Active Group...  under the File menu. 

1.2.2 What is a “toolbar” and how to use it? 
WinMLS makes extensive use of toolbars. A toolbar can be made visible and used all of the time in contrast to a 
standard dialog box. It is useful for checking settings and allows a fast change of the settings (no dialog box 
needs to be opened). All the settings in the toolbars can also be done from a standard dialog box (except for the 
Measurement settings toolbar), so the purpose of the toolbars is to increase the user friendliness. A toolbar can 
be placed anywhere on the screen, but if it is desired to use as much as possible of the screen to display the 
graph(s) then the toolbar can be removed. The toolbars are turned on/off from the View menu. From the View 
menu you see all available toolbars. Note that the toolbar on/off status and position is saved in the post-
processing setup. 

1.2.3 How to get a quick explanation of the buttons and menus? 
Place the mouse pointer on top of the button/list box or menu item you want to be explained. The explanation 
text will appear in the status bar at the bottom. For the toolbars, a short version of the explanation will appear as 
a tooltip just beside the mouse pointer. 

1.3 Important Terms 
These terms are important for the understanding and usage of this FAQ and WinMLS. 

1.3.1 What is a measurement group? 
This is what we call the document or window in WinMLS. A window can contain several measurements that can 
e.g. be plotted on top of each other. To add measurements to the window, either use File->Insert in Active 
Group… or perform a measurement. 
It is possible to have more than one window open in WinMLS. File->New Group opens an empty new window. 
File->Open... will open a measurement in a new window, and not in the current window. A common beginner 
mistake is to insert a measurement using File->Open … instead of using File->Insert in Active Group…. 

1.3.2 What is an active measurement? 
You can have several measurements in a window (called measurement group as described above). One of these 
measurements is called the active measurement. When performing or inserting a new measurement, this will 
become the active measurement.  
The active measurement is used in several ways 

• File->Save Active Measurement As.… will save the active measurement 



• Measurement->Measurement Information... will display information about the active measurement.  
• If auto-refresh is enabled in “active measurement” mode (Plot->Auto Refresh is set as shown in the 

figure below, 
 

 
 
the curve belonging to the active measurement will be refreshed when changes in the plot settings are 
made. 

1.3.3 What is an Active plot? 
WinMLS can display one plot or two plots in a window. If only one plot is displayed, this is always the active 
one. If two plots are displayed, you can click on one of the plots to set as active. A thin frame is drawn around 
the active plot. 

1.3.4 What is channel 1 and channel 2 on the sound card? 
WinMLS sometimes refers to channel 1 and channel 2 on the sound card. Channel 1 is the same as the left 
channel and channel 2 is the same as the right channel. 

1.3.5 What is a transducer? 
A transducer is a device for transforming a quantity to another quantity. An example is a microphone, which 
transforms sound pressure to voltage. Another example is a loudspeaker that transforms a voltage to sound 
pressure. 

1.3.6 What is a sound card? 
General term for hardware (A/D-D/A) used for performing the measurements. Sound cards can be built-in (they 
are not on a separate “card”) and USB. Calling a USB sound device or a built-in sound device for a sound card 
does not make much sense, but it is common practice so we will still use this term for all sound devices. 

1.3.7 What is an impulse response? 
When measuring a single input-single output linear system, such as a loudspeaker, the impulse response is 
defined as the output signal resulting from a short pulse input signal. The input signal pulse should theoretically 
be infinite short, this is called a Dirac pulse.  
The impulse response completely describes a linear system, it is quite intuitive (e.g. a hand-clap in a room will 
give the impulse response of the room), and the phase and magnitude frequency response can be calculated from 
the impulse response. Because of this and because a MLS measurement gives the impulse response as the result, 
the data from a MLS measurement is saved in time domain as an impulse response. 

1.3.8 What is MLS? 
MLS stands for Maximum Length Sequence. When the MLS measurement method was first introduced, the 
maximum length sequence was generated using shift registers. By connecting the shift registers in a special way 
it was found that a Maximum Length Sequence could be generated. This was the longest sequence that could be 
made before it repeated itself. If the number of shift registers is N the length of the sequence is 2^N - 1. The 
MLS signal can be used to measure any type of LTI (Linear Time Invariant) system, therefore nowadays 
Maximum Length Sequence measurements are used in different fields in addition to acoustics.  
 
The MLS method gives the impulse response of the measured system using cross-correlation between input and 
output signals. The impulse response can be easily windowed in the time domain. Using windowing, reflections 
(e.g. from the walls of the a room) may easily be removed from the frequency response. Using this feature it is 
possible to simulate the frequency response of a loudspeaker measured in an anechoic room. 
 
The number of averages determines how many times the MLS is repeated during the measurement. The reason 
for averaging is that it will decrease uncorrelated noise and thus increase the quality of the measurements. For 
each time the number of averages is doubled, the signal-to-noise ratio is theoretically increased with 3 dB. Note 
that the total measurement time increases when the number of averages increases. Be also aware of that if the 
system you are measuring is somewhat time-variant, a long measurement time is not good. An example of a 
time-variant system is a concert hall where people are running around. Try to avoid measuring during such 
situations. For room acoustical measurements, a measurement time of more that 60 seconds is seldom necessary. 



Electrical or mechanical systems are usually very little time-invariant, so the long measurement times are seldom 
a problem. 
 
 The MLS technique has many advantages when compared with other methods of measuring the response of a 
system. The MLS has a flat spectrum (contains equal amount of all frequencies. The DC component is rejected 
and may not be measured. The signal-to-noise ratio of a MLS measurement is high and may be increased by 
increasing the total measurement interval. The measured distortion of the system is spread throughout the 
computed impulse response as spurious peaks. Every MLS sequence has his own characteristic distortion 
pattern. Measuring the same system with different sequences may be used to detect the distortion.  

1.3.9 What is a transfer function? 
When measuring a single input-single output linear system, such as a loudspeaker, the transfer function is the 
FFT of the impulse response (do not take this as a definition, more an indication). 

1.4 Shortcut keys 
Some shortcut keys are supported. Requests for new shortcuts are welcomed.  
 
Ctrl+”G” Measurement->Start Measurement 
ESCAPE Measurement->Cancel Measurement 
Ctrl+”T” Measurement->Test Current Levels 
Ctrl+”F” Measurement->General Frequency Domain Settings… 
Ctrl+”W” Time data window settings for active measurement 
F5 Display the settings for the active plot type 
Ctrl+”A” File->Save Active Plot As… 
Ctrl+”I” File->Insert in Active Group... 
Ctrl+”N” File->New Group 
Ctrl+”O” File->Open... 
Ctrl+”P” File->Print Active Plot 
Ctrl+”S” File->Save Active Measurement As… 
Ctrl+”L” View->Volume and Input Level(s) Dialog 
Ctrl+INSERT Edit->Copy to clipboard… 
Ctrl+”C” Edit->Copy to clipboard… 
Ctrl+”M” File->Save Active Measurement->As Meas Sys Corr File… 
Ctrl+Alt+”C” File->Save Active Measurement->With Filename <_ActiveMeas_>… 
 

2 Troubleshooting 

2.1 An error message is given when trying to perform a measurement, why? 

2.1.1 The sound card does not support stereo full duplex 
If you have a mono full duplex sound card (this is the case for some older sound cards, but very unlikely if your 
sound card is new), then go to Measurement->Sound Card Settings and make sure 1-ch mode is set according 
to the figure below:  
 

 
 

2.2 My measurements look too good, why? 
This may be because somehow the output signal may be directly connected to the input (the sound card may be 
defective or badly constructed). This has been reported for an early version of SoundBlaster 128, SB128PCT 
(CT4700). However, the SB128 PCI (CT4810) has been reported to not have this problem. 

2.3 When changing the preferred sound device in windows multimedia properties, WinMLS 
does not work properly, how to fix this? 

WinMLS uses a device number for identifying the sound devices. When changing the preferred device in 
multimedia settings this number will change, this will affect the WinMLS device settings. Therefore, make sure 



to first set the preferred device in multimedia settings. Then to go to Measurement->Sound Card Settings and 
make sure the correct input device and output device is chosen. 

2.4 There is feedback during the measurement, how can it be turned off? 
You may experience feedback when connecting speakers and microphones to your sound card. This is because 
the sound card may patch the signal present on the input to the output. If the WinMLS mixer is used (set in 
Measurement-> Sound Card Settings…), this should be avoided by making sure  
is checked under Advanced Settings in Measurement->Sound Card Settings….  
If the WinMLS mixer is not used, the feedback is not just annoying but can affect the measurements as well, 
Feedback is detected as false echoes in the impulse response and as comb filtering in the frequency response. 
The unwanted feedback can be turned off using the Windows sound card mixer. The setting in the Windows 
sound card mixer that gives the feedback has different names depending on the sound card. If you mute all inputs 
and outputs that you are not using for the measurement signals the feedback should be damped. See the chapter 
If your Sound Card does not support the WinMLS Mixer in the WinMLS2000 User’s Guide for more 
information. 

2.5 Why does a small change the in volume settings in the WinMLS give no effect? 
If the WinMLS mixer is calibrated (see Measurement->Hardware Calibration...), a change in the volume 
setting will give effect since the calibration procedure has detected the level steps. However, if the mixer is not 
calibrated, the sound card level steps have not been detected, and slight changes in volume may not be 
supported. There should be at least 16 different levels and maximally 65535 levels of volume to choose from.  

3 Plotting and post-processing 

3.1 Plotting – general information 
Some general plot-settings are found on the standard toolbar to the right of the red stop sign. Important settings 
are found on Plot Toolbar (initially situated at the bottom). From the Plot Toolbar you can do all kinds of 
zooming, choose plot type, choose number of plots to be displayed (1 or 2) and open the settings dialog box for 
the active plot type. 

3.1.1 How to plot a measurement? 
If a measurement is performed, inserted or opened, it will be plotted automatically if the check box Perform 
plotting is turned on in Measurement->Measurement Tasks.... 

3.1.2 How to display two plots simultaneously, e.g. the upper plot displaying frequency response 
and the lower phase response? 

You can choose to have one or two plots in a window from the Plot->Select Plot Type(s) /Measurement(s)..., 

or use the  button on the Plot Toolbar. 

3.1.3 What does active plot mean and how is it set? 
See What is an Active plot? 

3.1.4 How to set the plot type (to e.g. phase response) and determine what measurement is to be 
plotted? 

All this can be done from the Plot Toolbar and the Measurement Selection Toolbar: The type of plot is 
determined from the list box list in the plot toolbar (View->Plot Toolbar). The “active” measurement is set from 
the list box in the measurement selection toolbar (View->Measurement Selection Toolbar).  
 
If you do not wish to use the toolbars, from Plot->Select Plot Type(s)/Measurement(s).... you can select the 
type of plot and the measurement you wish to plot assuming that the measurement has been inserted into the 
active window (This can be done from File->Insert in Active Group...). Changes in this dialog box will 
immediately apply to the active plot even though Plot->Auto Refresh is set in Off position. 

3.1.5 How to access the settings for the plot type? 
If two plots are displayed, first set the plot you want to access the settings for as active by clicking in it. Then 
type the F5-key or click the rightmost button on the Plot Toolbar or simply double click in the plot. The settings 
can also be accessed from the menu; Plot->Plot Type Settings. A dialog box will appear displaying the settings 
for the plot type. All settings (except layout settings) will be available from this dialog box. Note that the button 



 displays the settings for all the frequency domain plot types. If a 
setting in this dialog box is changed, it will thus affect all the frequency domain plot types in the active window. 

3.1.6 If a setting is changed for the displayed plot-type, how are the curves belonging to the plot 
updated? 

This is done automatically, the choices are as shown below: 
 

 
 

• If Plot->Auto Refresh->Active Measurement is selected, the curve belonging to the active 
measurement will be updated automatically if any changes in settings are being made.  

• If Plot->Auto Refresh->All Measurements is selected, all curves are updated automatically if any 
changes in settings are being made (see comment below). 

• If Plot->Auto Refresh->Off is selected, no curves will be updated. Auto-refresh can also be turned off 

with the  button. 
 
Refresh can also be done manually using: 

• Plot->Refresh - refreshes the curve belonging to the active measurement 

• Plot->Refresh All or  refreshes the curve belonging to the active measurement (see comment 
below). 

 
Note that Plot-Refresh All and Plot->Auto Refresh->All Measurements will refresh only the most recent 
curve of each measurement in the active plot. This means that if you have plotted several curves from the same 
measurement, these will not be refreshed. 

3.1.7 How to change y-axis scaling? 
The y-axis scaling can be changed, e.g. from Linear to dB of plot type Time Data (Impulse Response). 
If two plots are displayed, make the plot you want to change the scaling of active by clicking in it. Then click 

 (or F5) to open the active plot type settings. Then at the upper part of the dialog change the content of the 

Y-Axis list box.  

3.1.8 If waterfall is plotted, how to read the waterfall slice values using the cursor? 
This is only supported if the waterfall layout mode is Separate lines waterfall as shown below. 
 

 
 
This is set from the waterfall plot type settings (found by double-clicking in the plot, by typing F5, or Plot->Plot 
Type Settings->Waterfall…). 

On the right part of the Frequency Plots Toolbar, the buttons  and  can be used to mover upwards and 
downwards and select the slice. The selected slice from which the values are read from is plotted in green.  

3.1.9 If there are many lines in the waterfall plot, how to space the lines less close together? 
The lines can be spaced too far apart if there are many lines in the plot. If the waterfall layout mode is Separate 
lines waterfall this can be the case; the z-axis may disappear into the distance and the plot gets very flat in the y-
axis. 
 
This can be solved from Plot->Chart Settings for Active Plot..., select the 3D tag as shown below. 
 



 
 

One method is to change the z-axis density, this is done in . 
 
Another method is to turn off  and change the Rotation and Elevation values.  
 
Selecting another layout mode can also solve this problem. In Plot->Plot Type Settings->Waterfall select 
Waterfall or Surface in the layout mode list box.  

3.1.10 When plotting waterfall, how to select the start point? 
The start point is set by start of the time data window. See below on how to set this. 

3.1.11 How to set the time data window when plotting in frequency domain? (determine part of the 
time data to be used when transforming to the frequency domain)? 

The time data window determines the part of the time data to be used when transforming from time domain to 
the frequency domain. Three ways of setting  the time window this will here be described. 
 

• The time data window settings can be obtained from Plot->General Frequency Domain Settings…, 

click on the  button found in the upper left part of the 
dialog box. 
If you are performing division, the time window settings for the reference measurement are obtained by 

clicking the  button found in the lower left part of the 

dialog box. If you need faster access to these settings, they are found clicking  and  on the 
Frequency Plots toolbar (View->Frequency Plots Toolbar).  
 

• If the Time Data Plot type is displayed, the window start and end points can be set directly by clicking 
and dragging with the mouse. To do this,  must be checked in 
the time data plot type settings (Plot->Plot Type Settings->Time Data…). Some might find it difficult 
to do this since the mouse pointer has to be exactly on top of the vertical line that is to be moved. If you 
find it difficult to use the mouse for doing this, the fast method explained below may be useful. 

• Another way of setting the window directly is by using the Time Window toolbar (View->Time 
Window Toolbar). If a change is made and auto-refresh is on, the plot will be automatically updated 
with the new settings. After typing a value, click Enter to validate. 

 

3.1.12 How to speed up the plotting? 
If fast plotting is required, first make sure you are using Fast Line as line type. This can be set at the bottom of 
Plot->Advanced Plot Settings..., in the Curve type list box.  
 

 
 
Note that these settings apply for the active plot type only. 
The plotting speed can be additionally improved using two methods. The first method has no side effects and has 
a great effect on the speed; it is simply to set the curve width to size 1. If it is not set to width 1, the plotting is 
much slower. Set the width in Plot->Default Curve Styles..., this will apply to all plot types. Make sure that all 
the curves in the dialog box have width 1. Also at the bottom of the dialog box, make sure that Display active 
curve with width is set to 1. 



The other method gives very efficient plotting for large amounts of data, e.g. for large *.wav-files. From Plot-
>Advanced Plot Settings… check . If this setting is on, the points in between the points plotted 
are simply skipped independent of what part of the curve is displayed. This will affect all the plot-types 
originally having more elements than the maximum limit. Please note that the skipped points will not appear 
when zooming in, therefore it is not recommended to use this option on a fast PC. The plotting range can also be 
limited by checking . 

3.1.13 Where are the cursor values (x,y) in the plot displayed? 
The position of the mouse pointer relative to the curve of the active measurement is written to the Status Bar (at 
the bottom right). Using this you can read out the values of the active measurement curve. 
Note that if you have plotted several measurements it is the one belonging to the active measurement that is 
displayed. 

3.1.14 Where is the wavelength displayed? 
When a plot type has frequency as x-axis the wavelength is displayed in the status bar to the left of the x and y-
values (see above). 

3.1.15 How to save the data in the plot? 
The data in the active plot can be exported to .txt-file in File->Save Data in Active Plot As….  
A method that gives access to advanced settings is found in Plot->Chart Settings for Active Plot..., click the 
Export tag, then click the Data tag. The dialog box will then show the settings below. 
 

 
 
In the Series list, it can be chosen if all or just one series is to be exported. 

3.1.16 How to save the plot as a picture? 
The active plot is saved to a picture format in File->Save Active Plot as…. From this dialog box, several 
formats can be selected as shown below. 
  

 
 
If the .tee-format is selected, the file can be opened by WinMLS later and changes can be made, but a 
disadvantage is that the size can get large if the plot consists of large amounts of data.  
 
Ctrl+C or Edit->Copy to Clipboard will copy the active plot to clipboard.  
 
A method that gives access to more advanced settings is found in Plot->Chart Settings for Active Plot..., click 
the Export tag. The dialog box will then show the settings below. 
 



 
 
From the figure above, we see that it is possible to set the quality and size when saving as .jpg-file. 

3.1.17 How to view and manipulate the data of the plotted curves? 
The plotted data can be viewed and manipulated from Plot->Chart Settings for Active Plot..., click on the Data 
tag. Note that you can increase the size of this dialog box, which is convenient you want to inspect curves with 
large amounts of data. 

3.1.18 Why are plot toolbar axes limits not updated when a plot is zoomed or scrolled? 
Normally the x- and y-axis limits will be updated when zooming or scrolling, but if you have two plots visible 
and are zooming/scrolling in the plot that is not active, then they will not be updated since they will display the 
values of the active plot. 

3.1.19 How to make calculations, such as average and difference on plotted curves? 
First plot all the curves you want to perform calculation on and go to Plot-> Chart Settings for Active Plot.... 
In the dialog box, you will see the list of the plotted curves/series. Generate a new curve/series by clicking 

 Select series type, e.g. Fast Line as shown below. 

 
 
Click on the Functions tag in the upper part of the dialog box. You can select from three tags containing 
different mathematical functions, Standard, Financial and Extended. 
 



 
 
Double-click on the type of mathematical function you want, e.g. Add (see above). You will then go to the series 
properties (see below). 
 

 
 
In the Source Series part, mark the series you wish to do the computation on (in the figure above CurveMeas. 7 
and CurveMeas. 4 have been marked).  

Now use  to move them to the Selected: list. If you want to move all measurements, then use . 

When this is done, click  to exit the dialog box. You will now see the new series in the plot.  

You can change the title of the new series by clicking  in Plot->Chart Settings for Active Plot.... 
How to save the data in the plot to a *.txt-file is also described in this FAQ. 



3.1.20 How to plot a transfer function (e.g. room or loudspeaker measurement) in octave or third-
octave bands? 

The energy or power can be plotted in octave or third-octave bands if Frequency response/Spectrum is selected 
as plot type. 
 
Click F5 to display the plot settings dialog box. Make sure that Use Smoothing (or integration) is checked as 
shown in the figure below. Click on the Settings… button also shown in the figure below. 
 

 
 
In the new dialog box, select smoothing type as shown below (it will plot 1/3-octaves starting from 50 Hz). 
 

 
 
Click OK to exit the dialog boxes.  

3.1.21 How to plot spectrum in octave or third-octave bands? 
The easiest way is to load the setup called QuasiRealTimeAnalyzer. Below it is described more in detail how it 
can be done without loading the setup. This is not intended to be used for transfer function measurements, since 
it will give a 3 dB/octave bias because of the integration explained below. 
 
The energy or power can be plotted in octave or third-octave bands if Frequency response/Spectrum is selected 
as plot type. In Plot->General Frequency Domain Settings... select the scope mode to one of the below. 
 

 
 
Click F5 to display the plot settings dialog box. Make sure that Use Smoothing (or integration) is checked as 
shown in the figure below. Click on the Settings… button also shown in the figure below. 
 

 
 
In the new dialog box, select smoothing type as shown below (or select the 1-octave Integrated option). 
 

 
 
Click OK to exit the dialog boxes.  
An example of 1/3 octave normalized energy is displayed in the figure below.  
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In this figure, we have used curve type Histogram to get the bars (can be set in the bottom of the Plot-
>Advanced Plot Settings… dialog box). For information about how to display the values for each point, read 
the chapter How to change the curve style (color, type and width)? 

3.1.22 How to validate numbers typed in the Plot Toolbar? 
If values are entered to this toolbar, they must be validated clicking Enter if the auto-zoom button is turned on as 
shown below. 
 

 

3.2 Plot Chart Settings  
The features below are found in Plot->Chart Settings for Active Plot... or from the  button on the standard 
toolbar. Note that in this dialog, the plotted curves are called series and the plot settings are called chart settings. 
When there are two plots visible, we have two plots, and one chart setting for each of them. The chart has many 
possibilities, far from all are covered here. But when first starting to use it, it should be quite intuitive to explore 
the possibilities. 

3.2.1 How to change the curve type? 
When installing WinMLS, the default curve type is set in Plot->Plot Options… as shown in the figure below. 
 

 
 
To change the curve type without changing the default curve type, in Plot->Chart Settings for Active Plot..., 

click on  to. For an explanation see the documentation under Plot->Plot Options…. 

3.2.2 How to change the curve style (color, type and width)? 
The defaults curve style can be changed in Plot->Default Curve Styles…. The changes will apply when plotting 
a new measurement. To update the current curves, select Plot->Refresh All. 
If you want to keep the default curve styles but just want to change the curve styles in the current plot, then it can 
be changed directly from Plot->Chart Settings for Active Plot....  
If you want to change the color only, click on the curve to the left of the series title, the red horizontal line shown 
in the figure below.  
 

 
 
(You can do the same thing from the List of Curves toolbar, View->List of Curves Toolbar). 



 
If you want to display the style settings, double-click on the curve title (CurveMeas. 1 shown in the figure 
above). If the curve type is FastLine, the settings shown below will be displayed. 
 

 
 
From the Style list the options shown in the figure below can be selected. These are especially useful if plotting 
several lines and colors are not allowed. Note that if the curve width is larger than 1, the style can only be solid. 
 

 
 
To display the value for each point, marks must be set to visible. This is set from Plot-> Chart Settings for 
Active Plot... as shown in the figure below. First select the series, then the Marks tab. In the Style tab, make 
sure Visible is checked. 
 

 
 

3.2.3 How to plot figures in black and white only (e.g. for publishing)? 
Sometimes figures in color are not accepted, e.g. for publishing articles in journals. If this is the case, it is 
recommended to load the post-processing setup file named BlackNWhite (found on the Setups Toolbar). This 
setup will make sure that the background is white and the plotted curves are in black. If several curves are 
plotted, some curves are plotted dashed and dotted. The defaults for this are set in Plot->Default Curve 
Styles….  
If you are to change the curve style, please see How to change the curve style (color, type and width)?. An 
example of a plot in black and white made using WinMLS is shown below. 
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The plot can be saved from File->Save Active Plot As…. If saved in the .tee-format, it can be opened again 
using WinMLS, this is useful if formatting adjustments are to be made later. 

3.2.4 How to change the order of curves? 
From Plot-> Chart Settings for Active Plot..., the order can be changed by clicking and dragging. Note that the 
curve at the end of the list is the upper curve displayed in the plot. You can also change the order from the List 
of Curves Toolbar (View->List of Curves Toolbar). 

3.2.5 How can I delete a single curve? 
From Plot->Chart Settings for Active Plot..., click on the curve(s) to be deleted and click the delete button or 
delete key.  
You can also do it from the List of Curves Toolbar (View->List of Curves Toolbar) as shown below. 
 

 
 
Mark the curve(s) you want to delete by clicking on the curve name(s). Use Shift or Ctrl if you want to mark 
several curves. Then use the Delete key to delete the marked curves. 

3.2.6 How to choose between plotting several curves and a single curve? 
If Plot->Hold plotted curves is turned on, the new curve plotted will be added to the existing curves. If it is 
turned off, the existing curves will be deleted when a new curve is plotted. 
Plot->Hold plotted curves is also available on the standard toolbar as the  button. 

3.2.7 How to display one single curve as Solo? 
When there are several curves in the plot, it is sometimes useful to display only one of the curves temporarily 

without deleting the others. This can be done with the  button on the toolbar, or from Plot->Solo Active 
Measurement. 
 
When Solo is on, only the active curve is active and displayed and the other curves will not be visible in the plot, 
only in the legend. If Solo is turned off, all curves that were displayed when Solo was turned on will be 
displayed again.  

3.2.8 When printing a plot, why is the plot squeezed to the left corner? 
This is probably because the legend is displayed. The legend may be turned off using the  toggle on the 
Standard Toolbar. The legend may also be moved inside the plot, see below on how to do this. 

3.2.9 How to add legend, displaying a list of the curves that are in the plot? 
Turning on the  toggle on the Standard Toolbar adds legend. If you want to set the legend formatting or 
position, the legend settings are found in Plot->Chart Settings for Active Plot..., select the Legend tag. Note 
that a check box for determining if the curve is to be displayed in the plot, or not, can be added or removed from 
the legend. See below for more information about this. 

3.2.10 How to “turn off” a single curve from the plot without deleting it? 
When there are several curves in the plot, it is sometimes useful to temporarily set one of the curves inactive 
without deleting it. WinMLS offers several ways of doing this:  
In Plot->Chart Settings for Active Plot... all the available curves are displayed, they are shown in the plot only 
if the check box is checked. The list is displayed in the List of curves Toolbar (View->List of Curves 
Toolbar). 
It can also be done very efficiently by turning on the legend button on the standard toolbar. The legend settings 
are found from Plot->Chart Settings for Active Plot..., select the Legend tag. Then turn on the check box 
named Check boxes. 



3.2.11 How to zoom the plot using the mouse? 
If the mouse zooming is turned on (see below) this can be done. To zoom in, drag a rectangle from upper left to 
lower right. Note that this is the only way to zoom in if using the mouse. If you drag a rectangle any other way 
this does zooming out.  
Zooming can also be done very efficiently by the Plot Toolbar. Note that in certain cases, if the plot is to be 
zoomed out, the mouse zooming will not zoom enough. Then click on the Autoscale all button on the Plot 
Toolbar (View->Plot Toolbar). 

3.2.12 How to access zoom options, e.g. to turn the mouse zooming on/off ? 
From Plot->Chart Settings for Active Plot..., select the General tag, then select the Zoom tag as shown below.  
 

 
 
The mouse zooming can be set from the Allow check box. Note that the “animated” setting will do the zooming 
in steps; this is a nice visual effect, but is not recommended on a slow PC. The Minimum pixels edit box 
determines the minimum size of the rectangle drawn by the mouse to obtain zooming (if the rectangle is smaller, 
no zooming will be performed). The Pen and Pattern buttons can be used to display the zoom rectangle area in 
different ways.  

3.2.13 How to scroll the plot using the mouse?  
Clicking on the right mouse button and drag will do scrolling if scrolling is enabled.  
 
The type of scrolling (on/off/vertical/horizontal) can be set. Under Plot->Chart Settings for Active Plot..., 
select the General tag, then select the Scroll tag, then mouse zooming can be set from the Allow Scroll radio 
buttons.  
 

3.2.14 How to turn on and modify gridlines 
Gridlines can be turned on/off from a button on the standard toolbar. Note that when the Plot->Chart Settings 
for Active Plot... dialog is opened, the current gridlines are displayed even if they are turned off. Note also that 
if the plot type is Frequency response/Spectrum, Phase response/Function, Group delay, Waterfall or 
Levels and if the x-axis is logarithmic, some of the gridline settings are not user changeable. 
 
The gridline settings depend on the setup that is used. The gridlines can even be turned off in the setup. To turn 
on or modify the gridlines; in Plot->Chart Settings for Active Plot... select the Axis tag. Then select the axis 
from the list (Left Axis or Bottom Axis). Click on the Ticks tag. Finally click on the Grid… button and turn on 
the Visible check box.  
 



 
 
Minor gridlines are available from the Minor tag, found at the right side of the Ticks tag. 

3.2.15 The y-axis labels show only zeros, how to change this? 
The axis labels resolution has to be set. See below on how to do this. You have to make sure to set it for the Left 
Axis. If you select the exponential format this problem should be solved.  

3.2.16 How to set the axis labels format? 
As examples on setting the format, we will first show how to set the axis labels resolution, then the labels 
increment. 

3.2.16.1 How to set the axis labels resolution? 
A problem can be that the resolution of axis value numbers (now 3 decimals) should be switched to an auto-
function, because mostly 3 decimals is not necessary, sometimes it is too little. Using an exponential format can 
solve this. How the format is set will be shown. 
From Plot->Chart Settings for Active Plot... click on the Axis tab. Select the desired axis, found on the list to 
the left, e.g. Bottom Axis. Then click on the Labels tab, and finally on the Format tab (see figure below). 
 

 
 
The Values Format: list box has a list of used formats. You may also type your own format. To the left in the 
dialog box you see a list of the axes. Select the axis you want to change the format of (“left” is the y-axis and 
“bottom” is the x-axis). 



3.2.17 How to set the axis labels increment? 
This is useful if you for example want to plot the magnitude frequency response using axis labels with an 
increment of 5 dB/div for comparing with printouts from other measurement systems. 
We will show how you can force WinMLS to label the selected axis using a specified increment. From Plot-
>Chart Settings for Active Plot.... click on the Axis tab. Select the axis you want to modify (Left axis or 
Bottom Axis) in the left corner of the dialog box. Then click on the Scales tab (see figure below). Click on the 

 button found at the bottom of the figure below. In the new dialog box, type the desired increment 
using comma as separator and click OK. If you type “0,2”, the Desired Increment will be set to 0,2 as shown in 
the figure below. 
 

             
 
Note that the selected increment will only be displayed if there is enough separation between the labels. This 
should not be a problem, but by clicking the Labels tab shown in the figure above the separation can be set in 
percentage: 
 

 

3.2.18 How to display the numerical values of the Magnitude Frequency Response Guidelines? 
When Frequency Response/Spectrum is selected as the active plot type, it is possible to add guidelines. This 

can be done by clicking  to open the settings dialog. Then click on the guidelines  
button. From this dialog, the numerical values can be turned on/off using . 
To display the numerical value of these lines can also be done in the legends: 
In Plot-> Chart Settings for Active Plot..., click the Legend tab. In the Legend Style list box choose Last 
Values. This means that the last value of the series will be displayed in the legend. Since the guidelines are 
linear this is the value of the guideline. Turn the guideline on in the Visible check box at the upper left in the 
dialog box.  

3.2.19 How to add a text box to the plot? 
In Plot->Chart Settings for Active Plot..., click on the Tools tag. Then click on the Add… button. From the list 
select Annotation and click on the Add button. A text field as shown in the figure below will be displayed. Type 
the text in the field, and below the text field the position can be set. 
 

 
 



3.2.20 How to add a cursor (cross) that follows a curve? 
In Plot->Chart Settings for Active Plot..., click on the Tools tag. Then click on the Add… button. From the list 
select Cursor and click on the Add button. From the Series: list box, select the curve you wish the cursor to 
follow. Turn on the Snap and Follow mouse check boxes. Click Close to exit the dialog box. 
Note that if you selected the active measurement, the cursor values are displayed at the Status Bar. 

3.2.21 How can curves in the plot remain so that they are there when the program is restarted or a 
new window is opened? 

Do this if you want to start up the program with one or several reference curves present. 
The automatic save of the Plot Settings settings must be turned off since it will delete the curves. From Plot-
>Advanced Plot Settings…, make sure is not checked. 
If the layout settings are saved manually from the Save or Save As… button in the same dialog box (Plot-
>Advanced Plot Settings…), the curves will be deleted. To avoid this happening, perform the saving to the 
*.tee-file from File->Save Active Plot As…. Find the folder where WinMLS is installed and select the folder 
named Chart. Then select the folder corresponding to the plot type you are currently using. 
Note that when  is not checked, temporary .tee-files are 
not saved. This means that the settings that belong to the Plot Settings will not be saved when the program is 
exited or on File->New Group. 

4 Measurement 

4.1 How to perform a 1-channel measurement (MLS) using WinMLS? 
This is explained in the WinMLS2000 User’s Guide, see the chapter ‘The First Measurements”. If you are in a 
hurry, a short description is given below. 
 
This explains how a 1-channel measurement in loop-back mode can be performed with a loudspeaker and a 
microphone. (If you do not need to measure the distance between the microphone and loudspeaker, or if your 
sound card is synchronized, you do not need to measure in loop-back mode. Then you do not have to connect the 
output right channel to input in right channel, and make sure  
 

 
is set in in Measurement->Sound Card Settings). 
 
Measurement preparation:  
Connect a speaker to output left channel. Connect a microphone to input left channel. Connect the output of right 
channel to input right channel. Make sure  
 

 
 
is checked in Measurement->Sound Card Settings. The ‘end-check’ will notify you if gaps has occurred 
during the measurement an thus made the result wrong. 
 
Measurement procedure: 

Click the  button in the standard toolbar. A synchronization signal is first sent through the right channel 
output. The synchronization signal is recorded and is used to find the correct initial time delay.  
Then the MLS signal is played on left channel output, through the speaker. The signal is recorded at the left 
channel input where the microphone is connected.  
After the measurement signal is finished playing in left channel, the synchronization signal is played once more 
on the right channel output. This synchronization signal is compared against the first synchronization signal and 
the time difference is computed. The purpose of this is to check that there has been no gaps in the playback or 
record. Gaps may occur if the PC was busy with other things during the measurement.  
If no error has occurred, the system impulse response is found using cross correlation. The delay of the 
measurement system (pipeline delay in sigma-delta converters) is added in order to get the whole system 
response (the default is 40 samples, but this can easily be measured for the specific sound card by doing a loop-
back measurement of the sound card).  



 
It is possible to correct for the influence of the measurement system (sound card). This is done by first doing a 
loop-back measurement of the measurement system only. This measurement is then deconvolved with the actual 
measurements. Measuring the measurement system with system correction turned on will give a Dirac pulse 
(value 1 at the first sample and value ~0 at the other samples). This will give a flat magnitude and phase 
frequency response. 
If this correction is not done, there will be an extra time delay usually of about 1 ms (40 samples or ~0.3 meter) 
because of the sound card delay. 
 
It is further possible to perform 2-channel measurements (measure two system responses in one measurement) 
using the same loop-back technique. This is covered in the WinMLS User’s Guide. 

4.2 How to check that my sound card measurement is correct? 
Measurements of several sound cards/cards are found in the WinMLS sub folder Measurements/SoundCards. 
Plot your measurement and compare with one of these (use File->Insert in Active Group... to insert one or 
more of the sound card measurements). 

4.3 How to perform a triggered measurement? 
This instruction assumes that you have been using WinMLS, if not please read the start of the Measurement 
chapter. 
On the Measurement Selection Toolbar, set the measurement mode to Triggered, no excitation (scope) as 
shown below 
 

 
 

On the Measurement Settings toolbar, make sure that the number of averages is set to 1, as shown to the right 
in the figure below. 
 

 
 
Set the sequence order to a length that corresponds to a larger length than the signal you are to record. If you use 
16, as shown above, the measurement length is 1.365 sec. 
 
In Plot->General Frequency Domain Settings... set scope mode to 

. 
 
Now make sure the input level is set high enough, but not overloaded. Do this by selecting Measurement->Test 
Current Levels and “play” the signal that is to be use for the measurement. 
 
Finally, perform the measurement (Measurement->Start Measurement). 
Note that it takes a while before the recording starts, at the left part of the Status Bar you will be notified when 
it is started. 

4.4 How to calibrate the input of the measurement system? 
The purpose of calibrating the input is to be able to measure absolute level (input level absolute calibration) and 
to obtain the true transfer function gain independent of the level of the WinMLS mixer input (relative calibration 
of mixer). The calibration can be done in different ways dependent on the features of the sound card (e.g  if the 
sound card supports the WinMLS mixer or not) and the type of measurement you intend to perform. For some 
sound cards, e.g. VXPocket, a measurement setup file will be available with nominal calibration settings. 
 
If the sound card input and output is calibrated, a MLS measurement should give an amplification of 0 dB for a 
loopback measurement (input directly connected to output). If also the mixer is relatively calibrated, this should 
be independent of mixer settings. 

4.4.1 How to perform relative calibration of mixer input levels? 
The WinMLS mixer controls the analog input and output amplifier of the sound card (some sound cards do not 
have a Windows mixer, and some cards have a mixer that can not be controlled by WinMLS). The relative 



calibration will generate a file containing the gain steps for the mixer, this file is used for correction when the 
mixer gain is changed. So when a relative calibration has been done for the WinMLS mixer, changing the 
volume of the WinMLS mixer input will not affect the level of measurement.  
 
To activate relative calibration for the mixer, go to Measurement->Hardware Calibration.  
 

 
 
In the dialog box shown above under WinMLS mixer INPUT relative calibration make sure  
is checked. To the right of this check box, you can select the correction file to be used from a list of files.  
 

 
 
If you are using the sound card VXPocket or VX222, we recommend that you use the file VX222-VXPocket 
instead of generating a correction file. 
 

To generate a new correction file, click the  button. This calibration procedure may take some 
minutes, all the gain steps of the mixer will be tested and measured. When finished, we recommend that you test 
the results by performing some measurements with different WinMLS input volume settings. This can be done 
by measuring the sound card loopback (input connected to output), plotting the frequency response (Frequency 
Response/Spectrum). Making sure that all the measurements have exactly the same level. Especially the lowest 
mixer levels should be tested since these may be influenced by noise. It is possible to edit the values by opening 
the calibration file e.g. using the Windows Notepad (it is a text file). 
 
If your sound card supports 24 bits, the use 24 bits for recording to get the best results (in Measurement-
>Sound Card Settings set Input number of bits: to 24). If you are doing a 2-channel measurement, the relative 
calibration for both channels is done using the same correction file. The mixer steps for channel 1 should be 
equal to channel 2, but we recommend that you test this. 

4.4.2 How to perform absolute calibration of input level? 
The purpose of the calibration is to be able to measure the absolute quantity, e.g. voltage or sound pressure level 
(SPL). To activate input calibration, go to Measurement->Hardware Calibration. In the dialog box, enable the 



calibration by checking . To perform a new calibration or view the settings, click on the 

 button. Make sure the channel number to the right of the button is set to 1 if you are doing the 
calibration for one channel measurement. For a multi-channel measurement, each channel has to be calibrated, 
the procedure is the same as for calibrating channel 1. In the following we describe the procedure for calibrating 
channel 1. 
 

 
 
After clicking the Settings... button shown above, the Input level calibration for channel 1dialog box will be 
displayed.  
 

 
 
In this dialog box, the upper list box determines if you want to calibrate the whole measurement chain in one 
operation (Total calibration), or calibrate each part of your measurement system (Detailed calibration) as 
shown below.  
 

 
 
If you intend to calibrate with a transducer (e.g. a microphone) connected to the input, the check box 

 must be checked. In the list box to the right of the check box, specify the type of 
transducer. A microphone would get Pres [Pa]. By doing this you will get the correct units during calibration 
and the correct units on the left axis (y-axis) when plotting measurements. 
 
Make sure that the input and output volume is not too high because this will give clipping of the input signal. It 
should not be too low either, because this may give unreliable results due to background noise.  
 
Note that if you are using the VXPocket or VX222, there is a special gain setting in the sound card mixer under 
Advanced Input that can be used to switch the input from Line to Microphone (see the Tested Sound Cards 
file). 

4.4.2.1 How to perform “Total Calibration”? 
The purpose of this type of calibration is to calibrate the whole input chain in one operation. This calibration is 
fast and simple. However, if you are using WinMLS both for electrical measurements and measurements where 
you are using a transducer (e.g. a microphone) or a pre-amplifier with changeable gain, we recommend that you 
instead use the Detailed Calibration (see next chapter).  
 



If you are not already in the Input level calibration for channel 1dialog box, go there (Measurement-
>Hardware Calibration, click Settings… to the right of the Input calibration check box.  
 
First make sure that the list box named Type of calibration at the top of the calibration dialog box is set to Total 
Calibration.  
 

 
 
Right below, make sure that you have checked  if you are using a transducer. Select 
in the list box the unit of the transducer you are using (for a microphone this would be Pres [Pa]). 
 
The settings for the total calibration are shown below:  
 

 
 

Click the  button to view the Total Cal. Settings dialog box.  
 

 
 
From here you can set the level and frequency for the calibration, and choose if you want to use an external 
signal generator or use the sound card output as signal generator. Using the sound card output should be fine as 
long as you have something to measure the signal level with (the measured level is used as the reference level), 
e.g. a voltage meter if you are doing an electrical calibration.  
 
If you are to connect a signal generator or a calibrator to the input, choose Use external signal generator in the 
list box. Type the signal generator/calibrator frequency and level in the edit boxes. 
 
If you are to use the sound card output as signal generator choose Use sound card output as signal generator 
(full scale output) in the list box. Select the frequency, 1000 Hz should be fine for most purposes. Then the 
output signal must be measured with an external device in the unit you wish to do the calibration for. Use a 
voltage meter if you are doing an electrical calibration and a SPL meter if you are calibrating a microphone using 

a loudspeaker. The  button should be clicked to test the levels (End level test can be clicked 

to stop the playback of the calibration signal). After the  button is clicked, measure the level 
using the external device. Type the measured level in the dialog box below the frequency setting and exit the 

dialog box by clicking .  
  
Make sure that you have connected the calibration signal to the correct input channel (channel 1 is left). 
 

Now click the  button to perform the calibration. After the calibration is performed, the number to the 
left and the date to the right of the Calibrate button will be updated with the new settings. Now you can do a 
measurement to test if the calibration is correct. You can use sinusoid as excitation signal (see How to use a 



sinusoidal excitation signal?). Please note that if you repeat the calibration, the number may not seem to be 
changed, but if the date is updated, this is probably because exactly the same number is written. 
 
If  is checked, it is assumed that you are using a transducer when doing the level 
calibration. Note that if this check box is turned off, no warning will be given that you should redo the 
calibration. If you are going to do a measurement later without using the transducer, a new calibration must be 
performed. 

4.4.2.2 How to perform “Detailed Calibration”? 
The advantage of doing the detailed level calibration is that you can, without doing any new calibration, switch 
between doing an electrical measurement, measure with pre-amplifier and measure with transducer. 
 
If you are not already in the Input level calibration for channel 1dialog box, go there (Measurement-
>Hardware Calibration, click Settings… to the right of the Input calibration check box. Make sure that the 
list box named Type of calibration at the top of the calibration dialog box is set to Detailed Calibration.  
 

 
 
The group box Detailed calibration contains the settings for this calibration type.  
 

 
 
First determine what type of calibration you need. It is possible to calibrate the sound card and the transducer 
sensitivity. The pre-amplifier gain can also be specified. 
 
If you want to determine the amplification of the pre-amplifier, we suggest that you do this manually by plotting 
the frequency response of the measurement system with and without the pre-amplifier. Note that the sound card 
calibration and the pre-amplifier gain and status (checked/unchecked) must be correct in order to get a correct 
calibration of the transducer sensitivity. 

4.4.2.2.1 Sound card conversion calibration 
Start by calibrating the sound card, since the transducer calibration is dependent on the sound card sensitivity. 

Click the  button to the right of the Sound card conversion [dB] to display the settings.  
 

 
 
From this dialog box you can set the level and frequency for the calibration, and choose if you want to use an 
external signal generator or use the sound card output as signal generator. Using the sound card output should be 
fine as long as you use a voltage meter to measure the RMS voltage.  
If you wish to use an external signal generator, choose Use external signal generator in the list box. Type the 
signal generator/calibrator frequency and RMS voltage in the edit boxes. 



 
If you are to use the sound card output as signal generator choose Use sound card output as signal generator 
(full scale output) in the list box. Select the frequency, 1000 Hz should be fine for most purposes. Then the 

output signal must be measured with a voltage meter. If you click the  button, the output 
signal is played (End level test can be clicked to stop the playback of the calibration signal). After the 

 button is clicked, measure the level using the voltage meter. Type the measured level in the 

dialog box below the frequency setting and exit the dialog box by clicking . 
 
Make sure that you have connected the calibration signal to the correct input channel (channel 1 is left). 
 

Now click the  button to perform the calibration. After the calibration is performed, the number to the 

left and the date to the right of the  button will be updated with the new settings. Now you can do a 
measurement to test if the calibration is correct. You can use sinusoid as excitation signal (see How to use a 
sinusoidal excitation signal?). Please note that if you repeat the calibration, the number may not seem to be 
changed, but if the date is updated, this is probably because exactly the same number is written. 

4.4.2.2.2 Transducer sensitivity calibration 
Before you start calibrating your transducer you must make sure the sound card sensitivity and amplification 
gain and status (checked/unchecked) is correct. Therefore we recommend that you calibrate the sound card 
sensitivity (see above) before calibrating the transducer sensitivity. 
 

 
 
Start the calibration preparation by checking , and select in the list box the unit of the 
transducer you are using (for a microphone it would be Pres [Pa]). 
 

 
 

Click on the  button shown above to the right of the Transducer sensitivity to display the settings.  
 

 
 
From this dialog box you can set the level and frequency for the calibration, and choose if you want to use an 
external signal generator or use the sound card output as signal generator. Using the sound card output should be 
fine as long as you have a device for measuring the level. 
If you are to connect a signal generator or a calibrator to your input chain, choose Use external signal generator 
in the list box. Type the signal generator/calibrator frequency and level in the dialog box. 
 
If you are to use the sound card output as signal generator choose Use sound card output as signal generator 
(full scale output) in the list box. Select the frequency, 1000 Hz should be fine for most purposes. Then the 
output signal must be measured in the transducer unit (e.g. SPL) using an external device. Use a SPL meter if 



you are calibrating a microphone using a loudspeaker. If you click the  button, the output 
signal is played (End level test can be clicked to stop the playback of the calibration signal). After the 

 button is clicked, measure the level using the voltage meter. Type the measured level in the 

dialog box below the frequency setting and exit the dialog box by clicking . 
 
Make sure that you have connected the calibration signal to the correct input channel (channel 1 is left). 
 

Now click the  button to perform the calibration. After the calibration is performed, the number to the 

left and the date to the right of the  button will be updated with the new settings.  Now you can do a 
measurement to test if the calibration is correct. You can use sinusoid as excitation signal (see How to use a 
sinusoidal excitation signal?). Please note that if you repeat the calibration, the number may not seem to be 
changed, but if the date is updated, this is probably because exactly the same number is written. 

4.5 How to calibrate the output of the measurement system? 

4.5.1 How to perform relative calibration of mixer output levels? 
The purpose of calibrating the output is to be able to obtain the true transfer function gain independent on the 
level of the WinMLS mixer output (relative calibration of mixer). The calibration can be done in different ways 
dependent on the features of the sound card (e.g if the sound card supports the WinMLS mixer or not) and the 
type of measurement you intend to perform. For some sound cards, e.g. VXPocket, a measurement setup file will 
be available with nominal calibration settings. 
 
The procedure for calibrating the output mixer is equal to the procedure for calibrating the input mixer, so please 
follow the procedure How to perform relative calibration of mixer input levels?. 

4.5.2 How to perform calibration of absolute output level? 
To calibrate the output of the measurement system is very similar to calibrating the input. If you choose to use 
the sound card input to measure the levels during the output calibration, it is required that the input is calibrated 
first. Therefore we strongly recommend that you do the input calibration before doing the output calibration.  
 
Make sure that the input and output volume is not so high that it gives clipping of the input signal or so low that 
the calibration gets unreliable.  
 
Note that if you are using the VXPocket or VX222, there is a special gain setting in the sound card mixer under 
Advanced Input that can be used to switch the input from Line to Microphone (see the Tested Sound Cards 
file). 
 
First determine if you are going to do total calibration or detailed calibration. 

4.5.2.1 How to perform “Total Calibration”? 
The purpose of this type of calibration is to calibrate the whole output chain in one operation. We recommend 
that you instead use the Detailed Calibration (see below) if you are using WinMLS both for electrical 
measurements and measurements where you are using a transducer (e.g. a loudspeaker), or if you are using an 
amplifier with changeable gain.  
 
If you are not already in the Input level calibration for channel 1dialog box, go there (Measurement-
>Hardware Calibration, click Settings… to the right of the Input calibration check box.  
 
First make sure that the list box named Type of calibration at the top of the calibration dialog box is set to Total 
Calibration.  
 

 
 
Right below, make sure that you have checked  if you are using a transducer. Select 
in the list box the unit of the transducer you are using (for a microphone this would be Pres [Pa]). 
 



The settings for the total calibration are shown below:  
 

 
 

Click the  button to view the Total Cal. Settings dialog box.  
 

 
 
Type the desired signal frequency and level in the dialog box. 1000 Hz should be fine for most purposes. From 
here you can also set the level, and choose if you want to use an external meter or use the sound card input to 
measure the output level. Using the sound card input for measuring the output level is fine if you have calibrated 
the input.  
 
If you are to use an external meter to measure the output level, choose Use external meter to measure level in 
the list box. Then measure the output level on channel 1 (left) using the external device after clicking the 

 button. Type the measured level in the dialog box below the frequency setting (you are also 
asked to enter the level during the actual calibration, the level you have typed now will show as default). 
 
If are to use the sound card input to measure the level, select Use soundcard input to measure level. The sound 
card input will now measure and determine the level automatically, no number to be typed, but you must be sure 
that the sound card input is calibrated properly and that it is connected to input channel 1 (left). 
 
 

Now click the  button to perform the calibration. After the calibration is performed, the number to the 
left and the date to the right of the Calibrate button will be updated with the new settings. Now you can do a 
measurement to test if the calibration is correct. You can use sinusoid as excitation signal (see How to use a 
sinusoidal excitation signal?). Please note that if you repeat the calibration, the number may not seem to be 
changed, but if the date is updated, this is probably because exactly the same number is written. 
 
If  is checked, it is assumed that you are using a transducer when doing the level 
calibration. Note that if this check box is turned off, no warning will be given that you should redo the 
calibration. If you are going to do a measurement later without using the transducer, a new calibration must be 
performed. 
 

4.5.2.2 How to perform “Detailed Calibration”? 
The advantage of doing the detailed level calibration is that you can, without doing a new calibration, switch 
between doing an electrical measurement, measure with amplifier and measure with transducer. 
 
If you are not already in the Input level calibration for channel 1dialog box, go there (Measurement-
>Hardware Calibration, click Settings… to the right of the Input calibration check box. Make sure that the 
list box named Type of calibration at the top of the calibration dialog box is set to Detailed Calibration.  
 



 
 
The group box Detailed calibration contains the settings for this calibration type.  
 

 
 
First determine what type of calibration you need. It is possible to calibrate the sound card and the transducer 
sensitivity. The pre-amplifier gain can also be specified. 
 
If you want to determine the gain of the amplifier, we suggest that you do this manually by plotting the 
frequency response of the measurement system with and without the amplifier. Note that the sound card 
calibration and the amplifier level and status (checked/unchecked) must be correct in order to get a correct 
calibration of the transducer sensitivity. 
 

4.5.2.2.1 Sound card sensitivity calibration 
Start by calibrating the sound card, since the transducer calibration is dependent on the sound card sensitivity. 
Start by calibrating the sound card, since the transducer calibration is dependent on the sound card sensitivity. 

Click the  button to the right of the Sound card conversion [dB] to display the settings.  
 

 
 
From this dialog box you can set the frequency and level for the calibration, and choose if you want to use an 
external meter or use the sound card input to measure the output level. Type the desired signal frequency and 
level in the dialog box. 1000 Hz should be fine for most purposes. Using the sound card input for measuring the 
output level is fine if you have calibrated the input. 
 
If you are to use a voltage meter to measure the output level, choose Use external meter to measure level in the 
list box. Then measure the output level on channel 1 (left) using the voltage meter after clicking the 

 button. Type the measured level in the dialog box below the frequency setting (you are also 
asked to enter the level during the actual calibration, the level you have typed now will show as default). 
 
If are to use the sound card input to measure the level, select Use soundcard input to measure level. The sound 
card input will now measure and determine the level automatically, no number to be typed, but you must be sure 
that the sound card input is calibrated properly and that it is connected to input channel 1 (left). Exit the dialog 

box by clicking . 
 
Make sure that you have connected the calibration signal to the correct input channel (channel 1 is left). 
 



Now click the  button to perform the calibration. After the calibration is performed, the number to the 

left and the date to the right of the  button will be updated with the new settings. Now you can do a 
measurement to test if the calibration is correct. You can use sinusoid as excitation signal (see How to use a 
sinusoidal excitation signal?). Please note that if you repeat the calibration, the number may not seem to be 
changed, but if the date is updated, this is probably because exactly the same number is written. 

4.5.2.2.2 Transducer sensitivity calibration 
Before you start calibrating your computer you must make sure the sound card output sensitivity and amplifier 
gain and status (checked/unchecked) is correct. Therefore we recommend that you calibrate the sound card 
sensitivity (see above) before calibrating the transducer sensitivity. 
 

 
 
Start the calibration preparation by checking , and select in the list box the unit of the 
transducer you are using (for a loudspeaker it would be Pres [Pa]). 
 

 
 

Click on the  button to the right of the Transducer sensitivity to display the settings.  
 

 
 
From this dialog box you can set the level and frequency for the calibration, and choose if you want to use an 
external signal generator or use the sound card output as signal generator. Using the sound card input for 
measuring the output level is fine if you have calibrated the input. 
 
If you are to use an external meter to measure the output level, choose Use external meter to measure level in 
the list box. Then measure the output level on channel 1 (left) in the transducer unit (e.g. SPL) using the external 
device. Use a SPL meter if you are calibrating a loudspeaker. Measure the level after clicking the 

 button. Type the measured level in the dialog box below the frequency setting (you are also 
asked to enter the level during the actual calibration, the level you have typed now will show as default). 
 
If are to use the sound card input to measure the level, select Use soundcard input to measure level. The sound 
card input will now measure and determine the level automatically, no number to be typed, but you must be sure 
that the sound card input is calibrated properly (considering if you are using amplifier and transducer on the 
input) and that it is connected to input channel 1 (left). 
 

Now click the  button to perform the calibration. After the calibration is performed, the number to the 

left and the date to the right of the  button will be updated with the new settings. Now you can do a 
measurement to test if the calibration is correct. You can use sinusoid as excitation signal (see How to use a 
sinusoidal excitation signal?). 



4.6 How to measure the initial time delay (the distance between the loudspeaker and the 
microphone)? 

Sound cards do not usually have synchronized inputs and outputs, this means that something has to be done to 
find the correct initial time delay. An exception is the Card Deluxe, Siena and Vxpocket/VX222 sound cards, 
read more about how to do it for those cards in the document “Tested sound cards”.  
To measure the correct initial time delay, WinMLS has the possibility of using a synchronization signal. This 
option can be turned on in Measurement->Sound Card Settings as shown below. 
 

 
 
Read more about this in the User’s Guide. Note that this procedure will not correct for the delay of the sound 
card (~40 samples). To do this, you must perform a measurement system correction as described below. 

4.6.1 Why is the synchronization signal not strong enough? 
The first thing would be to try to increase the mixer synchronization input and output level. The settings in the 
suggestions below are found in Measurement->Sound Card Settings. 
 
1. Check that the cables are connected properly. 
2. Check that you have chosen the right audio devices 

 

 
 

3. Check that you have chosen the right sync line 
 

 
 

4. If nothing above helps, try to turn on the check-box: 
 

 
 
This will not work on older PC’s with bad performance. 

4.7 How to correct for the influence of the measurement system? 
In some cases it is important to be able to correct for the influence of the measurement system, e.g. when the 
exact phase is desired. How to correct for the influence of the sound card will now be described, if you want to 
include more e.g. an amplifier in the correction, the procedure is similar. If you use the sound card VXpocket (or 
VX222) calibration files have already been made, and you may use the existing files instead of measuring your 
own. Then you can go directly to the last part of step 2 below. 

4.7.1 Step 1 
Perform a measurement of the measurement system only, e.g. a loop-back measurement of the sound card. 

Use sequence order 14 and 32 averages or more. Make sure the  button on the Measurement Settings 
Toolbar is turned off.  
If you do not know the sound card delay, make sure Measure with synchronization signal is turned off in 
Measurement->Sound Card Settings. 



4.7.2 Step 2 
Save the measurement.  
 
It may be done manually from File->Save Active Measurement As... and using the folder Measurement 
System Correction which is a sub-folder of the folder where WinMLS was installed. Select the extension 
.wmb and the name: 
<Name><Multi-channel measurement tag><Channel #>_Fs<Sampling Frequency as integer>. 
 
For example a 1-channel measurement with sampling frequency 44100 Hz measured using the name of the 
sound card VXPocket will be VXPocket_ch1_Fs44100.wmb. 
 
The fastest way of doing this procedure is by doing it automatically using File->Save Active 
Measurement->As Measurement System Correction File…. Then the active measurement will be set as 
the correction file using the short name activemeas. 
 
When the file is saved according to this, the first part of the filename will be added in Measurement-
>Hardware Calibration under the list box in “Measurement system correction filename”. Select this 
name in the list box. 
 

 

4.7.3 Step 3 

Turn on the measurement system correction button  on the Measurement Settings Toolbar. 
 
If you have check-marked  in Measurement->Sound Card Settings, 

make sure the time delay  is set to the correct sound card delay (this can 
be found by plotting the impulse response of the sound card using samples as x-axis). 

4.8 How to do get logical filename suggestions of when performing several measurements? 
Before starting the measurement series, go to Measurement->Defaults for Saving... There select the folder you 
want the measurement to be saved as, and the name. You may also write comment and title. Type the number of 
measurements you are to perform in the autoname generator range.  
For example, if the range is 1-3 and the default filename is “Meas”. The suggested name for saving the first three 
measurements will be  
Meas_1.wmb, Meas_2.wmb, Meas_3.wmb 
Then when saving the forth measurement, the Defaults for Saving dialog box will automatically appear, and 
you may write a new default filename. 

4.9 How to get fine resolution on the WinMLS mixer slider? 
Some sound cards have mixers with very high resolution, e.g. VXpocket has a range of more than 80 dB 
and 0.25 dB per step, which gives many steps. The WinMLS mixer input and output level slider can be 
set using the mouse, but moving only one step may be difficult with the mouse. To move one step at a 
time, first click on the slider to set it active (a dotted border around the slider tells that it is active, see the 
figure to the right).  Then the up and down arrows on the keyboard will move the slider.  

4.10 How to use a sinusoidal excitation signal? 
Set Sinusoid as measurement mode in the Measurement Selection Toolbar as shown below. 
 

 
 
Since WinMLS was designed for MLS measurements, the length of the sinusoid is set by the Sequence 
Order and Averages on the Measurement Settings toolbar. The relative level and frequency of the 
sinusoid is set in Measurement->Sinusoid settings…, but the frequency is adjusted so an integer 
number of periods fit into the sequence length specified. Because of this, averaging can be used. If the 
sinusoidal signal is to be played back for a long period, use either several averages or use Measurement-
>Test Current Level(s). 



4.11 What format is recommended for saving measurement data? 
When installing WinMLS, the .wmb (WinMLS binary files) is the default format and it is recommended since 
it contains all information about the measurement.  
 
The other formats are mostly meant for exporting purposes. 
 
The .wav-format will also have stored the information, but it may cause problems because of the normalization 
option (can be set in Measurement->Defaults For Saving… or File->Convert Measurement(s)…). Note that 
.wav-normalization will change the scaling, and if normalization is not used when saving as .wav, the 
quantization noise is usually large.  

4.12 How to convert a measurement file, e.g. of extension .wmb to .wav? 
This is done from File->Convert Measurement(s). Several measurements can be converted by selecting the 
ones to be converted in the dialog. 
 

 
 

4.13 How to improve signal-to-noise ratio for low frequencies? 
It is possible to pre-filter the MLS sequence. This method can be used to boost frequencies that has poor signal-
to-noise ratio. See below how this can be done 

4.14 How to add pre-filtering (emphasis) to the excitation signal (MLS)? 
Both pre- and de-emphasis (Pre/Post-filtering) is available as buttons on the Measurement Settings Toolbar.  
 

 
 
Currently one type of filter is available (LowBoost200HzShelvingFirstOrder), it will boost the frequencies 
below 200 Hz with 20 dB using a first order filter. This is useful for measuring in environments where the low 
frequency background noise is greater than the high frequency background noise, which is the case for most 
rooms. 
 
The gain of the emphasis can be set under Measurement->Advanced Settings.... 
 



 
 

4.14.1 How to generate your own filter? 
Custom filter can be made using Matlab or by contacting us. The filter coefficient file format is the same as the 
Matlab mat-format, but change the extension name from .mat to .emp. To save filter coefficients in Matlab 
(assuming the a and b coefficients have been generated), the following algorithm can be used: 
save filtercoeffs.mat a b 
change the extension of the file from .mat to .emp. 
copy the file to the “Filters”-folder under the WinMLS-folder. 

4.15 How to access a measurement from memory? 

The measurements that are in memory are found on the Measurement Selection Toolbar. Clicking the  
button, all the measurements that are not plotted will be deleted. Note that even if no measurements are plotted, 
the reference and the active measurement in upper and lower plot will not be deleted. 

4.16 How to run WinMLS as batch or from Matlab? 
If you have a registered version of WinMLS you can see how to run WinMLS form batch by opening MS-DOS 
and go to the WinMLS folder. To display the help text type: 
winmls /h 
The function loadimp.m found in the WinMLS folder may be used to read .wmb or .wmt files into Matlab. 
 
WinMLS [/M MeasSetupfile] [/R] [/F FileName] 
/M: MeasSetupfile is the short name of a measurement setup to load.\n" 
/R: If RunAndExitAfterMeas is set then the measurement start immediately and exits afterwards 
/F: Filename is the name of a file to save 
/H: Show this help 
 
Example: WinMLS /M LSP_Setup /F LSP_Filename /R\n 
This example will load the settings in the measurement setup file LSP_Setup, perform a measurement and save 
the result as LSP_Filename before it exits.  
Note that in order to automatically save the measurement,  
has to be checked in Measurement->Measurement Tasks.... 

4.17 Can a given setup be automatically called using DOS switches? 
Yes, this is possible, see the chapter above. This feature can be used to load the same settings each time 
WinMLS is opened. If no measurement setup is specified, WinMLS will open with the settings it had when it 
was closed the last time it was used.  

4.18 What is the highest sampling rate available (important for e.g. scale modeling in room 
acoustics)? 

At the moment the highest sound card sampling rate is 96 kHz, which means that it is impossible to get results 
above 48 kHz. In a few months we have been promised that a high quality card capable of 192 kHz will be 
available, this will increase the frequency range up to a limit of 96 kHz. 

4.19 Can multi-channel measurements (>2 channels) be performed using WinMLS? 
WinMLS is capable of measuring up to 24 channels simultaneously. The number of channels is limited by the 
hardware. Please contact us if you are interested in a multi-channel (>2) measurement system. 

5 Room Acoustics 
Refer to the Room Acoustics User’s Guide for additional information. 

5.1 How to measure room acoustics? 
When using WinMLS for measuring room acoustics, it is recommended that a room acoustics setup is loaded for 
performing the measurements. These can be loaded and saved from the Setups Toolbar (can be turned on/off 



from the View menu), or from Measurement->Measurement Setup.... When the setup is loaded, you can click 
the GO button on the standard toolbar to start the measurement or File->Insert in Active Group... to insert a 
measurement. 
On the Room Acoustics menu, you can create your own settings for displaying the room acoustics parameters. 
These settings can be saved in the post-processing setup file. 

5.2 How are room acoustics parameters presented? 
Room acoustics parameters can be presented either in a grid or in a plot. If you want to display several 
parameters, use the grid. If you want to display one single parameter (e.g. reverberation time) you can use either 
the grid or the Room Ac. Parameters plot type (Can be set from the Plot Toolbar or Plot->Select Plot 
Type(s)/Measurement(s)....). See below on how to do this. If you plot the parameters using this plot-type, it is 
possible to plot several measurements for easy comparison. 

5.3 How can the Room Acoustics Parameters Grid be copied to a spreadsheet (e.g. Excel)? 
This can be done first by computing the parameters to a grid (see above). 
If you have problems, note that inserting in Excel from WinMLS acoustics parameter clipboard does not work if 
"," and not "." is selected as decimal divider. 
The reason is that Excel interprets what is in the cells dependent on the global Windows settings. If “.” Is the 
decimal divider, it works fine. It can be set from the windows Control Panel, select Regional and Language 
Options. Click the Customize… button. As Decimal Symbol, select “.”. 

5.4 Plotting: How to compute and plot room acoustics parameters such as reverberation 
time? 

The room acoustics parameters, e.g. reverberation time and clarity, are available in a plot type called Room Ac. 
Parameters. This plot type has like the other plot types a Settings dialog box (can e.g. be accessed by double-
clicking in the plot). From this dialog box, the type of parameter to be plotted is selected. Note that only a few 
settings are available in this dialog box, the rest of the settings are taken from Room Acoustic->Calculation 
Options… and Room Acoustics->Parameter Settings.... 

5.5 How to specify two measurements for computing room acoustics parameters? 
Two measurements are to be used to calculate parameters such as IACC and LF. When doing this, the primary 
measurement (omni-directional mic.) is the active measurement in the upper plot and the secondary 
measurement (figure-of-eight mic.) is set to be the active measurement in the lower plot. If only one plot is 
displayed and not two, the active measurement in the lower plot is found in the Measurement Selection 
Toolbar or in Plot->Select Plot Type(s)/Measurement(s)..... We recommend using this toolbar shown below to 
check that you have got the right impulse responses. 
 

 

5.5.1 Limitations when plotting parameters needing two measurements 
Only signal-to-noise ratio for primary impulse response is displayed in the plot in case two impulse responses are 
used in computing the parameter. In the grid, both signal-to-noise ratios are displayed. 
 
If you intend to plot room ac. parameters in the lower plot, the active measurement in the lower plot is used as 
primary measurement and if two measurements are needed to calculate the parameter, then this will give an error 
message. Instead, perform the plotting in the upper plot when parameters needing two impulse responses are to 
be plotted. 
 
If plotting is performed in the upper plot, there is still a problem if several curves are plotted and Plot->Refresh 
All is selected. Each curve will not remember what was used as secondary measurement when it was plotted, 
therefore the active measurement in the lower plot will be as secondary plot when refreshing all the curves.  

5.6 Numerical display: How to compute and display room acoustics parameters in a grid? 
First a measurement has to be active in the plot (upper plot if two plots are displayed). Do this by performing a 
measurement (Measurement->Start Measurement) or inserting a measurement (File->Insert in Active 
Group...). 
When a measurement is active in the plot, the name of it will be displayed in the WinMLS title and also in the 
Measurement Selection Toolbar. 



5.6.1 What about parameters that need two measurements (impulse responses) to be computed? 
Some parameters need two impulse responses to be computed. The number and type of microphones to be used 
is set from Room Acoustics->Calculation Options in the Microphone type(s) list box. If a type that uses two 
microphones is selected, it needs two measurements, a primary and a secondary. The primary measurement is 
taken from the upper plot and the secondary measurement is taken from the lower plot. These measurements are 
displayed in the Measurement Selection Toolbar, and can easily be changed from this toolbar as well. 

5.7 How to compute one parameter only, e.g. reverberation time? 
A single parameter can be plotted using the plot type Room Ac. Parameters, it can also be displayed in the grid 
as described below. 
In Room Acoustics->Parameter Settings... the type of parameters to be displayed can be selected. By using the 
check boxes, the user can determine which parameters to be computed. If only reverberation time is to be 
displayed, make sure that all check boxes, except reverberation time (T30) are turned off. 

5.8 How to export the computed parameters from the “Room acoustics parameters” grid? 
When Room Acoustics->Display Selected Parameters is selected, room acoustics parameters are displayed in 
a grid. To copy the parameters to clipboard, use the Copy to clipboard button below the grid. This will copy the 
marked numbers. If no numbers are marked, it will copy all parameters. Note that you can mark a column by 
clicking at the upper part of the column. 

5.9 How to change the bandwidth, e.g. obtain the reverberation time of the broadband 
measurement? 

The bandwidth is set from Room Acoustics->Calculation Options in the Bandwidth list box. 

5.10 How to display room acoustics parameters automatically after performing a 
measurement or inserting measurement file(s)? 

At the bottom part of Measurement->Measurement Tasks, there is a check box called Display selected room 
acoustics parameters check box. If this is on, room acoustics parameters will be displayed in a grid and/or 
written to text-file when a measurement is performed or when one or several measurement files are inserted 
using File->Insert in Active Group.... 

5.11 How to automatically compute room acoustics parameters from several measurements? 
At the bottom part of Measurement->Measurement Tasks, there is a check box called Display selected room 
acoustics parameters. If this is turned on, then room acoustics parameters are being computed and displayed to 
a grid when measurement files are inserted using File->Insert in Active Group.... (If Room Ac. Parameters is 
selected as plot type, the selected parameter will be displayed in the plot as well. Note that this will reduce the 
speed, since the computation will be performed twice.) File->Insert in Active Group... will insert all marked 
measurement. To mark several measurements, hold the <Ctrl> key while clicking on the measurements that are 
to be inserted. <Shift> can also be used to mark a group of measurements. 

5.12 How to average or doing other calculations on room acoustics parameters obtained from 
several measurements? 

This can be done from the Room Ac. Parameters plot type. On how to do this see the question "How to make 
calculations, such as average and difference on plotted curves?” 

5.13 Is there a way of automatically sending measurement channel two to the lower plot or 
insert measurements in both upper and lower plot in one operation. 

At the bottom part of Measurement->Measurement Tasks..., there is a check box that will do this called 
. If it is checked and a multi-channel measurement is 

performed, channel 1 will be plotted in the upper plot and channel 2 will be plotted in the lower plot. Make sure 
you are viewing two plots, if you only have one plot, channel two will not be displayed. 
If several measurements are inserted using File->Insert in Active Group…, the first measurement will be 
displayed in the upper plot, the second will be displayed in the lower plot, the third will be displayed in the upper 
plot, and the forth in the lower, and so on… This is useful when computing the room acoustics parameters that 
need two measurements. 
 
At the bottom part of Measurement->Measurement Tasks..., make sure  
is checked. If it is checked and a multi-channel measurement is performed, channel 1 will be plotted in the upper 
plot and channel 2 will be plotted in the lower plot. Make sure you are viewing two plots, if you only have one 
plot, channel two will not be displayed. 



If several measurements are inserted using File->Insert in Active Group…, the first measurement will be 
displayed in the upper plot, the second will be displayed in the lower plot, the third will be displayed in the upper 
plot, and the forth in the lower, and so on… This is useful for computing room acoustics parameters that need 
two measurements. Note that you may select measurements in any order by clicking on the measurement files in 
the File->Insert in Active Group… dialog. 
 

6 Various Applications 

6.1 How to measure loudspeaker frequency response? 
To measure the frequency response of a loudspeaker, no level calibration has to be performed. Load the setup 
named LoudspeakerMeas from the Setups Toolbar (usually situated at the lower right corner, can be found 
from View->Setups Toolbar). Perform a measurement (Measurement->Start Measurement) with a 
microphone connected to the input (left channel) and the loudspeaker connected to the output (left channel). 

6.2 How to use WinMLS as a level meter for measuring SPL values in octave, 1/3 octave, 
dBA? 

Tests comparing WinMLS with a sound level meter showed good agreement, but for measuring dBA the input 
measurement chain must be calibrated. The easiest way of doing this calibration is if you have a microphone and 
a calibrator. For how to do this, see How to perform “Total Calibration”?  
If you have a microphone with a known sensitivity, you may also use this and calibrate the rest of the input 
chain. For how to do this, see Sound card conversion calibration. 
 
To perform the measurement, first load the setup QuasiRealTimeAnalyzer (can be done e.g. from the Setups 
Toolbar). As default, the plot 1/3-octave Power Spectrum is selected.  

6.2.1 How to display in octaves? 
1-octave Power Spectrum can be set by first clicking in the plot, then type F5 to open the plot type settings. Then 
click the Settings... button shown below. 
 

 
 
In the Smoothing/Integration Settings dialog box, select 1-octave Integrated as shown below 
 

 
 

6.2.2 How to display in dBA? 
To display the dBA level, the plot type has to be changed from Frequency Response/Spectrum to Levels. This 
can be done from the Plots Toolbar normally situated at the bottom. 
 

 
 

6.2.3 How to display several measurements (e.g. for comparison and for saving the data)? 
This is done the same way as with other types of measurements, if Plot->Hold Plotted Curves is checked (same 
as the  button), a new measurement will be added. This is very nice for comparison, especially when plotting 
dBA values. The plotted data can be saved as text-file using File->Save Data in Active Plot As.... 

6.3 How to measure speech transmission indexes STI or RASTI? 
STI or RASTI can be measured using WinMLS. The software has previously been tested against MLSSA’s 
RASTI calculation and recently against the B&K Speech Transmission Meter. The agreement was good. 
Currently the sound card must be able to preform a MLS measurement. Please check this by going through the 
procedure described in the chapter Loop-back measurement of the sound card in the WinMLS2000 Users Guide. 



It is also recommended that you read and use the Speech transmission indices chapter in the Room Acoustics 
User’s Guide and use that as a reference when reading this. Below the steps for setting up and measuring STI 
and RASTI is given. 
 

1. Load measurement settings for room acoustics measurement 

Select the measurement setup named Room Acoustics  from the Setups 
Toolbar (initially situated at the bottom right). It will load the initial settings that we will slightly 
modify. 
If you are measuring in a reverberant room, having a reverberation time larger than one second, in the 
Measurement Settings Toolbar (View->Measurement Settings Toolbar), set the sequence order to 17 
as shown to the right in the figure below 
 

 
 

2. Select RASTI or STI as plot type. 
In Plot Toolbar (initially situated at the bottom), select plot type Room Ac. Parameters 

. Click in the plot to make it active and click F5 to access the plot-
type settings. Then select RASTI or STI as shown below 

 
 

3. Determine if noise compensation is to be used. 
Find out if your STI/RASTI measurement has to take the background noise into account. It should be 
done if the speech-to-noise ratio is less than 15 dB in the octave bands of interest. If no, in Room 

Acoustics->Parameter Settings... select the compensation option.  and 
skip the next point. If yes, read the next point. 
 

4. Find background noise level for noise compensation. 
There are two options for compensating for the background noise as explained below.  
 
The options Compensation (noise fixed) assumes that the background noise is measured. One advantage 
is that this method can be used in cases where the background noise is very high (averaging can be used 
to increase the signal-to-noise ratio). Another advantage is that it is not needed to calibrate the WinMLS 
input chain. The background noise level can be measured using an octave band level meter. The octave 
band values can be typed in by first going to the lower left part of the Room Acoustics->Parameter 

Settings.... The  button opens up a new dialog box where the necessary data can be entered. 
 
The option Compensation (noise updated automatically) computes the background noise from the 
measured impulse response with WinMLS. In order to do this, the input chain (including the 
microphone) must be calibrated. The easiest way of doing this is to use a microphone calibrator with 
known frequency and level. The calibration is also possible to do without a calibrator. See How to 
perform absolute calibration of input level? and perform one of the methods of calibration described 
there.  
Please note that this option should not be used on measurements performed using averaging since the 
averaging will reduce the effect of the background noise. Therefore, in the Measurement Settings 
Toolbar (View->Measurement Settings Toolbar), set the number of averages to 1 as shown to the 
right in the figure below 
 

 
 

On the same toolbar, make sure that the De-emphasis is turned off as shown: . This is 
because the de-emphasis will influence the calculation of the background noise. The Pre-emphasis can 
be left turned on, it will reduce the treble output and reduce the chance for distortion. Distortion gives 
spurious peaks in the MLS signal which will artificially increase the calculated background noise for 
higher frequencies. An example is shown in the figure below where the blue curve is the sampled 



background noise in octave band, the green curve is the computed background noise from an MLS 
measurement using pre-emphasis, the red curve is a MLS measurement with high level and the black 
curve is a MLS measurement with not so high level. From this we can see that using pre-emphasis gives 
the best estimation of the background noise. 
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Curve...\WinMLSmeasurements\STI_Pos1NearHighLevel.w mb
Curve...\WinMLSmeasurements\PosNear_BackgroundNoise.w mb
Curve...\WinMLSmeasurements\STI_Pos1Near_NotSoHighLevel.w mb
Curve...\WinMLSmeasurements\STI_Pos1Near_HighLevelPreEmphasis.w mb

 

When finished, save the measurement settings using the  button in the Setups toolbar (View-
>Setups Toolbar). 
 

5. Perform the measurement 
Connect the loudspeaker to the sound card output (left channel) and the microphone to the sound card 
input (left channel). Place the loudspeaker in the position of the “speaker” and the microphone in the 
position of the “listener”.  
Select Measurement->Test Current Levels and set the output level properly. If you are unsure, try 
measuring with different levels and see what gives the best result.  

Click the  button (or Measurement->Start Measurement) to perform the measurement. 
If you want measurements to be automatically repeated, in Measurement->Measurement Tasks... 
make sure  is checked.  
 

6. Displaying the results 
The results will be plotted as bars as shown in the figure below. In this figure the values for several 
measurements are plotted and the legend moved from its default position in the right corner.  
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Curve...\Studios\HTS4x2.w mb
Curve...\Studios\1032ASideRight.w mb
Curve...\Studios\1032ASideLeft.w mb
Curve...\Studios\1032ARight.w mb
Curve...\Studios\1032ARearRight.w mb
Curve...\Studios\1032ARearLeft.w mb
Curve...\Studios\1032ALeft.w mb
Curve...\Studios\1032ACentre.w mb

 
 These results can also be saved to a text-file from File->Save Data in Active Plot As.... The data is 
organized in two columns, the first contains the measurement names, the second the RASTI or STI 
values. 
If you only want to show only one RASTI/STI value in the plot, make sure Plot->Hold Plotted Curves 

 is not checked when plotting a new curve. 



6.4 How to measure loudspeaker impedance? 
Impedance is, according to Ohms law, defined as voltage divided by current. The current is found by measuring 
the voltage over a resistor R with known resistance. Use a resistor that can handle a power signal, a power 
resistor of 8 Ohm can be suited. 
Place the resistor in series with the loudspeaker and measure the voltage over the loudspeaker VLSP and the 
voltage over the resistor VR. The input impedance is give by: 
 
ZLSP= VLSP / I = R * (VLSP / VR) 
 
 
Load a setup for doing a MLS measurement, e.g. the setup named LoudspeakerSetup (can be done from the 
Setups Toolbar). Now we have performed the two measurements we want to do the division. How to do this is 
described in How to find the level difference of two measurements as function of frequency? 
 
To obtain the correct impedance scaling, in the Plot->Plot Type Settings->Frequency Response/Spectrum 
dialog box, in the group box Shift/Normalization of magnitude, make sure Shift Magnitude is selected in the 
list box as shown below.  

 
 
Below the list box there is a Shift [dB]: edit box. Here type the resistance of the resistor. Note that you have to 
convert it to decibels, that is 20*log10(resistor value). A resistor value of 8 Ohms gives a dB value of 18.06 as 
shown in the figure above. 
Impedance is a linear value. Therefore, in the same dialog box, set the y-axis scaling to linear as shown below. 
 

 

6.5 How to find the level difference of two measurements as function of frequency? 
Perform or insert the two measurements you want to see the difference between. Select Frequency Response - 
Spectrum as plot type and one of the measurements as active measurement. This can be done in the 
Measurement Selection Toolbar or in Plot->Select Plot Type(s) and Active Meas. 
 
The other measurement must then be set as reference measurement. This is most easily done from the 

Measurement Selection Toolbar also. First make sure the  button is checked, It makes the rightmost list 

box display the reference measurement if this is taken from memory. (If  is checked, the list box will not 
display the reference measurement but the measurement in the lower plot). Select the desired reference 
measurement from this list box. In the figure below, the measurement Left is the reference measurement and 
Right is the active measurement. 
 

 
 
If the list box is disabled, please do as described below. 

Finally perform the division from the Frequency Plots toolbar by clicking the  button. 
 
Setting the reference can also be done from the lower part of Plot->General Frequency Domain Settings... 
dialog box. The “reference measurement” part of the dialog box is shown below. 
 



 
 
Make sure  is checked. The in the list box below, 
select the desired “divisor” measurement (Right is selected in the example above). If you want to window the 

measurements, click . It should be checked that the window 

settings are equal for the two measurements. When the dialog box is exited with  you should now 
see the level difference between the measurements as function of frequency. 

6.6 How to find the level difference between stereo speakers? 
Do as the chapter above using a measurement of left speaker as the active measurement and a measurement of 
the right speaker as the reference measurement. 
 

6.7 Violin Acoustics 

6.7.1 Is it possible to process the impulse excitation using the constant Q transform (CAS Journal, Nov.93, 
p.1-4)?  

The constant Q-transform is similar to octave band smoothing of the frequency response. Please see the chapter 
"Smoothing or Integration" in "Menus and Dialog boxes.pdf" on how to use this.  
The other issues described in the CAS Journal article referred to above is only valid for periodic signals, and not 
for an impulse response. Ideally the Q-transform is performed using time-windows of increasing size for low 
frequencies. This feature is not directly supported in WinMLS, but tests using time-windows of different sizes 
did not show significant improvement using this method. 
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