
1 File ........................................................................................................................................... 6 
1.1 New Group ................................................................................................................ 6 
1.2 Insert in Active Group... ............................................................................................ 6 
1.3 Open Group... ............................................................................................................ 6 

1.3.1 Browser: Open......................................................................................................... 7 
1.4 Close ................................................................................................................................ 8 
1.5 Save Active Measurement As... ................................................................................ 8 

1.5.1 Browser for saving 1-channel measurement ........................................................... 8 
1.5.2 Browser for saving 2-channel Measurement ........................................................... 9 

1.6 Save Active Measurement ............................................................................................... 9 
1.6.1 As Measurement System Correction File ................................................................ 9 
1.6.2 With Filename <_ActiveMeas_>........................................................................... 10 

1.7 Save Data in Active Plot As... ....................................................................................... 10 
1.8 Save Active Plot As... .................................................................................................... 10 
1.9 Print Active Plot ...................................................................................................... 11 
1.10 Print Preview Active Plot... ..................................................................................... 11 
1.11 Convert Measurement(s)... ............................................................................................ 12 
1.12 Exit................................................................................................................................. 12 

2 Edit......................................................................................................................................... 12 
2.1 Copy to clipboard .................................................................................................... 12 

3 View....................................................................................................................................... 13 
3.1 Volume and Input Level(s) Dialog................................................................................ 13 
3.2 Measurement Selection Toolbar .................................................................................... 14 

3.2.1  Measurement mode............................................................................... 14 
3.2.1.1 MLS ................................................................................................................... 15 
3.2.1.2 MLS (scope) ...................................................................................................... 15 
3.2.1.3 No excitation (scope)......................................................................................... 15 
3.2.1.4 Trigged, no excitation (scope) ........................................................................... 15 
3.2.1.5 Sinusoid (scope) ................................................................................................ 15 
3.2.1.6 Excitation from text file..................................................................................... 15 

3.2.2  Delete unplotted measurements from memory............................................... 15 

3.2.3  Active measurement in upper plot .................................. 15 
3.2.4  Update both plots with the same measurement .............................................. 15 
3.2.5  Measurement in lower plot or reference measurement ... 16 
3.2.6  Select “lower plot measurement” or “reference measurement” in combo 
box 16 

3.3 Measurement Settings Toolbar ...................................................................................... 16 
3.3.1  Number of Channels to Measure ............................................................. 16 
3.3.2  Sampling Frequency ............................................................................ 16 
3.3.3  Sequence Order.......................................................................................... 17 
3.3.4  Length of Measured Data ....................................................................... 17 



 1

3.3.5  Number of Averages ............................................................................... 17 
3.3.6  Total Meas. Time.................................................................................... 17 
3.3.7  Number of sequences to pre-send .............................................................. 18 
3.3.8  Sequence Type............................................................................................. 18 
3.3.9  Measurement System Correction .................................................................... 18 
3.3.10  Pre-emphasis ................................................................................................... 18 
3.3.11  De-emphasis .................................................................................................... 19 
3.3.12  Type of emphasis........................................................................ 19 

3.4 List of Curves Toolbar................................................................................................... 19 
3.4.1 Deleting curve(s) from the plot ............................................................................. 19 
3.4.2 Dragging curves to change the order ..................................................................... 19 

3.4.3  Change curve type .......................................................................................... 19 
3.4.4  Display the curve ............................................................................................. 20 
3.4.5  Change the curve color.................................................................................... 20 

3.5 Plot Toolbar ................................................................................................................... 20 
3.5.1  Setting the lower x-axis limit.................................................... 20 

3.5.2  Setting the upper x-axis limit.................................................... 20 

3.5.3  Setting the lower y-axis limit ........................................................ 21 
3.5.4  Setting the upper y-axis limit........................................................ 21 
3.5.5  Auto-scale the plot in all directions ................................................................ 21 
3.5.6  Display one or two plots in the window ......................................................... 21 
3.5.7  Selecting Plot Type in Active Plot .................................... 22 
3.5.8  Settings for the Active Plot............................................................................. 22 

3.6 Frequency Plots Toolbar................................................................................................ 22 
3.7 Time Window Toolbar .................................................................................................. 23 

3.7.1  Setting the lower window limit ................................................... 24 
3.7.2  Setting the upper window limit ................................................... 24 
3.7.3  Window length .......................................................................................... 24 
3.7.4  Window x-axis unit ......................................................................................... 24 
3.7.5  Time data window type ........................................................ 24 
3.7.6  Display time window in time data plot type................................................... 24 

3.8 Setups Toolbar ............................................................................................................... 24 
3.8.1  Select a new Measurement Setup .......................................... 25 
3.8.2  Save Measurement Setup................................................................................ 25 
3.8.3  Save Post-processing Setup when Measurement Setup is saved.................... 25 
3.8.4  Select a new Post-processing Setup........................................ 25 
3.8.5  Save Measurement Setup................................................................................ 25 



 2

3.9 Standard Toolbar ........................................................................................................... 25 
3.10 Status Bar....................................................................................................................... 27 

3.10.1 Status bar during a measurement........................................................................... 27 
4 Measurement ......................................................................................................................... 27 

4.1 Start Measurement ................................................................................................... 28 
4.2 Cancel Measurement ................................................................................................ 28 
4.3 Test Current Levels ....................................................................................................... 28 
4.4 Set Input Volume(s)....................................................................................................... 28 
4.5 Set Output Volume ........................................................................................................ 28 
4.6 Measurement Information… ......................................................................................... 28 
4.7 Delete Unplotted Measurements ............................................................................ 29 
4.8 Sound Card Settings ...................................................................................................... 29 

4.8.1 Mixer and Synchronization Settings...................................................................... 30 
4.8.1.1 Synchronization Mode – Measurement of initial time delay, or not. ................ 30 
4.8.1.2 Loop-back settings............................................................................................. 32 

4.8.2 Input Settings ......................................................................................................... 33 
4.8.3 Output Settings ...................................................................................................... 33 
4.8.4 Sound Card Specific Settings ................................................................................ 34 
4.8.5 Advanced settings.................................................................................................. 35 

4.9 Hardware Calibration… ................................................................................................ 35 
4.9.1 Absolute Input Level Calibration .......................................................................... 36 

4.9.1.1 General settings ................................................................................................. 37 
4.9.1.2 Total calibration................................................................................................. 37 
4.9.1.3 Detailed Calibration........................................................................................... 38 

4.9.2 Absolute output level calibration........................................................................... 39 
4.9.3 Relative calibration of mixer input........................................................................ 39 
4.9.4 Relative calibration of mixer output...................................................................... 40 
4.9.5 Measurement System Correction........................................................................... 40 

4.10 Measurement Settings Toolbar ...................................................................................... 40 
4.11 Sinusoid Settings… ....................................................................................................... 40 
4.12 Advanced Settings ......................................................................................................... 41 

4.12.1 Pre-D/A sound card output amplitude ................................................................... 41 
4.12.2 Emphasis offset...................................................................................................... 42 
4.12.3 Limits for automatic setting of volume ................................................................. 42 

4.13 Measurement Tasks… ................................................................................................... 42 
4.13.1 Tasks when performing a measurement ................................................................ 43 
4.13.2 Tasks when performing or inserting a new measurement from file ...................... 44 

4.14 Defaults for Saving... ..................................................................................................... 45 
4.14.1 Default file-parameters .......................................................................................... 46 
4.14.2 Title and comments ............................................................................................... 47 
4.14.3 Autoname generator .............................................................................................. 47 

4.15 Measurement Setup... .................................................................................................... 47 
4.15.1  Select setup ............................................. 48 
4.15.2 ................................................................... 48 

4.15.3  Save setup .......................................................................................... 48 



 3

4.15.4  Save setup as ...................................................................................... 48 

4.15.5  Delete setup........................................................................................ 49 

4.15.6  Load setup.......................................................................................... 49 

4.15.7  Close dialog ....................................................................................... 49 
5 Plot......................................................................................................................................... 49 

5.1 Add Curve(s) ........................................................................................................... 50 
5.2 Delete All Curves ..................................................................................................... 50 
5.3 Hold plotted curves ................................................................................................. 50 
5.4 Menu: Solo Active Measurement Curve ................................................................. 50 
5.5 Auto Refresh.................................................................................................................. 51 

5.5.1 Active Measurement.............................................................................................. 51 
5.5.2 All Measurements.................................................................................................. 51 
5.5.3 Off.......................................................................................................................... 51 

5.6 Refresh Active ............................................................................................................... 52 
5.7 Refresh All..................................................................................................................... 52 
5.8 Select Plot Type(s)/Measurement(s)... .......................................................................... 52 

5.8.1 Number of plots .............................................................................................. 52 
5.8.2 Plot Type in Primary (upper) Plot ......................................................................... 53 
5.8.3 Active measurement in Primary (upper) Plot ........................................................ 53 
5.8.4 Plot Type in Secondary (lower) Plot ..................................................................... 53 
5.8.5 Active measurement in Secondary (lower) Plot .................................................... 53 

5.9 Chart Settings for Active Plot... ............................................................................... 53 
5.9.1 Chart page.............................................................................................................. 54 
5.9.2 Series page ............................................................................................................. 54 
5.9.3 Data page ............................................................................................................... 55 
5.9.4 Export tab .............................................................................................................. 55 
5.9.5 Print tab.................................................................................................................. 56 

5.10 Plot Type Settings.......................................................................................................... 56 
5.10.1 Time Data… .......................................................................................................... 56 

5.10.1.1 X-axis settings ............................................................................................... 57 
5.10.1.2 Y-axis settings ............................................................................................... 57 
5.10.1.3 Y-axis scaling ................................................................................................ 57 

5.10.1.4 Velocity of sound .............................................................. 58 
5.10.1.5 Show time window for active measurement.................................................. 58 
5.10.1.6 Remove DC-component ( 0 Hz).................................................................... 59 
5.10.1.7 Processing Type............................................................................................. 59 
5.10.1.8 Filtering ......................................................................................................... 60 

5.10.2 Integrated Time Data (Step Response)... ............................................................... 62 
5.10.3 Energy-time Curve ................................................................................................ 62 

5.10.3.1 Frequency domain windowing ...................................................................... 63 
5.10.4 Schroeder Curve… ................................................................................................ 64 

5.10.4.1 Integration Options ........................................................................................ 64 
5.10.5 Frequency Response/Spectrum.............................................................................. 65 



 4

5.10.5.1 X-axis settings ............................................................................................... 65 
5.10.5.2 Y-axis settings ............................................................................................... 65 
5.10.5.3 General Frequency Domain Settings ............................................................. 65 
5.10.5.4 Type ............................................................................................................... 65 
5.10.5.5 Smoothing or Integration............................................................................... 66 
5.10.5.6 Guidelines ...................................................................................................... 69 
5.10.5.7 Compensation of Magnitude ......................................................................... 71 
5.10.5.8 Shift/Normalization ....................................................................................... 71 

5.10.6 Phase Frequency Response/Function... ................................................................. 72 
5.10.6.1 X-axis settings ............................................................................................... 73 
5.10.6.2 Y-axis settings ............................................................................................... 73 
5.10.6.3 General Frequency Domain Settings ............................................................. 73 
5.10.6.4 Phase type ...................................................................................................... 73 
5.10.6.5 Smoothing...................................................................................................... 74 
5.10.6.6 Remove delay in frequency range ................................................................. 74 
5.10.6.7 Subtract delay ................................................................................................ 74 

5.10.7 Group Delay .......................................................................................................... 74 
5.10.7.1 X-axis settings ............................................................................................... 75 
5.10.7.2 Y-axis settings ............................................................................................... 75 
5.10.7.3 General Frequency Domain Settings ............................................................. 75 
5.10.7.4 Type ............................................................................................................... 76 
5.10.7.5 Smoothing...................................................................................................... 76 

5.10.8 Waterfall ................................................................................................................ 76 
5.10.8.1 X-axis settings ............................................................................................... 77 
5.10.8.2 Y-axis settings ............................................................................................... 77 
5.10.8.3 Z-axis settings................................................................................................ 77 
5.10.8.4 Waterfall layout ............................................................................................. 78 
5.10.8.5 Energy-Time-Frequency (ETF) calculation settings ..................................... 80 
5.10.8.6 Mode.............................................................................................................. 81 
5.10.8.7 Cycles ............................................................................................................ 82 
5.10.8.8 FFT shift ........................................................................................................ 82 
5.10.8.9 Floor............................................................................................................... 82 
5.10.8.10 General Frequency Domain Settings ............................................................. 83 
5.10.8.11 Smoothing...................................................................................................... 83 
5.10.8.12 Microphone correction .................................................................................. 83 
5.10.8.13 Reference ....................................................................................................... 83 
5.10.8.14 Shift magnitude.............................................................................................. 83 

5.10.9 Room Ac. Parameters... ......................................................................................... 83 
5.10.9.1 Type ............................................................................................................... 84 
5.10.9.2 Plotting dependency on SNR......................................................................... 84 
5.10.9.3 Calculation Options ....................................................................................... 85 
5.10.9.4 Parameter Settings ......................................................................................... 85 
5.10.9.5 Display Signal to Noise Ratio (SNR) ............................................................ 85 

5.10.10 Levels................................................................................................................. 85 
5.10.10.1 Type of level .................................................................................................. 86 
5.10.10.2 Time Data processing .................................................................................... 87 
5.10.10.3 1/3 octave frequency range............................................................................ 88 



 5

5.11 General Frequency Domain Settings... .......................................................................... 88 
5.11.1 Active measurement settings ................................................................................. 89 

5.11.1.1  Time window settings ................. 89 
5.11.1.2 ........................................... 91 

5.11.1.3 ...................................................................... 91 
5.11.2 Reference measurement......................................................................................... 91 

5.11.2.1  Perform division ....... 91 
5.11.2.2 Select reference measurement ....................................................................... 92 

5.11.2.3 ...................................................... 92 
5.11.3 Fourier transform size............................................................................................ 92 

5.11.3.1 ................................................................... 93 
5.11.3.2 ..................................................................... 93 
5.11.3.3 ................................................................... 93 
5.11.3.4 ................................................................................ 93 

5.11.4 Various................................................................................................................... 93 
5.12 Default Curve Styles...................................................................................................... 94 

5.12.1 Selecting curve color ............................................................................................. 95 
5.12.2 Selecting curve width and style ............................................................................. 96 
5.12.3 Display curve belonging to active measurement with different width .................. 96 
5.12.4 Wrap index ............................................................................................................ 97 

5.13 White background on copy/print ................................................................................... 97 
5.14 Advanced Plot Settings….............................................................................................. 97 

5.14.1 Add text to Plot...................................................................................................... 98 
5.14.1.1 Add to Title.................................................................................................... 99 
5.14.1.2 Add to Axis Titles.......................................................................................... 99 
5.14.1.3 Add to Footer............................................................................................... 100 

5.14.2 Various................................................................................................................. 100 
5.14.3 Curve Type and corresponding Chart-file ........................................................... 101 

5.14.3.1 Plot type ....................................................................................................... 101 
5.14.3.2 Curve type.................................................................................................... 101 
5.14.3.3 Chart-file...................................................................................................... 103 

5.15 Post-Processing Setup.................................................................................................. 103 
5.15.1  Select setup ........................................... 104 

5.15.2  Save setup ........................................................................................ 104 

5.15.3  Save setup as .................................................................................... 104 

5.15.4  Delete setup...................................................................................... 104 

5.15.5  Load setup........................................................................................ 104 

5.15.6  Close dialog ..................................................................................... 104 
6 Room Acoustics................................................................................................................... 104 
7 Window ............................................................................................................................... 104 
8 Help ..................................................................................................................................... 105 

8.1 Help Topics.................................................................................................................. 105 



 6

8.2 About WinMLS... ........................................................................................................ 105 
8.3 License Options... ........................................................................................................ 106 

 
 

1 File 
Several file operations are accessed via the File menu as shown below. 
 

 
 

 
 

 

1.1 New Group  
Creates a new window displaying one or two plots. It is named group, since the window may 
contain a group of measurements. 

1.2 Insert in Active Group...  
Inserts measurement file(s) to the active measurement group window. Text-file(s) containing data 
that is to be plotted may also be inserted. A browser is displayed where one or several files may 
be selected. File types to be displayed in the browser are: 
 

 
 
Information about the file formats is given below. 

1.3 Open Group...  
Opens a measurement, text or plot file in new measurement group window. 
 
Open Group... does the same as Insert in Active..., except: 
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1. Open Group… will open a new window using the settings in the current plot window 
while Insert in Active Group… will insert the data in the active plot. 

2. Plot chart file type (*.tee) may only be selected from Open Group..., because it is a new 
plot and can not be inserted to a current plot window. 

1.3.1 Browser: Open 
A browser is displayed. File types to be displayed in the browser are: 
 

 
 
The file types are described below 

1.3.1.1.1 Measurement Files (*.wmb, *.wmt, *.wav, *.tim) 
Lists the measurement file types described below. 

1.3.1.1.2 WinMLS Binary Files (*.wmb) 
The recommended file type, binary file including header. The header contains information about 
the sound card and other measurement settings. The header has been extended since WinMLS 
ver. 2, but the old file format may still be read. 

1.3.1.1.3 Measurement Text Files (*.wmt) 
File type in text format. It has a header containing some measurement settings. Note that the 
scaling may not be correct when using this format. 

1.3.1.1.4 Mono 16-bit WAV Files (*.wav) 
Wave-file, the common binary format for PC audio. If the .wav-file was generated using 
WinMLS it contains the same header as the *.wmb-format is using. Note that the scaling will not 
be correct when the .wav-file is saved in WinMLS using the normalization option. Since the 
format is 16-bits, it is recommended that it is normalized when saving to obtain the best possible 
resolution. 

1.3.1.1.5 Measurement MLSSA files (*.tim) 
File type used by the software MLSSA. Note that the scaling may not be correct when using this 
format. 

1.3.1.1.6 Plot Chart Files (*.tee) 
File type containing the chart settings used in the plots. These are the settings found in Plot-
>Chart Settings for Active Plot, e.g. background gradient color, mouse zooming and axis 
settings. 
If such a file type is opened, it is done in a new window. 

1.3.1.1.7 TAB-separated Data (*.txt) 
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Not supported yet in the current version!!! Text-file containing data that is to be plotted. The 
data must be grouped in columns and separated using TAB. One column of data plots one curve 
using 0,1,2,3.... as x-axis. Several columns of data will use the first column as x-axis and plots the 
remaining as curves. All columns must be the same size. 

1.4 Close  
Closes the active window. If there are any unsaved measurements in the window, the user is 
asked to save or not. 

1.5 Save Active Measurement As...  
Saves the measurement that is active in the plot window in time domain (e.g. the result of a MLS 
measurement is an impulse response). The file formats are described in the Open Group... 
chapter above. 
 
If the active measurement is a performed 1-channel measurement or opened from file, the 1-
channel browser is displayed. If a 2-channel performed measurement is active, the 2-channel 
browser is displayed. If a > 2-channel performed measurement is active, the multi-channel 
browser is displayed. These three browsers are shown below. Note that it is possible to increase 
the size of the browsers by dragging in the lower left corner. 

1.5.1 Browser for saving 1-channel measurement 
 

 
 
The usage should be quite intuitive. The defaults are set by clicking the button 

. 



 9

1.5.2 Browser for saving 2-channel Measurement 
 

 
 
The usage should be quite intuitive. The defaults are set by clicking the button 

 which is the same as Measurement->Defaults for Saving…. 

1.6 Save Active Measurement 
Displays sub-menus for saving the active measurement shown below. 
 
 

 
 
Each item is explained below. 

1.6.1 As Measurement System Correction File 
Saves the active measurement as measurement system correction files and sets it as active in the 
measurement system correction part of Measurement->Hardware Calibration.... It is named 
activemeas. If the active measurement is a multi-channel measurement, each channel will be 
corrected. 
In order to turn on the measurement system correction feature, click the  button on the 
Measurement Settings Toolbar. 
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1.6.2 With Filename <_ActiveMeas_> 
Saves the using the filename '_ActiveMeas_'. The folder and extension is taken from 
Measurement->Defaults for Saving.... Note that if a measurement with the same name already 
exists, it will be overwritten. 
If the active measurement is multi-channel, channel 2 get the name '_ActiveMeas_2', channel 3 
gets '_ActiveMeas_3' and so on. 
This is the fastest way of saving a measurement and is well suited if another application, e.g. 
MLSSA, is used to export measurements while measuring with WinMLS. 

1.7 Save Data in Active Plot As... 
Saves the curves in the plot as columns in a .txt-file. 
All curves belonging to a measurement in the plot are saved as columns using tab as separator. A 
one-line header contains the title of the columns. The first column of the header is named ”x-
axis”, the next column(s) are given the name of the series title (maximum 30 characters). The 
character Tab is used as column separators in the header also. 
 
Note that if the x-axis is not the same for all series, then only the curve(s) that has the same x-axis 
values as the first plotted measurement is saved. This is the case e.g. if the sampling frequency is 
not the same, e.g. if a value is missing e.g. when plotting room acoustics parameters. 
 
Note also that an alternative method that gives access to advanced settings is found in Plot-
>Chart Settings for Active Plot..., click the Export tab, then click the Data tab. The dialog box 
will then show the settings below. 
 

 
 

1.8 Save Active Plot As... 
Saves the active plot in one of the formats shown below 
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A method giving access to more advanced settings is found in Plot->Chart Settings for Active 
Plot..., click the Export tab. The dialog box will then show the settings below. 
 

 
 
From the example in the figure above, we see that it is possible to set the quality and size when 
saving as .jpg-file. 

1.9 Print Active Plot  
Prints active plot in active window. 

1.10 Print Preview Active Plot...  
Print previews active plot in active window. 
As we see in the figure below, this dialog box can be used to determine printer, set orientation, 
margins and amount of details in the plot. 
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1.11 Convert Measurement(s)...  
Converts a measurement file of one of the supported formats to one of the other supported 
formats. 
 

 
 
The dialog box above shows an example on how to convert three files of the format .wmb to 
.wav. The .wav-files are put under in the Target path. 

1.12 Exit 
Closes all windows and quits WinMLS.  
 
Measurement and post-processing setups are saved to temporary files so the settings are the same 
the next time WinMLS is opened. 

2 Edit 
2.1 Copy to clipboard  
Copies the active plot to the clipboard so that it may easily be pasted to other software, such as 
Word. 
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3 View 
From this menu you can select which resources you wish to view on your screen. The ones which 
are viewed are check-marked as shown in the figure below.  
 

 
 
Note that the toolbars can be moved around and the positions are saved in the post-processing 
setup file. 

3.1 Volume and Input Level(s) Dialog 
Displays a dialog box for setting volume and input level(s). 
The content of the dialog box to be displayed depends on the settings. If the WinMLS mixer is 
used and if measuring in sync. loop-back mode, it will look like the figure below. 
 

 
 
If sync. loop-back mode is not used, the controls Sync.Out and Sync. Input are not needed and 
will not be displayed in the dialog box. The horizontal waitbar at the bottom of the dialog box 
informs the user about the measurement progress. 
 



 14

The sliders are used to set the volumes. If the mixer is not calibrated, Uncal. will be written 
above the volume which may be given a value in the range 0-65535. Changing the volume from 
e.g. 20000 to 20001 will usually not make any difference. How much it has to be changed to 
actually change the volume is sound card dependent.  
The calibration procedure will determine the volume in dB, and if calibration is turned on 
(Measurement->Hardware Calibration) the last part of the dialog box shown in the figure 
above will look as shown below. 
 

 
 
It is now possible to see how much the volume is changed in dB, and this information is used to 
determine the absolute gain of the systems to be measured. 
 
If the sound card does not support the WinMLS mixer, WinMLS is not able to set the volumes 
and the dialog shown below will be displayed. 
 

 
 

3.2 Measurement Selection Toolbar 
The Measurement Selection Toolbar is used for selecting measurement mode and 
measurements for post-processing. 
 

 

                          

3.2.1  Measurement mode 
The measurement modes are shown in the figure below. 
 

 



 15

 

3.2.1.1 MLS 
This is the default measurement mode and should be used for measurements of 
impulse/frequency response. The MLS-specific settings are found in the Measurement Settings 
Toolbar. 

3.2.1.2 MLS (scope) 
This mode is similar to the MLS mode, except that no post-processing (Hadamar transform) of 
the recorded signal is performed. This may be useful for detecting errors. 

3.2.1.3 No excitation (scope) 
In this mode, no signal is played. It is intended for analyzing a signal, such as finding the 
background noise level. The length of the recorded signal is also given hereby the sequence 
order in the Measurement Settings Toolbar. 

3.2.1.4 Trigged, no excitation (scope) 
This mode is intended for analyzing impulsive signals. It is similar to the No excitation (scope) 
mode except that the maximum of the signal is automatically detected and the signal shifted so 
the maximum is found after 150 samples. 

3.2.1.5 Sinusoid (scope) 
A sinusoid is used for excitation, otherwise the mode is similar to No excitation (scope). 
Measurement->Sinusoid Settings sets the frequency and level of the output signal. 

3.2.1.6 Excitation from text file 
In this mode, any excitation signal may be specified as a text file. The file must be put in the 
WinMLS folder and be named WinMLSExcitation.txt. An example file is found in the 
WinMLS folder. 

3.2.2  Delete unplotted measurements from memory  
Same as File->Delete unplotted measurements. 

3.2.3  Active measurement in upper plot 
From the combo box to the right of the  icon, the active measurement in the plot is selected (if 
two plots are displayed in the window, it selects the active measurement in the upper plot). All 
the performed and inserted measurements are available from the combo box list.  

3.2.4  Update both plots with the same 
measurement  

If the active window contains two plots and if  is toggled, the combo box to the left of the 
button will determine the active measurement for both plots. If it is not toggled, the combo box to 
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the right of the button will determine the active measurement in the lower plot, given that  is 
toggled (see two chapters below). 

3.2.5  Measurement in lower plot or 
reference measurement 

This combo box displays the active measurement in the lower plot if  is toggled. If  is 
toggled, it displays the reference measurement (the reference measurement is used for division). 

3.2.6  Select “lower plot measurement” or 
“reference measurement” in combo box 

As explained in the chapter above, the status of these two toggles, determines what the combo 
box to the left of the toggles will display, the active measurement in the lower plot or the 
reference measurement. 

3.3 Measurement Settings Toolbar 
As different from the other toolbars, none of the settings in this toolbar can be found in any 
dialog box. If you intend to use WinMLS for advanced MLS measurements, this toolbar should 
be useful. It is, however, hidden in the default setup since new users may find it confusing. 
 

 
 

3.3.1  Number of Channels to Measure 
From this combo box choose the number of channels you want to measure. If this is set to 1 ch., 
one impulse response is the result of a MLS measurement. If it is set to 2 ch., two impulse 
responses will be the result and so on. WinMLS is capable of measuring up to 24 separate 
channels. In the standard versions 1 or 2 channels are offered, if you need more please contact us. 

3.3.2  Sampling Frequency 
The sampling frequency determines how many samples per second the sound card transmits and 
receives. It determines the frequency range of your measurements. Theoretically the frequency 
range is half the sampling frequency (Nyquist criterion). You may get close to this limit if you 
correct for the influence of the measurement system.  
The supported sampling frequencies is sound card-dependent, most sound cards support 11025, 
22050 and 44100 Hz. The newer cards support 48000 Hz, and some new cards 96000 Hz. A 
sound card that supports 192000 Hz should soon be available.  
You may select the sampling frequency from the list of the most usual sampling frequencies, but 
you can also write the number directly in the window. If the sound card does not support the 
selected sampling rate, an error message will appear when trying to start a measurement. 
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3.3.3  Sequence Order 
Range: Typically 11-20 using PC with 16 MB RAM, or even higher order with more RAM. 
The important thing to know about the Sequence Order is that it determines the number of 
samples of the measured data. See Length of Measured Data, which is discussed below. 
 
The sequence order determines the number of samples in the maximum length sequence (MLS). 
The number of samples in the MLS is given as 2^ (Sequence Order) – 1. When the MLS 
measurement method was first introduced, the maximum length sequence was generated using 
shift registers. By connecting the shift registers in a special way it was found that a Maximum 
Length Sequence could be generated. This was the longest sequence that could be made before it 
repeated itself, and the length was given as 2^(# of shift registers) - 1. The Sequence Order is the 
same as the number of shift registers used to generate the sequence. It was found that this 
sequence had very useful properties for measurements.  

3.3.4  Length of Measured Data 
The Sequence Order and the Sampling Frequency gives the length of the measured data. 
Increasing the sequence order increases the length of the measured data, while increasing the 
sampling frequency decreases it. When measuring systems with long delays, such as a room, this 
number should be increased. If it is too low, the measured impulse response may have time 
aliasing. This is because the impulse response has not finished its decay.  

3.3.5  Number of Averages 
The number of averages determines how many times the MLS signal is repeated during the 
measurement. The desired number of coherent averages (pre-averages) can be typed in the edit 
window or chosen from the list. Up to 256 averages can be done if the sound card resolution is 24 
bits, and 65536 averages if it is 16 bits. 
The reason for averaging is that it will decrease uncorrelated noise and thus increase the quality 
of the measurements. For doubling of the number of averages, the signal-to-noise ratio is 
theoretically increased with 3 dB.  
The total measurement time increases when the number of averages increases. Note that if the 
system you are measuring is somewhat time-variant, a long measurement time can decrease the 
quality of the measurement. An example of a time-variant system is a concert hall where people 
are running around. Try to avoid measuring during such situations. In any case, for room 
acoustical measurements, a measurement time of more than 60 seconds is not recommended. 
Electrical or mechanical systems are usually very little time-invariant, so for those long 
measurement times seldom is a problem. 

3.3.6  Total Meas. Time 
The total measurement time is displayed here. It is approximately given as Length of Measured 
Data multiplied by the number of averages plus pre-sent sequences (explained below). If 
measuring in loop-back mode, add approximately two seconds. 



 18

3.3.7  Number of sequences to pre-send 
This parameter decides how many times the excitation signal is to be played before the input 
signal is recorded and the measurement actually takes place. 
When measuring using the MLS method, the excitation signal must be played at least once before 
recording the result. This is because the system to be measured has a transient immediately after 
the excitation that must be suppressed. After playing one sequence, this should have died out if 
the other parameters are correctly set. Therefore, the number of sequences to pre-send should be 
set to 1. 

3.3.8  Sequence Type 
Two different types of sequences for MLS measurements are available, A or B. This feature is 
meant for distortion/non-linearity checking. Non-linearity causes spurious peaks in the impulse 
response. The peaks are replications of the true impulse response. For measurements using a 
different sequence, these peaks are situated at different places in the impulse response. By 
visually inspecting two impulse responses measured with different sequences, the amount of non-
linearity may be determined. Distortion/non-linearity is usually caused by the transducers (either 
microphone or loudspeaker) and may in some cases be reduced by reducing the volume. 

3.3.9  Measurement System Correction 
Using this option will correct your measurements for the influence of the measurement system. 
But in order to do this, your measurement system first has to be measured. The procedure for this 
is described in the FAQ. Measurement System Correction is not recommended if you measure 
without using synchronization loop-back because a linear phase shift is added since the start of 
the impulse response may not be correctly determined. Also the magnitude frequency response 
may in some cases be incorrect because of this shift of the impulse response. 
 
If you measure using synchronization loop-back, you might experience a small tail at the very 
end of the impulse response. This is a result of the correction filtering procedure. If this tail is 
more than –50 dB below the maximum of the impulse response, it should be nothing to worry 
about for most applications. 
 
When the Measurement System Correction is turned on, the relative amplification will be 
measured, even if no level calibration has been performed. If the amplification of the system you 
are measuring has increased 5 dB after you performed the reference measurement, the peak of the 
impulse response will be at 5 dB. The linear amplification may be displayed by plotting for 
example the first part (it is given by the maximum) of the impulse response using linear axis. To 
plot the amplification in dB, do the same using logarithmic x-axis, or plot the magnitude 
frequency response. 

3.3.10  Pre-emphasis 
This option will pre-filter the excitation signal using the filter found in the Type of Emphasis 
combo box described below.  
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3.3.11  De-emphasis 
This option will post-filter the recorded signal using the inverted filter found in the Type of 
Emphasis combo box described below.  

3.3.12  Type of emphasis 
This combo box contains the filter(s) used for pre- and de-emphasis. The MLS signal is initially 
white, which means that it contains an equal amount of all frequencies. For most acoustics 
measurements it gives a better result to use a signal that gives more power to the lower 
frequencies. Selecting LowBoost200HzShelvingFirstOrder it will boost the frequencies below 
200 Hz with 20 dB using a first order filter. For more information read How to add pre-filtering 
(emphasis) to the excitation signal (MLS)? in the FAQ. 

3.4 List of Curves Toolbar 
This toolbar gives immediate access to the curves in the active plot. 
 

 
 
The operations described below can be done from this toolbar. Note that if two plots are 
displayed in the window, the operations will only affect the active plot. 

3.4.1 Deleting curve(s) from the plot 
A curve may be deleted by first marking it, then pushing the Delete key. In the figure above, the 
curve named CurveMeas. 2 is marked since it has a blue background. Note that if several curves 
are marked, they may all be deleted. 

3.4.2 Dragging curves to change the order  
If a curve in the toolbar is marked (CurveMeas. 2 in the example above), the curve may be 
dragged up or down using the mouse. Note that the curve at the end of the list is displayed as the 
top curve in the plot. In the figure above, CurveMeas. 3 will be displayed on top, while 
CurveMeas. 1 will be below all the other curves. 
Note that if several curves are marked, they may all be dragged. 

3.4.3  Change curve type 
Clicking on this icon, will display a dialog box where a new curve type may be selected. 
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3.4.4  Display the curve 
If  is checked, the curve will be displayed in the plot. If not it will not be displayed but is 
present in memory and may be displayed later. 

3.4.5  Change the curve color 
The color of a curve may be changed by clicking  (found to the left of Curve Meas. 1 in the 
figure of the toolbar above). A dialog box will be displayed from where a new color may be 
selected. 

3.5 Plot Toolbar 
This toolbar should be found very useful. It contains settings for zooming in x- and y-direction, 
selecting one or two plots, which plot type(s) to be displayed and finally a button for accessing 
the settings of the active plot type. In the figure below we see a plot with the toolbar on top. 
 

 
 
Note that if two plots are plotted in the current window, the settings for the active plot will be 
displayed in the toolbar. It is a good exercise to click in the other plot to set it active and see how 
the toolbar settings will change. 

3.5.1  Setting the lower x-axis limit 
The controls shown above are used to set the lower x-axis limit.  
If auto-scale lower x-limit  is toggled, the minimum x-value of any of the curves in the plot 
will be used as minimum value. The edit window  shows the current value, 10 Hz in this 
example. It is possible to type a new value, but remember to validate it by clicking Enter. 
The controls  are used for moving the limit in either left or right direction. 

3.5.2  Setting the upper x-axis limit 
The controls shown above are used to set the upper x-axis limit.  
If auto-scale upper x-limit  is toggled, the maximum x-value of any of the curves in the plot 
will be used as maximum value. The edit window  shows the current value, 24000 Hz in 
this example, which is the maximum in x-direction since  is toggled. It is possible to type a 
new value, but remember to validate it by clicking Enter. 
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The controls  are used for moving the limit in either left or right direction. 
 

3.5.3  Setting the lower y-axis limit 
The controls shown above are used to set the lower y-axis limit.  
If auto-scale lower y-limit  is toggled, the minimum y-value of any of the curves in the plot 
will be used as minimum value. The edit window  shows the current value. It is possible 
to type a new value, but remember to validate it by clicking Enter. 
The controls  are used for moving the limit either up or down. 

3.5.4  Setting the upper y-axis limit 
The controls shown above are used to set the upper y-axis limit.  
If auto-scale upper y-limit  is toggled, the maximum x-value of any of the curves in the plot 
will be used as maximum value. The edit window  shows the current value. It is possible 
to type a new value, but remember to validate it by clicking Enter. 
The controls  are used for moving the limit either up or down. 

3.5.5  Auto-scale the plot in all directions 
This is a very method of auto-scaling a plot. 
If  is toggled, the plot is auto-scaled in all x- and y-direction. As a result of this, all the four 
buttons , ,  and  will be toggled. So clicking  has the same effect as clicking all 
these four buttons. 

3.5.6  Display one or two plots in the window 
If  is not togged, one plot is displayed in the active window as shown in the left part of the 
figure below. If  is toggled, two plots are displayed in the active window as shown in the right 
part of the figure below.  
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3.5.7  Selecting Plot Type in Active Plot 
This combo box contains the plots shown in the figure below and lets the user select which plot 
type the active plot should contain. 
 

 
 

3.5.8  Settings for the Active Plot 
Clicking on this button will display a dialog box containing the settings for the active plot. An 
alternative method is to double click in the active plot. 

3.6 Frequency Plots Toolbar 
This toolbar gives quick access to settings useful for all the general frequency domain plot types 
(magnitude, phase, group delay and waterfall). 
 

 
 
Note that if two plots are displayed in a window, the toggles will affect only the active plot. An 
exception is the toggles involving the “global” Plot->General Frequency Domain Settings…. 
 
 

 Logarithmic x-axis. Same as  found in the plot type 
settings. In case WinMLS is displaying two plots, only the active plot will be refreshed 
when the button is clicked. 

 Smooth curve. Same as  found in the plot type settings. In case WinMLS is 
displaying two plots, only the active plot will be refreshed when the button is clicked. 
 

 Invert curve. Same as  in Plot->General Frequency Domain 
Settings… 

 Microphone compensation. Same as  found in settings for the Frequency 
Response/Spectrum plot type 

 Display guidelines on frequency response. Same as  found only in settings 
for Frequency Response/Spectrum plot type 
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 Perform division using reference measurement. Same as 
 in Plot->General Frequency Domain 

Settings… 
 Update reference measurement on new measurement. Same as  

in Plot->General Frequency Domain Settings… 
 Display time window settings for the reference measurement. Same as 

 in Reference measurement group in Plot-
>General Frequency Domain Settings… 

 Display time window settings for the active measurement. Same as 

 in Active measurement group in Plot->General 
Frequency Domain Settings… 

 File->General Frequency Domain Settings… 
 

 Waterfall slice scrolling downwards, used to set the active slice, for reading cursor values 
displayed at the Status Bar. The active slice gets a green color. This button is enabled only 
if the waterfall layout mode in the waterfall plot type settings is Separate lines waterfall as 
shown in the figure below. 

 
 

 Waterfall slice scrolling upwards, used to set the active slice, for reading cursor values 
displayed at the Status Bar. The active slice gets a green color. This button is enabled only 
if the waterfall layout mode in the waterfall plot type settings is Separate lines waterfall as 
shown in the figure above. 

3.7 Time Window Toolbar 
This toolbar will set the time window used for FFT-calculation for the frequency domain plot 
types. Below the toolbar is displayed together with the Time Data plot type. The time data 
window is displayed in yellow. 
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3.7.1  Setting the lower window limit 
The controls shown above are used to set the lower window limit.  
The button  will move the time window to the lowest possible value.  
The edit window  shows the current value in the unit displayed in  as will be explained 
below. It is possible to type a new value, but remember to validate it by clicking Enter. 
The controls  will move the window one sample in each direction and is thus to be used only 
if very small moves are required. 

3.7.2  Setting the upper window limit 
The controls shown above are used to set the upper window limit. They work similar to those 
described in the chapter above, so no further explanation should be needed. 

3.7.3  Window length 
This control shows the total window length in the unit displayed in  as will be explained 
below. 

3.7.4  Window x-axis unit 
This control displays the unit of the x-axis. In the figure above it is set to ms, which means that 
the unit is milliseconds. The unit is always the same as the x-axis unit for the Time Data plot 
type. 

3.7.5  Time data window type 
The possible window types are shown below. 
 

 
 
Note that when windowing transient signals such as impulse responses, a rectangular or half 
window should be used. A full window is usually used for stationary signals. 

3.7.6  Display time window in time data plot type 
If this is toggled, the selected time window will be displayed when plotting Time data. 

3.8 Setups Toolbar 
Using this toolbar is a convenient way of loading and saving the measurement and post-
processing setups. 
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The purpose of this dialog bar is to make it easier for the user who wants to work with setup files. 
All the WinMLS settings are saved in setup files. From this toolbar most things can be done, 
except deleting a setup file which can be done from Measurement->Save/Load Measurement 
Setup… or Plot->Save/Load Post-proc Setup…. 
 
The save diskette-icon would change appearance when the setup is changed, e.g. it is disabled 
when it is not changed. This is the way for the user to see if the settings have been changed, this I 
think will be useful!!! 
 

3.8.1  Select a new Measurement Setup 
From this combo box a new measurement setup may be loaded. In addition to the measurement 
settings, post-processing settings will also be loaded, since the measurement setup contains a link 
to the post-processing setup. This measurement setup combo box thus is able to load all WinMLS 
settings. 

3.8.2  Save Measurement Setup 
Click this button to save the measurement setup, the Save As dialog box will be displayed, this 
will be described under Measurement->Save/Load Measurement Setup…. 
 If any of the measurement settings are changed, the icon turns red . This way the user will be 
notified that the settings have been changed since the last setup was loaded. 

3.8.3  Save Post-processing Setup when 
Measurement Setup is saved 

If this is toggled, the post-processing setup will be saved when the measurement setup is saved. 
The toggle is the same as the  setting in Plot->Save/Load Post-
proc Setup…. 

3.8.4  Select a new Post-processing Setup 
From this combo box a new post-processing setup may be loaded. 

3.8.5  Save Measurement Setup 
Click this button to save the post-processing setup, the Save As dialog box will be displayed. 
This will be described under Measurement->Save/Load Measurement Setup…. 
 If any of the post-processing settings are changed, the icon turns red . This way the user will 
be notified that the settings have been changed since the last setup was loaded. 

3.9 Standard Toolbar 
The standard toolbar contains the most frequently used buttons. 
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 File->New… 
 File->Insert… 
 File->Open… 
 File->Save Active Measurement As… 
 File->Print 
 File->Print Preview… 
 Edit->Copy to Clipboard 
 Measurement->Start Measurement 
 Measurement->Cancel Measurement 
 Plot->Select Plot Type(s) and Active Meas… 
 Plot->Chart Settings for Active Plot... 
 Plot->Hold Plotted Curves 
 Plot->Solo Active Measurement Curve 
 Plot->Auto Refresh 

Determines if auto refresh is turned on or off. If it is turned on, it can be in two modes as 
seen from the Plot->Auto Refresh sub-menu. Either Active Measurement or All 
Measurements. 

 Plot->Refresh All 
 Plot->Delete All Curves 
 Plot->Add Curve(s) 
 Add legend to active plot. This and other legend settings are found in Plot->Chart Settings 

for Active Plot..., select the Legend tab. 
 Add gridlines to active plot. This and other gridlines settings are found in Plot->Chart 

Settings for Active Plot..., select the Axis tab, then select the Ticks tab, or the Minor tab 
for the minor gridlines. 

  Display title to active plot. This and other title settings are found in Plot->Chart Settings 
for Active Plot..., select the Titles tab. 

  Display footer  to active plot. This and other comment settings are found in Plot->Chart 
Settings for Active Plot..., select the Titles tab. Then select SubFoot as shown in the 
figure below. 
 

 
 

  Display axis title to active plot. This and other axis title settings are found in Plot->Chart 
Settings for Active Plot..., select the Title tab. 
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3.10 Status Bar 
The status bar is displayed at the bottom line of the software. The left part is used to display the 
help text when the mouse cursor is placed at a control. For example, if the mouse cursor is placed 
at the  button, the text  will be displayed. 
 

 
 
To the right of the help text, the cursor values (x,y) in the plot is displayed, as shown above. This 
is the position of the mouse pointer relative to the curve of the active measurement. Using this 
you can read out the values of the active measurement curve. Note that if you have plotted 
several measurements it is the cursor values of the active measurement that will be displayed. 
 
If a frequency domain plot type is displayed, the wavelength, half- and quarter-wavelength will 
be displayed to the right of the cursor values as shown in the figure below. 
 

 
 

3.10.1 Status bar during a measurement 
When performing a measurement, the current average and its input level(s) are displayed in the 
status bar. In the figure below the levels for average 8 for a 2 channel measurement is displayed. 
 

 
 

4 Measurement 
This menu contains the measurement settings 
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4.1 Start Measurement  
Starts a measurement using the current settings. 
A too high output volume may damage your equipment, so consider adjusting down the output 
volume before selecting this option. The levels cannot be adjusted during a MLS measurement 
since it will give a wrong result. 

4.2 Cancel Measurement  
Cancels a measurement if one is being performed.  

4.3 Test Current Levels 
Recording (and playback) is started so the user may see the current input (and output) level(s). 
This is useful for setting optimal levels before performing a measurement.  
Note that a too high output volume may damage your equipment, so consider turning down the 
output volume before selecting this option.  

4.4 Set Input Volume(s) 
Sets the input volume, starting from the lowest possible level and gradually increasing. The 
volume is adjusted so the input level is set in the range –1.5 dB to –5 dB. These limits may be set 
in Measurement->Advanced Settings…. 
 
The procedure works only if the WinMLS mixer is supported, and it works for 1- and 2-channel 
measurements. 
 
If the procedure is slow, adjusting the volume sliders manually will help increasing the speed. 

4.5 Set Output Volume 
Sets the output volume. This procedure is similar to setting the input volume as discussed above.  

4.6 Measurement Information… 
Displays information on the active measurement as shown in the figure below. 
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Note that the measurement file formats .wmb and .wav will contain all information, while the 
formats .wmt and .tim contain less information. However, note that if the .wav-file is normalized 
when saved, its level information will not be correct. 

4.7 Delete Unplotted Measurements  
Deletes all the measurements that are present in the memory (of the active window), except the 
measurements that are plotted.  
Even the unsaved measurements will be deleted. Since WinMLS stores all the performed and 
inserted measurements in memory as default, it may be needed to clear the memory. 

4.8 Sound Card Settings 
Opens the Sound Card Settings dialog as shown below.  
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4.8.1 Mixer and Synchronization Settings 
 

 
 

 should be checked to make use of the WinMLS internal mixer. If it 
cannot be checked, this may be because your sound card does not have a software mixer, or it is 
not compatible with the Windows® sound system. If not checked, several settings in this dialog 
box will be disabled. 

4.8.1.1 Synchronization Mode – Measurement of initial time 
delay, or not. 

 should be checked if the measurement is to be performed in loop-
back mode. Then the settings below must be set. 
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The initial time delay is the same as the time a pulse takes to travel through the system we are 
measuring. Typically the distance from the loudspeaker to the microphone. This can be measured 
in several ways when measuring transfer functions with WinMLS.  
These settings only apply when measuring transfer functions and not when measuring in scope 
mode. 
 

 

    
 
Each of the items in the list shown in the figure above is explained in the chapters below. 

4.8.1.1.1 Only if my sound card ‘is synched’ 
‘Is synched’ means that the sound card is able to start record and playback at the same time, or 
with a delay that is constant. This must be fulfilled to be able to measure the initial time delay 
correctly.  
 
Note that the constant time delay for the sound cards may be of importance. If this is the case, use 
the mode Yes, my sound card ‘is synched’ explained below. 
 
WinMLS checks the sound card type. If it is one of the types we have tested and found to be 
‘synched’ then the measurement is performed so that the initial time delay will be found. 
 
In the current version of WinMLS the Digigram VX sound cards, Siena, Card Deluxe and Delta 
1010LT is on the “list”. Please note that the Digigram VX pocket and Delta 1010LT has a 
deviation of 1 sample when using this method of determining initial time delay. 
 
If the sound card is not found in our list, then the measurement is performed in the No, detect 
start of measurement mode explained below. 

4.8.1.1.2 No, detect start of measurement 
This mode does not measure the initial time delay. The initial time delay is removed so the 
impulse starts from the very beginning. A special algorithm is used to detect the start of the 
impulse response. 
 
Multi-channel measurement note: The start detection will not work properly if a multi-channel 
transfer function measurement is performed and one of the channels contains a non-impulsive 
signal. This is because all channels are searched to find the start of the first pulse. 

4.8.1.1.3 Yes, my sound card ‘is synched’ 
You can select this mode if you know that your sound card is able to start record and playback at 
the same time, or with a delay that is constant. The constant delay can be corrected for in the  

 setting explained below. 
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The initial time delay will be measured if this is set properly. 

4.8.1.1.4 Yes, with loop-back and end-check 
The measurement is performed using a physical loop-back, usually connected from output right 
channel to input right channel.  
A pulse is sent through the loop-back before the measurement is performed and it makes it 
possible to determine the initial time delay correctly. 
After the measurement is finished, a pulse is also sent through the loop-back. The time delay 
between this pulse and the pulse sent before the measurement was started is checked. This end-
check is used to detect errors in the measurement caused by non-continuous play or record. The 
loop-back settings (see below) must be properly set. 
 
For more detailed explanation see the WinMLS User’s Guide in the chapter Measurement 3: 
Measuring using loop-back. 

4.8.1.1.5 Yes, with loop-back, no end-check 
Same as the mode above, except that the end-check is not performed. This means that this mode 
measures the initial time delay exact, but errors in the measurement caused by non-continuous 
play or record are not detected. The loop-back settings (see below) must be properly set. 
 
gives the delay of the sound card in samples. This is found by doing a MLS measurement of the 
sound card with its input connected to the output using a cable. Plotting the first part of the 
resulting impulse response using Time Data as plot-type and Samples as x-axis, will show the 
delay. 

4.8.1.2 Loop-back settings 
 gives the delay of the sound card in samples. The delay is found by 

doing a MLS measurement of the sound card with its input connected to the output using a cable. 
Plotting the first part of the resulting impulse response using Time Data as plot-type and Samples 
as x-axis, will show the delay. In addition to being used for the loop-back, this setting is also used 
for the Yes, my sound card ‘is synched’ mode. 
 

 gives the input line used when performing a loop-back 
measurement. For the Digigram® cards, Analog Input should be selected, but for other sound 
cards it is usually Mic or Line. 
 

 gives the channel that the loop-back is to be connected to. If the 
loop-back input is stereo, it is usually connected to Right channel. But if it is mono (e.g. the Mic 
input), it must be set to Left. 
 

 should be checked if problems occur when measuring in loop-back 
mode. A short MLS signal is used for the synchronization instead of the standard pulse. This 
signal is less prone to noise, but may demands a fast PC since will need more processing. If you 
are using a sound card capable of measuring DC offset (e.g. TB Tahiti/Monterey) it is strongly 
recommended to use this setting. 
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4.8.2 Input Settings 
 

 
 

 gives the sound card input device. Note that the combo box list may 
contain devices that cannot be used for measurements. 

 

 gives the input line. For the Digigram® cards, Analog Input should 
be selected, but for other sound cards it is usually Line, or Mic. Note that the combo box 
list may contain lines that cannot be used for measurements, e.g. CD player and Aux. 

 gives the bit depth used for recording. You may choose either 16 or 
24 bits. 24 bits usually gives a slightly better measurement result and allows a larger 
dynamic range, but your sound card may not support 24 bits. 

 opens the dialog box for setting input devices if a multi-channel 
(>2 channels) measurement is to be performed. 

4.8.3 Output Settings 
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 gives the sound card output device. Note that the combo box list 
may contain devices that cannot be used for measurements. 

 

 gives the input line. It is usually called Wave Output or Wave, or a 
translation if your operative system is not English. 

 

 gives the bit depth used for playback. You may choose either 16 or 
24 bits. Your sound card may only support 16 bits. Bit depth makes no difference to the 
MLS signal if emphasis is not used, but 24 bits usually gives slightly better measurement 
results if pre-emphasis is used. 

 

 gives the master volume for all output lines and can be given a 
value from 0 to 65535. We recommend that you set it to 65000 (or exactly the maximum 
value 65535). If you have problems with distortion on your sound card output, then 
setting a lower value might reduce this. 

4.8.4 Sound Card Specific Settings 

 
 
The sound card specific settings are sound card dependent. On some sound cards you may set 
Treble and Bass, 3-D sound and other settings, but for other sound cards no such settings are 
supported. In that case all settings will be ghosted as shown in the figure above.  
If your sound card has such special settings, it is likely that they will influence the result of your 
MLS measurements. Therefore, WinMLS will extract these settings and allow you to set them. 
These settings will be saved in the measurement setup file as the other measurement settings. 
This way you are sure to have exactly the same settings each time you do a measurement.  
 
The output tone controls Treble and Bass found on the left side of the figure above can be set to 
a number from 0 to 100. This setting will greatly affect the frequency response of your sound 
card. You may use this as an equalizer to boost either the high or the low frequency region. 
If any of the Other settings are supported, they will be listed and turned off as default. You may 
turn them on by checking them. We recommend that you do not check the controls unless you 
know exactly what the control does. For more information about this, consult your sound card 
hardware documentation. A way of testing it would be to compare a measurement with the 
control turned off with a measurement with the control turned on.  
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Note that it is possible that a sound card has settings that is not displayed in the Sound card 
specific settings, e.g. the Digigram sound cards volume settings Advanced Input and Advanced 
Output. 

4.8.5 Advanced settings 
 

 
 

 should be checked if you want to save everything that is recorded 
during the whole measurement to a .wav file. This can be useful if you need to see what has 
happened during your measurement. Then you can simply play the file and listen to it, or open 
the file in a sound editor. For 1 channel measurements, a mono .wav file is generated, for multi-
channel measurements a stereo .wav file is generated. 

 gives the name and path of the diagnosis file to be saved. 
 determines if unwanted feedback that may occur between the 

measurements should be turned off. If this is not checked, feedback may occur between the 
measurements because then the original sound card volume is being restored. If checked, it will 
make sure that the volume setting causing feedback is turned off. 

 gives if input/output is mono or stereo when performing a 1-
channel measurement. In most cases this should be set to Stereo. However, if you have a sound 
card that is mono full duplex (probably an older card), you may set it to Mono. 

4.9 Hardware Calibration… 
Displays the dialog box shown below. 
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4.9.1 Absolute Input Level Calibration 
 

 
 

 determines if the input is to be absolute calibrated. 
 displays the input absolute calibration settings  dialog box as described below. 

 determines which channel the Settings… are displayed for. For a 1-channel 
measurement, this number should be set to 1. 
 



 37

 
 

4.9.1.1 General settings 
 is used to choose between Detailed calibration and Total calibration. 

These will be discussed below. 
 should be checked if you are having a transducer (e.g. a microphone) 

connected to the input. It makes sure the units are correctly set and allows you to specify the 
transducer sensitivity if Detailed calibration is selected. 

choose the unit of your transducer. If you are using a microphone, select 
Pres [Pa]. 
 
 
 

4.9.1.2 Total calibration 
The purpose of this type of calibration is to calibrate the whole input chain in one operation 
without having to calibrate the sound card first. This calibration is fast and simple, but we 
recommend that you instead use the Detailed Calibration (see below) if you are using WinMLS 
both for electrical measurements and measurements where you are using a transducer (e.g. a 
microphone), or a pre-amplifier with changeable gain. 
 

 
 

 gives the number WinMLS uses to calibrate the input. This number will automatically be 
set when clicking the  button, but it may be manually set. 

 performs the calibration procedure. 
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 opens the calibration settings shown below. 
 displays the date of the last calibration. It is set by clicking . 

 

 
 
In the dialog box above you can set the level and frequency for the calibration, and choose if you 
want to use an external signal generator or use the sound card output as signal generator. Using 
the sound card output should be fine as long as you have something to measure the signal level 
with (the measured level is used as the reference level), e.g. a voltage meter if you are doing an 
electrical calibration. The Test level button should be clicked to test the levels. 
 

4.9.1.3 Detailed Calibration 
 

 
 

 is for 
calibrating the sound card input sensitivity. This must be done before calibrating the Transducer 
sensitivity. 
 

 should be turned on if you are using an external pre-amplifier. 
Type the amplifier gain in the edit box. If you want to determine the amplification of the pre-
amplifier, we suggest that you do this manually by plotting the frequency response of the 
measurement system with and without the pre-amplifier. Note that the sound card calibration and 
the pre-amplifier gain and status (checked/unchecked) must be correct in order to get a correct 
calibration of the transducer sensitivity. 

 the transducer 
sensitivity of your transducer may be given by the manufacturer, then you may type this value in 
the edit box. You may also measured the transducer sensitivity by clicking the  button. 
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However, you should first click the  button to set the correct calibration settings. You 
must also make sure the Amplifier Gain and Sound card conversion settings are correct. 

4.9.2 Absolute output level calibration 
 

 
 

 Determines if the input is to be absolute calibrated. 
 Displays the output absolute calibration settings  dialog box as described below. 

 

 
 
This dialog box is very similar to the Input Level Calibration displayed in the chapter above. 
For an explanation please refer to this chapter, or to the FAQ. 

4.9.3 Relative calibration of mixer input 
The WinMLS mixer controls the analog input amplifier of the sound card (some sound cards do 
not have a mixer, and some cards have a mixer that can not be controlled by WinMLS). The 
relative calibration uses a file containing the gain steps of the mixer for correction when the 
mixer gain is changed. So when a relative calibration has been done for the WinMLS mixer, 
changing the volume of the WinMLS mixer input will not affect the level of the measured 
transfer function. See FAQ for more information. 
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 If checked, the relative calibration is performed using the correction file described 
below. 

 For selecting the correction file. If your sound card has two input lines, 
e.g. a microphone and line input, they will probably not have the same gain steps. Therefore, if 
you plan to switch measurement input line, the calibration file must be switched. How a 
correction file is generated is described below. 

 Click to generate a new input mixer correction file for the inputs and outputs selected 
in Measurement->Sound Card Settings. A dialog box will be displayed giving directions on 
how to perform the mixer input calibration. The procedure may take a few minutes. You will be 
notified when the calibration is finished. 

 Determines in what way the input levels are displayed. In the 
current version of WinMLS, it can only be displayed relatively with 0 dB as maximum (Full scale 
input). The maximum value of the input is found (within each average). 

4.9.4 Relative calibration of mixer output 
The relative calibration of mixer output is very similar to the relative calibration of mixer input. 
Please see chapter above for explanation.  
 

 
 

4.9.5 Measurement System Correction 
The influence of the measurement system can be corrected as described in the FAQ How to 
correct for the influence of the measurement system? 
 

 Selects the measurement system correction.  
 

 If this is checked, the full name of the measurement system correction files shown in the 
combo box above will be displayed. 

4.10 Measurement Settings Toolbar 
The Measurement Settings Toolbar is displayed if this is checked. The toolbar may also be 
turned on/off from the View menu. The reason for having this toolbar here is that the settings in 
this particular toolbar cannot be set from a dialog box, which is normal. And these settings should 
be found from the Measurement menu. 

4.11 Sinusoid Settings… 
Displays the dialog box shown below used to set the frequency and level if sinusoid is selected as 
output signal. 
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The Frequency can be set no higher than half the sampling frequency. Note that if you close the 
dialog box and open it again, the frequency will have changed slightly from the value you have 
typed. This is because it has switched to the nearest possible exact frequency. The frequency 
resolution is increased by increasing the sequence order in the Measurement Settings Toolbar. 
The Level [dB FS] is the full scale level given in Decibels. Its maximum value is 0, which is the 
maximum amplitude for the Digital-to-Analog converter. The output level may be further 
adjusted using the volume settings. 

4.12 Advanced Settings 
Displays the dialog box shown below. 
 

 
 

4.12.1 Pre-D/A sound card output amplitude 
These settings will set output:  

 Inverts the output signal if it is checked. If the measured impulse 
response has a negative peak, toggling this will invert the peak. 
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 The edit box  gives the full-scale amplitude in Decibels 
of the measurement output signal (and for the relative sound card mixer calibration). Its 
maximum value is 0, which is the maximal amplitude for the Digital-to-Analog converter. 

 The edit box  gives the full-scale amplitude in Decibels 
of the signal used for absolute calibration of the sound card. 

4.12.2 Emphasis offset 
 The pre-emphasis output amplitude is determined from this 

setting in combination with the  (this is why we have called it 
offset). Depending on the selected type of pre-filtering, a too high value may cause the amplitude 
to exceed the maximal amplitude. If this causes clipping of the signal, an error message will be 
displayed. 

 This is used to scale the recorded signal when measuring using 
post-emphasis. 

4.12.3 Limits for automatic setting of volume 
These settings will determine the limits when using Measurement->Set Input Volume and 
Measurement->Set Input Volume. 

 The volume is set so that the level is above this limit when 
using Measurement->Set Input Volume. 

 The volume is set so that the level is below this limit when 
using Measurement->Set Input Volume. 

 The volume is set so that the level is above this limit when 
using Measurement->Set Output Volume. 

 The volume is set so that the level is below this limit when 
using Measurement->Set Output Volume. 

4.13 Measurement Tasks… 
Displays the dialog box shown below used to determine what tasks are to be performed when a 
measurement is performed, inserted or opened. 
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4.13.1 Tasks when performing a measurement 
 determines if a new measurement is to be 

performed in the active window or if a new window is to be opened. If Perform measurement 
in new group (windows) is selected, a new window will be opened when a new measurement is 
performed. This is similar to the two options you have when opening a measurement file. You 
may then choose between Insert… and Open…. Insert… will open the measurement file in the 
existing window, while Open… will open it in a new window 
 

 will add a delay after you start the measurement 
before it is actually performed. If you have to do something before each measurement and you 
don’t have anyone to start the measurement for you, this delay after starting the measurement 
may be useful. 

 determines if the dialog box found in View->Volume and 
Input Levels(s) dialog is to be displayed when a measurement is performed. 

 determines if the measurement should be saved 
automatically using the filename and other parameters from Measurement->Defaults for 
Saving…. 
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 determines if a new measurement is to be 
started after performing a successful measurement. It makes it possible to perform several 
measurements without user interaction. 

 determines if an executable file is to be run after a measurement is 
performed. The name of the executable must be specified in the field below the check box. This 
may be used for controlling a turntable of type B&K®. For information about this, run the file 
BKturntable.exe found in the WinMLS folder. 

 adds a delay after the measurement has been 
performed. This may be useful when several measurements are performed in automatic mode. 

4.13.2 Tasks when performing or inserting a new 
measurement from file 

 determines if a message box should pop up asking 
the user if the previous measurement is to be saved when performing or inserting a new 
measurement.  

 determines if the unplotted measurements should 
be kept in memory or not. If you are to perform several hundred measurements, you should be 
aware of that it might fill up the memory if they are not removed. Measurements are deleted by 
using File->Delete Unplotted Measurements, alternatively Delete unplotted measurements 
from memory will delete all measurements as long as they are not set as active or plotted. This 
prevents the memory to run full. It is useful if a repeated measurement is to be done and each 
measurement is never supposed to be stored. E.g. when calibrating a sound system, repeated 
measurements are needed but the results are not to be kept in memory. To sum up, this option 
deletes the previous unplotted measurements from memory after a new measurement has been 
performed and plotted. 

 determines if plotting is to be performed when a measurement is performed or 
inserted. 

 determines if the data in the active plot is to be saved after a measurement 
is performed or inserted. The filename of the text file depends on if the measurement has a file 
name or not. If the measurement does not have a filename, it is saved under the default folder 
given in Measurement->Defaults for Saving. The filename is 
“PlotMeasFromMem<Measurement number>.txt”. If the measurement has a filename, it is saved 
using the measurement filename but with the extension .txt. 
This is useful for batch-processing, e.g. if you want to compute the smoothed magnitude 
frequency response of several measurement files and send the data to a text files. This is done 
automatically by using File->Insert, then mark the measurements files you want to process and 
insert them. 

 determines if room acoustics parameters are to be displayed 
and/or saved after a measurement is performed or inserted. The setting telling if it is displayed or 
saved to file or both is found in the bottom of the Room Acoustics->Calculation Options… 
dialog box.  
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The Send to Text file option is useful for calculating the room acoustics parameters of several 
files and saving the results in one operation. First check this option, then make sure Send to 
Text-file is checked in Room Acoustics->Calculation Options…. In File->Insert, select all the 
files that you want to process. If the measurement has a filename, it is saved using the 
measurement filename(s) but with the extension .txt. The filename of the text file depends on if 
the measurement has a file name or not. If the measurement does not have a filename, it is saved 
under the default folder given in Measurement->Defaults for Saving. The filename is 
“RoomAcMeasFromMem<Measurement number>.txt”. 

 If this is turned off both channels in a 2-channel 
measurement are plotted in each plot. If you for example, view the impulse response in the upper 
plot and the magnitude frequency response in the lower plot, you normally want to do it this way. 
If the option is turned on and a 2-channel measurement is performed, channel 1 is plotted in the 
upper plot and channel 2 is plotted in the lower plot (if the window has two plots). This option is 
useful if you wish to view two plots having the same plot type. This is done in the room acoustics 
measurement setup file RoomAcMeasurement. Here the time-data plot type is displayed in both 
plots. When a two-channel measurement is performed, channel 1 is plotted in the upper plot and 
channel 2 is plotted in the lower plot. It makes it easy to compute room acoustics parameters that 
need two impulse responses, a primary and a secondary. The primary impulse response is taken 
from the upper plot, while the secondary is taken from the lower plot. 
This also applies if two measurements are inserted using File->Insert. See the FAQ for more 
information. 

4.14 Defaults for Saving... 
Displays the dialog box containing the defaults for saving measurements shown in the figure 
below. After a file is saved the default folder, format, title, comment(s) and current counter is 
updated. 
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4.14.1 Default file-parameters 
From here the default file folder, name and extension is set. Note that the default filename for 
saving will in addition contain a number given by the Autoname generator as will be described 
below. A single channel measurement using the settings above would get the suggested filename 
with full path: c:\winmls2000\measurements\Meas_1.wmb 

 should be checked if you want to normalize when saving to .wav-file. This 
should be done to ensure maximum quality. However, note that if the .wav-file is normalized 
when saved, its level information will not be correct. 

 gives the tab used for determining the filenames for a multi-
channel measurement. A 2-channel measurement would, using the settings shown in the figure 
above, get the following two suggested filenames: MeasCh1_1 and MeasCh2_1. 
A multi-channel file will get the default name: 
<default filename> + <multi-channel tab> + <channel number> + <_> + <measurement auto-
numbering> 
The reason for doing it in this order is to ensure flexible listing of the measurements in the 
Windows® file explorer. If you list the measurements using date, the multi-channel 
measurements will be listed after measurement number. If you list the measurements using 
filename, they will be listed after channel number since the channel is added before the 
measurement number. 
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4.14.2 Title and comments 
Title and comments will be saved to the file header except for the .wmt format, which only saves 
the comment. The title has a maximum of 80 characters and the comment 60 characters. 
The title will appear in the plot title if  is checked in Plot->Advanced Plot 
Settings… and if  is checked on the Standard Toolbar. 
The comment will appear in the plot title if  is checked in Plot->Advanced 
Plot Settings… and if  is toggled on the Standard Toolbar. 
For a multi-channel measurement, comments may be given for each channel by clicking 

. 
 

4.14.3 Autoname generator 
The autoname generator is used to automatically assign a number to the suggested measurement 
filename. 
 

 
 
The first edit box  gives the start number of the auto-numbering. The second edit box 

 gives the number where the auto-numbering ends. When this end-number is reached, the 
auto-numbering starts at the start number again. If you for example, are to perform 8 
measurements that should have the same name, but numbered 1 to 8, you should set this to 8. 
Then when saving measurement number 9 the Defaults for Saving dialog box will be displayed 
and you may change the name. 

 displays the current value of the counter. E.g. after saving 5 
measurements, the counter will have the value 5. 

4.15 Measurement Setup... 
Measurement setup defines as all the settings in the measurement menu.  
 

 
 
When WinMLS is exited, the setup filename is saved in registry and all the current settings are 
saved to a temporary setup. The next time WinMLS is run, this setup file is opened and the 
settings restored. 
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To prevent the user from accidentally deleting or overwriting a setup file, the setup files may be 
write-protected. 

4.15.1  Select setup 
Displays the selected measurement setup. Setups are chosen from a list as shown in the figure 
below. 

 
 

4.15.2  
If this is checked, the post-processing setup is also saved when saving the measurement setup. 

4.15.3  Save setup 
Saves the current measurement settings using the name in the Setups combo box. 

4.15.4  Save setup as 
Opens a dialog box for saving the current measurement settings. 
 

 
 
If  is not checked, the post-processing setup will not be 
saved and the dialog box will look like in the figure below. 
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4.15.5  Delete setup 
Deletes the selected setup. 
The button is disabled when only one setup file is left to make sure not all setups are deleted. 

4.15.6  Load setup 
Loads the selected setup and then closes the Measurement Setup… dialog box. Note that you 
will not be asked to save the previous settings. 

4.15.7  Close dialog 
Closes the dialog box. No new setup will be loaded. 

5 Plot 
This menu contains all post-processing features, except for the room acoustics. The first part of 
the menu, as shown below, contains commands and settings for manipulating the plot(s). 
 

 
 
The next part allows the user to select which plot type(s) to display and what measurement(s) to 
plot. It also contains chart settings that apply for the active plot only and settings that are specific 
for each plot type. 
 

  
 
The last part contains various settings that applies to all plots, except for General Frequency 
Domain Settings... that applies for the frequency domain plot types only. 
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Each item is explained in detail below. 

5.1 Add Curve(s)  
Adds new curves(s) to the active plot. The data is taken from the active measurement and 
normally one single curve is added. If a multi-channel measurement has been performed and is 
active, curves for all the channels are added. The curves are always added to the current plot 
independent on the Plot->Hold Plotted Curves setting. If it is desired to remove the old curves 
before adding new curve(s), then this can be done as described below by using Plot->Delete All 
Curves. 

5.2 Delete All Curves  
Deletes all curves in the active or both plots. The dialog box shown below is displayed. 
 

 
 
You may choose to delete the curves in the active plot or in both plots (if two plots are present in 
the window). 

 

5.3 Hold plotted curves  
If this menu-item is checked, the existing curves in the plot(s) will remain in the plot when a new 
curve is plotted. If it is unchecked, the existing curves in the plot(s) will be deleted when a new 
curve is plotted. In the software MLSSA® and some other software holding plotted curves is 
called Overplot. Note that in WinMLS you may change the settings for the curves you have 
already plotted.  

5.4 Menu: Solo Active Measurement Curve  
If you have several curves in the plot and want to view only one curve temporarily, this “solo” 
setting can be used. If ”solo” is turned on, it hides all curves that do not belong to the active 
measurement.  
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If there are several curves of the same active measurement, only the last plotted curve is visible. 
The other curves are not deleted from the plot, but are set invisible. They may easily be set 
visible again by turning “solo” off. If ”solo” is turned off, the curves that were visible before 
”solo” was turned on are set visible again. 
 
When Plot->Refresh All is selected or if auto-refresh is performed in refresh all mode, all the 
curves that are refreshed are set visible. This is because when refreshing all, it is likely that the 
user wants to display all the refreshed curves. 

5.5 Auto Refresh 
Auto-refresh will refresh the curve(s) if any settings influencing the viewed plot(s) are changed.  
Examples of settings that will cause auto refresh are the settings in the dialog box that pops up by 
clicking in the active plot, the toolbar buttons influencing the plotting and changing the time 
window size clicking and dragging the mouse. 
Note that the settings in Plot->Chart Settings for Active Plot... are not controlled by the auto-
refresh, as these settings are always immediately updated. E.g. if you change the plot background 
gradient colors in the Plot->Chart Settings for Active Plot... dialog box, this will be done 
immediately, even before closing the dialog box. 
 
The type of refresh depends on what is checked in the sub-menu as shown below  
 

 
 
Each of these is described below. 

5.5.1 Active Measurement 
If this is checked, the most recent curve of the active measurement is refreshed when changes in 
the settings are made. If the active window has two plots, both plots are refreshed. For details see 
documentation for Plot->Refresh Active. 

5.5.2 All Measurements 
If this is checked, the most recent curves of all measurements in the active window are refreshed 
when changes in the settings are made. If the active window has two plots, both plots are 
refreshed. For details see documentation for Plot->Refresh All. 

5.5.3 Off 
If this is checked, no auto-refreshing is performed. But if a measurement is performed or inserted, 
it will be plotted. Refreshing must be done manually using Plot->Refresh Active or Plot-
>Refresh All. Set auto-refresh in Off modus if you wish to perform manual refreshing as will be 
described below. But note that if the settings in Plot->Chart Settings for Active Plot... are 
changed, this will immediately change the settings in the active plot. 
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5.6 Refresh Active 
Refreshes the most recent curve of the active measurement in the active plot. Refresh Active is 
meant for use only when auto-refresh is turned off, see above. It is a “manual” refresh and gives 
the user somewhat more control. If the active window has two plots, only the active plot is 
refreshed. If no curve of the active measurement exists in the active plot, it will be added. 

5.7 Refresh All 
Refreshes the most recent curves of all measurements in the active plot. Refresh All is meant for 
use when auto-refresh is turned off or set in Refresh Active mode, see above. It is then useful if 
you change a setting and you want all curves to be updated with this setting. Note that if you are 
plotting in frequency domain, the current time data window size is used when refreshing, even if 

 is checked (found by clicking 

 in Plot->General Frequency Domain Settings…) 
Note also that if several curves of a measurement are present in the plot, only the most recent 
curve will be updated. If the active window has two plots, only the active plot is refreshed. If no 
curve of the active measurement exists in the active plot, it will be added. 

5.8 Select Plot Type(s)/Measurement(s)... 
Displays the dialog box shown below for setting the plot type and active measurement in upper 
and lower plot. 
 

 
 
The settings in this dialog box, may also be set from the Plot Toolbar and the Measurement 
Selection Toolbar. 

5.8.1 Number of plots  
Select if a single plot or two (double) plots are to be viewed as showed below. 
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5.8.2 Plot Type in Primary (upper) Plot 
Selects the plot type from a list of all the available plot types. If two plots are displayed, this is 
for selecting the plot type in the upper plot. 
 

 

5.8.3 Active measurement in Primary (upper) Plot 
Selects the active measurement from a list of all the performed or inserted measurements in the 
active window. If two plots are displayed, this is for selecting the active measurement in the 
upper plot. 
 

 

5.8.4 Plot Type in Secondary (lower) Plot 
Selects the plot type in the lower plot from a list of all the available plot types. 
 

 
 

5.8.5 Active measurement in Secondary (lower) Plot 
Selects the active measurement in the lower plot from a list of all the performed or inserted 
measurements in the active window.  
 

 

5.9 Chart Settings for Active Plot...  
Displays the dialog box shown below. 
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This dialog box gives many possibilities. The settings of this dialog box are saved to chart files 
for each plot type and are restored when the plot type is displayed. The chart files are found in the 
Chart subfolder in the folder where WinMLS is installed. 
Note that changes in the plotted curve, e.g. changing colors, will not be saved. Default curve 
styles are set in Plot->Default Curve Styles.... 
 
Now each tab page as shown in the figure below will be described, starting with the Chart page. 
 

 
 

5.9.1 Chart page 
This is the page that is displayed when opening the dialog box. It defines the overall display 
parameters for the active plot, such as background, axis, titles and legend. An explanation of 
some of these parameters is given in the FAQ document. 

5.9.2 Series page 
Gives access to the settings that applies to each curve (here it is called series) as shown below. 
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The Series page will contain parameters dependent on the series type concerned, and the 
available parameters will depend on the curve type chosen (in the figure above the curve type is 
Fast Line). The setting  at the top of the Series tab page shows 
which curve you are editing. 

5.9.3 Data page 
Gives access to the data (x- and y-values) of the active plot as shown in the figure below. 
 

 
 
By clicking on the cells, the data may be deleted, changed or added. 

5.9.4 Export tab 
Displays advanced setting for exporting the data in the active plot to picture formats. 
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Use the  button for saving. 
 
If the Data tab is selected, advanced settings for exporting data is available as shown in the figure 
below. 
 

 
 

5.9.5 Print tab 
The Print tab gives access to the same settings as File->Print Preview… and we recommend 
using that instead. 

5.10 Plot Type Settings 
Gives access to all the plot type settings as shown in the figure below. 

 
 
Note that double-clicking in the plot is a faster way to access the plot type settings for the active 
plot. The  button on the Plot Toolbar may also be used. 
The settings for each plot type will be explained below. 

5.10.1 Time Data… 
Displays the dialog box shown below. 
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5.10.1.1 X-axis settings 
Selects the unit of the x-axis from one of the units displayed in the list shown below. 
 

 
 
The chosen unit is also used in the user interface, e.g. as unit for the time window. 
 
When the x-axis is changed, the upper and lower limits are will be properly scaled so the same 
segment of the curve(s) will be displayed. If several curves are plotted and the x-axis setting is 
changed e.g. from Time [samples] to Time [ms], the curves will be updated using the Plot-
>Refresh All procedure. 

5.10.1.2 Y-axis settings 
Selects the unit of the y-axis and the processing of the data from one of the choices displayed in 
the list shown below. 
 

 
 
When the y-axis is changed, the upper and lower limits will be auto-scaled to make sure the 
curve(s) are appropriately viewed. If several curves are plotted and the y-axis setting is changed, 
the curves will be updated using the Plot->Refresh All procedure. 

5.10.1.3 Y-axis scaling 
 Three types of scaling of the time data is supported as shown below. 
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No scaling – no scaling of the measurement. 
Normalize – the measurement is normalized. 
The amplitude of the absolute value of the time data is set to 1 if the y-axis is Linear or Squared 
(Energy). It is set to 0 dB if the y-axis is dB. If performing a 2-channel measurement, do not use 
this normalization setting if it is desired to see the difference in levels between the impulse 
responses. 
Scale by:  - scales the measurement with the given factor. If the y-axis is 
Linear, the measurement is multiplied with the factor. If the y-axis is Squared (Energy), the 
measurement is first squared and then multiplied with the factor. If the Y-axis is dB, the 
measurement is shifted (not scaled) with the factor. 

5.10.1.4 Velocity of sound  
Gives the velocity of sound and the unit. 
Two units may be chosen: 
 

 
 
The velocity of sound is used to compute the x-axis unit if Distance [meter] or Distance [feet] is 
chosen for the time domain plot types. It is also used to compute the quarter, half and whole 
wavelengths displayed in the Status Toolbar for the frequency domain plot types. 
 
Note that if you are performing vibrational measurements, e.g. using an accelerometer instead of 
a microphone, it is the velocity of propagation in the structure that is to be typed, not the sound 
velocity. 
 
Note that changing the velocity of sound in this dialog box will also affect the other time domain 
plot types, such as energy-time-curve. 
 
The speed of sound, denoted c, may be found if the temperature is known using the formula 
 
c = (331.4 + 0.6*T) 
 
where T is the temperature in centigrade. 

5.10.1.5 Show time window for active measurement 
 If checked, the time data window is displayed in the Time 

Data plot type as shown below. The time data window consists of the three yellow straight lines 
and it is valid for the active measurement. (there may be more than one measurement in the 
window and these may have different time data windows). 
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The window start and end points can be set directly by clicking and dragging with the mouse. In 
order to do this, the mouse pointer has to be exactly on top of the vertical line that is to be moved. 
The mouse pointer changes shape when it comes close to the limit. 
In order to make sure auto-scaling of the y-axis can be effectively used, the vertical start and end 
lines are kept within the curve area. (The length is 10% larger than the minimum of the curve 
with the smallest y-value, and 10% less than the maximum of the curve with the greatest y-
value.) The whole window is thus visible if auto-scaling is used. 

5.10.1.6 Remove DC-component ( 0 Hz) 
 If checked, the DC-component will be removed when plotting.  

The DC-component is removed by subtracting the DC-component of the last half of the 
measurement data. 

5.10.1.7 Processing Type 
 This contains the processing options showed below 

 

 
 

5.10.1.7.1 No processing 
No extra processing is done on the measurement data. 

5.10.1.7.2 Integral (Step response) 
Integrates the measurement data. This is useful for example if you are measuring velocity but 
want to display displacement. If the measurement is an impulse response, the result is a step 
response. This is because the integral of an impulse response is a step response. 
When performing integration, the DC-component should be removed, so make sure 

 is checked. 
Instead of using this integration option, you may use the plot type named Integrated Time Data 
(Step Response). 
The numerical integration is performed by cumulative summing of the elements. This gives a 
time shift error of one half sample which gives a linear phase shift. No correction for this is 
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performed, but it may be done using the Subtract delay check box in the phase 
response/function plot type settings.  

5.10.1.7.3 Double integral 
Computes the double integral of the measurement data. This is useful for example if you are 
measuring acceleration but want to display displacement.  
When performing the double integration, the DC-component should be removed, so make sure 

 is checked. 
The numerical double integration is performed by twice cumulative summing of the elements. 

5.10.1.7.4 Derivative 
Computes the derivative of the measurement data. This is useful for example if you are 
measuring displacement but want to display velocity.  
The numerical derivation is performed by taking forward differences on the left and right edges 
and taking cantered differences on interior points. 

5.10.1.7.5 Double derivative 
Computes the double derivative of the measurement data. This is useful for example if you are 
measuring displacement but want to display acceleration.  
The numerical double derivation is performed by computing the derivative as described above 
twice. 

5.10.1.7.6 Cumulative energy 
Computes the cumulative energy of the measurement data. 
The computation is performed by first computing the energy, then cumulative summing of the 
energy elements. 

5.10.1.8 Filtering 
If  is checked, filtering of the measurement is performed according to the 

filtering options  as shown below. 
 

 
 

5.10.1.8.1 Type of filtering 
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Selects the type of filtering from the list below 

 
 
A BandPass filter lets the frequencies within a band pass and suppresses the other. A BandStop 
filter suppresses the frequencies within a band and lets the other frequencies pass. A LowPass 
filter lets low frequencies pass and suppresses the high frequencies. A HighPass filter does the 
opposite. 

5.10.1.8.2 LowPass/HighPass filter settings 
This group contains the settings if the type LowPass or HighPass has been selected. 
 

 Specifies the cut-off frequency of the filter. The frequency may be 
typed or selected from the list of standard 1/3-octave frequencies. 

 Specifies the filter order. The order is selected from the list and has 
the range 1-14. 

 Specifies the filter type. In the current version of WinMLS, 
only the type Butter is supported. 

5.10.1.8.3 BandPass/BandStop filter settings 
This group contains the settings if the type BandPass or BandStop has been selected. 
 

 If BandPass is the filter type and this is checked, several bands 
may be filtered and thus several curves are plotted depending on the start and stop frequency and 
the octave fraction bandwidth. How to determine the bands is explained below.  
Note that if Filter several bands is checked, it is strongly recommended to make sure Plot-
>Hold plotted curves is unchecked. This is because many curves will be generated, and the 
refreshing does not handle this special case with several curves of one measurement. Plot-
>Refresh Active and Plot->Refresh All, will add new curves and not replace the old ones. 
 

 Determines the centre frequency. Any frequency may be 
typed or it may be selected from the list of standard 1/3-octave frequencies. If 

 is checked and the filter type is BandPass, two frequency values 
are to be selected, the start and end centre frequencies. The number of curves to be plotted within 
this frequency range is given by the Bandwidth described below. If the bandwidth is set to 1 
octave or 1/3 octave, the standard frequencies within the specified frequency range is used. For 
other bandwidth settings the centre frequencies are calculated beginning at the start centre 
frequency. 
 

 Determines the filter octave bandwidth. Any bandwidth may be typed 
or it may be selected from the list. A bandwidth of 1 octave is according to the ISO 3382 
standard. 
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 Specifies the filter order. The order is selected from the list 
and has the range 2-14, only even numbers. Filter order 6 is according to the ISO 3382 standard. 
If the order is greater than 6 it does not give a stable result for low frequencies, e.g. filter order 8 
and bandwidth 1/3-octave will not give a stable filter below a centre frequency of 350 Hz. 

 Specifies the filter type. In the current version of WinMLS, 
only the filter type Butter is supported which complies with the ISO 3382 standard. 

5.10.2 Integrated Time Data (Step Response)... 
Displays the dialog box shown below. 
 

 
 
All the settings of this dialog box are explained in the Time Data plot type documentation. 

5.10.3 Energy-time Curve 
Displays the dialog box shown below 
 

 
 
Most of the Energy-time Curve settings are found and described under the Time Data plot type 
settings. But for the Energy-time Curve the y-axis can only be plotted in dB (the y-axis scaling is 
set to  which is the most common way to view the Energy-time Curve). The 
Frequency Domain Windowing settings are also unique for this plot type and are explained 
below. 
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5.10.3.1 Frequency domain windowing 
The Energy-time Curve is computed by first transforming from time domain to frequency 
domain.  
 

 
 
If  is checked, this transform is performed faster using a Fourier transform with a data 
length of an order of two. The data are padded with zeros to get this length. This may introduce 
an error if a DC-component exists.  
 
After the Fourier transform, a window may be applied to the complex frequency data before 
performing the inverse transform. The following choices are possible: 
 

 
 

5.10.3.1.1 Unwindowed 
No frequency domain windowing is performed. All frequencies are given equal weight. 

5.10.3.1.2 Half-Hanning 
A Half-Hanning window is applied in frequency domain. This results in an attenuation of the 
higher frequencies. This option is recommended for loudspeaker measurements. 

5.10.3.1.3 Blackman-Harris (full) 
A Blackman-Harris full window is applied in frequency domain. This results in an attenuation of 
both the lower and higher frequencies, while the mid-band frequencies are not attenuated. 

5.10.3.1.4 Filtering using Hamming 
A Hamming window is applied in frequency domain. Note that if this is selected, the usual 
filtering controlled by  will not be applied. However, the centre frequency and 
the bandwidth for the Hamming windowing is taken from the filtering options, accessed by 

clicking . In the dialog box, the centre frequency and bandwidth are set as shown 
below. 
 

 
 
Using the settings above will give the most weight to the frequencies around 1000 Hz and filter 
out all frequencies below 707 Hz and above 1414 Hz. 
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5.10.4 Schroeder Curve… 
Displays the dialog box shown below. 
 

 
 
Most of the Schroeder Curve settings are found and described under the Time Data plot type 
settings. But the Schroeder Curve y-axis can only be plotted in dB (the y-axis scaling is set to 

 which is the most common way to view the Schroeder Curve). The DC-component is 
removed for the Schroeder curve and it is computed from the last 50% of the measurement data. 
The Integration Options settings are also unique for this plot type and are explained in the 
chapter below. 
The Schroeder curve is backwards integration of the impulse response. When computing the 
Schroeder Curve, the start of the impulse response is detected. The Schroeder curve is used to 
find the reverberation time as described further in the Room Acoustics User’s guide. 

5.10.4.1 Integration Options 
The integration options are described in the Room Acoustics User’s Guide. 
 

 
 
The integration options are: 
 

 
 
1. Whole response 

Integration using the whole impulse response, no noise analysis carried out.. 
 

2. Truncation 
Integration of the impulse response, truncated at or above the crosspoint between the response 
and the stationary noise floor. 
 

3. Truncation and compensation 
Integration of the impulse response, after truncation at or above the crosspoint between the 
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response and the stationary noise floor, compensated for the truncated energy. This is 
recommended if the measurements are of reasonably high quality. 

5.10.5 Frequency Response/Spectrum... 
Displays the dialog box shown below. 
 

 
 

5.10.5.1 X-axis settings 
Selects the unit of the x-axis from one of the units displayed in the list shown below. 

 

5.10.5.2 Y-axis settings 
Selects the unit of the y-axis and the processing of the data from one of the choices displayed in 
the list shown below. 

 
 
If several curves are plotted and the y-axis setting is changed, the curves will be updated using 
the Plot->Refresh All procedure. 
 

5.10.5.3 General Frequency Domain Settings 
Click the button  to open the dialog box also accessed from 
Plot->General Frequency Domain Settings…. 

5.10.5.4 Type 
Select the type of frequency response/spectrum.  
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In the current version of WinMLS, only Magnitude is supported. 

5.10.5.5 Smoothing or Integration 
If the check box shown below is checked, frequency domain smoothing or integration is 
performed. 

 
 

The type of smoothing or integration is set from the  button and is described below. 
 

5.10.5.5.1 Smoothing Settings 
 

 
 
Smoothing calculates the mean of frequency response magnitude values over a sliding frequency 
band. The band is usually set in octaves (e.g. 1/3 octave wide) to give an equal distribution along 
a logarithmic frequency axis. A linear band may also be used and may be useful if a linear 
frequency axis is used. 
Smoothing in power is the standard method of smoothing if it is applied on magnitude frequency 
response or spectrum. The mean of the squared amplitude values are computed. But you may also 
smooth to get the mean in magnitude instead of the mean in power, by setting the smoothing type 
to Octave – magnitude mean/interpolation. Another feature of this setting is the interpolation, 
that means that it finally interpolates the calculated smoothed values to the frequency points used 
if no smoothing was applied. Smoothing may increase the calculation time. 
If the dialog box is opened from the Frequency Response/Spectrum plot type settings dialog box, 
integration may be chosen instead of smoothing. 

5.10.5.5.1.1 Smoothing type 
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The types of smoothing are shown in the list below. The two integration options at the bottom of 
the list shown below are only available if the Smoothing settings dialog box is opened from the 
Frequency Response/Spectrum settings dialog box. 
 

 
 

5.10.5.5.1.1.1 Octave – magnitude mean/interpolation 
Smoothing in magnitude mean. After smoothing, the calculated smoothed values are interpolated 
to the frequency points used if no smoothing was applied. In Smoothing parameters described 
below, the bandwidth is set. Because of the interpolation, this is the slowest method of 
smoothing. 
This smoothing algorithm has been contributed by Dr. Aki Mäkivirta, Genelec Oy. 

5.10.5.5.1.1.2 Octave - low frequency correction 
Octave smoothing with a correction for low frequencies. If the number of points within the 
smoothing window is less than 3, then the data is plotted without being smoothed. This will avoid 
the stair-like shapes for low frequencies sometimes seen if using the option Octave – no 
correction. If magnitude frequency response or spectrum is plotted, the energy is smoothed, not 
the mean or Decibel. In Smoothing parameters described below, the parameters for this 
smoothing type are selected. 
For high frequencies, the smoothing is stopped when there is not enough bandwidth for a full 
smoothing. E.g. if 1 octave is chosen and Fs=48000, the highest frequency would be (Fs/2) *2^(-
1/2)= 16.9 kHz. For 1/3 ovtave it would be(Fs/2) *2^(-1/6) = 21.4 kHz. 

5.10.5.5.1.1.3 Octave - no correction 
This option is the same as above, except that no low frequency correction is performed. 

5.10.5.5.1.1.4 Constant 
Constant bandwidth smoothing. Suited if the data it plotted using a linear frequency axis. Note 
that the starting frequency is at half the constant bandwidth. E.g. if Smooth over [Hz] in 
Smoothing parameters is set to 100, the first frequency plotted is at 50 Hz. 

5.10.5.5.1.1.5 Constant (low freq.) - Octave (high freq.) 
This method does Constant bandwidth smoothing up to Start frequency [Hz] (see below). 
Above this frequency it is Octave smoothing. 

5.10.5.5.1.1.6 1-octave IEC Integrated (energy) 
Plots the energy in octave bands. 
This option is available only if the Smoothing settings dialog box is opened from the Frequency 
Response/Spectrum settings dialog box. 

5.10.5.5.1.1.7 1/3-octave IEC Integrated (energy) 
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Plots the energy in 1/3-octave bands. 
This option is available only if the Smoothing settings dialog box is opened from the Frequency 
Response/Spectrum settings dialog box. 

5.10.5.5.1.2 Smoothing parameters 
Contains the parameters for the various types of smoothing described above. Parameters that are 
not used for the chosen smoothing type are disabled. 
 

 
 

5.10.5.5.1.2.1  
Determines the frequency where the smoothing starts. Below this frequency, nothing is plotted if 
the smoothing type is Octave - low frequency correction, Octave - no correction or Constant. 
If the smoothing type is Constant (low freq.) - Octave (high freq.), then constant bandwidth 
smoothing is performed below this “start frequency” and octave smoothing is performed above. 

5.10.5.5.1.2.2  
Determines how many points are to be computed and plotted within each division. The value may 
be typed or chosen from the list. If the smoothing type Octave - low frequency correction or 
Octave - no correction is selected, it gives the number of points within the octave fraction band 
specified (see Smooth over [octaves]). There are more points at high frequency when plotting on 
a logarithmic x-axis, but using this method we end up with a constant number of points over the 
whole frequency range. The software SMAART® uses the term Fixed Points Per Octave (FPPO). 
If the smoothing type Constant is selected, it gives the number of points within the constant band 
specified (see Smooth over [Hz]). 
If the number is larger than 1, it is the same as doing a sliding window smoothing because the 
windows will overlap. 

5.10.5.5.1.2.3  
Determines the smoothing bandwidth in octaves. The value may be typed or chosen from the list. 
This is used if the smoothing type is Octave - magnitude mean/interpolation, Octave - low 
frequency correction, Octave - no correction and for the octave smoothing part of Constant 
(low freq.) - Octave (high freq.). 

5.10.5.5.1.2.4  
Determines the constant smoothing bandwidth in Hertz. The value may be typed or chosen from 
the list. This is used if the smoothing type is Constant and for the constant bandwidth smoothing 
part of Constant (low freq.) - Octave (high freq.). 



 69

5.10.5.6 Guidelines 
 

 
 
If  is checked, guidelines are added to the active measurement. If it is unchecked, 
guidelines that are in the plot will be deleted. 

The type of guidelines is set from the  button and is described below. 

5.10.5.6.1 Guidelines settings 
Guidelines for displaying maximum gain, minimum gain, average gain, and up to four different 
average gain offsets are supported. 
 

 
 

5.10.5.6.2 Frequency range 
Sets the frequency range where the guidelines are to be displayed. The maximum guideline 
frequency is truncated if it is greater than the maximum frequency of the active plot.  
 

 
 

5.10.5.6.3 Display numerical values 
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Determines if numerical values are to be displayed on the guidelines and if they are to be 
transparent or have a yellow field around the value. 
 

 
 

5.10.5.6.4 Guideline 
 

5.10.5.6.5  Maximum Gain 
If checked, a horizontal line is drawn where the maximum of the active measurement magnitude 
frequency response curve is found within the frequency range given by the minimum and 
maximum frequency. 

5.10.5.6.6  Minimum Gain 
If checked, a horizontal line is drawn where the minimum of the active measurement magnitude 
frequency response is found within the frequency range given by the minimum and maximum 
frequency. 

5.10.5.6.7  Average Gain 
If checked, a horizontal line is drawn where the average of the active measurement magnitude 
frequency response is found within the frequency range given by the minimum and maximum 
frequency. 
Note that the average is computed from the plotted data (e.g. if the data are plotted in Decibels, 
the average will be computed from the Decibels data). 

5.10.5.6.8  Average gain offset. 
Four average gain offsets are available. 
If  is checked, a horizontal line will be drawn at the average value added 

an offset given by the  setting to the right of the check box. 

5.10.5.6.9 Guideline style 
 

 
 
The color of the guidelines is set by clicking at the color field . The line width is selected 

from the line width  list box. The line style is selected from the line style list box 
. Note that if the line width is greater than the smallest width, which is 1, the line 

style can only be Solid. 
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5.10.5.7 Compensation of Magnitude 
Compensation of the magnitude frequency response is possible. In the current version of 
WinMLS, one compensation is possible and it is called microphone compensation, but any other 
compensation may be done instead. Note that the Equalizer compensation is always disabled). 
 

 
 
In order to do the compensation  must be checked, then the file containing the 
compensation data must be selected from . 
If no such file exists, it can be made.  
An example of the format of the file is shown below. First a line containing the title, then a line 
with the title of each of the two columns, then the data columns, frequency column first followed 
by the magnitude frequency response data. 
 
"Transfer Function Mag - dB volts/volts (0.33 oct)" 
      "Hz"      "Data" 
  13.81928,   5.60038 
  18.42571,   5.60038 
  23.03213,   5.60038 
  32.24499,     5.60038 
…. 
 
The frequency separation has no restrictions, spline interpolation is used to get the needed 
frequencies. 

5.10.5.8 Shift/Normalization 
Makes it possible to shift or normalize the curve. 
 

 
 

 determines the type of shift/normalization and has the 
possibilities shown and explained below. 
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5.10.5.8.1 No Correction 
No shifting/normalization is performed. 

5.10.5.8.2 Normalize to 0 dB 
The curve is shifted so largest value is 0 dB. 

5.10.5.8.3 Fix to Frequency Value 
The curve is shifted so that at a specified frequency it is given a specified value. In the figure 
below, the specified frequency is 1000 Hz and at this frequency the curve is shifted so the value 
is 0 dB. 

 
Note that if the y-axis is set to Linear or Squared (energy), the shift will still be given in dB, so 
a shift of 0 dB will give the value 1. 

5.10.5.8.4 Shift 
The curve is shifted, and the amount of shifting in dB is given below. 
 

 
 
Note that if the y-axis is set to Linear or Squared (energy), the shift will still be given in dB, so 
a shift of 20 dB is the same as multiplying the Linear value by 10 and the Squared (energy) by 
100. 

5.10.6 Phase Frequency Response/Function... 
Displays the dialog box shown below. 
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Note that the phase is influenced by the sound card response. This may be removed by using the 
measurement system correction feature. Most sound cards have a delay of some samples that give 
a linear phase shift. It is possible to remove a pure delay by using the delay removal and 
subtraction features of this dialog box. 
The microphone will also influence the phase, to get an accurate phase, use a precision 
microphone with as high a bandwidth (higher than the measurement frequency range) and flat 
frequency response as possible. 

5.10.6.1 X-axis settings 
Selects the unit of the x-axis from one of the units displayed in the list shown below. 
 

 
 

5.10.6.2 Y-axis settings 
Selects the unit of the y-axis and the processing of the data from one of the choices displayed in 
the list shown below. 
 

 
 
If several curves are plotted and the y-axis setting is changed, the curves will be updated using 
the Plot->Refresh All procedure. 
 

5.10.6.3 General Frequency Domain Settings 
Click the button  to open the dialog box also accessed from 
Plot->General Frequency Domain Settings…. 
 

5.10.6.4 Phase type 
Selects the type of phase from the list below. 
 

 
 
Minimum and excess phase are viewed unwrapped and smoothing (explained below) is 
performed as the last computation if it is checked. 

5.10.6.4.1 Wrapped phase 
Restricts the phase range to –180 to +180 degrees, or –π to + π if radians is chosen as y-axis. The 
phase of a measurement will usually exceed this range, which results in jumps in the phase. 
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5.10.6.4.2 Unwrapped phase 
The unwrapped phase is not restricted to the wrapped range, and has no jumps. The unwrapped 
phase is computed from the wrapped phase by changing absolute jumps greater than 180 degrees 
to their 2*180 degrees complement. Note that if the phase curve is not smooth, the computation 
of unwrapped phase may give a wrong result. Because of this, it is not recommended to select 
unwrapped phase when displaying the phase of a room measurement. View the phase as wrapped 
instead. 

5.10.6.4.3 Minimum phase 
The minimum phase is computed by taking the Hilbert transform of the log magnitude frequency 
response. If a system is minimum phase this means that for a given frequency response, the input 
energy will be transferred to the output in the least amount of time. 

5.10.6.4.4 Excess phase 
The excess phase is the difference between the actual phase and the minimum phase, the phase 
shift in excess of the minimum phase shift.  
For excess phase measurements the phase influence of the microphone can usually be ignored 
since a microphone usually has a nearly minimum phase response. 

5.10.6.5 Smoothing 
If the check box shown below is checked, frequency domain smoothing is performed. 

 
 

The type of smoothing or integration is set from the  button and is described in the 
frequency response/spectrum plot type settings documentation. 

5.10.6.6 Remove delay in frequency range 
If  is checked, the delay is removed in the frequency range 
specified below the check box: 

 
If the settings above are used, the delay is removed in the range 50-10000 Hz. If Subtract delay 
as described below is used together with this option, the delay is first removed in the specified 
frequency range, then the delay is subtracted. 

5.10.6.7 Subtract delay 
If  is checked, the specified delay  is removed. If Subtract delay and 
Remove delay in frequency range (described above) is used together, the delay is first removed 
in the specified frequency range and finally the delay is subtracted. 

5.10.7 Group Delay 
Displays the dialog box shown below. 
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Group delay is the derivative of the phase with respect to frequency. The numerical derivation is 
performed by taking forward differences on left and right edges and taking cantered differences 
on interior points. 
 

5.10.7.1 X-axis settings 
Selects the unit of the x-axis from one of the units displayed in the list shown below. 
 

 
 

5.10.7.2 Y-axis settings 
Selects the unit of the y-axis and the processing of the data from one of the choices displayed in 
the list shown below. 
 

 
 
If Milliseconds – Logarithmic is selected, note that the logarithm of negative group delay values 
cannot be computed. If negative values exist, they are not plotted. 
If several curves are plotted and the y-axis setting is changed, the curves will be updated using 
the Plot->Refresh All procedure. 
 

5.10.7.3 General Frequency Domain Settings 
Click the button  to open the dialog box also accessed from 
Plot->General Frequency Domain Settings…. 
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5.10.7.4 Type 
Selects the type of phase from the list below 
 

 
 

5.10.7.4.1 No processing 
No processing of the group delay is performed. 

5.10.7.4.2 Minimum group delay 
The minimum group delay is computed as the derivative of the minimum phase frequency 
response. 

5.10.7.4.3 Excess group delay 
The excess group delay can be used to check time alignment in speaker system. It is computed as 
the derivative of the excess phase frequency response. 

5.10.7.5 Smoothing 
If the check box shown below is checked, frequency domain smoothing is performed. 

 
 

The type of smoothing or integration is set from the  button and is described 
in the frequency response/spectrum plot type settings documentation. 
 

5.10.8 Waterfall 
Displays the dialog box shown below. 
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5.10.8.1 X-axis settings 
Selects the unit of the x-axis from one of the units displayed in the list shown below. 
 

 
 

5.10.8.2 Y-axis settings 
Displays the unit of the y-axis. Only Decibels is supported. 
 

 
 

5.10.8.3 Z-axis settings 
Selects the unit of the z-axis from one of the units displayed in the list shown below. 
 

 
 
If several curves are plotted and the x-axis setting is changed e.g. from Time [samples] to Time 
[ms], the curves will be updated using the Plot->Refresh All procedure. 
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5.10.8.4 Waterfall layout 
Settings for determining some of the waterfall layout properties. 
 

 
 
Note that other layout settings such as zooming, rotation, elevation, offset are found in Plot-
>Chart Settings for Active Plot... under the 3D tab as shown below. 
 

 
 
In order to set the Rotation and Elevation,  must be unchecked. 

5.10.8.4.1 Mode 
Selects how the waterfall is viewed. 
 

 
 
Three choices are possible as shown below. 
 

 
 

5.10.8.4.1.1 Separate lines waterfall 
The waterfall plotted as separate lines. 
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The first advantage of this mode is that slices containing more than 2000 points can be plotted. 
This is not possible with the other two modes, so if more than 2000 points are tried to be plotted 
WinMLS automatically switches to this mode. 
The second advantage of this mode is that the  and  buttons on the Frequency Plots 
toolbar can be used to set the active slice for reading cursor values on the Status Bar (displayed 
at the bottom of the WinMLS area as shown in the figure above). 
 

5.10.8.4.1.2 Waterfall 
The waterfall is plotted using horizontal slices as shown in the figure below. The figure is made 
using File->Copy to Clipboard with Plot->White background on Copy/Print checked. 
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The mode waterfall has a limit of 2000 points in each slice. To get within this limit we 
recommend using smoothing. 

5.10.8.4.1.3 Surface 
The waterfall is plotted using lines from all the neighbouring data-points as shown in the figure 
below. The figure is made using File->Copy to Clipboard with Plot->White background on 
Copy/Print checked. 
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The mode surface has a limit of 2000 points in each slice. To get within this limit we recommend 
using smoothing. 

5.10.8.4.2 Perspective 
If  is checked, the backside of the waterfall plot is displayed. 

5.10.8.4.3 Display plotting of each slice 
If  is checked, each slice will be plotted right after it has been computed. 
Note that if it is checked, the plotting will take more time since if it is unchecked, all slices will 
be computed and then plotted in one operation. 

5.10.8.5 Energy-Time-Frequency (ETF) calculation settings 
Determines the special settings for the Energy-Time-Frequency mode. The special settings 
determine size of the data used for computing each slice (FFT size) and the window type applied 
on each of the slices. Note that no zero-padding is applied in computing Energy-Time-Frequency 
mode. The DC-component, if any, is not removed from each slice. 
 

 

5.10.8.5.1 Window type 
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Select the window type to be used for computing each of the slices. The choices are displayed 
below. 
 

 

5.10.8.5.2 FFT size 
Select the length of the data to be used for computing each of the slices using the Fourier 
transform. The number must be specified in samples, it can be typed or chosen from the list. The 
resulting length in milliseconds is also displayed. 
 

 

5.10.8.6 Mode 
Sets what type of waterfall plot is to be displayed. 
 

 
 
The choices are displayed and explained below. 
 

 

5.10.8.6.1 Energy-Time-Frequency (ETC) 
The Energy-Time-Frequency mode is the same as a spectrogram. The data used for computing 
the waterfall is the windowed measurement data. The time window on the data in General 
Frequency Domain Settings (the time window is found clicking the button 

) determines the part of the time data the ETF is 
calculated from. It also determines if the time data is to be windowed before computing the ETF.  
The windowed measurement data are divided into slices and the Fourier transform is computed 
for each slice. Special settings for this mode are found in the bottom right of this dialog box 
under Energy-Time-Frequency (ETF) calculation settings. The special settings determine the 
size of the data used for computing each slice (FFT size) and the window type applied on each of 
the slices. Note that no zero-padding is applied in computing Energy-Time-Frequency mode. The 
DC-component, if any, is not removed from each slice. 

5.10.8.6.2 Cumulative Spectral Decay (CSD) 
This mode is generated by computing the FFT of successively left-shifted versions of the 
windowed measurement data. The first slice is exactly the same as plotting the magnitude 
frequency response (Frequency Response/Spectrum plot type). This is because the FFT size 
and time window on the data is the same in General Frequency Domain Settings ( the time 

window is found clicking the button ). The next slices 
are computed by shifting this window (successive slices are shifted). The size of the shift is 
specified in FFT Shift. The number of slices is determined by Cycles (number of slices). The 
computation does not stop if the end of the measurement is reached. The DC-component is 
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removed from each slice. This is done by subtracting the DC-component of the last half of each 
slice. 

5.10.8.7 Cycles 
Determines the number of slices to be displayed. 

 
 
If Cumulative Spectral Decay (CSD) is selected as waterfall mode, the number of slices to be 
plotted is set here.  
If Energy-Time-Frequency (ETC) is selected as waterfall mode, the number of slices to be 

displayed is set by the time data window ( the button  in 
General Frequency Domain Settings). However, the number of slices is displayed, but is 
disabled. 

5.10.8.8 FFT shift 
Sets how many samples the slices are to be shifted before computing the magnitude frequency 
response on the measurement data. The number is also displayed in milliseconds as shown below.  
 

 
 

5.10.8.9 Floor 
Determines if a floor is to be used and where to set the floor. The purpose of the floor is to make 
the waterfall plot look nicer. The waterfall data having values lower than the floor limit, e.g. –60 
dB will be given this value. The floor is thus not the same as the y-axis minimum value. 
 

 
 
Three choices are available as shown below. 
 

 
 

5.10.8.9.1 No floor 
The waterfall is displayed without any floor.  

5.10.8.9.2 Use floor: 

Floor is used and the floor limit is determined using the dB setting .  

5.10.8.9.3 Auto 
Floor is used and the floor limit is determined automatically so that a percentage of the last part 
(20 percent) of the measurement data, given by , will be a part of the floor. 
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5.10.8.10 General Frequency Domain Settings 
Click the button  to open the dialog box also accessed from 
Plot->General Frequency Domain Settings…. 
Note that the settings that do not apply to the waterfall plot type are disabled. 
If complex division using the reference measurement is selected in Plot->General Frequency 
Domain Settings…, the resulting complex frequency response is inverse Fourier thus performing 
deconvolution. The deconvolved measurement is used for the waterfall computation. The window 
limits for the deconvolution are set by the window settings in the dialog box 

 and . But if 
Cumulative Spectral Decay is chosen as mode, the end window limit for the active measurement 
is set as the end of the measurement. 

5.10.8.11 Smoothing 
If the check box shown below is checked, frequency domain smoothing is performed on each 
slice. 

 
 

The type of smoothing or integration is set from the  button and is described 
in the Frequency response/Spectrum plot type settings documentation. 

5.10.8.12 Microphone correction 
If  is checked, the microphone compensation specified in 
the Frequency response/Spectrum settings (Plot->Plot Type Settings->Frequency 
Response/Spectrum…) is used for the waterfall plot also. 
Note that each frame is compensated for the microphone magnitude response. 

5.10.8.13 Reference 
If  is checked, the selected slice (in the figure below slice number 1) is used as 
reference. All slices will be viewed as differences to the reference slice. The reference slice will 
therefore be flat. 
 

 
 

5.10.8.14 Shift magnitude 
If  is checked, the magnitude is shifted in dB given by  
 

 
 

5.10.9 Room Ac. Parameters... 
Displays the dialog box shown below. 
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Room acoustics parameters, such as reverberation time and speech transmission index can be 
displayed. 
 

5.10.9.1 Type 
The types of acoustical parameters that may be computed and displayed are shown below.  
 

 

 
 
The parameters are explained in the Room Acoustics Users Guide. 

5.10.9.2 Plotting dependency on SNR 
If the check box shown below is checked, values of parameters that have a worse signal-to-noise 
ratio than the number specified below will not be displayed. 
 

 



 85

 

5.10.9.3 Calculation Options 
Clicking  opens the same dialog box as Room Acoustics-
>Calculation Options…. An explanation of the dialog box is given in the Room Acoustics Users 
Guide. 

5.10.9.4 Parameter Settings 
Clicking  opens the same dialog box as Room Acoustics-
>Parameter Settings…. An explanation of the dialog box is given in the Room Acoustics Users 
Guide. The settings in the dialog box that are not used for the plot type are disabled. 

5.10.9.5 Display Signal to Noise Ratio (SNR) 

 
 
The signal-to-noise ratio can be displayed in the plot as numbers in the plots as shown in the 
figure below. 
 

 
 
If  is checked, the SNR is added as marks above the plot points as 
shown in the figure below. If  is checked, the mark is transparent and 
not yellow.  

5.10.10 Levels 
Displays the dialog box shown below. 
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Note that this plot type may not be automatically refreshed for all kinds of changes in settings. 

5.10.10.1 Type of level 
The type of level is selected as shown below. 

 
 
The choices are displayed below.  
 

 
 
Note that in order to give for example the RMS of the sound card input signal, the input must be 
calibrated (Measurement->Hardware Calibration) and the measurement must not be in 
transfer function mode (e.g. a MLS measurement will consider the output at well). 

5.10.10.1.1 RMS  
The RMS value of the windowed measurement data is computed and displayed. The window 
settings are found in Time Data processing described below.  

5.10.10.1.2 Energy 
The RMS value of the windowed measurement data is computed and displayed. The window 
settings are found in Time Data processing described below.  

5.10.10.1.3 Linear sum (1/3 oct., scope mode) 
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The linear sum of 1/3-octave frequency bands is computed and displayed. The frequency range is 
determined in the 1/3 octave frequency rang settings. 
 
If the measured data is a transfer function (for example measured with MLS output signal), the 
data are corrected for the output signal so that the value for the input only is computed. This 
makes it possible to plot the input level and is why it is called scope mode. Two types of scope 
mode is supported, either Stationary signal (power) or Transient signal (energy). The scope 
mode settings are found in the lower right of the dialog box displayed after clicking 

 as shown in the figure below. 
 

 
 
If you are measuring impulse responses, Transient signal (energy) should be selected. 
 
 
Note that the correct absolute value is given only if the absolute level of the input is calibrated. In 
Measurement->Hardware Calibration...., click the Settings... button as shown below. 
 

 
 
Note also that if Microphone compensation is turned on in Plot->Plot Type Settings-
>Frequency Response/Spectrum... as shown below, 
 

 
 
then microphone compensation will also be used in when computing the frequency response for 
the Levels plot type. 

5.10.10.1.4 dBA 
The dBA-weighed sum of 1/3 octave frequency bands is computed and displayed. The 
computation is done as explained in the chapter above Linear sum (1/3 oct., scope mode). 
 

5.10.10.1.5 dBB 
The dBB-weighed sum of 1/3 octave frequency bands is computed and displayed. The 
computation is done as explained in the chapter above Linear sum (1/3 oct., scope mode). 
 

5.10.10.1.6 dBC 
The dBC-weighed sum of 1/3 octave frequency bands is computed and displayed. The 
computation is done as explained in the chapter above Linear sum (1/3 oct., scope mode). 
 

5.10.10.2 Time Data processing 
Determines how the measurement data is processed before computing RMS or Energy. 
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If  is checked, the measurement data will be processed according to 

the settings obtained by clicking . These settings are described 
under Plot->Plot Type Settings->Time Data…. 

Clicking  gives access to the time window settings determining 
what part of the measurement data to be used for the computation and the window applied to the 
measurement data. 

5.10.10.3 1/3 octave frequency range 
Determines the frequency range used for computing the Linear sum, dBA, dBB and dBC. 
 

 
 

Clicking  gives access to the settings for computing the octave 
bands. The frequency response data are integrated to obtain the energy in each band. 
 

5.11 General Frequency Domain Settings... 
Displays the dialog box shown below containing settings that apply to all frequency domain plot 
types. 
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5.11.1 Active measurement settings 
Settings for the active measurement in the upper plot, and the active measurement in the lower 
plot, if there are two plots. However, if Plot->Refresh All is selected, all the most recent curves 
for each measurement will be refreshed using the current settings. 
 

 

5.11.1.1  Time window settings  
Clicking this button opens the dialog box displayed below for setting the window size and type. 
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5.11.1.1.1 Measurement name 
Displays the measurement the window is applied to. 

 
 

5.11.1.1.2 Window type 
Selects the type of window to be used. 
 

 
 
The possible choices are shown in the figure below. Note that if an impulse response is to be 
windowed, it is not recommended to use a full window. 
 

 
 

5.11.1.1.3 Window size 
Sets the start and end of the window. The corresponding y-values are also shown. 
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The unit  determines the units of the window limits to be displayed in the 
dialog box. The following may be selected: 
 

 
 
The button  is used to set the end of the measurement to the end window limit. 
If  is checked, the X-max is set to the maximum value 
possible when a new measurement is performed or inserted. 

5.11.1.2  
Determines if the processing of the Time Data plot type is to be applied before computing the 
frequency response. Note that if this is not checked, the DC-component is automatically 
removed. 

5.11.1.3  
Opens the settings for the Time Data plot type shown below. 
 

 
 
Only the Time Data Processing settings are enabled since the other settings have no effect in the 
frequency domain. This dialog box is explained in the Time Data Settings documentation. 
 

5.11.2 Reference measurement 
Contains the settings for the reference measurement. 

5.11.2.1  Perform division 
If checked, the active measurement is divided complex with the reference measurement. If the 
sampling frequency is not the same for the active and the reference measurement, no division is 
performed and an error message is displayed. 
The zero-padding size has to be the same for the two measurements or else the division will not 
work, also the zero-padding size must be larger than the window size for both measurements to 
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prevent truncation. Therefore the longest Time Data Window of the two measurements is used as 
basis of finding the zero-pad size. 

5.11.2.2 Select reference measurement 
The reference measurement can be selected either from file or from the measurements available 
in memory. 
 

 
 
If you want to select the measurement from file, first check , then click the  button to 
open the browser. Note that the selected file is not added to the memory measurement file list. 
If the measurement is selected from memory as shown in the figure above, it is possible to update 
the reference measurement when a new measurement is performed by checking 

. Then if a new measurement is performed or inserted, the reference 
measurement is set to the current active measurement, for example if the active measurement is 
Meas. 3 and a 1-channel measurement is performed. The new active measurement will get the 
name Meas. 4, while the reference measurement will be updated to Meas. 3, since Meas. 3 was 
the active measurement before the measurement was performed. This feature is useful if you 
want to monitor the difference between the current and the previous measurement. For example 
if. 3 measurements are inserted in one operation (using File->Insert), the reference measurement 
will be updated 3 times. When the first measurement is plotted the current active measurement 
will be used as reference measurement- When the second measurement is plotted, the first 
measurement will be used as reference measurement. When the third measurement is plotted, the 
second measurement will be used as reference measurement. This is useful to monitor the 
difference between the measurements taken after one another. 
If a multi-channel measurement is performed and  is checked, channel 
2 of the performed or inserted measurement will be set as the reference measurement. E.g. if a 2-
channel measurement is performed and has the name Meas. 4, ch. 1, the reference measurement 
will be updated to Meas. 4, ch 2. If two or more measurements are inserted and 

 is checked 
This feature is useful if you want to monitor the difference between the two channels. 

5.11.2.3  
Clicking this button opens the dialog box for setting the window size and type for the reference 
measurement. This dialog box is similar to the button for setting the time window for the active 

measurement , and refer to this to get more information. 

5.11.3 Fourier transform size 
Selects the size of the Fourier transform for the active measurement and for the reference 
measurement if division is to be performed. The choices shown in the figure below will be 
discussed. 
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5.11.3.1  
This is the setting that gives the greatest speed since the Fourier transform is executed fastest 
when the length of the data is order of two, e.g. 1024 which is 2^10. If the windowed data does 
not have a order of two length, the data must be padded. E.g. if the length of the windowed data 
is 700 samples, the data are padded to obtain the length 1024. Usually zeros are used for this 
padding, therefore the name Zeropadding, but WinMLS does not pad zeros, instead it pads the 
last value of the windowed data. This is done to prevent from errors in case the data has a DC-
component. Note that because this method is applied, this setting should not be used with a 
Rectangular window on non-transient data (this is not recommended anyway). 

5.11.3.2  
Used to get a Fourier size equal to the exact size of the time data window. 

5.11.3.3  
Used to determine the exact size of the Fourier transform. Any number may be typed in the 

 box. But the numbers on the list gives the best computational speed since they are an 
order of two. 

 
 
An error message is given if the selected Fourier transform size is less than the size of the time 
data window and reference measurement time data window if division is to be performed. 

5.11.3.4  
Gives the frequency separation in Hertz, which is the distance between each point along the 
frequency axis. The frequency separation is equal to the Fourier transform size divided by the 
sampling frequency.  

5.11.4 Various 
Contains frequency domain various settings. 
 
If  is checked, the complex frequency response (after division, if 
division is selected) is inverted.  
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If  is checked, a vertical line is added to the frequency domain plot types 
as shown in the figure below. 
 

 
 
The “Frequency resolution line” will indicate graphically where the data should not be trusted. At 
the thick part of the line, the results should not at all be trusted. At the thin part of the line (which 
is twice the size of the thick line), the result is not certain. 
 
The color of the line is set in Plot->Default Curve Styles…. The line refers to the active 
measurement curve. 
 The scope mode setting  has no effect if the measurement is a 
transfer function (a MLS measurement). If the measurement is performed in scope mode, the 
choices shown in the figure below are available.  
 

 
 
The settings will affect the scaling of the frequency response. If Stationary signal (power) is 
selected and the plot type is Frequency Response/Spectrum, the power will be plotted. If the 
signal is a transient signal, this should not be selected since the level will depend on the window 
and zero-padding length. To prevent this, select Transient signal (energy). 

5.12 Default Curve Styles 
Displays the dialog box shown below. 
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In the upper left of the dialog box shown above, the styles for the time data window and the 
frequency resolution line is set. After that the styles for curve 1-16 is set. Curve 1 is the first 
curve plotted, and from the figure above we see that this has a red color. The next has a blue 
color and so on. 
 

 

5.12.1 Selecting curve color 
The color is selected by clicking on the color field . This will open the dialog box displayed 
below. (The language of the dialog box will set to the language of your operative system, this is 
why the text in the figure below is not in English). 
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Any color may now be selected by clicking somewhere in the field to the upper right of the 
dialog box displayed above. The color may also be selected by clicking in any of the  fields.  

5.12.2 Selecting curve width and style 
The curve width and style is set from . 
 
The choices are listed below.  
 

 
 
If the curve width is 1, which is the smallest possible, it is possible to plot the line with dashes 
and/or dots. Note that if the curve contains many data points, the dashes and dots may get so 
close in the plot that the line looks like it is Solid. But if the plot is saved in a picture format, this 
should not be the case. 
Note that if a curve width greater than 1 is selected, the plotting speed is much decreased. 

5.12.3 Display curve belonging to active measurement 
with different width 

The curve (most recent) belonging to the active measurement may be displayed with a width 
different from the other curves as shown below. If curves from several measurements are plotted, 
this is useful for finding the curve belonging to the active measurement. 
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If In neither plot is selected, this option is turned off. This is recommended, since if a curve 
width greater than 1 is used, the plotting speed is decreased. We recommend using Plot->Solo 
Active Measurement Curve instead. 

5.12.4 Wrap index 
This is useful if several curves are plotted and you want the colors to repeat. 
 

 
 
If the wrap index is e.g. set to 4 and 8 curves are plotted, the first 4 curves will get colors as 
selected from the Default Curve Styles list. But the 5th curve will get the same color as the first 
curve, the 6th curve will get the same color as the second curve, and so on. 

5.13 White background on copy/print 
If this is checked, when copying or printing the background is set to white. This may be useful 
for saving ink. 

5.14 Advanced Plot Settings… 
Displays the dialog box shown below. 
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5.14.1 Add text to Plot 
These settings determine if the plot title/footer/labels are to be updated and what is written after a 
measurement is plotted.  
 

 
 
If no check boxes are checked, the text is not changed. This is useful if you want to use your own 
text. The axis labels is set in Plot->Chart Settings for Active Plot... under the Axis tab, then 
under the Titles tab as shown in the figure below.  
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The title is set in Plot->Chart Settings for Active Plot... under the Titles tab. The footer is also 
set there by selecting  as shown below. 
 

 
 

5.14.1.1 Add to Title 
 

 
 
If  is checked, the title of the plot type is added to the plot title. The title added is 
normally the name of the plot type. E.g. the plot type Time Data gets “Time Data” as title. But 
the title may in some cases depend on the plot type settings. E.g. if the plot type is Room ac. 
Parameters and Reverberation Time (T30) is selected as parameter type, the title is 
“Reverberation Time (T30)”. 
 
If  is checked, the title of the measurement that is plotted is added to the plot 
title. Note that if the measurement is a .wmt-file or .wav-file not generated using WinMLS 2000, 
the measurement header will not contain any title. 
 
In order to actually view the title in the plot, the button  on the Standard Toolbar must be 
toggled. 

5.14.1.2 Add to Axis Titles 
 

 
 
If  is checked, axes units will be added according to the plot type settings and the plotted 
measurement data header. 
 
In order to actually view the title in the plot, the button  on the Standard Toolbar must be 
toggled. 



 100

5.14.1.3 Add to Footer 
 

 
 
If  is checked, the date of the plotted measurement is added. 
 
If  is checked, the name of the plotted measurement is added. 
If  is checked, the comment of the plotted measurement is added. 
If  is checked, the date when the last curve was plotted is added. 
 
Note that if the measurement is a .wmt-file or .wav-file not generated using WinMLS 2000, the 
measurement header will not contain any measurement date or comment. 
 
In order to actually view the title in the plot, the button  on the Standard Toolbar must be 
toggled. 

5.14.2 Various 
 

 
 
These settings apply to all plot types. 
 
If  is checked, a message box is displayed when 
closing the active window asking if the plot is to be saved.  

 
 

If Yes is chosen, the browser for saving the active plot as picture format is displayed (same as 
File->Save Active Plot As…). 
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If  is checked, the chart-file is saved when the 
post-processing setup is saved. Also when the temporary post-processing setup is saved, a 
temporary Chart-file is saved. A Chart-file contains all the settings in the Plot->Chart Settings 
for Active Plot... dialog box except for the settings of the plotted curves. 
Note that when it is unchecked, the curves in the plot are not deleted automatically. This means 
that when a new Group window is opened or when the software is run, the previous curves are 
not deleted. 
 
By checking  only every nth point will be plotted if the total length of the data is 
below as certain limit. This may be useful to make the plotting faster if a large file is to be 
plotted, e.g. a large .wav-file. 
 
By checking , it is possible to plot just a certain range of the data points. 
This may be useful for plotting a part of a large file. 
 
If  is checked, a transfer function measurement (a MLS 
measurement) is plotted in scope mode. This means that only the scaling of the input is 
considered, and not the output scaling. 

5.14.3 Curve Type and corresponding Chart-file 
 

 
 

5.14.3.1 Plot type 
The Curve type and Chart-file that corresponds to the selected Plot type is displayed. The user 
may select a new Curve type and Chart-file for the specific plot type. All the available plot 
types are present in the list. 

5.14.3.2 Curve type 
In the post-processing setups found when installing WinMLS, the default curve type for most plot 
types is set to FastLine as shown in the figure below. 
 

 
 
This means that the curves are drawn using the FastLine type. Please note that for the Room Ac. 
Parameters plot type, single-valued parameters are plotted with the plot type Bar independent of 
the curve type chosen here. 
Some of the available curve types are shown in the figure below. 
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Note that not all the curve types from the list will make sense for all plot types. Some useful 
items are: Line (it has more features than FastLine and is used for the RoomAc Parameters plot 
type), Bar, Area, Point, FastLine, Histogram (useful e.g. for plotting octave bands). 
 
Examples on how the curve types look like are found in Plot->Plot Layout…. From this dialog 
box the curve type in the current plot can be set. 
 

 
 
In the dialog box obtained from Plot->Plot Layout…, click on  shown in the figure above.  
A new dialog box will be displayed showing curve types to select from, some of which are shown 
in the figure below. 
 

 
 

By clicking on the small arrow in the lower left corner of Fast Line , the possibilities for 
this line type is displayed as shown in the figure below. 
 

 
 
For the curve type Line, the following choices are possible. 
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5.14.3.3 Chart-file 
A Chart-file (*.tee) contains all the settings in the Plot->Chart Settings for Active Plot... dialog 
box, except for the curve style settings.  
 

 
 
A new Chart-file may be selected from the list of available files. Note that the check box 

 must be unchecked, or it will not work properly 
in this version of WinMLS. 
Use the Save button to save the current Chart file, the Save As... button to save the current Chart 
file with a new name and the Delete button to delete the current Chart file. 

5.15 Post-Processing Setup... 
Post-processing setup defines as all the WinMLS settings, except for the measurement settings 
which are defined in the measurement setup found in the measurement menu.  
 

 
 
When WinMLS is exited, the setup filename is saved in registry and all the current settings are 
saved to a temporary setup. The next time WinMLS is run, this setup file is opened and the 
settings restored. 
To prevent the user from accidentally deleting or overwriting a setup file, the setup files may be 
write-protected. 
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5.15.1  Select setup 
Displays the selected post-processing setup. Setups are chosen from a list as shown in the figure 
below. 

 
 

5.15.2  Save setup 
Saves the current post-processing settings using the name in the Setups combo box. 

5.15.3  Save setup as 
Opens a dialog box for saving the current measurement settings. 
 

 
 

5.15.4  Delete setup 
Deletes the selected setup. 
The button is disabled when only one setup file is left to make sure not all setups are deleted. 

5.15.5  Load setup 
Loads the selected setup and then closes the Post-processing Setup… dialog box. Note that you 
will not be asked to save the previous settings. 

5.15.6  Close dialog 
Closes the dialog box. No new setup will be loaded. 

6 Room Acoustics 
See the Room Acoustics User’s Guide for documentation on this menu. 

7 Window 
This menu contains standard windows settings and a list of the measurement groups as shown 
below. 
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8 Help 
This menu contains Help, About and License information. About contains information about the 
software, e.g. version number. Help and License is not yet properly implemented. 
 

 
 

8.1 Help Topics... 
Not yet implemented. A help file will be made that can be downloaded from www.winmls.com. 

8.2 About WinMLS... 
Displays the About dialog box. 
 

 
 

If the  button is clicked the default Internet browser is opened and the homepage 
www.winmls.com is visited. 

http://www.winmls.com/
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8.3 License Options... 
Displays the dialog box for registering WinMLS as shown below. 
 

 
 

If the  button is clicked the default Internet browser is opened and the homepage 
www.winmls.com is visited. 

http://www.winmls.com/

	File
	New Group
	Insert in Active Group...
	Open Group...
	Browser: Open
	
	Measurement Files (*.wmb, *.wmt, *.wav, *.tim)
	WinMLS Binary Files (*.wmb)
	Measurement Text Files (*.wmt)
	Mono 16-bit WAV Files (*.wav)
	Measurement MLSSA files (*.tim)
	Plot Chart Files (*.tee)
	TAB-separated Data (*.txt)



	Close
	Save Active Measurement As...
	Browser for saving 1-channel measurement
	Browser for saving 2-channel Measurement

	Save Active Measurement
	As Measurement System Correction File
	With Filename <_ActiveMeas_>

	Save Data in Active Plot As...
	Save Active Plot As...
	Print Active Plot
	Print Preview Active Plot...
	Convert Measurement(s)...
	Exit

	Edit
	Copy to clipboard

	View
	Volume and Input Level(s) Dialog
	Measurement Selection Toolbar
	Measurement mode
	MLS
	MLS (scope)
	No excitation (scope)
	Trigged, no excitation (scope)
	Sinusoid (scope)
	Excitation from text file

	Delete unplotted measurements from memory
	Active measurement in upper plot
	Update both plots with the same measurement
	Measurement in lower plot or reference measurement
	Select “lower plot measurement” or “reference measurement” in combo box

	Measurement Settings Toolbar
	Number of Channels to Measure
	Sampling Frequency
	Sequence Order
	Length of Measured Data
	Number of Averages
	Total Meas. Time
	Number of sequences to pre-send
	Sequence Type
	Measurement System Correction
	Pre-emphasis
	De-emphasis
	Type of emphasis

	List of Curves Toolbar
	Deleting curve(s) from the plot
	Dragging curves to change the order
	Change curve type
	Display the curve
	Change the curve color

	Plot Toolbar
	Setting the lower x-axis limit
	Setting the upper x-axis limit
	Setting the lower y-axis limit
	Setting the upper y-axis limit
	Auto-scale the plot in all directions
	Display one or two plots in the window
	Selecting Plot Type in Active Plot
	Settings for the Active Plot

	Frequency Plots Toolbar
	Time Window Toolbar
	Setting the lower window limit
	Setting the upper window limit
	Window length
	Window x-axis unit
	Time data window type
	Display time window in time data plot type

	Setups Toolbar
	Select a new Measurement Setup
	Save Measurement Setup
	Save Post-processing Setup when Measurement Setup is saved
	Select a new Post-processing Setup
	Save Measurement Setup

	Standard Toolbar
	Status Bar
	Status bar during a measurement


	Measurement
	Start Measurement
	Cancel Measurement
	Test Current Levels
	Set Input Volume(s)
	Set Output Volume
	Measurement Information…
	Delete Unplotted Measurements
	Sound Card Settings
	Mixer and Synchronization Settings
	Synchronization Mode – Measurement of initial time delay, or not.
	Only if my sound card ‘is synched’
	No, detect start of measurement
	Yes, my sound card ‘is synched’
	Yes, with loop-back and end-check
	Yes, with loop-back, no end-check

	Loop-back settings

	Input Settings
	Output Settings
	Sound Card Specific Settings
	Advanced settings

	Hardware Calibration…
	Absolute Input Level Calibration
	General settings
	Total calibration
	Detailed Calibration

	Absolute output level calibration
	Relative calibration of mixer input
	Relative calibration of mixer output
	Measurement System Correction

	Measurement Settings Toolbar
	Sinusoid Settings…
	Advanced Settings
	Pre-D/A sound card output amplitude
	Emphasis offset
	Limits for automatic setting of volume

	Measurement Tasks…
	Tasks when performing a measurement
	Tasks when performing or inserting a new measurement from file

	Defaults for Saving...
	Default file-parameters
	Title and comments
	Autoname generator

	Measurement Setup...
	Select setup
	Save setup
	Save setup as
	Delete setup
	Load setup
	Close dialog


	Plot
	Add Curve(s)
	Delete All Curves
	Hold plotted curves
	Menu: Solo Active Measurement Curve
	Auto Refresh
	Active Measurement
	All Measurements
	Off

	Refresh Active
	Refresh All
	Select Plot Type(s)/Measurement(s)...
	Number of plots
	Plot Type in Primary (upper) Plot
	Active measurement in Primary (upper) Plot
	Plot Type in Secondary (lower) Plot
	Active measurement in Secondary (lower) Plot

	Chart Settings for Active Plot...
	Chart page
	Series page
	Data page
	Export tab
	Print tab

	Plot Type Settings
	Time Data…
	X-axis settings
	Y-axis settings
	Y-axis scaling
	Velocity of sound
	Show time window for active measurement
	Remove DC-component ( 0 Hz)
	Processing Type
	No processing
	Integral (Step response)
	Double integral
	Derivative
	Double derivative
	Cumulative energy

	Filtering
	Type of filtering
	LowPass/HighPass filter settings
	BandPass/BandStop filter settings


	Integrated Time Data (Step Response)...
	Energy-time Curve
	Frequency domain windowing
	Unwindowed
	Half-Hanning
	Blackman-Harris (full)
	Filtering using Hamming


	Schroeder Curve…
	Integration Options

	Frequency Response/Spectrum...
	X-axis settings
	Y-axis settings
	General Frequency Domain Settings
	Type
	Smoothing or Integration
	Smoothing Settings
	Smoothing type
	Octave – magnitude mean/interpolation
	Octave - low frequency correction
	Octave - no correction
	Constant
	Constant (low freq.) - Octave (high freq.)
	1-octave IEC Integrated (energy)
	1/3-octave IEC Integrated (energy)

	Smoothing parameters


	Guidelines
	Guidelines settings
	Frequency range
	Display numerical values
	Guideline
	Maximum Gain
	Minimum Gain
	Average Gain
	Average gain offset.
	Guideline style

	Compensation of Magnitude
	Shift/Normalization
	No Correction
	Normalize to 0 dB
	Fix to Frequency Value
	Shift


	Phase Frequency Response/Function...
	X-axis settings
	Y-axis settings
	General Frequency Domain Settings
	Phase type
	Wrapped phase
	Unwrapped phase
	Minimum phase
	Excess phase

	Smoothing
	Remove delay in frequency range
	Subtract delay

	Group Delay
	X-axis settings
	Y-axis settings
	General Frequency Domain Settings
	Type
	No processing
	Minimum group delay
	Excess group delay

	Smoothing

	Waterfall
	X-axis settings
	Y-axis settings
	Z-axis settings
	Waterfall layout
	Mode
	Separate lines waterfall
	Waterfall
	Surface

	Perspective
	Display plotting of each slice
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