
1 Installation 
The installation procedure is described below. 
 

1. Run the self-extracting .exe-file found on the CD or Internet. If the files on the CD is not zipped, run the file 
Setup.exe and skip the next point below. If you have downloaded the software from the Internet, please 
note that the documentation should be downloaded as well. 

2. A dialog box named WinZip Self-Extractor will appear, click the  button 

3. The installation will now begin. Click on the  button to go through the dialog boxes. The 
average user should accept the suggested settings, but please read the license agreement carefully. The 
suggested folder for installation is C:\winmls2000. Note that if you are going to run WinMLS from batch or 
from Matlab, it is strongly recommended that the installation folder name does not contain any spaces, 
therefore “Program Files” is not the suggested folder for installation. 

 
The software can be used for 20 days for evaluation purposes. This period may be extended, but the software has to 
be expired first. Note that the software is for evaluation purposes only. 
 
After installation WinMLS can be opened from an icon on the desktop or from the WinMLS program group. The 
documentation can also be found from the WinMLS program group. The software can be used for evaluation 
purposes in a period of 20 days. For extended use, please contact us at www.winmls.com. 

2 The available versions of WinMLS 2000 and features/limitations 
We have versions suited for the professional, university and amateurs. Currently the versions show below are 
available. The prices may change without notice, and the latest prices will be found at our homepage from where the 
software can be purchased. It is also possible to extend the evaluation version for a small fee. 

2.1 Professional versions of WinMLS 

2.1.1 WinMLS Pro Plus 192 kHz 
Same as Pro Plus but maximum sampling frequency is 192 kHz. Not available yet since no 192 kHz sound cards are 
available. 

2.1.2 WinMLS Pro with Room Acoustics 
Same as Pro Standard, except that full room acoustics according to ISO 3382 is included 
The “Internet” price is $ 1149. 

2.1.3 WinMLS Pro 
Maximum sampling frequency is 96 kHz. 
Maximum number of channels measured simultaneously: 2 channels 
Room acoustics: Plotting of reverberation times (broadband, low-mid-high, octave, 1/3-octave), EDT, Centre Time, 
but not the rest of the parameters of the ISO 3382 standard. 
16 and 24 bits playback/record supported. 
1 or 2 channel simultaneous measurement (up to 24 channels can be ordered). 
The “Internet” price is $ 999. 

2.1.4 WinMLS Lite 
Same as WinMLS Pro with the following limitations: 
Maximum number of channels measured simultaneously: 1 channel 
Maximum sampling frequency 48 kHz 
Resolution, record/playback: max 16 bits (24 bits is not supported). 
Maximum 1 channel can be measured simultaneously. 

http://www.winmls.com/


Limitation of 3 curves overlay (means that maximum three curves from different measurements can be plotted in the 
same plot)  
Limitation of 3 measurements in memory, the list must be deleted if more.  
Saving of setups with a new name is not possible, except for saving the setup with the current name using the Save 
button in Measurement->Measurement Setup.... (settings when closing WinMLS are restored when starting 
again). 
No guidelines available for frequency response plots. 
The plot types Step response, Schroeder curve, Energy-time-curve, Waterfall and Levels are not supported.  
No calibration of mixer and absolute level (making it difficult to measure SPL). 
No correction of measurement system. 
No emphasis of MLS signal (pre/post-filtering) of measurement signal. 
No calling from command line specifying parameters (e.g. running WinMLS from Matlab). 
The “Internet” price is $ 499.  

2.1.5 Multi-channel versions of WinMLS 
The multi-channel versions prices are given below: 
4 channel Pro version $ 1599 
8 channel Pro version $ 1899 
16 channel Pro version $ 2199 
24 channel Pro version $ 2399 
 
To upgrade with Room Ac. version costs $ 150, to Plus costs $ 500 
Contact us if you are interested in evaluating an multi-channel version. 

2.2 Versions for personal and classroom usage 
If you are a student or an audio amateur you can purchase WinMLS 2000 at a very low price. Note that the personal 
versions are not allowed for commercial usage or research. They have the same features as the professional versions, 
but it will be written in the plots, and in the measurement file comments that it is for non-commercial usage only  
 
The internet prices are as follows: 
Personal with Room Acoustics  $ 99 
Personal $ 79 
Personal Lite $ 39 

2.3 Special versions of WinMLS 
If you want a customized version of WinMLS, please contact us. 

3 Registering WinMLS 
If you have purchased WinMLS please send an e-mail to register the software. The e-mail must contain the version 
of WinMLS that you have purchased and the serial number. The serial number is found in the upper part of the 
Register dialog box that is shown when an unregistered version of WinMLS is started.  
 

 
 
When we receive the serial number, we will send an e-mail to you with the unlock code that will register the 
software when it is typed in the edit box shown in the figure below. 
 

 
 



Note that you must click the  button, then click . 
 

3.1 Very important: Backup your license 
When WinMLS 2000 is registered, a license backup file (.slx) will be is created in the folder where WinMLS 2000 is 
installed. Take a backup of this file on a floppy in case the hard drive should crash. 
In the case of a PC's Windows installation requiring a reinstall, it is possible that the license details for a registered 
piece of software may be lost. In this event, the license backup file (.slx) that is created on registration, is used to 
restore the license details.  
Should the license need restoring, place the backup .slx file in the same directory as WinMLS and run the program, 
the .slx file will be read and the registration details restored. Once restored, the file does not have to remain in the 
directory as the registration details are written back into the program.  

3.2 License Transfer 
Once you have registered, you can transfer the license from one machine to another without key disks or transfer 
files. This is done from the Register dialog box displayed when running WinMLS, and is only possible to do after 
the software is registered.  
To open the Register dialog box after you have registered, go to Help->License Options....  
On the license screen, the 'transfer the license to another pc' option will be enabled.  
 

 
 
Click on  and enter the serial number of the unregistered copy of the software on 
the target pc. 
Once the target serial number has been entered click on the 'Transfer' button, a message box will popup confirming 
the transfer (this is a good chance to double check the serial number is correct). WinMLS will then invalidate the 
license on the first machine (i.e. preventing the software from running), and generate the unlock code for the target 
pc.  
By entering the unlock code on the Register License screen of the evaluation version on the target pc, the license 
transfer process will be complete and the software fully functional.  
For example, this option allows your version of WinMLS to be used on both a laptop and desktop PC. This would be 
particularly useful for customers who are not based in any one location or office, the unlock code can simply be 
quoted over the phone or via email. This way the license can be transferred back and forth as necessary. 

4 Documentation 
Before starting using WinMLS we strongly recommend following the step-by-step procedure in the chapter The first 
measurements in the WinMLS 2000 User’s Guide. 
In the current version no context sensitive help is available. However, a file containing the documentation of the 
menus and dialog boxes is found in the WinMLS program group. There we also recommend the list of supported 
sound cards. Issues regarding the various types of sound cards are described in this document. In the Measurements 
sub-folder you will find some measurement examples (e.g. studios, large rooms, sound cards, loudspeaker and violin 
measurements). 
Most important aspects should be covered in the Frequently Asked Questions-file. A very frequently asked 
question taken from this file is shown: 

4.1 How to zoom the plot using the mouse? 
If the mouse zooming is turned on (see below) this can be done. To zoom in, drag a rectangle from upper left to 
lower right. Note that this is the only way to zoom in if using the mouse. If you drag a rectangle any other way this 
does zooming out.  



Zooming can also be done very efficiently by the Plot Toolbar. Note that in certain cases, if the plot is to be zoomed 
out, the mouse zooming will not zoom enough. Then click on the Autoscale all button on the Plot Toolbar (View-
>Plot Toolbar). 

5 Known Issues 

5.1.1 Trouble with protection  
In very few cases there seems to be a problem with the protection software that causes the 20 days evaluation period 
to end before it is supposed to. If this happens, give us the serial number and we will extend the evaluation period for 
you. 

5.1.2 IBM TP 600X laptop running Windows 2000 
This laptop had software that overrides the windows mixer. Therefore the input level could not be adjusted. Please 
contact us if you have similar problems. 

5.1.3 Double-clicking in the plot will not open the plot type settings dialog 
This feature had to be disabled because it has been reported to be unstable in some cases. This is to be fixed in a 
future version. 
The plot type settings can still easily be accessed typing F5, or from the rightmost button on the Plot Toolbar. 

5.1.4 Help-file or context-sensitive help is not yet integrated in the software 
A pfd-file containing the documentation of all menu items and dialog boxes are available. See also the other files 
found in the WinMLS program group. 
You may contact us, and we will send you the help file when it is ready. 

5.1.5 Opening/inserting .txt-files with first column x-axis and second column y-axis is 
not yet supported 

Support for reading .mat-files (Matlab format) is not yet supported either. 

5.1.5.1 This applies only when importing text-data is implemented 
After opening txt-file using File->Open, the plot type “Imported Data…” is selected. This will become the active 
plot type, and must manually be changed to another plot type (e.g. frequency response) if a measurement is to be 
plotted. 

5.1.6 The plot background colors in look strange 
The gradient colors used as background in WinMLS may look strange. This is because your PC supports only 16 
colors. It can easily be fixed by selecting more than 16 colors. From the Start button select Settings, then Control 
Panel. Select Display, in the Display dialog box select the Settings tab. Select at least 256 colors. Another way of 
solving this is to use the post-processing setup called “NoBackgroundColors” or “BlackNWhite”. This can be done 
e.g. in Save/Load Post-proc Setup... on the Plot menu. 

5.1.7 The room acoustics IACC computation has not yet been carefully tested.  

5.1.8 If nothing happens on Room Acoustics->Calculate is, please try again. 
This problem that has been reported is probably because the system is low on memory. 

5.1.9 Placing several toolbars together at the very top or bottom of WinMLS may not 
give same positioning on restart. 

The toolbars may not be positioned exactly the same way when the post-processing setup is loaded. 



5.1.10 When using Digigram VX222 or VXpocket V2 sound cards, measuring with 24 
bits may give error message or problems with synchronization 

If installing the latest driver (www.digigram.com) does not fix this problem, please try 16 bits input/output in 
Measurement->Sound Card Settings.... 

5.1.11 If the system is low on memory, e.g. after opening several programs, WinMLS 
may become unstable and crash. 

5.1.12 It has been reported that WinMLS causes an abnormal termination when shutting 
down the PC if the operative system Windows Millennium is used. 

5.1.13 Loading chart files from Plot->Advanced Settings... works only if Save current 
chart file when saving post-processing setup is checked. 

Documentation must be updated as well. 

5.1.14 Setups toolbar 
The post-processing save icon turns red if the post-processing setup is changed. It also turns red if settings in the 
chart files (all the settings in Plot->Chart Settings for Active Plot) are changed, but there are cases where this will not 
happen, e.g. on File->New… and when loading WinMLS. 

5.1.15 Exiting WinMLS when it is not maximized 
If WinMLS is exited while it is not maximized, the toolbars will not be situated in the same positions when it is 
opened again. If you have problems with this, try to load a plot setup to restore old toolbar settings. 

5.1.16 It is not possible to open measurement files from outside WinMLS (e.g. file 
explorer) 

This is because of the batch functionality currently overrides the drag-and-drop functionality. 

5.1.17 For logarithmic plots, the minor gridlines are only present if the plot range is more 
than an entire decade (e.g. 1000-10000).  

An example is: In a plot the frequency starts at 20 Hz but the minor tick mark and corresponding grid line does not 
display until 100 Hz. Start from 10 Hz instead, and the minor gridlines will be displayed. 
Note that an extra gridline is added at 20 kHz. 

5.1.18 Measurement->Set Automatic Input Level(s) is slow 
It works for one and two channels input, but it is slow. The user can increase the speed by manually moving the 
volume sliders. We plan on increase the speed if the mixer correction is used (the mixer levels are known). 
The same applies for setting the output level automatically. 

5.1.19 Plot settings toolbar supports up to 4 decimals. 
If you are plotting signals with very small levels (~0.0001), the plot settings toolbar will not work very well. 

5.1.20 Auto-scaling of y-axis maximum value 
Auto-scaling y-axis maximum value is set to zero if the value is less than zero. 
 
If you are plotting more than one curve and the plot type is time data, and the time-data-window is displayed, then 
auto-zooming will not work when removing a curve that has larger y-values than the other curves. 
 
To activate the auto-zooming, click twice on the Auto-scale All button on the Plot settings toolbar. 
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5.1.21 If there are problems measuring with WinMLS, try to reload the measurement 
setup, or load a new setup. 

If WinMLS crashes the temporary setup can be corrupt, to load the setup will solve this problem. Please report if you 
have problems with this, and send us the corrupted setup file if possible. 

5.1.22 Special case: If two plots are displayed showing the same plot type. 
If two plots are displayed showing the same plot type (e.g. frequency response in both upper and lower plot), New… 
will only restore the settings for only one of these. This is because a single file is used for saving the plot-type *.tee-
files. 

5.1.23 When moving toolbars or turning them on/off, the post processing setup file 
toolbar does not give indication that the setup is changed (red icon). 

5.1.24 Opening/inserting 24 bits .wav-files is not possible in this version 
It is recommended to use the .wmb-format for saving 24 bits files. 

5.1.25 Refresh All will not update the colors correctly if there exists several curves of the 
same measurement. 

5.1.26 Minor issues 

5.1.26.1 If several curves are in the plot, it may happen that an error will occur 
in plotting Guidelines. 

5.1.26.2 In Measurement Settings toolbar 
When the number of pre-sequences is changed, the total measurement time readout is not updated. 

5.1.26.3 Disabling emphasis and system correction buttons  
They will not be disabled when WinMLS is started if the temporary setup is different than the master setup. 

5.1.26.4 Real part and imaginary part of frequency response/spectrum 
It is not available yet, but is planned to be included. 

6 Changes and fixes in the last beta versions 

6.1 Latest fixes - (fixed after Release 3.00 Build003) 

6.1.1 Laptop built-in chips just recently tested 
The laptops IBM x20 (Crystal Soundfusion) and Dell Inspiron 3800 (Ess Media 3) were tested and were found to 
work. 

6.1.2 Running WinMLS2000 on MAC 
WinMLS2000 works on PowerMAC with the limitations shown below.  
 
1. The software Virtual PC ver. 2.1.2 or higher must be installed. 
2. You need to contact us to get a special version of WinMLS. If there is a problem, the ocx-files must be installed 
manually using the regsvr32 command as explained below. 
From the Start menu, go to Run... In the prompt type: 



regsvr32 d:\windows\system32\msflxgrd.ocx 
regsvr32 d:\windows\system32\teechart5.ocx 
On some systems the files are not placed in 'd:\windows\system' instead of 'd:\windows\system32'. 
 
3. Measurements cannot be performed since Virtual PC ver. 2.1.2 only supports 8 bits. It is possible that the latest 
version of 'Virtual PC' will support 16 bits. We did not yet test this. 

6.1.3 Measurements of initial time delay 
New modes for measuring initial time delay have been added. See the Measurement->Sound Card Settings... 
documentation for more information. 

6.1.4 Scaling of Time-data Plot-types 
When changing x-axis in the time-data plot types, the axis limits are changed properly. When y-axis is changed, 
auto-zooming is automatically turned on to make sure the data are appropriately viewed. 

6.1.5 Added double-clicking from Explorer 
Double-clicking on WinMLS measurement files causes the file to be opened in WinMLS in a new window.  
The following file types are associated automatically to WinMLS during install: 
.wmb, .wmt and .tim 
If you want to associate .wav-files to WinMLS, this can be done manually. 
Fixed setting correct Group number when opening measurement files using double-clicking. 
For the Room Ac. Parameters plot type, single-valued parameters are plotted with the plot type Bar independent of 
the curve type chosen in Plot->Advanced Plot Settings....  

6.1.6 Plotting waterfall 
If  “Display plotting of each slice” was turned on, Waterfall plot did not work properly. For “Separate lines” mode, 
the z-axis label was not correct. For Waterfall/Surface modes it gave an error message. 
All this was because of the extra 20 kHz gridline we are adding. Now a check is added to see if waterfall is being 
plotted. Fixed 26122001. 

6.1.7 Switching to a different curve type 
The “Undefined plot error”-message box has been changed to: “The plotting was not successful. This will be 
displayed probably because a curve was tried to be refreshed using a new curve type. 'Plot->Refresh All' or 'Plot-
>Add curve(s)' should solve this problem.” 

6.1.8 Setup files 
Updated setup-file settings: 
Changed room ac. calculation mode to “Truncation and Compensation” 
Changed pre-emphasis offset from –10 to 10. 
Waterfall: 
Plotting waterfall in separate lines mode, the z-axis is switched. 
Use 1/24 octave smoothing and layout mode “Waterfall” 
Turned off Inverted in Waterfall Depth axis, else the axis will be inverted when plotting in “Separate Lines” layout 
mode. 
Plot waterfall in the “Display plotting of each slice” mode.  

6.1.9 Other Issues 
When plotting spectrum in stationary scope mode, do not compensate for zero-padding, it gives wrong result! For 
energy it makes no difference, so use the actual size for scaling instead of the zero-padding size. 
 
Improved format Bar curve type. 
 



When plotting STI/RASTI or Levels and selecting a measurement from the list, the measurement number will now 
be updated correctly. 
 
Scaling units were removed in Y-axis label for plot-types Phase and Group Delay. 
 
Improved format of Bar curve type. The x-axis position is not moved. 
 
Fixed title name when plotting spectrum. 
 
Transfer function measurements can now be scaled and plotted correctly in Scope mode. 
 
Changed name of microphone compensation file. 
 
Frequency Response/Spectrum settings: removed (energy) from Squared since it can be power as well. 
 
Saving measurements done with 24-bits can now be saved as .wav-file (16 bits). 
 
Reading some types of .wav-files was not correct. 16 samples was added in the start of the .wav-file. Now fixed. 

6.1.10 Room Acoustics  
If Broadband is selected, in the ‘Calculate’ grid the frequency was previously set to 0, now “All” is written instead. 
When writing text-file, the frequency is still set to 0. 
When 1/3-octave band RT-time is selected as plot-type, microphone type and bandwidth is now disabled in 
Calculation Options. 
When Room Acoustics->Calculation Options is changed, room ac. parameters is refreshed in the plot. 
Plotting room ac. parameters that gave a warning could cause a crash before, e.g. IACC was tried to be computed for 
one microphone only. This is now fixed. 

6.1.11 Levels plot type 
Added dBB and dBC, updated the documentation.  
 
For octave band computed values: 
Increased frequency range down to 10 Hz for computation of frequency response 1/3-octave bands. If the measured 
data is a transfer function (for example measured with MLS output signal), the data are corrected for the output 
signal so that the value for the input only is computed. 
 
Fixed computing of frequency response that previously could cause crash in Levels plot type. 

6.2 Fixed after Release 3.00 Build002 

6.2.1 Saving of plotted data to text-file 
If the plot contains only series that has one value (dBA, RMS, STI are examples of such), the data will be plotted as 
a row with the same header as described above. 

6.2.2 Scope modes 
Improved title. The plot title now displays if it is Power Spectrum Magnitude or Energy Spectrum Magnitude 

6.2.3 Time data filtering in frequency domain 
The time data can be filtered before computing the frequency domain. Now the type of filter is indicated in the 
legend for the frequency domain plot types, not only the time domain plot types. 

6.2.4 Minor issues 
Disabling of post/pre-emphasis in Measurement Settings toolbar should now be correct. 



 
When Help->License Options... is exited and WinMLS is not licensed the notification message box is taken out. 
 
Refreshing of Levels plot is done after time window is changed. 
 
If changing division file in the Measurement Selection Toolbar, the upper plot was not auto-refreshed. Fixed 
26112001. 
 
Typing error in Sound card specific settings 
Typing error, Triggered 
 
In case WinMLS is displaying two plots, the Frequency Plots Toolbar buttons LogX, smoothing, invert, guidelines 
and division only refreshes the active plot. 
Changed this so that LogX still only refreshes the active plot, while the other refreshes both plots if auto-refresh is 
selected. Fixed 26112001. 
 
error message “Increase the fft size, 2 samples, ...” was improved. 
 
Waterfall plot, Energy time frequency specific settings are now disabled when the waterfall mode is Cumulative 
spectral decay. 
 
In the Frequency Response/Spectrum Settings dialog box, the whole name of the microphone compensation files are 
now displayed if the list box content is displayed. Fixed 26112001. 
 
Copy button new tooltip: Copy the active plot. Fixed 26112001. 
Solo button got tooltip. Fixed 26112001. 
 
Loading of post-proc setup should no longer cause crash.  

6.2.5 Refresh All and Solo 
If Plot->Solo Active Measurement Curve is turned on when inserting measurements, all curves are not displayed 
when it is turned off again. This was solved 27112001 by turning Solo off before inserting and On after inserting. 
If Plot->Refresh All and solo is on, all the measurements are viewed. This was solved by turning Solo off before 
inserting and On after inserting. 

6.2.6 Issues regarding the documentation 

6.2.6.1 All files are updated 
The FAQ is greatly improved, the text is corrected. 

6.2.6.2 Menus and Dialog Boxes 
Post-processing setup added in the menus and dialog boxes explanation. 
It has now been added. 

6.2.6.3 Example files 
Some sound card files were removed from the example files. 
The example file Studio1.wmb was updated, it now has correct header information (.wmb-file). 
Improved filename, comment and title for violin measurements. 

6.2.6.4 Post-processing setup files 
Energy-time-curve plot type now has “fast” checked. 



6.3 Changes and fixes since version 3.26 Beta 

6.3.1 Minor issues 

6.3.1.1 When sync-signal was not found, WinMLS sometimes crashed. Now fixed. 

6.3.1.2 After plotting waterfall, the mouse wheel was turned off when plotting 
another plot. Now fixed. 

6.3.1.3 Multi-channel comments dialog box is corrected. 

6.3.1.4 Moving mixer levels does now change the measurement setup icon to red. 

6.3.1.5 After closing the dialog box Help->License Options..., a dialog box is 
displayed telling what version WinMLS is registered as  

(if it is registered and not evaluation). 

6.3.1.6 Pre/De-emphasis buttons 
Pre and de-emphasis can now be used independently from the Measurement settings toolbar. 

6.3.1.7 When clicking Solo-button, the post-processing setup icon now gets red. 

6.3.1.8 When running from batch/Matlab 
Is now able to turn off automatic save if measuring in RunAndExit mode. 

6.3.1.9 Changing plot type from Plot toolbar 
Previously it could result in a crash, this is now fixed. 
 

6.3.1.10 Updated measurement setup files 
Added pre and de-emphasis to the measurement setups. 
Normalize .wav-files when saving is default. 
Set reasonable defaults for multi-channel measurements. 
“Solo active curve” is turned off as default. 

6.3.2 WinMLS has been carefully tested on Windows XP with good results 

6.3.3 There is a small memory leakage when WinMLS is exited. 
The leakage is now 0,6 KB for each time WinMLS is closed, which is very little 

6.3.4 The software previously could crash before when loading measurement setup 
from the toolbar or when selecting a new plot type from the Plot toolbar. 

This is now fixed. 



6.3.5 New protection method has been added. 

6.3.6 Running WinMLS from Batch or Matlab has been tested and with the new 
protection method and should now work. 

The new software protection fixed this problem. 

6.3.7 The mouse pointer now displays a small hour glass together with a pointer when 
WinMLS is measuring 

This is the case during an actual measurement, setting/testing of levels and calibration. 

6.3.8 When waterfall mode “Separate lines waterfall” is chosen, the depth axis (z-axis) 
is always set to automatic scaling 

If the depth axis is not automatically scaled, the scaling will be wrong. Because of this the mouse wheel scrolling 
was also turned off. 

6.3.9 Room acoustics 

6.3.9.1 Standard room acoustics setup now contains only 1 plot 

6.3.9.2 Improved plotting of STI and RASTI 
The x-axis is set to linear and use increasing numbers if STI/RASTI in case several measurements are plotted. STI 
and RASTI is now plotted as Bar curve type. When bar is plotted, mark is always displayed now. 
Previously when STI was not computed due to bad SNR, crash was the result. Now fixed. 
Note that STI and RASTI are plotted even if the SNR should be lower than the limit. 

6.3.9.3 ISO 3382 Strength calibration  
We have directional data for the B&K Omni-power speaker. These data makes the G-calibration very simple. Please 
contact us about this. 

6.4 Changes and fixes since version 3.25 Beta 

6.4.1 Time data plot type updates 

6.4.1.1 Filtering can be performed before Cumulative Energy is computed 

6.4.1.2 When LP/HP filtering is performed, cutoff frequency is now written to 
legend. 

6.4.2 Post-processing setup 

6.4.2.1 Upgraded default curve colors 
If you want to change the colors, this can be done from Plot->Default Curve Styles.... 

6.4.2.2 Saving problems 
Saving measurement setup and post-proc setup now saves the correct link to the post-processing file. In the previous 
version it had to be saved twice in order to work. 



6.4.3 Frequency domain plot types 
Crash could occur in previous version when complex division is performed when the file was of old .wmb-format. 
Fixed this, and fixed also crash when clicking on windowing button on Frequency Plots toolbar. 

6.4.4 Minor bug fixes and updates 

6.4.4.1 If a new window is displayed with two plots viewed, the upper plot is set 
as active. 

6.4.4.2 Filter order for HP/LP-filtering is now remembered in filtering dialog box. 

6.4.4.3 The default folder for saving plot is probably now updated correctly. 

6.4.4.4 The window title is now updated after a measurement is performed or 
inserted. 

6.4.4.5 When a chart file is opened the legend button is now not disabled. The 
solo and auto buttons are disabled. 

6.4.5 Room Acoustics 

6.4.5.1 Updated error message if Schroeder plot cannot be computed 

6.4.5.2 Warning, but no parameters 
If the lateral parameter was selected for a single microphone measurement and the acoustics parameters were to be 
computed, a warning was displayed, but no result. Now the result is displayed for the parameters that can be 
computed in addition to the warning. 

6.5 Changes and fixes since version 3.24 Beta 

6.5.1 Added Documentation 
Added WinMLS 2000 User’s Guide. 
For questions relating to the menus and dialog boxes, please read the new Menus and Dialog boxes Documentation 
file. 
Updated FAQ. 

6.5.2 Setup files changed 
The previous setup files need to be updated with the changes below in order to work. 
 
Added to measurement setup files: 
[Post_SavePlotAsText] 0 
 
Added to postproc. setup files: 
[RoomAcPlotType_bDisplaySNR] 1 
[RoomAcPlotType_nPlotType] 1 
[RoomAcPlotType_bDisplaySNRTransparent] 0 
[RoomAcPlotType_dDontPlotSNRLimit] 15 
[RoomAcPlotType_bDontPlot] 1 
 



Changes in Chart files: 
Footer font changed from italic red to normal black. 
Mouse zooming must is now displayed with a rectangle for all plot types. 

6.5.3 Fixed bug in scaling if transducer was set as active on input. 

6.5.4 Room ac. parameters and Levels plot types are now auto-refreshed properly. 
However, Levels may not be auto-refreshed in all cases. 
Added also labels and title to the Levels plot type. 

6.5.5 Fixed bug with plotting of room acoustics dependent on integration option. 

6.5.6 Added saving of measurement system correction file and “dump” of active 
measurement on File menu. 

6.5.7 Fixed bug with room acoustics MTF noise compensation. 

6.5.8 In rare cases typing numbers in some combo boxes would not work 
Is now fixed. 

6.5.9 Waterfall plotting 
The magnitude in dB should now be correct. 
 
Auto-floor percentage setting is now properly updated. 
 
Time data processing may optionally be used when plotting waterfall also. 
 
The z-axis labels are now correct. They were set to inverted in the previous chart files. Minor gridlines were also 
turned on in the chart file. 
 
Unused waterfall floor settings were disabled. 
FFT-size in Plot->General Frequency Domain Settings is enabled if waterfall is CSD. 

6.5.10 Moved automatic saving of plot data from Plot->Options to Plot->Measurement 
Tasks. 

Added Save data in active plot check box. This options may be used for batch-processing. 

6.5.11 Added computation of room ac. parameters to text-file for unsaved 
measurements. 

The Calculate Room acoustics parameters check box in Measurement->Measurement Tasks 
determines if room acoustics parameters are to be displayed and/or saved after a measurement is 
performed or inserted. The setting telling if it is displayed or saved to file or both is found in the bottom of 
the Room Acoustics->Calculation Options… dialog box.  
The Send to Text file option is useful for calculating the room acoustics parameters of several files and 
saving the results in one operation. First check this option, then make sure Send to Text-file is checked in 
Room Acoustics->Calculation Options…. In File->Insert, select all the files that you want to process. If 
the measurement has a filename, it is saved using the measurement filename(s) but with the extension 
.txt. The filename of the text file depends on if the measurement has a file name or not. If the 
measurement does not have a filename, it is saved under the default folder given in Measurement-
>Defaults for Saving. The filename is “RoomAcMeasFromMem<Measurement number>.txt”. 



6.5.12 Added Time Data plot type processing to frequency domain plot types 
The processing of the time data (e.g. filtering and integration) may now be applied in frequency domain also. A 
check box Use Time Data plot type processing before Fourier transform was added in Plot->General 
Frequency Domain Settings…. Other minor changes has also been done to the layout of this dialog box. The 
Remove DC check box has been removed from this dialog box, it is now set from the button Time Data plot type 
settings…. 

6.5.13 Fixed bug 
Sometimes when opening one dialog box on top of another, the focus was lost which could give crash. This is now 
fixed. 

6.5.14 “Levels” plot type added,  
Changed names from “User defined”. 

6.5.15 If 2 impulse responses files are used for Room Ac. Calculations, both filenames is 
used to generate the parameters filename if saving to text-file in enabled. 

6.5.16 Added new post-processing Setup file 
Added post-processing setup BlackNWhite, where there are no colors, all curves are plotted in black. 

6.5.17 Smoothing 
Changed the order of frequency domain smoothing options. Added integration options in addition to smoothing to 
magnitude: 
1-octave IEC Integrated 
1/3-octave IEC Integrated 
This allows plotting of energy in octave and 1/3-octave bands. 

6.5.18 Normalize wav-file 
Normalize .wav-file option is added to Measurement->Defaults For Saving and File->Convert Measurement(s) in 
convert measurements. Note that normalization will change the scaling, and if normalization is not used when saving 
as .wav, the quantization noise is usually large. Therefore, the .wmb format is recommended if the scaling is 
important. 

6.5.19 Added a new menu item on the File menu. Now saving as picture and data is two 
separate menus. 

6.5.20 Fixed bug: Clicking cancel on exiting a plot window when asking if a 
measurement is to be saved causes window to close! 

6.5.21 Zoom Toolbar no longer disabled when opening .tee-file 

6.5.22 Measurement system compensation folder has been renamed to measurement 
system correction 

Measurement system correction files can is no longer case sensitive. 



6.5.23 Error message when going from negative linear x-axis to log x-axis is no longer 
given. 

6.5.24 Filtering 
Time domain plot types, filtering info written in legend has been improved. 
Disabling/Enabling of filtering dialog box. 
Refreshing of filtering improved. 

6.5.25 Fixed bug in Energy-Time-Curve plot giving crash if filtering of multiple bands was 
used. 

6.5.26 Minor things 
When loading a new post-processing setup, the window size is set to the value in the setup file. The "Set end as 
maximum limit on new measurement" is now considered 
Fixed crash when performing smoothing with a very short time-window. 
Freq resolution in dialog is now updated when changes are made in the dialog box. 
Sinusoid freq. is no longer decreased after each measurement. 
The wrong measurement was previously opened when opening time data win. from dialog, but not from toolbar. 
That is because the measurement was not set yet.  
The channel number in Measurement->Information after a measurement is saved is now correct. 
The refresh button on the standard toolbar now does Plot->Refresh All. Before it did Plot->Refresh Active. Plot-
>Refresh All now plots the active measurement if no curves are plotted, and it no longer takes the wrong 
measurement if Waterfall is plotted. Refresh All were disabled like Refresh Active when no measurements exist. 
When saving plot data to text-file, the curve titles are specified in the header line. 
Replaced a check box with a combo box (loop-back input channel) in Measurement->Sound Card Settings. 
Changed name in Plot menu. New name: General Frequency Domain Settings 
Used 3 decimals on wavelength (mm resolution). 
When saving mixer file for input, the name of the line (e.g. mic or line-in) is added to the filename. 

6.6 Changes and problems fixed since version 3.23 Beta 

6.6.1 Opening/inserting .tee-files no longer causes the curves in the tee-file to be 
deleted. 

6.6.2 Bug fixed in changing between measurement groups. 

6.6.3 Room acoustics strength calibration is improved 

6.6.4 Room acoustics parameters can be saved directly to text-file. 

6.6.5 Added new curve styles, e.g. histogram. 

6.6.6 If line is plotted for Room Ac. Parameters, then a point is plotted in the data 
values. 

6.6.7 Several layout changes and small bug fixes have been made and  

6.6.8 Minor things 
Measurement system correction files can is no longer case sensitive. 



Perform filtering is turned on after exiting filter options with OK. 
Accessing Help file gives error message. 
Warning and error message handling improved for room acoustics ( more than one error code can be displayed). 

6.7 Some problems fixed since version 3.22 Beta 

6.7.1 Clicking on the button for displaying one or two plots on the Plot Settings toolbar 
may cause crash. 

Please report if you get this. 

6.7.2 In rare cases, the room acoustics parameter calculation might cause crash if the 
file is not a room response. 

If you have this problem, please e-mail the measurement file to us. 

6.7.3 When closing WinMLS or closing a measurement group an error message will 
sometimes be displayed.  

Please report if you get this. 

6.7.4 Setting labels on Y-axis dependent on transducer type and measurement mode 

6.7.5 If a measurement setup is loaded and the calibration mixer input/output file was 
not found, the selected measurement setup is not loaded correctly. 

6.7.6 Some has reported that using VXPocket with 24 bits for output (playback) gives 
error message. However 16 bits works. 

If MLS is used as output measurement signal, it makes no difference if 24 or 16 bits is used since the MLS is a 
binary sequence (really only needs 1 bit). But if you are using other excitation, such as pre-filtering or sinusoid it is 
better to use 24 bits. 

6.7.7 Double-clicking in plot causes WinMLS to crash 
Double-clicking in the plots is supposed to display the plot type settings dialog box. In this version instead of double-
clicking, we recommend that you use the F5 key. It will display the plot type settings for the active plot. 

6.7.8 Relative level calibration of mixer may give wrong result 
Please report if you get errors doing this. 

6.7.9 Waterfall plot 
It is not 100 % finished.  
Some of the plot settings are not remembered / recalled in the set-up file.  
You will not be able to set the FFT size in the Frequency Response/Spectrum settings box (this applies for 
Cummulative Spectral Decay only, the Energy Time Curve FFT-size is set from the Waterfall settings dialog).   
The auto refresh does not always happen. 
Cycles (number of slices) works for cumulative spectral decay only. It is not yet added to the setup file. 

7 Questions to the user 
If you are interested in helping us improving WinMLS, please send us your comments to the questions below. 

7.1 Default colors 
We do need help in finding better default curve colors in Plot->Default Curve Styles. 



7.2 Measurement examples 
We would appreciate if you could send us your sound card loopback measurement (input and output connected). 
Please send it to soundcard@winmls.com. 
 
We are working on putting together measurement examples (see the measurement folder after you have installed 
WinMLS). If you have performed measurements, please send them to us and we will consider adding them (we can 
both give you credit and anonymity, that is up to you). 

7.3 Axis labelling 
We have added y-axis labels given by the units used for the measurements. The problem with this is if several 
measurements are plotted using different units (e.g. a measurement of voltage and a measurement of SPL). Then the 
y-axis label will show the correct unit only for the active measurement. A solution is to add this information to the 
legend and to keep the y-axis the way it was before.  
But then again, the title of the plot displays the title of the active measurement, so that should perhaps be changed 
also. 
Comments? 
 
What should the units be if the active measurement is divided using the reference measurement? 

7.4 Delete all curves 
Plot->Delete All Curves should perhaps have cleared everything in the chart? Deleting the title, labels, etc is a 
problem if auto-text-adding is off and the user has typed his own info that he wants to keep. This can be solved by 
checking if auto-text-adding is used or not, if used, then delete. Comments? 

7.5 Testing level calibration 
We would like you to test the level calibration. Please see the FAQ file under the Measurement chapter for 
instructions. 

7.5.1 Sound card conversion factor 
About what to call the conversion for the sound card, we think it is best just to call it “Sound card conversion [dB]”, 
because we do not find a simple thing to call it (e.g. if the mixer is relatively calibrated, it is relative to the mixer). 
And is it really important for the user to know more than this? We intend that the user should perform the calibration 
and not find this number himself from the sound card users guide (which may also be impossible). Comments? 

7.6 Room Acoustics 
 

7.6.1 Is it important to have the time limits displayed in the grid/plot? 
For example, if plotting clarity, should the chosen time limit be displayed in the plot title or in the first column of the 
grid? 
 

7.6.2 Should the window in time domain after computing room ac. params be set to 
indicate where the start was detected? 

This can be used to see if there is an error in the start detection.Now the start is displayed in meters in the r(m) 
parameter when displaying to grid or writing to text-file. 
Should it be allowed to detect the start manually? 
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