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1 Introduction to the WinMLS Room 
Acoustics Module 

Room acoustics parameters can be calculated from measured impulse responses using the 
room acoustics post processing capability of WinMLS. The parameters are calculated 
according to the definitions, requirements and recommendations of the ISO 3382 standard1. 
Additional parameters like speech transmission indices are included as well. The results can 
be presented graphically, in a text window, or saved to a text file, with contents according to 
response type and calculation settings chosen by the user. 
 

2 Practical information, tips and warnings 
• When measuring room impulse responses using WinMLS, it is recommended that a room 

acoustics setup is loaded. Such a setup can be loaded and saved from the Setups Toolbar 
(can be turned on/off from the View menu), or from Measurement->Save/Load 
Measurement Setup. When the setup is loaded, the GO button on the standard toolbar 
can be used to start a measurement, or File->Insert can be chosen to insert an already 
existing response from a file.  

 
• Calculation options and parameter settings for the room acoustics calculations can be 

modified from the Room Acoustics menu. These settings are saved with the post-
processing setup file found on the Setups Toolbar. 

 
• The room acoustics calculations have been developed with accuracy as the main goal. 

Optimization of calculation speed has not been allowed to compromise accuracy. The 
calculations have been tested against international benchmarks with excellent results2. 

 
• The room acoustical parameter results are given with a considerably higher accuracy than 

the typical measurement repeatability when repeating measurements in a given position in 
a normal room. 

 
• To avoid time consuming calculations, do not permit excessive impulse response lengths 

and sampling rates. 
 
• For the noise detection and truncation compensation algorithms to work optimally, the 

impulse response should be sufficiently long to have a late part with a stationary noise 
floor, also after filtering in the analysis bands. 

 
• Observe normal caution required for high quality MLS measurements, like avoiding time 

wrapping, distortion and long averaging times in slowly time-varying systems. 
 

                                                 
1 ISO 3382: 1997, Acoustics - Measurement of the reverberation time of rooms with reference to other acoustical 
parameters. 
2 Post-processing tests have been carried out on impulse responses described in a report by J.S. Bradley, “An 
international comparison of room acoustics measurement systems,” National Research Council of Canada 
(1996). 
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• It can be worthwhile spending some time finding the right setup and level settings when 
measuring in a new room, to find the optimum trade-off between background noise 
(acoustical and electronic) and spurious components due to distortion. Loud is not always 
best in terms of resulting signal-to-noise ratio, due to loudspeaker distortion. 

 
• Always control the measurement quality while there is still time to repeat the 

measurement. Check normalized, logarithmic impulse responses to check whether the 
response is sufficiently raised above the noise floor and distortion components. Check 
room acoustical parameters for sensibility. Check decay ranges. Check filtered Schroeder 
plots to pinpoint anomalies. 

 
• The calculations will in general be meaningless if performed on non-impulsive sound 

records, even if results may be shown. 
 
• The calculations might be inaccurate when performed on impulse responses with very 

short decay times, for instance electronic systems (amplifiers, filters, etc.). The decay 
curve formation is based on the assumption that decay times are on the order of at least a 
tenth of a second, like it will be in any room but an anechoic chamber. 

 
• Examples of measured room impulse responses and corresponding parameters in text-file 

format are given in the WinMLS measurement examples folders. 
 
• Further descriptions of sensible measurement procedures can be found in ISO 3382. 
 

3 Specification of input impulse responses 
The room acoustics calculations operate on a primary and an optional secondary impulse 
response. Most parameters are based on a single response, usually measured with an omni-
directional microphone. These parameters are always calculated from the primary response. 
Some parameters, like lateral fractions and interaural crosscorrelations, are based on two 
responses. In these cases a secondary response must be provided as well, measured with an 
omni-directional or figure-of-8 microphone. The primary and secondary impulse responses 
must always have the same length and sampling frequency. 
 
Specification of input responses to the room acoustics calculations is done by making the 
responses active in plot windows. The primary response is always taken as the active 
measurement in the upper plot, and the secondary response is taken as the active measurement 
in the lower plot. If only a single plot is displayed, its active measurement becomes the 
primary response. The secondary response is still the active measurement in the lower plot, 
and is specified in the Measurement Selection Toolbar (shown in the figure below) or in 
Plot->Select Plot Type(s) and Active Measurement. In any case, it is a good idea to check 
one of these to make sure that the correct impulse responses are specified before room 
acoustics calculation is initiated. 
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After a measurement the resulting response becomes the active measurement in the current 
plot window. It is therefore automatically chosen for room acoustics calculations. 
Measurement channel two can be automatically sent to the lower plot by checking the appro-
priate box in the bottom part of Measurement->Measurement Tasks. If it is checked and a 
multi-channel measurement is performed, channel 1 will be plotted in the upper plot and 
channel 2 will be plotted in the lower plot. Make sure two plots are viewed, with only one plot 
channel two will not be displayed. 
 
If several measurements are inserted using File->Insert…, the first measurement will be 
displayed in the upper plot, the second will be displayed in the lower plot, the third will be 
displayed in the upper plot, and the forth in the lower, and so on. Note that measurements may 
be selected in any order by clicking on the measurement files in the File->Insert… dialog. 
 

4 Making calculations 
The room acoustics calculations can be initiated in three ways: 
 
1. From the main menu, item Room Acoustics->Calculate 

 
2. Choosing Room Acoustics Parameters as plot type, either from Plot->Select Plot 

Type(s) and Active Measurement or the Plot Toolbar. 
 

3. Checking Display selected room acoustics parameters at the bottom part of 
Measurement->Measurement Tasks. 
 

In case 1 calculations are carried out when choosing Calculate, and results for the selected 
parameters are displayed in a text grid window and/or saved a text file according to the 
settings in Calculation Options.  
 
In case 2 calculations are carried out each time plots are refreshed, and the result for the single 
selected parameter is plotted (the settings dialog box is displayed by double clicking in the 
plot). In both cases input responses are taken as active measurements as described above, and 
calculations are made according to the settings under the items Calculation Options and 
Parameter Settings in the Room Acoustics menu. 
 
In case 3 room acoustics parameters are being computed and displayed to a grid when 
measurement files are inserted using File->Insert. If Room Ac. Parameters is selected as 
plot type, the selected parameter will be displayed in the plot as well according to case 2. Note 
that this will reduce the speed, since the computation will be performed twice. 
 
Before parameter calculation, WinMLS automatically detects the start of the impulse 
response. This creates a reference for all subsequent time windowing and alignment of the 
response. Some parameters require impulse response energy to be calculated in time 
windows. All windowing is done before filtering to avoid energy leakage across window 
borders, even if this may increase the processing burden considerably. Then the impulse 
response is filtered in the specified frequency bands, the noise floor is optionally analyzed and 
compensated for, and a decay curve is calculated by backwards integration. The algorithms 
for the decay curve formation and parameter calculation are further described in the following 
subsections. 
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Errors leading to calculation abortion will prevent results from being presented and produce 
error messages explaining the situation. 
 

5 Presenting results 
Room acoustics parameters can be presented in a text grid, saved to a text file, or plotted 
directly in a graphics window. The check boxes Display in text grid and Send to text file 
specifies how to present and/or save results when the calculation is initiated through Room 
Acoustics->Calculate. All chosen parameters are displayed in the grid or saved to the file. 
 
If the text grid box is checked, a result window will open after the calculation is finished. The 
data in the grid can be copied to the Windows clipboard for export to spreadsheets or word 
processing software. 
 
An example of output data is shown below, the contents are:  
 
1. The name of the primary measurement, or impulse response file 
2. Octave band center frequencies in Hz 
3. SNR in dB, for primary and (optional) secondary input response 
4. Parameters as function of frequency 
5. Parameters independent of frequency 
6. Estimated source to receiver distance in m 
 

 
 
(This example incidentally shows a typical anomaly, the combination of a low frequency 
octave band filter, a short time window, windowing before filtering and a high noise floor 
creates transient effects that can produce odd looking results, like the 63Hz D(%) value. 
Calculations are according to recommendations, but the practitioner must use his common 
sense in interpretation of the data.) 
 
Blank fields indicate calculation errors, which are most often caused by noisy impulse 
responses and thereby insufficient decay range, or that time ranges are insufficient for a 
particular parameter. In these cases only particular parameters will be missing. 
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In some cases all parameters can be missing for a particular frequency band. The most 
common reason is when truncation of the impulse response at or above the noise floor is 
chosen in Calculation Options->Integration options, and the truncation point cannot be 
determined due to too much noise or an odd shape of the response after filtering in this band. 
See section 6.3 for more information about this situation.  
 
If output to a text file box is chosen, results will be saved to a text file with a similar format as 
the grid. Saving directly to text file can only be done if the room impulse response itself is 
saved in a file prior to calculation. The text file ends up having the same name as the impulse 
response file, with the extension .txt.  
 
For calculations using a secondary impulse response as well, the name of the resulting text 
file will be composed using both filenames, for instance: 
Primary: C:\WinMLS\Debug\Measurements\Studio1.wmb 
Secondary: C:\WinMLS\Debug\Measurements\Studio2.wmb 
Result: C:\WinMLS\Debug\Measurements\Studio1Studio2.txt 
 
Results can also be plotted directly in a plot window. Only a single parameter at a time can be 
displayed as function of frequency, but it is possible to plot the same parameter calculated 
from several impulse responses for easy comparison. Choose the Room Ac. Parameters plot 
type (can be done from the Plot Toolbar or Plot->Select Plot Type(s) and Active Meas.). 
The parameter to be plotted is chosen by double-clicking in the plot or from Plot->Plot Type 
Settings->Room Acoustics. An example of plotting reverberation time in octave bands for 
three different responses is shown below. 
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6 Calculation Options 
Room Acoustics->Calculation Options will display the dialog box controlling the 
fundamental setup of the room acoustics calculations. All settings are saved in the post-
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processing setup file. The dialog can also be reached via Plot->Plot Type Settings->Room 
Acoustics. 
 

 
 

6.1 Microphone type(s) 
Choose the processing mode by indicating the constellation of microphone(s) used during the 
measurements. The options are: 
 

 
 
1. Single omni-directional 

Single microphone, most common situation. 
 

2. Dual omni-directional 
Two independent microphones. This option is provided for independent measurements but 
where simultaneous calculation can be an advantage, when measuring using the 2-channel 
capability of WinMLS. Two separate calculations will be carried out, and results will be 
presented in separate windows or files. 
 

3. Omni-directional and figure-of-8 
Combination of an omni-directional (primary) and a figure-of-8 (secondary) microphone. 
This option is used for calculation of lateral parameters, see section 7.6. The secondary 
response will only be used for these parameters, other parameters are calculated from the 
primary response. 
 

4. Closely spaced omni-directional pair 
A pair of impulse responses from either two identical microphones measured 
simultaneously, or from a single microphone measured in two locations. In the present 
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version of WinMLS the processing is exactly like that carried out for option 5. This option 
is included for future extension, for instance calculation of lateral parameters without 
using a figure-of-8 microphone. 
 

5. Binaural pair 
A pair of impulse responses from either two identical microphones measured 
simultaneously, or from a single microphone measured in two locations. This option is 
used for calculation of binaural parameters, see section 7.7. The microphones are normally 
placed in or at the ear canal of a dummy head or a real person. The secondary response 
will only be used for these parameters, other parameters are calculated from the primary 
response. 

 
The different microphone types make possible different parameter calculations. For a 
description of the various parameters, see section 7. 
 

6.2 Bandwidth 
After being loaded to the room acoustics module, the impulse responses are filtered in bands 
according to the settings in this box. The options are: 
 

 
 
1. Octave 

Octave band filters, responses corresponding to the requirements in IEC 12603. Lowest 
octave where calculation is attempted is 63Hz, highest octave depends on the sampling 
frequency of the measured impulse response. 
 

2. Low-Mid-High 
Double-octave band filters, responses corresponding to the requirements in IEC 1260. 
Centre frequencies of 176.8Hz, 707.1Hz and 2828.4Hz provides three double octave 
filters corresponding to a low-mid-high combination of octave bands: 125Hz and 250Hz, 
500Hz and 1kHz, 2kHz and 4kHz. 
 

4. Broadband 
No filtering is performed. 
 

5. 1/3 Octave (Reverberation time only) 
Third-octave band filters, responses corresponding to the requirements in IEC1260. 
Lowest 1/3-octave where calculation is attempted is 40Hz, highest band depends on the 
sampling frequency of the measured impulse response. For this bandwidth only 
reverberation time is generally of interest, and therefore it is the only parameter 
calculated. The dialog Room Acoustics->Parameter Settings will be overridden and not 
available for changes. To minimize the influence of the filter response on the 
reverberation time calculation, the impulse responses are filtered backwards. This greatly 
improves the accuracy for short decay times at low frequencies. 
 

                                                 
3 IEC 1260: 1995, Electroacoustics – Octave-band and fractional-octave-band filters. 
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6.3 Integration options 
After filtering, backwards integration of the impulse response to form a decay curve, or 
Schroeder curve, is done as further preparation to the parameter calculations. If h(t) is the 
filtered impulse response, the decay curve is: 
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This provides a monotonically falling decay. The curve is usually normalized to start at 0dB. 
In practice the impulse response record is finite, and the integration becomes finite as well: 
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Also, a measured response tends to contain some noise. Due to the phase randomizing 
property of the MLS deconvolution, additive noise of any kind in the measurement will give 
rise to a stationary noise floor, see the example below. This is advantageous as a combined 
noise-decay analysis of the filtered impulse response record can reveal the location of the 
cross-point between the response and the stationary noise floor, the response can be truncated 
at or above this point to lessen the influence of the noise on the results, and finally the 
truncated energy can be estimated and taken into consideration. 
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If compensation for truncated energy is incorporated, and the estimated correction is denoted 
C, the decay curve is: 
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The integration options in WinMLS are: 
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1. Truncation and compensation 

Integration of the impulse response, after truncation at or above the crosspoint between 
the response and the stationary noise floor, compensated for the truncated energy. 
 

2. Truncation 
Integration of the impulse response, truncated at or above the crosspoint between the 
response and the stationary noise floor. 
 

3. Whole response 
Integration using the whole impulse response, no noise analysis carried out. 

 
The noise analysis, truncation and compensation are done after filtering, separately for each 
frequency band. Option 1 is the most accurate, and therefore recommended for most room 
impulse response measurements. However, it requires a measurement of reasonably high 
quality to give good results. 
 
The crosspoint between the decaying response and the stationary noise floor is detected using 
an iterative algorithm4. Subsequently, a truncation point is determined using a safety margin 
above the crosspoint. With the Noise margin parameter the user can specify in dB how far 
above the noise level at the estimated crosspoint the truncation point is chosen and integration 
shall start. Typical values are 5-10dB, the recommended value is 5dB. Higher margins should 
be used only with responses with extraordinary high signal-to-noise ratios. The late slope of 
the truncated response is calculated by a line fit, and a compensation for the energy lost by 
truncation is estimated assuming exponential decay to infinity. 
 
The decay curve forms the basis for calculation of the various decay time parameters, and it 
can be plotted using the Schroeder plot-type. The plots below give examples of the three 
options. If truncation is chosen, all room acoustical parameters involving the late part of the 
response is calculated based on a similarly truncated impulse response. If compensation is 
chosen and the truncated energy can be successfully estimated, all room acoustical parameters 
involving the late part of the response are corrected for the truncated energy. 
 
If the truncation point cannot be determined due to too much noise or an odd shape of the 
response after filtering, no parameters will be calculated for that particular frequency band. If 
a response produces trouble, turning off truncation and compensation and inspecting the 
filtered impulse response and Schroeder curve might reveal the source of the problem. 
 
The figure below gives an example of the three options. 
 

                                                 
4 A. Lundeby, T.E. Vigran, H. Bietz and M. Vorländer, "Uncertainties of Measurements in Room Acoustics," 
Acustica, vol. 81, pp. 344-355 (1995). 
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6.4 Result of calculation 
Room acoustics parameters can be presented in a text grid, saved to a text file, or plotted 
directly in a graphics window. The check boxes Display in text grid and Send to text file 
specifies how to present and/or save results when the calculation is initiated through Room 
Acoustics->Calculate. More information can be found in section 5. 
 

 
 
 

7 Parameter settings 
Room Acoustics->Parameter Settings will display the dialog controlling which parameters 
are to be calculated, using check boxes. For some of the parameters the calculation can be 
controlled by specifying level and time limits, or even more advanced settings. All settings 
are saved in the post-processing setup file. The dialog will not be available if 1/3-octave 
bandwidth is chosen in Room Acoustics->Calculation options->Bandwidth, since only 
reverberation time is calculated for the 1/3-octave. The dialog can also be reached via Plot-
>Plot Type Settings->Room Acoustics. 
 
For a more thorough introduction to the room acoustical parameters, see the ISO 3382 
standard, or any good textbook on room acoustics. 
 



12 

 
 

7.1 Decay range (SNR) 
The signal-to-noise ratio (SNR) is not included in the Parameter Settings dialog, it is 
however an important parameter, and it is always the first parameter given in the results grid 
(and can be displayed as marks in the room acoustics plots) and is therefore discussed here. 
 
Utilizing the phase randomizing property of the MLS deconvolution, the actual signal to noise 
ratio in the impulse response measurement can be estimated from the resulting response itself. 
This ratio is, however, not of much practical use in room acoustical analysis. Of much more 
interest is the so-called decay range, which directly describes the range of the decay curve 
which is available for analysis. For an explanation of the decay curve, see section 6.3.  
 
The SNR in dB as displayed by WinMLS is actually the decay range. It is taken as the level of 
the decay curve at the point where the response is truncated before forming the decay curve. 
The resulting decay range is therefore, in addition to the physical signal-to-noise ratio in the 
measurement, dependent on the type and shape of the room impulse response and the chosen 
noise margin in the response truncation. 
 
The decay range can be used directly to evaluate the quality of the room acoustical parameter 
calculations, especially the reverberation time T30. It should be noted, and is illustrated 
clearly in the examples in section 6.3, that if no compensation for energy removed by 
truncation has been done, the decay range as calculated here is meaningless. It will therefore 
not be displayed in the results grid unless Truncation and compensation is chosen in Room 
Acoustics->Calculation Options->Integration Options. 
 
If a secondary impulse response is used due to the chosen microphone option, a second row of 
SNRs will appear in the result grid. This is calculated separately for the secondary response. 
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7.2 Decay times 
The reverberation time (T30), is the 60dB decay time calculated by a line fit to the portion 
of the decay curve between -5 and -35dB. If the decay range is less than 35dB, the T30 is in 
WinMLS calculated using the range available. It is therefore important when using the T30, to 
keep an eye on the SNR to evaluate the quality. To be a valid measurement according to the 
ISO 3382 standard, the SNR should be displayed as 35dB or larger.  
 
The standard recommends a certain safety margin to the noise floor. It should be noted that 
the Noise margin parameter taken into account before forming the decay curve and 
calculating the decay range provides this safety margin. It is user changeable and described in 
section 6.3. 
 
The early decay time (EDT), is the 60dB decay time calculated by a line fit to the portion of 
the decay curve between 0 and -10dB. 
 
The user defined reverberation time (Tu), is the 60dB decay time calculated by a line fit to 
the portion of the decay curve in an interval specified in the level limit boxes, remembering 
the minus signs in front. It is often used as a T15 (-5 to –20dB) or T20 (-5 to –25dB) 
parameter, giving a well defined decay time measure for responses with inferior decay range, 
or providing an indication of double sloping of the decay if it is significantly different from 
the T30. 
 
All the decay time parameters are given in seconds. If the decay range in a particular 
frequency band is insufficient for EDT or Tu measurement, no calculation will be carried out. 
 

7.3 Early energy ratios 
The early to late index, or clarity, is 
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where te is the early time, typically 80ms for music application and 50ms for speech or stage 
evaluation.  
 
The early to total index, or definition, is 
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Definition is mostly used for speech signals, and the early time is usually taken as 50ms. 
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The upper integration limits are taken as the truncation point determined in the decay curve 
formation, or the end of the impulse response, according to the integration option specified. If 
compensation for truncated energy is calculated, this is taken into account as well to increase 
accuracy. 
 
The early limits can be changed in the boxes. 
 

7.4 Centre time 
The centre time is the first moment of the impulse response h(t): 
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The upper integration limits are taken as the truncation point determined in the decay curve 
formation, or the end of the impulse response, according to the integration option specified. If 
compensation for truncated energy is calculated, this is taken into account as well to increase 
accuracy.  
 
Due to the time-weighting in calculating the first moment, the centre time is more sensitive to 
the influence of noise, and will therefore be particularly inaccurately calculated if the SNR is 
low. To compensate for this, an analytical compensation for the truncation of the first moment 
is also calculated in the truncation and compensation integration option. 
 

7.5 Strength 
The sound strength, or level, is defined as 
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where h10(t) is the free-field response of the (assumed omni-directional) source at a distance 
of 10m, filtered in the same way as the impulse response itself.  
 
The upper integration limit in the numerator is taken as the truncation point determined in the 
decay curve formation, or the end of the impulse response, according to the integration option 
specified. If compensation for truncated energy is calculated, this is taken into account as well 
to increase accuracy. 
 
The reference level is: 
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There are various ways of specifying or estimating the reference level, and this is governed by 
the choices in the direct energy options dialog box. The method is common for strength (G) 
and late lateral strength (LG). 
 

7.5.1 Direct energy options 
Pushing the Options… button opens up the direct energy options dialog box, where it is 
specified how to calculate the reference level.  
 

 
 
The main options are: 
 

 
 
1. No reference energy 

Lref is assumed to be 0dB in all frequency bands, which means no correction is made on 
the level calculated from the primary impulse response. This can be used for instance if 
the source level is unknown or of no interest, but the level difference at various 
measurement positions shall be compared. In this case no other options are available in the 
dialog. 
 

2. Window active response 
h10(t) is estimated by windowing the primary impulse response, and Lref is calculated 
subsequently. In this case the window length and temperature is available for change. 

 
3. User specified 

Lref is given directly by the user, or calculated based on reference measurements speficied 
by the user. 

 
Option 2 and 3 will be explained further in the following subsections. It should be noted that 
the standard requires a fairly elaborate calibration measurement of the sound source to 
provide the reference energy at 10m. Only option 3 gives the possibility of obtaining G-values 
according to the ISO 3382 recommendations. 
 

7.5.2 Window active response 
This option is incorporated to provide a simple to use reference level calculation, without the 
use of separate reference response measurement or time-consuming reference level 
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measurements. The reference free-field impulse response is estimated from the measured 
(primary) impulse response as: 

)()(
10

)(10 twthrth ⋅≈      (9) 

where r is the estimated source to receiver distance and w(t) is a half-Hamming window 
starting on the arrival of the direct sound in the impulse response. After windowing, the 
reference response is filtered, and the reference levels are calculated. 
 
The window length can be specified in the dialog box, in ms. A recommended value is 5ms, 
which provides a useful trade-off between incorporating the impulse response of the 
loudspeaker while windowing out reflections from the surroundings. In normal concert hall 
measurements especially the stage floor reflection can be bothersome in this respect, it will in 
most cases fall inside the 5ms window. 
 
The source-to-receiver distance is estimated based on the detected initial time delay of the 
direct sound, which requires that the measurement must have been performed with a feedback 
loop in place. The temperature on the measurement site can also be specified, in degrees 
Celsius, as this influences the speed of sound and thereby the estimated distance. No great 
accuracy is required, and in most room measurements 20°C, normal room temperature, can be 
used. It should also be noted that the initial time delay detected from the impulse response 
will provide the distance to the face of the loudspeaker, not necessarily to the acoustic center 
of the source. 
 
Comparison with properly calibrated measurements have demonstrated that this method will 
normally provide too high G values at low frequencies due to insufficient window length, 
fairly good G values at mid frequencies (500-1000Hz), and too low G values at high 
frequencies due to the influence of the immediate surroundings of the transducers. Because of 
this G cannot be said to be calculated according to the ISO 3382 requirements. 
 

7.5.3 User specified reference level 
If user specified reference level is used, yet another dialog box can be opened with the button 
User specified settings. In this dialog Lref can be specified directly or calculated from 
reference measurements, all assuming calculation in octave bands are used. 
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Direct specification of Lref is done in dB. This is useful in the case where the source and 
measurement equipment has been pre-measured in an anechoic room or otherwise, the 
reference level calculated, and the actual room measurement performed with exactly the same 
equipment and level settings. Alternatively known level changes can be used and corrected 
for. The calculation procedure described in the following subsection can be used to find 
reference levels for later use. 
 

7.5.4 Reference level calculation procedure 
A reference level calculation procedure is implemented for use with various reference 
measurement situations. The procedure is initiated by pressing the Perform computation… 
button, which opens up a browser window and the user can specify a set of reference impulse 
response files. These responses must have the same length and sampling frequency. The 
responses are windowed according to the choice in Window type, and scaled according to the 
choice in Source distance. Thereafter the energy of each is calculated in bands, and the 
reference level is found by averaging the energy across all the specified responses. The results 
are displayed in the Direct energy corrections dialog box, and should be saved for later use 
and reference. The calculation might take a while. 
 
For a true omni-directional sound source a reference measurement in a single direction would 
be sufficient. Most practical sources are 12-faced speakers that start to show lobes in the polar 
pattern around 1kHz. The ISO 3382 standard therefore specifies that a proper reference level 
measurement shall be made in a free-field, and data from at least 29 directions shall be energy 
averaged. WinMLS can handle such a reference measurement, as well as any other less 
accurate reference that might be chosen. 
 
Alternatives may range from the full set measured in a free-field, via fewer directions, 
increasingly reflective environments, to actual in-situ single direction responses. The user 
must choose a reference from what is practically possible, and be aware of the resulting 
accuracy. 
 
The windowing options are: 
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1. Whole response (anechoic) 

This option assumes an actual free-field, or anechoic, measurement of high quality. If this 
is the case, it provides accurate reference levels across a wide frequency range. 
 

2. 50ms rectangular (anechoic) 
This option is similar to option 1 in that it is suitable for free-field measurements. The 
windowing improves accuracy for most measurements, as in most bands data beyond 
50ms will be noise anyway, and the window is sufficiently long to extend to very low 
frequencies. It is the recommended method for free-field reference measurements. 
 

3. 5ms Half-Hamming (in-situ, non-standard) 
This option is similar to the windowing of the active response as described in section 
7.5.2, and can be used for in-situ measurements where a reference impulse response is 
measured separately. This can typically be done in concert hall measurements where a 
close range measurement across an empty stage or to a front seat row can provide a better 
reference than the actual measurement positions. 

 
Source distance options are: 
 

 
 
1. Compute from measurement (using initial time delay) 

For this option the distance is detected and computed separately from the various 
reference responses, in the same way as described in section 7.5.2. The temperature can be 
changed in the dialog as well, and will influence the speed of sound and thereby the 
distance. It should be noted that the distance to the acoustic centre of the source will be 
somewhat longer than the distance detected to the nearest loudspeaker face, which might 
influence close measurements. It is required that the initial time delay is correct, and the 
measurements must have been made with a feedback loop. 
 

2. Specify in meters (meas. initial time delay is not used) 
This option should be chosen when the reference measurement distance is known, and the 
same for all reference responses in the set. 

 

7.6 Lateral parameters 
Calculation of lateral parameters requires microphone option omni-directional and figure-of-
8, and both primary and secondary impulse response specified. It is further assumed that the 
omni-directional and the figure-of-8 microphones have the same sensitivities and are properly 
equalized with respect to each other, in the direction of maximum sensitivity. The two 
impulse responses should be measured in the same position, if possible simultaneously. The 
figure-of-8 should have one of the null-directions pointing either towards the source or along 
the long axis of the room, see ISO 3382. It is also extremely important that they are mutually 
synchronized, with matching absolute time scales. This can for instance be accomplished 
measuring with a feedback loop, providing responses with a true initial time delay. 
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The early lateral energy fraction is 
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where hL(t) is the impulse response measured with a figure-of-eight microphone with one of 
its nulls pointed towards the source. The time limits are td, the direct time, and te, the early 
time. LF is normally used for music application, with direct time 5ms and early time 80ms. 
The limit 5ms is introduced to make sure the direct sound is totally suppressed. The time 
limits can be changed in the boxes. 
 
The late lateral strength is 
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This is a fairly new parameter, not mentioned in the standards so far, but it is believed to 
correlate well with subjective envelopment5. 
 
The upper integration limit in the numerator is taken as the truncation point determined in the 
decay curve formation for the lateral impulse response, or the end of the impulse response, 
according to the integration option specified. If compensation for truncated energy is 
calculated, this is taken into account as well to increase accuracy. 
 
The reference energy in the denominator is calculated just as for strength, the same options 
govern the calculation, and similar comments on accuracy apply, see section 7.5. 
 

7.7 Interaural crosscorrelation 
Calculation of the binaural interaural crosscorrelation parameters are normally done from a 
binaural pair of impulse responses, measured either with a dummy head or microphones in or 
close to the ears on a real person. It requires microphone option Binaural pair. (The 
microphone option Closely spaced omni-directional pair can also be used in the current 
version of WinMLS, it provides exactly the same processing.) It is not important that the 
responses are mutually synchronized. The primary response is taken as the left side and the 
secondary as the right side. 
 
The interaural crosscorrelation function is defined as 

                                                 
5 J.S. Bradley and G.A. Soulodre, "Objective measures of listener envelopment," J. Acoust. Soc. Am., vol. 98, pp. 
2590-2597 (1995). 
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where hL(t) and hR(t) are the left and right ear impulse responses respectively. The interaural 
crosscorrelation coefficient is taken as: 

( ) ms1ms1,maxI <<−= ττIACFACC      (13) 

WinMLS calculates three versions of the IACC; total with time limits t1=0 and t2=∞, early 
with time limits t1=0 and t2=80ms, and late with time limits t1=80ms and t2=∞. The time limits 
t2 for IACC early (early time) and t1 for IACC late (late time) can be changed in the boxes. 
 
The upper integration limit t2=∞ for IACC total and late is taken as the truncation point 
determined in the decay curve formation for the two impulse responses separately, or the end 
of the impulse responses, according to the integration option specified. 
 
The calculation of IACC is substantially more time consuming than the other parameters, 
even if it is implemented using a fast frequency domain algorithm. This is especially true for 
the late and the total versions. If not explicitly needed, these parameters should therefore be 
excluded from the calculations. 
 

7.8 Stage parameter 
Support is defined as6: 
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where it is assumed that the response is measured with an omni-directional microphone at a 
distance of 1m from the source. The time limits are td, the direct time, te, the early time, and tl, 
the late time. ST1 is defined with direct time 10ms, early time 20ms and late time 100ms. The 
time limits can be changed in the boxes to provide other versions of the parameter. 
 

7.9 Speech transmission indices 
The speech transmission index (STI) and the rapid version (RASTI) are single number 
measures based on both impulse response and signal-to-noise ratio in the room or speech 
transmission system. The standard IEC-60268-167 describes the measures, which are based on 
weighted sums of modulation transfer function (MTF) values. The weights currently used in 

                                                 
6 A. C. Gade, "Investigations on musicians room acoustic conditions in concert halls, II: Field experiments and 
synthesis of results," Acustica, vol. 69, pp. 249-62 (1989). 
7 IEC 60268-16: 1998, Sound system equipment – Part 16: Objective rating of speech intelligibility by speech 
transmission index. 
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WinMLS are from the original definitions of STI and RASTI8. The calculations are performed 
on the primary impulse response. 
 
In the calculation of the MTF the impulse response is taken up to the truncation point 
determined in the decay curve formation, or the end of the impulse response, according to the 
integration option specified. The MTF is determined by FFT of the filtered and truncated 
impulse response, and the values at the exact 1/3-octave modulation frequencies specified are 
found by linear interpolation. This is a fast and very accurate method for all but extraordinary 
short impulse responses, and for these the modulation reduction for speech transmission is 
negligible anyway. 
 
If the background noise is low it will not affect the speech intelligibility. However, the 
background noise should be taken into account if the speech-to-noise ratio is less than 15 dB 
in the octave bands of interest. This is done in the compensation settings fond in Room 
Acoustics->Parameter Settings... and explained below 
 

 
 

1. No compensation 
For this option the background noise is not taken into account. The calculations are 
based solely on modulation reduction caused by the impulse response, thereby 
assuming that the speech-to-noise ratio is less than 15 dB in the octave bands of 
interest. This is most common in room acoustics where the effects of reverberation 
and reflections usually dominate. 

2. Compensation (noise fixed) 
This options takes the background noise and assumed speech spectrum into account. 

The  button opens up a new dialog box where the necessary data can be 
entered as shown below. 
 

 
 
This includes the background noise and the assumed speech level on the microphone, 
both expressed as octave band sound pressure levels in dB, for the octave bands that 
are included in the STI calculation. For RASTI only data from the 500Hz and 2kHz 
bands are used. The background noise can be measured with WinMLS if the input 
chain (including the microphone) is calibrated. Alternatively a sound level meter may 
be used to measure the background noise. 
 

3. Compensation (noise updated automatically) 
This option is similar to the above, except that the Noise octave band corrections 
shown in the figure above are computed and updated automatically from the tail of the 

                                                 
8 T. Houtgast and H.J.M. Steeneken, "A review of the MTF concept in room acoustics and its use for estimating 
speech intelligibility in auditoria," J. Acoust. Soc. Am., vol. 77, pp. 1069-1077 (1985). 
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measured impulse response. In order to do this, the input chain (including the 
microphone) must be calibrated. The background noise is computed from the last 
10000 samples of the tail. Make sure that the measured impulse response has decayed 
sufficiently. 
Please note that this option should not be used on measurements performed using 
averaging since the averaging will reduce the effect of the background noise. 
Therefore use 1 averaging, and an impulse response length larger than 1 second (in a 
reverberant room, larger than 2 seconds). 

 
There is no provision for displaying the MTF itself in the present version of WinMLS. 
However, the last calculated MTF is dumped to file mtf.txt in the SetupsPostProcessing 
subdirectory in the WinMLS program directory, and can be viewed in a text editor. 

7.10 Source to receiver distance 
The source to receiver distance is estimated based on the initial time delay detected from the 
primary impulse response, and the speed of sound, as described in section 7.5.2. For the initial 
time delay, and thereby the source to receiver distance estimation, to be correct, the 
measurement must be performed with loop-back or a synchronized sound card. Even if this is 
the case, there will be an extra delay because of the sound card delay. This is set as 40 
samples as default (set in Measurement->Sound Card Settings...). However, if 
measurement system correction is used, this delay will be corrected for (set with the  
button in the Measurement Settings Toolbar). 
 
The source to receiver distance is always output in the result grid or file, and is used in some 
of the reference level calculation procedures described in section 7.5. 
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