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1 Introduction 
WinMLS 2000 is software for performing and evaluating audio, acoustical and vibrational 
measurements. It was designed for MLS (maximum length sequence) measurements of acoustical 
systems, but other types of measurements are also supported. Measurements based on MLS allow 
measuring system impulse responses with high accuracy. Until recently, such measurements were 
impossible without custom hardware solutions. With WinMLS, however, impulse responses can 
be measured with great dynamic range and fine resolution on a PC with a standard full duplex1 
sound card. Powerful and flexible post-processing capabilities are integrated in the software. In 
order to export the measurement data, several formats are supported. If further post-processing of 
the measurement data than the current version of WinMLS can offer is needed, MLSSA® (DRA 
Laboratories) and Matlab® (MathWorks Inc.) may be used. Software that can read text-files, such 
as Excel (Microsoft) may also be used.  
In the documentation, note that some parts may not be relevant for your type of sound card or the 
type of measurements you want to do. This text is written in a way that it should be 
understandable for persons having little experience with computers. Bold letters are used for 
items in the user interface, such as menus and buttons. If you have any questions or comments 
about WinMLS, please contact support@winmls.com, and please do visit us at 
www.winmls.com.  
 
Several other documents should be used as reference.  
For the installation procedure and a list of issues, please read the Readme file.  
For an answer to a wide range of questions, please read the FAQ file. If you have a problem, 
please see if you can find the solution in the FAQ before contacting us. 
For questions relating to sound cards, please read the Tested Sound Cards file. 
For questions relating to the content of the menus and dialog boxes, please read the Menus and 
Dialog boxes Documentation file. 
 

2 System Requirements 
The requirements for using the WinMLS software is a PC with a standard sound card/device 
running any of the Windows operative systems 95, 98, ME, NT or 2000. 

2.1 PC 
The minimum configuration recommended is a Pentium® processor, 16 Mb Ram, 30 MB of 
available disk space. 
If WinMLS is to be used for post-processing measurements, at least a 400 MHz processor with 64 
Mb RAM is recommended. This is because a slower PC will give bad performance on plotting 
long sequences (measurements of large rooms) and for computing room acoustics parameters. If 
your PC does not perform well enough to run WinMLS 2000, we recommend that you use the 
previous version of WinMLS, ver. 2, that can be downloaded from our homepage. 

                                                 
1 A full duplex sound card is capable of simultaneous record and playback. 

mailto:Lars.Morset@phys.ntnu.no
http://www.winmls.com/
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2.2 Sound card 
A standard Windows compatible sound card is needed to perform measurements. There is a wide 
range of sound card available (we prefer to call it “sound device” instead of “sound card”, since 
USB devices can also be used, but the term “sound card” is so widely used that we continue to 
use it.).  
For performing measurements that require an output signal, such as loudspeaker measurements, 
the sound device must be full duplex. A full duplex sound card is able to record and play 
simultaneously. Most sound cards are full duplex, but a few sound cards are still not capable of 
performing MLS measurements with WinMLS. See the document “Tested Sound Cards” for 
sound card recommendations, more information, and a list of tested sound cards. 

2.3 Hardware 
If you are using WinMLS for measuring electronic equipment only, such as amplifiers, cables for 
connecting to the sound card is in principle all the extra equipment needed. 
In order to use WinMLS for other types of measurements than electrical measurements, 
transducers are needed. A transducer is device for transforming a quantity to another quantity. 
Two well-known transducers are the microphone and loudspeaker. A microphone transforms 
sound pressure to voltage and a loudspeaker transforms voltage to sound pressure.  
In addition to microphone and loudspeaker, which will be discussed in more detail below, 
WinMLS supports transducers for measuring the quantities displacement, velocity, acceleration 
and force. 

2.3.1 Microphone 
Connect the microphone to the left channel sound card line input (if you are to perform a 2-
channel measurement, connect microphone channel 2 to the right input). 
 
If you have a cheap multi-media microphone that comes with the sound card, it can be used for 
testing purposes and for comparison measurements not acquiring a flat frequency response. The 
frequency range is probably also limited. Such a microphone must usually be connected to the 
microphone input of the sound card, since it will provide the phantom power supply voltage 
needed. 
 
For more information about microphones and for purchasing our low-cost microphone for 
performing loudspeaker frequency response measurements and amateur room acoustics 
measurements please visit our homepage or ask us. 
 
For high-quality measurements we recommend dedicated microphones. However, the price may 
be high, and an external phantom power supply or a microphone amplifier is often needed. 

2.3.1.1 Microphone amplifier/Phantom power supply 
Most soundcards are equipped with a single channel microphone input containing an amplifier. 
This can be used, eliminating the need of an external amplifier. For most sound cards it is better 
to use the Line input than the Microphone input since it gives a better signal-to-noise ratio. But 
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for most purposes the Microphone input is usually sufficient and gives a low voltage phantom 
power supply (~1 Volts) for the condenser microphone. 
 
If your microphone needs a greater voltage, a phantom power supply may be purchased or made 
using batteries. 
 
If none of the above is sufficient, we recommend using a microphone amplifier. Note that a 
microphone amplifier may be optimized for certain types of microphones. For instance, a 
phantom power supply voltage may be provided for condenser microphones. Also, the frequency 
characteristic may be optimized for a maximally flat frequency response and the input impedance 
may have been optimized for maximum signal-to-noise ratio.  

2.3.2 Loudspeaker 
Several applications involve a loudspeaker, e.g. measuring the loudspeaker itself or the 
reverberation time of a room. For room acoustics measurements it is important that the 
loudspeaker gives enough power and has a flat frequency response at the range of interest. If you 
intend to perform room acoustics measurements according to the ISO 3382 standard, the 
loudspeaker should also be omni-directional. However, for reverberation time measurements the 
directivity of the loudspeaker is usually not that important (depends on the shape of the room). 
 
Note that a long loudspeaker cable may cause a significant loss, therefore the cable should be a 
part of the configuration when calibrated measurements are to be performed. 

2.3.2.1 Power amplifier 
An amplifier is needed to supply enough power to the loudspeaker. The amplifier can either be an 
integrated part of the loudspeaker or external. Special functions, such as stereo enhancement, 
loudness or spatial sound must be switched off for measurement purposes. Filtering, such as bass, 
treble or equalization should be bypassed or set as neutral as possible. 
 
The loudspeaker amplifier input is to be connected to the left channel sound card output. 

3 Purchasing and Registering 
WinMLS can be purchased from our homepage www.winmls.com or from our distributors. Since 
this is a beta version the pricing and registration is not ready. Please contact us for questions. 

4 The first measurements 
The purpose of this chapter is to give a step-by-step description of how a measurement can be 
performed. The loop-back response of the sound card is first to be measured, then a simple 
measurement using a microphone and a loudspeaker. We recommend that you take the time to do 
this measurement because it is a good way of learning to use the software. It will also let you 
know if the sound card is suited and if the settings are correct. Finally, a loop-back sound card 
measurement may be used to detect the sound card input/output delay (because of the converters) 
and to correct the sound card’s influence on the measurements. 

http://www.winmls.com/
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4.1 Turning off Windows Notification Sounds 
Before you begin your measurements, it is recommended that the Windows notification sounds 
are turned off or send to another sound card if you have several cards installed. By doing this you 
avoid disturbing the measurements. You can turn off the system sounds in the following way: 
Find the Control Panel (click the Start button and choose settings). Then double-click on the 
folder Sounds. If you use Windows95:  
You see a dialog box Sound Settings. At the bottom of the dialog box, find Settings and choose 
No sounds. If you use Windows NT: 
You see a dialog box Sound Properties. Click Windows under Events. 
Then click on the list field under Schemes. When the list appears, choose No Sounds. 

4.2 Finding and Preparing the Volume Control 
If your sound card supports the WinMLS mixer, you do not need to read the following chapter 
since you will not use the external mixer to be discussed here. If your sound card has a mixer, but 
does not support the WinMLS mixer, this chapter is important. If your sound card does not have a 
software mixer at all, an external mixer can be used to set the levels. If you are unsure if your 
sound card supports the WinMLS mixer, go to Measurement->Sound Card Settings and try to 
check Use the WinMLS mixer. If it is impossible to turn it on, then your sound card does not 
support the WinMLS mixer. 
The first time you perform a measurement you will probably have to adjust the input or output 
volume levels. Then you have to find the Volume Control software that is supported by your 
sound card. Usually this is found in the Multimedia folder in Accessories, it may also be found 
in the Control Panel. Some sound cards only support their own volume control that is found in 
the specific sound card folder. A typical volume control is shown in the figure below. 
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The volume control above shows the output volume. When using WinMLS you only use the 
Wave Output shown in the figure above. It is a good idea to mute the other possibilities as 
shown in the figure above. But do not mute the master Volume Control. 
 
We also need to adjust the input volume. For this example it is found from the menu in the figure 
above. Choose options, then properties and Adjust volume for recording. Then the following 
window is displayed: 
 

 
 
Select the input you would like to use, either line-in or microphone. While you use WinMLS, you 
probably need to set both the input and output level. You should therefore have one of each open 
at the same time. To do this, just open a new volume control in addition to the one already open.  

4.3 Measurement 1: Loop-back measurement of the 
sound card 

 

4.3.1 Preparation 
For this measurement, we assume that no settings have been changed, WinMLS has its default 
configuration. If you are not sure, you can load the default configuration from the setups toolbar 
(View->Setups Toolbar). Chose the measurement setup named MasterSetup as shown in the 
figure below. 
 

 

4.3.1.1 Connections 
Find the output and input of the sound card. If your sound card has a microphone input, this may 
be used, we will use the line input in this example. Connect the output to the input (only left 
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channel will be used for the measurement, so you do not have to connect the right channel input 
and output). 

4.3.1.2 Sound card settings 
In Measurement->Sound Card Settings, make sure that the correct input and output device is 
chosen. In the figure below, the card VX222 is chosen as input and output device. If you have 
more than one sound card installed, it is strongly recommended to use the same sound card for 
input and output. This is because there is usually a small difference in sampling frequency and 
this may give a large measurement error for MLS measurements. 
 

 
 
While you still are in the Sound Card Settings dialog box, make sure  is 
checked. If it cannot be checked, this indicates that your sound card does not support the 
WinMLS Mixer. If this is the case, you will not be able to set the input and output line as 
described below. You should read the chapter Finding and Preparing the Volume Control for 
using the sound card mixer, if any. 
 
If possible, select input line as shown in the figure below. Depending on the sound card, you may 
choose between only one or several lines. Usually the line input is called Line-in or Line, and the 
microphone input is called Mic or Microphone. But the VX pocket/VX222 cards have only one 
analog input that can be used as both line and microphone input, thus the input line is just called 
Analog Input. The output line has usually only one choice, and it is usually called Wave or 
Wave Output. 
 

 
 
Click OK to close the dialog box. 

4.3.2 Measurement procedure 

4.3.2.1 Set the input and output levels 
Select Measurement->Test Current Levels to display the dialog box showing the input and 
output levels. If the WinMLS mixer is supported, sliders for setting the mixer levels will also be 
displayed. Use the sliders for adjusting the levels, if you see no sliders, please see the chapter 
Finding and Preparing the Volume Control on how to adjust the levels. 
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The input level must be less than zero to avoid clipping, but as near zero as possible. In the 
figure, the input level is –6.51 dB, which tells how far it is from clipping. If the level is lower 
than –40 dB or increasing the volume does not increase the level, the cables are not properly 
connected. 
The level indicator shown to the right of the figure is colored red if there has been clipping during 
a measurement. 

4.3.2.2 Performing the measurement 
When the levels are set, select Measurement->Start Measurement to start the measurement. 
When the measurement is finished, it should look similar to the figure below. 
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Figure 1 Screenshot after loop-back measuring the Digigram VX222 sound card. 
 
The red curve in the upper plot displays the impulse response of the sound card and the lower plot 
displays the magnitude frequency response obtained from the impulse response. We see that the 
impulse response is very short and the frequency response is very flat in the range 20-20000 Hz. 

4.3.2.3 Saving the measurement 
Save the measurement by clicking the  button or File->Save Active Measurement As…. The 
dialog box shown below will be displayed. 
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Choose a name, title and comment, then click the Save button. 

4.3.3 Changing plot settings 
We will now find the delay in unit samples. First double-click in the upper plot window. This will 
open the Time Data Settings dialog box. To the upper left select Time [samples] as axis unit for 
the x-axis: 
 

 
 
Zoom in on the x-axis of the upper plot. Do this by typing the number 100 in the edit box to the 
right of the  button found at the lower left. Then the upper window will display the first 100 
samples of the x-axis as seen in the figure below 
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From this we see that the sound card has a delay of 41 samples. It is possible to correct for this 
delay, how to do this is explained in the measurement part of the FAQ. 
 
Now restore the old x-axis unit Time [ms] from the Time Data Settings dialog box and restore 
also the maximum axis value by clicking the  button. We will now plot the impulse response 
using dB as y-axis. To do this, first double-click in the plot window. This will open the Time 
Data Settings dialog box. To the upper left select dB as axis unit for the y-axis: 

 

 
 
Click OK to exit the dialog box, this will update the plot with the new settings. The result should 
look similar to the figure below. 
 

 
Figure 2 VX222 sound card measured loop-back, plotted using dB as y-axis. 
 

4.3.4 Verifying the sound card measurement 
If your loop-back sound card measurement performed in the chapter above looks suspicious, we 
recommend that you first compare it with the other measurements of sound cards. Click  or 
File->Insert to insert a new file into the current window. 
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Double-click on the Soundcards folder shown in the figure above to display the available 
measurements of sound cards. 
Note that you can select several files by holding the Ctrl key when clicking. As shown in the 
figure below (some of these files may not be found in your installation, but they can be found at 
our homepage or by contacting us) 
 

 
 

Click  to insert the files. The result will be similar to the figure below (some changes 
to the layout has been done, which will be explained later). From the figure we see the results 
from the different sound cards. The measurement in brown could probably be improved by 
optimizing the volume settings, but we see that the frequency response is smooth for all the 
measurements. 
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4.3.5 Sound Card Troubleshooting 
If the response of your sound card does not look at all like the other sound cards, you have 
checked that your settings are correct, the cables are properly connected and the sound card is not 
on the list of sound cards that does not work with WinMLS, please contact support from our 
homepage and attach your sound card measurement file. 
 
If the response has spurious peaks, this is an indication of distortion. Try to reduce it by 
decreasing the input or output level of the sound card. 

4.3.6 Saving the settings 
WinMLS will always save the last used settings when the software is closed to temporary setup 
files. You may still want to save your settings. Do this by clicking  on the Setups Toolbar. 

4.4 Measurement 2: A simple loudspeaker 
measurement 

This chapter assumes that the chapter above has been read. Note that for all sound cards, except 
for VXpocket and VX222, this measurement procedure will not measure the distance between the 
loudspeaker and microphone (initial time delay). In the examples we have used a typical low 
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quality loudspeaker and microphone that comes with the sound card, thus showing how low 
quality equipment may influence the measurement. 

4.4.1 Preparation 
Connect a speaker to output left channel. Connect a microphone to input left channel, the microphone 
input can be used if any, then make sure that microphone is chosen as Input Line in Measurement-
>Sound Card Settings.  
Place the microphone in front of and near the loudspeaker. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4.4.2 Measurement procedure 
Select Measurement->Test Current Levels to display the dialog box showing the input and 
output levels. Adjust the levels so no clipping occurs, -6 dB should be fine. 
 
When the levels are set, select Measurement->Start Measurement to start the measurement. 
When the measurement is finished, it should look similar to the figure below. 

Loadspeaker  
as Output 

Figure 2: Schematics for one-channel measurement 

Sound Card

Left    Right 
   Input 

Right   Left 
 Output 

Playback 
signal

Microphone 
as Input 

Recorded signal 
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4.4.3 Post-processing the measurement 
 

 
Figure 3 Multimedia microphone and loudspeaker measured on axis at a distance of ~20 
cm. Time window 50 ms. 
 
In the upper right part of the figure above, we see that there are several spurious peaks. These are 
due to distortion in the loudspeaker or microphone, reducing the volume did not reduce the 
magnitude of these peaks. These peaks do not, however, influence the frequency response shown 
in the lower part of the plot significantly. Note that a rectangular window is used on the impulse 
response of length 50 ms displayed in yellow in the figure. The limits can be changed by clicking 
and dragging, or from the Time Window Toolbar shown in the middle of the figure above. 
Decreasing the window size will reduce the noise in the frequency response, but note that it will 
give a decreased frequency resolution and thus false results for very low frequencies. The 
“Frequency resolution indication line” shown in the figure above depends on the window size and 
is meant to warn the user where the results may not be trusted. At the thick part of the line, the 
results should not at all be trusted. At the thin part of the line (which is twice the size of the thick 
line), the result is not certain. 
Note that if the frequency resolution is not sufficient, two resonance peaks may not be resolved, 
but shown as one peak. 
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4.5 Measurement 3: Measuring using loop-back 
This chapter assumes that you have performed the measurements described above. The main 
purpose of the loop-back is to determine the correct initial time delay of the system being 
measured (e.g. the distance between the loudspeaker and the microphone). Most sound cards do 
not have a constant time difference in start of playback and record, it is different from one 
measurement to another. This makes it impossible to find the initial time delay with the usual 
measurement method, but this is easily detected if using the loop-back. 
 
When using a loop-back it is also possible to detect errors in the measurement caused by non-
continuous play or record. This is usually a problem only for slow PC’s, but can occur if you run 
other tasks on your PC while performing a measurement. If such an error is detected the 
measurement will be repeated and a warning is given in the status bar. 

4.5.1 Preparing loop-back 
A loop-back is a physical connection from the output to the input of the sound card as shown in 
the figure below. The MLS output signal is always played in the left channel and the loop-back 
output signal is played in the right channel. Connect the cables as shown in the figure below,  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
You might need to purchase extra cables to be able to connect the loop-back. 
If the input you are using for the microphone signal is mono (the microphone input is usually 
mono), no right input channel exist. Then connect the loop-back input cable to the right channel 
input of the line input instead. 
 

Loadspeaker  
as Output 

Figure 3: Schematics 1-channel measurement using feedback loop. 
Line input is used for  
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Open Measurement->Sound Card Settings dialog box. Make sure ‘Yes, with loop-back and 
end-check’ is selected as shown in the figure below.  
 

 
 
Now select the Loop-back Input Line you used for connecting the loop-back to, in the figure 
above Line-In is chosen. Make sure Loop-back input channel is set to Right. 
The sound card delay must now be set in samples, this we already have found in the first 
measurement procedure we described. This number can vary from 10-80. After typing this 
number, click OK to exit the dialog box.  
 

4.5.2 Loop-back measurement procedure 
Select Measurement->Test Current Levels to display the dialog box showing the input and 
output levels. If your sound card supports the WinMLS mixer, the volume controls Sync. Out 
and Sync. Input will be displayed as shown to the right in the figure below. Use these controls to 
set the volume of the loop-back synchronization signal. 
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Select Measurement->Start Measurement to start the measurement. An error message will be 
given if the loop-back volume is too low or too high.  
The result of a successful measurement will now have almost the correct initial time delay. But as 
we have seen, the sound card has a delay of some samples, which is usually less than 1 
millisecond. To subtract this delay a measurement system correction of the sound card must be 
performed as described in the FAQ. 

4.5.3 This happens during a loop-back measurement  
1. When the measurement is started a synchronization signal is first sent through the right 

channel output to the loop-back. The synchronization signal is recorded and is later used 
to find the correct initial time delay.  

2. The MLS signal is now played on left channel output, through the speaker. The signal is 
recorded on the microphone.  

3. The synchronization signal is played once more on the right channel output. This 
synchronization signal is compared against the first synchronization signal and the time 
difference is computed. The purpose of this is to check that there has been no gaps in the 

playback or record. This check is not performed if  is set in 
Measurement->Sound Card Settings.... 

4. If no error has occurred, the system impulse response is found using cross correlation. The 
sound card delay (pipeline delay in sigma-delta converters) is added in order to obtain the 
whole system response (the default is 40 samples, but should be measured for the sound 
card as shown above). 

4.6 Performing a 2-channel measurement 
The number of channels to be measured is set in the Measurement Settings toolbar. The figure 
shows the setting for performing a two-channel measurement. 
 

 
 
A 2-channel measurement is similar to a one-channel measurement. If you are measuring using 
the loop-back, special consideration must be taken as described below. The rest of the procedure 
is very similar to a one-channel measurement as described in the previous chapters. 

4.6.1 Synchronization Loop Connection for 2-channel 
Measurement 

To perform a 2-channel measurement in loop-back mode, the loop-back must be mixed with the 
measurement signal in one of the channels. How this is best done depends on if your sound card 
has one or two input lines. 
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4.6.1.1 2-channel loop-back for sound cards with one input 
only 

If your sound card only has one input line, e.g. Line input, a device has to be used for summing 
the signals, see the figure below. An audio mixer or a passive device (consisting of 3 resistors) 
can be used, you may also contact us for purchasing such a device. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 3: Schematics for two-channel measurement using 
synchronization loop-back for one single input.
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4.6.1.2 2-channel loop-back for sound cards with two physical 
inputs (e.g. line and microphone input) 

If your sound card has two input lines, e.g. Line and Microphone input, no external device is 
needed to connect the loop-back. Choose different lines for Input Line and Loop-back Input 
Line found in the Measurement->Sound Card Settings dialog box. If your Loop-back Input 
Channel is mono, make sure the right channel is chosen as shown below.  
 

 
 
Connect, using a cable, the output of the synchronization loop (which is on the right channel) to 
the line and channel you have chosen as input for the synchronization loop. Note that you may 
have to split the cable you are connecting to your output to access the output-signal that is on left 
channel. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4.6.2 
M

Read this
record. If 
channel m
micropho

Sound Card

loop-back 

Left  Right Mono 
Line In    Mic. In 

Output
signal 

Right   Left
   Output 
Figure 4: Schematics for two-channel measurement using 
synchronization loop-back for two physical inputs.
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Synchronization Loop-back Connection for 
ono Full Duplex Sound Cards 

 chapter only if the sound card is only capable of one-channel simultaneous play and 
you have such a card you cannot do 2-channel measurements. The card will support 1-
easurements without using a synchronization loop. But if the card has both a 

ne input and a line input and if it supports the WinMLS mixer, WinMLS also support 
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1-channel measurements using synchronization loop for such cards. To do this, you must choose 
different inputs for the Input Line and the Loop-back Input Line as described in the chapters 
above. Then make the synchronization loop by connecting a cable from the sound card output to 
the input you chose as Loop-back Input Line. Note that you need to split your output cable from 
the sound card. One part is for the synchronization loop that we just showed how to connect. The 
other part is for the output signal. 
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