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1 Introduction
WinMLS is software for performing and evaluating audio, acoustical and vibrational measurements. 

The name WinMLS consists of the first part ‘Win’ because it is Windows based software. We also hope to ‘win’ the
heart of our WinMLS users by offering flexible, user-friendly and powerful software for an affordable price.
The last part of the WinMLS name is ‘MLS’ which is a measurement method.
WinMLS was initially based on this MLS (maximum length sequence) method which was perhaps the most powerful
measurement methods at that time (in 1996). Today sine sweep methods are in most cases prefferred to the MLS
method, but MLS is still available as an option in WinMLS and is recommended for speech parameter measurements.

With WinMLS impulse responses can be measured and FFT and octave band analysis can be done with great dynamic
range and fine resolution on a PC with a standard (full duplex) sound card. Powerful and flexible post-processing
capabilities are integrated in the software. In order to export the measurement data, several formats are supported. If
further post-processing of the measurement data than the current version of WinMLS is needed, MLSSA® (DRA
Laboratories) and Matlab® (MathWorks Inc.) may be used. Software that can read text-files, such as Excel
(Microsoft) may also be used. 

In this documentation, note that some parts may not be relevant for the version of WinMLS you have purchased, or
your type of sound card, or the type of measurements you want to perform. 

This document should be written in a way that should be understandable for readers having little experience with
computers. Bold letters are used for items in the user interface, such as menus and buttons.

1.1 Plotting and post-processing overview

WinMLS has many plotting and post-processing possibilities. The figures below will explain how you can take
advantage of and understand some of these possibilities.

If you don’t use WinMLS everyday you may forget how the powerful plotting features works. We recommend that
you make a copy of and put the two figures below on the wall besides your monitor so you can have a quick look at
these to refresh your memory.



Curves, Plots and Measurement Raw Data 
 

A measurement can either be opened from file  or performed using the sound card to 

sample the data . The measurement raw data is samples of a waveform or an impulse 
response. WinMLS stores all measurement raw data in memory. Below you see a list of 
measurement raw data from both performed mesurements (that are not yet saved) and 
measurements opened from file. The measurement raw data are post -processed and plotted as 
curves. 
 

  

               
 

 
 
 
 
 
 
 

Active Plot Type - displays the plot 
type in the active plot (currently 
Frequency Response - Spectrum) 

Legend – displays the curves 
in the plot. The curves may 
be visible or invisible  

Curves can be erased. The 
corresponding measurement 
raw data may also be cleared. 

Open settings for Active 
Plot Type , for example  
vertical axis linear or log 

Reference 
measurement - 
used for division 

Active Plot - Two plots are currently 
displayed and the lower plot is active 
(indicated by thin frame). The toolbars 
display settings for the active plot. 

Clear your last measurement. Clear 
the raw data and all curves belonging 
to the active measurement. 

Visible curves (checked) 

Invisible curves (unchecked) 

Measurement Selection Toolbar 
Measurement raw data are stored in 
memory. The selected is called the 
Active Measurement. 

Active Plot Type Toolbar  – 
displays most common settings 
for the active plot type. 

 

Zoom, Scale and Refresh 
 
 
 
 
 
 
 

 

Auto-scale All - 
in all directions 

Display one or two plots 
(currently two plots are 
displayed) 

Display/hide Legend list 

Mouse Zoom - to zoom In: drag a 
rectangle from upper left to lower 
right. Zoom Out by dragging in any 
other direction. 

Auto-scale 
lower limit 

Mouse Scroll - right click and drag to 
scroll horizontally and vertically. Use 
the mouse scroll wheel to scroll the 
plot vertically. 

Lower limit (currently 20 Hz), on 
change push Enter to validate. 

Move lower 
limit up/down  

Overlay – when 
adding a new curve 
don’t erase previous 

Solo – display only 
active curve, set other 
curves as invisible. 

Refresh – when changing a plot 
setting the active curve or all 
curves can be manually refreshed. 
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In order to use WinMLS efficiently it is important to understand the user interface. WinMLS can have one or two
plots displayed (in the figure above there are two plots, the upper plot displays the time data and the lower displays the
Frequency Response – Spectrum). 

If you click anywhere in one of the plots, you will see a thin black frame around it to indicate that the plot is ‘active’.
In the figure below this black thin frame is around the lower plot. This frame indicates that the plot is active, and all
the settings in the user interface will relate to this plot, e.g. the axis limits in the lower left in the figure below. 

If you click the  button found to the right of the “plot type” list, you will access all the settings for the active plot.
The idea is that if you are uncertain about where a setting is found, you will find it by clicking this button. The curve
color or width can be changed permanently from Plot->Layout->Curve Styles and Colors....

1.2 Help and explanations

1.2.1 A quick explanation of the menus

If you are unsure of the meaning, place the mouse pointer on top of the button/list box or menu item you want to be
explained. The explanation text will appear in the status bar at the bottom as shown in the figure below.

1.2.2 An explanation of the dialog boxes

All the dialog boxes have a  button you can click to open the help file. It will open the reference
documentation to explain the settings in the dialog box.

1.2.3 A quick explanation of the toolbars

For the toolbars, a short version of the explanation will appear as a tool tip just beside the mouse pointer.



1.2.4 Remove the toolbars

You can select which toolbars to be displayed from the Toolbars menu. For example all toolbars can be removed in
production control applications where toolbars may be only annoying and keyboard shortcuts are more convenient.
The toolbar position is remembered if storing the setup from Setup->Store.... You may also freeze the toolbar position
from Setup->Options....

1.2.5 Where to find the WinMLS documentation?

All of the WinMLS documentation is available in the help file. If you are unsure of something, please try the search
functionallity of the help file. For example, if you would like to know how to do a frequency domain division of two
measurements, first go to Help->Help Topics... to open the help file. Then click on the search tab and type a word
related to the question you would like to have answered. In this case we use the word divison as shown in the figure
below. Then type Enter to start the search.

Several topics are found, click on the topic you wish to read more about. Then you may click on the Contents tab to
see where the topic is situated. This first topic in the list was found in the . This means that the
setting is found in the Plot menu. More spesific General Frequency Domain Settings... as we can see from the figure
below.

1.3 Credits

Many WinMLS users have contributed with their knowledge and work to make WinMLS what it is today. We are very
grateful for this. Some of the contributors are listed below.

Programming
Jon Terje Kommandantvold (C++, MFC), Dr. Johan L. Nielsen (Room Acoustics), Jens Jørgen Dammerud (Building
Acoustics)

Testing and Advice
USA
Neil Thompson Shade (consultant, president of Acoustical Design Coll., Ltd)
Pat Brown (president of SynAudCon)

UK
Peter Mapp (acoustics consultant)
Martial Rousseau (Ph. D. B&W Loudspeakers)

Norway
Jens Jørgen Dammerud (acoustics consultant), Dr. Johan L. Nielsen, Magnus Ognedal, Olav Sundøy (sound
technician), Simon Carlsen (acoustics consultant), Håvard Christensen (sound engineer), Olav Arntzen.

Finland
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Andrew Goldberg (Genelec Finland)

Sweden
Lennart Ødlund (sound engineer and acoustics consultant, PA Ljud AB)
Tobias Kirchner (acoustics consultant, Ingemansson Technology AB)

Germany
Ingolf Bork (Dr. Ing, research on acoustics PTB, Braunschweig)
Chris Horn (sound engineer, HORN Audio-Video-Systeme Braunschweig)

2 Hardware Requirements
The requirements for using the WinMLS software is a PC with a standard full duplex sound card running any of the
Windows operative systems 95, 98, ME, NT, 2000 or XP.

2.1 PC

The minimum configuration recommended is a Pentium® processor, 64 Mb Ram, 400 MHz processor, 50 MB of
available disk space.

If WinMLS is to be used for ‘live’ measurements, there recommended minimum configuration is 256 Mb Ram, 1.8
GHz processor. For multi-channel ‘live’ measurements an even better configuration is recommended.

2.2 Sound card

A standard full duplex Windows compatible sound card is needed to perform measurements. There is a wide range of
sound card available. Today, all sound cards should be full duplex unless they only have playback functionallity. 

A few sound cards are still not capable of performing MLS measurements with WinMLS. See the help section named
Tested Sound Cards for sound card recommendations, more information, and a list of tested sound cards.

2.3 Hardware

If you are using WinMLS for measuring electronic equipment only, such as amplifiers, cables for connecting to the
sound card is in principle all the extra equipment needed.
In order to use WinMLS for other types of measurements than electrical measurements, transducers are needed. A
transducer is device for transforming a quantity to another quantity. Two well-known transducers are the microphone
and loudspeaker. A microphone transforms sound pressure to voltage and a loudspeaker transforms voltage to sound
pressure. 
In addition to microphone and loudspeaker, which will be discussed in more detail below, WinMLS supports
transducers for measuring the quantities displacement, velocity, acceleration and force.

2.3.1 Microphone

Connect the microphone to the left channel sound card line input (if you are to perform a 2-channel measurement,
connect microphone channel 2 to the right input).

If you have a cheap multi-media microphone that comes with the sound card, it can be used for testing purposes and
for comparison measurements not acquiring a flat frequency response. The frequency range is probably also limited.



Such a microphone must usually be connected to the microphone input of the sound card, since it will provide the
phantom power supply voltage needed.

For more information about microphones and for purchasing our low-cost microphone for performing loudspeaker
frequency response measurements and amateur room acoustics measurements please visit our homepage or ask us.

For high-quality measurements we recommend dedicated microphones. However, the price may be high, and an
external phantom power supply or a microphone amplifier is often needed.

2.3.1.1 Microphone amplifier/Phantom power supply

Most soundcards are equipped with a single channel microphone input containing an amplifier. This can be used,
eliminating the need of an external amplifier. For most sound cards it is better to use the Line input than the
Microphone input since it gives a better signal-to-noise ratio. But for most purposes the Microphone input is usually
sufficient and gives a low voltage phantom power supply (~1 Volts) for the condenser microphone.

If your microphone needs a greater voltage, a phantom power supply may be purchased or made using batteries.

If none of the above is sufficient, we recommend using a microphone amplifier. Note that a microphone amplifier may
be optimized for certain types of microphones. For instance, a phantom power supply voltage may be provided for
condenser microphones. Also, the frequency characteristic may be optimized for a maximally flat frequency response
and the input impedance may have been optimized for maximum signal-to-noise ratio. 

2.3.2 Loudspeaker

Several applications involve a loudspeaker, e.g. measuring the loudspeaker itself or the reverberation time of a room.
For room acoustics measurements it is important that the loudspeaker gives enough power and has a flat frequency
response at the range of interest. If you intend to perform room acoustics measurements according to the ISO 3382
standard, the loudspeaker should also be omni-directional. However, for reverberation time measurements the
directivity of the loudspeaker is usually not that important (depends on the shape of the room).

Note that a long loudspeaker cable may cause a significant loss, therefore the cable should be a part of the
configuration when calibrated measurements are to be performed.

2.3.2.1 Power amplifier

An amplifier is needed to supply enough power to the loudspeaker. The amplifier can either be an integrated part of
the loudspeaker or external. Special functions, such as stereo enhancement, loudness or spatial sound must be
switched off for measurement purposes. Filtering, such as bass, treble or equalization should be bypassed or set as
neutral as possible.

The loudspeaker amplifier input is to be connected to the left channel sound card output.

3 Installation and Registering
This section explains how to get started using WinMLS. 

If you need more detailed information, all dialog boxes have a  button that you can click to open the
reference documentation. In the reference documentation there is also a FAQ section.

3.1 Install and register software

If you have a CD with WinMLS 2004, insert this CD in your computer. The installation should start automatically. If
not, run the file named setup.exe found on the CD.
If you do not have a CD and have not yet downloaded WinMLS, you can download from
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www.winmls.com
Start the installation.
Follow the installation procedure using default settings.

After the installation, start WinMLS (by clicking the WinMLS icon on your desktop, alternatively click the 
button and locate the WinMLS Program Group. 
When WinMLS is started, you will see this dialog box.

If you want to evaluate the software and have not purchased it, first select the level you wish to test as shown in the
figure below. Note that the higher the level, the more features you will enable.

Then click the  button. Note that there are currently no restrictions on the evaluation version of
WinMLS except for the time limitation, all features are included. 

If you have purchased WinMLS but not yet registered the software, click the  button. 

After clicking one of the two buttons above, you will see the dialog box shown below (the figure below shows the
”Try for FREE…” dialog box, but the ‘Purchase…” dialog box is very similar).

You first open the website to fill in the form and then receive at a later date an unlock code via email.



IMPORTANT! Follow the procedure given in the dialog shown above. You need to obtain an unlock code from us to
run the software. If you have previously submitted the registration form, you can e-mail the code to us directly.

3.1.1 WinMLS license levels

Our goal is to provide solutions to a wide range of users. This is done by offering seven different license levels with
increasing  software complexity and price.

The higher the license level number, the more features are included. Each license level is explained below.

3.1.1.1 Level 1: Small sound system calibration

This level contains the features you need to calibrate your home sound system and to measure sound level in one-third
octaves and dBC.
The setups that this level contains is described below. 

See table in the Detailed license level description section below for more details.

3.1.1.1.1 Sound card setups

All the sound card setups are available, except for the personal version where the professional sound cards Digigram
and Lynxstudio are not supported. 

3.1.1.1.2 Sound System_Stereo and Surround

This setup will allow you to measure your home sound system (stereo and surround).

3.1.1.1.3 Sound System_Spectrum Analyzer and dBC

This setup will display the sound level in one-third octave bands so you can see at what frequencies you have high
levels of sound and dBC that describes the total level of the sound.

3.1.1.1.4 Subwoofer Positioning
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Perform level measurement of your sub to find the sub placement that gives the highest level. Some general
recommendations are also given.

3.1.1.1.5 General_Freq. and Time Response

This wizard will guide you through setting up WinMLS to display frequency and time response of the system you are
measuring, e.g. your loudspeaker, sound card.

3.1.1.2 Level 2: Sound System and Loudspeaker Measurements 

This setup is meant for loudspeaker measurements and sound system calibration. All the features and setups of level 1
are included, in addition the setups below are included.

See table in the Detailed license level description section below for more details.

3.1.1.2.1 Room Acoustics_Reverberation Time

This setup will let you measure reverberation time in one-third octave bands. If you are going to measure other room
acoustics parameters, you must purchase a higher level license.

3.1.1.2.2 Loudspeaker setups

Setups for measuring loudspeaker frequency response and impedance.

3.1.1.3 Level 3: More features e.g. data export supported

See table in the Detailed license level description section below for more details.

3.1.1.4 Level 4: Room Acoustics/Speech

See table in the Detailed license level description section below for more details.

3.1.1.5 Level 5: Full setup functionallity

This version will allow you to save setups where you can specify the file names. This gives a high degree of
flexibility. 
In addition this version has more advanced features for room acoustics and speech post-processing.  

See table in the Detailed license level description section below for more details.

3.1.1.6 Level 6: Advanced/extremely-fast distortion measurement

License level 6 includes all harmonic distortion measurement features.

See table in the Detailed license level description section below for more details.

3.1.1.7 Level 7: Production Control, Building Acoustics

License level 7 includes production control and building acoustics features.

See table in the Detailed license level description section below for more details.

3.1.1.8 Detailed license level description

Level Level 1 Level 2 Level 3 Level 4 Level 5 Level 6 Level 7
Measurement
2 input channels (or more for multi-channel
versions)

1 ch.
only.

x x x x x x

Sampling Frequency [kHz] 48, 44.1
only

48 48 96 96 200 200

Sound card and mic. Compensation x x x x x x x
Access to setting autoname counter and range x x x



24/32 bits record/playback   x x x x x
Calibrate using known microphone sensitivity or
sound level meter

x x x x x x x

Calibrate using Calibrator x x x x x x
Calibration for measuring distance, velocity,
accelleration and force

x x x

Single sine sweep (the exitation signal that gives
the best results)

x x x x x x x

MLS excitation signal x x x x
Single sine sweep duration > 10 seconds for better results in extremely
noisy environments

x x x

Pre/post-filtering of output signal x x x x
System delay up to 15 ms (e.g. for home theater
system) 

x x x x x x x

Scope mode
Sinusoid/Noise Signal generator x x x x x
FFT-based octave band analysis 1/6-th octave
band

x x x x x x x

FFT-based octave band analysis, any bandwidth
desired

x x x x x

Full FFT-resolution x x x x x
IEC 1-octave and 1/3-octave analysis x x x
dBC x x x x x x x
dBA x x x x x x
dBB, linear weighting x x x x x
Triggered measurement (ballon burst, pistol
shot)

x x x x x

Run WinMLS from command line x x x x x

User Interface
Easy user interface x x x x x x x
"Full" user interface (may still use easy user
interface)

x x x

Optional pop-up menu (right click) x x x

Zoom plot using mouse (drag from upper left to
lower right to zoom in, drag in any other direction
to zoom out)

x x x x x x x

Scroll plot using mouse (right-click and drag or
use mouse wheel)

x x x x x x x

Chart settings (setting background colors, etc…) x x x x
Animation of plot x x x x
Control refreshing of text in plots x x x
Advanced plot settings x x x
User configurable wizard generator/editor x x x x x x x
Save data using Measurement Panel Toolbar x x x x x x x
Save data from File Menu x x x x x
Dump raw data to file '_ActiveMeas_' (so it can easily be
opened in other software)

x x x x x

Auto-saving of raw data x x x x x
Frequency response, Polarity, Level (dBC),
System Delay, Time Data

x x x x x x x

Set time window limits using mouse x x x x x x x
Phase response x x x x x x
Frequency response guidelines x x x x x
Step response, Energy-time-curve, Waterfall x x x x x
Export curves (e.g. Magnitude and phase data) x x x x x
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Statistics (Mean value of curves) x x x x x x
Statistics (Average, min/max, STD) on curves x x x
Keyboard shortcuts for fast loading of setups x x x x
Possibility to turn off right-click popup menu and freeze toolbar position
when loading new setup

x x x

Solo active curve when multiple curves x x x
User may control refreshing of curves x x x
User can route different channels to different
plots

x x x

Setups
Sound System Calibration setup and Spectrum
Analyzer setup

x x x x x x x

Loudspeaker impedance x x x x x x
Loudspeaker near field frequency/phase
response

x x x x x x

Musical acoustics setups x x x x x
Export/Import setup (useful to backup setup) x x x x x x x
Store setup using same setup name x x x x x x x
Access to advanced settings when storing
setups

x x x x

Store/Load setups with user defined names x x x
Determine what settings to start WinMLS with (previous settings,
specified setup, etc…)

x x x

Specify what folder setups are loaded from x x
Include Measurements in Setup (store
workspace)

x x

Harmonic Distortion
THD for sinusoidal signal x x x x x
THD for sine sweep (2-5th harmonic, full
frequency range)

x x x x

Separate harmonics up to 5th harmonic x x x
RubNBuzz (> 5th harmonic can be displayed) x x
Compose sum of harmonics (e.g. 10-14
harmonic)

x x

Weighting of separate harmonics x x

Room Acoustics
Display RT60 (as T30) in plot 1/3-oct bands x x x x x x
Display T20 and T30 in Plot or Table, EDT in
plot

x x x x x

Display green/red color if effective deay range (signal-to-
noise ratio) is not sufficient

x x x x x

Display effective decay range (signal-to-noise
ratio) in plot and tables

x x x

ISO 3382 Parameters (RT60, EDT, Tc, C, D, G,
LF, G, LG, IACC )

x x x x

Echo Detection Map x x x
Listen to time data/impulse response (mono) x x x
Schroeder curve plot x x x x
Manual setting of start of impulse response when
computing parameters

x x x

User-defined time limits for room ac.
Parameters

x x x

Late lateral strenght, ISO 3382 Calibration to
find Strength

x x x

Deconvolution of signal from file x x x
1/3-oct bandwidth x x x x x x



Oct., Low-Mid-High, Broadband (bandwidth) x x x x

Speech Parameters
RASTI (assume low bakground noise) x x x x x x
STI (assume low bakground noise, STIPa is a
subset of STI)

x x x x x

%Alcons (STI-based) x x x x
STIr Male, STIr Female (include effects of
masking, etc.)

x x x

MTI, MTF, MTIr, MTFr x x x
Background noise influense calculated from calibrated
measurement 

x x x x

Calculate Speech parameters allowing user to change speech/background noise
level as post-processing

x x x

Sound System Calibration
Spectrum Analyzer (12th. oct) x x x x x x x
Surround, Sub, Stereo Sound System x x x x x x x
Live (real time)  check during performance x x x x x x
Fast quasi-continuous sound system
measurement

x x x x x x

Frequency-dependent Time Window x x x x
Fastest continuous sound system measurement (multi mode, requires
>1.5 GHz processor)

x x x

Loudness x x

Calibration
Audiometer x x x

Building Acoustics
Airborne Sound Reduction  ISO 140-4:1997 and
ISO 717-1:1997

x

Production Control
Passed/Failed testing in single plot x x x
Access to Test Options x
Absolute limit curves x x
Tolerance limit curves x

3.1.2 License Transfer

Once you have registered, you may transfer the license from one machine to another without key disks or transfer files.
This is done from the Help->License Options... dialog, and is only possible to do after the software is registered (not
when it is in trial mode). 

For example, this option allows your version of WinMLS to be used on both a laptop and desktop PC. This would be
particularly useful for customers who are not based in any one location or office, the unlock code can simply be
quoted over the phone or via email. This way the license can be transferred back and forth as necessary.

On the license screen, the  option will be enabled. 

27



Click on  and enter the serial number of the unregistered copy of the software on the
target PC. You have to install WinMLS on the target PC to obtain this number.

Once the target serial number has been entered, click the  button. A message will be displayed
confirming the transfer. WinMLS will then invalidate the license on the source PC (i.e. preventing the software from
running), and generate the unlock code for the target PC. 
By entering the unlock code on the Register License screen of the evaluation version on the target pc, the license
transfer process will be complete and the software fully functional. 

3.1.3 What if the new unlock code does not work?

If the license transfer operation fails, please contact us at support@winmls.com and send the following information
(important):

Destination serial number
The new unlock code (obtained with the transfer license operation using the destination serial number).

3.2 Loading the setup for your application

After completing the registration and running WinMLS, you will first see the dialog box shown below.

Note: If you do not want this dialog to be opened the next time you start WinMLS, make sure

 is checked.

If you click the  button, you will see the dialog box shown below.



You can also open this dialog from Setup->Load... if it is not displayed. The easiest way of using WinMLS is to load
a setup that contains the settings for your application, e.g if you want to use WinMLS for measuring reverberation
time, load the setup named Room Acoustics_Reverberation Time. There are also setups for measuring the frequency
response of a sound system, loudspeaker impedance, building acoustics, production control, etc...

Now select the setup for your type of measurement application through the dialog shown above. If you cannot find a
setup for your type of application in the list, please see www.winmls.com/support where we plan to post new setups
or contact us.

Click the  button to load the setup, the Load Measurement Setup dialog box will be closed. 

3.3 Turning off Windows notification sounds

If you want to avoid the Windows notification sounds to be sent to the output used for measurements, you can either
turn the sounds off or play them using another sound card (if you have more than one card in your system). To play the
notification sounds using another sound card, you need to set this sound card as the preferred device for your system.
You can turn off the system sounds as explained below.

For Windows 2000/XP:

Click the  button to find the Control Panel  (you may have to select Settings first). Then
double-click on the folder Sounds and Audio Devices shown below.

(It may be named Sounds only).

Then click on the list field under Sound schemes. When the list appears, choose No Sounds as shown below.
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If you wish to play the notification sounds using another sound card instead of turning them off, click the Audio tag
shown in the figure above and select the preferred sound device.

For Windows95/98: 
Open the Control Panel, find the multimedia settings. Find Settings and choose No sounds. 

Windows NT:
Open the Control Panel, click the Sounds icon. Find the dialog box Sound Properties. Click Windows under Events.

4 Sound card settings
The first section describes how to set the sound card settings for a general sound card. If you are going to use
WinMLS for analysis only, and not for performing measurements, you may skip this section.

If you are using Windows XP as operative system and, you can optimalize your PC for sound card applications by
following the instructions given at this link:
http://www.musicxp.net/tuning_tips.php
It is really worthwile having a look at this website, especially if you are having problems getting you sound card to
work properly.

4.1 Sound card settings for general sound card

If you have a Digigram VXpocket/VX222 sound card, you may skip this section and go to the next section that will
explain how to use this specific sound card. The Tested Sound Cards section of the documentation contains the sound
cards that have been tested with WinMLS. This may give you useful information about how to use your sound card
with WinMLS.

To do: Go to Setup->Load... and find the sound cards section as shown below

Select the sound card you have from this list. When you have done this, you may skip the sections below. But if you
have problems using the sound card you should go through these sections.

To do: If you did not find your sound card on the list of setups, load the setup named Sound Cards_Load if error
with setup as shown in the figure above. This setup is loaded as default if there is an error when loading a setup.



Open the dialog box shown below from Measurement->Sound Card....

 

The sound card settings will be explained step-by-step in the next sections. Keep this dialog box open. 

4.1.1 Step 1 – Select input device

The input device name is usually similar to your sound card’s name. If you are unsure what to select, you may choose
the most likely device, or read the PC or sound card documentation.
 

4.1.2 Step 2 – Select output device

This is very similar to setting the input device. 

4.1.3 Step 3 – Select mixer (volume control)

The three options shown below will be explained in detail in the following sections.

4.1.3.1 Let the WinMLS mixer control the Windows mixer

If your sound card supports the Windows mixer (most sound cards do), we recommend that you let WinMLS override
and control the Windows mixer as shown below.

When this is selected, step 3b, 3c and 3d will be displayed as shown in the figure below.
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This allows you to be able to change the analog input and output volumes from within WinMLS.
Note that if you are using a LynxStudio card you should not use the WinMLS mixer and instead select No software
mixer.

If your sound card does not support the Windows mixer, a message will appear informing about this. Note that some
sound cards may have problems controlling the Windows mixer. If this is the case you may use one of the other
options in 3a, e.g. No software mixer or Use manufacturer mixer.

4.1.3.1.1 Step 3b – Select mixer input line

If you are not using the WinMLS mixer, it is not possible to set the input line shown below. Depending on the sound
card, you may choose between only one or several input lines as shown in the figure.



                                           

Some of the names may be different than those shown. Usually if you want to use the line input of your sound card
you can find it as Line In or Line, and if you want to use the microphone input you can find it as Mic or Microphone.

There are some exceptions, the VX pocket/VX222 cards only have one analog input that can be used as both line and
microphone input, thus the input line is just called Analog Input.

4.1.3.1.2 Step 3c – Select mixer output line

If you are not using the WinMLS mixer, it is not possible to set the output line. Otherwise, the output line usually has
only one choice, and it is usually called Wave or Wave Output.

4.1.3.1.3 Step 3d – Mixer calibration (optional)

You should skip this part now, it will be covered later.

4.1.3.2 No software mixer

If your sound card does not support the Windows mixer or if you have problems using the mixer, you may set it not to
use any mixer

4.1.3.3 Manufacturer sound card mixer

You may set-up WinMLS to open the mixer application from the sound card manufacturer when the  button (found
on the Standard Toolbar) is clicked. How to do this is shown below.

Click the  button to select the mixer application.
You will then be asked to specify the path of the mixer application. Consult your sound card documentation on how to
find this.
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4.1.4 Number of bits

The number of bits used for recording (input) and playback (output) is usually set to 16, but can be set to 24 or 32. If
your sound card does not support more than 16 bits, an error message will be given when attempting to measure using
24 or 32 bits resolution. 

Note that even if your sound card supports 24 bits it is not certain that WinMLS will support it.

4.1.5 Specific sound card settings

If your sound card requires special settings, you can click the  button to display all the sound card settings
as shown.

Make sure settings such as 3D-sound is turned off (not present in the figure above).

Important! If the setting below is selected in step 3,

the setting  should be checked so that you avoid feedback. This feedback may
otherwise occur when you are not performing any measurement with WinMLS (the Windows mixer can be set to
monitor the input signal and this may generate feedback if it is not turned off).

4.1.5.1 Line selection

The default setting line selection setting is shown below. 

The purpose of this setting is that WinMLS will make sure the volume is set only for the selected mixer line (for
example line in or microphone). But it has been reported that this default setting will not work on a few sound cards
(some of the Sound Blaster cards may have this problem). Therefore when you start measuring, if controlling the input
or output volume from WinMLS seems to be impossible, you should try one of the other alternatives that are present
to handle bugs in the sound card drivers or operative system. We recommend that you see the Specific sound card
settings reference section and try the other available settings. It should be possible to fix, especially if you inspect the
Sound Card Windows mixer while trying the different alternatives. If it is not possible, the alternative of turning the
WinMLS mixer line selection off is explained below.

If you have followed the procedure in this section, the sound card settings should now be correct. Click  to
close the Sound Card Settings dialog.

Now store the changes. Go to Setup->Store..., make sure the setup name is ‘Sound Cards_Load if error with setup’.

Click the  button to exit the dialog.



4.1.6 Special case: Using the Windows mixer directly

If your sound card supports the Windows mixer, skip this section since this enables the WinMLS mixer to control the
volume. If you cannot get WinMLS to control the volume properly, you can use this method (needed only in very rare
cases).
The Windows mixer may be found in the Multimedia folder in Accessories, it may also be found in the Control
Panel. Some sound cards only support their own volume control that is found in the specific sound card folder. A
typical volume control is shown in the figure below.

The volume control figure above shows the output volume. When using WinMLS you only use the Wave Output
shown in the figure above. It is a good idea to mute the other volume controls as shown in the figure above. But do not
mute neither the Wave Output nor the master Volume Control.

We also need to adjust the input volume. For this example it is found from the menu in the figure above. Go to
Options->Properties… and Adjust volume for recording. Then the following window is displayed:

Select the input you would like to use, either line-in or microphone. While you use WinMLS, you probably need to set
both the input and output level. You should therefore have one of each open at the same time. To do this, just open a
new volume control in addition to the one already open.
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4.1.7 Multi-channel (>2 channel) measurements

To set WinMLS to measure multi-channel (e.g. 4 channels), go to Measurement->Settings… and select 4 ch. as
shown below

In the general case, the WinMLS mixer should not be set to control the Windows mixer since the WinMLS mixer can
only control 2 channels. Go to Measurement->Sound Card… and in step 3 shown below, select either ‘Open
manufacturer mixer’ or ‘No software mixer’. The exception is if you are using the Digigram VXpocket 440, then
select ‘Let the WinMLS mixer control the Windows mixer’, read more about this in the Using VXpocket 440 for 4-
channel measurement section.

Click the  button and select sound card recording devices shown below.

As has been mentioned, for a greater than 2-channel measurements WinMLS does not control the input or output
levels. Therefore you must set the levels using your sound card mixer application or the Special case: Using the
Windows mixer directly.

4.1.8 Settings for doing a 1 channel transfer function/impulse response measurement

Connect the measurement microphone to sound card input channel 1 (left).

If you are using a sound card with stereo input, connect the sound card output ch. 2 to sound card input ch. 2. This
internal loop gives the reference measurement. 
If you are using a sound card with mono input which most microphone inputs are, go to Measurement->Settings...
and select 'Generator' as shown in the figure below. You should then in step 7 correct for the sound card frequency
response and delay.

Note: This method may not be as stable as the metod using ch. 2 as reference when doing repeated measurements
(sound card dependent).



Connect the sound card output ch. 1 (left) to the sound system input. Left and right ch. of the sound system should be
measured separately.

4.2 Sound card settings for Digigram Vxpocket

The VXpocket v2 is the sound card we sell and recommend for measurements using a laptop PC. We also sell a
similar PCI card for stationary PC measurements named VX222 and a 4-channel card for laptop called VXpocket 440.
You can follow the procedure in this section for the VX222 and VXpocket 440 cards as well as the VXpocket v2 card.

4.2.1 Install the VXpocket

Insert the VXpocket card in one of the PCMCIA slots on your laptop. Attach the cables.

Important Point Number 1! Fasten the cables to the parallel port with the two screws that comes with the sound card
as shown in the figure below. You may alternatively connect to the com port or screen output connector. This will
make it more difficult to break the connection.

Important Point Number 2! If a Found New Hardware wizard is displayed, just click the Cancel button to exit. It
will not be used to install the driver. 
Use the following instructions to install the sound card drivers. If you have received a CD from us, the driver should
be found on this CD. If you don’t have a CD, download the latest drivers from www.digigram.com. It is not
recommended to use older drivers.
Run the driver file and follow the installation instructions using default settings.

4.2.2 Select VXpocket as the sound card to be used

Go to Setup->Load... and find the sound cards section as shown below

Now select the VXpocket setup shown at the bottom of the list in the figure above to load the settings for your card.
Go to Measurement->Sound Card.... If error messages are displayed, just click the OK button to exit these until the
dialog shown below is displayed. Now select the settings shown in the figure below.
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Important Point Number 1!  The name of the device is VXpocket In #1 and VXpocket Out #1 as shown in step 1
and 2 above. Do NOT select the device named VXpocket Audio Card (WDM). If you cannot find the right device
under the list in step 1 and step 2 above, exit and restart WinMLS. If this did not help, try to restart your PC.
Important Point Number 2! In step 3b, make sure Analog Input is selected (not Digital Input).

Now the mixer gain steps will be defined for the VXpocket sound card. More details about this will be explained later.
Click the  button in the Sound Card Settings dialog and set the Sound card mixer gain steps
part as shown below.

When this is done, click  to exit the dialog boxes. 

4.2.3 Connecting the microphone to the VXpocket without using a microphone preamplifier

As default, the VXpocket is set with line level inputs. This is suited for doing electrical measurements. If this is what
you want to measure, you can skip this part.
This section will explain how the VXpocket input can be changed from line input to microphone input (If you are
using the VX222 PCI-card, note that it features a selectable digital gain up to +18dBV, but cannot be used as a
microphone input).

Note: If you are measuring very high sound pressure levels, you may use the line input as it is and can skip this part.

Note: If the PC is set to sleep mode, the microphone gain may be turned off. You can solve this by restarting the PC.
This seems be a problem with the Digigram driver and may be fixed in future versions.

The VXpocket has the following input gains : 0 dB is the line gain, +30 dB to +51 dB in 3 dB steps are the
microphone gains.

4.2.3.1 For a gain of 0 dB, a +10 dBu maximum input signal gives 0 dBFS.

For a gain of +30 dB, a - 20 dBu maximum signal gives 0 dBFS.



For a gain of +51 dB, a - 41 dBu maximum signal gives 0 dBFS.

If you have purchased a package from us that includes a microphone or if you own a microphone you want to connect
directly to the VXpocket card, follow these instructions. The battery driven microphone we sell with the software is
meant to be connected directly to the VXpocket left input (channel 1). We also sell microphones that need a battery
driven phantom power supply to work with this card. If you have such a phantom power device, connect the
microphone to the phantom power input, then connect the phantom power output to the VXpocket left input (channel
1).

Open the VXpocket mixer as shown below (consult your VXpocket documentation on how to open the mixer, usually

it can be opened by double-clicking the blue Digigram icon  on the Windows taskbar).

Click the  button to open the dialog shown below.

We will only modify the input level. The output level should not be changed from the default settings. The default
values are shown in the figure above, the modified values are shown in the figure below.
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The Nominal In value determines if the VXpocket input is line or microphone. The Nominal In is set to 4.0 dBu as
default to operate as line input. If it is set in the range from -20 dBu to –41 dBu, it will operate as microphone input.
This is what we want, so change the Nominal In value from 4.0 dBu to –41 dBu.
Finally set Headroom In to 0.0 dB as shown in the figure above.

Click  to close the dialog.

Note: The input level in microphone mode will only work if the slider for channel 2 is set to minimum. In the
WinMLS menu, go to Toolbars->Levels (and Mixer) to open the dialog and set the Input Ch. 2 slider to minimum.
The Input Ch. 1 slider will set the level for both inputs in case you are using two inputs. In other words, channel 1
and 2 input volumes are linked in microphone mode.

The mixer has only a few gain settings when it is set as microphone input. These mixer gain steps can be determined,
and you should do this if you want to set different input levels while maintaining the calibration. Go to Measurement-
>Calibration…, click the  button shown below to complete the process of finding the gain steps.



Note: Below is a plot of some gain steps. It shows that above 2 kHz, the microphone gain is not flat. The deviation
between the highest gain and lowest gain is > 1 dB at 10 kHz and 4 dB at 20 kHz. This is a characteristic of the
VXpocket microphone gain and Digigram explains that it is related to the small size of the sound card. So be careful if
using the microphone gain steps above 5 kHz if you expect a flat frequency response when using the highest
microphone gains.

Important! The calibration should always be redone after changing the VXpocket level as explained above. For more
details, see the Calibration… section.

4.2.3.2 Standby mode

The Digigram driver may have the problem that if your PC goes to standby mode, the PC must be restarted in order to
perform a WinMLS measurement with the microphone input. If this is a problem we strongly suggest that you make
sure that your PC does not automatically enter standby mode.

4.2.3.3 Advanced information about the mixer levels

The information in the section above is enough to get started, but additional information is given below. Let N be the
nominal input level, and H the input headroom.
The following must be done to switch the input to microphone gain:

• N + H = -41 (e. g. Nominal = -47 dBu and Headroom = 6 dB),
• if the fader Analog In is set to a gain higher or equal to 0 dB, the microphone gain is +51 dB.
• if the fader Analog In is set to a gain lower than 0 dB, the micro gain is set to a value from +30 dB to + 51 dB

in 3 dB steps.
• the Analog In balance fader should not be used in microphone gain mode, as this will modify the microphone

gain value.

4.2.3.4 Using VXpocket 440 for 4-channel measurement

We sell and recommend the VXpocket 440 card for portable 4-channel measurements where you need all channels to
be synchronized (find correct delay times).
To set WinMLS to measure 4 channels, go to Measurement->Settings… and select 4 ch. as shown below

For the VXpocket 440 to be synchronized (the delay is the same for all input channels), the WinMLS mixer must be
set to control the Windows mixer. Go to Measurement->Sound Card… and select the settings shown below
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Click  and select the settings shown below.

For a greater than 2-channel measurements, WinMLS does not control the input or output levels. Therefore you must
set the levels using the Digigram mixer shown below. Open the mixer from the blue Digigram icon on the task bar

.

Set the Analog In sliders to set the level for channels 1 and 2. To set the level for channels 3 and 4, you need to select
the VXpocket 440 Mixer #2 from the menu as shown below.



If WinMLS is unstable, this is probably because the input level is set to the minimum. Make sure the levels are set
above the minimum value for all input channels that are to be used.

After you are done go to Options->Save current configuration as default to save the Digigram mixer settings so
they are the same the next time you turn on you computer.

4.2.3.4.1 Microphone level for the VXpocket 440

The VXpocket 440 has three input gains: 0dB, +30 dB, and +48 dB.
0 dB is the line gain, +30 dB and + 48 dB are the microphone gains.
For a gain of 0 dB, a +10 dBu maximum input signal gives 0 dBfs (digital full scale).
For a gain of +30 dB, a - 20 dBu maximum signal gives 0dBfs (digital full scale).
For a gain of +48 dB, a - 38 dBu maximum signal gives 0dBfs (digital full scale).
Let N be the nominal input level, and H the input headroom.
The following must be done to switch the input to microphone gain:

• N + H = -38, e. g. Nominal = -44 dBu and Headroom = 6 dB,
• if the fader Analog In is set to a gain higher or equal to 0 dB, the microphone gain is +48 dB.
• if the fader Analog In is set to a gain lower than 0 dB, the microphone gain is +30 dB.
• the Analog In balance fader should not be used in microphone gain mode, as this would modify the

microphone gain value.

4.2.3.5 Old driver version

If you are using an older version of the VXpocket driver, the dialog box will look like below

We recommend that you update your driver. If you are still using this older version, set it to Microphone input by
setting Nominal In less than -27.0 (for example to –30) and Headroom In to 0.0.

4.2.3.6 Save the configuration

After doing the changes, you should save the setup from Options->Save Current configuration as default as shown
below.

Click  to close the dialog.
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4.2.4 General information about the Digigram cards (VXpocket, PCXpocket, PCX9 and VX 222)

Issues common to these cards for usage with WinMLS are described below. Please also read the section in the Tested
Sound Cards section describing the specific Digigram card you plan to use.

The WinMLS Audio Mixer is supported, but is not able to choose between analog and digital input. This is done from
the windows input mixer or the Digigram mixer.

4.2.4.1 Digital input/output

The digital mode is S/PDIF. Digital mode has been tested to work with the output when connecting to some external
D/A, but it may not work for input. We tested that a digital loop-back measurement cannot be performed. 

4.2.4.2 Note about calibration

We found that the VXpocket card gives distortion (clipping) when we use a full scale sinusoidal output (0 dBFS) with
the output mixer set to maximum. To avoid this distortion, reduce the output level by 6.5 dB either from the mixer or
by setting the dBFS-value to –6.5.

4.2.4.3 Selecting analog or digital gain

On VXpocket, it is possible to use both the analog gain and the digital gain when the analog input is set in microphone
mode.
The default in the latest drivers is analog mode. But note that when using high levels of analog gain, the frequency
response may not stay flat above 10 kHz.

You can change from analog to digital gain in the configuration file PcxNPWav.ini.

The path to PcxNPWav.ini depends on the O.S. :
- under Windows 98/Me/NT4, it is situated in : <O.S. drive>\PCXNP\VX
- under Windows 2000/XP, it is situated in : <O.S. drive>\<Windows directory>\System32\Drivers\Digigram\VXKit

In section [General] of PcxNPWav.ini, set the parameter :
Use Line In Digital Volume=1
then you have to reboot the system.

Don't forget that it is only for microphone mode, in line mode use only the control "Line Input Volume" which already
acts on digital gain (there is no analog gain for line mode).

4.2.4.4 If you need sample-accurate initial time delay

If WinMLS is not in loop-back mode (See the Measurement->System Delay...), note that the initial time delay of the
sound card varies with maximum one single sample. This means that if you want the exact same initial time delay
from one measurement to another you should make sure WinMLS is in loop-back mode (it uses channel two for the
synchronization loop-back).

4.2.4.5 Breakout cables

The breakout cables of the VXpocket and PCXpocket may be damaged if you do not screw it to the PC using the
screws that come with the cable. A new cable typically costs $ 100.



4.2.4.6 Heating of the card may slightly affects the absolute level calibration

The VXpocket (and possibly the PCXpocket) card can get quite hot (45degC) when positioned in the PC Card slot
with anther PC card. This affects the input sensitivity slightly. Tests have shown that the input sensitivity is directly
related to the card's temperature and stabilizes after about one hour. The change in the input sensitivity is
approximately 0.001dB/degC. The maximum difference seems to be ~0.015 dB. This is not significant for acoustic
measurements but electrical measurements may demand better accuracy. In this case it is recommended to leave the
computer on for about 1 hour before performing critical measurements. The output sensitivity is unaffected by
operating temperature of the sound card.

4.3 Sound card settings for Sound Blaster MP3+

This USB sound device worked fine in our tests except for the high crosstalk between input and output. This crosstalk
makes this sound card unsuitable some types of measurements e.g. low values of STI. 
We have made WinMLS setups that loads the settings that give the best results for this card as will be explained
below.

4.3.1 Installation

These points are very important:
• You must install the Sound Blaster drivers from the CD. Although it seems to work without the installation

CD, do not just use the drivers that are installed when plugging in the USB-device.
• Before using the card, make sure that you do not have anything connected to the headphones output otherwise

there will be no signal played back in the line output. 
• There is a small switch near the USB input, this must be set in the position Digital/Analog if you want to use

the line or microphone input as shown in the figure below.

4.3.2 Select mp3+ as the sound card to be used

After installing, load a for this card from Setup->Load... under the Sound Cards section as shown in the figure
below.

Important: If you are going to measure impulse or frequency response, you need to connect a loop-back from the
right channel output to the right channel input as shown in the figure below.
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The phone cable shown in the figure above can be purchased in most stores that sell electronic equipment.

You may also set the sound card settings manually. 
Go to Measurement->Sound Card.... If error messages are displayed, just click the OK button to exit these until the
dialog shown below is displayed. Now select the settings shown in the figure below. 

In step 3b in the figure above we have selected Line-In, if you want to use the microphone input on the sound card
you should instead select Microphone. In the figure below you see the microphone input plotted in blue and the line
input plotted in red.

Note: We did not get very good results when using generator as reference 

and when Measurement->System Delay... is set to one of the two settings shown below.

Any other setting seemed to give good results.

Note: If you want to correct for the mic. input, first set the output mixer to a very low level (for example -44 dBFs) to
avoid distortion. 



Important: We only got good results with sampling frequency 48000 Hz. This is usually the default setting, but be
sure go to Measurement-> Settings... to check that the sampling frequency is set to 48000 Hz.

4.4 Calibrating your sound card

This section explains how the sound card can be calibrated. Please follow the procedure in the order given, first do the
mixer calibration (if desired), then the level calibration.

If you have not already loaded a setup in the Sound Cards section,  to Setup->Load... and load one of the setups in
the Sound Cards section (if you cannot find your sound card then load another sound card setup).

4.4.1 Mixer calibration

Go to Measurement->Calibration… and click the  button shown below.

Now follow the instructions to complete the calibration for the input mixer levels.

Now repeat the same procedure for the output mixer levels by clicking the button shown below. 

This calibration may not be possible for some sound cards. If the calibration is not successful you will be notified that
it has failed.

Note: If you after testing different volume settings find that there is an error with the calibration, this may happen for
the lowest volume settings and these can be deleted. The calibration file can be edited manually. To do this, go to the
folder where WinMLS is installed and find the subfolder named Mixer. Open the file in a text editor, e.g. Notepad.

4.4.2 Level calibration

To do this calibration you will need a voltage meter.

4.4.2.1 Calibrate the input

Go to Measurement->Calibration… and click the button shown below.

47



In the new dialog box, click the  button to open the dialog shown below. Now follow
this procedure step by step.

Note: In step 2 above it may give better results if you use 100 Hz instead of 1000 Hz because in general a voltage
meter may be more accurate for 100 Hz.

4.4.2.2 Calibrate the output

Go to Measurement->Calibration… and click the button shown below.

In the new dialog box, click the  button to open the dialog shown below. Now follow
this procedure step by step.

4.4.2.3 Wizard

Go to Measurement->Wizard->Editor… to where you can write comments about the sound card. These comments
will be displayed to the user when the setup is loaded.

4.4.2.4 Store the setup

Go to Setup->Store… to open the dialog for storing the setup. Now type the name of the sound card and the input
used (line or microphone). For the setup to be stored under the right section, first part of the setup name must be
‘Sound Cards_’.

4.5 Testing your sound card.

If your sound card is not found in the list of sound card setups, this section will explain how you can make such a
setup and test it.



4.5.1 Making a setup for your sound card

Go to Setup->Load... and see if you can find your sound card in the Sound Cards section. If  you could not find your
sound card in the sound card setups you should make your own sound card setup, this section explains how to do this. 

Please follow the procedure in the given order.
Go to Setup->Load… and load one of the setups in the Sound Cards section, preferably the setup named Sound
Cards_Load if error with setup.

Now go to the Calibrating your sound card section above and follow the procedure. First do the mixer calibration (if
desired), then the level calibration.

When finished making a setup, you must save it using Setup->Store.... Make sure that you start with Sound Cards_,
an example is shown below.

After storing the setup you may use Setup->Export… to export the setup if you want to make a backup of it. If you
want to help us and other WinMLS user, you can e-mail it to us and we may distribute this setup to other WinMLS
users. Our goal is to provide setups for as many sound cards as possible.

4.5.2 Multi-channel sound card

When testing a multi-channel sound card it is in some applications important to make sure that the input channels are
sample-synchronous. This means that the is no delay between the channels.
Note: Some data acquisition boards (that are not sound cards) is using multiplexing. Sound cards are not using this
method. A multi-channel sound card consist of stereo pairs where each stereo pair contains two channels. All stereo
sound cards (2 channels) should be sample-synchronous since they only have one stereo pair. But a sound card with
more than two input channels should be checked.

To do this check connect output channel 1 to input channel 1. Then connect output channel 2 to input channel 3. 

Perform a 3 or 4 channel measurement in WinMLS where you measure channel 1, 2 and 3. Now compare the impulse
responses of channel 1 and channel 2. If they are exactly on top of each other, then the input channels are sample-
synchronous.

Perform multiple measurements to make sure the result is the same for each measurement.

4.5.2.1 Example: Measuring M-audio FW 1814
Go to Setup->Load... and load the setup named General_Freq. and Time Response. Go to Measurement-
>Settings… and select 4 ch. in the upper right corner as shown below.

In step 5 select the sampling frequency you wish to use, e.g. as shown below.
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Go to Measurement->System Delay... to open the dialog box shown below.

In this dialog you can select any of the choices above since we only want to measure the delay between the channels.

Click the  button in the dialog box shown above if you like more information about measuring the system
delay.

Go to Measurement->Sound Card... to open the dialog box shown below. 

Press the  button to assign the input channels as shown in the figure below.

Now perform several measurements and compare the impulse responses of channel 1 and channel 2. If they are exactly
on top of each other, then the input channels are sample-synchronous.

The figure below shows output channel 1 connected to input channel 1 and output 2 connected to channel 2, which
means the same stereo pair.



This confirms that the input channels 1 and 2 are sample-synchronous, which would be expected.

The next figure shows output channel 1 connected to input channel 1 and output 2 connected to channel 3, which
means across two different stereo pairs.

This shows a 1 sample time difference between input channel 1 and 3. This means that these channels are not sample-
synchronous.

If the sound device has more than 4 inputs, you can control the other by switching channels in the multi-channel input
device setup. In the figure below we have selected stereo pair 5/6 to be measured in Ch. 3-4.

In this way you can control that all available stereo pairs are sample-synchronous.

The figure below shows channel 1 versus channel 5 (ch. 3):

The next figure shows channel 3 versus channel 5:
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If they are not sample synchronous but the difference is stable (e.g. always one sample), this difference may be
corrected as a post-processing. It depends on what application you are using it for.

5 Tested Sound Cards
Sound cards that have been tested with the WinMLS software is presented and recommendations are given. 

If you already have a sound card you wish to use, we recommend that you try to find the chapter about this sound card
in this documentation (you may use the search function). If you have a sound card that is not on the list of tested sound
devices, we recommend that you test it. If you follow the ‘The first measurements walk-through’ section you will learn
how to best use this sound card.
Please report to us the results of your test. Measurements of some sound devices are found in the WinMLS folder
under Measurements->SoundCards (if you do not find them, you must download the example measurements from
our homepage).

We should have chosen to use the term “sound device” instead of “sound card” since “sound card” is not a good word
for the range of possible sound hardware (e.g. a USB sound devices is not a card). Still, we use the term sound card,
since it is so often used.

5.1 Recommended Sound Cards

Most of the cards that have been tested will give decent results for ordinary transfer function measurements (e.g.
sound system calibration and reverberation times), except for the very high and low frequencies.

If you are going to purchase a new card we recommend that you study this document and find a suited card for your
type of measurements. The Sound Blaster cards should in general work fine, note that some cards (SB Live, PCI128
and other Sound Blaster compatible cards) work best at sampling frequencies 48, 24 and 12 kHz. This is because they
work internally only at 48 kHz and other sampling frequencies (except for 24 and 12 kHz) are obtained by an internal
frequency conversion.

A USB device has the advantages that it can be used on a laptop, and easily be moved from one PC/laptop to
another.We tested the USB device MP3+ and Creative Extigy, and were quite pleased, the price makes it a good
alternative.

If you are doing high-end measurements you should read the recommendations below and also the information given
below about the cards that you plan to choose.



5.1.1 High-end measurements

For a high-end stationary system, we recommend the Digigram VX 222 or one of the high quality analog cards or
digital cards (e.g. Prodif). You may order these cards from by contacting us. They will be shipped directly to you from
Digigram, so we are able to give you a good price. Please note that with the card Lynx 2C, you are able to perform
measurements with a sampling rate of up to 200 kHz, in addition it has 6 input channels and can be extended to 24
input channels. This card is very good and you may also order this card by contacting us.

For a high-end portable system, we recommend the card VX Pocket by Digigram. Alternatively, you could use a
laptop with a docking station and install one of the high quality sound cards listed below. 

We recommend the two Digigram cards VXPocket (laptop) and VX222 (stationary PC) since they are of high quality,
support most of the WinMLS features (such as level and mixer calibration) and have been tested well.

The VXPocket is a PCMCIA card to be used in a laptop and the VX222 is a PCI card to be used in a stationary PC. It
is an advantage that the cards have the same drivers, this means that if you have both a stationary and portable system,
they will be very similar. The card has a stereo line/microphone input. Note that Digigram has released a 4-channel
PCMCIA card, VXpocket 440 that is ideal for 4-channel measurements. The cards can be ordered from us.

5.2 Sound Cards that do not work with the MLS method

Note that you can use most the sound cards in the list below for the other measurement methods. If you use the sine
sweep method, you must use a single sweep only and no averages.

Some sound devices do not support simultaneous play and record and therefore cannot be used with WinMLS. Most of
the newer cards support simultaneous play and record operation, but may not work with WinMLS due to errors in the
hardware or with the driver.

The list below shows the cards that have been tested and been shown not to work with the MLS method. If this is
because of a bug in the sound device driver, note that the sound device may work with future releases of the driver. It
is also possible that some of these have an internal sampling of 48 kHz, this means that they will work properly only at
sampling frequencies 48, 24 and 12 kHz.

USB Pre – sampling frequency input/output is not equal
Edirol Ua-1A – sampling frequency input/output is not equal
Roland USB Audio Interface (UA-30) – sampling frequency input/output is not equal
SonicPort – This is a device for the USB port. It seems to work fine, but in full duplex mode it does not work properly
and we were not able to get correct measurements using this device. It is probably because sampling frequency
input/output is not equal.
LP600 – did not seem to work.
Turtle Beach Montego – sampling frequency input/output is probably not equal. Sampling frequency 48 kHz might
work.
Turtle Beach Montego 2– sampling frequency input/output is probably not equal.  Sampling frequency 48 kHz might
work.
Yamaha DS-XG – sampling frequency input/output is probably not equal. Sampling frequency 48 kHz might work.
Event Darla, Layla and Gina – sampling frequency input/output is probably not equal.
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5.3 Sound Cards that have been tested to work with WinMLS

Sound Devices
PCI (stationary PC)

Chan
-nels

Mix-
er

Mic.
Input

Price AD/D
A bit

Fs
[kHz]

Nois
e

Frequency
Range [Hz]

VX222 (Digigram) 2 Yes Adj. $430 24 48 ++ 5 – 24k
Echo Layla 20 8 No
Echo MIA 2 No No ? 16/24 96 ++ 3 – 45k 
TB Santa Cruz 2 Yes Yes ?   ? 48 + 8 – 23k
Terratec EWX 24/96 2 Yes No ? 24 96 +++ 3 – 46k
Card Deluxe 2 No No ?   24 96 +++ ?
Sek’d PRODIF 96 PRO 2 No No ?   24 96 +++ 5 – 46k
LynxTWO 6 No No $1100 24 215** +++
Lynx L22 2 No No 24 215** +++
Waveterminal 192X 2 Yes No $399 24 48 ++ 2 – 23k
Delta 1010LT 8 Yes Yes 24 96 ++
RME Hammerfall DIGI9652 24 No No $775 24 96 DIG ?
Sonorus STUDI/O 16 No No $849 24 96 DIG ?
MULTIWAV PRO18 2 No No ? 24 48 DIG ?
Soundtrack 128 Ruby 2 Yes Yes $300 20 48 +(+) 9 – 20k
Midiman DMAN 2044 1 No No $280 20 48 ++ 10 – 22k
Marian Marc 8 8 No No $500 24 96 ++
SEK’D ARC 88 8 No No $500 16 48 + 20 – 20k
Ensoniq Audio PCI 1 Yes Mono $40 16 48* + 5 – 22k
Sound Blaster PCI64 1 Yes Mono $40 16 48* + 5 – 22k
Sound Blaster PCI128 1 Yes Mono ? 16 48* + 5 – 22k
SB Live Value 2 Yes Mono ? 16? 48* + 7 – 16k
SB Live Platinum 2 Yes Mono ? 16? 48* + 7 – 20k
ISA (stationary PC)
TB Monterey/Tahiti 2 Yes No $200 18 44.1 + 0 – 20k
TB Fiji/Pinnacle 2 Yes Stere

o
$350 20 48 ++ 5 – 23k

Sound Blaster AWE 64 2 Yes Mono $70 16 48 - 10 – 21k
Sound Blaster 16 2 Yes Mono $20 16 44.1 - 50 – 20k
Sound Blaster AWE 32 2 Yes Mono $30 16 44.1 - 20 – 19k
SEK’D ARC 44 4 No No $250 16 48 0 60 – 19k
Crystal   CS32BA11  2 No Mono $30 16 48 - 20 – 20k
ESS 1868 1 Yes Mono $20 16 44.1 - 50 – 9k
CARDD PLUS 2 No No $400 18 48 +(+) 10 – 22k
TB Multisound Classic ? ? ? ? ? ? ? ?
USB
USB Duo 2 Output Yes 24 96 ++ 4-21k
USB MobilePre 2 Output Yes 16 48 + ?
USB Quattro 4 Output Yes 24 96 ++ 4-21k
M-audio Transit 2 Yes Yes 24 48 ++ 3-23k
Creative SB LIVE External 2 Yes Yes 24 96 ++ 4-21k
Creative Mp3+ 2 Yes Yes $50 16 48 + 2-21k
Creative Extigy 2 Yes Mono $130? 24 48 ++ 3 – 23k
Egosys U2A 2 No - - - - - 1.5 – 23k
Firewire
MOTU 828 8 ? - - - - - 5 – 23k
PCMCIA (Laptop)
VXpocket (Digigram) 2 Yes Adj. E610 24 48 ++ 5 – 24 k



VXpocket 440 (Digigram) 4 Yes Adj E850 24 48 ++ 5 – 24 k
PCXPocket V2 2 Yes No $1400 20 48 +(+) 5 – 23 k
Sound Chips/Laptops
Yamaha AC-XG 2 Yes ? - 16 48 0 45 – 14k
Dell Inspiron 3800 (Ess
Media3)

2 Yes Yes - 16 48 + 10 – 20k

IBM x20 (Crystal
Soundfusion)

Yes Yes - 16 48 + 6 – 20k

IBM Thinkpad A22E
(Crystal)

2 Yes Yes - 16 48 - 6 – 20k

Dell Latitude CPt 500GT 2 Yes Mono - 16 48* + ?
MagicMedia 256, (Dell) 2 Yes Mono - 16 48 + 7-20k
OPL3-Sax 2 Yes Yes - 16 48 - 30– 21k
CS4232, Thinkpad 380 1? Yes Yes - 16 ? - 80– 19k
CS423x, Tosh. Tecra 2 ? Yes - 16 ? - 100– 7k
ESS 1878 1 Yes Yes - 16 44.1 - ?
ESS Maestro 2 Yes Yes - 16 48 + 8-20

* Works only for sampling frequency 48 kHz (and probably 24 and 12 kHz, but this has not been tested for all the
cards)
** Currently 200 kHz, a special driver version that can handle 215 kHz will soon be released.

The list above shows the cards that have been tested and been shown to work with WinMLS. If you have, or plan to
purchase, a card on the list, please read the comments on the card below. In the chapter above we provide a list of
sound devices that does not work with WinMLS. Cards that are not on any of these lists may also work fine. Please
report to us if you test a card that is not on the list. Note that we cannot give any guarantee that the information in this
document is correct. 

If you intend to do 2 channel measurements with correct initial time delay, you need a feedback loop from your sound
device output directly to the sound device input (except for some professional cards). In this case we recommend
sound cards that have a microphone input in addition to the usual line input for this purpose. If the sound device you
are using does not have any microphone input in addition to the line input, a special feedback loop device has to be
built or purchased from us. More information about this is given in the User’s Guide.

5.3.1 Explanations

We cannot guarantee information given in the table above may contain errors. Note that the sound devices working
with Widows 95 should also work with Win 98 and ME. The OPL3-SAx that is listed under Sound Chips is also used
on sound devices. Each term in the table is explained below:

Sound Devices displays the name of the sound devices. At the bottom of the list, sound chips usually used in laptops
are displayed.

Channel(s) indicate the maximum number of channels that can be measured with WinMLS using the sound device.
Note that the ARC88 can measure 8 channels, but a hardware error gives a small time difference between the channel
pairs. Note also that Midiman DMAN 2044 is a 4-channel card, but it can only be used for 1-channel measurements
without feedback loop in the current version of WinMLS.

Mixer tells if the sound device supports the built in WinMLS audio mixer that makes it easier to perform the
measurements and you may also save volume settings for each measurement. If the WinMLS audio mixer is not
supported, you may still perform measurements; especially the ARC44 and ARC88 have a nice external mixer.

Mic. input tells if the sound device has an input for microphone. If “Adj.”, then the card has a input that can be
selected to be either line or microphone input. If “Yes” there is a microphone input in addition to the line input and
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you can do 2 channel measurements with feedback loop without having to order a special device for this (If you want
to, we can supply such a device). You can connect a feedback loop to either the line input or the microphone input,
and use the other input for your measurements. See the User’s Guide for more information about this.

Price, the suggested price of the cards is only meant to give an indication and may not be correct.

AD/DA tells how many bits the analog to digital and digital to analog converters is. Note that for most of the sound
devices and in the current version of WinMLS, only 16 bits digital play and record is supported. So the extra bits that
the 18 and 20 bits converts have are not used. Anyway the cards that have 18 and 20 bits converters usually do have
less background noise than the cards having 16 bits converters.

Fs [kHz]– This column displays the upper sampling frequency that the sound device supports. In addition to this, all
the sound devices in the table support 11025 kHz, 22050 kHz and 44100 kHz. Some sound devices like the ARC44
support a wide range of sampling frequencies.

Noise indicates the level of the background noise. DIG means that the card is digital and converters are needed. +++
means an extremely low noise level (better than -100 dB A-weighed), ++ means very low level (appr. -96 dB A-
weighed), + means low level (appr. -85 dB), 0 means a fairly low level ( appr. –75 dB), - means quite high level (the
range  –75 dB to  -50 dB). Note that other systems for MLS measurements use 12-bits cards, which gives at best a
background noise level of –76 dB. Unless you want extremely accurate measurements, the level of background noise
does not have to be critical. In many cases increasing the measurements time can average it out.

Frequency Range - Frequency response range given as the upper and lower frequencies where the magnitude
frequency response is -3 dB down. For the sound devices that have built-in bass and treble settings, e.g. the OPL3-Sax,
this was difficult to measure because the frequency response is not flat in the middle. If no comment is added, the bass
and treble settings were set to maximum value during the measurements and we measured the frequencies where the
drop-off is 3 dB down from the average value of the frequency response in the “linear range”. In this case we have
measured the maximum frequency range.

Operative System tells if the sound device can be run in Windows 95(98) and/or in Windows NT. If it supports
Windows 95 then it should support Windows 98 also.

5.4 PCI cards

5.4.1 Digigram VX222

This card has several types of external connectors available. 
Max output level is 22 dBu. Output level adjustment: down to - 91.5 dBu by 0.5 dB steps.
The VX222 features a selectable digital input gain up to +18dB.
SNR (un-weighted): better than 93 dB
THD + Noise (un-weighted): better than  -90 dB (0.003%) with 1 kHz signal at -1 dB FS
Frequency response (20 Hz / 20 kHz): +- 0.1 dB
Difference in phase (20 Hz / 20 kHz): 0.2 degrees / 2 degrees
Inter-channel isolation at 1 kHz: better than -95 dB

Read more about this card in the chapter General information about the Digigram cards (VXpocket, PCXpocket,
PCX9 and VX 222).
The Digigram homepage URL is www.digigram.com.

5.4.2 Echo Layla 20

This was tested by a WinMLS user (not by us).



I was able to get the software to work with my Echo Audio Layla 20, but it took some work.  The Layla20 has 8
analog and 2 digital input channels, with 10 analog and 2 digital outputs, 20 bits, up to 48K sample rate, seperate
internal PCI card.  I was using driver version 6.05.  
 
I found that on the Layla20 setup, I had to unlink all of the individual channels in WDM mode (so there were
effectivley 5 separate stereo output devices and 5 input stereo input devices as Windows sees it.  Then, I had to change
the setting of the synchronization for the wave devices.  I originally kept them synch'd, but I had to unsync them inside
of the driver in order to get WinMLS to work.  I was never able to get the WinMLS mixer to work with the Layal20.

5.4.3 Echo MIA

PCI soundcard with two TRS balanced inputs with 64x oversampling A/D converters. Two TRS balanced outputs with
128x oversampling D/A converters. Both the inputs and outputs can be used unbalanced without problems. It also has
S/P DIF digital inputs and outputs. The input sensitivity is either -10dBV or +4dBu. Supported sampling frequencies
are 8, 11.025, 16, 22.05, 32, 44.1, 48, 88.2 og 96 kHz. Resolution ut to 24 bits. Only 16 bits worked in Windows 2000
(24 bits worked for Windows 98). The WinMLS mixer cannot be used.
More info is found at:
http://www.echoaudio.com

5.4.4 Hercules GameSurround Fortissimo II

This information was given to us by Jim Gutterman <jim@x-gecko.com>:
I am using a Hercules GameSurround Fortissimo II with Optical Outputs, and to date it had been working fine with
WinMLS.  This card seems to be the best low-cost ($50) card I have found.  It has excellent audio characteristics with
fully digital I/O as well as 4 channels of analog output and good mic in.

Main page for card:
http://us.hercules.com/products/product.php3?id=9 

Specs:
http://us.hercules.com/products/techspec.php3?id=9 

Reviews:
http://us.hercules.com/mediaroom/reviews/index.php3?product=9 

5.4.5 TB Santa Cruz

This card has noise components at 50, 150, 250, … This was found by windowing the last half of the impulse response
using a Hamming (full) window and plotting the resulting magnitude frequency response. The measurement is
available in the Soundcards folder.

5.4.6 Terratec EWX 24/96

The tests were done using the analog input/output (the card also has spdif) by Kjell Olav Aalmo. The operative
systems Win98 and Win2000 were used for the test. Win2000 did not work in 24 bits mode. It worked fine in Win98.
The sensitivity can be set to +4dBu and -10dBV on both input and output. The card also has an extra input amplifier
that can be set in the range 0 to +18 dB. Supported sampling frequencies: 8000, 9600, 11025, 12000, 16000, ,22050,
24000, 32000, 44100, 48000, 88200, 96000. The buffer size can be adjusted to optimize.
More info is found at:
http://www.terratec.net/products/ewx2496/ewx2496_details.htm
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5.4.7 Card Deluxe

High quality card that showed good results in our tests, but note that it does not have a software mixer. Very good
specifications, it has four built-in mono full size jack connectors. In order to get a correct measurement, the analog
input monitoring must be turned off. If not, there will be an internal loop-back.

This is written by Mr. Al Pickard from Digital Audio Labs, Inc. that tested the card:
We had a customer that was having some trouble with the loopback test - it turned out that he had theinternal monitor
loop turned on so he was getting feedback. All is well now.

As far as the latency is concerned, there is a feature on the CardDeluxe Configuration Panel (access via Device
Manager) that is designed to eliminate latency variations.  In the "Record mode" section of the Configuration tab,
there is a button labeled "Lock to playback".  Selecting this will insure that the record and playback channels start
together, so the latency will always be the same number of samples. I tried several tests with this set both ways, and it
was always stable.  But I have seen variations of a sample or two in other applications when "Lock to playback" is not
selected.  It depends on the CPU speed, OS, etc.

More details are found at
http://www.digitalaudio.com/carddeluxe/default.htm

5.4.8 Sek’d Prodif 96 Pro

This is a 24 bit (20 bit effective) 96 kHz card, with 2 analog and 2 digital (S/PDIFF, AES/EBU, ADAT, optical
(toslink) in/outputs. It has been tested by one of our customers, Peutz & Associés B.V. They found that the signal to
noise ratio is approx -130 dB and the lower frequency limit approx. 5 Hz (-6 dB) without compensation.  The 2 analog
and 2 digital in/outputs are usable at the same time. Several cards can be linked for synchronous multi-channel
measurements. See http://www.sekd.com/Prodif96/Prodif96.htm.

5.4.9 LynxTWO

Using this card you can measure multi-channel with full bandwidth up to 96 kHz with WinMLS.
Using the Lynx2 sound card you can do this since it can measure with sampling frequencies up to 200 kHz (215 kHz is
promised). And the good thing, the Lynx2C card has 6 analog inputs. All the channels have been tested (Windows 98
and Windows XP) and was found to be synchronized. Note that you need a special version of WinMLS to be able to
measure with sampling frequencies above 96 kHz. 

The WinMLS mixer is not supported, go to Measurement->Sound Card... and make sure the setting below is
selected:

Use an external (outside of PC) mixer to set levels or use the Lynx mixer. The Lynx mixer works in the digital domain
so the levels should be kept at maximum to get optimal results.
24 bits sampling is supported, and this will work if you select 32 bits in Measurement->Sound Card... as shown in
the figure below.



The time delay is stable when used with WinMLS (according to our tests) and is given below. This means that you do
not have to use loop-back to be able to measure correct delay times.
Time delay for Fs < 50.5 kHz, 64 samples
Time delay for Fs >= 50.5 kHz < 101 kHz, 47 samples
Time delay for Fs >= 101 kHz , 40 samples

Measuring at sampling frequency 200 Hz, we found that the response was -10 dB down at 100 kHz to avoid aliasing.
This should be sufficient. 

To set the input levels, open the Lynx mixer application. Go to 
Settings->Analog In 1+ 2 Trim
Here you can select between the input levels
+ 4 dBu
-10 dBV
The procedure for setting the output level is similar.
Note: Although you are getting –30 dBFS of input signal or less, this sound card is so good that you will still get good
results for most applications.

Contact us to purchase this card from us.
See 
http://www.lynxstudio.com/lynxl22.html
for more details.

5.4.9.1 Problems with the Lynx card

In a previous version of the driver I had no problems with using WinMLS with the Lynx Two card. When I updated
the driver I got problems. Find some screenshots of WinMLS and the Lynx mixer below that should explain the
problem

Echoes in sound card impulse response shown in time data plot (dB as y-axis, time in milliseconds as x-axis)
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Resulting frequency response.

Zoomed in on the impulse response in the figure below. The period is a little more than 2 milliseconds.

How to avoid this echo using the Lynx card?

The echo is because the signal on the sound card input is played on the sound card output after a delay of  apprx. 2
milliseconds (which is the delay of the AD + DA converters)
I used the following settings on the Lynx mixer



Play Mix B has to be turned on, else I get no sound.

5.4.10 Lynx L22

Same as LynxTWO, but it is two channels only. A great card, probably the best available. You can purchase this card
from us. See the Lynx TWO section for more information.

5.4.11 Waveterminal 192X

In March 2002 we tested driver version 3.50 of the Waveterminal mixer (also called Console).
Make sure the sampling frequency is set to AUTO, if not it is impossible to perform a measurement.
Sampling frequency 16, 88 and 96 kHz did not work, got only noise.
96 kHz worked only when we set Latency to 2048 samples, and even then we got noise when doing a loop-back
measurement. 192 kHz is not possible with the current version of the driver. 24 bits output was not possible.
32 bits input/output was not possible

5.4.12 Delta 1010LT

This sound card was tested with 8-channel measurements, and it worked fine except that we were not able to get 24
bits analog working in WinXP and the WinMLS mixer could not work in Win98. We did not test any other operative
systems.
The synchronization seem to have a deviation of maximum 1 sample if not measuring in loop-back mode.
See http://www.m-audio.com.

5.4.13 RME Hammerfall DIGI9652

High quality digital card. For more information about the card and about AD/DA converters please see
http://www.rme-audio.com/english/index.htm 

5.4.14 Sonorus STUDI/O

Please see http://www.sonorus.com for information.

5.4.15 MULTIWAV PRO18

Please see http://www.sonorus.com for information.
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5.4.16 Soundtrack 128 Ruby DDMA

Read about this card and place international orders online at 
http://www.hoontech.com/
SNR has been measured to be better than –84 dB at the line input. The card has many interesting options. The
SoundTrack Analog(ADC/DAC) Bracket can be added to the card. It is a 120dB, 96Khz 24bit high-performance
Analog to Digital Converter for SoundTrack 128 family and SoundTrack Digital audio series. It only costs $99.

5.4.17 Midiman DMAN 2044

Midiman DMAN 2044 is a 4-channel card, but it can only be used for 1-channel measurements without feedback loop
in the current version of WinMLS. Note that you need a physical mixer device to control the input volume.

5.4.18 Marian Marc 8

This is the new version of the Sek’d ARC88 card, and the problems with the ARC88 card (see below) seem to be
fixed. With this card you can do sample-accurate multi-channel delay measurements.

It has 8 channels, 24 bit and 96 kHz sampling frequency, it also has a nice mixer, but it cannot be controlled by
WinMLS. The connectors are phono, but it is possible to purchase a box front end. Note that channel 1 (left) is one
sample ahead of the other channels (2-8), this should be fixed in the latest driver version. Please see
http://www.marian.de for more information.

5.4.19 Marian ARC88

Note that the ARC88 can measure 8 channels, but due to a hardware error there is a small time difference between the
channel pairs. It has been developed drivers for NT which we have tested and have found to work except that some
measurement give an error message when using feedback loop.
The input channels are switched (input ch. 1 is really input ch. 2, input ch. 3 is really input ch. 4. and so on). This
means when using feedback loop, make sure “Feedback Loop Input always on Ch. 1” is on. 
Please see http://www.marian.de for more information.

5.4.20 Ensoniq Audio PCI

The audio quality is good, and the price is very low. The card also supports the WinMLS Audio Mixer if the
microphone input is used. The card was first tested on NT 4.0 and unfortunately we could not obtain correct
measurements. But when running Windows 95 it worked when we used the mono microphone input except for
sequence order 11 and 12 (which is in many cases seldom used). Note that since we had to use the microphone input,
only 1-channel measurement is supported. We used a driver that upgrades the card to the Sound Blaster PCI 64. Later
we did a new test, and then we were able to get correct measurements on channel 2 (see the following information
about the Sound Blaster PCI 64).

5.4.21 Sound Blaster PCI 64

This sound device is very similar to Ensoniq Audio PCI, so the information given above should apply for this card
also. When the card is used in full duplex mode, there seem to be an internal loop in channel 1 of the card. This gives a
very high amount of cross talk, which makes channel 1 impossible to use for MLS measurements. Channel 2 does not
have this cross talk and can be used.



5.4.22 Sound Blaster PCI 128

For one of these cards we tested the output signal was directly connected to the input so we had –20 dB cross-talk.
This may be because the sound card was defect or badly constructed. This card was an early version of SoundBlaster
128, SB128PCT (CT4700). However, the SB128 PCI (CT4810) has been reported not to have this problem.

This sound device is very similar to Ensoniq Audio PCI, so the information given above should apply for this card
also. When the card is used in full duplex mode, there seem to be an internal loop in channel 1 of the card. This gives a
very high amount of cross talk, which makes channel 1 impossible to use for MLS measurements. Channel 2 does not
have this cross talk and can be used.

5.4.23 SB Live Value

Using the microphone input is problematic, but the line input gives good results. It worked fine when we used the
sampling frequencies 48, 24 and 12 kHz.

5.4.24 SB Live Platinum 

It worked fine when we used the sampling frequencies 48, 24 and 12 kHz.

5.5 ISA cards

5.5.1 Turtle Beach Monterey/Tahiti

This is the only high quality sound device we know of that has response down to 0 Hz. It is thus very suited for low
frequency measurements. Unfortunately these cards are not produced anymore, but we have a few cards in stock, and
it should be possible to get a card used. If you are using a Turtle Beach Tahiti or Monterey sound device, you must
download and install the latest drivers <tah95dx.zip> to make the WinMLS Audio Mixer work properly under
Windows 95. If you want to use this card under Windows NT, special drivers can be downloaded. We have tested
these and they worked fine.

5.5.2 Turtle Beach Fiji/Pinnacle

The audio quality is very good, but in order to make WinMLS work please read the information below. The Pinnacle
card is supposed to be equal to the Fiji except that it has added a MIDI interface and synthesizer. 

A weakness is that when you perform a measurement using feedback loop Fiji/Pinnacle can suddenly stop working
and cause the PC to crash. This usually happens once for every 100 measurements. If you do not use the feedback loop
option this error will not occur.

The sound device driver has a bug, but WinMLS compensates for this bug so it does not affect the measurement.
However you should be sure that you use driver version 4.03 (contact us if you don’t have it). If you use driver 3.02,
you will probably get an “Application Error” message. We have tested this driver and WinMLS on Windows NT 4.0,
and it works fine.

If the S/PDIF input is chosen in the Windows mixer, an error message is given and WinMLS cannot run. Therefore
make sure the Windows mixer input is not chosen as S/PDIF before you start WinMLS. 
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5.5.3 Sound Blaster AWE 64

All the features of WinMLS should work with this sound device. Note that the microphone input is mono.

5.5.4 Sound Blaster 16

All the features of WinMLS work with this sound device. Note that the microphone input is mono.

5.5.5 Sound Blaster AWE 32

We have had problems getting this sound device to work when feedback loop is used. If the Windows Notification
sounds are not turned off, WinMLS may crash. How this is done is explained in the user’s guide. In some
configurations it is reported that using 32 averages will not work if feedback loop is used.

5.5.6 SEK’D ARC44

ARC44 is a 4-channel card capable of running the 4-channel version of WinMLS. This card has been in use with
WinMLS by professionals for several years.

5.5.7 Crystal CS32BA11

The background noise level is rather high.

5.5.8 ESS 1868

Can only be used for 1-channel measurements. The background noise level is high.

5.5.9 CARDD PLUS

A card with very good audio specifications, see their web page at http://www.digitalaudio.com/cardd/cardd.asp
It cannot use the WinMLS Audio mixer. When you use CARDD PLUS, you must make sure that you have specified
CARDD PLUS as your default card for playing and recording. You can do this by clicking the Multimedia icon in the
Control Panel. Set CARDD PLUS as your preferred devices in the Audio settings.

5.5.10 Turtle Beach Multisound Classic

A user has found that this card is working with WinMLS.

5.6 USB Devices

5.6.1 USB Duo

This device has some advantages and some disadvantages.

Disadvantages:
• It does not work with all sampling frequencies. It is strongly recommended that you use one of these: 44100,

22050, 11025, 8000 or 4000 Hz. Do NOT use 48000. 
• The input level mixer cannot be controlled by WinMLS. 



• To measure accurate system delay, you need to use the WinMLS loop-back feature, else you can get several
milliseconds error.

• It is not powered by the USB or batteries, thus not so portable.
• A 0.1 dB gain difference on the channels was reported.
• WinMLS is able to override the windows mixer, but setting the input level slider in WinMLS does not give

any effect. The input level cannot be set from software. The microphone input levels can be set using an
external know. This is dangerous for calibrated measurements and it is therefore recommended that you
calibrate the level using a calibrator before you start a new measurement series.

Advantages:
• It handles very high input levels (+ 22dBu at the line input). This is a jack input where a mono jack must be

used. Note that it does not handle a balanced signal. 
• Line out can deliver more than +20 dBu and the THD is about 0.001 %
• It has built in phantom power and can handle very high input levels.
• The output mixer can be calibrated.
• A sampling frequency as low as 4000 Hz can be set which is a good thing for low frequency measurements.
• Not able to get 24 bits mode to work with WinMLS.

Note that if you are going to use it for 2 channel measurements, it is not simple to measure the correct initial time delay (time of
flight).

We have seen that if the output mixer is controlled by WinMLS, the volume is not always set back to what it was before WinMLS
performed measurements.

First, you must set the control panel to MME as shown below

Note that it might be set back to ASIO so you may have to set it back to MME.

You can click the  icon found on the taskbar.

More info at
http://www.midiman.net/products/m-audio/duo.php

5.6.2 MobilePre USB

Do NOT use sampling frequency 48000. 44100 seems to work fine.
The phantom power did not work well on the microphones we tested it with, if using the sound card phantom power,
the frequency response will drop with a few dB for higher frequencies.
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Important: If you are going to measure impulse or frequency response, you need to connect a loop-back from the
right channel output to the right channel input as shown in the figure below.

The sound card settings is set as shown below.

5.6.3 USB Quattro

This is similar to the USB Duo (see above) but it has 4 input and no microphone inputs. However, a 4 channel
microphone preamp can be added.

More info at
http://www.midiman.net/products/m-audio/quattro.php

5.6.4 M-audio Transit

Install the card as explained in the M-audio documentation.

To open the settings for the M-audio sound card, click the  icon found at the bottom right .
In the settings we can set the sound card to handle 24 bits input (not output) and microphone input.

The first thing to do is to set the latency to Very High as shown below



The input has a DC voltage of 1-2 Volts that a standard multimedia microphone is using. To turn on the microphone
gain, make sure that one of the +14, +20 or +26 settings are selected as shown below.

If you use this microphone boost/gain and you want to use system correction, it is recommended that you do a new
system correction loopback measurement with the same gain. The self-noise on the mic inputs is rather high for high
frequencies, it may be 16 dB at 10 kHz and 13 dB at 5 kHz (measured when input is connected to output).

To enable 24 bits input, make sure the setting below is selected.

Then you can open WinMLS, go to Measurement->Sound Card… and select 24 bits input as shown below.

To correctly measure system delay with this sound card, channel two has to be used as loopback.

5.6.5 Creative Soundblaster LIVE External

This is a USB sound card similar to Creative MP3+, but this card is 24 bits.
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Important: The driver must be installed from the CD that comes with the package.

Very important: The CMSS button must be turned off. If the CMSS green light is on, the result will not
be correct.

The input can be set to 24 bits, but the output does not work with 24 bits. The ‘Measurement->Sound Cards…’ dialog
box should look as shown below.

Only the line input can be used if the correct system delay is to be measured. This is set as default in one of the setups
that comes with WinMLS,  'Yes, with loopback, no end-check' is selected as shown in the figure below ('Yes, with
loopback, with end-check' did not work). 

In the bottom part of the figure above, please note that What U Hear shold not be selected. 
If you do not want to measure the system delay, go to 'Measurement->System Delay' and in the upper list box select
'No, remove system delay'. 

The frequency response is +- 3 dB in the frequency range 4 Hz-21 kHz.

If you want to do calibrated measurements, the external hardware output control  is no problem since it is

controlled by WinMLS. But if you are using the microphone input, the microphone input control  is not
controlled by the software and cannot be touched after a input calibration.



Note: When something is connected to the line input, the mic input does not work.

5.6.6 Creative Mp3+

This card is described in the sound card settings section in the documentation.

5.6.7 Creative Extigy

Testing this USB device was a positive experience. We tested it using Windows 98 and a HP laptop running a Pentium
3 700 MHz and 64 Mb RAM. The installation was smooth, but we had to turn off the device, and then turn it on again,
after the installation to get it to work properly. Since the Soundblaster Extigy worked so well, it is likely that the
Soundblaster Audigy (which is a sound card for stationary PC) will also work.

What you should know when using this device: 

If you experience problems with feedback, you must go to the sound card output mixer and make sure that
Microphone and Line-In is muted and turned down. Again make sure you do it for the output mixer, not the input.
In Measurement->Sound Card..., go to Output line and select the lower Wave, not the upper (two Wave’s are
displayed in the list).
Input Mixer shoud be set to below -7 dB (30000 uncalibrated) to get optimum SNR.
Output Mixer should be set to below -4 dB (40000 uncalibrated) to get optimum SNR.
If you want to calibrate the mixer levels, the files containing the mixer conversion factors, are available in WinMLS.
We recommend that you go to to Measurement-> Calibration... and select Creative SB Extigy as WinMLS mixer
OUTPUT relative calibration as shown below.

For the WinMLS mixer OUTPUT relative calibration section, you have to know if you are measuring using the
microphone input or the line input, since the mixer levels are slightly different in the low range. If you use the
microphone input ,select Microphone - Creative SB Extigy, else select Line-In - Creative SB Extigy. 

Input Mixer shoud be set to below -7 dB (30000 uncalibrated) to get optimum SNR.
Output Mixer should be set to below -4 dB (40000 uncalibrated) to get optimum SNR.
In order to get the best results, we have also provided mixer files where we have removed the levels that do not give
good results. These have (Good SNR) appended to their names and can also be selected from Measurement->
Calibration, example Microphone - Creative SB Extigy (Good SNR).
If you want to calibrate the sound card to measure input voltage, we found the Sound Card Input conversion to be
9.681. You may also use this number as a nominal settings, but it applies only if the mixer is calibrated.
First go to Measurement->Calibration..., then click on the upper Settings... button, then type the number in the
Sound Card Conversion edit box. Do check if your measurements are reasonable using this conversion factor.

Negative: If you want a portable system it is not so good that it needs 12 Volts power supply. 
Start Record/Playback can vary with 200 samples, which means that initial time-delay can only be measured correctly
if using loop-back. But when measuring with loopback, we found that the End sync pulse was not detected. This was
not a problem in our case, since it seems always to give correct measurement (the purpose of the End sync pulse is to
detect gaps in recording/playback which ruins the measurement).
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96 kHz sampling frequency was a disaster, It was not possible to get a decent measurement above 24 kHz because the
filters seem to be the same as for Fs= 48 kHz. Also, we had problems sometimes getting overloaded input level.
16 and 24/32 bits use different filters, so the frequency response using 16 bits is 3-23 kHz, while for 24 bits it is 3-18
kHz using 48 kHz as sampling rate.

Positive: The price is very low. It can be used with any PC, stationary and laptop. The mixer can be calibrated. Gives
very good results when used properly. Using measurement system correction, we were able to get the magnitude
frequency response within +-0.01 dB from 1 Hz to 20 kHz measuring output-input loopback (using seq. order 16).

5.6.8 Egosys U2A

It has been tested with WinMLS and is now used by one of our customers. It worked except that the internal WinMLS
mixer could not be used.
For more information see
http://egosys.net/eng/product/products/wt_u2a/WTU2A.html

5.6.9 USB Pre

The USBPre is a USB device with built-in microphone preamplifier and phantom power (48 Volts). Very nice, but
because of synchronization problems it cannot be used for MLS-type measurements and is not optimal for very high
quality sine sweep measurements either because it gives pre-ringing in the impulse response. If the right settings are
used as explained below, the USB Pre will give good results for most applications. But if your application is
measuring high quality impulse responses such as for deconvolving with music, we would not recommend it.

The reason for the problems is probably because the AD and DA do not use the same clock on the USB Pre. If you use
the device for peforming MLS measurements, you will see that the high frequency will roll off, and the roll-off will
increase as you increase the total length of the measurement (the small difference in sampling frequency becomes
more important when the measurement length increases).

We have made a setup where we have set optimal settings for the USB Pre. Load this setup from Setup->Load…,
then select the setup named Sound Cards_USB Pre.

In Measurement->Sound Card… we have set the settings shown below. Note that 24 bits does not work in the
current version of WinMLS for the USB Pre.

Important: In Measurement->Settings…, we have set right channel input as reference as shown in point 6. in the
figure below. This setting will not be kept when you load another setup. Therefore when loading a new setup, set this
because it will give a much better result.



You should also always use Single sweep as shown in point 3. above. This will give the best results. If using multiple
sweeps, make sure that

 is set in point 6. as shown below.

In Measurement->System Delay… shown below, we have set the settings shown below. We had to set it to Yes,
with loop-back, no end-check because the end-check will not work because of the sampling frequency difference
between input and output.

Important: If you are going to measure impulse or frequency response, you need to connect a loop-back from the
right channel output to the right channel input as shown in the figure below.
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Note: It is not possible to set the input levels using the WinMLS mixer. It must be done from the knobs shown to the
left in the figure above. (Adjust these knobs so you get an input level between -40 and – 3 dBFs.)

In the above example, the Mic. input is used for measurement. 

Open your USB Pre application and select the settings shown in the figure above. By using the rightmost radio button
shown in the figure above you can also set another input. Each input must be calibrated (e.g. using a voltage meter
following the standard calibration procedure)

Inputs: The figure below shows how a microphone is connected to mic. Input channel 1 and a the phono loop-back
cable is connected to Tape input 2.

Outputs: The figure below shows how a the red phono loop-back cable is connected to right channel output. The black
phono cable is to be connected to the loudspeaker.



Because of the synchronization problems with the USB Pre, we do not recommend that you use the Measurement
System Correction feature of WinMLS, we instead recommend that you do what is described below (then there is no
need for measurement system correction if we assume the two channels have an equal frequency response).

If you have done what has been recommended above you may obtain good results as you can see from the two figures
below.

Below a similar measurement of the Lynx2 sound card is superposed in black. We see that for 20 kHz, the USB Pre
has a difference between left and right channel of 0.15 dB. Tor the Lynx2 card, this error is about 0.015 dB.
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This swept sine method has many advantages compared to MLS. Below we se an example of an impulse response
measured using the USB Pre and VXpocket. We recommend using the VXpocket for high quality measurements partly
because of the effects documented below.

In the figure above, we see that the USB Pre is more noisy than the VXpocket.

In the figure above, we have zoomed in on the x-axis. Here we can see the typical pre-ringing (that can be much worse
depending on the measurement parameters) from 0-6 milliseconds.

5.6.9.1 Troubleshooting

When testing the USB Pre, we several times got no response from the USB Pre. In order to make it work again, we
pulled out the USB cable from the device and pulled it in again. That worked fine, except that once we had to go to
Measurement->Sound Card... and reselect the input and output device to USBPre. 
If you download the latest beta verison of WinMLS this should be solved.

Gaps during the measurements. We had problems when performing measurements using several averages. This can be
solved by following the procedure given above, selecting the input channel 2 for deconvolution. 

See the troubleshooting section of the USB Pre help for more information.

5.6.9.2 More details

The latest version 1.5 has the ability to lock out front panel buttons via the control panel software. All other features of
USBPre 1.5 remain the same as the original USBPre hardware. A problem if you are doing calibrated measurements,



is that the input volume controls knobs do not move in steps and these cannot be locked. The input volume cannot be
set using software mixer either, it seems like it can be set from the WinMLS mixer input volume, but this is not true.

When using music (noise) as excitation, there seems to be cross-talk influencing the measurement. An example of an
impulse response measured using music is given below. 

By selecting the time window lower limit after the cross talk part as shown above, this problem should be solved.
WinMLS has a feature for automatically detecting the start of the impulse response (Time window settings). 
Theoretically, two impulses spaced 10 ms apart (the  distance from the cross talk to the start of the impulse response in
the figure above) will give a comb filtering effect with dips every 100 Hz. We did not see much of it in thefrequency
response plot, as seen below, where the red curve is using the window as shown in the figure above, while in the blue
curve, the window starts from 0 ms.
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We tried setting the levels to try to remove this crosstalk part, but we did not manage to do it. But if measuring using
sine sweep, we did not experience any crosstalk.

5.6.10 Midiman Quattro

Professional 4-in/4-out audio interface with MIDI and USB 
http://www.midiman.com/products/m-audio/quattro.php.
Does not seem to work with MLS. To perform measurements, follow the same procedure as with the USB Pre.
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5.7 Firewire Devices

5.7.1 Motu828

It is a single-rack unit device with 8 input and 8 output channels. I only use two of them with WinMLS. The loopback
response is an impulse and the transfer function is flat in both magnitude and phase. The noise floor is very low. The
price is about $750 USD. See frequency response below.
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See below and  http://www.motu.com for information.
• sampling rates 44.1, 48K
• 24-bit analog converters. 
• CueMix Plus? zero-latency hardware patchthru system. 
• Sample-accurate digital transfers between ADAT digital tape decks and the computer via the ADAT sync port. 
• Eight 24-bit analog outputs on balanced/unbalanced 1/4" TRS jacks 
• Six 24-bit analog inputs on balanced/unbalanced 1/4" TRS jacks 
• Two 24-bit analog inputs on balanced/unbalanced 1/4"/XLR combo Neutrik connectors. 
• Two mic pre-amps with switchable 48-volt phantom power on the front panel. 
• 105dB dynamic range 
• Front panel volume control over monitor input level on main outs. 
• Front panel headphone jack with independent volume control. 
• Front panel signal present LEDs for all analog and digital I/O. 
• Trim controls for all inputs on front panel. 
• Dedicated front panel clock status LEDs. 
• 8 channels of 24-bit ADAT optical input/output. 
• Stereo S/PDIF in/out in optical and coax formats - ADAT lightpipe and S/PDIF optical formats share the same jacks
and can not be used at the same time. However, you may use ADAT lightpipe in and optical S/PDIF out
simultaneously and the S/PDIF coax I/O and lightpipe I/O may be used simultaneously.analog inputs 8 channels,
analog outputs 8 channels, S/PDIF RCA 2 channels, S/PDIF optical 2 channels, ADAT Lightpipe 8 channels, protocol:
FireWire  



5.8 PCMCIA cards (laptop)

5.8.1 VXPocket (V2) by Digigram

The big advantage of this card is that it can be used in most laptops since it is a PCMCIA card. This card is a good
solution if you need to do high quality measurements with your laptop without using a docking station. Several
professional users are using it with WinMLS. The user support on the card is good. 
Specifications:
Max output level is 10 dBu. Output level adjustment: down to - 91.5 dBu by 0.5 dB steps (we found that it is really in
0.25 dB steps).
SNR (un-weighted): better than 94 dB
THD + Noise (un-weighted): better than  -89 dB (0.003%) with 1 kHz signal at -2 dBFS
Frequency response (20 Hz / 20 kHz): +- 0.15 dB
Difference in phase (20 Hz / 20 kHz): 0.2 degrees / 2 degrees
Interchannel isolation at 1 kHz: better than -95 dB

Do not connect a phantom power supply unit to the output of the card, It might destroy it. Note that the output signal
noise will be decreased if the laptop is run only on battery and not using the power supply.
Read more about this card in the chapter General information about the Digigram cards (VXpocket, PCXpocket,
PCX9 and VX 222).
The Digigram homepage URL is www.digigram.com.

5.8.2 VXpocket 440 by Digigram

This sound card is very similar to the VXpocket, but it has four channels. Please note that the card is not synchronized,
read more about this in General information about the Digigram cards (VXpocket, PCXpocket, PCX9 and VX 222).
The Digigram homepage URL is www.digigram.com.

5.8.3 PCXPocket by Digigram

The big advantage of this card is that it can be used in most laptops since it is a PCMCIA card. We had problems with
distortion on the output, but by reducing the output volume the distortion disappeared. 
The user support is very good, but the price is rather high. You may order this card from us.

Read more about this card in the chapter General information about the Digigram cards (VXpocket, PCXpocket,
PCX9 and VX 222).
The Digigram homepage URL is www.digigram.com.

5.9 Sound Chips/Laptops

5.9.1 Yamaha AC-XG

Thanks to Clive Glover for measuring this device using the Toshiba 3490.

5.9.2 Dell Inspiron 3800 (Ess Media 3)

This laptop has a Ess Media 3.
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5.9.3 IBM x20 (Crystal Soundfusion)

This laptop has a Crystal Soundfusion chip. 

5.9.4 IBM Thinkpad A22E (Crystal WMD Audio Codec)

This laptop has a Crystal WDM Audio Codec. The operative system was Win98, processor Celeron 800mhz and
64mb sdram memory.

5.9.5 Dell Latitude CPt 500GT 

This laptop has a Sound Blaster compatible sound chip. It does not work with 44.1 kHz, but has been tested to work
with 48 kHz. The test was performed by a acoustics consultant company.

5.9.6 NeoMagic MagicMedia 256 CODEC

This chip is built in a DELL Latitude notebook and it gave very good results as we can see from the table. The stereo
crosstalk was found less than -80 dB, which is also very good. The mini-jack connectors seem to be very good.
However, if feedback loop is used (to get correct initial delay), this chip did not work on all the Latitude laptops we
tested. We also found that the sync output volume should be set to a low value and that the sync. input volume should
be increased instead.

5.9.7 OPL3-SAx

The OPL3-SAx sound chip is very often used in portable computers. We have tested WinMLS on some laptops that
has the sound chip, a Toshiba Satellite 320cds running Win95 and a Toshiba Satellite 230cx running WinNT. The chip
is also used on sound devices.

5.9.8 CS4232 in IBM Thinkpad 380

This type of chip was tested on an IBM Thinkpad 380. The chip showed nice audio properties. We did not get 2-
channel measurement to work. An amplifier seems to be needed for using a microphone since we did not get enough
level without.

5.9.9 CS423x in Toshiba Tecra

This type of chip was tested on the laptop Toshiba Tecra 730CDT. The frequency range listed in the table is quite
small, but is measured with no equalizing.

5.9.10 ESS 1878

We tested this chip on a Compaq Armada 1530 running Win95. The problem with this portable PC is that it only has
no line input, but only microphone input. In addition, the chip can only do 1-channel measurements. Because of this,
measurements using feedback loop is not supported.

5.9.11 ESS Maestro

Works with sampling frequency 48 kHz and 24 kHz, not with 44.1 kHz. However the consultant company 
that tested it reported that the card is not stable, it might therefore be impossible to perform measurement system
correction using this sound card. Please note that there is a 1 sample difference between left and right input



6 The first measurements walk-through
In this chapter we will explain how to use WinMLS for various types of measurements. If your type of measurement is
not fully covered in this section we still recommend that you follow this section to get familiar with using WinMLS.

Start WinMLS if it is not already running. Before you start, you should have installed your sound card. You must also
set the sound card settings. On how to do this, see the Sound card settings section.
Warning: The output signal from the sound card may be as high as a few volts. Therefore, before you start any
measurement, make sure you have not connected something that does not handle this voltage to the sound card output.

6.1 Measurement 1: Measuring the sound card response

The purpose of this test is to perform a simple measurement but also to check the frequency response and impulse
response of the sound card.
You need a cable to connect the sound card input to the sound card output as shown in the figure below (except if you
have a sound card that comes with a cable, such as the Digigram VXpocket).

In the figure above, a mini-jack cable is displayed which is used for most built-in and low-cost sound cards.

6.1.1 Preparation

We start by loading the settings we need to perform this type of measurement. Go to Setup->Load..., from the list
select the setup named General_Freq. and Time Response as shown in the figure below.

6.1.1.1 Connections

Find the output and input connections on the sound card. If your sound card has a microphone input, this may be
used, but we will use only the line input in this example. If your sound card has both microphone and line as input,
make sure you connect to the same input line as you selected in Measurement->Sound Card... (step 3b in the dialog).

Use a cable to connect the sound card output to the sound card line input (only left channel will be used for the
measurement, so you do not have to connect the right channel input and output).
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6.1.2 Setting analog input and output level

Make sure Toolbars->Levels (and Mixer) is checked or click the  button. Now the mixer you have selected in the
sound card settings, if any, will be displayed. Shown below is the WinMLS mixer.

Set the volume sliders to a low level as shown above and connect the device you want to test. Note that you can use
the keyboard arrow keys to do small volume changes, but you must first click at the volume slider to set it active.

Note: If WinMLS is not set to control the Windows mixer in the sound card settings, the dialog it will look like below,
only displaying the input levels and not the volume sliders.

In this case, it is not possible to set the analog input or output levels from WinMLS.



6.1.3 Setting digital output level

Setting the digital output level is useful if you are not able to set the output level using any other method or if you
want to experiment with the output level to get optimal performance. If WinMLS controls the Windows mixer, you
should just read the rest of this  section for your reference, but not adjust the default digital volume.

The digital output level is set from Measurement->Settings... by clicking the Levels tab as shown below.

In the example above, only the sine sweep level is enabled because sine sweep is selected as excitation signal. It may
be changed by the user as shown below, where it is changed to 0 dB.

This means that the output level is increased by 10 dB, from –10 to 0 dBFS.
On most sound cards the digital level should be set as high as possible (0 dBFS) to get the best quality measurements
(except if MLS is selected as excitation, then it should be set no higher than -13). But for many applications it does not
matter much to the measurement quality if it is set to 0 dBFS or –40 dBFS. Therefore the digital level can be used to
control the output level in this range. You can set the digital level to a low number to make sure the output level will
not be too high, and then increase it if it is too low.

Note that this Measurement->Settings… dialog does not have to be closed for the changes to take effect. If you start

a measurement while it is open, the current settings will be used. Click the  button to close the dialog keeping
the current settings.

6.1.4 Performing the measurement

Start testing the levels by selecting Measurement->Test Levels or click the  button on the standard toolbar.
Increase the output and input levels until the input level is in the range –30 to –3 dBFS (in the figure below, it is –13
dBFS). If the input level is overloaded, it is indicated with a red “lamp” on top of the level meter.
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The testing of levels can be stopped with Measurement->Cancel or with the  button on the standardtoolbar.

Start a measurement from Measurement->Start, or clicking the F2 button or the  button on the standard toolbar.

6.1.5 Sound card measurement result

When the measurement is finished, it should look similar to the figure below.

Figure 1 Screenshot after loop-back measuring the Digigram VX222 v2 sound card.



The red curve in the upper plot displays the magnitude frequency response of the sound card. The lower plot displays
the impulse response. We see that the impulse response seems to be very short and the frequency response is very flat
in the range 20 to 20000 Hz.

6.1.6 Saving the measurement

Save the measurement by clicking the  button on the standard toolbar or File->Save As…. The dialog shown
below will be displayed.

Choose a name, title and comment, then click the Save button. Click the  button or use Measurement-
>Saving Defaults... if you need to modify the saving defaults.

6.1.7 Changing plot settings

We will now find the sound card delay in the unit samples. First click in the upper plot window to set it as active (a
small border will appear around the active plot). Then go to Plot->Plot Type Settings->Active Plot… or click the

 button on the Plot toolbar. This will open the Time Data Settings dialog box since Time Data is the active plot.
To the upper left select Time [samples] as axis unit for the x-axis:

Zoom in on the x-axis of the upper plot. Do this by typing the number 100 in the edit box
 found in the Plot Toolbar (usually it is placed at the lower left in WinMLS, you

can turn it on/off from the View menu). Then the upper window will display the first 100 time samples of the x-axis as
shown in the figure below.
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From this we see that the sound card has a delay of 41 time samples. It is possible to correct for this delay as explained
in the measurement part of the FAQ

Note that you can also use the arrow keys to move the axis limits. This is the fastest way of making changes.

Try this: Hold down the Alt key while holding down the Left and Right arrow keys. This will move the upper axis
limit.
Then try this: Hold down the Ctrl key while holding down the Left and Right arrow keys. This will move the lower
axis limit.
Finally: Hold down the Shift key while holding down the Left and Right arrow keys. This should auto-scale the
lower and upper axis limit.

Note: If you need to set the vertical axis limits, use the same method as above but use the Upper and Lower arrow
keys.

Now restore the old x-axis unit Time [ms] from the Time Data Settings dialog box and restore the maximum axis

value by clicking the  button.

We will now plot the impulse response using dB as the y-axis. To do this, first click in the plot window to make it
active, then push the F5 key. This will open the Time Data Settings dialog box. In the upper left select dB as axis unit
for the y-axis:

Click OK to exit the dialog. This will update the plot with the new settings. The result should look similar to the figure
below.

Figure 2 A Digigram VX222 sound card measured loop-back, plotted using dB as y-axis.



6.1.8 Verifying the sound card measurement

If your loop-back sound card measurement performed above looks suspicious, we recommend that you first compare it
with the other measurements of sound cards. Click  on the standard toolbar or use File->Open… to open a new
measurement as shown in the figure below.

Double-click the Soundcards folder shown in the figure above to display the available measurements of sound cards.
Note that you can select several files by holding the Ctrl key while left- clicking. As shown in the figure below (some
of these files may not be found in your installation, but they can be found at our homepage or by contacting us).

Click  to open the file(s). 

You may now see the dialog shown below. Use this dialog to make changes, e.g., if you want to add new curves on top
of the existing curves or to erase the existing curves when adding new curves.
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Note: If  shown above is not checked, this dialog will not be displayed when a new
curve is added. When you become more familiar with WinMLS you may not want to display this dialog, but for a
beginner it is useful.

The result will be similar to the figure shown below (some changes to the layout have been done, which will be
explained later). From the figure we see the results from the different sound cards. The measurement in brown could
probably be improved by optimizing the volume settings, but we see that the frequency response is quite smooth for all
the measurements.

Note: In the figure below, the order of the plots are changed, displaying the time data (impulse response) in the upper
plot. The order of the plots can be changed from Plot->Plot Type/Routing/Test....



6.1.9 Sound Card Troubleshooting

If the response of your sound card does not look at all like the other sound cards, check that 
• your settings are correct
• the cables are properly connected

6.1.10 Saving the settings

If you want to keep your WinMLS settings when you restart WinMLS it is recommended that you store the setup. On
how to do this see the Store a backup of your setup section.

6.2 Measurement 2: Measurements requiring input calibration

If you are only interested in relative results and not absolute values such as Volts and SPL (sound pressure level), you
may skip this calibration part.
Some applications require calibration (for example to measure absolute values of sound pressure level, e.g. dBA) If
your application requires calibration, please read this example that explains how to obtain calibrated SPL values, such
as dBA. The easiest way of measuring dBA-level is to use an acoustic calibrator. Alternately, calibrated measurements
can be performed if the sensitivity of your microphone is known.

6.2.1 Preparation: Calibrating the gain steps of your mixer

The advantage of calibrating the gain steps of your mixer is that WinMLS will automatically compensate by the
appropriate number of decibels when you change the mixer volume. 
If you do not do this mixer gain calibration, you must redo the level calibration each time you change the WinMLS
mixer volume. If you don’t mind recalibrating if you change your WinMLS mixer volume or if you are not using the
WinMLS mixer, skip the rest of this section.

In order to do the mixer calibration, go to Measurement->Sound Card... and in step 3. Select mixer (volume

control), make sure  is selected.
Note that this may not be possible on some sound cards since they do not support the Windows mixer. If this is the
case, it is not possible to calibrate the mixer gain steps since WinMLS cannot control your sound card mixer, so you
may skip the rest of this section.

After setting WinMLS to control the Windows mixer, click the  button found in step 3d. to
calibrate the sound card mixer. 

As shown in the figure below you can decide if you want to define the gain steps of your mixer. 
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If your sound card is not found in the list shown above or you want to make a new gain steps file, click the 

button to start the mixer gain step calibration procedure. This procedure may take a few minutes. Click the 
button in the dialog if you need more information.

If you wish to calibrate the output, the procedure is very similar. When you are finished, click the  button
to close the dialog.

6.2.2 Combined input calibration example: Calibrating to measure absolute SPL

Go to Measurement->Calibration..., in the dialog and click the  button shown below.

Make sure Use input calibration is checked.
You should now see the dialog shown below.

Note: A faster method of displaying this dialog is to click the  button on the Standard toolbar.

In step number 1a, make sure  is checked and select

 in step number 1b. as shown above.

In step number 2, we have selected . If you select , you first need to calibrate your sound card

before calibrating your microphone (or another transducer). The  calibration must be used if you do not

have a calibrator but the sensitivity of your microphone is known (e.g. 20 mV/Pa). Use also  if you have
an external input amplifier with fixed gain steps and want to adjust the gain steps of this amplifier, or if you are using
WinMLS to perform both electrical measurements and measurements using a microphone. 

If you want a quick and simple calibration, we recommend that you use  as selected above.



Note that the number  shown in the figure above is updated after the calibration. It shows the maximum
input level that WinMLS is able to measure (a higher level will result in digital clipping). In this case it is 130.654 dB
SPL. If you want to measure SPL higher than 130.654 dB, e.g. 140 dB, you have two alternatives:

• If WinMLS is set to control the sound card mixer, and the input volume is not set to minimum during the
calibration, you can measure higher input levels just by decreasing the sound card mixer input volume slider.

• If WinMLS is not set to control the sound card mixer, you must decrease the sensitivity on either the sound
card, pre-amplifier or microphone and redo the calibration.

In step number 3, click the  button to start the calibration.

The dialog shown below will be displayed (it may look somewhat different dependent on the selected type of
calibration).

Type in or choose the correct settings for your calibrator. In the figure above 1000 Hz and 94 dB is selected. You will
find the output level of your acoustic calibrator in the calibrator documentation (usually it is also written on the
calibrator). 

Connect the calibrator to your microphone. 

Click the  button (shown in figure above).
Turn on the calibrator to see if the input level is acceptable. 
The WinMLS mixer dialog will pop up to give you the levels, if not, you can also find the levels on the status bar
found at the very bottom of the WinMLS program . The level should be in the range -30 dBFS to -1
dBFS. If the level is less than –30 dBFS, it should be increased (a warning will be given if this is the case when you
perform the calibration).
Click the  button to perform the calibration. This will exit the dialog box if the calibration is successful. It
takes a few seconds and afterwards the new conversion factor and date and time for the calibration is displayed as
shown below.

Now click the  button to exit the calibration screen. 
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This completes the calibration of input channel 1. Note that if you are doing a 2-channel measurement and also want
calibrated values for channel 2, you need to calibrate channel 2 as well.

6.2.2.1 Verify that the calibration is correct

After the calibration is done you should perform a measurement to verify that the calibration is correct. Do not remove
your calibrator and make sure it is turned on while doing this measurement.

Go to Setup->Load... and load the setup named Level (Noise)_Leq (dBA, dBC, etc., Third-oct. Bands). As shown
in the figure below, the dBA value and the octave band level at 1000 Hz should now be very near 94.0 dB.

6.2.3 Individual calibration example: Measuring voltage using an adjustable attenuator

Go to Measurement->Calibration... and in the dialog box, click the Calibrate... button shown below.

You should now see the dialog shown below.

 



(A faster method of displaying this dialog box is to click the  button on the Standard toolbar.)

Follow this procedure step-by-step. 
In step number 1a, make sure  is not checked.

In step number 2, select . We select  since we will connect an external input
attenuator/amplifier and want to be able to adjust the gain steps of this device.

Note that the number  shown in the figure above is updated after the calibration. It gives you the maximum
input level that WinMLS can measure (a higher level will result in digital clipping). In this case it is – 4.731 dBV. 

In step number 3 click the  button shown below to start the calibration.

The dialog box shown below will be displayed (it may look different dependent on what type of calibration is
selected).

Follow the procedure in the dialog shown above.
Note: In step 2 above it may give better results if you use 100 Hz instead of 1000 Hz because in general a voltage
meter may be more accurate for 100 Hz.

You can click the  button (shown in figure above) to see if the input level is acceptable. The WinMLS mixer
dialog will pop up to give you the levels, if not, you can also find the levels at the status bar found at the very bottom
of the WinMLS program . 
If the level is less than –30 dBFS, it should be increased. A warning will be given if this is the case when you perform
the calibration and an explanation will be given on how you can increase the level. 
Now connect a volt- meter to the sound card output and measure the Vrms level. Type the measured level in step
number 5.
Click the  button to perform the calibration. This will exit the dialog box if the calibration is successful. It
takes a few seconds and afterwards a new conversion factor and date and time for the calibration is displayed as shown
below.

In step number 4a, select .
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In step number 4b, click the  button to open the browse dialog shown below.

The file named BAAP is selected. It contains the gain steps for the active attenuator we sell. BAAP stands for
Balanced Active Attenuator and Probe. You can open the file by right-clicking on it as shown in the figure below.

Select Open With found in the bottom of the figure below, then select Notepad.

The file is very simple and contains the numbers shown below.

20
0
-20
-40
-60

You can modify the numbers and also save with a new filename, but you must save the file in the same folder.

In step number 4b, select the gain step that your attenuator/amplifier is set to. In the example below, we have set it to –
60 dB, it will then attenuate 60 dB and the calibration will compensate for this.

Now click the  button to exit the calibration dialog and to complete the calibration.



6.2.4 Microphone magnitude frequency response correction

If you want to plot the frequency response as shown in the figure below, you can apply a correction for the magnitude
frequency response of your microphone. Note that this compensation will only apply to this magnitude frequency
response plot type (it can also be selected for the waterfall plot type, but not any of the other plot types). So for many
applications you can skip this part.

The data for your microphone needs to be in a file containing the frequencies as first row and level as second row.
You can write comments in the upper lines. An example of such a microphone compensation file is shown below
using comma as separator, you may also use tab as separator.

"Transfer Function Mag - dB volts/volts”
      "Hz"      "Data"
  13.81928,   5.60
  50.67069,   5.60
  198.0763,   5.07
  999.5946,   4.52
  3,150.796,   4.31
  10,000.55,   2.88
  15,998.12,   1.58
   20,001.1,  -0.78
  24,999.08,  -5.81

WinMLS will do a spline interpolation of the data so that a continuous spectrum compensation will be made.

Save such a file with the extension ‘.txt’ under the WinMLS subfolder named Microphone Compensation shown at
the bottom in the figure below.

To turn on the microphone compensation, go to Plot->Plot Type Settings->Frequency Response/Spectrum.... This
will open the dialog box shown below. 
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Now make sure  is checked. Then select the microphone compensation file, in the figure above we have

selected the file named ‘Neutrik 3382 example.txt’ . It is also possible to
correct for multiple microphones in case you are doing multi-channel measurements.

6.3 Measurement 3: A simple loudspeaker measurement

This section assumes that the first measurements walk-through sections have been completed.
Note: For most sound cards, except for the ones we recommend, this measurement procedure will not measure the
distance between the loudspeaker and microphone (also called ‘time of flight’ and ‘initial time delay’). To measure
this using any sound card will be explained later (using loop-back).

6.3.1 Preparation

Connect a speaker to the sound card left channel output. Connect a microphone to the sound card left channel input.
The microphone input can also be used, if any. In this case make sure that microphone is set as 3b. Mixer input in
Measurement->Sound Card... as shown below.

Place the microphone in front of and near the loudspeaker.

 

Loudspeaker  
as Output 

Sound Card 

Left    Right 
   Input 

Right   Left 
 Output 

Playback 
signal 

Microphone  
as Input 

Recorded signal  

Figure 3 Schematic diagram for a one-channel measurement



6.3.2 Measurement procedure

Go to Measurement->Test Levels to display the dialog showing the input and output levels. Adjust the input or
output volume so clipping does not occur. An input level of around -6 dBFs is fine.

Go to Measurement->Start to start the measurement.
When the measurement is finished, it should look similar to the figure shown below, except that in this figure the plots
are switched (the magnitude frequency response plot is displayed below the time data plot).

6.3.3 Post-processing the measurement

A typical result is shown in the figure below where we have used a typical low quality loudspeaker and microphone,
thus showing how low quality equipment can influence the measurement (this can be corrected).

In the plot in the figure below there are a few changes compared to the settings in the setup:
• The plots have switched order, showing time data on top.
• The time window used in the figure is rectangular and 50 ms. The time window in the setup is half-cosine and

200 ms. The limits can be changed by clicking and dragging, or making adjustments in the Time Window
Toolbar shown in the middle of the figure above. Decreasing the window size will reduce the noise in the
frequency response, but it will also give a decreased frequency resolution and thus false results for very low
frequencies.

• The Frequency Resolution Line shown to the left in the figure below depends on the window size and is
supposed to warn the user where the results may not be trusted. For frequencies at the thick part of the line,
the results should not at all be trusted. For frequencies at the thin part of the line (which is twice the length of
the thick line), the result is not certain. To display the frequency resolution line, go to Plot->Plot Type
Settings->General Frequency Domain... and make sure the check box  is
checked.

• We have used a MLS noise signal instead of the sine sweep that is default. This MLS signal causes the
spurious peaks that are shown at the end of the impulse response. When using the sine sweep signal, these
spurious peaks should not be shown.
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Figure 4 Multimedia microphone and loudspeaker measured on axis at a distance of ~20 cm. Time window 50 ms.

Note that if the frequency resolution is not sufficient, two resonance peaks may not be resolved, but shown as one
peak. I am not sure if this statement refers to the above figure or is a general statement describing one problem
resulting from the poor resolution These resonance peaks can be resolved if the time window size is large enough. But
this is a tradeoff since the frequency response would then include reflections from boundaries near the
speaker/microphone.

6.4 Measuring correct delay time
In this section we will discuss why we should be interested in measuring delay time and how this can be done using
WinMLS 

When calibrating a surround system, one of the issues is to find is the delay time from each loudspeaker position to the
measurement position. This must be found, since the surround system processor can correct for this delay time and
thereby improve the sound quality. You can find this delay time by measuring the distance, but it can also be found
using WinMLS. How to find this using WinMLS will be explained next.

The challenge when measuring delay is that many sound cards usually do not start to record and playback
simultaneously, and this delay between playback and record is usually not constant. Exceptions to this are the Lynx,
Card Deluxe, Siena/Marc 8 and Vxpocket/VX222 sound cards. Read more about this in the Sound cards section and
the Measurement->System Delay… section.

If you have one of the sound cards mentioned above, the delay can easily be measured, but the delay of the sound card
AD/DA converters gives an extra delay of about 1 ms. This delay can be corrected. The following sections explain the
various method of measuring the correct delay.

Note that this will not correct for the delay of the sound card AD/DA-converters, which usually is from 10 to100
samples. Removing this delay is the second problem if one wants to measure the exact distance from the loudspeaker
to the microphone. As an example, a loop-back measurement of the Soundblaster Extigy sound card is shown below.
We see that it is 40 samples long and in the right figure below we have changed the x-axis to meters to see that it is
equal to ~0.29 meters.
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In this case, the loudspeaker-microphone distance result measured will be 40 samples too long since the sound card
AD/DA-converters increases it. This delay can be corrected by subtracting 40 samples from the initial time delay
measured when measuring the loudspeaker-microphone distance.

Corrections can be made automatically. To do this, you must correct for the delay of the sound card. The easies way of
solving the problem with the delay is explained in Measurement walk-through 4 where channel two is used as
reference. You may go directly to this part and skip the next of this part. You may alteratively go to Measurement
walk-through 5 where a correction measurement is used to get the correct delay.

6.4.1 Finding delay from Time Data plot type
The safest way of finding the initial time delay is to plot the impulse response and manually detect where the direct
sound occurs. In the example below, a part of the impulse response is plotted using a vertical axis in dB. This makes it
easier to see the pre-ringing that may occur. This is seen as the small peak to the left of the first large peak. The delay
is given by the large peak.
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There are also other ways of finding the time delay and displaying it as a single value, e.g. if comparing several
measurements when aligning a surround setup as shown in the next section. Note that the vertical axis is chosen by the
vertical axis used by the Time Data plot type. The default is milliseconds, but in the examples below it is changed to
meters.

6.4.2 Delay/Distance from Parameters plot type
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The plot type Parameters has this option for plotting Delay/Distance as shown in the figure above. The algorithm
detects where the impulse response starts (the maximum of the impulse response is detected and the delay is set to
that value). 

In this example, the delay/distance is displayed in meters. This can be changed e.g. to milliseconds from the Plot-
>Plot Type Settings->Time Data… dialog. In this dialog, make sure milliseconds is selected as horizontal axis
instead of meters.

6.4.3 Delay from Room Acoustics plot type
The plot type Room Acoustics also has an option for finding the time delay or distance, and this is the algorithm
that is used when computing the room acoustics parameters under the Calculate menu. Note that this algorithm
some of the pre-ringing, so the value for the initial time delay is usually a little shorter. The result is displayed
using only one decimal as shown below. 

This plot type will only display the result in meters.
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6.4.4 Delay from Group Delay plot type
The plot type Group Delay displays the delay in milliseconds as a function of frequency. In case of a simple
impulse response, such as for a sound card, plotting the group delay will give the initial time delay with accuracy
better than 1 sample as shown below. The delay can be found by reading the value at the vertical axis at e.g. 1000
Hz. (In the plot below the group delay is smoothed in 1/6 octaves.)
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But for
more complicated impulse responses, the curves are more complicated. Shown below is the result from the
measurements used as examples in the sections above. We see that the delay changes somewhat as function of
frequency.



1/6 Oct. Smoothed Group Delay - Studio Measurements

Frequency [Hz]
100 1 000 10 000

Ti
m

e 
[m

s]
40
20

0
-20

6.4.5 Delay from Frequency Response - Spectrum plot type
As we see in the title of the plot below, the delay is displayed in both milliseconds and meters.

In order to display the delay in the title, go to Plot->Plot Type Settings->Time Window…. In this dialog make sure
the check box shown below is checked. 

If the check box is not checked, the delay will not be displayed in the title.
Note: The delay displayed in the title is given by the start of the time window. This algorithm will include pre-ringing
and may not always be correct. If you are in doubt, inspect the impulse response by displaying the Time Data plot
type.

6.5 Measurement 4: Measure correct delay and frequency response using channel 2 as
reference

For some applications, correcting for your measurement system (usually only the sound card) is recommended. A
simple way of doing this correction is to use channel 2 as reference. But for other applications, this is not required. If
you know that you are going to use WinMLS only as a signal generator or for measuring reverberation time or
background noise you may skip this part. 

Note: If you are using the USB Pre sound card, or another sound card where the input sampling frequency is not
exactly the same as the output sampling frequency, to obtain the best results you use channel 2 as reference as will be
explained below.

This section assumes that you have completed the first measurement walk-through.
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6.5.1 Connect a loop-back to be used as reference

A loop-back is typically a cable connected from the output to the input of the sound card as shown in the figure below.
The output signal is always played back in the left channel and the loop-back output signal is played back in the right
channel (for >2 channel measurement other rules apply). Connect the cables as shown in the figure below, with a cable
between right channel output and right channel input. 
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Figure 5 Schematic diagram for one-channel measurement using loop-back

You might need to purchase extra cables for the sound card to be able to connect the loop-back.

Note: The microphone input on a standard sound card is mono. If you try to connect to such an input, no right input
channel exists. If this is the case and your sound card has a line input, you may connect the loop-back input cable to
the right channel input of the line input. 
If your sound card only has a microphone input, which is the case for some built-in laptop sound cards, you cannot do
what is described in this section. However, you can still correct for your measurement system as explained in the
Measurement 5 section below.

6.5.2 Using channel 2 as reference

Now we will use channel 2 as reference. Note that if you want to perform a 2 channel measurement (e.g. measuring
the frequency response of 2 microphones) you cannot use this method since channel 2 is used as reference. If you want
to do a 2-channel measurement, skip the rest of this section.

Go to Measurement->Settings.... In step number 6. set-up the reference for the calculation of the impulse/frequency
response as shown below

The type of reference you can select is listed from the types below.



If you select Right channel input, the input signal from channel 2 is used as reference for computing the impulse
response. The sound card response is subtracted from the measurement result assuming that channel 1 and channel 2
are equal. This setting should work for all sound cards that have a stereo input.
The response and delay of the sound card will automatically be corrected using this method.

6.5.3 Verify that the channels are equal

To verify that the channels are equal, connect the output left channel to input left channel. Do the same with the right
channel by connecting the output right channel to input right channel.

You should also make sure that the volumes are set equal for both channels. If not, the frequency response will not be
centered at 0 dB but will have an offset that is determined by the volume difference.

Test and set the levels from Measurement->Test Levels. Adjust the volumes if required. The input signals for both
channels should be equal and in the range –30 to –3 dBFS.

Start the measurement from Measurement->Start. You should now see a flat magnitude frequency response as shown
in the figure below.

The Time Data plot should show the value 1 at the first sample and very near the value 0 at the other samples. If you
change the vertical axis from Linear to dB, you will see a noise floor that should be around –100 dB as shown in the
figure below.

6.6 Measurement 5: Measure correct frequency response and delay using internal
reference

The easiest way of correcting for the measurement system (typically the sound card) was explained in the section
above. You may also correct for the measurement system using the method described in this section. 

101



The advantage with this method is that it does not use an input channel as reference signal during the measurement,
thus all channels can be used if you want to measure several channels simultaneously (e.g. the frequency response of
multiple microphone positions).

Since this method uses a saved measurement of the same channel as reference, it will not matter if input channel 1 and
channel 2 are not equal which is a problem in the method described in the section above.

In Measurement->Settings..., select Generator as shown in step number 6 in the figure below.

When you select Generator, you can use all available input channels for measurements. This means that you can
measure the impulse/frequency response of two microphones simultaneously using a standard stereo sound card.
Measuring two channels simultaneously is not possible if you use Right channel input as reference, since then one of
the two available channels is used for the reference signal.
Note that Generator will not work very well if your sound card's input and output sampling frequencies are not
exactly the same (the deviation may be less than 1 Hz), as is the case with the USBPre manufactured by Sound
Devices(Trademark).

When using Generator, the sound card delay and frequency response are not corrected unless the  check box
is checked in step number 7 shown below.

If  is checked before the measurement is performed, it will correct your measurements for the influence of
the measurement system. 

Important! Do not check the  check box unless you have performed a correction measurement as explained
below. If you correct using a wrong correction measurement, the measurement results will obviously be wrong.

With the term “measurement system” we usually mean your sound card, but it is possible to include an amplifier as
well. We also sell a special attenuator (BAAP – Balanced Attenuator and Probe) to be used to measure electrical
signals that have too high voltage outputs for the sound card to handle. If you are using such an attenuator, the
amplifier can also be included in the correction.
In order to do this correction, your measurement system first has to be measured. The procedure for this is described
below.

We can measure the response used for correction simply by connecting a cable from the output to the input of
the sound card. Signal processing theory tells us that this correction can be used to "subtract" the influence of
the sound card from our measurements.

Note: If you want to record a signal only, e.g. to measure the background noise, it is more problematic to
correct for the sound card. This is because when we measure the influence of the sound card, we measure both
the input and output. WinMLS currently does not have a method for an input-only correction, except for the
microphone compensation feature found in Plot->Type Settings->Frequency Response/Spectrum....

Measure the measurement system (sound card) using the following procedure:
1. Connect a cable from the input to the output of the sound card.
2. Make sure the measurement system correction check box  is turned off as shown below. 

3. Perform a measurement.
4. Turn the measurement system correction on: . 



5. Save this measurement as the measurement system correction measurement by clicking the 
button. Then the active measurement will be set as the correction file. The suggested name is the same
of the sound card as shown below

 

6. Perform a measurement again. This should now be flat in the frequency domain. Also inspect it in
time domain it should be a very short peak (a so-called Dirac pulse) at time 0 milliseconds. 
Note: If you want to measure correct delay, check if you sound card is capable of doing this. If not,
you can use the loop-back feature explained in the next section. Click the  button to set the
delay settings.

7. Connect the usual equipment and perform measurements with and without the system correction and
observe the difference.

If you measure using synchronization loop-back, you might experience a small tail at the very end of the impulse
response (it can be seen if you plot the impulse response on a dB scale). This is a result of the correction filtering
procedure. If this tail is less than –50 dB below the maximum of the impulse response, it should be nothing to worry
about for most applications.

If  is checked, the relative gain of the system you are measuring can be measured, even if no calibration has
been performed. If the amplification of the system you are measuring has increased 5 dB after you performed the
reference measurement, the peak of the impulse response and frequency response curve will therefore be at 5 dB. The
linear amplification may be displayed by plotting for example the first part (it is given by the maximum) of the
impulse response using linear vertical axis. To plot the amplification in dB, do the same using a logarithmic vertical
axis, or plot the magnitude frequency response.

Once in a while you should verify that the measurement system correction is valid. Especially if you do not have
control over your sound card’s delay. You can test this by doing a loop-back measurement of your sound card (output
connected directly to input).

6.7 Measurement 6: Measure in a “safe” way using loop-back

The sections above have explained how to connect a loop-back. The output signal is always played back in the left
channel and the loop-back output signal is played back in the right channel and normally recorded in the right channel.

The main purpose of measuring using this loop-back is to determine the correct delay of the system to be measured
(e.g. the distance between the loudspeaker and the microphone). Most sound cards do not start playback and record
simultaneously, it is different from one measurement to another. This makes it impossible to find the delay without
this loop-back.

Note that the procedure described here is not the same as using the right channel input as reference. The loop in the
right channel is in this case only used to find the correct delay by sending out a pulse before the measurement starts.
When using right channel as reference, the response of the sound card is corrected for. The advantage with this
method is that you can measure two impulse/frequency responses simultaneously.

When using loop-back it is also possible to detect errors in the measurement caused by non-continuous play or record.
This is usually only a problem for a slow PC and for certain USB sound cards, but can occur if you run other tasks on

103



your PC while performing a measurement. If such an error is detected, the measurement will be canceled, a new
measurement will start and a warning is given in the status bar.

Go to Measurement->Settings… and make sure the dialog looks like below.

In this dialog, select Internal as shown in step number 6 below. 

Now click the  button as shown below.

In the Delay dialog, select ‘Yes, with loop-back and end-check’ as shown below.

Now select the Loop-back Input you used for connecting the loop-back to. In the figure below Microphone is
chosen. Make sure Loop-back right channel output o input channel is set to Right. If WinMLS is not set to control
the Window mixer, you cannot set these from WinMLS.

The sound card delay should now be set in samples. We have already measured the sound card delay in the first
measurement walk-through. This number can vary from 10-80 samples. After typing this number, click the OK button
to exit the dialog. 

6.7.1 Loop-back measurement procedure

Select Measurement->Test Levels to display the dialog box showing the input and output levels. If your sound card
supports the WinMLS mixer, the volume controls Sync. Out and Sync. Input will be displayed as shown to the right
in the figure below. Use these sliders to set the volume for the loop-back synchronization signal.



Select Measurement->Start to start performing the measurement. An error message will be given if the loop-back
volume is too low or too high. Adjust the volume accordingly.
The result of a successful measurement should now have almost the correct initial time delay. But as we have seen, the
sound card has a delay of some samples, which is usually less than 1 millisecond. To subtract this delay a
measurement system correction of the sound card must be performed as described in the Measurement section of the
FAQ or channel 2 can be used as reference.

6.7.2 This happens during a loop-back measurement 

1. When the measurement is started a synchronization signal is first sent through the right channel output to the
loop-back. The delay of the synchronization signal is stored and is later used to find the correct system delay.

2. The output signal is now played on left channel output through the loudspeaker. The signal is recorded by the
microphone.

3. After the left channel output signal is finished, the synchronization signal is played once more on the right
channel output. This synchronization signal is compared against the first synchronization signal and the time
difference is computed. The purpose of this is to check that there has been no gaps or glitches in the playback
or record. This final check can be turned off by selecting as shown below

4. If no error has occurred, the system impulse response is calculated. The sound card delay (pipeline delay in
sigma-delta converters) is added in order to include the whole system response (the default is 40 samples, but
should be measured for the sound card as explained in the Measurement 1 section).

6.7.3 What to do if the loop-back synchronization signal not strong enough
The first thing would be to try to increase the mixer synchronization input and output level. The settings in the
suggestions below are found.

1. Check that the cables are connected properly.
2. Check that you have chosen the right audio devices in Measurement->Sound Card....
3. Check that you have chosen the right sync input line and channel. Go to Measurement->Settings… and click the

 button to display the dialog shown below.
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4. If nothing above helps, try to turn on the  check box. This may not work on old PC’s
with bad performance.

6.8 Measurement 7: How to measure correct delay time when using the sound card mono
microphone input

The advantage with this method is that you do not need any cable connection to measure delay.

Go to Measurement->Settings… and click the  button. In the dialog select a Loop-back input line that
internally loops the output sound card signal to the input. For the sound card in the example, this is named Wave Out
Mix as shown below.

In addition, WinMLS must control the Windows mixer and you must set the synch. input and output levels to get a
high enough synchronization signal input. 

6.9 Measurement 8: Measuring 2 channels simultaneously

The number of channels to be measured is set in the upper right in Measurement->Settings…. The figure shows the
setting for performing a two-channel measurement.



A 2-channel measurement is quite similar to a one-channel measurement. But if you are measuring using the loop-
back, special consideration must be taken as described below. The rest of the procedure is very similar to a one-
channel measurement as described in the previous chapters.

6.9.1 Synchronization Loop Connection for 2-channel Measurement

To perform a 2-channel measurement in loop-back mode, the loop-back must be mixed with the measurement signal in
one of the channels. How this is best done depends on if your sound card has one or two input lines.
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2-channel loop-back for sound cards with one input only

If your sound card only has one input line, a device has to be used for summing the signals as shown in the figure
below. We see that the signal going to the Right input consists of both the microphone signal and the loop-back signal.

To sum these two signals, an audio mixer or so-called combiner may be used. A passive device (consisting of 3
resistors) can also be used but it may give impedance problems. Contact us for purchasing such a device.
 

Sound Card 

loop-back signal 

Left Right 
   Input 

Output 
signal 

Right   Left 
   Output 

Figure 6 Schematic diagram for two-channel measurement using synchronization loop-back for one single input.

6.9.1.2 2-channel loop-back for sound cards with two inputs (e.g. line and microphone input)

If your sound card has two input lines, e.g. Line and Microphone input, no external device is needed to sum the
signals needed. The signals can be summed using the two physical inputs of the sound card. Some sound cards also
have an internal loop-back that can be used. These two options are explained below.

6.9.1.2.1 Loop-back using two physical sound card inputs

Go to Measurement->Settings… and click the  button.



Choose a different line Loop-back input than the line you have selected for performing the measurement. If your
Loop-back input channel is mono, make sure the Left channel is chosen as shown below.

Connect the output of the loop-back (which is the right channel) using a cable to the line and channel you have chosen
as input for the synchronization loop. Note that you may have to split the cable you are connecting to your output to
access the output-signal that is on left channel (see the figure in the previous section).

6.9.1.2.2 Loop-back using sound card internal loop-back

The advantage with this method is that you do not need an extra cable.

Go to Measurement->Settings… and click the  button. In the dialog select a Loop-back input that
internally loops the output sound card signal to the input. For the sound card in the example, this is named Stereo
Mixer as shown below.
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6.9.2 Synchronization Loop-back Connection for Mono Full Duplex Sound Cards

Read this section only if the sound card is only capable of one-channel simultaneous play and record. This is a very
special case.
If you have such a card you cannot perform 2-channel measurements. The card will support 1-channel measurements
without using a synchronization loop. But if the card has both a microphone input and a line input and if it supports
the WinMLS mixer, WinMLS also support 1-channel measurements using synchronization loop for such cards. To do
this, you must choose different inputs for the Input Line and the Loop-back Input Line as described in the chapters
above. Then make the synchronization loop by connecting a cable from the sound card output to the input you choose
as Loop-back Input Line. Note that you need to split your output cable from the sound card. One part is for the
synchronization loop that we just showed how to connect. The other part is for the output signal.

6.10 Measurement 9: Performing a triggered measurement (e.g. balloon burst, or pistol
shot)

WinMLS can be used to record the response from a transient signal, such as a hammer strike, balloon burst or pistol
shot. 

Go to Measurement->Settings… and select the Scope Mode/Data Acquisition settings shown below. We use this
measurement mode since we will only record data.

Then turn off the generator by making sure  is not checked. Then set the input signal type to Transient
as shown below.

Now click the  button to display the whole dialog and make sure  is checked. 

In the example figure above the trigger level is set to –30 dBFS. This means that WinMLS starts measuring when the
input signal is -30 dB below the full scale input level (full scale is the higest possible level, above this level digital
clipping starts).

The Pre-trigger duration shown above determines how many milliseconds before the trigger level is reached we want
to include in the measurement. 

The Pre-record duration shown above is set to 200 to avoid that the trigging should start in case the sound card should
give a pulse when recording is starting (this may happen with some sound cards).



Note: In the left part of the Status Bar (positioned at the bottom of the WinMLS program) shown above you will be
notified when the measurement starts.

6.11 Measurement 10: Short guide to reverberation time measurements

This will explain how to perform reverberation time measurements and it is also useful if you are going to measure
other room acoustical parameters. In addition, it will describe how to find the statistics mean value and spread values
and how to export the results.

6.11.1 Introduction

WinMLS is software for measuring audio, acoustics and vibrations. By loading the correct setup, WinMLS becomes a
powerful and user-friendly system for measuring reverberation time as shown in the figure below.

6.11.2 Preparation

If you are going to use WinMLS for analysis only and not for performing any measurements you may skip the section
below and continue with the next section.
Before we start measuring we must load the correct sound card settings if that is not already done. How to do this is
described in the Sound card settings section. 
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6.11.2.1 Preparation for performing a measurement

To perform a simple 1-channel measurement, connect a microphone to the left input of the sound card and a
loudspeaker to the left output as shown below
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To load the setup for measuring reverberation time, go to Setup->Load… and find the setup named Room
Acoustics_Reverberation Time shown in the figure below

In the following sections several changes to the default setup will be suggested. You may store these changes. Do this
from Setup->Store….

6.11.3 Results

You can open a measurement file (e.g. with extensions .wav or .wmb) from File->Open.... For the room acoustics
parameter(s) to be calculated, the measurement or measurement file must contain an impulse response (measurements
that are wrong and contain e.g. background noise only will normally give an error message or completely wrong
results).

After a measurement is opened or performed, it will be displayed and look something like that shown below. 



Two plots are displayed, the lower displays the measured impulse response plotted on a logarithmic y-axis that
displays the level in dB. From this plot we see that there is a vertical yellow line to the left. This line detects the start
of the impulse response which is required for some room acoustical parameters but it is not so critical for calculating
the reverberation time.

Note: The upper plot above shows the octave band reverberation time values, the default is one-third octave bands.
How to change the bandwidth will be explained later. 

If you do not want to display the lower plot it can easily be removed from WinMLS. To do this click the  button
on the Plot Toolbar found in the bottom of the screen in the figure above (also see the figure below).

The upper plot displays the reverberation time in third-octave bands. Please note that the yellow number marks 
on each point give an indication of the measurement quality. This number displays the effective decay range (edr) and
should be greater than 25 to give a reliable result (25 is the lower limit for being able to compute T20 strictly
according to the standard). The higher number usually indicates a better quality. In the example plot above, we see that
we do not get any reverberation time values below 100 Hz. This is because the edr value is less than 25 and thus the
results cannot be trusted and are therefore not plotted. The 25 limit can be changed as we see in the dialog box shown
below.

To plot the curves without these  marks, make sure  is not checked in the dialog
box shown below.
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To open the dialog box shown above, go to Plot->Plot Type Settings->Room Acoustics... (or the F5 key or click the

 button on the Plot Toolbar).
You may set the marks to display the reverb time instead of the ‘edr’ as shown in the figure below by unchecking the

 check box as shown in the figure below.
Note: If you plot the reverberation time as marks in the plot as shown in the figure below (where the data is plotted in
octave bands), WinMLS does not do the check on the edr number as explained above.

6.11.3.1 How plotting works

If you are doing several measurements, the curves will be plotted on top of each other if  is checked
on the Plot menu, or if the  button found in the standard toolbar is turned on as shown in the figure below.

6.11.3.2 Save/Export Data in plot

Use Edit->Copy Plot to copy a plot to clipboard. This can easily be pasted to programs such as MS Word. An
example of three measurements plotted on top of each other in WinMLS and exported to MS Word using this method
is shown below.



Reverberation time (T30, 1/3-octave)

Frequency [Hz]
100 1 000 10 000
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2,2
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1,6
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1,2

1

0,8

0,6

0,4

0,2

Curve...\RoomAcoustics\omni.w av
Curve...\RoomAcoustics\f ig8.w av
Curve...\RoomAcoustics\stage.w av

The one-third octave band data can be saved to a text-file using File->Export Data... (shortcut Ctrl+E). An example
of the result when exporting two curves is shown below. The x-axis is the frequency axis.

x-axis Curve...\RoomAcoustics\omni.wav Curve...\RoomAcoustics\stage.wav
40 1.38 0.14
50 0.29 0.40
80 0.24 0.23
100 2.72 0.17
125 2.55 2.17
160 2.48 2.04
200 2.20 2.18
etc...

6.11.3.3 Limit the plotting range, e.g. plotting only in the range 100-5000 Hz

You can set WinMLS to plot in a specified range, e.g. 100-5000 Hz. In the section above we see that WinMLS plots
40, 50, 63 and 80 Hz. We do not want to include these 4 first numbers

To limit the plotting range, go to Plot->Layout->Advanced... and in this dialog box, make sure the setting is set as
shown below.

As explained above we start the range from 4 (since we do not want to include the four first values 40, 50, 63 and 80
Hz. And we end the range at 21, which is the 5000 Hz band.

Remember to store the setup from Setup->Store... if you want to store this setting.

Note: This setting applies for all plot types so if you set the window to display the time data, only points in the range
4-21 will be plotted.
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6.11.3.4 Displaying values in octave bands, octave bands, low-mid-high or broadband

So far the result has been displayed in one-third octave bands, but the result can also be displayed in octave bands,
low-mid-high or broadband. Go to Calculate->Calculation Options… to open the dialog shown below

Find the Bandwidth section and select the desired bandwidth. In the example figure below octave is selected

Frequency [Hz]
63 125 250 500 1000 2000 4000 8000 16000

T3
0[

s]

0,6

0,4

0,2

0

0.52

0.23 0.25
0.33

0.28 0.32
0.38 0.36

0.28

WinMLS Pro

6.11.3.5 Displaying other room acoustical parameters than reverberation time

From the plot type settings (Plot->Plot Type Settings->Room Acoustics... or F5) you can select what parameter you
want to plot as shown below



6.11.3.6 Calculating Statistics

Computing average and other statistics, such as STD, maximum and minimum, can be done in a spreadsheet by
exporting the data, but it can also be done directly in the plot. Doing it directly in the plot is faster.

To do this, first plot the curves you want to compute the mean value from. Make sure the  button is on so the

curves are plotted on top of each other. The  button should also be turned on to display the legend list shown to the
right in the figure below.

Now use Plot->Add Curve(s)... to open the dialog shown below
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Select the radio button  to plot statistics.
Then mark the curves you want to include for computing the mean value. In the example above, all three curves are

marked initially. Then click the  button to add the curve and to exit the dialog. The new curve is named
Mean and is shown in the figure below

6.11.3.7 Auto-statistics

Statistics, such as mean value, can also be set to update automatically. It updates whenever there is a change in the
curves in the plot, e.g. when a new curve is added. Note that the statistics  are computed using the visible curves (the
curves that are checked in the legend in the figure below, ‘1032ACentre’ is not checked and therefore not visible in
the plot).
In other words, in the figure below, the blue curve is set to invisible (unchecked), therefore the auto-statistics is
computed from the black and the red curves only.

To turn on the auto-statistics, you may use the  button from the Standard toolbar.



Open the dialog box containing the auto-statistics settings from Plot->Overlay Settings.... Make sure the settings are
set as shown below.

Click the  button to display the colors and line styles for the Mean curve as shown below

You may set the line width to at least 2 for the green Auto-statistics curve as shown above. A thicker curve will make
it easier to separate the auto-statistics curve from the other curves.

Important: If you want to display only the mean curve and not the other curves, the easiest method is to use the 
button, or Plot->Solo Curve. This is also useful if you want to export only the statistics curves.

If you want to display only the mean curve while deleting the other curves, you must first turn off the auto-statistics

from Plot->Overlay Settings.... Then delete the other curves. If you use the  button to turn off the auto-statistics,
the statistics curves are deleted from the plot.

6.11.3.8 Display the parameters in a table

You can also display the results in a table from the Calculate... menu (select Calculate->Reverb Times (RT-60)... or

the  button as shown in the figure below. The results from the active measurement will be displayed, the name of
this measurement is shown in the title in the figure below.
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Click the  button if you want to copy the data to the clipboard and paste it to a spreadsheet (for example MS

Excel). You can also select an area in the grid as shown in the figure above. Then click  to copy only the data
you have selected. In the figure above T30 for the bands 1000-2000 Hz is marked and will thus be copied.

In this case three reverberation times are displayed, EDT, T30 and T20. EDT is the early decay range (evaluated using
the decay curve range 0 to –10 dB) and should correlate well with the subjective impression of the reverberation.
If the ‘edr number is better than 35 dB, T30 gives the decay time according the definition (starting point –5, decaying
to –35). It is possible to specify this in more detail from Room Acoustics->User Defined->Settings....

The corr number should be as near –1 as possible, if it deviates from this it indicates that the reverberation curve is
not a straight decaying line. An example of such a case is if the room you are measuring has a coupling to another
room with a different reverberation time (e.g. if a large door is open between the two rooms). 
If this is the case, you may select the Schroeder Curve plot type and from this see if it is possible to do the
reverberation calculation in two parts. For example, the first calculation can be done in the range –5 to –23 dB and the
second from -23 dB to –45 dB.

More about measuring

If you are not going to use WinMLS for performing the measurements, you can skip this section.

To get the best results, three things are important
1. Use sine sweep as excitation signal (why will be explained in the following sections)

2. Use as long measurement duration as possible. With single sweep and sampling frequency 48 kHz you can try
40 or even 80 seconds. If the duration is too high, the PC will work very slow or even crash Windows. It
should help to add extra PC-memory. You can also try to change from single to multiple sweeps

, then you can use a much longer duration. But the multiple sweep method is
not so robust against time variance which can be a problem in large rooms or if people are moving around or if
there is temperature changes during the measurement.

3. Make sure you have as high an output volume level as possible from the loudspeaker. If you are using a sine
sweep as excitation signal, be careful so the volume is not too high that you  damage the loudspeaker. If you
are using MLS-noise as the excitation signal, avoid a too high output level to prevent distortion artifacts. You
may experiment with different loudspeaker volume levels to see what level gives the best results.

6.11.3.9 4.1 Theory

6.11.3.9.1 4.1.1 Measure impulse response using loudspeaker



A better result is usually given if the impulse response is measured using a stationary signal played from a loudspeaker
instead of a short pulse. To obtain the impulse response from a stationary signal we use a method called
deconvolution. Also using a stationary signal gives a more accurate and repeatable result than using a short pulse.

6.11.3.9.2 Impulse response

The impulse response is the basis for computing reverberation time and the other room acoustical parameters., Simply
put, the impulse response is the signal you get from a very short pulse, e.g. when you clap your hands. In a room, the
sound will be reflected from the walls, floor and ceiling. The impulse response consists of the reflections that reach
the microphone.

6.11.3.10 Measurements using a loudspeaker

Go to Measurement->Settings... to display the dialog box shown in the figure below.

In , type the estimated maximum approximate reverberation time, if you click on the
list, you get some alternatives.

              

It is also possible to type in another value that those.

Click the  button to display help for more explanation.

In , note that the measurement quality usually improves with increased measurement
duration. But an increased duration may be more demanding for the PC (especially if single sweep is selected as will
be discussed later).

6.11.3.10.1 Setting sampling frequency and sweep range

The sampling frequency and sweep range is set in the bottom in the figure below. You should set the sweep range
somewhat larger than the frequency range you are interested in measuring. The default settings should work well in
most cases.
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6.11.3.10.2 Alternative 1: Measure using a single sine sweep

Single sweep is set as default as shown under option 3. in the  dialog box below because it usually gives the best
results. 

Single sweep is robust against harmonic distortion, which means that you can use a high output volume on your
loudspeaker. 
Single sweep is also robust against time variance, which means that you can get good results even if people are
walking around in the room during the measurement. Read more about the other measurement methods by clicking the
Help button in Measurement->Settings....
The disadvantage with this method is that it can be time-consuming on older PCs to calculate the impulse response.

Note that a few sound cards e.g. the USB Pre sound card will only work if 

is selected in Measurement->Settings.... When this setting is selected you need to connect a cable from the input to
the output of channel 2 (right channel).
Most sound cards (e.g. the VXpocket sound card) will work with the default settings, which is Internal as shown
below.

6.11.3.10.3 Alternative 2: Measure using multiple sweeps



In a situation with high background noise and no time variance you can select  as shown in the
figure below instead of single sweep. A multiple sweep is less computationally demanding but does not offer the same
robustness against time variance as a single sweep. 

6.11.3.10.4 Alternative 3: Measure using MLS

This is a noise-like signal and will not give as good results as when using a sine sweep. Therefore it should only be
used only if the sound of the sine sweep is not desired.

6.11.3.10.5 Using music as excitation signal

This possible, but it is not recommended for high quality measurements.

6.11.3.11 Measure using starting pistol, balloon or hand clap

Open Measurement->Settings... and make sure it looks like below

When you start a measurement, WinMLS will now wait until the input level exceeds –30 dBFS (30 dB below digital
clipping). When the signal exceeds this level, the pistol shot/balloon burst will be recorded in 5.94 seconds and the
reverberation time will be computed.

6.11.3.12 Measuring spatial parameters (LF and IACC)

In order to measure spatial parameters, load the setup named Room Acoustics_Spaciousness (IACC, LF, LFC).

It is not required to measure two channels simultaneously measuring these parameters although it may be useful. It can
also be done using two single-channel measurements.
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6.12 Post-processing 1: Room acoustical parameters

This example on how to post-process room acoustical parameters in WinMLS was done as a part of a round robin. For
more info and for downloading the wav-file used in this example, see
http://www.limsi.fr/Individu/katz/www/IRroundrobin.html

6.12.1 Reverberation time

Task: Find the reverberation time and provide start and stop level criteria. For example, standard T20 or T30, manual
fit, etc.

How to do this in WinMLS: 
From Setups->Load..., load the setup named Room Acoustics_Reverberation Time.
From File->Open..., select the file AnalysisTestSig.wav that you have downloaded from the link above or the file you
wish to analyze. Then the reverberation time will be displayed in the upper plot and the impulse response will be
plotted on a dB axis in the lower plot.

Go to Room Acoustics->Reverb Times (RT-60)..., if the calculation options dialog is displayed, then select the
settings as shown below (change from Third 

Click  to exit the dialog box.Then the result should look like shown below where we also can see the time
window lower limit which is set automatically as default (the start may also be specified manually if that is desired as
described in the FAQ section).



Click the  button to copy the results to clipboard as shown below:

C:\WinMLSmeasurements\AnalysisTestSig.wav
F(Hz)   63  125  250  500

1000 2000 4000 8000
snr(dB) 14.4 23.1 27.7 33.9

36.3 33.7 26.5 16.6
edr(dB) 20.6 33.9 38.9 46.3

48.0 45.7 39.1 29.9
EDT(s) 3.05 2.18 1.69 1.24

1.12 1.10 1.07 0.77
T30(s) 3.03 1.76 1.63 1.22

1.18 1.16 1.12 0.91
corr -0.997 -0.998 -0.997 -
0.999 -1.000 -1.000 -1.000 -
1.000
T20(s) 3.03 1.81 1.49 1.15

1.20 1.15 1.11 0.92
corr -0.997 -0.996 -0.996 -
0.999 -0.999 -1.000 -0.999 -
1.000
r(m) 228.2

We have now found reverberation times T20 and T30.

6.12.2 EDT

Task: Please specify EDT10 and/or EDT15 if available.

How to do this in WinMLS: 
As seen in the section above, EDT is found. By EDT10 we assume it is meant a decay range of –5 to –15 dB which is
the same as EDT. 

But EDT15 is missing in the section above. It is the same as a decay range of –5 to –20 dB

To find this using WinMLS, we need to go to Room Acoustics->User Defined... to open the dialog box shown below
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Here make sure the User Defined Reverberation Time is set to a decay range of –5 to –20 to get EDT15. Note that it
has to be checked as shown above. In addition, check the Clarity (C) parameter, since we need that for later. Finally
click on the list shown above and select 50&80 since we want C50 and C80. You can get any C-value For example, if
you rather want C48 and C84 you can instead write 48&84. All parameters that have time limits have user defined
limits in WinMLS.

Now Room Acoustics->User Defined->Calculate will give you the result shown below

 

In the table above, T15 is the same as EDT15. You can mark the numbers we need as shown above and click the

 button. If you paste it it will contain the octave bands in the range 125- 4000 Hz as shown below:

1.71 1.53 1.17 1.23 1.13
1.14



6.12.3 Clarity

Taks: Please specify C50 and/or C80.

We found both C50 and C80 in the section above. The values are in the range 125- 4000 Hz are:

-8.5 -9.7 -0.6 -0.7  0.2
-0.2

-5.0 -5.9  2.0  1.8  3.5
 3.5

6.13 Post-processing 2: Measurement System Comparison NPL Surrey 2002

For more info and for downloading the measurement files, contact morset@winmls.com.

Note that the sine sweep method in the software was in an early beta version, because of this we have to be careful
when analyzing the data.

Go to Setups->Load... and load the setup named Room Acoustics_ReverberationTime.
Go to File->Open... and open the file named SineSweepHighLevelCut.wav.

The impulse response will be plotted on a dB axis in the lower plot.
Go to Calculate->ISO 3382..., if the calculation options dialog is displayed, then select the settings as shown below

Click  to exit the dialog box. 

6.13.1.1 Setting manual start of impulse response

Setting manual start of impulse response is very seldom needed, but in one of the impulse responses the start was not
correctly set.

If you have done what is explained above, the lower plot should look as shown below.

127



In the figure above, the yellow vertical line gives the detection of the time window. By default WinMLS finds the start
of the impulse response automatically but this can also be done manually. If we zoom in on the start of the impulse
response (click and drag with mouse from upper left to lower right) we see below that the time window starts before
the start of the impulse response.

If we drag the start of the time window a little to the right (click and drag using the mouse) we see in the figure below
that there is a sharp spike just before the impulse response. The WinMLS automatic detection set this as the start of
the impulse response.

Because of this, we will now turn off the automatic detection which is not correct in this case and use manual
detection. To do this, go to Calculate->Calculation Options... as shown below. 



Then click on the  button shown in the figure above to display the dialog box
shown below

Set the start of impulse response to manual as shown in the figure above.

6.13.1.2 Computing parameters

Now go to Calculate->ISO 3382... to compute the parameters as shown below.

 

Click the  button to copy the results to clipboard. The results are shown below (we have put the numbers in a
table. To do this in MS Word, first mark the data, then go to Table->Insert->Table... and the table is automatically
generated): 

G:\BigBackup\WinMLSmeasurements\NPLsurreyWorkshop\SmallRoom\SineSweepHighLevelCut.wav
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F(Hz)   63  125  250  500 1000 2000 4000 8000 16000
snr(dB) 30.1 50.3 53.7 54.3 54.0 55.3 52.6 43.0 24.5
edr(dB) 44.6 57.9 60.3 66.2 69.1 68.8 69.3 61.6 39.8
EDT(s) 0.34 0.29 0.24 0.21 0.22 0.18 0.18 0.20 0.20
T30(s) 0.35 0.26 0.22 0.19 0.21 0.21 0.20 0.19 0.18
corr -0.997 -0.995 -0.994 -0.992 -0.996 -0.998 -0.999 -0.998 -0.999
T20(s) 0.34 0.25 0.20 0.21 0.23 0.23 0.20 0.18 0.18
corr -0.997 -0.991 -0.993 -0.979 -0.995 -0.996 -0.998 -0.998 -0.999
Tc(ms)   32   30   29   20   20   19   19   20   20
C80
(dB)

13.3 19.6 24.0 23.3 20.5 22.0 24.0 24.4 22.9

D50
(dB)

  93   93   94   94   95   96   96   97  100

G(dB) 50.4 55.2 54.6 50.0 45.1 44.0 42.3 37.1 108.0
r(m) 60.8

The last parameter on the list, r(m), gives the distance from the loudspeaker to the microphone in meters. In this case
the r(m) value is wrong, since the sound card was not set to measure the correct time delay. If you have followed the
sections above, you have seen that WinMLS has no problem of measuring the correct time delay/distance if the sound
card is set properly.

6.13.1.3 How to select other parameters

Other parameters, such as C50 and EDT15 can easily be found.

How to do this: 
As seen in the section above, EDT is found. By EDT, it is meant a decay range of 0 to –10 dB.

But EDT15 is missing in the section above. Here we assume it is the decay range of –5 to –20 dB

To find this using WinMLS, we need to go to Calculate->User defined: Settings... to open the dialog box shown
below

 



Here make sure the User Defined Reverberation Time is set to a decay range of –5 to –20 to get EDT15. Note that it
has to be check marked. In addition, check the Clarity (C) parameter, since we need that for later. Finally click on the
list shown above and select 50&80 since we want C50 and C80.

Now Calculate->User Defined->Calculate will give you the result shown below

Here T15 gives the EDT15. You can mark the numbers we need as shown above and click the  button. 

G:\BigBackup\WinMLSmeasurements\NPLsurreyWorkshop\SmallRoom\SineSweepHighLevelCut.wav
F(Hz)   63  125  250  500 1000 2000 4000 8000 16000
T15(s) 0.35 0.26 0.23 0.26 0.22 0.21 0.21 0.17 0.18
corr -0.996 -0.984 -0.996 -0.982 -0.995 -0.997 -0.996 -0.997 -0.999
C50
(dB)

 6.7 10.8 12.1 11.5 13.0 14.1 13.5 14.5 11.7

C80
(dB)

13.3 19.6 24.0 23.3 20.5 22.0 24.0 24.4 22.9

6.13.1.4 What parameters we included for this comparison

Since we want to include both C50 and C80, we cannot use Calculate->ISO3382, but will instead use Calculate-
>User defined: Settings....
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We have also selected speech parameters, by clicking the  button we select that we do not want to consider
the background noise and select the speech parameters we want to include as shown below

Then if we select Calculate->User Defined->Calculate, the result contains all the desired parameters as shown
below.



The data are displayed in a table in the following section
G:\BigBackup\WinMLSmeasurements\NPLsurreyWorkshop\SmallRoom\SineSweepHighLevelCut.wav
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6.13.1.4.1 Results

6.13.1.4.1.1 SMALL ROOM
All data are measured in the same position using a custom made microphone. 
We use the data from the sweep measurements since they have the best signal-to-noise ratio (SNR).
The MLS-based measurement results are also 

F(Hz)   63  125  250  500 1000 2000 4000 8000 16000
snr(dB) 30.1 50.3 53.7 54.3 54.0 55.3 52.6 43.0 24.5
edr(dB) 44.6 57.9 60.3 66.2 69.1 68.8 69.3 61.6 39.8
EDT(s) 0.34 0.29 0.24 0.21 0.22 0.18 0.18 0.20 0.20
T30(s) 0.35 0.26 0.22 0.19 0.21 0.21 0.20 0.19 0.18
corr -0.997 -0.995 -0.994 -0.992 -0.996 -0.998 -0.999 -0.998 -0.999
T20(s) 0.34 0.25 0.20 0.21 0.23 0.23 0.20 0.18 0.18
corr -0.997 -0.991 -0.993 -0.979 -0.995 -0.996 -0.998 -0.998 -0.999
Tc(ms)   32   30   29   20   20   19   19   20   20
C50(dB)  6.7 10.8 12.1 11.5 13.0 14.1 13.5 14.5 11.7
C80(dB) 13.3 19.6 24.0 23.3 20.5 22.0 24.0 24.4 22.9
D50(dB)   93   93   94   94   95   96   96   97  100
G(dB) 50.4 55.2 54.6 50.0 45.1 44.0 42.3 37.1 108.0
STI 0.89    Ratin

g:
Excellen
t

STIrMale 0.89    Ratin
g:

Excellen
t

STIrFem 0.89    Ratin
g:

Excellen
t

RASTI 0.89    Ratin
g:

Excellen
t

%ALcons  1.4
MTI 0.86 0.89 0.88 0.88 0.90 0.90 0.90
MTF
0.63 Hz 0.997 0.998 0.998 0.998 0.998 0.998 0.999
0.80 Hz 0.996 0.997 0.997 0.997 0.998 0.998 0.998
1.00 Hz 0.993 0.996 0.995 0.995 0.996 0.996 0.997
1.25 Hz 0.990 0.993 0.992 0.993 0.994 0.994 0.995
1.60 Hz 0.984 0.989 0.988 0.989 0.990 0.991 0.991
2.00 Hz 0.975 0.983 0.981 0.983 0.985 0.985 0.987
2.50 Hz 0.962 0.975 0.971 0.973 0.977 0.978 0.979
3.15 Hz 0.942 0.961 0.955 0.959 0.965 0.965 0.968
4.00 Hz 0.912 0.939 0.930 0.936 0.946 0.946 0.950
5.00 Hz 0.872 0.910 0.897 0.905 0.920 0.920 0.924
6.30 Hz 0.816 0.867 0.850 0.862 0.883 0.882 0.887
8.00 Hz 0.743 0.809 0.790 0.803 0.833 0.829 0.832
10.00 Hz 0.662 0.741 0.729 0.737 0.774 0.768 0.764
12.50 Hz 0.572 0.661 0.679 0.660 0.704 0.697 0.679
r(m) 60.8

6.13.1.4.1.1.1 MLS-based measurements 
Here is data from the other measurements. Do not use these for the comparison.

6.13.1.4.1.1.1.1 MLS Measurement 1
Here we see that data in the upper and lower band is not valid (red color).



F(Hz)   63  125  250  500 1000 2000 4000 8000 16000
snr(dB) 11.6 27.7 29.6 22.6 26.5 25.5 25.0 23.8 12.3
edr(dB) 28.6 43.1 44.1 37.2 41.9 41.0 42.9 40.9 29.4
EDT(s) 0.24 0.29 0.22 0.15 0.19 0.19 0.18 0.17 0.17
T30(s) 0.38 0.26 0.24 0.23 0.21 0.20 0.19 0.19 0.15
corr -0.989 -0.991 -0.992 -0.997 -0.995 -0.999 -0.999 -0.995 -0.999
T20(s) 0.41 0.27 0.23 0.22 0.21 0.21 0.19 0.17 0.15
corr -0.992 -0.987 -0.977 -0.995 -0.987 -0.996 -0.998 -0.994 -0.999
Tc(ms)   26   30   22   13   14   13   12   12   12
C50(dB)  6.5 10.2 14.5 16.9 15.6 16.2 15.9 19.0 15.7
C80(dB) 15.2 17.5 24.8 24.9 23.4 25.1 26.8 26.9 29.5
D50(dB)  108   91   96   98   97   98   98   99   99
G(dB) -35.7 -31.1 -33.9 -37.5 -41.5 -44.7 -46.2 -50.7 20.3
STI 0.89    Ratin

g:
Excellen
t

STIrMale 0.90    Ratin
g:

Excellen
t

STIrFem 0.90    Ratin
g:

Excellen
t

RASTI 0.91    Ratin
g:

Excellen
t

%ALcons  1.3
MTI 0.84 0.89 0.91 0.90 0.89 0.90 0.92
MTF
0.63 Hz 0.997 0.998 0.999 0.998 0.998 0.998 0.999
0.80 Hz 0.995 0.997 0.998 0.998 0.997 0.998 0.998
1.00 Hz 0.992 0.996 0.997 0.996 0.996 0.996 0.997
1.25 Hz 0.988 0.993 0.995 0.994 0.993 0.994 0.996
1.60 Hz 0.981 0.990 0.992 0.991 0.990 0.991 0.993
2.00 Hz 0.971 0.984 0.988 0.986 0.984 0.986 0.989
2.50 Hz 0.956 0.976 0.981 0.979 0.976 0.979 0.984
3.15 Hz 0.933 0.963 0.971 0.968 0.963 0.967 0.975
4.00 Hz 0.897 0.943 0.955 0.950 0.942 0.949 0.960
5.00 Hz 0.851 0.916 0.934 0.925 0.914 0.924 0.940
6.30 Hz 0.787 0.878 0.903 0.890 0.874 0.887 0.910
8.00 Hz 0.704 0.825 0.861 0.840 0.818 0.836 0.866
10.00 Hz 0.615 0.762 0.812 0.780 0.753 0.775 0.811
12.50 Hz 0.514 0.687 0.750 0.705 0.677 0.705 0.739
r(m)  0.0

6.13.1.4.1.1.1.2 Measurement 2
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F(Hz)   63  125  250  500 1000 2000 4000 8000 16000
snr(dB) 10.9 28.3 34.5 31.7 30.1 30.2 26.4 24.4 12.0
edr(dB) 26.2 53.4 48.4 45.2 45.0 45.5 44.4 41.4 28.7
EDT(s) 0.23 0.25 0.19 0.18 0.20 0.17 0.17 0.18 0.18
T30(s) 0.32 0.26 0.24 0.22 0.21 0.19 0.18 0.20 0.17
corr -0.992 -0.986 -0.989 -0.992 -0.997 -0.998 -0.999 -0.998 -0.998
T20(s) 0.33 0.27 0.20 0.21 0.21 0.20 0.18 0.19 0.17
corr -0.992 -0.993 -0.989 -0.988 -0.995 -0.997 -0.998 -0.997 -0.999
Tc(ms)   23   25   21   15   15   13   13   12   13
C50(dB)  4.7 11.1 17.1 14.1 15.2 16.8 15.9 17.0 17.2
C80(dB) 12.2 19.4 23.9 25.1 23.8 25.6 26.2 25.8 28.7
D50(dB)  124   92   97   97   97   98   98   98   98
G(dB) -35.9 -31.9 -33.7 -37.9 -41.6 -43.6 -45.7 -51.0 20.1
STI 0.89    Ratin

g:
Excellen
t

STIrMale 0.90    Ratin
g:

Excellen
t

STIrFem 0.90    Ratin
g:

Excellen
t

RASTI 0.90    Ratin
g:

Excellen
t

%ALcons  1.3
MTI 0.85 0.90 0.89 0.89 0.91 0.90 0.91
MTF
0.63 Hz 0.997 0.998 0.998 0.998 0.998 0.998 0.999
0.80 Hz 0.995 0.998 0.997 0.997 0.998 0.998 0.998
1.00 Hz 0.992 0.996 0.995 0.996 0.996 0.996 0.996
1.25 Hz 0.988 0.994 0.993 0.994 0.994 0.994 0.995
1.60 Hz 0.982 0.991 0.989 0.990 0.991 0.991 0.992
2.00 Hz 0.972 0.986 0.983 0.985 0.987 0.986 0.987
2.50 Hz 0.957 0.979 0.975 0.976 0.979 0.979 0.980
3.15 Hz 0.935 0.968 0.961 0.963 0.968 0.967 0.970
4.00 Hz 0.901 0.951 0.940 0.943 0.951 0.948 0.953
5.00 Hz 0.858 0.927 0.911 0.916 0.927 0.923 0.930
6.30 Hz 0.800 0.893 0.870 0.876 0.892 0.885 0.896
8.00 Hz 0.729 0.845 0.814 0.821 0.844 0.831 0.848
10.00 Hz 0.655 0.785 0.751 0.756 0.788 0.767 0.790
12.50 Hz 0.579 0.710 0.682 0.677 0.721 0.691 0.718
r(m)  0.0



6.13.1.4.1.2 Large room

6.13.1.4.1.2.1 Upper postion: 
Use the MLS measurement, the 63 Hz octave is not valid. (There was an error with sweep measurements so it could
not be used.)

F(Hz) 63 125 250 500 1000 2000 4000 8000 16000
SNR
(dB)

14.93 48.82 55.10 53.20 47.73 47.21 45.34 44.45 38.08

EDT(s) 2.23 0.80 0.67 0.74 1.06 1.04 0.89 0.71 0.56
T30(s) 2.88 0.95 0.82 0.89 0.98 0.98 0.92 0.76 0.66
T20(s) 2.88 0.82 0.80 0.90 1.07 0.99 0.90 0.74 0.64
Tc(ms) 171.71 63.35 66.92 68.65 74.39 72.13 62.27 50.50 41.49
C50(dB) -1.43 0.50 -2.08 -1.31 -0.17 0.48 1.06 2.43 4.07
D50(%) 43.23 51.93 38.59 42.08 49.09 52.78 56.04 63.68 72.12
G(dB) -20.54 -17.23 -14.89 -18.25 -23.30 -24.55 -28.22 -32.22 46.31
ST1(dB) 5.09 5.83 10.57 7.98 5.85 5.97 6.38 6.09 5.46
STI 0.62
RASTI 0.61
r(m) 13.82

6.13.1.4.1.2.2 LeftPosFirstRow
Use MLS also here from 125 Hz, below it is not valid.
C:\WinMLS2000\Measurements\Surrey\LargeRoom\MLSLeftPosFirstRow.wmb
F(Hz) 63 125 250 500 1000 2000 4000 8000 16000
SNR(dB) 22.63 48.79 52.42 53.40 49.11 47.70 44.21 44.15 38.92
EDT(s) 1.05 0.90 0.89 0.93 1.00 0.95 0.85 0.66 0.52
T30(s) 1.77 0.93 0.66 0.85 0.98 0.99 0.93 0.74 0.65
T20(s) 1.77 0.95 0.68 0.88 1.01 0.96 0.90 0.72 0.60
Tc(ms) 90.00 72.50 77.62 65.40 74.56 70.95 61.32 40.19 30.91
C50(dB) 2.16 0.93 -2.72 0.35 -0.56 -0.24 0.89 4.08 5.62
D50(%) 61.07 56.54 34.72 51.26 47.19 48.50 55.23 72.07 79.84
G(dB) -18.27 -17.57 -14.05 -18.24 -24.02 -24.62 -28.32 -30.45 48.58
ST1(dB) 5.85 5.23 12.24 4.18 5.46 4.94 5.32 2.08 0.49
STI 0.61
RASTI 0.59
r(m) 10.22

6.13.1.4.1.2.3 CentrePosThirdRow
Use MLS also here from 125 Hz, below it is not valid.

F(Hz) 63 125 250 500 1000 2000 4000 8000 16000
SNR
(dB)

32.36 47.75 51.20 52.32 47.00 46.05 44.36 44.48 38.50

EDT(s) 1.36 0.52 0.69 0.86 0.99 1.05 0.94 0.71 0.53
T30(s) 1.81 1.04 0.74 0.87 1.01 1.01 0.93 0.77 0.67
T20(s) 1.81 1.01 0.73 0.87 0.98 1.01 0.93 0.77 0.64
Tc(ms) 102.05 51.26 63.71 68.39 67.70 64.19 57.63 40.21 29.81
C50(dB) 0.63 5.26 1.49 -0.15 1.00 1.19 1.78 4.01 6.05
D50(%) 65.10 76.84 57.58 50.17 56.12 56.69 60.09 71.52 80.55
G(dB) -17.61 -15.60 -13.41 -18.15 -23.43 -24.87 -28.57 -31.61 47.51
ST1(dB) 3.06 9.22 14.29 4.44 5.57 3.47 2.84 1.25 -0.07
STI 0.65
RASTI 0.60
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r(m) 11.41

7 Program Setups

7.1 Setups

The current WinMLS settings can be saved for usage later from Setup->Store.... A setup can be loaded from Setup-
>Load....

7.1.1 Store a backup of your setup

After you have set up the sound card and optional calibration, it is recommended that you store a backup setup. This
setup will then be loaded if there should be an error reading the setup.

Go to Setup->Store... and open the dialog shown below.

You need to check two things before storing.
1. Change the setup name to Sound Cards_Load if error with setup as shown below.



2. Make sure the check box  is checked. This is important since if an error
with the setup occurs it is important that new sound card settings are loaded.

Now click  to save the setup.

Note: In the general case, the check box  is not checked.
Then WinMLS will use the existing sound card, level and calibration settings will not be loaded. This is because most
users don’t want these settings to be changed when a new setup is loaded. An exception is if you have two sound cards
and you want to use setups that switch between using the two sound cards.

7.1.2 Loading the original setup again

You can restore previously saved settings by loading a setup. Setup->Load... loads the settings needed for performing
the measurement. 

7.1.3 Set WinMLS to start with a specific setup

When you start WinMLS, the settings you had when you closed WinMLS will be loaded. This is default, but can be
changed. You can do this from Setup->Options.... 

In Settings to be loaded on startup, there are three alternatives. The setting  is
useful in many situations. (Limitaiton: This setting will not work if using a setup with multiple windows. The user will
be notified about this.)

You may also want to load the setup you used when you last used WinMLS, but not with the changes, if any, you
made. Then select the  setting.

In some cases it is desired to load the same setup each time WinMLS starts. Then you can be sure that the settings are
exactly the same each time WinMLS is opened, and you are not dependent on changes you did the last time you used
WinMLS.
Do this by making sure the radio button below is selected and select the setup you wish to load from the list shown
below.

In the example above we have set WinMLS to load the setup named Sound System_Surround (5.1). You should
select the setup you want to use for your application.
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Click  to exit the dialog box.

Now exit WinMLS and restart it again. When WinMLS is restarted, it should load the setup you selected above.

7.1.4 WinMLS Structure Diagram

Below is a diagram showing the various parts involved when using WinMLS to measure a parameter based on the
impulse response.
 

 

 

Sound Card 

Microphone 

WinMLS Measurement Settings  
(signal generation) 

Phantom Power/Optional Pre-Amp 

Loudspeaker 

Sound Card Driver 

Windows Multimedia Settings 

Measurement parameters set by user  
(max. reverb time, total duration) 

WinMLS Measurement Settings 
(Obtains the Impulse Response) 

WinMLS Post Processing Settings 
(Post-process Impulse Response)  

Plotting using Charting Library Windows Display Driver 



7.1.5 WinMLS File Structure Diagram

WinMLS stores its settings in several files found under different sub-directories of the WinMLS folder as shown
below.

The two diagrams below is using these WinMLS sub-directories.

The diagram below shows he files used by WinMLS for obtaining the settings for performing a measurement and the
Measurement Panel toolbar that can be used for quickly saving a measurement.
 

Measurement Set-up 
.wms(SetupsMeasure-
ment dir.) 

Measurement System Correction Files 
_ch_sampfreq.wmb  
(Measurement System Correction dir.) 

Emphasis Files 
.emp (Filters dir.) 

WinMLS Windows Mixer 
Calibration Files 
.mxi & .mxo (Mixer dir.) 

WinMLS Measurement 
settings made in the menus 
and dialog boxes 

Signal Proc. ⇒   
Measurement 

Data 

Measurement Panel 
.wmb 
(MeasurementPanel dir.) 

Amplifier Gain Steps 
.txt (AmpGainSteps dir.) 

Pictures used in Wizard 
Picture file formats  
(Pictures dir) 

Figure 7 Software file structure for obtaining a measurement.

The diagram below shows the files used by the software for post-processing and plotting measurement data.
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Post Processing Set-up 
.wmp  
(SetupsPostProcessing dir)  

Limit Curves 
.txt and .ref 
(Limitcurves dir) 

Plot Layout 
.tee  
(Chart dir) 

Microphone Compensation File 
.txt 
(Microphone Compensation dir) 

WinMLS Post Processing 
settings made in the program 

Data Processing 
and Plotting 

Figure 8 Software file structure for post-processing and plotting a measurement.

8 Troubleshooting and Known Issues

8.1 Troubleshooting

8.1.1 My sound card does not seem to work correctly?

If you have problems stopping the measurement, if you have “gaps” during the measurement or simply do not get good
results this may be because your PC is not optimalized. On how to optimalize your PC for sound card applications see:
http://www.musicxp.net/tuning_tips.php
It is really worthwile having a look at this website.

8.1.2 WinMLS mixer and Windows XP

There is a bug in Windows XP that makes WinMLS select the wrong input line for the mixer. We have compensated
for this, so it should work. This is a problem only for the sound cards that can select between line input and mic input
in the WinMLS mixer (not e.g. the Digigram VXpocket). Note that the Windows XP bug may be fixed in future
versions of the operative system. If so, see the Specific sound card settings section in the Measurement->Sound
Card… referenced section for more information.

8.1.3 Why is it impossible to control the input level with the WinMLS mixer?

This has been reported for some sound cards, e.g. Soundblaster cards (Live, 128). This seems to be because there
seems to be a bug in the sound card driver. On how to fix this, see the Specific sound card settings section in the
Measurement->Sound Card… referenced section.



8.1.4 My frequency response measurements look too flat, why?

This may be because somehow the output signal may be directly connected to the input (this is probably because the
WinMLS mixer is used as discussed below, try to turn it off). This has been reported for an early version of
SoundBlaster 128, SB128PCT (CT4700). However, the SB128 PCI (CT4810) has been reported not to have this
problem.

8.1.5 Problem after changing preferred sound devices

If changing the preferred sound device in Windows multimedia properties while WinMLS is running, WinMLS may
not work properly, how to fix this? 
The easiest way of avoiding this problem is to  close WinMLS before changing this setting. WinMLS uses a device
number for identifying the sound devices. When changing the preferred device in multimedia settings this number will
change, this will affect the WinMLS device settings. Therefore, after setting the preferred device in multimedia
settings reload the setup that contains your sound card settings. If you do not have such a setup, go to  Measurement-
>Sound Card... and make sure the correct input device and output device is chosen.

8.1.6 I can hear feedback, how can it be turned off?

You may experience feedback when connecting speakers and microphones to your sound card. This is because the
sound card may patch the signal present on the input to the output. If the WinMLS mixer is used (set in
Measurement-> Sound Card…), this should be avoided by making sure  is checked

in Measurement->Sound Card … (you may have to click the  button). 
If the WinMLS mixer is not used, the feedback is not just annoying but can affect the measurements as well. Feedback
is detected as false echoes in the impulse response and as comb filtering in the frequency response. The unwanted
feedback can be turned off using the sound card mixer application (if any) or the Windows sound card mixer. The
setting in the Windows sound card mixer that gives the feedback has different names depending on the sound card. If
you mute all inputs and outputs that you are not using for the measurement signal, the feedback should be avoided.

8.1.7 Why does a small change the in volume settings in WinMLS give no effect?

If the WinMLS mixer is calibrated (see Measurement->Calibration...), a change in the volume setting will always
have an effect since the calibration procedure has determined the level steps that actually changes the level. However,
if the mixer is not calibrated, the sound card level steps have not been determined, and slight changes in volume may
not be supported. There should be at least 16 different levels and maximally 65535 levels of volume to choose from. 

8.1.8 Trouble with WinMLS evaluation period

In very few cases there seems to be a problem with the protection software that causes the evaluation period to end
before it is supposed to. If this happens, please contact us.

8.1.9 Problems with IBM TP 600X laptop running Windows 2000

This laptop had software that overrides the windows mixer. Therefore there were problems automatically adjusting the
input level. Please contact us if you have similar problems.

8.1.10 The plot background colors look strange, why?

The gradient colors used as background in WinMLS may look strange if your PC is set to display 16 colors. It can
easily be fixed by selecting more than 16 colors. From the Start button select Settings, then Control Panel. Select
Display, in the Display dialog box select the Settings tab. Select at least 256 colors.
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8.2 Issues

8.2.1 Double-clicking in the plot will not open the plot type settings dialog

This feature had to be disabled because it has been reported to be unstable in some cases. This is to be fixed in a future
version. The plot type settings can still easily be accessed typing F5, or from the rightmost button on the Plot Toolbar.

8.2.2 Room Acoustics

When a room acoustics parameter is plotted with bandwidth Broadband, the style should be set to Value. If not, the
x-axis labeling will not be correct. On how to do this, see the FAQ section “How to change the x-axis of the Room
Ac. Parameters plot type when plotting octave band parameters”.

8.2.3 Abnormal termination on shutdown

It has been reported that WinMLS causes an abnormal termination when shutting down the PC if the operative system
Windows Millennium (WinME) is used.

8.2.4 Setups toolbar

The post-processing save icon turns red  if the post-processing setup is changed. It also turns red if settings in the
chart files (all the settings in Plot->Layout->Edit...) are changed, but there are cases when changes in the chart files
will not be reckognized, e.g. on File->New and when loading WinMLS. When moving toolbars around or turning

them on/off, the setup toolbar does not give an indication that the setup  is changed (red icon).

8.2.5 Plot settings toolbar supports maximum 4 decimals.

If you are plotting signals with very small levels (~0.0001), the plot settings toolbar will not work very well.

8.2.6 Auto-scaling of y-axis maximum value

Auto-scaling y-axis maximum value is set to zero if the value is less than zero.
If you are plotting more than one curve and the plot type is Time Data, and the time-data window is displayed, then
auto-zooming will not work when removing a curve that has larger y-values than the other curves. To activate the auto-

zooming, click twice on the  button on the Plot Settings Toolbar.

8.2.7 A tip that will avoid WinMLS to crash

If you get an error message with the title Matrix<LIB> as shown below, do not click the OK button. Just
continue using the software and ignore this message. If you click the OK button, this will cause WinMLS to
crash. 



8.2.8 Special case: If two plots are displayed showing the same plot type.

If two plots are displayed showing the same plot type (e.g. frequency response in both upper and lower plot), only one
of these plot settings will be rembered the next time WinMLS is started or the setup is loaded. This is because a single
file is used for saving the plot-type settings.

8.2.9 Opening or saving as 24 or 32 bits .wav-files is not possible in this version

It is recommended to use the .wmb-format.

8.2.10 Refresh All

If you are refreshing curves and have selected All Curves as shown below, this may not update the colors correctly if
there exists several curves of the same measurement.
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9 FAQ: General

9.1 How to get started analyzing measurements files (e.g. wav files)?

Go to Setup->Load…. In this dialog select a setup as shown in the figure below. In this example a setup for
calculating reverberation time is to be loaded.

After the setup is loaded, follow the wizard explanation that comes with the setup. But you may skip the part related to
performing the measurement since you already have the measurement on file.

Use File->Open… to open the file you wish to analyze.

9.2 How to solve a problem with WinMLS?

Step 1. Search the help file: Open the help file (select Help Topics... on the Help menu or push F1). Then click
the Search tab. Type a search word that is related to your question and click the List Topics button.

Step 2. Troubleshooting: The help file has a section you should check out named Troubleshooting and Known
Issues. 
Step 3. Recently discovered issues: Check out the latest discovered issues section on www.winmls.com (you
may also search here).
Step 4. User forum: Post a question explaining your problem on our user forum at www.winmls.com.
Step 5a. Professional version support: If you have purchased the Professional version, please e-mail us for
support. You may also call us if you have urgent needs, you find the telephone number at www.winmls.com.
Step 5b. Support on the personal version: If you have purchased one of the lower cost personal versions,
support is given only at our user forum. 
Note: If your license is lost, you need to purchase a new license.



9.3 How to transfer the license from one computer to another computer

This is described in the help file. To find the section, first open the help file (select Help Topics... on the Help menu).
Then click the Search tab. Type License Transfer as search word and click the List Topics button. Then you will
find the section License Transfer that explains the procedure. 

9.4 What if a setting is changed, how to make sure it is set the same way the next time
WinMLS is started?

All WinMLS settings are saved to a temporary setup file that can be loaded when WinMLS is started (set this from
Setup->Options…). Then your settings will remain the same as when you closed WinMLS. But if a new setup is
loaded (using Setup->Load...), these settings are lost. Therefore we recommend that you save the settings using
Setup->Store...).

9.5 I don’t like the way the toolbars are positioned, can I do something about it?

Yes, like most professional Windows software, you can select what toolbars you want displayed and move them to
where you want them positioned. 
Turn on/off a toolbar from the Toolbars menu.
Position a toolbar by clicking and dragging in the toolbar area where there are no buttons.

10FAQ: Measurements

10.1 How to measure with WinMLS?

Go to Setup->Load… and find the setup that is closest to the measurement you wish to perform in the list box. This
will load the WinMLS settings needed for this type of measurement. Most setups also contain a wizard that will guide
you through the measurement.

Start the measurement by clicking the  button (or from Measurement->Start). If you want to cancel the

measurement before it is finished, click the  button (alternatively the Esc key or Measurement->Cancel).

10.2 How to test the input levels?

You can test the input levels from Measurement->Test Levels. The levels are displayed in the After testing the
levels, the level indicator

10.3 How to calibrate the input of the measurement system?

The purpose of calibrating the input is to be able to measure absolute level, e.g. SPL or voltage. The calibration can be
done in different ways dependent on the features of the sound card (e.g if the WinMLS mixer can control the sound
card mixer or not) and the type of measurement you intend to perform. Note that for some sound cards, e.g. VXPocket,
a measurement setup is available with nominal calibration settings that can be loaded. To do this, go to Setup-

>Load... and go to the sound cards section as shown below. Click the  button to load the setup as shown
in the figure below.
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If the sound card input and output is calibrated, an impulse/frequency response measurement should give an
amplification of 0 dB for a loop-back measurement (input directly connected to output). If WinMLS controls the
Windows mixer and it is calibrated, the gain should be independent of mixer settings (changes in mixer settings will
not change the gain of a loop-back measurement).

10.4 How to calibrate the output of the measurement system?

10.4.1 How to perform calibrate the of mixer output levels?

The purpose of calibrating the output is to be able to obtain the true transfer function gain independent on the volume
setting of the Windows mixer controlled by WinMLS. For some sound cards, e.g. VXPocket, a measurement setup file
is available with nominal calibration settings.

The procedure for calibrating the output mixer is found from Measurement->Calibration…. Click the 
button to open the dialog shown below.

10.4.2 How to perform calibration of output level?

The purpose of the output level calibration is to be able to measure the gain of the impulse response/transfer function
with the correct units. To calibrate the output of the measurement system is only needed if you are using the output
(not if you are measuring input signals only). 
To method for calibrating the output is very similar to the method for calibrating the input. If you choose to use the
sound card input to measure the levels during the output calibration, it is required that the input is calibrated first.
Therefore we strongly recommend that you perform the input calibration before doing the output calibration. 

First determine if you are going to do a combined (EASY) calibration or an individual (ADVANCED) calibration.
This will be explained in the next section.

10.4.2.1 How to perform “Combined Calibration”?

The purpose of this type of calibration is to calibrate the whole output chain in one operation. We recommend that you
consider using the Individual Calibration (see below) if you are using WinMLS both for electrical and measurements
where you are using a transducer (e.g. a loudspeaker), or if you are using an amplifier with changeable gain. 



If you are not already in the Output Level Calibration dialog box, go to Measurement->Calibration…, click the

 button to the right of the Use output calibration check box as shown below. 

In the dialog, follow each step to complete the calibration. E.g. in step 2, you must select Combined as shown below.

If  is checked, it is assumed that you are using a transducer when doing the calibration. 
Note: If this check box is later turned off, no warning will be given that you must redo the calibration. If you are going
to perform a measurement later without using the transducer, a new calibration must be performed. This is not
required if you follow the procedure in the following section.

10.4.2.2 How to perform “Individual Calibration”?

The advantage of doing the individual calibration is that you can, without doing a new calibration, switch between
doing an electrical measurement, measure with amplifier and measure with transducer.

If you are not already in the Output level calibration dialog box, go to Measurement->Calibration…, click the

 button to the right of the Use output calibration check box is shown below

In the dialog, follow each step to complete the calibration. E.g. in step 2, you must select Individual as shown below.

10.5 How to measure using an external source?
In some cases it is more convenient to use an external source than to use the sound card output for playing the
measurement signal. For example if the source is placed very far away from the microphone (a wireless transmission is
also an alternative in this case). Another example is a sound system that does not have any direct input except a CD-
player.

10.5.1 Measure with signal from a CD-player

Here we will discuss how to use a CD-player to playback the measurement signal and the problems related with this
when measuring impulse/frequency response. To minimize the problems, we will use a single sweep as measurement
signal.
A better and more flexible method is to use a DAT/MD/CDR-player. This will be explained in the section below.

Go to Setup->Load... and load the setup named General_External Source (DAT, CD, MD).

10.5.1.1 Make a .wav-file and write it to the CD

If you are able to record the signal with your playback device, we recommend that you follow the procedure in the
next section instead of the procedure that follows below.
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The sampling frequency has been set to 44100 Hz. In the figure below, we see that the length of the sweep is 20
seconds and there is 3.8 seconds of silence after each sweep. 

The number of measurement cycles is 16, which means that there will be 16 sweeps in the wav-file. The total file
length will be 380 seconds. Use only one sweep for a single measurement, but we use the number 16 if you need to do
several measurements (e.g. measure in several positions). To increase the number of sweeps that are played you can
either increase this number, or set the CD-player in repeat modus.

Export the measurement signal to a .wav-file using Measurement->Export Stimulus....
This file will be given a name that contains the measurement parameters as shown below.

Now use your CD-recording software to write this file to a CD.

The result of the measurement may not be quite as good as when using the sound card to playback the measurement
signal since the CD-player and the sound card may have slightly different sampling frequencies. But if you use a
single sweep as the measurement signal, this should not be a problem.

10.5.1.2 Alternative: Record the signal to your playback device

If you have a DAT/MD or CD-recorder that can record music, you should not use the write-to-wav-file method
explained above. Instead use this method:

1. Connect the output from you sound card to the input of your DAT/MD/CD-player. 
2. Start recording on your DAT/MD/CD-player and go to Measurement->Start in WinMLS to playback the

sweep signal. (Make sure that the levels are not too low or distorting).

Use this recorded sweep signal for your measurements, and make sure you play it back using the same device as you
recorded it with. This will overcome the problems that may occur because of the small sampling frequency differences
between the DAT/MD/CD and the sound card. 

If you use this method you are not restricted to using a single sweep. You may use multiple sweeps or if you prefer a
noise signal you can use this MLS.

For a detailed description, see the Measure with DAT/MD/CDR as external source section below.



10.5.1.3 Before measuring

When you are measuring using external signal you must use exactly the same measurement settings as when the signal
was generated. Therefore it is strongly recommended that you use the same setup for your measurements. If you need
a special post-processing, you can load post-processing settings from Window->Load Post-processing....

At the bottom of the Measurement->Settings... dialog, you can limit the length of the impulse response to be
measured to reduce the file size, below it is limited to 2 seconds.

Now click the Imp/Freq Res tag shown below

The calculation part should be set as shown in the figure below

Now click the  button. If you are using an external source and have no connection, it is impossible to measure
the delay (time of flight) between the loudspeaker and microphone. Therefore it is very important that you select No,
remove system delay as shown below.

If you have not selected this setting, the impulse response may not be positioned at the beginning as shown in the
figure below where the impulse response starts at 9000 milliseconds. This is wrong and may cause problems for the
calculation.

When using an external source the impulse response should always start at the beginning as shown in the figure below.
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10.5.1.4 Start the measurement

Before starting the measurement, you also need to change the no. of meas. cycles from 16 to 1 as shown in the figure
below, the other measurement settings must remain the same. 

After doing this you should save the setup from Setup->Store....

Play the signal from the external source. You should now hear a sweep signal.

If the measurement is of single sweeps it is important that you start the measurement (Measurement->Start) just
before the sweep reaches the microphone. Start the measurement when there is silence (do not start a measurement in
the middle of the sweep). If this is not done correctly, you may miss a part of the upper or lower frequency range.

10.5.2 Measure with DAT/MD/CDR as external source

This section applies if you can record the measurement signal from WinMLS to an external source and play it back
using the same source. This can be done with a DAT, MD (mini-disc) or CDR (CD-player that can also record). Even
though the MD compresses the signal somewhat, our users have reported good results.

10.5.2.1 Why use an external source?

• if you do not wish to have a cable from the source to the PC (e.g. if measuring a car stereo, it might be
difficult to connect the sound card output)

• if you don’t have a PC at the measurement location, but have access to two DAT/MD/CDR-players



10.5.2.2 How?

You can either use WinMLS to playback the output signal and record using a DAT/MD/CDR player, or you can do it
opposite.

You can also use two DAT/MD/CDR players to do the recordings. Then you can analyze the recorded signals in
WinMLS later. To do this, just playback the recorded signal from the DAT/MD/CDR while you perform a
measurement in WinMLS. The WinMLS measurement-parameters have to be exactly the same, please see the section
about performing the measurement below.

We recommend that you playback the signal from the DAT/MD/CDR and use WinMLS to record the signal. This is
because then you will get the result (the impulse response) immediately and you can therefore more easily detect
possible errors. A guide on how to do this using sweep as stimulus follows below.

10.5.2.3 Before measuring

Go to Measurement->Settings...and click the Imp/Freq Res tag shown below

The calculation part should look like below

Now click the  button shown in the figure. If you are using an external source and have no connection, it is
impossible to measure the delay (time of flight) between the loudspeaker and microphone. Therefore select No,
remove system delay as shown below

10.5.2.4 Record stimulus on DAT

If you want to use a CD-player or a device that plays a .wav-file and can use a single sweep as stimulus, it is
recommended that you use the procedure given in the Measure with signal from a CD-player section.
Otherwise, you can follow this section where you can use use your own measurement parameters, but it is
recommended that you record a signal with long duration to your DAT/MD/CDR player.

Go to Measurement->Settings... and type in a duration of e.g. 400 seconds as shown in step 2 below
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Now connect the DAT player input to the left sound card output and start the measurement (Measurement->Start).
Then start recording on your DAT/MD/CDR player.

After finishing the recording, you should decrease the total duration of the measurement. In the example below, it is
set to 20 seconds.

Note that the other parameters must not be changed. Therefore we recommend that you save the setup (Setups-
>Store... ). 

10.5.2.5 Start the measurement

Play the DAT/MD/CDR recording you made. You should hear the measurement signal.

Go to Measurement->Start to start a the measurement.

The result of the measurement should look like a measurement performed using WinMLS only, except that it is
impossible to measure the time delay using this method.

When you perform measurements later, remember to load the same setup or make sure you use the same settings:
The same sampling frequency
The same type of excitation (all settings must be the same, except the number of averages)

10.5.3 Detection of arrival time does not seem to be right, why?

On of our customers reported:
“Here you have two measured impulse responses measured using the MD player. The arrival times are not corrected as
you can see. Around the impulse you see some artefacts, probably due to the MD player. When I play the original
wave file over another sound card the impulse response is cleaner, but this is good enough for acoustic
measurements.”



In the lower of the two figures above, we see the impulse response plotted on a dB vertical axis. When doing this we
see that the impulse response has a very long pre-ringing. This is typical and is probably due to the artifacts of the MD
player

In the frequency response plot, we also see that there is a dip at 7 kHz in the red curve. Such a dip should be avoided if
using the method of a single sweep and starting the measurement just before the sweep starts.

10.6 How to make a new wizard or edit an existing wizard?
Before writing your own wizard in WinMLS, there are things you should be aware of that will be explained in this
section.
 
A wizard can be used for most applications. It can be useful for yourself, since you can use it to write a step-by-step
list of what to do. It may even be more convenient to use the wizard if you need to explain a specific task to someone
new to WinMLS. Integrating such instructions as a part of the software has its advantages. The wizard can be made as
simple as shown in the figure below.

10.6.1 Guidelines for the WinMLS wizards
When writing the wizards that come with WinMLS, we try to follow the following guidelines

• The text in the default wizards is written in English (US).
• Use lots of spaces so the text is easy to read. There should not be more than 2-3 lines of text before a space as

shown in the figure above.
• Use capital letters in the first letters in the title words, e.g. a title may be:

Welcome to the Impedance Wizard
• When possible, use the Help-button feature in to open web-links, documents and chapters in the help file from

the wizard (more about this below). Hypertext or html code is not supported.

10.6.1.1 Distributing wizards
If you have written a wizard that you would like to share with other WinMLS users, we are interested in seeing it. We
may be interested in distributing or including or include it as one of the a wizards in software updates. For this we will
give you credit. It should follow the guidelines above. We are also interested in translations of the existing wizards to
other languages.
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10.6.2 Step-by-step guide to create a wizard

10.6.2.1 Prepare a wizard document
First you have to organize the task you are going to “wizardize” into steps. If you plan for more than one wizard step,
we recommend that you first write a document including what the pictures look like.
Each chapter should be a wizard step and must contain 
title
text 
picture
Important! The picture must be small to fit in the wizard window, the maximum is 220 pixels wide and 230 pixels high.
The picture must be in one of the supported picture formats, that is jpg, gif, emf, wmf, bmp, pcx or tee. The png format
is currently not supported.

We recommend that your picture file name start with the name of the wizard and then the name of the wizard step, for
example Loudspeaker_Impedance_Theory.gif. where Loudspeker_Impedance is the name of the wizard and
Theory is the name of the wizard step.

Each wizard step may contain further documentation that can be opened if the  button is clicked as shown
below. 

You may assign a section in the help file to this button or alternatively a document either locally on the hard disk or
from the web. This allows you to integrate documentation that is too complex to be displayed in the wizard.

10.6.2.2 Move the figures to the <Pictures> folder
When the document explained above is made and you have made your picture files, move the picture files to the
subfolder named Pictures in the folder where WinMLS is installed.

10.6.2.3 Move the documentation to the <Docs> folder

If you have documents that you want to link to the  button that are not web-pages it is recommended to
move these files to the subfolder named Docs in the folder where WinMLS is installed. If you do this, you do not need
to specify any path and the files will be included if you export the setup using File->Export….

10.6.2.4 Create the wizard
In WinMLS go to Measurement->Wizard->Editor... to display the dialog shown below



In this dialog, make sure  is checked.

10.6.2.4.1 Add a new wizard step

click the  button to add a new wizard step as shown below.

As seen above, the text Untitled appears in the Wizard steps field. Double-click on Untitled to modify the wizard
step you added. How to do this is shown in the section below.

10.6.2.4.2 Insert title and text
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Write the title and text as indicated in the upper part of the figure above.
If you want to write numbered list like shown below you need to end the line with <Enter> and start with adding
spaces to get the alignment correct

1. This is the first line of text
    This is the second line of text
2. This is the third line of text
    This is the forth line of text
3. This is the fifth line of text
    This is the sixth line of text

The extra Enter and spaces needed are shown below:
1. This is the first line of text <Enter>
<add spaces> This is the second line of text

As we can see, the wizard step settings at the bottom is included as well as shown in the figure above. This will be
explained in the next sections.

10.6.2.4.3 Select image
Select the image you want the wizard step to contain from the list shown below

10.6.2.4.4 Lock program while the wizard is shown

Picture is
displayed here



If  is checked, it is impossible for the user to access any settings in WinMLS, except
the wizard dialog itself. If it is unchecked, the user can use WinMLS while the wizard dialog is displayed. This is
useful if you want the user to change one or more setting in WinMLS before continuing to the next wizard step.

10.6.2.4.5 Show this wizard step
If the check box  is checked, the wizard step will be displayed. If it is not checked, the
wizard step will not be displayed when the wizard starts.

10.6.2.4.6 Select what to be done when the ‘Next >’ button is clicked
Decide what operation you want to do when the ‘Next >’ button is clicked as shown below

10.6.2.4.7 Decide how many measurements to perform before displaying a new wizard step
If you have selected Display next wizard step this setting does not have any effect.
Otherwise, WinMLS will show the next wizard step after a number of measurements is performed as shown below.

10.6.2.4.8 Select what to be done when the ‘Help’ button is clicked
Decide what operation you want to perform when the ‘Help’ button is clicked as shown below

The  button will not be displayed in the wizard so the user can see it if the text field in the figure above is
not empty. In this field, you may specify one of the following:

• A link to a web page, example: www.winmls.com
• An identifier that opens a page in the WinMLS help file. The identifier is composed by ‘IDH_’ plus the

heading name. If there are spaces or punctuations in the heading name, use ‘_’.
Example: If the heading is “Calculate Menu” you must write “IDH_Calculate_Menu”.
Example: If the heading is “Load...”, you must write “IDH_Load___”.

• A file that exists on your hard disk, example: test.txt. Any file format is supported if you PC has the software
for opening the document. It is recommended to move these files to the subfolder named Docs in the folder
where WinMLS is installed. If you do this, you do not need to specify any path for the files and these

documentation files will be included if you export the setup. Click the  button to open a file from your
hard disk.

Click the  button to check if what you have specified is correct.

10.6.2.5 Store the setup
When you exit the wizard editor you are asked if you want to store the setup as shown below. 
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It is recommended that you answer “Yes”. Note: If you are writing a new wizard, remember to save the setup under a
new name so the previous setup is not overwritten.

10.7 How to auto-name when saving measurements?

Before starting to measure, go to Measurement-> Saving Defaults... In this dialog select the folder you want the
measurement to be saved under, and the default name as shown in the figure below. 

You may also write a comment and a title. Type the number of measurements you are to perform in the auto-name
generator range as shown below.

For example, if the range is 1-3 and the default filename is “Meas”. The suggested name for saving the first three
measurements will be 
Meas_1.wmb, Meas_2.wmb, Meas_3.wmb
Then when saving the forth measurement, the Defaults for Saving dialog box will automatically appear, and you may
write a new default filename.

10.8 What does the Windows sound card mixer do when WinMLS is set to control it?

The WinMLS mixer fully controls and overrides the Windows sound card mixer during the measurement. This means
that when WinMLS is set to control the Windows mixer, there is no point in adjusting levels in the Windows sound
card mixer.

10.9 How to get fine resolution on the WinMLS mixer and signal generator slider?

The signal generator slider (shown at the bottom of the figure below) and WinMLS mixer input and
output level sliders can be set using the mouse, but moving only one step may be difficult with the
mouse. To move in single steps, do the following:
First click on the slider to set it active (a dotted border around the slider tells that it is active, see the
figure to the right).  Then use the arrow keys on the keyboard to move in single steps. 



10.10What format is recommended for saving measurement data?

In most of the default setups, the .wmb (WinMLS binary files) is the default file format and is recommended since it
contains extra information about the measurement. This information can be displayed from Measurement-
>Information….

The .wav-format will also store this this information, but normalization must be done since the .wav format currently
supports only 16-bits. If normalization is not used when saving as a .wav file, the quantization noise is usually large.
The .wav-normalization should not change the scaling of the results since the normalization factor is stored and used
when opening the file in WinMLS.

10.11How to convert a measurement file, e.g. of extension .wmb to .wav?

This is done from File->Convert Measurement(s). Select the measurements to be converted as shown in in the dialog
below.

10.12How to improve signal-to-noise ratio for low frequencies?

It is possible to pre-filter the MLS sequence before it is played and then post-filter the recorded signal to compensate
for the pre-filtering to obtain the correct impulse response. This method can be used to boost frequencies that has poor
signal-to-noise ratio. See below how this can be done

10.13How to add pre-filtering (emphasis) to the excitation signal?

Both pre- and de-emphasis (Pre/Post-filtering) is available from Measurement->Settings… when measuring impulse
responses. 
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It is not recommended to use this emphasis for sine sweep excitation signal.

10.13.1How to band limit the excitation signal?

If you are using a sine sweep for your measurements, the signal is band limited by setting the sweep range. If you have
selected a noise signal (such as MLS), the emphasis setting can be used to do the band limiting.
The reasons for band limiting the output signal are twofold:

• You can get greater signal level out from the loudspeaker. 
• The bandwidth limited signal would eliminate very low and very high frequencies which could overload the

loudspeaker or amplifier. E.g., Norsonic has this as a feature on one of their pink noise generators. The signal
selection can be (1) bandwidth limited 89 to 5623 Hz (suitable for 125 to 4000 Hz octave frequency bands)
and (2) full bandwidth (no bandwidth limiting). We have not investigated how much an improvement this will
give in signal-to-noise ratio.

How? The band-limiting can be done by using the pre-filtering option and by using a proper filter. An example of
generating a filter that bandlimits low frequencies to 80 Hz is given in the next section.

Emphasis is set in Measurement->Settings... as shown in the bottom of the figure below.

10.13.2How to generate your own emphasis filter?

A custom filter can be made using Matlab or by contacting us. The filter coefficient file format is the same as the
Matlab mat-format, but change the extension name from .mat to .emp. An example on generating and saving filter
coefficients in Matlab is given below. Note that this generates a filter that is unstable if it is inverted so it can only be
used for pre-filtering, not for post-filtering (since the post-filtering uses the inverted filter). Since the purpose of this
filter is to band-limit the output below 80 Hz for the sampling frequency 48000 Hz, this is no problem for this
application.

Fs=48000; % Sampling frequency in Hz
FcutOff = 80; % Cutoff frequency in Hz
Wn= FcutOff/(Fs/2); % Normalized cutoff frequency
FilterOrder = 6; % Filter order
FilterType = 'high'; % Filter Type
[b,a] = BUTTER(FilterOrder,Wn, FilterType); % Generate filter
save HighPassFc80Hz_Fs48000Hz.emp a b -mat

To use this filter, run the code and copy the generated file ‘HighPassFc80Hz_Fs48000Hz.emp’ to the
‘Filters’-folder under the WinMLS-folder.

The example below generates a bandpass filter for the frequency 250 Hz and sampling frequency 22050 Hz.

Fs=22050; % Sampling frequency in Hz
FcutOff = [125 500]; % 250 Cutoff frequency in Hz
Wn= FcutOff/(Fs/2); % Normalized cutoff frequency
FilterOrder = 6; % Filter order
FilterType = 'bandpass'; % Filter Type
[b,a] = BUTTER(FilterOrder,Wn, FilterType); % Generate filter
save BandPassFc1500Hz_Fs22050Hz.emp a b -mat



10.14How to check the background noise spectrum of an impulse response measurement?

If you have measured an impulse response, the noise spectrum can be found by time-windowing the last part of the
impulse response.

Go to Setup->Load... and load the setup named General_Freq. and Time Response. Open the measurement using
File->Open... or perform a measurement. The result is typically as shown below. In the upper plot we see a flat
frequency response. This is a measurement of a sound card.

Now in the lower plot, click on the vertical yellow line to the very left in the plot. Drag this line with the mouse to the
right. When releasing the line, the result is shown below.
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From the upper plot (frequency response) we see that there is a noise floor with clear components at 1 kHz, 2 kHz, 3
kHz, 4 kHz and 5 kHz.

10.15What is causing sine sweep artifacts such as pre-ringing?

When using the sine sweep as excitation signal, artifacts may occur. 
These artifacts are pre-ringing (signal before the impulse response starts) and low frequency noise in the middle of the
impulse response.

It has been reported that these artifacts occur when

• Measuring while the microphone holder is not stable (is moving). This may happen if you are measuring in an
anechoic chamber. If the floor is not fixed, it   may be vibrating if you don’t wait untill the vibration ends (e.g.
after closing a door or changing microphone position).

• If the input signal is very high so the sound card is used near maximum sensitivity. This has been seen on the
Digigram VXpocket v2 card.

10.16How to access a measurement from memory?

The measurements that are present in memory are found in a list box from Measurement->Information… or on the
Measurement Selection Toolbar. 



10.17How to delete a measurement?

If you have performed a measurement and want to delete it, go to Measurement->Clear Memory->Active
Measurement…. 

You may also use the  button in the Measurement Selection toolbar.
If you want to clear all measurements, the easiest method is Plot->Erase Curve(s)…. Make sure the Clear memory
check box shown below is checked.

 
Go to Measurement->Tasks… if you want to select if a measurement is to be automatically deleted if it is erased
from the plot as shown below.

10.18How to run WinMLS as batch file?

If you have a registered version of WinMLS you can see how to run WinMLS form batch by opening MS-DOS and go
to the WinMLS folder. To display the help text type:
winmls /h

WinMLS [/M MeasSetupfile] [/R] [/F FileName]
/M: MeasSetupfile is the short name of a measurement setup to load.\n"
/R: If RunAndExitAfterMeas is set then the measurement start immediately and exits afterwards
/F: Filename is the name of a file to save
/H: Show this help

Example: WinMLS /M “Room Acoustics_Reverberation Time” /F RAC_Filename /R\n
This example will load the settings in the measurement setup file Room Acoustics_Reverberation Time, perform a
measurement and save the result as RAC_Filename before it exits. 
Note that in order to automatically save the measurement, Automatic saving has to be selected in Measurement-
>Measurement Settings... as shown below.

10.19Can a given setup be automatically called using DOS switches?

Yes, this is possible, as shown in the batch file section above. This feature can be used if you want multiple shortcuts
that open different setups when WinMLS is started as explained in the next section. If no measurement setup is
specified, WinMLS will open with the settings as specified in Setup->Options.... 

10.20How to open WinMLS with different setups?

The setup that is opened when WinMLS is started is specified in Setup->Options….
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Alternatively, you can generate multiple shortcuts where each shortcut specifies the setup that WinMLS will load on
startup (see below).

  Renamed shortcuts for three tasks: 

To configure a shortcut as shown in the figure above, first left click on it to mark it and click the right mouse button.
Then select Properties from the popup menu. This will display the dialog box shown below.

In the dialog box we have added the text:
/M “Room Acoustics_Reverberation Time”
after the WinMLS path. This will make sure that WinMLS is opened with the setup named Room
Acoustics_Reverberation Time. 

To change the shortcut name, click the General tab shown in the figure above.

10.21How to read WinMLS files in Matlab?

The function loadimp.m found in the WinMLS folder can read the WinMLS measurement files .wmb or .wmt into
Matlab. To get an explanation on how it is used, open Matlab and change directory to the directory where WinMLS is
installed, then type:
help loadimp
in the Matlab workspace and push Enter. 

10.22How to run WinMLS as a function from Matlab?

The function runwinmls.m found in the WinMLS folder can run WinMLS from Matlab. It can be controlled so
WinMLS performs a measurement and exits immediately afterwards. To get an explanation on how it is used, open
Matlab and change directory to the directory where WinMLS is installed, then write help runwinmls. 

10.23What is the highest sampling rate available (important for e.g. scale modeling in room
acoustics)?

At the moment the highest sound card sampling rate is 200 kHz, which means that you may to get results up to 96 kHz.
Note that this high sampling rate is only supported in the higher level license versions.



10.24Can multi-channel measurements (>2 input channels) be performed using WinMLS?

WinMLS is capable of measuring up to 24 channels simultaneously, but the low priced versions measures maximum
one or two channels simultaneously. The number of channels is also limited by the hardware. Please contact us if you
are interested in purchasing a multi-channel (>2) measurement system, we also sell soundcards that are ideal for multi-
channel measurements.

10.25How to get the size of the measured impulse response to be a power of two (2N)?

Some other software demands that the size of the impulse response is a power of two.
To make an impulse response of this size in WinMLS you must go to Measurement->Settings... and set the Max.
decay time + system delay [s] since this determines the length of the impulse response.

The length in seconds and that is found by the formula

#seconds = #samples / Fs

Using the formula above, if the sampling frequency Fs equals to 48000 and the #samples you want is 214 then the
#seconds is 0.34133 as shown in the figure below.

If the number of samples you want is 214-1 then you must use the formula above and type in the number (214-1)/48000
= 0.34131.

Note: If the check box  is checked the size should always be a

power of two (you find the check box by clicking the  button in Measurement->Settings...).

Note: If you are using the Impulse/Frequency Response Advanced mode shown in the figure below you can specify

the length of the impulse response using the  check box.

10.26How to write a program for reading the WinMLS .wmb file format

An example of reading the recommended measurement file format .wmb is given in the file loadimp.m found in the
folder where WinMLS is installed. It is written in the Matlab programming language, but is very similar to the
programming language C. The file format is listed in the file format.h also found in the folder where WinMLS is
installed.
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11 FAQ: Plotting and Post Processing

11.1 Plotting – general information

Some general plot-settings are found on the standard toolbar to the right of the Cal button. 

Important settings are found on Plot Toolbar (positioned at the bottom in the default setups). 

From the Plot Toolbar you can do zooming, choose plot type, choose to display one or two plots in the window and
open the settings dialog box for the active plot type.

11.1.1 How to plot a measurement?

If a measurement is performed or opened from file, it will be plotted automatically if Plot in active window or Plot in
all windows is selected in Measurement->Measurement Tasks... as shown below.

11.1.2 How to display two plots simultaneously, e.g. the upper plot displaying frequency response
and the lower phase response?

You can choose to display one, two or even more plots in a window from the Plot->Plot Type/Routing/Test.... To

switch between displaying one or two plots, you may also use the  button on the Plot Toolbar.

11.1.3 How to set the plot type (e.g. to waterfall) and determine what measurement is to be plotted?

All this can be done from the Plot Toolbar and the Measurement Selection Toolbar: The type of plot is determined
from the list box list in the plot toolbar (View->Plot Toolbar). 

The active measurement is set from the list box in the measurement selection toolbar (View->Measurement Selection
Toolbar) shown below. 

Alternatively you can set this from Measurement->Information....

11.1.4 How to access the settings for the plot type?

If two plots are displayed, first set the plot you want to access the settings for as active by clicking in it. Then push the

F5-key or click the  button found to the right on the Plot Toolbar. The settings can also be accessed from the
Plot->Plot Type Settings->Active Plot…. A dialog box will appear displaying the settings for the plot type. All
settings (except layout settings) should be available from this dialog. 



Note: the button  displays the settings for all the frequency domain plot types.
If a setting in this dialog box is changed, it will thus affect all the frequency domain plot types.

11.1.5 If a setting is changed for the displayed plot-type, how are the curves in the plot
updated/refreshed?

Curves that are already plotted may be refreshed automatically or manually, this is set from Plot->Auto-Refresh…
and is shown below:

If Auto Refresh is not checked, the plotted curves must be updated manually. Do this from Plot->Refresh… or the

 button on the Standard toolbar. 

If  is selected, the curve belonging to the active measurement will be updated
automatically if any changes in settings are being made. 

If  is selected, all curves are updated automatically if any changes in settings are made.

Auto-refresh can also be turned on/off using the  button on the Layout toolbar.

11.1.6 How to change the vertical axis scaling?

The y-axis scaling can be changed, e.g. from Linear to dB of plot type Time Data (Impulse Response).
If two plots are displayed, set the plot to which you want to change the scaling active by clicking in it (you will then
see a small frame around it). Go to Plot->Plot Type Settings->Active Plot… to open the active plot type settings.
Then in the upper part of the dialog box change the content of the Vertical axis list box shown below. 

11.1.7 Why is the phase shift not within 360 degrees when measuring with WinMLS?

A typical question from people with experience from traditional measurement equipment is: 
Question: “I have started to try to measure phase responses now, but it seems like WINMLS always presents a huge
phase shift with increasing frequency that is far from reality. Several thousand degrees while reality is maybe 360
degrees. It looks like this phase shift is somehow "built in" and always present in any measurement.”

Answer: It is true that the phase shift is built-in. If you measure the impulse response of a loudspeaker you will notice
that there is a certain flight time (given by the distance from the loudspeaker to the microphone). This flight time gives
a delay and this delay is the same as a linear phase shift. A delay of as little as 1 sample will give a phase shift that
linearly increases with frequency and is as much as 180 degrees at half the sampling frequency. 

This phase shift can be removed in several ways. 
The easiest way is to go to Plot->Plot Type Settings->Phase Response/Function…. In the dialog make sure the
check box shown below is checked.
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Alternatively, you may type in the time of flight delay in milliseconds in the same dialog box.

You may also make sure the time window is set so the initial delay is not included.

11.1.8 How to filter a measurement, e.g. using a bandpass filter?

Make sure one of the time domain plot types is displayed, e.g. Time Data (Impulse Response). Note also that if
changing the filter settings for the Time Data (Impulse Response) plot type, the time domain plot types Step
response, Energy-time curve and Schroeder curve will also get the same filter settings (if they are displayed in the
same window).

To change the filter settings, first go to Plot->Plot Type Settings->Active Plot… to open the active plot type settings.

In the dialog box, make sure  is checked and the click the  button to display the filtering
settings. Select the type of filtering you wish to use and click the OK button to exit the dialog boxes.
Note: The filtering will also be applied to the frequency domain plot-types if

 is checked in Plot->Plot Type Settings->General Frequency
Domain....

11.1.9 What toolbars are useful when working with a waterfall plot?

Using the 3D Plot Toolbar, you may now use the mouse (drag) to rotate the 3D-plot and change other properties.

Note that the Plot Type Toolbar may also useful as shown below

The Time Window toolbar may also be useful since it defines the starting limit from where the waterfall is computed.
If ETF (Energy Time Frequency) is selected as calculation mode, the end limit defines how many slices to be plotted.

11.1.10What waterfall calculation mode should be used?

We recommend that you use the Energy-Time-Frequency mode if you are analyzing recorded data. Open the plot type
settings for waterfall (push the F5 key) and select as below in the upper right

If you are analyzing loudspeaker impulse responses, the Cumulative Spectral Decay mode should instead be selected.



11.1.11If waterfall is plotted, how to read the value of a specific waterfall slice?

This feature is only supported if the waterfall layout mode is set to Separate lines waterfall as shown below.

This is set from the waterfall plot type settings Plot->Plot Type Settings->Waterfall….

On the right part of the Active Plot Type toolbar (see figure above), the buttons  and  can be used to move
upwards and downwards and select the time slice. The selected time slice from which the values are read from is
plotted in green color. 

Note: If you have turned on the cursor from Plot->Layout->Cursor… to read out the cursor values, you should also
turn on Plot->Solo Curve. This will remove the slices in front of the active slice as shown in the figure below (the one
with the green slice in front is there the Solo Curve feature is used).
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11.1.12How to set the depth of the waterfall plot?

The waterfall lines can be spaced too far apart if there are many lines in the plot. The depth axis may disappear into
the distance.

The easiest way of setting this is by using the 3D Plot Toolbar. Click the  button and the click and drag in the
waterfall plot to change the depth.

This can also be solved from Plot->Layout->Edit..., select the 3D tag as shown below.

One method is to change the z-axis density, which is adjusted in the percent 3D dialog box shown below.
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Another method is to turn off  and change the Rotation and Elevation values. 

Selecting another layout mode can also solve this problem. Go to Plot->Plot Type Settings->Waterfall…. In the
dialog select Waterfall or Surface in the layout mode list box. 

11.1.13When plotting waterfall, how to select the start point?

The start point is set by the start of the time data window. See the next section on how to set this.

11.1.14The right part of my waterfall look strange, how can I fix this?

In the WinMLS screenshot below, we see that the rightmost part look strange.

It should rather look like the figure below.

To set it to the mode shown in the figure above, go to Plot->Plot Type Settings->Waterfall... and in the dialog box
select Separate lines waterfall as shown below



Note: When using this mode you may have to adjust the plot depth as described in the above section: How to set the
depth of the waterfall plot?.

11.1.15How to set the time data window when plotting in frequency domain?

The time data window determines the part of the time data to be used when transforming from time domain to the
frequency domain. Three ways of setting the time window will be described.

• The time data window settings can be obtained from Plot->Plot Type Settings->General Frequency

Domain …, click the  button found in the upper left part of the
dialog box.
If you are performing division and need a different time window for the reference measurement, the time

window settings for the reference measurement are obtained by clicking the  button found in the

lower left part of the dialog box. If you need faster access to these settings, they are found clicking  and
 on the Active Plot Type toolbar (View->Active Plot Type). 

• If the Time Data plot type is displayed the window start and end points can be set directly by clicking and
dragging with the mouse. To do this,  must be checked in Plot->Plot
Type Settings->Time Data..... If you do not like to use the mouse for doing this, the fast method explained
below may be useful.

• Another way of setting the window directly is by using the Time Window toolbar (View->Time Window
Toolbar). If a change is made and auto-refresh is on, the plot will be automatically updated with the new
settings. After typing a value, click Enter to validate.

11.1.16How to speed up the plotting?

If fast plotting is required, first make sure you are using Fast Line as line type. This can be set at the bottom of Plot-
>Layout->Curve Styles and Colors…, in the Curve type list box shown below. 

Note that these settings apply for the active plot type only. The plotting speed can be improved further by using two
methods. The first method has no side effects and has a good effect on the speed; it is simply to set the curve width to
size 1 as shown below. 

If it is not set to width 1, the plotting will be slower. Make sure that all the curves in the dialog box have width 1. Also
at the bottom of the dialog box, make sure that Emphasis active curve using width is turned off as shown below.
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The other method gives very efficient plotting for large amounts of data, e.g. for large *.wav-files. From Plot-
>Layout->Advanced … check one of the check boxes shown below.

The lower check box limits the plotting range.
If the upper check box is checked, the points in between the points plotted are simply skipped independent of what
part of the curve is displayed. This will affect all the plot-types originally having more elements than the maximum
limit. Please note that the skipped points will not appear even if zooming in, therefore it is not recommended to use
this option on a fast PC. 

Finally the plotting after each measurement can be turned off from Measurement->Measurement Tasks..., by

making sure  is selected. 

11.1.17Where are the plot cursor values (x,y) displayed?

The position of the mouse pointer relative to the curve of the active measurement is written to the Status Bar (at the
bottom right). 

Using this you can read out the values of the active measurement curve.
Note that if you have plotted several measurements it is the active measurement curve that is displayed.

11.1.18Where is the wavelength displayed?

When a plot type has frequency as x-axis the wavelength is displayed in the status bar to the right of the x and y-values
(see previous section).

In the figure above, the wavelength (w), half wavelength (w/2) and quarter wavelength (w/4) are displayed. On how to
set the unit to feet, see the next section.

11.1.19How to change the wavelength unit from meters to feet?

This is done by changing the unit for the speed of sound from m/s to ft/s. To do this, go to Plot->Plot Type Settings-
>Time Data... and select [ft/s] as show in the figure below

11.1.20How to save the curve data in the plot?

The curve data in the active plot can be exported to .txt-file in File->Export Data …. 
A method that gives access to more advanced settings is found in Edit->Advanced Export.... In the dialog click the
Data tag. The dialog box will then show the settings below.



In the Series list, you can choose if all curves or just one curve are to be exported.

11.1.21How to save the plot as a picture?

The active plot is saved to a picture format in File->Export Plot…. From this dialog box, several formats can be
selected as shown below.
 

If the .tee-format is selected, the file can be opened by a viewer that comes with WinMLS and changes can be made,
but if the plot consists of large amounts of data the size may be very large. 

Ctrl+C or Edit->Copy Plot will copy the active plot to clipboard. 

A method that gives access to advanced settings is found in Edit->Advanced Export.... In the dialog box click the
Data tag. The dialog box will then show the settings below.

From the figure above, we see that it is possible to set the quality and size when saving as .jpg-file.

11.1.22How to view and manipulate the data of the plotted curves?

The plotted data can be viewed and manipulated from Plot->Layout->Edit..., click on the Data tag. Note that you can
use the mouse to increase the size of this dialog box, which is convenient you want to inspect curves with large
amounts of data.
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11.1.23How to make calculations, such as subtraction?

Note that the method that will be described only works if the data has exactly the same vertical axis values. Also note
that if a value is missing, it is set to zero. This can be a problem e.g. when calculating the average of reverberation
times, if some values are not plotted because the signal-to-noise ratio (SNR) is poor. Therefore we recommend that
you use the statistics feature in Plot->Overlay Settings… or Plot->Add Curve(s)… for such purposes. That feature
is also much easier to use.

First plot all the curves you want to perform calculations on and go to Plot-> Layout->Edit.... In the dialog box, you

will see the list of the plotted curves/series. Generate a new curve/series by clicking the  button. Then
select series type, e.g. Fast Line as selected in the figure below.

Click on the Functions tag in the upper part of the dialog box. You can select from three tags containing different
mathematical functions, Standard, Financial and Extended as shown in the figure below.



Double-click on the type of mathematical function you want, e.g. Add (see above). After double-clicking, you will go
to the series properties shown below.

In the Source Series tab, mark the series you wish to do the computation on (in the figure above CurveMeas. 7 and
CurveMeas. 4 have been marked). 

Now use the  button to move them to the Selected: list. If you want to move all measurements use the  button.

When this is done, click the  button to exit the dialog box. You will now see the new series in the plot. 

You can change the title of the new series by clicking the  button in Plot->Layout->Edit.....
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11.1.24How to plot the level of a measurement in octave or one-third-octave bands?

The energy of an impulse response or the power of a stationary signal or noise can be plotted in octave or one-third-
octave bands if Frequency response/Spectrum is selected as the plot type.

Go to Plot->Plot Type Settings->Active Plot… to display the plot settings dialog box. Select 1-Oct. Integrated or
1/3-Oct. Integrated as shown below.

11.1.25Why can I not see the (one-third)-octave values below 40 Hz?

This is probably because 1-Oct. Integrated or 1/3-Oct. Integrated is selected as explained in the section above. If
this is the case, there is a limit of 40 Hz below where the level canot be evaluated.

11.1.26How to plot the smoothed frequency response at the standard IEC octave or one-third-octave
frequencies?

Go to Plot->Plot Type Settings->Active Plot… to display the plot settings dialog and select Magnitude as shown
below.

Note: You may also include marks on each frequency value as shown in the figure. 

To do this, make sure the check box shown below is checked

In the same dialog box, find the smoothing settings shown below.

Make sure  is checked and click the  button shown in the figure above.
In the new dialog, select smoothing type as shown below (it will plot 1-octaves at the standard center frequencies).



Note if  or  is checked, the center
frequencies will not be the standard IEC frequencies.

Click the  button to exit the dialog boxes. 

Finally the plot can be displayed in bars instead of a line. To do this, go to Plot->Layout->Curve Styles and
Colors… and select the curve type BAR as shown below

The figure shown below will then look like below

11.1.27How to plot the smoothed curves more 'graceful'

This is done by interpolating a smooth curve through the smoothed points (see red curve below) rather than straight
lines from point to point (blue curve).
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Please note that the smoothing can be applied to all the frequency domain plots (phase, group delay, waterfall).

Go to Plot->Plot Type Settings->Active Plot… to display the plot settings dialog box. Make sure  is

checked as shown in the figure below. Click the  button also shown in the figure below.

In the dialog box, select smoothing type as shown below (it will interpolate the data so the curve will look very nice).

Note: This slows down the plotting and should not be used if you have set WinMLS to measure and update the plots in
“real time”.

11.1.28How to plot spectrum in octave or one-third-octave bands?

The easiest way is to load the setup named Level (Noise)_Leq (dBA, dBC, etc., third-oct bands) from Setup-
>Load…. Below it is described in more detail how it can be done without loading the setup. This is not intended to be
used for transfer function measurements, since it will give a 3 dB/octave bias because of the integration explained
below.

The energy or power of a signal can be plotted in octave or one-third-octave bands if Frequency response/Spectrum
is selected as the plot type. In Plot->Plot Type Settings->General Frequency Domain... select the scope mode to
one of the settings below.

What you choose depends on if the signal you are analyzing is stationary or transient. If you set it to Automatic which
is recommended, WinMLS automatically determines the setting based on the measurement parameters.

Go to Plot->Plot Type Settings->Active Plot… to display the plot settings dialog box. Make sure that the setting
below is selected.



Click the OK button to exit the dialog boxes. 
An example of 1/3 octave normalized energy is displayed in the figure below. 

Normalized energy in 1/3-octaves
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For information about how to change curve styles, see the How to change the curve style section.

11.1.29How to validate numbers typed in the Plot Toolbar?

If values are entered in this toolbar, they must be validated by clicking Enter if the auto-zoom button is turned on as
shown below.

11.1.30How to limit the plotting range, e.g. plotting only in the range 100-5000 Hz?

You can set WinMLS to plot data only in a specified range, e.g. 100-5000 Hz.

To limit the plotting range, go to Plot->Layout->Advanced... and in this dialog box, you can specify what points you
wish to include in the plot as shown below.

If you wish to plot in the range 100-5000 Hz, you need to find the point that corresponds to 100 Hz and the point that
corresponds to 5000 Hz.
To do this, go to Plot->Layout->Edit... and click the Data tag shown in the figure below. Now use the vertical scroll
bar to scroll down to X value equal to 100 shown in the figure below, we see that it corresponds to point number 229. 
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If we use the scroll bar to scroll further down we see that 5000 Hz corresponds to number 13610 as shown in the
figure below..

Now go to Plot->Layout->Advanced... and in this dialog box, you can specify these points we found as shown below.

The result is now a frequency response plot as shown below.

Remember to store the setup from Setup->Store... if you want to store this setting.

You can do this for all plot types. For an example on how to do it for the Room Acoustics plot type, in the
Measurement walk-through section see the section Limit the plotting range, e.g. plotting only in the range 100-5000
Hz.

Warning: This setting applies for all plot types so if you set the window to display the time data, only points in the
range 229-13610 will be plotted in all the plots in the active window. Therefore if you want to display multiple plots
while using this feature you should use Window->New Window... to add new windows where the settings are
independent on each other.

11.2 Plot Chart Settings 

The features we will discuss in this section are found in the Plot->Layout->Edit... dialog box. Note that since this
dialog box is a part of the external plotting library WinMLS is using, the terminology is slightly different than the rest
of the software. The main differences are:

• The plotted curves are named series.
• The plot settings are named chart settings. 

When there are two plots displayed, the settings in the Plot->Layout->Edit... dialog box are independent. 

11.2.1 How to change the curve type?

When installing WinMLS, the default curve type is set in Plot->Layout->Curve Styles and Colors… as shown in the
figure below.



To change the curve type without changing the default curve type, in Plot->Layout->Edit..., click  to open the
dialog. For more explanation see the documentation under Plot->Layout->Advanced….

11.2.2 How to change the curve style (color, type and width)?

The defaults curve style can be changed in Plot->Layout->Curve Styles and Colors…. 
Note: These changes will not apply before you delete the curves in the plot and plot them again. 
If you just want to change the curve styles in the current plot, then go to Plot->Layout->Edit.... If you want to change
the color only, click on the curve to the left of the series title, the red horizontal line shown in the figure below. 

(You can do the same also from the List of Curves toolbar, see View->List of Curves).

If you want to display the style settings, double-click on the curve title (CurveMeas. 1 shown in the figure above). If
the curve type is FastLine, the settings shown below will be displayed.

From the Style list the options shown in the figure below can be selected. These are especially useful if plotting
several lines and colors are not allowed. Note that if the curve width is larger than 1, the style can only be solid.

To display the value for each point, marks must be set to visible. This is set from Plot-> Layout->Edit... as shown in
the figure below. First select the series, then the Marks tab. In the Style tab, make sure the Visible check box is
checked.

11.2.3 How to change the background color

The background color is set from Plot->Layout->Edit…. Select the tabs as shown below (Chart->Panel->Gradient) as
shown below. 
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Now you can change the colors. In the example above, the gradient starts with white and ends with blue. The results is
as shown below.

If you do not wish to use a gradient, make sure the check box shown below is not checked

Then select the Background tab as shown below

In the example above, the selected color is white. Click the Panel Color… button to change this.

11.2.4 How to plot figures in black and white only (e.g. for publishing articles)?

Sometimes figures in color are not accepted, e.g. for publishing articles in journals. If this is the case, it is
recommended to load the post-processing setup named BlackNWhite (do this from Window->Load Post-
processing…). This setup will make sure that the background color is white and the curves are plotted in black. If
several curves are plotted, instead of using different colors the curves are dashed or dotted. The defaults for this are set
in Plot->Layout->Curve Styles and Colors…. 
If you are to change the curve style, see the How to change the curve style section. An example of a plot using this
setup is shown below.
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The plot can be saved from File->Export Plot…. If saved in the .tee-format, it can be opened again using the tee-files
viewer. This can be useful if formatting adjustments are to be made later.

11.2.5 How to change the order of curves?

From Plot-> Layout->Edit..., the order can be changed by clicking and dragging. Note that the curve at the end of the
list is the upper curve displayed in the plot. You can also change the order from the List of Curves Toolbar (turn it on
from View->List of Curves).

11.2.6 How to erase curves from the plot?

Deleting curves can be done from Plot->Erase Curve(s)….

Alternatively, you can do it from Plot->Layout->Edit..., click on the curve(s) to be deleted and click the delete button

 or the delete key. 
You can also do it from the List of Curves Toolbar (View->List of Curves) as shown below.

Mark the curve(s) you want to delete by clicking on the curve name(s). Use Shift or Ctrl to mark several curves. Then
use the Delete key to delete the marked curves.

11.2.7 How to choose between plotting several curves and a single curve?

If Plot->Overlay is checked, the new curve plotted will be added to the existing curves. If it is turned off, the existing
curves will be deleted when a new curve is plotted.

Plot->Overlay is also available on the standard toolbar as the  button.

11.2.8 How to display one single curve and set the other curves as invisible?

When there are several curves in the plot, it is sometimes useful to display only one of the curves temporarily without

deleting the others. This can be done with the  button on the toolbar, or from Plot->Solo Curve.
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When Solo is on, only the curve belonging to the active measurement is visible. The other curves will be invisible in
the plot, but they are not deleted from the legend list. If Solo is turned off, all curves that were displayed when Solo
was turned on will be displayed again. 

11.2.9 How to display the legend (a list of the curves that are in the plot)?

The  button on the Standard Toolbar displays the legend list. See the next section on how to position and format
the legend list.

11.2.10How to “turn off” a single curve from the plot without deleting it?

When there are several curves in the plot, it is sometimes useful to temporarily set one of the curves to inactive
without deleting it. WinMLS offers several ways of doing this.

The easiest way of doing this is to use the legend (turn it on from Plot->Layout->Legend). To set the legend
formatting or position, the legend settings are found in Plot->Layout->Edit..., select the Legend tag as shown below. 

Note that if  is checked, a check box is added to the legend. Use this check box to set the curve visible
or invisible in the plot. In the example below, the curve named Studio1 is not visible in the plot beause it is not
checked in the legend list.

Note: If WinMLS has more than one plot displayed, all plots will be updated if you click on a curve in the legend list.
In the example above this means that the Studio1 curve will be set to invisible in all the plots. If you want a curve to be
set invisible/visible in only the active plot, then you can use the methods that is explained next.

In Plot->Layout->Edit... all the available curves are displayed, they are shown in the plot only if the check box in
front of the curve name is checked. 

This list is also displayed in the List of curves Toolbar (View->List of Curves).



11.2.11When printing a plot, why is the plot squeezed to the left corner?

A typical plot is shown below.

The plot is squeezed to the left because the legend is displayed. The legend may be turned off from Plot->Layout-

>Legend or using the  toggle on the Standard Toolbar. The legend may also be moved inside the plot as shown
in the section below.

11.2.12How to change the text (and the title, sub title, sub foot, foot) and to store these settings?

You can set all these from Plot->Layout->Edit... as shown below.

Note: In order for the text not to be overwritten the next time a curve is plotted, you must go to Plot->Layout->Text
Refreshing.... In the dialog box shown below make sure the check boxes are unchecked as shown below. If they are
unchecked, the text will not be refreshed and therfore the text you have typed in the dialog shown above will not be
erased.
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11.2.13How to change the names displayed in the legend?

The default names of measurements that are performed (and not opened from file) can be changed from Plot-
>Layout->Text Refreshing... as shown below.

Measurements that are opened from a file are given the same name as the filename. As shown in the figure above, you
can select if you want to add the folder name and/or file extension to the filename.

A way of changing the name is to save the file, then the new filename will be displayed in the legend. Alternatively the
default names of the curves in the legend can be changed from Plot->Layout->Edit.... Select the curve you wish to

rename. In the figure below, Meas. 5 is selected. Then click the  button and type the new name.

Note: The new names will not be remembered, which means that they will be lost when the curves are deleted or
refreshed.

11.2.14How to move the legend to an arbitrary position, e.g. inside the plot?

The legend can be moved inside the plot as shown below.



You can also display the legend above or below the plot. In the figure below the legend is plotted below the plot.

Setting the legend position is done from Plot->Layout->Edit…. Make sure you select the tags as shown in the figure
below, starting from the upper Chart, Legend, Position.

Make sure  is checked if you want the legend to be moved inside the plot. But if you want the legend
positioned below the plot make sure  is turned off and the  radio button is checked.
Note: If storing the setup, these changes will be kept.

11.2.15The legend list is filled up, how to solve this?

The legend list may fill the whole plot window as shown below. If this is the case, the curves at the bottom of the list
may not be shown. 
To show all curves you can do one of the following

• Move the legend list to the bottom or the top of the plot as explained in the section above.
• Increase the plot window by dragging at the window upper or lower limit.
• Go to Plot->Erase Curves… and erase some curves from the legend list.
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11.2.16How to access zoom options, e.g. to turn the mouse zooming on/off ?

From Plot->Layout->Edit..., select the General tag, then select the Zoom tag as shown below. 

The mouse zooming is allowed if the  check box is checked. Note that if the  check box is
checked, the zooming is done in steps; this is a nice visual effect, but is not recommended on a slow PC. The

 determines the minimum size of the rectangle drawn by the mouse to obtain zooming (if the

rectangle is smaller, no zooming will be performed). The  buttons can be used to display
the zoom rectangle area in different styles and colors. 

11.2.17How to zoom the plot with the mouse?

To zoom in, drag a rectangle from upper left to lower right. Note that this is the only way to zoom in when using the
mouse. If you drag a rectangle in any other direction zoom out is performed. 
Zooming can also be done very efficiently from the Plot Toolbar. 

It can also be done from the menu Plot->Axis Range.

Note that in certain cases, if the plot is to be zoomed out, the mouse out-zooming will not zoom out completely, but

zoom out to the previous setting. If you want to zoom out completely, click on the  button shown above.



Note: If the mouse zooming is deactivated, see the section above to activate it.

11.2.18Personal versions only: How to move the curves away from the nag screen?

You may scroll the plot using the mouse as explained in the next section.

11.2.19How to scroll the plot using the mouse? 

If your mouse has a wheel, you may use this wheel to scroll vertically.
Clicking the right mouse button and dragging will scroll the plot. 

The direction of scrolling can be set. Under Plot->Layout->Edit..., select the General tag, then select the Scroll tag,
then mouse zooming can be set from the Allow Scroll radio buttons shown below. 

You may also select what mouse button to be used for the scrolling as seen above.

11.2.20How to turn on and modify gridlines

Gridlines as shown in the plot below can be turned on/off from Plot->Layout->Gridlines. 

Note: When the Plot->Layout->Edit... dialog box is opened, the current gridlines are displayed even if they are
turned off. 
Note: If the plot type is Frequency response/Spectrum, Phase response/Function, Group delay, Waterfall or
Levels and if the x-axis is logarithmic, some of the gridline settings are not user changeable.

To modify the gridlines; in Plot->Layout->Edit... select the Axis tag. Then select the axis where you want to modify

the gridlines from the list (Left Axis or Bottom Axis). Click on the Ticks tag. Finally click on the  button
and turn on the  check box. 
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Minor gridlines are available from the Minor tag, found at the right side of the Ticks tag.

11.2.21The y-axis labels show only zeros, how to change this?

The axis labels resolution has to be set. See the section below on how to do this. You have to make sure to set it for
the Left Axis. If you select the exponential format this problem should be solved. 

11.2.22How to set the axis labels format?

As examples on setting the label format, we will in the next sections first show how to set the axis labels resolution,
then set the label increment.

11.2.22.1 How to set the axis labels resolution?

In some cases axes labels with 3 decimals is not necessary, in other cases it is insufficient. Using an exponential
format can solve this. How the format is set will be shown.
From Plot->Layout->Edit... click on the Axis tab. Select the desired axis, found on the list to the left, e.g. Bottom
Axis. Then click on the Labels tab, and finally on the Format tab (see figure below).



The Values Format: list box has a list of used formats. You may also type your own format. To the left in the dialog
box you see a list of the axes. Select the axis you want to change the format of (“left” is the y-axis and “bottom” is the
x-axis).

11.2.23How to set the axis label increment?

Setting the axis label increment is useful e.g. if you want to plot the magnitude frequency response using axis labels
with an increment of 5 dB per division for comparing with printouts from other measurement systems.
You can force WinMLS to label the selected axis using a specified increment. From Plot->Layout->Edit.... click on
the Axis tab. Select the axis you want to modify (Left axis or Bottom Axis) in the left corner of the dialog box. Then

click on the Scales tab (see figure below). Click on the  button found at the bottom of the figure below. In
the new dialog, type the desired increment using comma as separator and click OK. If you type “0,2”, the Desired
Increment will be set to 0,2 as shown to the right in the figure below.

            

Note that labels at the selected increments will only be displayed if there is enough separation between the labels. This
should not be a problem, but by clicking the Labels tab shown in the figure above the separation can be set in
percentage:

11.2.24How to display the numerical values of the Magnitude Frequency Response Guidelines?

When Frequency Response/Spectrum is selected as the active plot type, guidelines can be added. Go to Plot->Plot

Type Settings->Frequency Response/Spectrum…. Then click the guidelines  button to open the
dialog shown below. 

The numerical values are displayed if  is checked as shown to the left in the figure
below.
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To display the numerical value of these lines can also be done in the legend as shown below

To do this, go to Plot-> Layout->Edit... and click the Legend tab. In the Legend Style list box choose Last Values
as shown below.

This means that the last value of the series will be displayed in the legend and not the curve name. Since the guidelines
are straight lines this is the value of the guideline. 



11.2.25How to find the maximum frequency and its value?

You can find the maximum frequency (e.g. the feedback frequency) from the Frequency Response – Spectrum plot
type. 

Go to Plot->Layout->Advanced.... In this dialog box, make sure  is checked.
This will update the cursor with the maximum value each time you perform a new measurement. 

If you want to add a cursor, make sure that Plot->Layout->Cursor is checked.

You can also find the frequency with the highest gain by selecting the Parameters plot type. Select the Parameters
plot type in the list in the Plot Toolbar. Go to Plot->Plot Type Settings->Parameters… and select as shown below.

This will display the frequency on the horizontal axis and the level on the vertical axis.

The frequency and level will also be displayed in the status bar.

For all the plot types you can add a textbox that will contain the numerical values as shown below.
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How to do this is explained in a section below. You can easily change the font of the text. In cases where you have to
be far away from your PC and don’t see well, we recommend that you use a large text font, for example as shown
below.

In the figure above we have covered the whole plot with the text. This is useful if you only want the numerical value
of the frequency and gain.

To do this we removed the axis.
This is done from Plot->Layout->Edit, select the Chart and Axis tabs, then make sure  is not checked as
shown below.

11.2.26How to add a box displaying the cursor values? 

This is done the same way as adding text to the plot as explained in the section below.
This will work even if the cursor is not checked in Plot->Layout->Cursor. The current mouse position in the active
curve will be used.

11.2.27How to delete a text box from a plot?

This is done by following the method in the section below, but instead of clicking the Add button to add text, click the
Delete button to remove the text (annotation).

11.2.28How to add cursor values and a box with custom text to a plot?

This will explain how to add cursor values or custom text such as your own comments to the plots, and example is
shown below for custom text.



One of the text boxes you add to the plot, will be used to display the cursor value as shown in the figure below.

Therefore, if you only add one text box it will be used for the cursor values. If you wish to add a box with your own
text you need to add two Annotation boxes as will be explained below.

In Plot->Layout->Edit..., click on the Tools tag as show in the figure below. Then click the  button.

From the list select  and click the  button. If you want to add your own text, do this operation
twice to add two Annotation tools.

If you want to type your own text, select the upper Annotation tool as shown below, (if you pick the lower
Annotation the text will be replaced by the cursor values) 
Then type your text in the Text field as shown below. 

Important: To display the annotation in the plot, you must make sure  is checked as shown in the figure
above. Then set the position of the text box by adjusting the left and top values

While you adjust these, you should see the text box moving around in the plot.

Note that you may format the text in many ways, for example it can be made transparent by checking 
shown below.
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The font can be changed from the Text tab by clicking the  button shown below.

Select the tabs shown above to set other layout options.

11.2.29How to add a cursor that follows a curve?

A cursor will follow the active curve if Plot->Layout->Cursor is checked.

11.2.30How to make a cursor to follow a curve when there are several curves of the same
measurement?

If you have plotted several harmonic distortion components (or filtered several bands) there are multiple curves that
belong to the same measurement. If you want the cursor to follow the second order distortion component, you have to
set this manually. 
Go to Plot->Layout->Edit... and click the Tools tag as shown below. Then select the desired harmonic component. In
the figure below, H3 (which is harmonic component 3) is selected.

11.2.31How can curves in the plot remain so that they are there when WinMLS is restarted?

Go to Setup->Store… and make sure the  check box is checked.
Note that this only works for saved measurements and the measurements must be saved in a subfolder under the folder
where WinMLS was installed.



11.2.32How to print graphs at very high quality

In File->Print Preview… you can decide how detailed you want the graphs to be printed. The setting below is the
default

The Detail property controls how screen pixels are mapped to printer pixels. By default it is set to Normal, meaning
screen proportions will be respected when printing (Normal represents the Screen resolution printing 'What you See'). 
The closer the slider is moved left towards More, the higher the resolution of screen pixels passed to the printer.
The method is similar if you are using File->Print Preview All…, but in this dialog box, the Detail Level layout is
somewhat different and its value is stored.

11.2.33How to remove PASSED/FAILED text from the plot area?

The reason PASSED/FAILED is displayed in the plot is that the production control/test features have been used.
This can be turned off from Plot->Plot Type/Routing/Test.... Make sure no check-boxes are checked under the Limit
curve section as shown below.

After doing this, go to Plot->Refresh… and click the  button. Then the PASSED/FAILED text should be
removed.
If not, you must remove it manually. The procedure is the same as removing the nag screen as shown in the section
below. This is because the nag screen and the PASSED/FAILED text are both a picture.

11.2.34How to remove ”Illegal for commercial usage and research” nag screen when upgrading
from the personal version

The nag-screen below may be a problem if you have purchased the personal version first and then purchased the
professional version.

You can delete this from Plot->Layout->Edit… to open the dialog box shown below.
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Click the Panel tag, then click the  button to remove the nag screen.

To remove the footer text shown above push the F6 key again if you need to open the dialog box shown below.

Click on the Titles tag, then make sure  is selected. Then delete the text “WinMLS2000 Personal ...”
shown at the very bottom of the dialog box. That should do it.

Note that you may want to store the setup from Setup->Store….

11.2.35How to remove or add a picture in the plot area?

A picture can be added/removed from the plot. The procedure is the same as removing the nag screen (which is a
picture) as shown in the section above.

11.2.36When using Plot->Add Curve(s)… to add an extra curve and changing the plot type settings,
the extra curve gets the same color as the first. How can this be fixed?

This happens only if  is selected in Plot->Auto-Refresh.... To avoid this, instead of ‘all curves’ select
‘active curve’ as shown below.

Alternatively go to Plot->Layout->Edit… from where the curve colors can be set by clicking on the colored line
shown below.



12FAQ: Room Acoustics
Refer to the help in the dialog boxes for additional information.

12.1 How to measure room acoustics?

When using WinMLS for measuring room acoustics, it is recommended that a room acoustics setup is loaded. For
example, go to Setup->Load… and select the setup named Room Acoustics_ReverberationTime from the list of
setups. Then follow the instructions given in the wizard that appears after loading the setup.

12.2 How are room acoustics parameters presented?

Room acoustics parameters can be presented either as numbers in a table or plotted as curves. If you want to display
several parameters simultaneously, it may be easiest to use the table (but you may display multiple plots as well, the
advantage of this is that you may display the results from several measurements in one plot). The parameters are
displayed in the table from the Calculate menu.

12.3 How to set manual start of the impulse response?

For some room acoustical parameters, it is important that the start of the impulse response is known. In the figure
below, the start of the impulse response is not correctly found as shown by the yellow line.

If WinMLS is not able to detect the start of the impulse response, this can be done manually. To do this go to

Calculate->Calculation Options..., then click on the  button to display the
dialog box shown below

Select the setting shown above. Then use Time Data plot type to set the time window. This procedure is also described
in the Measurement Walk-Through section.
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12.4 How can the Room Acoustics Parameters Grid be copied to a spreadsheet (e.g.,
Excel)?

This can be done first by computing the parameters to a table (see section above on how to do this). When this is done,

click the  button, or Alt+C to copy the data to the windows clip board. Note that you may mark the cells you
want to copy, if no cells are marked, all cells are copied. After doing this, you can now paste the data to a spreadsheet.

12.5 How to fix problems with the formatting when pasting room acoustics parameters to
Excel?

If you experience problems with the formatting, note that inserting in Excel from WinMLS, acoustics parameter
clipboard does not work properly if "," is selected as a decimal divider.
The reason is that Excel interprets the cell content based on the global Windows settings. If “.” is the decimal divider,
it works fine. Set this from the windows Control Panel (found from the windows Start button), select Regional and
Language Options. Click the Customize… button. As the Decimal Symbol, select “.”.

12.6 How to fix problems with the formatting when reading a room acoustics parameters
text-file to Excel?

If you experience problems with the formatting, note that opening a WinMLS acoustics parameter text-file in Excel
from WinMLS acoustics parameter clipboard does not work properly if "," and not "." is selected as the decimal
divider. How to change the decimal divider in Windows is explained above.
If you do not want to do this, another solution is possible.

When opening a text-file in Excel, you have to go through a wizard. In the third step, the wizard (upper part) will look
like below.

Click on the Advanced... button. Then the dialog box shown below will be displayed.

Make sure that the Decimal separator is set to “.” as shown in the figure above (you will have to change it from “,” to

“.”. Then click  to close the dialog box. Finally click the  button.

12.7 Is the relationship between T30 and T60 linear, so that T60=2*T30?

No, all the methods for measuring reverberation time in WinMLS gives the time it takes for the sound to decay 60 dB
as result. In a normal room, this decay is supposed to be linear as function of time (a straight line). We can therefore



find the reverberation time by measuring 30 dB decay and extrapolate the rest of the line down to 60 dB. This is what
is recommended in the ISO 3382 standard and is useful in cases where it is difficult to get a signal-to-noise ratio that is
better than 60 dB.

12.8 Strength ISO 3382 Calibration Procedure
A reference level calculation procedure is implemented for use in various reference measurement situations.

For a true omni-directional sound source a reference measurement in a single direction would be sufficient. But most
practical sources are 12-faced speakers that start to show lobes in the polar pattern around 1kHz. The ISO 3382
standard therefore specifies that a proper reference level measurement shall be made in a free-field, and data from at
least 29 directions shall be energy averaged. The following section explains how to do measure this reference level.

12.8.1 Performing calibration measurements

Before measuring you must be sure that the equipment you are calibrating is the equipment you are going to use for
the measurement (even the cables should be the same).
Before measuring it is recommended that you calibrate your input chain (microphone, optional amplifier and sound
card) e.g. using a calibrator.

If you want your measurements to be completely according to the ISO 3382, you need to measure 29 measurements
along a circle around the loudspeaker placed in a free field (in an anechoic chamber or outdoors far above the ground).
Each step should be 360/29 = 12.4 degrees. To simplify the positioning, you can place the loudspeaker on a turntable.
Keep the microphone in the same horizontal plane when doing the calibration measurements.

This procedure can optionally be done automatically from WinMLS since WinMLS can run an executable file after
each measurement (see Measurement->Tasks...). The file ‘BKturntable.exe’ found in the WinMLS folder will
control a BK turntable, but only works under Window 95/98. Please contact us if you have or need information about
other turntables. The turntable can also be moved manually.

The microphone should be placed up to 10 meters away from the loudspeaker, but 3 meters should be sufficient.
Measure the distance you are using and write it down since it may be used for the calculation later. 
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1. Close any open dialogs.

2. From Setup->Load..., if you have not done so already, load the setup named Room Acoustics_Strength (G). 

3. Go to Plot->Plot Type/Routing/Test… and set the settings shown below to display the Frequency Response
– Spectrum plot type in the upper plot.

4. Go to Measurement->Settings.... In the opened dialog box, set Max. decay time + system delay to 0.4
seconds as shown below. The total duration can be set to 10 seconds as shown below.

5. Set WinMLS to Ask after meas. to ask user to save after measurement is performed as shown below

6. Close the dialog using the  button.
7. Go to Measurement->Saving Defaults.... 

8. In this dialog select the folder where you want to save your calibration measurements using the 
button and specify a folder and default filename as shown below.

9. In the bottom part of the dialog, turn on the auto-name counter as shown below. Set it to stop at 29
measurements if you want to do this strictly according to ISO 3382.

10. Close the dialog clicking the  button. Go to Setup->Store... and store the setup under a new name
e.g. Room Acoustics_Strength Calibration if you want to save the settings for later use.

11. Move the microphone to the desired distance from the loudspeaker. In an anechoic chamber 3 meters will be a
good distance to use. Make a note of the distance you are using.



12. Perform the measurements of each position and save them (you can use File->Save As... to save if you are not
asked to save after each measurement). Make sure all measurements are saved in the same folder (which they
will be if you don’t change the folder during the measurements).

Below is a typical example of a calibration measurement. We see that up to 1000 Hz the curves follow each other
which means that it is omni-directional. But above 1000 Hz we see the effects of directivity.

You now have measurements that can be used for calculating the octave bands corrections needed to get the
correct calibration. These will only be valid for new measurements if you do not change the output calibration
values. Now go to Setup->Load... and reload the setup named Room Acoustics_Strength (G).

To calculate the octave bands corrections, go to Calculate->Speech->Settings... to open the dialog box shown
below.
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In this dialog box select ISO 3382 Strength as shown above and then click the 
button to open the dialog shown below.

Follow the steps in the dialog box above. In step 2 you need to either type the distance or you can have WinMLS
to calculate the distance for you. The most safe method is to specify the distance manually (if you are sure about

the value). Click the  button in the dialog above for more information.

After completing this procedure, go to Setup->Store... and store the setup.

Now this setup can be used for measuring strength values according to the ISO 3382 standard.

12.8.2 Less accurate calibration

WinMLS can also measure Strength using less accurate loudspeaker reference measurement. Alternatives may range
from the full set measured in a free-field, via fewer directions, increasingly reflective environments, to actual in-situ
single direction responses. The user must choose a reference from what is practically possible, and be aware of the
resulting accuracy.

12.9 How to detect echoes from a measured impulse response?

We recommend that you plot the impulse response using dB on the vertical axis and milliseconds on the horizontal
axis. Furthermore you can normalize the vertical axis so the direct sound is set to 0 dB (assuming that the direct sound
is stronger than the reflections).
Open the plot type settings by clicking in the active plot and hit the F5 key and make sure the settings is set as shown
below.



Then the early reflections can be found as peaks in the plot as shown below.
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In the example above, we have added a background picture that indicates where you have coloration, image shift,
useful early energy, echoes and reverberation.
To this background picture, go to Plot->Plot Type Settings->Time Window… to display the time window settings.

Make sure  is checked.

Note that to use this map properly, you have to set the time window lower limit to the direct sound (usually the first
strong reflection). This is done automatically when a measurement is inserted if

 is checked in the time window settings. 
Note: The time window start detection is updated when room acoustics parameters are calculated. (This detection
algorithm is slightly different than the  detection)

12.9.1 Why does the relative axis of the map not always quite follow the yellow time limit line?

Below we see that the black y-axis of the map is slightly to the right of the vertical yellow line. This is because the
software searches about 1 millisecond to the right of the yellow time limit line to find the maximum and it then moves
the picture to this maximum. This is because the y-axis of the “early reflections”-picture should line up directly on the
maximum level as shown in the picture below and not before the maximum level.
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12.9.2 Why is it not possible to drag the map to 0 milliseconds

Note that it may not be possible to move the map to 0 milliseconds. The reason is that WinMLS searches for the
maximum level in a 1 milliseconds window and places the map where the maximum is (see the above section where
the map cannot be set to 0 milliseconds).

12.9.3 How to make my own map?

You can easily make your own map. Just use the file EarlyReflectionsFrame.psd found in the Charts sub-folder of
the WinMLS folder.

Warning!!! Do not change the size of the map in any direction or scaling. Any change will cause the axes to be wrong.

If you do make your own map we appreciate if you could send it to us.

12.10How to specify two measurements for computing room acoustics parameters?

Two measurements are to be used to calculate parameters such as IACC and LF. This can be done in Calculate-
>Calculation Options… as shown below where we have selected the microphone type Omni-directional and fig-8
that is used for the LF parameter. If you want to calculate IACC instead of lateral fraction, select the

 microphone type(s).

Above we see that Meas.2 is selected as Omni mic and Meas.3 is selected as Fig-8 mic.

When doing this, the primary measurement (omni-directional mic.) is the active measurement in the upper plot and the
secondary measurement (figure-of-eight mic.) is set to be the active measurement in the lower plot. The active
measurement in the lower plot can also be found and set from the Measurement Selection Toolbar as shown below



12.10.1Limitations when plotting parameters needing two measurements

An example of a plot needing two impulse responses is shown below.

If displaying edr in marks in the plot, only edr for the primary impulse response is displayed in the plot in case two
impulse responses are used in computing the parameter as shown in the figure below.

In the table, both signal-to-noise ratios are displayed as shown in the figure below.

If you intend to plot room acoustical parameters in the lower plot, the active measurement in the lower plot is used as
the primary measurement and if two measurements are needed to calculate the parameter, then this will give an error
message. Instead, perform the plotting in the upper plot when computing parameters needing two impulse responses
are to be plotted.
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There is still a problem if several curves are plotted and Plot->Refresh… is selected with the setting  as
shown below.

Each curve will not remember what was used as secondary measurement when it was plotted, therefore the active
measurement in the lower plot will be as the secondary plot when refreshing all the curves. Therefore, use the setting

 instead of .

12.11How to change the bandwidth, e.g. obtain the reverberation time of the broadband
measurement?

The bandwidth is set from Room Acoustics->Calculation Options… in the Bandwidth list box as shown below.

12.12How to display room acoustics parameters automatically after performing a
measurement or opening measurement file(s)?

The last part of the section below explains how to do this.

12.13Batch processing: How to automatically compute room acoustics parameters from
several measurements?

Go to File->Open... and select the files you want to batch process.Shown below, we have marked seven files that are
to be batch processed.



To mark several measurements, hold the <Ctrl> key while clicking on the measurements that are to be inserted.
<Shift> can also be 
Note: The files you want to batch-process have to be in the same folder. 

If you only want to export the curves that are plotted (e.g. reverberation time), click the  button to peform
the calculation and use File->Export Data... to export the data. Before you do this, make sure that Plot->Overlay is
checked. If not, the old curves will be erased when plotting a new curve

A more powerful method will now be explained.
Click the  button shown above to open the dialog box shown below (this dialog can also be
opened from Measurement->Measurement Tasks...).

Make sure  is checked. Then the selected parameters (in the figure above Reverb times are
selected) are being computed and displayed to a table, printer or file(s) dependent on the settings in Calculate-
>Options.... If you have selected to send result to a text-file as shown below, text-files will be generated with the same
name as the measurement files you have opened and they will be put in the same folder.

Note that the plotting will reduce the speed. But you can turn off the plotting as shown in the figure below
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If you are batch-processing many files, you should also make sure that the measurements are deleted from memory
after the parameters are computed. This is done as shown below

12.14How to average room acoustics parameters obtained from several measurements?

This can be done from the Room Acoustics plot type. On how to do this see the Calculating Statistics and Auto-
statistics sections in the measurement walk-through section.

12.15Is there a way of automatically sending measurement channel two to the lower plot?

If you are going to calculate parameters that are based on two impulse responses, it may be useful to display
measurement channel 1 in the upper plot and measurement channel 2 in the lower plot.

To do this, first go to Measurement->Settings... and select 2 channel measurement as shown in the figure below.

Now go to Plot->Plot Type/Routing/Test…. In the example below, channel 1 is routed to the first plot while channel
2 is routed to the second plot.

This also applies if several measurements are opened using File->Open…, then channel 1 measurement will be
displayed in the upper plot, the channel 2 measurements will be displayed in the lower plot.

Note: If the wrong measurement is plotted, you may change this from Measurement->Information... or from the
Measurement Selection toolbar.

12.16How to change the horizontal axis of the Room Acoustics Parameters plot type?

As default the horizontal axis labels display the octave band values as shown below.
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It is, however, possible to change the axis labels and gridlines.
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It will now be explained how to change the axis to an ordinary logarithmic axis as shown above (if you want to switch
back again, you need to do exactly the opposite of the description below).

Click on axis in the Room Acoustics plot type. It will display the dialog box shown below. Click on the Axis tag, then
the Labels tag. Then at the axis list at left select Bottom Axis.

Now change the Style from Auto to Value as shown below.

Note that when a room acoustics parameter is plotted with bandwidth Broadband, the style should be set to Value. If
not, the x-axis labeling will not be correct.

213



Now select the Scales tag as shown below:

Now we need to change the Log Base from 2 to 10 as shown below.

12.17How is the criterion in the automatic detection of the initial time delay of the impulse
response?

The start of the impulse response is taken as the first sample that exceeds a threshold determined by the difference
between the max level and noise peak of the squared impulse response. The noise peak is taken as max of the last third
of the response.

13FAQ: Applications

13.1 Where to find information about the WinMLS setups?

The usage of the WinMLS setups are usually described in a wizard. This wizard is usually started when the setup is
loaded. If not, it can be started from Measurement->Wizard->Start….

13.2 How to measure loudspeaker frequency response?

No calibration has to be performed to measure the frequency response of a loudspeaker. Load the setup named
Loudspeaker_Near Field from Setup->Load… and follow the instructions.

13.3 How to measure velocity, acceleration and force with WinMLS?

13.4 How to measure vibrations with WinMLS?

Vibrational measurements can be performed with WinMLS.

To find the levels in one-third octave bands, go to Setup->Load… and select the setup Level (noise)_Leq (dBA,
dBC, etc. ,third oct. bands). You can also load a suitable setup in the General section if you want to do other types
of measurements..



If you want to measure the absolute values, you need to calibrate the input. Click the  button on the Standard
Toolbar to open the calibration dialog as shown below.

In section 1b. above, select the type of transducer. Follow the sections below for detailed information about the

calibration procedures, or click the  button in the dialog box.

Note: When plotting these quantities in the frequency domain, a reference is used. The most known reference is 20
microPa which is used to determine SPL (94 dBSPL equals 1 Pascal). There are standards for such references, e.g.,
ISO 1683. The references we are using are as follows:
Displacement: no reference is used and the data is plotted as RMS meters.
Velocity: The reference is 10-9 m/s and the quantity is named Lv.
Acceleration: The reference is 10-6 m/s2 and the quantity is named La.
Force: The reference is 10-6 Newton and the quantity is named Lf.

13.4.1 Measuring with an accelerometer or a velocity/displacement measuring device

To measure the absolute values and not just relative values, click the  button on the standard toolbar. This will
open the dialog box shown below.

In step 1a. make sure the  check box is checked. 
In step 1b. select the type of vibration measurement device. 
If you are measuring with an accelerometer, select:

If you are measuring with a device for measuring velocity, select: 

If you are measuring with a device for measuring displacement, select: 
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In step 2 we must select how the calibration should be done. There are two methods, Individual (advanced) and
Combined (easy). These methods will be explained in the sections below

13.4.1.1 Combined calibration

Use this method if you use a calibrator or if you are able to measure the vibration of your vibrational transducer. For
example a shaker with know vibration (displacement, velocity or acceleration).

If you don’t have access to such equipment, but if the sensitivity of your transducer is known you can still do the
calibration. To do this, go to the next section and skip the rest of this section.

To do the combined calibration, select the  settings shown in the figure below.

In step 3 shown in the figure above, click the  button to open the dialog box shown below. If you have an

external device to generate the vibration for the calibration, select  in step 1. Then the dialog box
will be displayed as shown below.

In step 2 select the frequency of the device you are using for the calibration. The device must generate a vibration at a

single frequency. In the list box you can type in any frequency, in the example above it is set to .

In step 3a connect your transducer to the vibration generator. For example, if your transducer is an accelerometer and
your vibration generator is a shaker, then connect the accelerometer to the shaker.

In step 3b click the  button, after doing this a dialog box will be displayed showing the calibration input
level. It should be adjusted so it is in the range -30 to 0 dBFS.

In step 4, type the level used for the calibration.
If you are measuring with an accelerometer, the level is given in La  which is defined as the acceleration relative 10-6
m/s^2. So for acceleration, the reference is 10-6 m/s2 and the quantity is named La. If the level of your vibration device
is measured in m/s^2, it can be coverted to dB using this formula:



dB = 20*log10(Lin / (10-6))

where

dB – logarithmic value
Lin – linear value

If you are measuring displacement then no reference is used, type in the level in RMS meters.
Velocity: The reference is 10-9 m/s and the quantity is named Lv.
Force: The reference is 10-6 Newton and the quantity is named Lf.

13.4.1.2 Individual calibration

If you have selected  in step 3 which is the advanced method of calibration, the dialog box will look as
shown below.

In step 3 the sound card must be calibrated. If the sound card sensitivity is known, click the  button to make it
possible to enter the sensitivity manually. Then type in the sensitivity.
If the sound card sensitivity is not know, click  the  button and follow the instructions
in the Individual calibration example: Measuring voltage using an adjustable attenuator section.
In step 4a select if you are using an amplifier. If yes, in step 4b type the amplifier gain. If you have an amplifier with
gain steps, you can make a file with gain steps so you can easily switch gain steps. See the Individual calibration
example: Measuring voltage using an adjustable attenuator section for more information. 
In step 5, if the transducer sensitivity is known, click the  button to make it possible to enter the sensitivity
manually. Then type in the sensitivity. If the sensitivity is not known, click the 
button to calibrate the transducer.

13.4.2 Measuring with a force hammer

How this can be done is explained in one of the setup wizards. 

To open this wizard, go to Setup->Load... and load the setup named Musical Acousitcs_Violin Force Hammer.
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13.5 How to measure the frequency response of the measurement system including the
microphone and loudspeaker?

The problem with the loudspeaker is that it is usually not omni-directional. If you want to measure the response of
your measurement system in one loudspeaker position you may try this procedure.
Do a typical impulse response measurement. 
Make sure you plot the frequency response by selecting the plot type named Frequency Response - Spectrum. Do
this from the list box in the Plot toolbar or from Plot->Plot Type/Routing/Test....

Place the microphone near the loudspeaker, 5 cm (2 inches) should be fine. Since it is so close to the loudspeaker it
does not matter much if it the measurement is performed in a room.
Start a measurement.
Inspect the frequency response. It should not and will probably not be flat, but this measurement can be used to test the
level and calibration.

13.6  How to perform automated measurements with WinMLS, e.g. using a turntable?

Measurements can be started automatically and a turntable can be controlled from WinMLS. (For information about
controlling the turntable, run the file BKturntable.exe found in the WinMLS folder. This file only works with
Windows 95/98.)

To enable automatic start of a new measurement, go to Measurement->Tasks... and make sure
 is checked.

If you want to run an executable file after the each measurement, make sure  is
checked. Specify the name of the .exe-file you want to run between the measurements as shown below.

If you want to save the intermediate results, go to Measurement->Saving Defaults... and set the default folder and
file name as shown below

Also enable auto-naming and select the number of measurement. In the example below, 10 measurements are
performed. After the 10 measurements are successfully performed, the Saving Defaults dialog will pop up so you can
change the file name.

13.7 A frequency resolution of 1 Hz is desired, how to set the frequency resolution?

To get a true frequency resolution of 1 Hz, you need 1 second of the signal in the time domain. Set this in
Measurement->Settings…, an example is shown below where 1. Max decay time + system delay is set to 1.0.



If the sampling frequency is 48000 kHz, this means 48000 samples.

The frequency resolution can also be set as post-processing in WinMLS using the time data window (true frequency
resolution), do this in Plot->Plot Type Settings->Time Window…. To get maximum true frequency resolution, set
the lower limit as low as possible and the upper limit as high as possible. This can be done by clicking the

 button as shown below.

Another way is by setting the length of the FFT larger than the time window. This is done from Plot->Plot Type
Settings->General Frequency Domain.... Select the  radio button as shown in the rightmost
figure below. 

  

If you see the bottom line of both figures above, you see that the frequency separation changes from 2.93 Hz to 0.37
Hz. Note that the zero-padding does not add any extra information, but it has the same effect as an interpolation in the
frequency domain. But this interpolation may be very useful. In the figure below the red curve shows the sinusoidal
signal at 1 kHz without zero-padding and the blue curve is when using zero-padding. We see that the blue curve
detects the frequency to be 1 kHz, while the red curve does not have enough points to detect this accurately.

Power Spectrum Magnitude - 0.3 seconds recorded 110 dB @1 kHz
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13.8 How to plot harmonic distortion for a sinusoidal signal?

Go to Setup->Load… and load the setup named General_Harmonic Distortion (1 kHz sine) and follow the
instructions in the wizard.

Start a measurement from Measurement->Start or if you want to analyze a file that contains a sinusoidal signal use
File->Open.
In the setup, four plots are displayed as shown in the figure below. 

Important: The THD + N plot displays the total harmonic distortion for an external signal as default. If you are using
your sound card output to playback the sinusoid signal, then you should change this to internal signal to increase the
accuracy. Go to Plot->Plot Type Settings->Parameter… and select THD (internal sinusoid) as shown below. But
do not use this setting if you do not generate the signal from the sound card.

You may also select THD without the noise as shown in the figure below

If you wish to compare multiple measurements in the plot, make sure that Plot->Overlay is checked as shown in the
figure below.



The Power Spectrum plot displays the harmonic distortion components. By moving the mouse cursor above the
harmonic you wish to find the value of, the value is displayed in the text box as shown below.

The Normalized Time Data plot displays the normalized time data signal from 10 to 13 milliseconds. In the figure we
clearly see that the signal is clipping.

The ETF (Energy Time Frequency) plot displays the frequency as horizontal axis, time as vertical axis and level as
color. From this plot you may check that the distortion components are constant as function of time (which they should
be).

13.8.1 Measurement Settings

As default, Measurement->Settings… is set to playback a sinusoidal signal of 1000.49 Hz as shown in the figure
below.

At the bottom of the dialog box shown above, we see that the measurement duration is set to 1.365 seconds as shown
in the figure below.
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13.9 How to measure loudspeaker frequency response and use SPL as vertical axis?

To do this the input has to be calibrated. Click the  button on the standard toolbar to do this.
In addition, we have to set up the plotting so that it plots in scope mode. 
A frequency response of a system is found by measuring the input and the output of the system. The system gain will
NOT change if we increase the signal we feed the system with (e.g. if we have a linear amplifier with gain 30 dB, the
gain will still be 30 dB if we increase level of the input signal to the amplifier input).

But if we want to find the SPL of a loudspeaker, the SPL is obviously dependent on the gain of the signal we input to
the loudspeaker. Therefore we have to plot in scope mode, since scope mode only considers the input signal to the
sound card.

To do this, go to Plot->Plot Type Settings-> Frequency Domain Settings... and make sure
 is checked as shown below.

Then set the scope mode, the options are shown below

What you choose depends if the signal you are analyzing is stationary or transient. It is recommended that you set it to
Automatic, WinMLS then determines what it is based on the measurement parameters (if a .wmb-file is opened, the
measurement parameters are found from the file header).

13.10How to set the output signal amplitude to a calibrated value, e.g. 2.83 VoltsRMS?

Normally the sensitivity measurements are done when the voltage over the loudspeaker is 2.83 VoltsRMS.

The output signal can be set to a certain amplitude using several methods, but the easiest way is perhaps to use a
voltage meter to measure the voltage over the loudspeaker terminals.

Do this the following way:

Go to Measurement->Settings... and click the Levels tag to display the settings shown below.

If you want to calibrate, click the  button and follow the procedure for output calibration. See the section for
more information. When the calibration is finished, the dialog box will look as shown below.



In the upper list box select Signal Generator Only. Make sure the frequency is near 1000 Hz as shown in the figure
below.

You should click the Levels tab as shown in the figure above to check that the level for the sinusoid is the same as for
the signal you are using for the measurements (in the example figure below we use sine sweep as excitation signal)

Now start the generator from Measurement->Start.
Connect a voltage meter over the loudspeaker terminals and adjust the output level so it is 2.83 Vrms. You can use the
Levels tag setting shown in the figure above to set the output level. but then you need to set the same level for the
output signal that you are using for the measurement (sine sweep).
To do this, switch back to Impulse/Frequency Response and set the same level as you set in Signal Generator Only.

If your WinMLS can control the mixer level of your sound card, you may also control the level from the WinMLS
mixer as shown in the figure below.
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13.11How to measure the anechoic response of a loudspeaker without doing the
measurement in an anechoic chamber?

You can time-window the impulse response to remove unwanted reflections from surfaces. But since this time-
windowing will reduce the frequency resolution, you should try to position the loudspeaker as far away as possible
from reflecting surfaces and/or to damp the reflecting surfaces as much as possible. 

Then set the time window so the first reflection is not included. This will work for higher frequencies, but the
frequency resolution will normally not be sufficient for low frequencies. 

To get the best results, it is recommended to use a short time window for high frequencies and a longer time window
for low frequencies. See the High-frequency window (short) section for information on how to do this.

13.12How to measure loudspeaker directivity?

In this application we want to measure the loudspeaker directivity as function of frequency.

To do this we start by loading the setup named Loudspeaker_Near Field. We want the results in third-octave bands,
to do this, go to Plot->Plot Type Settings->Frequency Response/Spectrum… and select the setting shown below.

We have measured the loudspeaker in 5 degrees steps in one plane from 0 to 180 degrees. This gives 18 measurements
as shown in the figure below. 
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To see the directivity more clear as function of position, we want to display this in a 3D plot as shown in the figure
below. From this figure we see that the frequency response has a dip at 500 Hz and a peak at about 1000 Hz for
Meas_13 to Meas_19.

The settings for obtaining this plot will not be explained. The plot range is set to 50-6000 Hz in the Plot toolbar as
shown below.

Go to Plot->Layout->Curve Styles and Colors… to change the line style to Area as shown below. 
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You may have to go to Plot->Refresh… and select the setting below to refresh the curves with this setting.

Now go to Plot->Layout->Edit… and select the 3D tag and other settings shown in the dialog box below.

13.13How to measure levels, such as in octaves and dBA?

Go to Setup->Load... and load a setup in the Level (Noise) section as shown below.

13.13.1How to use WinMLS as a level meter for measuring SPL values in octave, 1/3 octave, dBA?

To perform the measurement, go to Setup->Load… and select the setup named Level (noise)_Leq (dBA, dBC, etc.,
third oct. bands). As default, the one-third octave bands and dBA is selected. Follow the wizard in this setup for more
information.



13.13.2How to find the level of a measured impulse response (for example in dBA)?

The input chain must be calibrated. Then to be able to get the correct level for an impulse response we must select the
transient signal scope mode.
To do this is explained in the section How to measure loudspeaker frequency response and use SPL as vertical
axis?

13.13.2.1 How to find the background noise level of my impulse response measurement?

Set the time window to the last part of the impulse response, using for example the last 0.2 seconds of the impulse
response which should give a good result. We assume that the impulse response has died out and we have only
stationary noise in this last part of the impulse response. Now set the scope mode to Stationary signal as shown below
since the noise is stationary.

13.13.3How to display the level in octave bands?

Octave or one-third octave spectrum is selected from the Frequency Response – Spectrum plot type. Open the
settings dialog from Plot->Plot Type Settings->Frequency Response/Spectrum… and select the setting as shown
below.

13.13.4How to display the level in dBA?

To display the dBA level, the Parameter plot type must be selected. This can be done from the Plots toolbar normally
at the bottom in most setups.

Now click the button shown above to open the settings dialog box. From this dialog box, select dBA as shown below.

13.13.5How to display several measurements (e.g., for comparison and for saving the data)?

If Plot->Overlay is checked, a new measurement curve will be added on top of the existing curves. This is very nice
for comparison, especially when plotting dBA values. The plotted data can be saved as text-file using File->Export
Data....

13.14How to calculate Loudness/Sone (ISO 532B / DIN 45631)?

In Plot->PlotType/Routing/Test..., select Frequency Response/Spectrum as plot type as shown in the figure below.
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Click the  button to exit the dialog box.
Now go to Plot->Plot Type Settings->Active Plot... to display the dialog shown below.

First select the horizontal axis as shown below

Then make sure that you select specific loudness as shown above. You have two choices of loudness. If you are
measuring under free field conditions, select Spec. Loudness (free). 
For example according to EPLF NORM 021029-1 the measurements should be done under free field conditions. A
free field condition is defined as:

• A laboratory room which provides a free field over a reflecting plane as in a semi-anechoic room.
• A room in which the contribution of the reverberant field to the sound pressures in the measurement positions

are small compared with those of the direct field of the source.

In a diffuse field, the reverberant field contributes to the direct field of the source, which it will do in an ordinary
room. If this is the case, select Spec. Loudness (diffuse).

13.15How to measure speech transmission indices, such as STI and RASTI?

Speech Intelligibility can be measured using WinMLS. The easiest way is to go to Setup->Load… and load one of the
setups under the Speech subsection. Follow the instructions in the setup wizard step by step. This section contains
additional information. An example of speech parameter plots is shown below.



       

STI or RASTI can be measured using WinMLS. The software has been tested against MLSSA’s STI/RASTI
calculation, the B&K Speech Transmission Meter and other systems. The agreement was excellent.

The sound card must be able to perform a MLS measurement in order to measure speech parameters with the
recommended method. You may want to check this by going through the procedure described in the Measurement 1:
Measuring the sound card response section.

1. Displaying the results
The results may be plotted as bars as shown in the figure below. In this figure the values for several
measurements are plotted and the legend moved from its default position in the right corner. 
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Speech Transmission Index (STI)
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 These results can also be saved to a text-file from File->Export Data.... The data is organized in two
columns, the first contains the measurement names, the second the RASTI or STI values.

If you want to display only one RASTI/STI value in the plot, make sure Plot->Overlay  is not checked
when plotting a new curve.

The following sections discuss how to measure under different conditions.

13.15.1The background noise is “normal”

The easiest case for measuring STI is if the background noise is “normal” when you are measuring. This works if the
background noise during the measurement is stable and at the right level. This may not be the case e.g. if you are
measuring a swimming pool with no people present and the ventilation system turned off. Then the background noise
is clearly too low and you may have to compensate for this. WinMLS lets you do this.

Then you can measure using the default setup named ‘Speech_All Parameters’ found from Setup->Load….

13.15.2The background noise is “too high”

If you have background noise present that is higher than a ‘normal’ background noise situation, you may still measure
STI. To do this you can increase the duration of the measurement. 
To do this, go to Measurement->Settings… and in the total duration setting, type in 30 seconds as shown below.

If you have a lot of extra background noise we also recommend that you select Single Sweep instead of MLS and
make sure that the Emphasis is set to None. To do this, go to Measurement->Settings… and make sure it is set as
shown below.



13.15.3The background noise is “normal” but is varying a lot

The easiest method is simply to do many measurements and average the result. To do the average, first make sure that

Plot->Overlay… is checked. If you click in the STI plot and then click the  button, the mean value for the
displayed measurements will be displayed in the green line as shown in the figure below. The STD is also displayed as
the two dash-dotted lines.

A solution here may also be to increase the duration of the measurement, e.g. to 30 seconds. This will average out the
variations of the background noise.

13.15.4The background noise is “too low”

You may add the background noise and speech level as post-processing. This is useful if the background noise during
the measurement too low (e.g. you measure at night-time).

You can also investigate the effect of different levels of background noise or speech level.
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To set this, go to Calculate->Speech->Settings... and select 'Background noise and speech levels given in table below'
as shown below. 

13.15.5I am measuring the speech parameters of an acoustical system (a room) and not a sound
system

In this case, distortion should be removed (since the distortion is not from the acoustical system but from the sound
system that is used for the measurement).
The distortion can be removed using sine sweep as excitation signal and cutting the last part of the impulse response,
but this will also remove some of the noise.
Therefore the noise should be measured separately and be corrected for in the table as discussed in the section above.

13.16How to measure loudspeaker impedance?

Impedance can be measured using WinMLS. The easiest way is to go to Setup->Load… and load one of the
impedance setups under the Impedance subsection. Then follow the instructions in the wizard carefully.

13.17How to find the level difference of two measurements as function of frequency?

Perform or open the two measurements you want. Select Frequency Response - Spectrum as plot type and set one of
the measurements as active measurement. This can be done in the Measurement Selection Toolbar or in
Measurement->Information….

The other measurement must then be set as the reference measurement. Do this from the lower part of Plot->Plot
Type Settings->General Frequency Domain... dialog box. The “Reference measurement” part of the dialog box is
shown below.

Make sure  is checked. The in the list box shown above,
select the desired “divisor” measurement (Calib2 is selected in the example above). If you want to use an individual
window setting on the reference measurements, make sure  is checked.

Then click the  button to display the time window settings for the reference measurement. 



When the dialog box is exited with  you should now see the level difference between the measurements as
function of frequency.
If you want to display the transfer function in octaves or 1/3-octaves, see the How to display the level in octave
bands? section.

13.17.1When dividing the same measurement, why is the result not a flat line?

As a test to check that the division is working, you can use the same measurement as active and reference. The result
should be a straight line at 0 dB for the magnitude frequency response.
But if  is checked, the time window can be different for the reference
measurement. This will cause some deviation from the straight line at 0 dB.

13.18How to find the level difference between stereo speakers?

Do as described in the section above using a measurement of left speaker as the active measurement and a
measurement of the right speaker as the reference measurement.

13.19How to measure at very low frequencies?

Using the sine sweep it is possible to get very good results for low frequencies. In the figure below we have measured
the loop-back output to input of the USB Duo. It goes down to –85 dB at 0.02 Hz!

To get the result above we used the settings below
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We tried to go as low as 50 Hz in the Range [Hz] parameter, but were not successful. We did these measurements with
sampling frequency 44100 Hz just to show that it is possible to get very good results for low frequencies using high
sampling rates (some sound cards do not have low sampling rates available). But for low frequency measurements we
recommend that you use as low a sampling frequency as possible.

13.20Violin Acoustics

13.20.1 Is it possible to process the impulse excitation using the constant Q transform (CAS Journal, Nov.93,
p.1-4)? 

The constant Q-transform is similar to one-fourth octave band smoothing of the frequency response. Please see the
Smoothing section in the Plot->Plot Type Settings->Frequency Response /Spectrum… dialog box in on how to use
this. 
The other issues described in the above CAS Journal article are only valid for periodic signals, and not for an impulse
response. Ideally the Q-transform is performed using time-windows of increasing size for low frequencies. This
feature is not directly supported in WinMLS, but tests using time-windows of different sizes did not show significant
improvement compared to using this smoothing method.

14File menu
Several file operations are accessed via the File menu as shown below.



14.1 New

Opens a new instance of WinMLS. If you instead want to open a new window to plot a new curve, do this from
Window->New Window....

14.2 Open...

Opens measurement file(s) containing raw time data or text files that are plotted directly. For the time data
measurement files, WinMLS optionally plots the data or computes parameters (see Measurement->Tasks... for
details). The data are stored in memory and can be selected from the Measurement Selection toolbar. For the text-file
(s), the data must be organized as columns. This is the format used when exporting data from WinMLS.

A browser is displayed as shown below. 

To open multiple files, mark the files you wish to open. To mark several measurements, hold the <Ctrl> key while
clicking on the files. <Shift> can also be used.
Note: To open the files in the order you specified, you must start to mark the files from the bottom and mark them
upwards. It does not work if you mark the files from the top and go downwards.

14.2.1 File types

File types to be displayed in the browser are:
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The file types are described below

14.2.1.1 Supported Files (*.wmb, *.wmt, *.wav, *.tim, *.txt. *.sdf)

Lists each measurement file type is described below.

14.2.1.2 WinMLS Binary Files (*.wmb)

This is the recommended file type. It is a binary file in floating point resolution and it includes a header. The header
contains information about the sound card and other measurement settings. The header has been extended in new
major updates of WinMLS, but the old file format may still be read. The data format is time domain raw data.

14.2.1.3 Measurement Text Files (*.wmt)

File type in text format. It has a header containing some measurement settings. 
Note: The scaling may not be correct when using this format. The data format is time domain raw data.

14.2.1.4 Mono 16-bit WAV Files (*.wav)

Wave-file, the common binary format for PC audio. If the .wav-file has been written from WinMLS it contains the
same header as the *.wmb-format. The scaling should be correct when the .wav-file is saved in WinMLS and
reopened in WinMLS. However, since the format is 16-bits, the data are normalized to decrease loss in quality. Be
aware of this if you plan to compare measurements in other programs than WinMLS. 
Saving multi-channel .wav-file as a single file will restore the correct level in WinMLS only if calibration is turned
off, since the calibration data is only present for channel 1. For details see Saving Defaults....
The data format is time domain raw data.

14.2.1.5 Measurement MLSSA files (*.tim)

File type used by the software MLSSA. The scaling may not be correct when using this format. The data format is
time domain raw data.

14.2.1.6 Text Files (*.txt)

When opening a text file, you are first asked if you want to open the file either as measurement time domain raw data
or as data to be plotted without any further post-processing. The data must be grouped in columns and separated using
TAB. If the data file contains only one column of data, WinMLS will plot these data using 0,1,2,3.... as x-axis. If the
data file contains several columns of data will use the first column as x-axis data and plots the remaining as curves. All
columns must be the same size.

14.2.1.7 Norsonic Files (*.sdf)

Reads single-channel and multi-channel files in the Norsonic file format. This is not supported in all versions of
WinMLS.

14.2.2 Perform deconvolution

If the  check box is checked and if measurement raw time data is opened, the data in the file(s)
that is opened is deconvolved. You can use this if you have measured a sine sweep and want to compute the impulse
response.
Note: The parameters used for the deconvolution is taken from Measurement->Settings.... If these parameters are not
exactly the same as was used when the sweep was recorded, the result will be wrong.



14.2.3 Measurement Tasks…

Clicking this button opens the Measurement Tasks dialog. From this dialog you can determine what tasks are to be
done when a measurement is opened. See the Measurement->Tasks… section for details.

14.3 Close 

Closes the active window if there is more than one window is displayed. If only one window is displayed, it cannot be
closed. You can change the content of the window from Window->Load Post-processing....

14.4 Save As...

Saves time domain data for the measurement that is active in the plot window. The possible file formats are described
in the File->Open... section.

If you have performed a 2-channel measurement, the 2-channel browser will be displayed. If you have performed a >2
channel measurement, the multi-channel browser is displayed. These three browsers are described below. 
Note: It is possible to increase the size of the browsers by dragging the lower left corner.

14.4.1 Browser for saving 1-channel measurement

If the active measurement is a 1-channel measurement or if it has been opened from a file, the 1-channel browser
shown below is displayed.

The maximum size of the title is 80 characters and the maximum size of the comment is 60 characters. The defaults

and other save settings can be altered by clicking the  button (which is the same as Measurement-
>Saving Defaults…).
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14.4.2 Browser for saving 2-channel Measurement

If you have performed a 2-channel measurement, the 2-channel browser is displayed. Note that a 2-channel
measurement is saved as two separate files. If you want to modify the filename, remember to do this for both channels.

The maximum size of the title is 80 characters and the maximum size of each comment is 60 characters. The defaults

and other settings for saving are set by clicking the button  (which is the same as  Measurement->Saving
Defaults…).

14.4.3 Browser for saving multi-channel (>2 channels) Measurement

Note that a multi-channel measurement with N channels is saved as N separate files. The exception is if saving as .
wav-file, it can optionally be saved as a single file, see  Measurement->Saving Defaults….



The usage should be quite intuitive. A multi-channel tag is added to the filename indicating what channel it is.
Optionally a counter can be added which is useful if you are performing a series of measurements.
The maximum size of the title is 80 characters and the maximum size of each comment is 60 characters.

The defaults are set by clicking the button  button (Measurement->Saving Defaults…).

14.5 Save All Unsaved...

Loops through and asks the user to save all unsaved measurements that are present in the WinMLS memory. For a list
of measurements in memory, see Measurement->Information.... The suported file formats are described in the    File-  
>Open... section.

14.6 Advanced Save

Displays sub-menus for saving the active measurement, as shown below.

Each item is explained in the following sections.

14.6.1 Measurement as System Correction File

Saves the active measurement as measurement system correction file and sets it as active in the measurement system
correction part of Measurement->Settings... as shown below. 

The name of the sound card is suggested, but you can type any name as shown below
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If the measurement is a multi-channel measurement, each channel will be corrected.

14.6.2 With Filename ‘_ActiveMeas_’

Saves the active measurement and gives it the filename '_ActiveMeas_'. The folder and extension is taken from
Measurement-> Saving Defaults.... Note that if a measurement with the same name already exists, it will be
overwritten.
For multi-channel measurements, channel 2 is given the name '_ActiveMeas_2', channel 3 the name '_ActiveMeas_3',
and so on. This is the fastest way of saving a measurement and is well suited if another application is used to post-
process measurements while measuring with WinMLS.

14.6.3 Curve(s) as Tolerance Reference(s)

This is intended for production control. It will save the active curves in all plots as a tolerance reference. 

14.7 Export Data...

Exports plotted curve(s) as data columns in a text-file.

All curves belonging to a measurement in the active plot are saved as columns. If  one-line header is
included that contains the title of each column. The axis is named ”x-axis”, the data column(s) are given the name of
the series title (maximum 30 characters). The character Tab is used as column separator in the header as well as for the
data.



If  is checked, each curve will have each own vertical axis. If WinMLS is
displaying multiple plots and if  is checked, the data from all plots will be exported.

If  is checked, the curve data from all the plots in WinMLS are merged. This is useful e.g. if
you are plotting the magnitude frequency response in one plot and the phase response in another plot and want to
export a file that consists of the frequency as the first column, the magnitude as the second row and the phase as the
third row.

If  is not checked and the x-axis is not the same for all curves in the plot, an x-axis is
constructed that contains all the x-axis values for all the curves. This is the case e.g. if the sampling frequency is not
the same, or if a value is missing e.g. when plotting reverberation time and the effective-decay-range is not good
enough to compute a value. If a y-value does not exist at a certain x-value, no text is written to indicate that it is not a
number.
If  is checked, then you should check if the axis is correct if

 is not checked.

For a more advanced method of exporting, see Edit->Advanced Export....

These exporting procedures are slow if data with more than 30000 points are to be exported. Therefore, if you want to
export the frequency response, you should turn on smoothing to reduce the size of the data (make sure ‘interpolate
back to original data points’ is turned off). If you want to save the raw time data we recommend that you use the File-
>Save As... procedure and use the .wmt format. This will save the raw time data in a text file with a short header.

14.8 Export plot...

Saves the active plot in one of the following formats:

For an advanced method of exporting, see  Edit->Advanced Export....

14.9 Print

Prints the active plot to the default printer

14.10Print Preview...

Print preview of the active plot.
As we see in the figure below, this dialog box can be used to determine printer, set orientation, margins and amount of
details in the plot.
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14.11Print All...

If you have more than one plot displayed, use this to print all displayed plots. The print should look similar to what
you see on the screen.

14.12Print Preview All...

If you have more than one plot displayed, use this to print preview all displayed plots. The print preview should look
similar to what you see on the screen.



Change the detail level value shown above if you want to modify the detail level of the plot.

14.13White Background

If this is checked, all plots are given a white background when they are copied, printed or saved as a picture. This will
save ink when printing without changing the background color in the plot.

14.14Convert Measurement(s)... 

Converts a measurement file of one of the supported formats to one of the other supported formats.
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The dialog box above shows an example on how to convert three files of the format .wmb to .wav. The .wav-files are
put in the Target path.

Note: The data in the .wav-files will be normalized.

When clicking the  button, the files will be converted and a progress dialog will appear as shown below.
This can be hidden behind the Convert Measurement(s) dialog box, but if there are errors in the conversion it will be
displayed on top. It will also be displayed if you exit the Convert Measurement(s) dialog box

Please note that if you have a *.tim or *.wav file, you can open the file directly in WinMLS and do not have to do this
conversion first.

When converting from *.wmb to *.tim, the MLSSA setup file ‘MLSSAsetupFile.set’ is used to determine the
parameters that cannot be determined from the *.wmb file. The file ‘MLSSAsetupFile.set’ is found in the WinMLS
folder. Edit the contents of this file if you wish to use other parameters.

If you have a *.wmb file and convert it to *.tim and then convert it back to *.wmb, some measurement information
will be lost since the headers of these file formats will not contain the same settings. 

14.15Exit

Closes all windows and quits WinMLS. 

Measurement and post-processing setups are saved to temporary files so the settings are optionally the same the next
time WinMLS is opened. For details, see Setups->Options….

15Edit menu
From this menu you can copy data to clipboard.

15.1 Copy plot

Copies the active plot to the clipboard so that it may be pasted to other software, such as MS Word. The graphics
format is Windows metafile. If you need a different format, you may try Edit->Advanced Export....



15.2 Copy Data

Copies the data in the active plot to the clipboard so that it may easily be pasted to other software, such as MS Excel.
The format is the same as when saving the plot data to file, for details see File->Export Data....

15.3 Copy Data Options

Displays the dialog shown below.

All curves belonging to a measurement in the active plot are exported as columns. If  one-line header
is included that contains the title of each column. The axis is named ”x-axis”, the data column(s) are given the name of
the series title (maximum 30 characters). The character Tab is used as column separator in the header as well as for the
data.

If  is checked, each curve will have each own vertical axis. If WinMLS is
displaying multiple plots and if  is checked, the data from all plots will be exported.

If  is checked, the curve data from all the plots in WinMLS are merged. This is useful e.g. if
you are plotting the magnitude frequency response in one plot and the phase response in another plot and want to
export a file that consists of the frequency as the first column, the magnitude as the second row and the phase as the
third row.

If the x-axis is not the same for all curves in the plot, an x-axis is constructed that contains all the x-axis values for all
the curves. This is the case e.g. if the sampling frequency is not the same, or if a value is missing e.g. when plotting
reverberation time and the effective-decay-range is not good enough to compute a value. If a y-value does not exist at a
certain x-value, no text is written to indicate that it is not a number.

If  is checked, this dialog will be displayed before the data is sent to clipboard
on Edit->Copy Data….

Click the  button to copy the data to the clipboard.

15.4 White background (2)

If this is checked, all plots are given a white background when they are copied, printed or saved as a picture. This will
save ink when printing without changing the background color in the plot.
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15.5 Advanced Export...

The advanced method for exporting is shown below, where the Data tab is selected.

Below we have selected the Picture tab.

From the example in the figure above, we see that it is e.g. possible to set the quality and size when saving as .jpg-file.

16Toolbars menu
From this menu you can select which resources you want to be displayed on your screen. The visible toolbars are
check-marked as shown in the figure below. 



Note: The toolbars can be moved around on the screen. Their positions and on/off status are saved in the setup file. 

16.1 Levels (and Mixer)

Displays a dialog for setting the soundcards output and input level(s).

If you do not want to display this dialog automatically before each measurement, it can be turned off in
Measurement->Tasks... by making sure  is not checked.

The content of the dialog to be displayed depends on the current settings. If WinMLS is set to control the Windows
mixer, the mixer will look like similar to the figure below. 
Note: The rightmost Sync. Out and Sync. Input section is only displayed if a synchronization signal is used to find
correct delay.

   
 
The horizontal waitbar at the bottom of the dialog box 

 informs the user about the measurement progress.
The level indicator lamp shown in the figure below
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becomes red if there has been digital clipping during the measurement (e.g. the input level is too high for the sound
card to handle). If this is the case, the measurement can be invalid and it should be repeated with a decreased input
and/or output level.

The sliders are used to set the volume. If the mixer is not calibrated, Uncal. will be written above the volume number,
as shown below.

The value given in the figure above gives the uncalibrated volume (minimum is 0 and maximum is 100). Small
changes in the volume e.g. from 50.0 to 50.5 may not make any difference. How much it has to be changed to actually
lead to a change in the output level is sound card dependent. The mixer calibration procedure will determine the level
in dB. In the figure below is taken from Measurement->Calibration..., where Input slider unit is set to Defined gain
steps [dB].

In this case, the bottom part of the dialog box will look as shown below. As we see, the numbers are changed from
relative percentage values to absolute decibel [dB] values.

It is now possible to see how much the volume is changed in dB, and this information is automatically applied to
determine the absolute gain of the system to be measured. This means that you may change the mixer levels, and still
maintain your calibration (the recorded signal will have the same amplitude independent on the mixer settings).

16.1.1 The mixer levels can be “frozen”

If you want to measure absolute quantities, e.g. SPL or Voltage, the level calibration must be checked in
Measurement->Calibration..., as shown below



If WinMLS is set to control the windows mixer, and the gain steps are not set to be defined, a warning message is
given if you try to change the volume as shown below. 

The warning is given because changing the mixer levels will make the level calibration invalid. In order to change the
mixer level, go to Measurement->Calibration.... and either use defined gain steps, or turn off the level calibration
check boxes. 

16.1.2 WinMLS does not control the Windows mixer

If the sound card does not support or you do not with to control the Windows mixer, WinMLS is not able to set the
volumes and the dialog shown below will be displayed only showing the input level(s).

16.2 Measurement Selection Toolbar

The Measurement Selection Toolbar is used for selecting what measurement(s) are to be post-processed.

 

              

16.2.1  Clear active measurements from memory 

Same as Measurement->Clear memory->Active Measurement..., see this section for details.

16.2.2  Active measurement 

Select what measurement to be post-processed (plotted) from this list box. All performed and opened measurements
are available from the list. 
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16.2.3  Update both plots with the same measurement 

if  is toggled and if the active window contains two plots as shown below, 

the combo box to the left of the button  will determine the active measurement for both

plots. If  is not toggled, the combo box to the right of the button  will determine the
active measurement in the lower plot.

16.2.4  Measurement in lower plot

This combo box displays the active measurement in the lower plot if  is toggled. This part will not be displayed if
the window contains only one plot.

16.3 Measurement Panel Toolbar

The Measurement Panel is useful if you need to quickly save data. In the figure below, the text in the buttons are set
to a 5.1 surround sound setup just to show an example.

The 10 leftmost buttons can be assigned to a measurement each. In the figure above, button 7, 8, 9 and 10 are not yet
assigned. We see this because an assigned button has a color below it. 
When an unassigned button is clicked, the active measurement is assigned to this button and plotted with the color of
the button. The button will then display the color below it and be turned on. If you then turn this button off, the curve
will be erased from the plot. But the measurement exists so you can later turn the button on, and the curve will be
plotted. 

You may use keyboard shortcut keys instead of clicking the buttons with the mouse.
The shortcut key for clicking a button is <Ctrl> + <Button Number>.
The shortcut key for assigning a button is <Ctrl> + <Shift> + <Button Number>. (With this shortcut key you can
assign a new measurement to a button that is already assigned without deleting it).

The shortcut key for removing measurements from buttons  is <Ctrl> + <Shift> + D.



The shortcut key for opening the settings  is <Ctrl> + <Shift> + S.

Note: The measurement raw time domain data is saved. Therefore, if the plot type settings are changed, this may
change the curve (e.g. if smoothing is turned on). An alternative way of not displaying the curve of a certain button
without recalculating the curve, is to set it invisible from the legend list check boxes in the plot. In the figure below,
the Left button is set invisible.

16.3.1 Reset Buttons

Clicking the  button will ask if you want to remove measurement(s) assigned to the measurement panel toolbar.
You have three alternatives as shown below.

Note: This operation does not delete the measurements from the hard disk. But if a reset button is pressed, it will be
saved and the measurement will be overwritten with the new active measurement without asking the user. To keep the
old measurement data, use the option below and e.g. change the folder where the data is saved.

16.3.2 Measurement Panel Options

The  button displays the dialog shown below

Ten (10) buttons on the toolbar can be named by the user as shown above, the two other buttons to the right are for
deleting and settings.
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To set the curve styles and colors of the measurement panel curves, click the 
toolbar. This will open the Plot->Layout->Curve Styles and Colors… dialog.
Note: From this dialog, you will se that the color of Button 1 is the same as Curve 7, the color of Button 2 is the same
as Curve 8, etc…

The measurements will be saved in the folder shown below. 

The user may specify his own folder. This way the user can save in a new subfolder for each new measurement
session. This is useful e.g. if measuring several surround systems and wanting to save the data for each.

The data are saved with the names given in the button captions shown below.

16.4 List of Curves Toolbar

This toolbar gives immediate access to the curves in the active plot.

The operations described below can be done from this toolbar. 

Note: If two plots are displayed in the window, the operations will only affect the active plot.

Note: The curve at the end of the list is displayed as the top curve in the plot. In the figure above, CurveMeas. 3 will
be displayed on top, while CurveMeas. 1 will be displayed below all the other curves.

16.4.1 Erasing curve(s) from the plot

A curve may be erased by first marking it as shown below

Then push the Delete key. Note that if several curves are marked, they may all be deleted. Hold the Shift key down to
select several curves.



16.4.2 Dragging curves to change the curve order

If a curve in the toolbar is marked (CurveMeas. 2 in the example above), the curve may be dragged up or down using
the mouse.

16.4.3  Change the curve type

Double-click on this icon to display a dialog where a new curve type may be selected.

Note: This change of curve type will not be remembered if the curve is erased from the plot. To set a new permanent
curve type, see  Plot->Layout->Curve Styles and Colors….

16.4.4  Display the curve

If  is checked, the curve will be visible in the plot. If it is not checked, it will not be visible. However it is still
available in the plot legend list and can be set as visible later.

Note: Only the active plot will be updated. If WinMLS has more than one plot displayed and you want all plots to be
updated, you must instead click on a curve in the legend list in the plot (turn on the legend list from Plot->Layout-
>Legend).

16.4.5  Change the curve color

The color of a curve may be changed by double-clicking  (found to the left of Curve Meas. 1 in the figure of the
toolbar above). A dialog will be displayed from where new colors may be selected.
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16.5 Plot Toolbar

This toolbar should be very useful. It contains settings for 
• scaling in horizontal and vertical direction
• selecting one or two plots to be displayed in the window
• which plot type to be active
• accessing the settings of the active plot type. 

In the figure below we see a plot with this toolbar on top.

Note: If two plots are plotted in the current window, the settings for the active plot will be displayed in the toolbar. If
you have two plots displayed, it is a good exercise to click in the other plot to set it active and see how the toolbar
settings will change.

16.5.1  Setting the lower x-axis limit

The controls shown above are used to set the lower x-axis limit. 

If auto-scale lower x-limit  is toggled, the minimum x-value of any of the curves in the plot will be used as

minimum value. The edit window  shows the current value, 10 Hz in this example. It is possible to type a new
value, but remember to validate it by pressing Enter.

The controls  are used for moving the lower limit in either left or right direction.

16.5.2  Setting the upper x-axis limit

The controls shown above are used to set the upper x-axis limit. 

If auto-scale upper x-limit  is toggled, the maximum x-value of any of the curves in the plot will be used as

maximum value. The edit window  shows the current value, 24000 Hz in this example, which is the maximum

in x-direction since  is toggled. It is possible to type a new value, but remember to validate it by pressing Enter.

The controls  are used for moving the upper limit in either left or right direction.

16.5.3  Setting the lower y-axis limit

The controls shown above are used to set the lower y-axis limit. 

If auto-scale lower y-limit  is toggled, the minimum y-value of any of the curves in the plot will be used as

minimum value. The edit window  shows the current value. It is possible to type a new value, but remember
to validate it by pressing Enter.



The controls  are used for moving the lower limit either up or down.

16.5.4  Setting the upper y-axis limit

The controls shown above are used to set the upper y-axis limit. 

If auto-scale upper y-limit  is toggled, the maximum x-value of any of the curves in the plot will be used as

maximum value. The edit window  shows the current value. It is possible to type a new value, but remember
to validate it by pressing Enter.

The controls  are used for moving the upper limit either up or down.

16.5.5  Auto-scale the plot in all directions

If  is toggled, the plot is auto-scaled in both x- and y-directions. As a result, all the four buttons , ,  and

 will be toggled. So clicking  has the same effect as clicking all these four buttons.

16.5.6  Display one or two plots in the window

If  is not toggled, one plot is displayed in the active window as shown in the left part of the figure below. If  is
toggled, two plots are displayed in the active window as shown in the right part of the figure below. 

  

16.5.7  Plot Type in Active Plot

This list box contains the plot types (e.g. time data, phase response, frequency response, etc...) shown in the figure
below.
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16.5.8  Settings for the Active Plot

Clicking on this button will display a dialog box containing the settings for the active plot. This button can be very
useful. If you do not remember where to find a plot setting, check this button first.

16.6 Active Plot Type Toolbar

The content of this toolbar depends on what plot type is selected. It displays the most common settings for the selected
plot type. 

16.6.1 Toolbar for time domain plot types

If the selected plot type is time data, integrated time data (step response), energy-time-curve or Schroeder curve, the
toolbar will look as shown below

Change y-axis. Same as  found in the plot type settings (press the F5 key to

open the dialog). One click on the  button sets the vertical axis to one of the settings shown below

Change x-axis. Same as  found in the plot type settings (press the F5 key). 

Increase filter frequency. If filtering is turned off, clicking this button will turn on filtering and set the lowest

filter frequency. Turn off filtering by clicking several times. Click the  button to set the filter type and step
used for each click (e.g octave or 1/3 octave).

Decrease filter frequency. If filtering is turned off, clicking this button will turn on filtering and set the highest

filter frequency. Turn off filtering by clicking several times. Click the  button to set the filter type and step
used for each click (e.g  octave or 1/3 octave).

Filter settings. For details see the Plot->Plot Type Settings->Time Data.... documentation.

Time window settings. For details see Plot->Plot Type Settings->Time Window….

16.6.2 Toolbar for frequency Response

Note that if two plots are displayed, normally the selections will affect only the active plot. An exception is the
selections involving the “global” Plot->Plot Type Settings->General Frequency Domain…. These settings will
affect all the frequency domain plot types.

Logarithmic or linear x-axis. Same as  found in the plot type settings. 



Invert curve. Same as  in Plot->Plot Type Settings->General Frequency
Domain…

Smooth curve. Same as  found in the plot type settings. Click the  button to
change the smooth settings.
Display general frequency domain settings. For details see Plot->Plot Type Settings->General Frequency
Domain….

Time window settings. Same as  in Active measurement group in Plot->Plot
Type Settings->General Frequency Domain….

Display guidelines on frequency response. Same as  found only in settings for Frequency
Response/Spectrum plot type

Microphone compensation. Same as  found in settings for the Frequency Response/Spectrum plot
type

Perform division using reference measurement. Same as  in
Plot->Plot Type Settings->General Frequency Domain….

Update reference measurement on new measurement. Same as  in Plot->Plot Type
Settings->General Frequency Domain….

Display time window settings for the reference measurement. Same as

 in Reference measurement group in Plot->Plot

Type Settings->General Frequency Domain…. Note that  is disabled if
 is not checked, because in this case the reference measurement

time window settings are the same as the active measurement time window settings and can be accessed using

the  button.

Waterfall slice scrolling downwards, used to set the active slice, for reading cursor values displayed at the
Status Bar. The active slice gets a green color. This button is enabled only if the waterfall layout mode in the
waterfall plot type settings is Separate lines waterfall as shown in the figure below.

Waterfall slice scrolling upwards, used to set the active slice, for reading cursor values displayed at the Status
Bar. The active slice gets a green color. This button is enabled only if the waterfall layout mode in the waterfall
plot type settings is Separate lines waterfall as shown in the figure above.

16.7 Time Window Toolbar

This toolbar will set the time window used for FFT-calculation for the frequency domain plot types. In the figure
below the toolbar is displayed together with the Time Data plot type. The time data window is displayed in yellow.
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16.7.1  Lower window limit

The controls shown above are used to set the lower window limit. 

The  button will use an algorithm to detect the start of the time data. Currently it only works for impulse
responses, and should be set to 0 for other signals. 

The edit window  shows the current value in the unit displayed in  (milliseconds) as will be explained
below. It is possible to type a new value, but remember to validate it by pressing Enter.

The controls  will move the window one sample in each direction and is thus to be used only if very small
changes are required.

16.7.2  Setting the upper window limit

The controls shown above are used to set the upper window limit. They work similar to those described in the section
above.

Clicking the  button will move the upper window limit to the end of the active measurement.

Note: If this control is disabled, the window is in “fixed size” mode. This is explained below.

16.7.3  Window length

This control shows the total window length in the unit displayed in  as will be explained below.
Note that if “fixed size” mode is selected for the time window, it is possible to type the length of the time window
directly, as shown below.

In this example the length of the time window is 500 ms.

The controls  will move the window one sample in each direction and is thus to be used only if very fine changes
are required.

16.7.4  Window x-axis unit

This control displays the unit of the horizontal axis. In the figure above it is set to ms, which means that the unit is
milliseconds. The unit is always the same as the x-axis unit for the Time Data plot type.

16.7.5  Time data window type

The available window types are shown below.

Note: When windowing transient signals such as impulse responses, a rectangular or half window should be applied.
A full window is usually used for stationary signals. To sum this up

• A full window should never be applied on a transient signal!
• A half window should never be applied on a stationary signal!



16.7.6  Display time window in time data plot type

If this is toggled, the selected time window will be displayed when plotting with the Time Data plot type.

16.8 Setups Toolbar

Using this toolbar is a convenient way of loading and saving the measurement and post-processing setups.

The purpose of this dialog bar is to make it easier for the user who wants to work with setup files. All the WinMLS
settings are saved in setup files. The most common settings concerning setups are found in this toolbar. All settings are
found in the Setup menu.

16.8.1  Select a new Measurement Setup

From this combo box a new measurement setup may be loaded. In addition to the measurement settings, post-
processing settings may also be loaded, since the measurement setup contains an optional link to the post-processing
setup. Thus this measurement setup combo box is able to load all WinMLS settings.

16.8.2  Store Measurement Setup

Clicking the measurement setup icon  is identical to Setup->Store.... 

If any of the measurement settings are changed, the icon turns red . This informs the user that the settings have
been changed since the last setup was loaded.

16.8.3  Select a new Post-processing Setup

From this combo box a new post-processing setup may be loaded.

16.8.4  Store Post-processing Setup

Clicking the post-processing setup icon  is the same as Window->Store Post-processing As....

If any of the post-processing settings are changed, the icon turns red . This informs the user that the settings have
been changed since the last setup was loaded.

16.9 Standard Toolbar

The standard toolbar contains frequently used buttons. The buttons in this toolbar depend on the WinMLS license
level. Here all buttons are documented.

The button and the position on the menu is given below.

File->New
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File->Open…

File->Save As…

Measurement->Information…

File->Print

File->Print Preview…
Edit->Copy Plot

Measurement->Start

Measurement->Cancel

Measurement->Test Levels

Toolbars->Levels (and Mixer)

Measurement->Settings...

If WinMLS is in 1-channel measurement mode, the input calibration dialog is opened. Otherwise the
Measurement->Calibration... dialog is opened.

Plot->Layout->Legend

Plot->Erase Curves...

Plot->Overlay

Plot->Solo Curve

Plot->Refresh...

Plot->Add Curve(s)...

This button does the same as the check box  found in the Plot->Overlay Settings... dialog.

The only difference is that if you use the  button to turn off the auto-statistics, the statistics curves are deleted from
the plot.

Calculate->Last Choice Again...

16.10Status Bar

The status bar is displayed at the bottom line in WinMLS. The left part is used to display the help text when the mouse

cursor is placed at a control. For example, if the mouse cursor is placed at the  button, the text
 will be displayed.

To the right of the help text, the cursor values (x,y) in the plot is displayed, as shown above. This is the position of the
mouse pointer relative to the curve of the active measurement. Using this you can read out the values of the active
measurement curve. Note that if you have plotted several measurements, only the cursor values for the active
measurement will be displayed.

If a frequency domain plot type is displayed, the wavelength, half- and quarter-wavelength values (in meters) will be
displayed to the right of the cursor values as shown in the figure below. 



To compute the distance in meters, the speed of sound is used. The speed of sound is set in Plot->Plot Type Settings-
>Time Data....

16.10.1Status bar during a measurement

When performing a measurement, the current average and its input level(s) are displayed in the status bar. In the figure
below the levels for average no. 8 for a 2 channel measurement is displayed.

16.11Layout Toolbar

The layout toolbar contains frequently used layout settings. 

Plot->Auto-Refresh.... Determines whether auto refresh is turned on or off.

Plot->Layout->Edit.... Display settings 

Plot->Layout->Cursor. Display cursor in plot.

Plot->Layout->Gridlines. Display gridlines in plot. This and other gridlines settings are found in Plot-
>Layout->Edit..., select the Axis tab, then select the Ticks tab, or the Minor tab for the minor gridlines.

 Plot->Layout->Title. Display title in plot. This and other title settings are found in Plot->Layout->Edit...,
select the Titles tab.

 Plot->Layout->Footer. Display footer in plot. This and other comment settings are found in Plot->Layout-
>Edit..., select the Titles tab. Then select SubFoot as shown in the figure below.

 Plot->Layout->Axis Labeling. Display labels in plot. This and other label settings are found in Plot->Layout-
>Edit..., select the Axis tab. Then select the Labels tab.

Plot->Layout->Legend. Add legend to active plot. This and other legend settings are found in Plot->Layout-
>Edit..., select the Legend tab.

Plot->Layout->3D. Show the plot in 3D. This and other 3D settings are found in Plot->Layout->Edit..., select
the 3D tab.

16.123D Toolbar

The 3D toolbar contains frequently used settings for 3D plots. It is intended for the waterfall plot type, but can also be
used with the other plot types. But 3D must first be turned on (e.g. from Plot->Layout->Edit...).
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Normal.

Rotate.

Move.

Zoom.

Depth.

Click this to remove the toolbar.

Plot->Layout->Edit....
Field for displaying rotation, offset and zooming.

17Setup menu
The setup menu enables the user to quickly load and store new settings.

17.1 Load...

Load new settings.



When WinMLS is exited, the setup filename is saved in registry and all the current settings are saved to a temporary
setup. The next time WinMLS is started, this setup file is opened and the settings restored.
To prevent the user from accidentally deleting or overwriting a setup file, you can write-protect the setup files (e.g
from the Explorer progam).

17.1.1 Select measurement setup to be loaded

Displays the selected measurement setup. Setups can be chosen from the list of the available setups as shown in the
figure below.

A setup can be deleted by clicking the  button. The button is disabled when only one setup file is left in order
to make sure not all setups are deleted.

The setups can also be selected from the tree structure shown below. 

This gives a better overview if you have many setups, since the setups are grouped and you can open/close each
category. A new category is defined with the underscore ‘_’ in the setup name.

17.1.2 Setup description

The setup description field gives a brief description of the selected setup. Using this you can click on the setups and
read the description to find the setup that you need.
Known issue: In the special case if the selected item in the list of setups is both a setup and a setup category, then the
setup description will not be updated.

17.2 Store...

Stores the current WinMLS settings so they can be restored using Setup->Load…. 
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Clicking the  button will display the additional settings shown below.

17.2.1 Setup name

The name of the setup. Type a new name if you do not wish to overwrite the current setup.
Known issue: If  the setup name contains comma, it will not be included if you want to make a zip-file of the setups
using the zip-features that are a part of Windows XP. To avoid this problem, use Winzip (www.winzip.com) to make
the zip-file.

17.2.2 Setup description (2)

The setups descriptions should describe the selected setup. The description may contain the following information:

• What kind of measurement(s) is the setup suited for
• How it should be used (hardware setup)
• How it can be adjusted
• Is calibration needed
• What post-processing setups are suited for this measurement setup

In addition to the setup description we recommend using the Wizard feature (Measurement->Wizard->Editor...).



17.2.3 When loading this setup include

You can select if you want to load the below settings when the setup is loaded.

17.2.3.1 Measurements

• If  is checked, WinMLS will open the measurements present in memory at the time the setup
was saved. But because only a link to the measurements is saved, there are some restrictions: The
measurements must have been saved (as raw time data). You can save using File->Save As..., or you can turn
on auto-saving from Measurement->Settings.... 
Note: The measurements must be saved in a subfolder of the setups folder (it is as default the folder where
WinMLS was installed).

17.2.3.2 Sound card, level and calibration settings

If  is checked, the sound card, level and calibration settings are loaded when the
setup is loaded. 
If it is not checked, you can load the setup without changing the sound card, level and calibration settings. This makes
it much easier to switch between measurement settings (you don’t have to reselect e.g. the sound card settings each
time you switch setup, since they will stay unchanged). 

All the default setups that come with the installation of WinMLS should have this setting turned off, except if there
are setups that contain these settings on purpose. After loading a setup which has this

 check box turned on, please note that you may have to reselect the sound card
settings.

Here is a list of the settings that this applies to:
All settings in Toolbars->Levels (and Mixer), Measurement->Sound Card..., Measurement->Calibration.... 

In Measurement->Settings..., it applies to some of the settings.
In the Imp/Freq. Res tag under no. 7, the measurement correction file(s) and the delay settings shown below

In the Levels tag, the level and polarity settings shown below

17.2.3.3 Post-processing setup

Make sure  is checked if you want the post-processing settings to be loaded when a
setup is loaded (Setup->Load...).
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17.2.4 Store post-processing setup

If  is checked, the post-processing setup is also stored when storing the measurement
setup.

If  is not checked, the post-processing setup will not be stored and the post-processing
settings in the dialog box will be disabled as shown below.

17.3 Import

Imports exported setups (see next section on how to export a setup). 

When a setup is imported, the settings are just made available to WinMLS. To load the settings for this setup, it must
be loaded using  Setup->Load….

Note: Existing setup files having the same name as the name of the setup you are importing will be overwritten.

17.3.1 Importing setups to a new folder

To avoid this you may select a new folder from Setup->Folder... before importing the setup. An example of this will
now be given, and we will use the folder named C:\data.
Go to Setup->Folder.... as shown below, and select the folder name C:\data.



Now go to Setup->Import... and select the zip-file containing the setup you want to import.

Then go to Setup->Load..., select this setup and click the  button.

Now you should have restored the settings you had when you stored the setup including the measurements.

After doing this, you must reset the setup folder to the original folder, e.g. to C:\Program Files\WinMLS2004,
following the procedure given in this section. 

17.4 Export

Exports the current settings to zip-file. 
Note: Only the current selected setup and the temporary setups are exported, not all the setups. The temporary setups
are included so the exact settings can be restored if the current settings are not the same.

Note: Measurements are also included in the zip-file if  is checked in Setup->Store.... This is useful
for the following purposes

• Multiple measurements are saved in one file together with the settings and can be opened in WinMLS using
Setup->Import….

• Sharing setups with other WinMLS users. (Measurements can also optionally be included.)
• Backup your current setups

In the example below we see how the data from such a zip-file can be restored in WinMLS.
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17.5 Shortcuts...

Use this dialog box if you want to assign shortcuts to a setup.

You can use the keys F9-F12, also in combination with the ALT key.

Select the setup you want to load from the list 
If you want a measurement to be started directly after the setup is loaded, make sure  is checked.

The settings in this dialog box are saved to the PC registry. If you need to set it up differently, log on as a different
Windows user.

17.6 Folder...

Here you may select to load the setups from another folder than the default setups folder. This is useful if you have
exported a setup including measurements to a zip file. Then you may import the setup files to a new folder and set this
in the dialog box shown below. For more details on the usage, see the Setup->Import... section. 



17.7 Options...

Open this dialog to modify the settings shown below.

17.7.1 Load settings when WinMLS is started

A setup contains all the WinMLS settings, e.g. what output signal to be used and what to be plotted as result of a
measurement. Therefore it is very important what setup that is loaded. The options below let the user decide what to
be loaded when WinMLS is started.

17.7.1.1 Load specified setup

Select  if you want WinMLS to always start with the same
setup/settings. In some cases it is useful to load the same setup when WinMLS is started. Then you are sure that the
settings are exactly the same each time WinMLS is opened, independent of changes to the settings made the last time
WinMLS was used.
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17.7.1.2 Load the previous settings

Some users want WinMLS to start with the same settings that then had when they last closed WinMLS. Then make
sure  is selected.

Note: If you are loading a setup that consists of several windows, this method of loading the previous settings is not
supported. A warning about this will be given. In such a case, you must set it to the option above or the option below.

17.7.1.3 Load the last used setup

Select  if you want to load the setup you used the last time you exited WinMLS. 

Note: If you have made changes to the setup before you exited WinMLS and if you did not save these settings, these
changes will not be kept when WinMLS is started. To keep these settings, you must remember to store the setup (using
Setup->Store…).

17.7.1.4 Ask user what setup to load

Select  if you want to be asked what setup to load when WinMLS is started. The Setup-
>Load… dialog box is then displayed when WinMLS is started.

17.7.2 Setup-independent options

These options will remain the same if loading a new setup.

17.7.2.1 Freeze toolbar position

If  is checked, loading a new setup will not have an effect on the visibility
and position of the toolbars. If it is unchecked, loading a new setup will load new toolbar visibility and position
settings.

17.7.2.2 Show popup on mouse right-click

If  is checked, the pop-up menu shown below will be displayed when the right mouse
button is clicked in the plot area. The pop-up menu contains the most used settings.



17.8 Full Menu/All Toolbars

If this menu item is checked, the full menu is displayed and all toolbars are available. If this menu item is not checked,
only the menu items and toolbars that we estimate are most used are available. If you cannot find a menu item or a
toolbar you need, then make sur that Full Menu/All Toolbars is checked.

18Measurement menu
This menu contains the measurement settings

18.1 Start

Starts a measurement using the current WinMLS measurement settings.
A too high output level may damage your equipment, so consider reducing the output volume before selecting this
option. For most types of measurements, the volumes should not be adjusted during a measurement since it will give a
wrong result.

18.2 Cancel

If a measurement is being performed, selecting Cancel will stop the measurement. You may also use the Esc key. 
Note: If WinMLS is measuring in continuous mode and PC-demanding calculations is performed, clicking the Esc key
repeatedly can be used if there is problems stopping the measurement.

18.3 Test Levels

Recording (and playback) is started so the user may see the current input (and output) level(s). This is useful for
setting the levels before performing a measurement. 

Note: A too high output level may damage your equipment, so consider turning down the output volume before
selecting this option. 
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18.4 Information…

Displays what is the active measurement and shows information about this measurement as shown in the figure below.

All measurements present in memory are found in the list shown below, and you can select what measurement you
want to display information about. The information is updated automatically.

You may also change the active measurement from the list of measurements shown above.

If you have more than one plot displayed in the window, you can choose to update the active plot or all the plots with
the new measurement.

Click the  button to activate the change. If you do not want to set a new measurement as active, click

the  button.

Note: The measurement file formats .wmb and .wav will contain all information, while the formats .wmt and .tim
contain less information.

18.5 Clear Memory->Active Measurement

Clears the active measurements from memory and deletes all curves belonging to this measurement. This is useful if
you have performed a measurement you are not satisfied with, and want to get rid of it.



18.6 Clear Memory->All Measurements

Clears all the measurements that are present in memory, except the measurements that are plotted. 
Even measurements that are not saved will be deleted. Since WinMLS stores all the performed and opened
measurements in memory as default (can be turned off from  Measurement->Tasks...), it may be needed to clear the
memory once in a while.

18.7 Listen

Use this to listen to the active measurement. The data are normalized and played back using the same playback
settings as used for performing a measurement. 
The time window determines what part of the active measurement that is to be played. This part is repeated in a loop.
Currently it only works for single channel (mono) measurements.

18.8 Calibration…

Displays the dialog shown below.

18.8.1 Input level calibration

The input level calibration part is displayed below.

 determines if input calibration is turned on.

Clicking the  button displays the input calibration dialog.

 determines which channel the input calibration dialog is displayed for. For a normal 1-channel
measurement, this number should be set to 1.
Note: A typical problem is that the user calibrates only input channel 1 and then later does a 2 channel measurement
and forgets that channel 2 is not calibrated.
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18.8.1.1 Combined calibration

When clicking the  button, you should see the dialog shown below. If you in step 2. choose to perform a

combined calibration  there are only 4 steps, as shown below

Step 1. is explained in the next section.
In step 3. the user can either click the  button and follow the calibration procedure or type the Maximum
input SPL level manually after clicking the  button.

If clicking the  button, the dialog shown below is displayed

In step 1, select if you want to use the sound card output or an calibrator as source.

In step 2, select the calibration frequency. If you use an external generator this must be set to sinusoidal signal with the
frequency that is set here.

In step 3 connect the source you have selected the input. You might want to click the  button to test the level.
You will be given a warning when performing the calibration if the level is not set correctly.



In step 4, enter the calibrator SPL-level.

In step 5, click the  button. This will perform the calibration and check that the level is sufficient and the
distortion is not too high. If this is OK; the calibration is finished, the dialog box is closed and the calibration time and
date is written in the Input level calibration dialog

18.8.1.2 Individual calibration

In the most advanced case where we do an individual calibration 

 the dialog box will look like below.

Note: The date for the last calibration is displayed as shown below.

The date is updated both when performing an automatic calibration (e.g. using a calibrator) and if performing a
manual calibration (by typing the sensitivity directly to the edit box).

18.8.1.2.1 Transducer (1)

In step 1a, the check box   should be checked if a transducer (e.g. a microphone) is
connected to the input. This makes sure that units are correctly set in the plot and also allows you to specify the
transducer sensitivity if individual calibration is selected.

In step 1b. select the unit of your transducer. If you are using a microphone select the setting

.
If you are measuring using another transducer, see the FAQ section for more information.

18.8.1.2.2 Select how to calibrate the input chain

In step. 2, select if you want to do an easy combined calibration or an advanced individual calibration.

If you select the advanced  calibration, you first need to calibrate your sound card before calibrating your

microphone (or another transducer). The  calibration must be used if you do not have a calibrator but the

sensitivity of your microphone is given (e.g. 20 mV/Pa). Use also  if you have an external input amplifier
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and want to adjust the gain steps of this amplifier, or if you are using WinMLS to perform both electrical
measurements and measurements using a microphone. If any of the above suggestions are not relevant for you, we

recommend that you use .

In the rest of the documentation, we assume  has been selected.

18.8.1.2.3 Sound card calibration

This assumes that  was selected in step 2. If not, this dialog may look differently but the principle should
be the same.
Click the  button to start the calibration of your sound card.

In step 1, select if you want to use an external signal generator or the sound card output as source.

In step 2, select the calibration frequency. If you use an external generator this must be set to sinusoidal signal with the
correct frequency.

In step 3 connect the source you have selected to the sound card input. You might want to click the  button
to test the level. If the signal generator output RMS voltage is not available, you also need to measure this using a
RMS voltage meter. 

In step 4, enter the measured signal generator RMS voltage.

In step 5, click the  button. This will check that the level is sufficient and the distortion is not too high. If
this is OK; the sound card calibration is finished, the dialog box is closed and the calibration time and date is written
in the Input level calibration dialog

18.8.1.2.4 Amplifier gain

This assumes that  was selected in step 2. If not, this dialog may look differently.
In step 4a. select if you are using a pre-amplifier or not. 
If yes, type the amplifier gain in step 4b. 



If your amplifier has adjustable gain in steps and you want to switch between gain steps without redoing the
calibration, read the part below. If not, you can skip it.

You can type the gain steps of your amplifier in a text file (column data) and make WinMLS use this file instead of the
current values shown below

This file can be selected by clicking the  button as shown below.

If you right-click the file  , you can choose to open it in Notepad

Type in the values of your amplifier as shown below. 

Remember to save the file afterwards.
The file must be saved in the WinMLS sub-folder  .../AmpGainsteps/Input/ for the input calibration and .../
AmpGainsteps/Output for the output calibration.

If you want to determine the gain steps of the amplifier, we suggest that you do this manually by plotting and
inspecting the frequency response of the amplifier for the available gain steps.
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18.8.1.2.5 Transducer calibration

This assumes that  was selected in step 2. If not, this dialog may look differently.
In step 5 you can calibrate to find the sensitivity of your transducer. If the previous steps have been done correctly, the
sensitivity will be correct. But if the transducer sensitivity is given you may also use this number. First click the

 button so you can type your own number

Then type the sensitivity of your transducer as shown below.

If you want to perform the calibration, click the  button to open the dialog shown
below

In step 1 select the source of your calibration signal. 

We will assume the sound card output is selected and that the transducer is a microphone. If you have access to a
calibrator, the procedure is less complicated and is therefore recommended. The procedure described here assumes
that you have access to a sound level meter.

In step 2. type the frequency you wish to use. 1000 Hz is typically used.

Follow step 3. The microphone of the sound level meter should be as close as possible to the microphone you use with
WinMLS.
In step 4, note that if the input level is too high you can reduce the sound card output calibration level from the value 0
which represents maximum output level.

(This dialog box is not enabled before you click the  button).

In step 5, type in the sound level measured using the sound level meter.
Follow step 6 and 7 to complete the calibration.



18.8.2 Output level calibration

The purpose of the absolute output level calibration is to be able to measure impulse responses/transfer function gain
with the correct units.

 determines if the output is to be calibrated.

 displays the output calibration settings dialog.

The usage of this dialog box is very similar to the Input Level Calibration dialog box. See the Input level calibration
section for more information.

18.8.3 Sound card mixer gain steps

The advantage of calibrating the gain steps of your mixer is that WinMLS will automatically compensate by the
appropriate number of decibels when you change the mixer volume. This way you will get the correct level
independent of the mixer volume settings. Also, if you do not do this and want to maintain the calibration, you must
redo the level calibration each time you change the sound card mixer volume (a warning about this will be displayed).

In order to perform mixer calibration, go to Measurement->Sound Card... and in step 3. Select mixer (volume

control), make sure  is selected.
Note that this may not be possible on some sound cards since they do not support the Windows mixer. If this is the
case, it is not possible or required to calibrate the mixer gain steps, so you can skip this section.

After setting WinMLS to control the Window mixer, click the  button found in step 3d. to
calibrate the sound card mixer. 

As shown in the figure below you can decide if you want to define the gain steps of your mixer. 
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The advantage of using  is that WinMLS will automatically compensate by the
appropriate number of decibels when you change the volumes of the mixer. Thereby you always get the correct level
of your measurement.

If you see the name of your sound card in the ’gain steps’ list shown below, you can select it and do not need to run
the procedure for making a new gain steps file.

If you want to make a new gain steps file, click the  button. The dialog box shown below will be opened.

This procedure may take a few minutes. 

Only channel 1 is used to find the mixer gain steps. This means that if you are measuring using both channels and the
mixer gain steps in channel 1 is not equal to channel 2, there will be an error in the result.

If the level is too high to do the calibration, which may be the case if you are calibrating a microphone input, you
should reduce the output calibration level [dBFS]. It can be set in the range 0 dB to – 60 dB, an example is shown in
the figure below.



18.9 Settings...

The measurement settings dialog box contains all the settings for performing a measurement (obtaining the time
domain raw data, e.g. impulse response) except for the calibration settings. 
Note that the measurement settings dialog will look different dependent on what type of measurement you have
selected. An example is shown below

The upper settings are common. At the upper right, select how many input channels to measure. In the example above

it is set to . The standard version of WinMLS allows you to measure up to two channels, but we also sell
versions that can measure up to 24 channels simultaneously.

Then at the upper left you can select what type of measurement you want to perform.

Each type is described in the sections below.

You can also set WinMLS to open this each time you perform a measurement. To do this, make sure the setting at the
bottom of the dialog shown below is not checked.

If the check box shown below is checked, the Measurement->Settings... dialog will not be opened when you perform
a new measurement.

Note: If this dialog box is opened, it does not lock for any other WinMLS settings, they can all be accessed. So you do
not need to close this dialog box before starting a new measurement. It may be convenient to have it opened if you
want to monitor or change your measurement settings.

18.9.1 Signal Generator Only

Select this if you want to use WinMLS to generate a signal only and don’t want to measure the response of the signal.
The dialog will then look as shown below

281



Click the  button to display the more advanced settings shown below.

Each of the settings in this dialog will be explained below.

18.9.1.1 Signal type

Select from the list shown below the signal to be generated from WinMLS.

18.9.1.2 Frequency

If Sine is selected as signal type, the frequency setting is displayed as shown below 

To set the frequency in large steps, drag the slider using the mouse.

If the  button is turned off (which we recommend), the last half of the slider scale is logarithmic. This is the
normal way of representing such a slider. But if you need to fine-tune the high frequencies very accurately, you should
try turning the  button on. For more information about fine-tuning see the next section.

18.9.1.2.1 Fine-tuning the frequency



To fine-tune the frequency, use the arrow keys on your keyboard (works only if the slider has focus) or use the 
control shown in the figure above. The frequency steps available depend on the selected block size. If you increase the
block size, the frequency steps become finer but updating becomes slower.
You may also type the desired frequency directly in the  edit box shown in the figure above. If the current
WinMLS setting does not support the frequency, the nearest supported frequency will be displayed when the edit box
looses focus (to have it loose focus pus the Tab key or click somewhere else with the mouse).

18.9.1.3 Source

Select what output the signal is to be played.

If External is selected, no signal will be played so do not select this option. For an explanation of the other options,
see the Generator type and source section below.

18.9.1.4 Fs - Sampling frequency

Select the sampling frequency from the list, or type in the desired value.

The sampling rates that can be used depend on your sound card and also on what version of WinMLS you have
purchased. WinMLS displays an error message when a measurement is started if the selected sampling frequency is
not supported.

18.9.1.5 Block size [ms]

Select the block size from the list, or type the desired value in milliseconds. The number of samples is shown to the
right in the figure below.

Note: The block size determines the frequency resolution of the frequency slider. The higher the block size, the higher
the resolution. If the block size is 1000 ms, each step will be 1 Hz.
The block size also determines the update speed when the frequency slider is moved. Decrease the block size to
increase the update speed.

18.9.2 Scope Mode/Data Acquisition

Select this if you want to measure an input signal such as background noise, a sinusoid or an impulsive signal. 
If you want to measure the impulse or frequency response using a source (typically a loudspeaker), you should instead

select the choice  found below on the list. 
But if you wish to measure the impulse response using a short pulse, e.g. a balloon burst or a gun shot you should use

the  option.

The dialog shown below is displayed.
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Click the  button to display the more advanced settings shown below.

18.9.2.1 Generator on

If the generator is turned on , the dialog typically looks as shown below

See the Frequency section above for information.

18.9.2.2 Generator off

If the generator is not turned on , no output signal will be generated from WinMLS. You need to select
what type of input signal to be measured from the two choices below

If Stationary is selected, the dialog will look like below.

If Transient is selected and the  button is clicked, the Various section will look like below.



If  is checked, WinMLS will wait until the input level exceeds the trigger level (in this example –
30 dBFs, which is 30 dB below digital clipping). When the signal exceeds this level, the signal will be recorded and
the length is given by the Length of recorded data setting.

The pre-trigger duration  determines how many milliseconds to be included in the
measurement before the trigger level was exceeded.

18.9.2.3 General settings

Then general settings are shown below

18.9.2.3.1 Sampling frequency

Select the sampling frequency from the list, or type in the desired value.

Which sampling rates you can use depends on your sound card. WinMLS displays an error message when a
measurement is started if the chosen sampling frequency is not supported.

18.9.2.3.2 Length of recorded data [ms]

Select the block size from the list, or type in the desired value in milliseconds.

The values available in the list utilize the fastest FFT algorithm. If you are using FFT for post-processing, it is
therefore recommended that you select a predefined block size from the list and don’t type your own value.

Note: The block size also determines the frequency resolution of the frequency slider. It also determines the update
speed when the frequency slider is moved. For more information, see the Frequency section above.

18.9.2.3.3 Mode

Select what to do with the measurement result from the list shown below.

For details see Impulse/Frequency response section below.
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18.9.2.3.4 Saving

Select save mode from the list shown below

For details see Impulse/Frequency response section below.

Click  to open the  Measurement->Saving Defaults… dialog.
Click  to open the Measurement->Tasks... dialog.

18.9.3 Impulse/Frequency Response

Select this if you have a source (e.g. a loudspeaker) and want to measure the impulse response or any parameter that
can be derived from the impulse response, such as frequency response, reverberation time, etc...

Click the  button to display the more advanced settings shown below.

18.9.3.1 Max decay time + system delay [s]

Max. decay time + system delay is used by WinMLS to determine the measurement parameters that will obtain the
best result.



Generally you do not need to be very accurate when setting this parameter. Follow the rules in the two subsections
below. 

This setting will also determine the length of the impulse response that is measured. For example, if you set it to 1.5 as
shown in the figure above, then the measured impulse response will also have a length of 1.5 seconds. Increasing the
length of the impulse response results in slower plotting and it is also takes more space on your hard disk if you are
saving your measurements.

Note: You can type the desired number directly in the  control (you do not have to select from the list).

Note: If Impulse/Frequency Response Advanced is selected as shown below, this setting is not used if Sweep or
MLS is selected as measurement signals. Instead a Sweep or MLS tab is displayed where it can be set. The figure
below shows the Sweep tab.

In this case you have to select the measurement settings manually by clicking the Sweep or MLS tabs.

18.9.3.1.1 Decay time

If you are measuring a room, clap your hands once and count the seconds of decay (until the sound has died out). In a
small room the decay time may be as low as 0.5 seconds or even less.
If you are measuring an electrical system there is usually a high-pass filter to remove the DC-component. The cutoff
frequency of this high-pass filter usually determines the length of the impulse response.

The decay time for the high-pass-filter is given by:

Decay time = 1 / cutoff frequency

For example, below we show a figure of a loop-back electrical measurement of a sound card. We see that the high-
pass cutoff frequency (-3 dB) is 10 Hz.
The decay time for this example is 1/10 = 0.1 seconds. So to perform an accurate measurement, the length of the
impulse response should be at least 0.1 seconds.

18.9.3.1.2  System delay

By system delay we mean the time it takes to send a short pulse through the system under consideration. It is also
called ‘time of flight’ or ‘initial time delay’.

If measuring using a loudspeaker and a microphone, the system delay is given by the distance from the loudspeaker to
the microphone. 
The system delay in seconds is given by the formula:
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Delay = Distance \ Speed of sound

For example, if the distance is 34 meter (100 feet), the delay is 0.1 seconds when the speed of sound is 340 m/s (1115
ft/s).

In many cases, e.g. if you are performing a vibrational measurement and the transducers are positioned near each
other, the system delay is so small that it can be ignored.

18.9.3.1.3 Performing a test measurement

You can also perform a test measurement to set these parameters. Then you can e.g. plot the reverberation time to see
if the decay time you guessed was correct. You can also plot the impulse response using dB as y-axis. In the figure
below, 3 sound card electrical loop-back measurements are shown. We see that for the red curve the noise floor is
reached after 150 ms. For this measurement 0.15 s can be used.
For the two other curves, the noise floor has not been reached within the 350 ms range that is displayed.

18.9.3.2 Measurement duration

No. 2 determines the measurement duration in seconds as shown below. 

Generally you should increase the measurement duration if you want to obtain a better measurement result. A longer
measurement duration means that you put more energy into the system and thus that it is more robust against
background noise. 
The problem with increasing the measurement duration is time variance (the system/device you are measuring is
slightly changing as function of time).  The problem with time variance is minimized if Single Sweep is selected as
measurement signal in no. 3. When Single Sweep is selected we can expect that for each time you double the
measurement duration the snr (signal-to-noise ratio) increases by 3 dB.

The duration of the measurement may not be exactly the number of seconds specified, but WinMLS will find the
optimal settings as near as possible to this setting.

18.9.3.2.1 More about Measurement Duration

The total duration setting is not used if Impulse/Frequency Response Advanced is selected as shown below, and you
have selected Single sweep, Multiple sweeps or MLS as measurement type in no. 3 as shown below.



 

In this case you have to select the measurement settings manually by clicking the Sweep or MLS tabs. From this
dialog you can set the sequence/cycle length and number of cycles/averages manually. We recommend not using the
Impulse/Frequency Response Advanced mode since the user has very high flexibility and may set the parameters so
an optimal measurement result will not be obtained.

18.9.3.3 Generator type and source

No. 3 lets you select what type of generator signal to be used, as well as the output source channel(s). 

You can choose from the signal types shown below.

To get the best measurement results, select one of the two first choices, Single sweep or Multiple sweeps. If you want
to monitor a sound system during a concert, select External source. If you want to measure speech parameters (and
want to consider harmonic distortion), select MLS.

The rightmost list box lets you select where the measurement signal is to be played, as shown below.

If you want to perform remote measurement, select External. To use this you must have previously recorded the
stimulus generated by WinMLS to a DAT-player (or another source). You may also export the stimulus to a .wav-file
from Measurement->Export Stimulus.... 

If Left channel is selected, the stimulus is played back through the left channel, which means that the output source
must be connected to the left channel output of the soundcard. 
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If Right channel is selected, the stimulus is played back through the right channel, which means that the output source
must be connected to the output channel output of the soundcard. 

If Left & right ch. is selected, the stimulus is played through both left and right channels. Note: If you are measuring
a stereo sound system, it is not recommended to measure both loudspeakers simultaneously. 

If L&R InvPolarity is selected, the stimulus is played in both left and right channel, but the right channel has
opposite polarity, e.g. 180 degrees out of phase. Example: If this option is selected the sound will be directed to the
surround speakers when measuring a Dolby Surround Sound System.

If Alternate L&R is selected, the first measurement is performed using right channel output, the second with the right
channel output, the third with the left channel output, and so on. This may be useful when measuring a stereo sound
system, since the loudspeakers should not be measured simultaneously.

18.9.3.4 Emphasis

No. 4 is for selecting emphasis. For normal usage we do not recommend emphasis, the exception is if you are using
MLS as stimulus. If you are measuring using MLS and you are not measuring speech parameters (STI/RASTI), we
recommend using Pink as filter

If you are measuring STI/RASTI and do not require to include distortion components, you can use sine sweep as
excitation signal instead of MLS and no emphasis. The exponential sine sweep separates the distortion components
from the measurement and can therefore not be used if distortion is to be included (distortion will give a poorer
STI/RASTI rating).

If you are measuring STI/RASTI and want to include background noise in the measurement, you should use
Pre/Output only and select filter STI/RASTI as shown below.

If you are measuring STI/RASTI and want to include background noise in the measurement, you also need to set the
total duration exactly twice the length of the maximum decay time. An example of this is shown below

18.9.3.5 Sampling frequency and sweep frequency range

No. 5 is for setting the sampling frequency and frequency range if single sweep or multiple sweeps is selected as
excitation. 

If you want to measure at low frequencies only, first set the sampling frequency as low as possible. 

Which sampling rates you can use depend on your sound card, some sound cards can go down to 8 kHz and even 4
kHz. WinMLS gives an error message when you start a measurement if the selected sampling frequency is not
supported. 

If you have selected sine sweep as stimulus, you can select the sweep frequency range as shown below. 



Our experience is that the best results are obtained if the upper sweep frequency is set to Max as shown in the figure
above. At least you should follow this: WE RECOMMEND THAT YOU SET THE LOWER FREQUENCY
SOMEWHAT LOWER THAN THE LOWEST FREQUENCY YOU WISH TO MEASURE. For example, you with to
measure down to 20 Hz. Then you should start the sweep at 16 Hz as shown in the figure above.

To increase the accuracy for low frequencies, the highest frequency can be set lower than  in the figure
above which means half the sampling frequency. This is shown below

If the upper frequency is much lower than the Nyquist frequency (Fs/2), resampling is used to reduce the file size. This
means that after the measurement is performed, the measurement is processed so that the high frequencies above the
selected upper frequency are removed.
Note: The result of the resampling process depends on the measurement settings. You should first perform a loopback
measurement of the sound card to check the result. If it has ripple in the frequency response that is too high for your
application, increase the measurement duration and try again. Best results have been reported if you select the settings
in step no. 6 as shown below

(Note:  will not be displayed if single sweep mode is selected in no. 3)

In sweep settings (advanced mode), the resampling can be turned off if that is desired.

18.9.3.6 Reference

No. 6. sets the reference for the calculation of the impulse/frequency response. 

As a reference you can select from the types below

If you select Right ch. input, the input signal from channel 2 is used as reference for computing the impulse response.
This setting should work for all sound cards (with stereo input). The response and delay of the sound card will
automatically be corrected using this method.
If you have selected External source in nr. 4, Right channel input is automatically selected as reference.

If you select Generator, you are not using an input channel as reference and you can thus measure using all input
channels. This means that you can measure the impulse/frequency response of two microphones simultaneously using
a standard stereo sound card. With a standard 2-channel soundcard this is impossible if you use Right channel input
as reference, since then one channel is used for the reference signal.
Note: that Generator will not give optimal results if your sound card does not have exactly the same sampling rate on
the input as the output (an example of such a card is the Sound Devices USB Pre).

The last choice No reference is meant only for error-checking since it does not compute the impulse/frequency
response but only displays the input signal.
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18.9.3.7 Correction

If you in 6. Reference have selected Generator as reference, the sound card delay and frequency response is not
automatically corrected for. But this can be done here.

 

The sound card delay and frequency response is not automatically corrected for. But this can be done in point no. 7 as
shown below.

If  is checked before the measurement is performed, it will correct your measurements for the influence of
the measurement system. With the term ‘measurement system’ we usually mean your sound card, but it is possible to
include an amplifier as well. We also sell a special attenuator to be used to measure electrical signals that is too high
for the sound card, this can also be included in the correction. The output of a power amplifier usually gives too high
voltage so the sound card cannot be directly connected to it.
In order to do this correction, your measurement system first has to be measured. The procedure for this is described
below.

We can measure the response used for correction simply by connecting a cable from the output to the input of the
sound card. Signal processing theory tells us that this correction can be used to "subtract" the influence of the sound
card from our measurements. 

(But if we want to record a signal only, e.g. to measure the background noise, it is more problematic to correct for the
sound card. This is because when we measure the influence of the sound card, we measure both the output and the
input. WinMLS currently does not have a method for such a correction, except the microphone compensation found in
Plot->Plot Type Settings->Frequency Response/Spectrum....)

Measure the measurement system using the following procedure
1. Connect a cable from the input to the output of the sound card. 
2. Make sure the measurement system correction check box  is turned off:

3. Perform a measurement.
4. Turn the measurement system correction on, . 
5. Save this measurement as the measurement system correction measurement by clicking the  button.
6. Perform a measurement again. This should now be flat in the frequency domain. Inspect it in time domain

also, it should be a very short peak (Dirac pulse) at time 0 ms.
7. Now connect the usual equipment and perform measurements without and with the system correction and

observe the difference.

(If you measure using synchronization loop-back, you might experience a small tail at the very end of the impulse
response. This is a result of the correction filtering procedure. If this tail is more than –50 dB below the maximum of
the impulse response, it can be neglected for most applications.)

When  is checked, the relative amplification will be measured. If the amplification of the system you are
measuring has increased by 5 dB after you performed the reference measurement, the peak of the impulse response
will therefore be at 5 dB. The linear amplification may be displayed by plotting for example the first part (it is given



by the maximum) of the impulse response using linear axis. To plot the amplification in dB, do the same using
logarithmic x-axis, or plot the magnitude frequency response.

You should now and then verify that the measurement system correction is valid. Especially if you are unsure about
your sound card delay. This can be tested by performing a loop-back measurement of your sound card (output
connected directly to input).

Clicking the  button will display the  Measurement->Sound Card... dialog.

Clicking the  button will display the Measurement->Delay… dialog.

18.9.3.8 Mode

In no. 8 you decide what mode to measure in.

The details are explained below.

18.9.3.8.1 Single or Multi mode

Select one of the choices shown below.

18.9.3.8.1.1 Single
Select this if you want to display the result of the measurement or save the measurement data to disk after a single
measurement is finished. 

18.9.3.8.1.2 Multi
Select this if you want to measure continuously. When a measurement is finished, the next measurement is started
immediately without any break. In the single mode above, the calcualtions and plotting are done before performing a
new measurement. In this multi mode, the calculations and plotting is done while the measurement si being performed.

This is suited for logging data (e.g. noise levels) and if tuning a sound system, e.g. an equalizer. In this case you want
the graphics update as fast as possible. No averaging is used in this mode,and the fact that averaging is not used is an
advantage since you want the result to reflect new settings as quick as possible.
Stop the measurement from Measurement->Cancel, or push the Esc button.

If your PC is not fast enough for this mode, you can still update the plot after each measurement. To do this, select
Single mode (explained above) and go to Measurement->Tasks.... In this dialog you need to set two settings. 
1. Make sure the check box 

is checked. This will start a new measurement as soon as the previous measurement is finished. 
2. To avoid the memory to be filled up, you also should set the memory to Don’t keep as shown below.

18.9.3.8.2  Saving and Measurement Tasks

If you have selected Single mode, the saving and tasks options will be displayed.
Click  to open the  Measurement->Saving Defaults… dialog.
Click  to open the Measurement->Tasks... dialog.
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Select one of the methods shown below for saving

18.9.3.8.2.1 Manual save
Save the measurement using File->Save As....

18.9.3.8.2.2 Ask before meas.
If this is selected you will be asked before performing a measurement whether you wish to save the previous
measurement or not.

18.9.3.8.2.3 Ask after meas.
If this is selected you will be asked after performing a measurement whether you wish to save the previous
measurement or not.

18.9.3.8.2.4 Automatic...
If this is selected the measurement will automatically be saved. The filename and other parameters are taken from
Measurement->Saving Defaults….

18.9.3.9 Calculation of harmonic distortion

If and only if you have selected Single Sweep or Multiple Sweeps in step no. 3 as shown below, it is possible to
measure harmonic distortion.

If the  check box is checked, the harmonic distortion components of
the measurement are included. If it is not checked, these components are removed from the measurement. This can be
done since the harmonic components are separated from the impulse response part of the measurement.
Note: The measurement result raw data may be very long if this setting is turned on and if you are using a single
sweep with a long duration. To reduce the length of the measurement, you should consider measuring using multiple
sweeps if you need a long measurement duration. This will reduce the disk space required for storing the
measurements and speed up the computations.

18.9.4 Impulse/Frequency Response Advanced

Same as “Impulse/Frequency Response”, but here you have access to all advanced options (sweep and MLS settings).
If this advanced mode is not selected, WinMLS will find the optimal settings for these parameters for you. So select
this mode only if you want to override this. We recommend that you use this option only if you have previous
experience with these measurement methods. If you do not obtain godd results using this mode, switch back to the
standard mode and check the result using the standard mode. 
Since the standard mode uses the settings we have found to give optimal results, we will not comment on how the
parameters can be set to obtain the best results in this advanced mode.

18.9.4.1 Sweep Tab

Displays the settings shown below. 



18.9.4.1.1 Length

• The sweep duration determines the duration of the sweep. 
• The silence duration is the period of silence after the sweep ends. This silence period allows the system to

decay before the measurement is ended.
• The cycle duration is given by the sum of the sweep duration and the silence duration.
• No. of pre-send cycles determines how many sweep cycles are to be played before the measurement is started.
• No. of meas. cycles is the same as the number of averages. This means how many cycles are averaged in time

domain.
• Total duration is the duration of the entire measurement

18.9.4.1.2 Type (6)

The sweep can be either linear or exponential as shown below

A linear sweep sweeps at the same speed for all frequencies and will thus create a white spectrum.
A exponential sweep increases the sweep speed exponentially starting from the lowest frequency. In most
measurement situations, it is strongly recommended to use the exponential sweep.

The sweep is faded in and out if the check box  is checked.

18.9.4.1.3 Calculation

If the check box  is checked, a 6th order Butterworth highpass filter is used to filter
out the frequencies below the frequency where the sweep starts. This is useful if your sweep starts at a higher
frequency. The impulse response will look cleaner when the low frequency content is filtered out.
Important: If you are measuring phase, make sure the check box is NOT checked. This is because the filtering will
affect the phase response.
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If the check box  is checked, resampling is used to reduce the
sampling frequency. If the sweep is set to end at a low frequency, the frequencies above this frequency are not to be
included and resampling can be used. 
Note: The resampling decreases the sampling frequency of the measurement result. If this option is not used, noise
blow-up may occur in the impulse response because of the high-frequency content that is not removed.

If the check box shown below is checked, the impulse response is limited to the length specified in the edit box shown
below.

18.9.4.2 MLS Tab

Displays the settings shown below. 

18.9.4.2.1 Sequence order

The sequence order determines the number of samples in the maximum length sequence
(MLS). The number of samples in the MLS is given as 2^ (Sequence order) – 1. 

When the MLS measurement method was first introduced, the maximum length sequence was generated using shift
registers. By connecting the shift registers in a special way it was found that a maximum length sequence could be
generated. This was the longest sequence that could be made before it repeated itself, and the length was given as 2^(#
of shift registers) - 1. The Sequence order is the same as the number of shift registers used to generate the sequence.
It was found that this sequence had very useful properties for measurements and it is still today used. 

18.9.4.2.2 Sequence duration

The sequence duration  determines the duration of one measurement cycle. It is given by the
number of samples in the MLS divided by the sampling frequency.

18.9.4.2.3 No. of meas. cycles (averages)

The No. of meas. cycles (averages) is the same as the number of averages. This means
how many cycles are averaged in time domain.

18.9.4.2.4 No. of pre-send cycles

The No. of pre-send cycles  determines how many sweep cycles are to be played before
the measurement is started. 



18.9.4.2.5 Sequence type

Two different types of sequences for MLS measurements are available, A or B. 

This feature may be used for distortion/non-linearity checking, although it is recommended to use the sine sweep
method of measuring harmonic distortion. 
Non-linearity causes spurious peaks in the impulse response. The peaks are replications of the true impulse response.
For measurements using a different sequence, these peaks are situated at different places in the impulse response. By
visually inspecting two impulse responses measured with different sequences, the amount of non-linearity may be
determined. Distortion/non-linearity is usually caused by the transducers (either microphone or loudspeaker) and may
in some cases be reduced by reducing the volume.

18.9.5 Levels Tab

Clicking the Levels tab opens the settings shown below.

18.9.5.1 Output level

The digital output level is set in dBFS, this means that 0 dBFS is maximum.

The level is set differently for each WinMLS output signal. Here sine sweep is set to -10 dBFS as shown below.

But if we change to MLS as output signal, the level is set to -13 as shown below.

Note: When using MLS, do not use a higher output level than -13 dBFS. A higher output level will probably cause
distortion.

The output signal will be inverted if  is checked.
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18.9.5.2 Change output level

Use this setting if you want WinMLS to automatically change the output level after a measurement s performed. This
is useful when performing automated measurements, e.g. when checking how high output level is needed to exceed a
distortion limit.

If the increase check box  is checked as shown above, the level will be set after a measurement is
performed.

In the example above, the output level will start at -10 dBFS and will be in increased with 5 dB after each
measurement until 0 dBFS is reached.

You may also decrease the output level by typing a negative number as shown below.

In this example, the ouput level will start at -10 dBFS and be decreased with 5 dB after each measurement until -40
dBFS is reached.

Clicking the  button will reset the current level to the initial output level which in this case
was -10 dBFS as shown below.

18.10Sound Card...

Opens the Sound Card Settings dialog as shown below. 



Click the  button to also display the settings shown below

18.10.1Input device

The input device name is usually similar to the name of your sound card. If you are unsure what to select, just select
the one you think it is or read the documentation of your PC or sound card to find the name of the sound card. 

Note: The list box may contain devices that cannot be used for measurements. In this case, an error message will be
given when the measurement is started.

18.10.1.1 Multi-channel input device

If you in Measurement->Settings... have set WinMLS to do a multi-channel measurement (>2 channels), the list box
is replaced by a button as shown below

Clicking this button will open the dialog for selecting multiple devices. This is needed since a single device is stereo,
so for recording 8 channels four devices are required

18.10.2Output device

This is very similar to setting the input device. In most cases the names are the same.
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18.10.3Mixer (volume control)

If your sound card supports the Windows mixer (most sound cards do), we recommend that you let WinMLS override
and control the Windows mixer.

Note: Some sound cards may have problems with using this setting, if this is the case you should use one of the other
options (explained below).

18.10.3.1 Let the WinMLS mixer control the Windows mixer

This allows you to be able to change the analog input and output volumes from within WinMLS.
Note that if you are using a LynxStudio card you should not use the WinMLS mixer and instead select No software
mixer. Otherwise, select Let the WinMLS mixer control the Windows-mixer as shown

If your sound card does not support the Windows mixer, a message will appear informing about this.

18.10.3.1.1 Step 3b – Mixer input

If you are not using the WinMLS mixer, it is not possible to set the input line. Depending on the sound card, you may
choose between only one or several input lines as shown in the figure below. 

                                           

Some of the names may be different than those shown. Note that the list may contain lines that cannot be used for
measurements, e.g. CD player and Aux.
If you want to use the line input of your sound card you can find it as Line In or Line, and if you want to use the
microphone input you can find it as Mic or Microphone. 
There are some exceptions, the VX pocket/VX222 cards only have one analog input that can be used as both line and
microphone input, thus the input line is just called Analog Input. 

18.10.3.1.2 Step 3c – Mixer output

If you are not using the WinMLS mixer, it is not possible to set the output line. Otherwise, the output line usually has
only one choice, and it is usually called Wave or Wave Output.

18.10.3.1.3 Step 3d – Mixer calibration

Calibrate the gain steps of you software mixer. See the Measurement->Calibration... section. 



18.10.3.2 No software mixer

If your sound card does not support the Windows mixer or if you have problems using the mixer, you may set
WinMLS not to use any mixer

18.10.3.3 Manufacturer sound card mixer

A few sound cards have their own mixer application and thus support this feature. You may set WinMLS to open this
mixer application from the sound card manufacturer. How to do this is shown below.

Click the  button to select the mixer application.
You are asked to specify the path. Consult your sound card documentation on how to find this path.

18.10.4Number of bits

 gives the bit depth used for playback. You may choose 16, 24
or 32 bits. Your sound card may only support 16 bits. 24 or 32 bits usually gives slightly better measurement results if
you perform measurements that require high precision. The methods WinMLS use for measuring impulse responses
are so robust against background noise that you might not see much difference.

The number of bits used for recording (input) and playback (output) is usually set to 16, but can be set to 24 or 32. If
your sound card does not support more than 16 bits, an error message will be given when attempting to measure. 

Note: Even if the sound card supports 24 bits it is not certain that WinMLS will support it. Please contact us if this is a
problem.

18.10.5Specific sound card settings

If your sound card requires special settings, you can click the  button to display all the sound card settings.

The sound card specific settings are sound card dependent and will therefore look different dependent on what sound
card is selected. On some sound cards you may set Treble and Bass, 3-D sound and other settings, but for other sound
cards no such settings are supported and they will therefore be disabled in the dialog shown above.
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The special settings may influence on the result of your measurements. Therefore, WinMLS will extract these settings
and allow you to set them. These settings will be saved in the setup as the other sound card settings. This way you are
sure to have exactly the same settings each time you perform a measurement. 

Note: A sound card may have settings that are not displayed here, e.g. the Digigram sound cards volume settings
Advanced Input and Advanced Output. In this case you must make sure that the settings are correctly set.

You should here make sure that settings that will disturb the measurement, like 3D-sound, is turned off (not present in
the figure above).

18.10.5.1 Sound card specific

Shows settings specific to the sound card as shown below.

The  is the default setting. Then WinMLS will make sure the volume is set on the
selected mixer line (for example line in or microphone). But it is reported that this will not work on a few sound
cards (some of the sound blaster cards may have this problem). Therefore when you start measuring, if controlling the
input or output volume from WinMLS is impossible, you should try one of the other alternatives that are present to
handle bugs in the sound card drivers or operative system. The choices are

Off – use this if you want to use the Windows mixer to select the mixer line. You must manually open the Window
mixer and select the mixer lines for input (and output). In the example below, Microphone is selected as mixer line
for the input.



Auto,Invert if XP – WinMLS selects the correct mixer line in the Windows mixer. But if the operative system is XP,
this selection is inverted.
Auto - WinMLS selects the correct mixer line in the Windows mixer.

Auto-Invert -  WinMLS selects the correct mixer line in the Windows mixer but inverts the selection.

In addition, an offset can be set. This is set to zero as default as shown below .

You should make sure  is checked. It determines if unwanted feedback that may occur
between the measurements should be turned off. If this is not checked, feedback may occur between the measurements
because then the original sound card volume is being restored. If checked, it will make sure that the volume setting
causing feedback is turned off.

If any checkboxes below the  checkbox are displayed, they will be listed and turned off as
default as shown below

You may turn them on by checking them. We recommend that you do not check the controls unless you know what the
controls actually do. For more information about this, consult your sound card hardware documentation. A way of
testing the effect would be to compare a measurement with the control turned off with a measurement with the control
turned on. 

18.10.5.2 Output volume and EQ (sound card specific)

 gives the master volume for all output lines and can be given a value from 0 to 65535. We
recommend that you set it to 65000 (or exactly to the maximum value 65535). If you have problems with
distortion on your sound card output, then you should try setting it to a lower value.

The output tone controls Treble and Bass found on the left side of the figure above can be set to a number between 0
and 100. This setting will greatly affect the frequency response of your sound card. You may use this as an equalizer
to boost either the high or the low frequency region.

18.10.6Save for diagnosis

 should be checked if you want to save everything that is recorded during the whole measurement to
a .wav file. This can be useful if you need to see what has happened during your measurement. Then you can simply
playback the file and listen to it, or open the file in a wave editor. 

Click the  button to set path and filename.

18.11System Delay…

Displays the dialog shown below.
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The system delay is the same as the time a signal takes to travel through the system we are measuring. If we are
measuring a loudspeaker, the delay caused by the distance between the loudspeaker and the microphone and is also
called time of flight. The delay can be measured in several ways with WinMLS. It can also be plotted in the plot types
Room Acoustics and Parameter.

Note: These delay settings is only applied when WinMLS is measuring impulse/frequency response and not when
used as a signal generator only or in scope mode. Also if right channel is used as reference in Measurement-
>Settings…, these delay settings will not be used.

18.11.1Ability to measure system delay

Each of the items in the list shown in the figure above is explained in the sections below.

18.11.1.1 Sound card dependent

If  is selected, WinMLS checks if the selected sound card device is found in a list of
sound cards we have tested and found to be able to measure system delay. If yes, then the measurement is performed
so that the correct system delay will be found.

The following cards are in this list: Lynx, Card Deluxe, Siena/Marc 8, Delta 1010LT and Digigram Vxpocket/VX222.
Note that the Digigram VX pocket and Delta 1010LT has a deviation of 1 sample when using this method of
determining initial time delay.



That the sound card is in this list means that the sound card is able to start record and playback at the same time, or
with a delay that is constant. This must be fulfilled to be able to measure the initial time delay correctly.

If the sound card is not found in our list, then the measurement is performed in the No, remove system delay mode
explained below. If you have found that your sound card is synchronized but not any of the sound cards mentioned
above, then you should select the mode Yes, my sound card is synched.

18.11.1.2 No, remove system delay

This mode does not measure the system delay. The system delay is removed so the impulse response should always
start from the very beginning. A special algorithm is used to detect the start of the impulse response.

Multi-channel measurement note: The start detection may not work properly if a multi-channel transfer function
measurement is performed and one of the channels is not measuring a transfer function. This is because all channels
are searched to find the start of the first pulse and the detection may give a wrong result for the channel that is not
measuring a transfer function.

18.11.1.3 Yes, my sound card is synched

You can select this mode if you know that your sound card is able to start record and playback at the same time, or
with a delay that is constant. 

The constant delay can be corrected for in the 

 setting explained below.

The system delay will be measured if this is set properly. Check this by performing a measurement of the sound card
system delay. 

Connect the sound card input to the sound card output, then perform measurements while adjusting the delay. Make
sure that the maximum of the sound card impulse response is at 20-60 samples to make sure the left-side tail of the
sound card is considered. Below is an example of a response that could be shifted some samples to the left. 
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By changing the y-axis to dB, it is easier to see the noise floor as shown below. 
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In this case the sound card delay should be set to about 50 samples to include the pre-ringing before the max is
reached.

Note: We have had users that set the sound card delay to 0 samples. When doing this, they do not include the pre-
ringing when measuring systems with very short time delay. But in return, the time delay will be correct even without
using any correction.

18.11.1.4 Yes, with loop-back and end-check

The measurement is performed using a physical loop-back, usually connected from output right channel to input right
channel. 
A pulse is sent through the loop-back before the measurement is performed and it makes it possible to determine the
initial time delay correctly.
Also after the measurement is finished, a pulse is sent through the loop-back. The time delay between this pulse and
the pulse sent before the measurement was started is checked. This end-check is used to detect errors in the
measurement caused by gaps or errors in play or record (this may happen e.g. if the PC is used for other things while
the measurement is performed). The synch. Signal settings (see section below) must be properly set.

For a more detailed explanation see Measurement 6: Measure in a safe way using loop-back in the section The
first measurements walk-through.

18.11.1.5 Yes, with loop-back, no end-check

Same as the mode above, except that the end-check is not performed. This means that this mode measures the initial
time delay exact, but errors in the measurement caused by non-continuous play or record are not detected. The loop-
back settings (see below) must be properly set.

18.11.2Synch. signal settings

 gives the input line used when performing a loop-back measurement. For the
Digigram cards, Analog Input should be selected, but for other sound cards it is usually Mic or Line In.

 gives the channel that the loop-back is to be connected to. If the loop-back input is
stereo, it is usually connected to Right channel. But if it is mono (typically the Mic input on a built-in sound card), it
must be set to Left.

 should be checked if problems occur when measuring in loop-back mode. A short
MLS signal will then be used for the synchronization instead of the standard pulse. This signal is less prone to noise,
but may demand a faster PC since will need more processing. If you are using a sound card capable of measuring DC
offset (e.g. TB Tahiti/Monterey) it is strongly recommended to use this setting.



18.12Tasks…

Displays the dialog box shown below. From here you can decide what tasks to be executed when a measurement is
performed or opened.

18.12.1When performing or opening a measurement

These settings apply both when performing and opening a measurement from file

18.12.1.1 Plotting

Determines if plotting is to be performed when a measurement is performed or opened. Select one of the choices
below

A single window can have up to 8 plots (1 or 2 plots is normal), and if Plot in active window is selected the plotting
will take place in all plots in the active window. If Plot in all windows is selected, the measurement will be plotted in
all plots.

If you have only one window displayed, there is no difference between the last two alternatives (a new window can be
opened from Window->New Window...)
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18.12.1.2 Memory

Select one of the choices below

                 

This determines if the measurements that are not plotted should be kept in memory or cleared from memory. 

If you are to perform several hundred measurements, it might fill up the PC memory if  is selected and
the measurements are not cleared now and then. Measurements can be cleared by using Plot->Erase Curve(s)… if the
check box  is checked as shown below.

This prevents the memory to run full. It is useful if a repeated measurement is to be done. 

To sum this up, if  is selected the previous unplotted measurements will be cleared from memory after a
new measurement has been performed.

18.12.1.3 Export data

Data from the plot(s) can be exported file when a measurement is performed or opened. 

                 

Note: The exporting will be very slow if trying to export plots that contain many points (>30000 points). 

The options below can be selected.

18.12.1.3.1 Do not export

If  is selected, no data will be exported from the plot(s).

18.12.1.3.2 Export to text file

If  is selected, the data in the plot(s) will be exported after a measurement is performed or opened. The
filename of the text file depends on if the measurement is saved to file or not. If the measurement does not have a
filename, it is saved under the default folder given in Measurement-> Saving Defaults.... The filename is set to
“PlotMeasFromMem<Measurement number>.txt”. If the measurement has a filename, it is saved using the
measurement filename but with the extension .txt.
This is useful for batch-processing, e.g. if you want to compute the frequency response of several measurement files
and send the data to a text file. 
To do this, go to File->Open... and mark the measurements files you want to process (use the shift-key to mark
multiple measurements).

Click the  button shown below to open the export options. See the Edit->Copy Data Options… section for
more information.



18.12.1.3.3 Append to text-file

If  is selected, the data in the plot(s) will be appended to the specified file after a measurement is
performed or opened.

Click the  button shown below to specify the filename. In the example below, the data will be writte to the
file “C:\test.txt”.

18.12.1.4 Calculate parameters

If the check box  is checked, room acoustics parameters are to be computed after a measurement
is performed or opened. 

The parameters that can be selected are the same as the parameters found on the Calculate menu.

                                     

How the result is displayed is set in the Calculate->Calculation Options… dialog box as shown below.

The  option is useful for calculating the room acoustics parameters of one or several files and saving the
results in one operation. 

If the measurement has a filename, it is saved using the measurement filename(s) but with the extension .txt.

18.12.2When performing a measurement

 will add a delay (in seconds) after you start the measurement before
it is actually performed. If you have to prepare something before each measurement and you don’t have anyone to start
the measurement for you, this delay after starting the measurement may be useful.

 determines if the dialog box found in View->Volume and Input Levels(s)
dialog is to be displayed when a measurement is performed.

 determines if a new measurement is to be started after
performing a successful measurement. It makes it possible to perform several measurements without user interaction.

 determines if an executable file is to be run after a measurement is performed. The
name of the executable must be specified in the field below the check box. This may be used e.g. for controlling a
turntable of type B&K®. For information about this, run the file BKturntable.exe found in the WinMLS folder. This
file may only work with Windows 95/98.
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 adds a delay after the measurement has been performed. This may
be useful when several measurements are performed in automatic mode.

18.13Saving Defaults...

Displays the dialog box containing the defaults for saving measurements shown in the figure below. After a file is
saved the default folder, format, title, comment(s) and current counter is updated.

Click the  button to display the settings shown below.

18.13.1Default file-parameters

From here, the default file folder, name and extension is set. 

Note: The default filename for saving may in addition contain a number given by the Autoname generator, as will be
described below. A single channel measurement using the settings above will result in the suggested filename with full
path: c:\winmls2003\measurements\Default_1.wmb



18.13.1.1 Add extra tag to filename

If  is checked, you add additional information to the end of the file name. This is currently
used for sound insulation measurements, but may be useful in other situations where you need to perform several
measurements in different postions.
See the list below.

               

The list content can be modified by the user by editing the measurement setup file. The list value is updated when the
auto-name counter has reached its upper. If it is set to 3 as shown below

the files will be given the names

Default_LS1.wmb, Default_LS2.wmb, Default_LS3.wmb
Default_LR1.wmb, Default_LR2.wmb, Default_LR3.wmb
Default_BR1.wmb, Default_BR2.wmb, Default_BR3.wmb
Default_TR1.wmb, Default_TR2.wmb, Default_TR3.wmb

18.13.1.2 Format

Select the default format

           

If you select the *.wav format and if  is checked, the calibration may not be
maintained in all channels for a multi-channel measurement.

18.13.1.3 Multi-channel measurement tag

 gives the tag used for determining the filenames for a multi-channel
measurement. A 2-channel measurement would, using the settings shown in the figure above, get the following two
suggested filenames: DefaultCh1_1 and defaultCh2_1.
A multi-channel file will get the default name:
<default filename> + <multi-channel tab> + <channel number> + <_> + <measurement auto-numbering>
The reason for doing it in this order is to ensure flexible listing of the measurements in the Windows® file explorer.
When listing the measurements using date, the multi-channel measurements will be sorted by measurement number. If
you list the measurements using filename, they will be sorted by channel number since the channel is added before the
measurement number.
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18.13.2Default title and comments

Title and comments will be saved to the file header except for the .wmt format, which only saves the comment. The
title and comment fields can contain  80 and 60 characters, respectively.
The title will appear in the plot title if  is checked in Plot->Layout->Text Refreshing… and if
Plot->Layout->Title is checked on the menu.
The comment will appear in the plot title if  is checked in Plot->Layout->Text Refreshing…
and if Plot->Layout->Footer is checked on the menu.
For a multi-channel measurement, default comments may be given for each channel by clicking the

 button.

18.13.3Autoname generator

The autoname generator is used to automatically assign a number to the suggested measurement filename.

The first edit box  gives the start number of the auto-numbering. The second edit box  gives the number
where the auto-numbering ends. When this upper limit is reached, the auto-numbering wraps around. So if you are to
perform 8 measurements that should have the same name, but numbered 1 to 8, you should set this to 8. Then when
saving measurement number 9 the Saving Defaults dialog box will be displayed and you may change the default
name.

The current counter displays the current value for the counter. E.g. after successful saving of 5 measurements, the
counter will have the value 5.

18.14Export Stimulus...

The idea is to export the stimulus to a .wav-file to use it for remote measurements when it is impossible to connect the
sound card output.
Generally we recommend using a DAT-player to sample the output signal from the sound card instead of using this
feature (because of the small deviation in sampling frequency between input and output). 

If you export a single sweep, which we recommend, make sure the whole sweep is included when performing the
measurement. Do this by starting the sweep simultaneously with the measurement.

Currently it is only possible to export a sine sweep signal.



18.15Wizard->Start

If a wizard exists in the current WinMLS setup and is set to be used, this command will start the wizard from the first
step.

18.16Wizard->Editor...

From here you can make your own wizard or modify an existing wizard.

If  is checked, the Wizard will be used if it contains any wizard steps.

18.16.1Wizard Step dialog: Add a new wizard step

Click the  button to add a new wizard step.

As seen above, the text Untitled appears in the Wizard steps field. Double-click on Untitled to modify the wizard
step you added.

If this dialog box is opened from Measurement->Wizard->Options..., the Wizard step settings at the bottom is
included in addition to the part that the user can see.
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18.16.1.1 Insert title and text

Type the title and text as indicated in the upper part of the figure above.

18.16.1.2 Select image

Select the image you want the wizard step to contain from the list shown below

The desired images in the list shown above. If you cannot find your picture, you must move it to the folder shown
below e.g. using Windows Explorer. 

The common picture formats are supported: jpg, gif, emf, wmf, bmp, pcx, png and tee. Important note: The maximum
picture size is 220 pixels wide and 230 pixels long.

18.16.1.3 Select operation

Decide what operation you want to do when the  button is clicked, as shown below

Picture is
displayed here



If  is not selected, the setting shown below should be set to ‘1’ unless you plan to
perform more than one measurement before showing the next wizard step.

18.16.1.4 Lock program while wizard is shown

If  is checked, it is impossible for the user to access any settings in WinMLS, except
the wizard dialog itself. If it is unchecked, the user can use WinMLS while the wizard dialog is displayed. This is
useful if you want the user to change a setting in WinMLS before continuing to the next wizard step.

18.16.1.5 Show this wizard step

If  is checked, the wizard step is displayed to the user when the wizard is started.

18.16.1.6 Decide how many measurements to perform (if any) before displaying a new wizard step

If you have selected  you can ignore this setting.
Otherwise, WinMLS will show the next wizard step after a number of measurements. This is shown below.

18.16.1.7 Help ...

Decide what operation you want to perform when the ‘Help’ button is clicked as shown below

The  button will not be displayed in the wizard so the user can see it if the text field in the figure above is
not empty. In this field, you may specify one of the following

• a link to a web page, example: www.winmls.com
• an identifier that opens a page in the WinMLS help file. The identifier is composed by ‘IDH_’ plus the

heading name. If there are spaces or punctuations in the heading name, use ‘_’
example: If the heading is “Calculate Menu” you must write “IDH_Calculate_Menu”.
example: If the heading is “Load...”, you must write “IDH_Load___”.

• a file that exists on your hard disk, example: test.txt. Any file format is supported if you PC has the software
for opening the document. It is recommended to move these files to the subfolder named Docs in the folder
where WinMLS is installed. If you do this, you do not need to specify any path for the files and these

documentation files will be included if you export the setup. Click the  button to open a file from your
hard disk.

Click the  button to check if what you have specified is correct.

18.16.2Delete wizard step

Click the  button to delete the selected wizard step. 

Note: If you are not sure it really should be deleted, you can set a wizard step invisible. You find this option by

clicking the  button.
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18.16.3Edit wizard step

Click the  button to edit the selected wizard step.

18.16.4Move Up wizard step

Click the  button to move the selected wizard step one step up.

18.16.5Move Down wizard step

Click the  button to move the selected wizard step one step down.

19Plot menu
This menu contains the settings for plotting and post-processing related to that as shown below. 

The last three menu items have sub-menus as well. All menus and dialogs will be explained in detail below.

19.1 Erase Curves...

The dialog box shown below is displayed to erase curves.



You can erase all curves, or all invisible which is the curves that are not checked in the legend list (to display the

legend list, right click in the plot and make sure  is checked.) You may also erase all visible
curves.

19.1.1 More than one plot displayed

If you have more than one plot displayed, you may choose to erase curves in active plot or all plots as shown below

19.1.2 More than one window displayed

If you have more than one window displayed, you can also select if you want to delete all plots in all windows as
shown at the end of the list in the figure below.

19.2 Solo Curve

If you have several curves in the plot and want to display only one curve temporarily, this Solo Curve setting can be
used. If it is turned on, it hides all curves that do not belong to the active measurement. 

If there are several curves of the same active measurement, only the last plotted curve will be visible as shown in the
legend list below.

The other curves are not deleted from the plot, but are set as invisible. They may easily be set visible again by turning
Solo Curve off. If Solo Curve is turned off, the curves that were visible before Solo Curve was turned on are set
visible again.

Note that if Plot->Refresh... is selected with the setting shown below

or if Plot->Auto-Refresh... is set as shown below 

all the curves that are refreshed are set visible when Solo Curve is turned off. This is because when refreshing all
curves, it is likely that the user wants to display all the refreshed curves.

317



19.3 Add Curve(s)

Adds new curves(s) to the active plot (in case more than one plot is displayed). If the active plot is empty or contains
curve(s) from a only a single measurement, the curve is added without displaying any dialog. Then the curve is
computed from the active measurement and normally only one single curve is added. 

But if the active plot contains one or more measurements, the dialog box below is displayed allowing the user to select
to add a new curve based on the active measurement or to perform a statistical operation based on some of the plotted
measurements.

Click the  button to add the curve.

19.3.1 Active measurement curve

If active measurement curve is selected as shown below, the curve is computed from the active measurement

If a multi-channel measurement has been performed and is active, curves for all the channels are added. The curves are
always added to the current curves independent on the Plot->Overlay setting. If it is desired to remove the old curves
before adding new curve(s), then this can be done as described below by using Plot->Erase Curves....

19.3.2 Statistics

Displays the dialog shown below. 



If statistics is selected the user can select different statistical operations as shown below

                    

The curve(s) to be added is computed based on the previously plotted measurements. In the figure below we have
selected the four first measurement to be included.

 is checked, which means that each measurement is given an individual weight. If you do not need any
weighing, make sure  is not checked.

19.4 Overlay

If this menu-item is checked, the existing curves in the plot(s) will remain in the plot when a new curve is plotted. If it
is unchecked, the existing curves in the plot(s) will be deleted when a new curve is plotted. In WinMLS you may
change the settings for the curves you have already plotted using Plot->Refresh... or Plot->Auto-Refresh.... 

19.5 Overlay Settings...

The dialog box show below will be displayed
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The setting below is the same as Plot->Overlay.

                                        

The setting shown below is the same as Plot->Solo Curve.

                                        

19.5.1 Statistics (auto-update)

The statistics of the visible curves in the plot will automatically be computed if  is checked as
shown below.

Note that this setting depends on the selected plot type (e.g. phase or frequency response). This means that you have to
click in the plot to set it active and then open this dialog box to turn on the statistics.

You can select from three different types of statistics as shown in the list below.

Click the  button to open the curve styles dialog for the statistics curves as shown next.

19.5.1.1 Statistics Styles and Colors

Displays the dialog shown below.



The styles and colors is set for the Auto-statistics curve (which is the Mean value) and the Upper and Lower spread.

The color of the curves is set by clicking at the color field . The line width is selected from the line width

 list box. Note that if you are plotting statistics of a curve that consists of >50000 points (e.g. the time data
plot type), a line width larger than 1 will make the plotting slower.

The line style is selected from the line style  list box.

If plotting parameters that has only one value, the mean value will be displayed as the green line shown in the figure
below.

The statistics line in the figure above has numbers (marks) that display the value. This is set from Plot->Plot Type
Settings->Frequency Response/Spectrum…. In this dialog box, click the button shown below.

This will open a dialog displaying the settings shown below.

If  is checked, the numbers will be displayed.

19.5.2 More settings

19.5.2.1
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Clicking the button  is the same as selecting Plot->Plot Type Settings->Active Plot…
from the menu and displays the active plot settings. These settings are different for each plot type.

If you want this dialog box to always be displayed before adding a new curve, make sure

 is checked. This is useful for beginners and it is checked as default in WinMLS. Note
that this dialog box will not be displayed if the plot contains no curves.

19.6 Refresh...

Displays the dialog shown below.

You can decide to refresh only the active curve or all curves as shown below

            

19.6.1 All curves

 is the choice you should use to refresh all curves. This setting will refresh all curves. It should be used
when auto-refreshing is either turned off or if it is set to only refresh the active measurement curve. (the exception is if
you have added several curves of the same measurement as shown in the legend list below

In this case, only the most recent curve will be refreshed)

19.6.1.1 Refreshing in frequency domain

If you are plotting in frequency domain, the current time data window size is used when refreshing, even if
 is checked (found by clicking

 in Plot->Plot Type Settings->General Frequency Domain…). It is also
so that if a measurement has a shorter length than the current time window, zeropadding is used so that all

measurements will be calculated using the same Fourier Transform size when is selected.



19.6.2 Active curve

 is meant for use only when auto-refresh is turned off, see next section. The “manual” refreshing lets the
user decide when to refresh the curve belonging to the active measurement. 

19.6.3 In what plot is refreshing applied?

Further, you can select in what plots you want to refresh the curve(s), as shown below.

19.7 Auto-Refresh...

Displays the dialog shown below.

If  is checked, auto-refreshing is turned on. Auto-refresh will refresh the curve(s) if any settings
influencing the viewed plot(s) are changed. 
Examples of such settings are the plot type settings (push F5), the toolbar buttons influencing the plotting and changes
in time window size.

If  is selected, the active measurement curve will be refreshed when there is a change in the settings that
has an effect on the plot.

If  is selected, all measurement curves will be refreshed when there is a change in the settings that has
an effect on the plot.

If you want this dialog to be always displayed before adding a new curve, just make sure 
is checked. This is useful for beginners and it is checked as default in WinMLS.

Note: The settings in Plot->Layout->Edit... are not controlled by the auto-refreshing, as these settings are always
immediately updated. E.g. if you change the plot background gradient colors, the change will take effect immediately,
even before closing the dialog.

19.8 Plot Type/ Routing/ Test

The dialog shown below is important for advanced use of WinMLS, such as production control.
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This dialog box may seem complex. However, the following explanation should make it easy to understand.

19.8.1 Plots in window

WinMLS can display up to 8 plots simultaneously in a window. Below, two plots (double) is selected.

 

19.8.2 Stack plots

This setting only has effect when two plots are displayed.
 

 

If  is selected, the plots are displayed on top of each other as shown below.



If  is selected, the plots are displayed side-by-side as shown below.

19.8.3 Resizing

This setting only has an effect when two plots are displayed.

If  is selected, you can use the mouse to resize the plots as shown below.

19.8.4 Limit curve / Test options

Clicking the  button opens the dialog box shown below.
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19.8.4.1 Notify user of test result

If a test fails, there are several ways of notifying the user.

If  is checked, the background color in the plot will be changed if the test

fails. The “failed” color is set by clicking the  button.

If  is checked, a picture with the text Passed or Failed will be displayed in the plot
depending on if the test in the plot has actually passed or failed. 

The pictures used for displaying this text can be replaced if you wish to change the messages. The files are found in
the WinMLS setup subfolder named Charts and are named Failed.bmp and Passed.bmp.

A overall test may consist of separate tests in several plots. If  is checked,
a Message Box is displayed if one or more of the tests has failed.

19.8.4.2 Generate limit curves

The limit curves are based on a text file, the settings below determine how the limit curves are generated.



If  is checked, the limit curves are not absolute but instead
generated based on a reference measurement. To set the a new such reference measurement, click the

 button. 

The y-axis specified in the text file does not have to correspond to the y-axis of the data that is to be checked.
Therefore the limit curve must be interpolated to have the same y-axis. This can be done by the two methods shown
below.

                                          

We recommend using the Straight line (fast) interpolation since it is much faster.

19.8.4.3 Plotting of limit and error curves

These settings determine the layout in the plot.

If you want to display the limit curve in the plot, make sure that  is checked.

If  is checked, the part of the curve that is outside the specified limits will be given a
different color and line style. The colors and line styles is set clicking the button shown below.

Clicking the  button will display the dialog shown below for setting curve styles and colors.

The color of the curves is set by clicking at the color field . The line width is selected from the line width

 list box. The line style is selected from the line style list box .

19.8.5 Plot type

This list box contains the plot types (e.g. time data, phase response, frequency response, ...) shown in the figure below.
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19.8.6 Routing

The routing selects which channel of the measurement is to be routed to what plot. 

         

Select one of the settings below.

All channels will route all measurements to the plot. Ch. 1 will route only measurement channel 1 to the plot.

Note: This setting applies both to performed measurements and measurement files that are opened from file.

19.8.7 Limit curve

If any of the check boxes  are checked, testing will be performed for this plot. Click the 
button to select a file as shown in the figure below.

It is strongly recommended to put the limit curve files in the WinMLS subfolder named LimitCurves.

Click the  button to open the file in the default text editor as shown in the figure below.



Here you can edit the numbers. Remember to save the changes.

19.8.8 Reference measurement routing

This setting is used for setting the reference measurement that is used for performing complex division. It will only
have an effect on the frequency domain plot types.

If the  check box is checked, division will be performed.
The channel used for division must be selected, there are several options. In the example below, channel 2 is used for
division when a 2-channel measurement is performed

Click the  button to open the Plot->Plot Type Settings->General Frequency Domain… which contains
all the settings for the reference measurement.

19.9 Plot Type Settings: Overview

The plot type settings gives access to all the plot type settings as shown in the figure below.

The settings for each plot type will be explained in the following sections.
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19.10Plot Type Settings: Active Plot...

Displays the settings for the active plot type. Each of the plot types can also be accessed from the Plot->Plot Type
Settings menu.

It only one plot is displayed in the window, this gives the active plot type.
If two or more plots is displayed in the window, the active plot has a small frame around it.

19.11Plot Type Settings: General Frequency Domain Settings...

Displays the dialog box shown below containing settings that applies to all frequency domain plot types (e.g. phase
response, group delay).

19.11.1Active measurement settings

Gives the settings for the active measurement.

Click the  button to open the time window setting dialog (can also be
opened from Plot->Plot Type Settings->Time Window…).

19.11.1.1 Use Time Data processing before computing frequency response

 determines if the processing of the Time Data plot type is to
be applied before computing the frequency response. Note that if this is not checked, the DC-component is
automatically removed.



Click the  button to open the settings for the Time Data plot type, as shown below.

Only the Time Data Processing settings are enabled since the other settings have no effect in the frequency domain.
This dialog box is explained in the Plot->Plot Type Settings->Time Data.... reference documentation.

19.11.2Reference measurement

Contains the settings for the reference measurement.

19.11.2.1  Perform division

If checked, the active measurement is divided complex with the reference measurement. If the sampling frequency is
not the same for the active and the reference measurement, no division is performed and an error message is displayed.
The zero-padding size has to be the same for the two measurements or else the division will not work, also the zero-
padding size must be larger than the window size for both measurements to prevent truncation. Therefore the longest
Time Data Window of the two measurements is used as basis of finding the zero-pad size.

19.11.2.2 Use unique time window for reference measurement

If   is not checked, the time window settings for the reference
measurement is the same as for the active measurement and can be opened from the

 button.

In some measurements, the reference measurement time window should be set different than the active measurement
time window. An example is if the reference measurement has a very short duration but the active measurement has a
long duration. Then a shorter window should be applied to the reference measurement. To do this, make sure

 is checked and click the  button to set the time window.
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19.11.2.3 Select reference measurement

The reference measurement can be selected either from file or from the measurements available in memory.

If you want to select the measurement from file, first check , then click the  button to open the browser.
Note that the selected file is not added to the memory measurement file list.
If the measurement is selected from memory as shown in the figure above, it is possible to update the reference
measurement when a new measurement is performed by checking . See Plot->Plot
Type/Routing/Test... on how to set-up the routing.

19.11.2.4 Time window settings for Reference Measurement...

Clicking the  button opens the dialog box for setting the window size and
type for the reference measurement. This dialog box is similar to the button for setting the time window for the active

measurement , and refer to this to get more information.

19.11.3Fourier transform size

Selects the size of the Fourier transform for the active measurement and for the reference measurement if division is to
be performed. The choices shown in the figure below will be discussed.

19.11.3.1 Zeropad to lowest possible order of two

 gives the greatest speed since the Fourier transform is executed faster when the
length of the data is order of two (e.g. 1024 samples which is 2 to the order of 10). If the time window applied to the
time data does not have length that is an order of two, the data will be padded with zeros at the end to obtain this
length. E.g. if the length of the time window is 700 samples, zeros are added from sample 701 etc. to obtain the length
1024. 
Usually zeros are used for this padding, therefore this is usually called Zeropadding, but WinMLS does not pad zeros,
instead it pads the last value of the windowed data. This is done to prevent from errors in case the data has a DC-
component. 

Note: Because this method is applied, this setting should not be used with a Rectangular window on non-transient
data (this is not recommended in any case).

19.11.3.2 Exact same as Time Window 

 is used to get a Fourier size equal to the exact size of the time data window. This
may give slow execution if the size of the time data window is not an order of two.



19.11.3.3 Zeropad to a fixed number of samples

 is used to determine the exact size of the Fourier transform. Any number may be

typed in the  box. But the numbers on the list gives the best computational speed since they are an order of
two as shown below

An error message is given if the selected Fourier transform size is less than the size of the time data window. (The
same is true for the reference measurement time data window if division is to be performed.)

19.11.3.4 Frequency separation

 informs the user about the frequency separation given in Hertz, which is the distance
between each point along the frequency axis. The frequency separation is equal to the Fourier transform size divided
by the sampling frequency. 

19.11.4Various (5)

Contains frequency domain various settings.

If  is checked, the complex frequency response (after division, if division is selected)
is inverted. 
If  is checked, a vertical line is added to the frequency domain plot types as shown in the
figure below.

The “Frequency resolution line” will indicate graphically where the data should not be trusted. At the thick part of the
line, the results should not at all be trusted. At the thin part of the line (which is twice the size of the thick line), the
result is not certain.

The color of the line is set in Plot->Default Curve Styles…. The line refers to the active measurement curve.

If  is checked, a transfer function measurement is plotted in scope mode. This means
that only the scaling of the input is considered, and not the output scaling. This means again that if you have calibrated
correctly you can display the sound preassure level of a frequency response plot.
Note that this setting has an  effect on the scaling of all plots, not just the frequency domain plots 

 The scope mode setting  has no effect if the measurement is a transfer function.
But if the measurement is performed or set to scope mode, the choices shown in the figure below are available. 
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The settings will affect the scaling of the frequency response. If Stationary signal (power) is selected and the plot
type is Frequency Response/Spectrum, the power will be plotted. If the signal is a transient signal, this should not be
selected since the level will depend on the window and zero-padding length. To prevent this, select Transient signal
(energy).

If you select , which is strongly recommended, WinMLS determines the scope mode based on
the measurement settings.

19.11.5Averaging, time constant

Averaging using a time constant is be done if  is checked.

                                        

The default options are fast and slow as shown above, but the user may also type in any other number.

Note: The time constant currently only applies on data filtered using frequency domain filtering and not on time
domain filtered data.

19.12Plot Type Settings: Time Window...

Displays the dialog box shown below containing time window settings. The time window settings are used to
determine what part of the time data is used when computing the FFT (or frequency response).

19.12.1Measurement name

Displays the measurement the window is applied to. 

Note: If Plot->Refresh... is set to refresh all curves as shown below, all plotted measurements will be updated with
the new time window settings. This will give wrong results e.g. if the start of the time window not set to include the
start of the impulse response for all measurements.



19.12.2Window type

Selects the type of window to be used.

The possible choices are shown in the figure below. 

Note: If an impulse response is to be windowed, it is recommended not to use a full window since full window does
not include all of the first part of the signal. Normaly the first part is most important for the impulse response. For
impulse response measurements it is normal to use a Hanning/Cosine (half) or a Rectangular window.

19.12.3Window size

Determines the upper and lower window limits.

The unit  determines the units of the window limits to be displayed in the dialog box. The
following may be selected:

When the dialog is displayed, the selected unit is the same unit as selected in the Time Data plot type.

The desired lower limit can be typed as shown below. 

If your data is an impulse response, it is possible to detect the start of the impulse response by clicking the
 button.

The size of the window is then set by setting the upper limit or setting a fixed size as shown below.
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If you select Fixed size, the time window will always have the same size. This is useful in some applications. If the
fixed size specified here should extend the size of the measurement, the size will be truncated.

The button  is used to set the end of the measurement to the end window limit. This gives the maximum
frequency resolution.

19.12.4High-frequency window (short)

The decay time for transient signals varies as function of frequency. Using this option the time window size will
depend on frequency.

If  is checked, the window size of the high frequency part can be set different than the window size
of the low frequency part.
Usually the decay time for low frequencies is longer than the decay time for high frequencies. To remove the influence
on background noise it is therefore useful to apply a shorter window at high frequencies.
You can determine the length of this window:

You can also set the transition range where the low and high frequency windows overlap:

According to the settings above, the high frequency window of only 10 milliseconds is gradually applied from 70 Hz
and fully applied from 900 Hz.

Warning: This high-frequency window must only be applied on transient signals. On a stationary signal it makes no
sense and will give wrong results.

19.12.5When new measurement is set as active

You can also set the window to be automatically updated when a new measurement is opened as shown below.

Note that this is valid when you open a new measurement from File->Open..., but also if you select a new
measurement as active from Measurement->Information... or from the Measurement Selection toolbar.

If  is checked, the lower window limit is detected as the start of the impulse response. If you
are not measuring impulse responses you should not use this setting.

If  is checked, the upper window limit is set to the maximum value.



19.12.6Add to window in Time Data plot type

If  is checked, written information is added to the time window in the Time Data plot type as shown below

In the example below  was selected. If you instead select , the text will be displayed inside the
window as shown below.

If  is checked, a picture used for detecting echoes etc. should be displayed
as shown in the figure below.
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Note: This only works if the vertical axis is set to dB since the picture has dB as y-axis. For more details see How to
detect echoes from a measured impulse response? in the FAQ section.

19.13Plot Type Settings: Frequency Response/Spectrum...

Displays the dialog box shown below.

19.13.1Horizontal axis (6)

Selects the unit of the x-axis from one of the units displayed in the list shown below.

19.13.2Vertical axis

Selects the unit of the y-axis and the processing of the data from one of the choices displayed in the list shown below.

If several curves are plotted and the y-axis setting is changed, the curves will be updated using the Plot->Refresh...
procedure with the setting “All curves”.

19.13.3Compensation of Magnitude (frequency dependent level)

In the current version of WinMLS, the magnitude compensation is called microphone compensation because it is most
used to compensate for the microphone. 



(Note: The Reference compensation shown above is always disabled, it is not yet implemented).
In order to do the compensation,  must be checked, then the file containing the compensation data must
be selected from the list box

If no such file already exists for your microphone, it can be made.

The file must the frequency response (magnitude) of the microphone in dB and NOT the correction to be applied.

An example of the format of the file is shown below. 

Transfer Function Mag - dB
      Hz      Data
  13.81928   5.60038
  32.24499     5.60038
  101.3414,   5.372102
  400.7591,   4.776608
  10000.55,   2.880676
  12501.84,   2.386298
  15998.12,   1.588305
   20001.1,  -0.786294
  24999.08,  -5.802491

First an optional line containing the title, then an optional line with the title of each of the two columns, then the data
columns, frequency column first followed by the magnitude frequency response data. The data columns can be either
comma or tab-separated.

You can use any frequencies when specifying the file as long as they are increasing, spline interpolation is used to
calculate the needed frequencies. 

Note: Because of the spline interpolation you should not have a large frequency range where there are no values and
the upper and lower frequency must be present in the file (the lower frequency may be 20 Hz and the upper 20000 Hz).

The file must be saved with extension .txt and put in the WinMLs subfolder named Microphone Compensation. 

19.13.3.1 Multi-channel microphone compensation

Read this if you have a multi-channel version of WinMLS, if you are using multiple microphones simultaneously and
want to correct for the magnitude frequency response of each microphone. 
This is implemented using the _ch tag used for other multi-channel parts of the software. 

We will give an example of using four microphones, but it is very similar for 2 or 24 microphones. 
First generate a set of compensation files like explain in the section above. The filename must end with _ch and the
channel number:
Neutrik3382_ch1.txt
Neutrik3382_ch2.txt
Neutrik3382_ch3.txt
Neutrik3382_ch4.txt
etc…
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In the example above the microphone is obviously four Neutric 3382. If you have microphones of different brands find
a common name for them since the name part in front of _ch has to be the same. This is because WinMLS supports
more that one set of multi-channel microphones and uses the name part to keep them apart. 

Move these files to the WinMLS subfolder named Microphone Compensation. 

These will now be displayed as a single item named as neutrik3382_MultiCh1-4 in the list box shown below. Set this
as your selected choice.

Now you have seperate microphone compensation for 1, 2, 3 and 4 channel measurements.

Important note: This compensation applies when performing multi-channel measurements, but it will also be applied
correctly when opening .wmb and .wav files measured using WinMLS as well, since the channel number is stored in
the file header and WinMLS will use this info to find the corresponding microphone compensation file.

19.13.4Shift/Normalization

Makes it possible to shift or normalize the curve.

 determines the type of shift/normalization and has the possibilities shown and
explained below.

19.13.4.1 No shift or normalization

No shifting/normalization is performed.

19.13.4.2 Normalize maximum to 0 dB

The curve is shifted so the maximum value is 0 dB.

19.13.4.3 Fix frequency to level

The curve is shifted so that the specified frequency is given a specified value. In the figure below, the specified
frequency is 1000 Hz and at this frequency the curve is shifted so the value is 0 dB.



Note: If the vertical axis is set to Linear or Squared (energy), the shift will still be given in dB, so a shift of 0 dB will
give the value 1 at 1000 Hz if the vertical axis is Linear.

19.13.4.4 Shift level

If the vertical axis is set to dB, the shift will still be given in dB The curve is shifted, and the amount of shifting in dB
is given from the setting shown below.

If the vertical axis is set to Linear or Squared (energy), the setting will change as shown below

From above, we see that the curve can be multiplied with a factor and even subtracted by a value. Both multiplication
and subtraction is used in the setup for measuring loudspeaker impedance (it depends on how the circuit is connected).

19.13.4.5 Set average to 0 dB

Computes the average in the frequency range determined by the guideline lower and upper limit. see Guidelines
chapter below. The average is then subtracted so the average value will be 0 dB.

This can be useful when EQ-ing a sound system, where the goal is to obtain a flat magnitude frequency response and
the absolute level is not important. Using this setting, the deviation from a flat curve is read directly from the plot,
since the mean value is 0 dB.

19.13.5Type (2)

Select the type of frequency response/spectrum to be plotted if your measurement is an exponential sweep as will be
explained below. 

         

19.13.5.1 Magnitude

The magnitude of the complex frequency response is computed. 

19.13.5.2 Real part

The real part of the complex frequency response is computed. 

19.13.5.3 Imaginary part

The imaginary part of the complex frequency response is computed. 

19.13.5.4 1-Oct. Integrated

The level in octave bands is computed. 
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The computation can be done either in time domain or frequency domain dependent on the setting shown below

If IEC is selected, the octave filtering will be done in time domain and according to the IEC 1260 standard.
If Fast is selected, the octave band values are found first computing a FFT and then summing all the bins within the
octave bands using equal weighting. This method is typically faster, but the results are not exactly the same as the IEC
1260 standard.

19.13.5.5 1/3-Oct. Integrated

The level in one-third octave bands is computed. The settings are the same as for 1-Oct. Integrated shown in the
previous section.

19.13.5.6 Spec. Loudness (diffuse)

Loudness is calculated according to ISO 532B and DIN 4531. Use this “diffuse” method if your measurement
conditions is a diffuse field. 

19.13.5.7 Spec. Loudness (free)

Loudness is calculated according to ISO 532B and DIN 4531. Use this “free” method if your measurement conditions
is a free field.

19.13.5.8 Airborne Sound Reduction

Computes the airborne sound reduction. It will only work with a special sound insulation setup named
SoundInsulation_Airborne. So in order to calculate airborne sound insulation you need to load this setup and it is
also strongly recommended to read the documentation for this setup.

19.13.6General Frequency Domain Settings (2)

Click the  button to open the dialog that is also accessed from Plot->Plot
Type Settings->General Frequency Domain….

19.13.7Harmonic Distortion

This setting allows you to calculate harmonic distortion as function of frequency (if your measurement is an
exponential sweep as will be explained below).

If  is checked, harmonic distortion will be computed.
You can select either Separate or Power Sum as shown below

If Separate is selected, you can calculate and plot individual harmonic distortion components.

If Power Sum is selected, the selected harmonics are summed in one curve. Click the  button to open the
Harmonic Distortion Settings shown below.



19.13.7.1 The method for calculating harmonic distortion

When computing harmonic distortion using this method, the basis is an impulse response measured using a sine sweep
(exponential). The last part of this impulse response contains the harmonic distortion components if

 was checked in Measurement->Settings… when the measurement
was performed.
Note: The WinMLS distortion detection depends on the position of the time window lower limit. If your measurement
does not have a large delay, the time window lower limit can be set to 0 milliseconds. If your measurement has a delay
(> 1 millisecond), you can set the time limit manually or set it automatically using  the

 feature in Plot->Plot Type Settings->Time Window….
Note: If the time window upper limit is set to a value higher than half the length of the impulse response, it is
automatically reduced to the half length of the impulse response. This is to avoid the distortion part when calculating
the frequency response.

19.13.7.2 Harmonic Distortion Settings

Contains settings for computing harmonic distortion based on an exponential sweep measurement.

19.13.7.2.1 Select Harmonics

Select the harmonics you want to include by clicking while holding the <Ctrl> or <Shift> key.

Click the  button to select all harmonics.

19.13.7.2.2 Weights

The weights are displayed only if Power Sum (and not if Separate harmonics) has been selected. 
If  is checked, the harmonics are weighed using the weights shown below
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19.13.7.2.3 Divide with fundamental

If  is checked, the harmonic distortion is divided by the fundamental. This will calculate the
relative harmonic distortion.

If Linear is selected as vertical axis in the plot settings and  is checked, the harmonic distortion
is plotted in percentage [%].

19.13.7.2.4 Plot fundamental

If  is checked, the fundamental (the non-distorted frequency response) will be plotted in addition to
the harmonic distortion.
The fundamental is computed using the currently selected time data window.

19.13.7.2.5 Frequency resolution

This setting determines how much of the harmonic distortion component that is to be included in time domain. 

30 % as shown above is used as default in the standard setups. If this is increased, a longer sized window is used on
the distortion components. If a longer window is used, more noise will be included, but if a too short window is used,
the whole distortion impulse response may not be included. This can be inspected by plotting the impulse response on
a logarithmic vertical axis. 
It is also possible to calculate the effective decay range of each of the harmonic distortion components from the
Calculate menu. In order to do this, the time window must not be set manually and must be set to include the harmonic
distortion component to be evaluated. This is set in the dialog box opened by clicking the

 button in Plot->Calculation Options….

19.13.7.2.6 Upper frequency

A sound card may have problems with aliasing at high frequencies. To avoid these problems in the harmonic distortion
calculation, the upper frequency can be limited by setting a smaller percentage than 100. This will also limit the
frequency range of the result.

19.13.7.2.7 Interpolation type

Interpolation is used to compute the harmonic power sum.

Two types can be selected as shown below

Spline is the most accurate, but we recommend using Straight line since it is much faster.

19.13.8Smoothing

If the check box shown below is checked, frequency domain smoothing is performed.



The type of smoothing or integration is set from the  button and is described below.

19.13.8.1 Smoothing settings

The smoothing settings dialog is used for all the frequency domain plot-types (magnitude, phase, group delay,
waterfall). Each plot type has its own smoothing settings dialog box to keep the smoothing settings independent. The
smoothing settings dialog boxes are exactly the same for the plot types, except that only the plot type Frequency
Response/Spectrum has the  setting.

19.13.8.1.1 Smoothing bandwidth

Smoothing calculates the mean of frequency values over a sliding frequency band. The band is usually Octave (e.g.
one-third octave wide) to give an equal distribution along a logarithmic frequency axis. 

A Constant band may also be used and may be useful e.g. if a linear frequency axis is used to display the data.

The last setting Constant@low freq. – Octave@high freq does Constant bandwidth smoothing at low frequencies.

But from the  frequency Octave smoothing will be used.

19.13.8.1.2 Interpolate back to original data points

If  is checked, after smoothing, the calculated smoothed values are interpolated to
the frequency points used if no smoothing was applied.
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The advantage with the interpolation is that the curve will look smooth and nice. The disadvantage is that the
interpolation is rather slow. It should therefore not be used for real time applications.

19.13.8.1.3 Don’t smooth if too few data points

If  is checked it will avoid the stair-like shapes for low frequencies sometimes
seen if this option is not checked.

If the number of points within the smoothing window is less than 3, then the data is plotted without being smoothed. 

19.13.8.1.4 Power smoothing

Only the plot type Frequency Response/Spectrum has this  setting. Smoothing in power instead of
magnitude is a widely used method of smoothing, but some prefer to . 

19.13.8.1.5 Smooth over [octaves]

 Determines the smoothing bandwidth in octaves. You can type a value or
chosen from the list. This setting is visible and used if the smoothing type Octave or Constant (low freq.) - Octave
(high freq.).

19.13.8.1.6 Smooth over [points per division]

Determines how many points are to be computed within each division (octave).
You can type a value or chose from the list. If octave smoothing is selected, it gives the number of points within the
octave fraction band specified (see Smooth over [octaves]). There are more points at high frequency when plotting on
a logarithmic x-axis, but using this method we end up with a constant number of points over the whole frequency
range. 
If the smoothing type Constant is selected, it gives the number of points within the constant band specified (see
Smooth over [Hz]).
If the number is larger than 1, it is the same as doing a sliding window smoothing because the windows will overlap.

19.13.8.1.7 Smooth over [Hz]

 This setting is visible and used if the smoothing type Constant or Constant
(low freq.) - Octave (high freq.) is selected. It determines the constant smoothing bandwidth in Hertz. The value may
be typed or chosen from the list.

19.13.8.1.8 Start octave smoothing at [Hz]

 This setting is visible and used if the smoothing type Constant (low freq.) -
Octave (high freq.) is selected. It determines the frequency where the octave band smoothing starts. Below this
frequency, Constant smoothing is applied.

19.13.9Guidelines

If  is checked, guidelines are added to the active measurement curve. If it is unchecked, guidelines that
are in the plot will be deleted.

Click the  button to open the guideline settings described below.



19.13.9.1 Guidelines settings

Guidelines for displaying maximum gain, minimum gain, average gain, and up to four different average gain offsets
are supported.

19.13.9.2 Frequency range

Sets the frequency range where the guidelines are to be displayed. The maximum guideline frequency is truncated if it
is greater than the maximum frequency of the active plot. 

19.13.9.3 Display numerical values

Determines if numerical values are to be displayed on the guidelines and if they are to be transparent or have a yellow
field around the value.

19.13.9.4  Maximum Gain

If checked, a horizontal line is drawn where the maximum of the active measurement magnitude frequency response
curve is found within the frequency range given by the minimum and maximum frequency.

19.13.9.5  Minimum Gain

If checked, a horizontal line is drawn where the minimum of the active measurement magnitude frequency response is
found within the frequency range given by the minimum and maximum frequency.
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19.13.9.6  Average Gain

If checked, a horizontal line is drawn where the average of the active measurement magnitude frequency response is
found within the frequency range given by the minimum and maximum frequency.

Note: The average is computed from the plotted data (e.g. if the data are plotted in Decibels, the average will be
computed from the Decibels data).

19.13.9.7 Average gain offsets

Four average gain offsets are available.
If  is checked, a horizontal line will be drawn at the average value added an offset given by

the  setting to the right of the check box.

19.13.9.8 Guideline style

The color of the guidelines is set by clicking at the color field . The line width is selected from the line width

 list box. The line style is selected from the line style list box .

19.13.10Values as Marks

If  is selected, the values will be displayed as marks in the plot with the specified decimals

An example on using marks with 1 decimal is shown below

19.14Plot Type Settings: Phase Frequency Response/Function...

Displays the dialog box shown below.



The phase is influenced by the sound card response. This may be removed by using channel 2 as reference or the
measurement system correction feature. Most sound cards have a delay of some samples that give a linear phase shift.
It is possible to remove a pure delay by using the delay removal and subtraction features of this dialog box.

The microphone will also influence the phase, to get an accurate phase, use a precision microphone with as high a
bandwidth (higher than the measurement frequency range) and flat frequency response as possible.

19.14.1Horizontal axis (46 (2)

Selects the unit of the x-axis from one of the units displayed in the list shown below.

19.14.2Vertical axis (2)

Selects the unit of the y-axis and the processing of the data from one of the choices displayed in the list shown below.

If several curves are plotted and the y-axis setting is changed, the curves will be updated using the Plot->Refresh...
procedure with the setting “All curves”.

19.14.3General Frequency Domain Settings (3) 

Click the button  to open the dialog box also accessed from Plot->Plot Type
Settings->General Frequency Domain….

19.14.4Phase type

Selects the type of phase from the list below.
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Minimum and excess phase are viewed unwrapped and smoothing (explained below) is performed as the last
computation if it is checked.

19.14.4.1 Wrapped phase

Restricts the phase range to –180 to +180 degrees, or –π to + π if radians is chosen as y-axis. The phase of a
measurement will usually exceed this range, which results in jumps in the phase.

19.14.4.2 Unwrapped phase

The unwrapped phase is not restricted to the wrapped range, and has no jumps. The unwrapped phase is computed
from the wrapped phase by changing absolute jumps greater than 180 degrees to their 2*180 degrees complement. 

Note: If the phase curve is not smooth, the computation of unwrapped phase may give a wrong result. Because of this,
it is not recommended to select unwrapped phase when displaying the phase of a room measurement.

19.14.4.3 Minimum phase

The minimum phase is computed by taking the Hilbert transform of the log magnitude frequency response. If a system
is minimum phase this means that for a given frequency response, the input energy will be transferred to the output in
the least amount of time.

19.14.4.4 Excess phase

The excess phase is the difference between the actual phase and the minimum phase, the phase shift in excess of the
minimum phase shift. 
For excess phase measurements the phase influence of the microphone can usually be ignored since a microphone
usually has a nearly minimum phase response.

19.14.5Smoothing (2)

If the check box shown below is checked, frequency domain smoothing is performed.

The type of smoothing is set from the  button and is described in the frequency response/spectrum plot type
Smoothing settings.

19.14.6Remove delay in frequency range

If  is checked, the delay is removed in the frequency range specified below 

If the example above are used, the delay is removed in the range 50-10000 Hz. If Subtract delay (that will be
discussed below) is used together with this option, the delay is first removed in the specified frequency range, then the
delay is subtracted.



19.14.7Subtract delay

If  is checked, the specified delay  is removed. If Subtract delay and Remove delay in
frequency range (described above) is used together, the delay is first removed in the specified frequency range and
finally the delay is subtracted.

19.15Plot Type Settings: Group Delay...

Displays the dialog box shown below.

Group delay is the derivative of the phase with respect to frequency. The numerical derivation is performed by taking
forward differences on left and right edges and taking cantered differences on interior points.

19.15.1Horizontal axis (3)

Selects the unit of the x-axis from one of the units displayed in the list shown below.

19.15.2Vertical axis (3)

Selects the unit of the y-axis and the processing of the data from one of the choices displayed in the list shown below.

If Milliseconds – Logarithmic is selected, note that the logarithm of negative group delay values cannot be computed.
If negative values exist, they can not be plotted.

19.15.3General Frequency Domain Settings (4)  

Click the button  to open the dialog box also accessed from Plot->Plot Type
Settings->General Frequency Domain….
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19.15.4Type (3)

Selects the type of phase from the list below

19.15.4.1 No processing (3)

No processing of the group delay is performed.

19.15.4.2 Minimum group delay

The minimum group delay is computed as the derivative of the minimum phase frequency response.

19.15.4.3 Excess group delay

The excess group delay can be used to check time alignment in speaker system. It is computed as the derivative of the
excess phase frequency response.

19.15.5Smoothing (3)

If the check box shown below is checked, frequency domain smoothing is performed.

The type of smoothing is set from the  button and is described in the frequency
response/spectrum plot type Smoothing settings.

19.16Plot Type Settings: Waterfall...

Displays the dialog box shown below.



19.16.1Horizontal axis (4)

Selects the unit of the horizontal axis from one of the units displayed in the list shown below.

19.16.2Vertical axis (4)

Displays the unit of the vertical axis. Only Decibels is supported.

19.16.3Depth axis

Selects the unit of the depth axis (z-axis) from one of the units displayed in the list shown below.

19.16.4Waterfall layout

Settings for determining some of the waterfall layout properties.

Other layout settings such as zooming, rotation, elevation, offset are found in Plot->Layout->Edit... under the 3D tab
as shown below.

In order to set the Rotation and Elevation, make sure  is not checked.
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19.16.4.1 Mode (2)

Selects what the waterfall should look like.

Three choices are possible as shown below.

19.16.4.1.1 Separate lines waterfall

The waterfall plotted as separate lines. In the example below the line type  is selected in Plot-
>Layout->Curve Styles and Colors….

The first advantage of this mode is that slices containing more than 2000 points can be plotted. This is currently not
possible with the other modes, so if more than 2000 points are tried to be plotted WinMLS will give a warning and
automatically switch to this mode.

The second advantage of this mode is that the  and  buttons on the Active Plot Type Toolbar can be used to
set the active slice for reading cursor values on the Status Bar (displayed at the bottom of the WinMLS area as shown
in the figure above).

19.16.4.1.2 Waterfall

The waterfall is plotted using horizontal slices as shown in the figure below. The figure is transferred from WinMLS
using File->Copy Plot with Edit->White background checked.
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The mode waterfall has a limit of 2000 points in each slice. To get within this limit we recommend using smoothing
with the setting  unchecked.

In the figure below, we see another example of waterfall in this mode.
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In the figure below, the layout is changed. The ortogonal function is turned on. If you prefer this layout, go to Plot-
>Layout->Edit... and check the  check box shown below.
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19.16.4.1.3 Surface

The waterfall is plotted using lines from all the neighbouring data-points as shown in the figure below. The figure is
transferred from WinMLS using File->Copy Plot with Edit->White background checked.
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The mode surface has a limit of 2000 points in each slice. To get within this limit we recommend using smoothing
with the setting  unchecked.

19.16.4.1.4 Spectrogram (ColorGrid)

Added new layout mode Spectrogram (ColorGrid). With this mode it is only possible to view the frequency axis as
linear and without smoothing. If not, the result will be wrong.
But this is useful for viewing low-frequency data, e.g. when looking for standing waves. 

Note: The vertical axis is the time axis and the horizontal axis is the frequency axis. The level is given by the color
only, indicated in the legend list. 
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To plot the data without using smoothing (it reduces the number of data points and we cannot plot more than 2000
points), select a portion of the data that you want to plot in Plot->Layout->Advanced.... In the plot above, only the
first 1000 points were plotted which is sufficient for the low frequency range.

19.16.4.2 Perspective

If  is checked, the waterfall plot is turn around so the start of the time axis is first
displayed.

19.16.4.3 Display plotting of each slice

If  is checked, each slice will be plotted right after it has been computed. 

Note: If it is checked, the plotting will take more time since if it is unchecked, all slices will be computed and then
plotted in one operation.

19.16.5ETF parameters

Determines the special settings for the Energy-Time-Frequency mode. The special settings determine size of the data
used for computing each slice (FFT size) and the window type applied on each of the slices. Note that no zero-
padding is applied in Energy-Time-Frequency mode. The DC-component, if any, is not removed from each slice.

19.16.5.1 Window type (2)

Select the window type to be used for computing each of the slices. The choices are displayed below.



19.16.5.2 FFT size

Select the length of the data to be used for computing each of the slices using the Fourier transform. The number must
be specified in samples, it can be typed or chosen from the list. The resulting length in milliseconds is also displayed.

19.16.6Mode (3)

Sets what type of waterfall plot is to be displayed.

The choices are displayed and explained below.

19.16.6.1 Energy-Time-Frequency (ETC)

The Energy-Time-Frequency mode is the same as a spectrogram. The data used for computing the waterfall is the
windowed measurement data. Push <Ctrl> + <w> to open the time window settings.
The windowed measurement data are divided into slices and the Fourier transform is computed for each slice. Special
settings for this mode are found in the bottom right of this dialog box under ETF Parameters. The special settings
determine the size of the data used for computing each slice (FFT size) and the window type applied on each of the
slices. 

Note: No zero-padding is applied in computing Energy-Time-Frequency mode. The DC-component, if any, is not
removed from each slice.

19.16.6.2 Cumulative Spectral Decay (CSD)

This mode is generated by computing the FFT of successively left-shifted versions of the windowed measurement
data. The first slice is exactly the same as plotting the magnitude frequency response (Frequency
Response/Spectrum plot type). This is because the FFT size and time window on the data is the same in General
Frequency Domain Settings. (Push <Ctrl> + <w> to open the time window settings).The next slices are computed by
shifting this window (successive slices are shifted). The size of the shift is specified in FFT Shift. The number of
slices is determined by Cycles (number of slices). The computation does not stop if the end of the measurement is
reached. The DC-component is removed from each slice. This is done by subtracting the DC-component of the last
half of each slice.

19.16.7Cycles

Determines the number of slices to be displayed.

If Cumulative Spectral Decay (CSD) is selected as waterfall mode, the number of slices to be plotted is set here. 
If Energy-Time-Frequency (ETC) is selected as waterfall mode, the number of slices to be displayed is set by the time
data window (push <Ctrl> + <w> to open the time window settings.). 
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19.16.8FFT shift

Sets how many samples the slices are to be shifted before computing the magnitude frequency response on the
measurement data. The number is also displayed in milliseconds as shown below. 

19.16.9Floor

Determines if a floor is to be used and where to set the floor. The purpose of the floor is to make the waterfall plot
look nicer. The waterfall data having values lower than the floor limit, e.g. –60 dB will be given this value. The floor
is thus not the same as the y-axis minimum value.

Three choices are available as shown below.

19.16.9.1 No floor

The waterfall is displayed without any floor. 

19.16.9.2 Use floor:

Floor is used and the floor limit is determined using the dB setting . 

19.16.9.3 Auto

Floor is used and the floor limit is determined automatically so that a percentage of the last part (20 percent) of the
measurement data, given by , will be a part of the floor.

19.16.10General Frequency Domain Settings (5)    

Click the button  to open the dialog box also accessed from Plot->Plot Type
Settings->General Frequency Domain….
When the dialog is opened, note that the settings that do not apply to the waterfall plot type are disabled.
If complex division using the reference measurement is selected in Plot->Plot Type Settings->General Frequency
Domain…, the resulting complex frequency response is inverse Fourier thus performing deconvolution. The
deconvolved measurement is used for the waterfall computation. The window limits for the deconvolution are set by
the window settings. But if Cumulative Spectral Decay is chosen as mode, the Time Window upper limit for the active
measurement is set as the end of the measurement. 

19.16.11Smoothing (4)

If the check box shown below is checked, frequency domain smoothing is performed on each slice.

The type of smoothing or integration is set from the  button and is described in the Frequency
response/Spectrum plot type 



19.16.12Waterfall microphone compensation

If  is checked, the microphone compensation specified in the Frequency
response/Spectrum settings (Plot->Plot Type Settings->Frequency Response/Spectrum…) is used for the waterfall
plot also.

Note: Each frame is compensated for when the microphone magnitude response is enabled.

19.16.13Reference to slice

If  is checked, the selected slice (in the figure below slice number 1) is used as reference. All slices
will be viewed as differences to the reference slice. The reference slice will therefore be flat.

19.16.14Shift magnitude

If  is checked, the magnitude is shifted in dB given by 

19.17Plot Type Settings: Room Acoustics...

Displays the dialog box shown below.

Room acoustic parameters, such as reverberation time and speech transmission index can be plotted.

19.17.1Calculation Settings

The types of acoustical parameters that may be computed and displayed are shown below. 
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The parameters shown in the list above are explained in the documentation for the menu item Calculate->User
defined: Settings....

When plotting a parameter that has only one value (e.g. STI), the x-axis is set to linear. When plotting a multiple value
parameter (e.g. Reverberation time in octave bands), the x-axis is set to logarithmic. As default the x-axis displays the
octave band values, but it is possible to change the axis labels and gridlines. On how to do this, see the How to change
the horizontal axis of the Room Acoustics Parameters plot type? section.

Clicking  opens the same dialog box as Calculate->Calculation Options… .

Clicking  opens the same dialog box as  Calculate->User defined->Settings….
The settings in the dialog box that are not used for the plot type are disabled.

19.17.2Plot layout

If the  check box shown below is checked, values of parameters that have an
effective-decay-range (edr) that is less than the number specified below will not be displayed.

If  is checked and  is not checked, the value
of the parameter is added as marks above the plot points as shown in the figure below. 



Alternatively, the edr can be displayed in the plot as numbers in the plots as shown in the figure below if
 and  are both checked.

If  is checked, the mark is transparent and not yellow.

Transparent mark:                    Yellow mark: 

19.18Plot Type Settings: Parameter...

Displays the dialog box shown below.
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Note: If auto-refresh is turned on, this plot type may not be automatically refreshed for all kinds of changes in the
settings which is the case with the other plot types. If the plot is not refreshed, use Plot->Refresh... to refresh the
curves if you have changed a setting that you believe has not caused the curves to be auto-refreshed.

19.18.1Type of parameter to plot

The type of parameter is selected as shown below.

The choices are displayed below. 

19.18.1.1 RMS 

Computes the RMS value of the time data specified by the Time Data window.

Note: In order to compute the corrrect RMS value of the sound card input signal, the input must be calibrated (see
Measurement->Calibration...) and the measurement must not be in transfer function mode (e.g. a MLS measurement
will consider the output at well).

19.18.1.2 Energy

Computes the energy of the time data specified by the Time Data window.

19.18.1.3 Linear sum

The linear sum of 1/3-octave frequency bands is computed and displayed. The frequency range is determined in the
1/3 octave frequency range settings.

If the measured data is a transfer function (for example measured with MLS output signal), the data are corrected for
the output signal so that the value for the input only is computed. This makes it possible to plot the input level and is
why it is called scope mode. Two types of scope mode is supported, either Stationary signal (power) or Transient
signal (energy). The scope mode settings are found in the lower right of the dialog box displayed after clicking

 as shown in the figure below.

If you are measuring impulse responses, Transient signal (energy) should be selected.

Note that the correct absolute value is given only if the absolute level of the input is calibrated. In Measurement-
>Calibration...., click the Settings... button as shown below.



Note also that if Microphone compensation is turned on in Plot->Plot Type Settings->Frequency
Response/Spectrum... as shown below,

then microphone compensation will also be used in when computing the frequency response for the Parameter plot
type.

19.18.1.4 dBA

The dBA-weighed sum of 1/3 octave frequency bands is computed and displayed. The computation is done as
explained in the Linear sum section above.

19.18.1.5 dBB

The dBB-weighed sum of 1/3 octave frequency bands is computed and displayed. 
The computation is done as explained in the Linear sum section above.

19.18.1.6 dBC

The dBC-weighed sum of 1/3 octave frequency bands is computed and displayed. 
The computation is done as explained in the Linear sum section above.

19.18.1.7 Delay (time of flight)

Used to find the delay in milliseconds of an impulse response.
The algorithm to find the delay used here is very simple. The maximum value of the impulse response is found and the
time where this maximum value occurs is the delay.
This should work well where the direct sound is strong, but will not give correct results if later reflection is stronger
than the direct sound.

19.18.1.8 THD + N (internal sinusoid)

Use this to compute THD+N if the sinusoid is generated from WinMLS. 

19.18.1.9 THD (internal sinusoid)

Use this to compute THD if the sinusoid is generated from WinMLS. 

19.18.1.10THD + N (external sinusoid)

Use this to compute THD+N if the sinusoid is generated from another source than WinMLS. 

19.18.1.11Level[Fundamental frequency]

Use this to compute both the level of the fundamental and the fundamental frequency. Plots the level as y-axis and
fundamental frequency as x-axis. 

19.18.1.12Level[# of measurements]

Use this to compute the level of the fundamental frequency.

19.18.1.13Polarity

The polarity plots the value 1 if the polarity is positive and the value -1 if the polarity is negative. In the figure below,
3 measurements are plotted, the blue has positive polarity, the red has negative polarity and the pink has positive
polarity.
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The polarity check is simply performed by computing the maximum and minimum values of the time data and
comparing these.
Note: Under difficult conditions this check may not always give the correct result. To be sure, you should inspect the
impulse response manually.
You can select that you want to calculate the polarity from the impulse response. Or you can set WinMLS to first
compute the step response before computing the polarity. This is set from the Time Data plot settings and will be
explained below. 

The polarity testing also depends on the Time Data time window. Therefore it is important that you make sure that the
time window is set so that the part you want to use for the polarity check is included in the time window as shown in
the figure below (<Ctrl>+<Shift>+<w> opens the time window settings).

You can also perform calculations on the impulse response, the most used operation is to integrate it to obtain the step
response. Click F5 while the Time data plot is active to open the plot type settings (if the time data plot is not

displayed, you can toggle the  button on the Plot Toolbar to display one more plot, and select the Time Data plot
type in this plot).

The type in the figure above should either be set to No processing or Integral (Step response) as the example above



Note that the other settings (DC-component and filtering) will also be included when finding the polarity.
If you do not want this to be included when finding polarity but do want it in the Time Data plot, you can turn it off
from Plot->Plot Type Settings->General Frequency Domain…, make sure

 is turned off as shown below.

19.18.2Time Data processing

Determines how the measurement data is processed when computing RMS or Energy.

If  is checked, the measurement data will be processed according to the settings

obtained by clicking . These settings are described under Plot->Plot Type Settings-
>Time Data.....

Clicking  gives access to the time window settings determining what part of the
measurement data to be used for the computation and the window applied to the measurement data.

19.18.31/3 octave frequency range

Determines the frequency range used for computing the Linear sum, dBA, dBB and dBC.

Clicking  gives access to the settings for computing the octave bands. The frequency
response data are integrated to obtain the energy in each band.

19.19Plot Type Settings: Time Data…

Displays the dialog box shown below.
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19.19.1Horizontal axis (5)

Selects the unit of the x-axis from one of the units displayed in the list shown below.

The chosen unit is also used in the user interface, e.g. as unit for the time window.

When the x-axis is changed, the upper and lower limits are will be properly scaled so the same segment of the curve(s)
will be displayed. If several curves are plotted and the x-axis setting is changed e.g. from Time [samples] to Time
[ms], the curves will automatically be updated using the Plot->Refresh... procedure with the setting “all curves”.

19.19.2Vertical axis (5)

Selects the unit of the y-axis and the processing of the data from one of the choices displayed in the list shown below.

When the y-axis is changed, the upper and lower limits will be auto-scaled to make sure the curve(s) are appropriately
viewed. If several curves are plotted and the y-axis setting is changed, the curves will be updated using the Plot-
>Refresh... procedure with the setting “all curves”.

19.19.3Vertical axis scaling

 Three types of scaling of the time data is supported as shown below.

No scaling – no scaling of the measurement.
Normalize – the measurement is normalized.
The amplitude of the absolute value of the time data is set to 1 if the y-axis is Linear or Squared (Energy). It is set to
0 dB if the y-axis is dB. If performing a 2-channel measurement, do not use this normalization setting if it is desired to
see the difference in levels between the impulse responses.



Scale by:  - scales the measurement with the given factor. If the y-axis is Linear, the
measurement is multiplied with the factor. If the y-axis is Squared (Energy), the measurement is first squared and
then multiplied with the factor. If the Y-axis is dB, the measurement is shifted (not scaled) with the factor.

19.19.4Velocity of sound 

Gives the velocity of sound and the unit.
Two units may be chosen:

The velocity of sound is used to compute the x-axis unit if Distance [meter] or Distance [feet] is chosen for the time
domain plot types. It is also used to compute the quarter, half and whole wavelengths displayed in the Status Toolbar
for the frequency domain plot types.

If you are performing vibrational measurements, e.g. using an accelerometer instead of a microphone, it is the velocity
of propagation in the structure that is to be typed. It is named velocity of sound because most users will measure with
a microphone.

Note that changing the velocity of sound in this dialog box will also affect the other time domain plot types, such as
energy-time-curve.

The speed of sound, denoted c, may be found if the temperature is known using the formula

c = (331.4 + 0.6*T)

where T is the temperature in centigrade.

19.19.5Time window

If  is checked, the time data window is displayed in the Time Data plot type as shown below.
The time data window consists of the three yellow lines and it is valid for the active measurement (there may be more
than one measurement in the window and these may have different time data windows).

The window start and end points can be set directly by clicking and dragging with the mouse. In order to do this, move
the mouse pointer on top of the vertical line that is to be moved. The mouse pointer will change shape when it comes
near the limit.
In order to make sure auto-scaling of the y-axis can be maintained, the vertical start and end lines are kept within the
curve area. The whole window is thus visible if auto-scaling is used.

Click the  button to access the time window settings Plot->Plot Type Settings-
>Time Window….
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19.19.6Remove DC-component (0 Hz)

If  is checked, the DC-component will be removed when plotting. 
The DC-component is removed by subtracting the DC-component of the last half of the measurement data.

19.19.7Processing Type

 This contains the processing options explained below

19.19.7.1 No processing (2)

No extra processing is done on the measurement data.

19.19.7.2 Integral (Step response)

Integrates the measurement data. If the measurement is an impulse response, the result is a step response. This is
because the integral of an impulse response is a step response. It is also useful if you are e.g. measuring velocity but
want to plot displacement.
When performing integration, the DC-component should be removed, so make sure  is
checked.
Instead of using this integration option, you may also use the plot type named Integrated Time Data (Step
Response).
The numerical integration is performed by cumulative summing of the elements. This gives a time shift error of one
half sample which gives a linear phase shift. No correction for this is performed, but it may be done using the
Subtract delay check box in the phase response/function plot type settings. 

19.19.7.3 Double integral

Computes the double integral of the measurement data. This is useful for example if you are measuring acceleration
but want to display displacement. 
When performing the double integration, the DC-component should be removed, so make sure

 is checked.
The numerical double integration is performed by twice cumulative summing of the elements.

19.19.7.4 Derivative

Computes the derivative of the measurement data. This is useful for example if you are measuring displacement but
want to display velocity.
The numerical derivation is performed by computing forward differences on the left and right edges and computing
cantered differences on interior points.

19.19.7.5 Double derivative

Computes the double derivative of the measurement data. This is useful for example if you are measuring
displacement but want to display acceleration.
The numerical double derivation is performed by computing the derivative as described above twice.

19.19.7.6 Cumulative energy

Computes the cumulative energy of the measurement data.
The computation is performed by first computing the energy, then cumulative summing of the energy elements.



19.19.8Filtering

If  is checked, filtering of the measurement is performed according to the filtering options

 as shown below.

19.19.8.1 Type of filtering

Selects the type of filtering from the list below

A BandPass filter lets the frequencies within a band pass and suppresses the other. A BandStop filter suppresses the
frequencies within a band and lets the other frequencies pass. A LowPass filter lets low frequencies pass and
suppresses the high frequencies. A HighPass filter does the opposite.

The room acoustics bandpass settings shown in the figure above need some extra explanation.

19.19.8.1.1 Room Acoustics Bandpass settings

The difference between BandPass and RoomAcoustics Bandpass is that the RoomAcoustics Bandpass is using only
the standard filter order, frequencies and bandwidths.

The BandPass/BandStop filter settings looks as shown in the figure below.

See the BandPass/BandStop filter settings section below for details.

19.19.8.2 LowPass/HighPass filter settings

This group contains the settings if the type LowPass or HighPass has been selected as shown below.

371



 specifies the cut-off frequency of the filter. Any frequency may be typed or selected from the
list of standard 1/3-octave frequencies.

 Specifies the filter order. The order is selected from the list and has the range 1-14.

 Specifies the filter type. You can select from the two types shown below

Select the type Butter Forward if you want a traditional filter function. If you select Butter Forward/Reverse the
filtering will be performed once forward and once backwards. Thus there will be zero phase distortion and the filter
order will be doubled.

19.19.8.3 BandPass/BandStop filter settings

This group contains the settings if the type BandPass or BandStop has been selected as shown below.

If BandPass is the filter type and  is checked, several bands may be filtered and thus
several curves are plotted depending on the start and stop frequency and the octave fraction bandwidth. How to
determine the bands is explained below. 
Note that if Filter several bands is checked, you should note that if Plot->Overlay is checked, many curves will be
generated.

 Determines the centre frequency. Any frequency may be typed or it may be
selected from the list of standard 1/3-octave frequencies. If  is checked and the filter
type is BandPass, two frequency values are to be selected, the start and end centre frequencies as shown below. 



The number of curves to be plotted within this frequency range is given by the bandwidth described below. If the
bandwidth is set to 1 octave or 1/3 octave, the standard frequencies within the specified frequency range is used. For
other bandwidth settings the centre frequencies are calculated beginning at the start centre frequency.

 Determines the filter octave bandwidth. Any bandwidth may be typed or it may be
selected from the list. A bandwidth of 1 octave or 1/3 octave is typically used.

 Specifies the filter order. The order is selected from the list and has the range 2-
14, only even numbers. Filter order 6 is according to the IEC standard. If the order is greater than 6 it does not give a
stable result for low frequencies, e.g. filter order 8 and bandwidth 1/3-octave will not give a stable filter below a centre
frequency of 350 Hz.

 Specifies the filter type. You can select from the two types shown below

Select the type Butter Forward if you want a traditional filter function. If you select Butter Forward/Reverse the
filtering will be performed once forward and once backwards. Thus there will be zero phase distortion and the filter
order will be doubled.

19.20Plot Type Settings: Integrated Time Data (Step Response)...

Displays the dialog box shown below.

The settings are explained in the  Plot->Plot Type Settings->Time Data.... section.

19.21Plot Type Settings: Energy-time Curve

Displays the dialog box shown below
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Most of the Energy-time Curve settings and explained in the  Plot->Plot Type Settings->Time Data.... section. The

Energy-time Curve the vertical axis can only be plotted in dB. The vert. axis scaling is here set to  which
is the most common way to view the Energy-time Curve. The Frequency Domain Windowing settings are also
unique for this plot type and are explained below.

19.21.1Frequency domain windowing

The Energy-time Curve is computed by first transforming from time domain to frequency domain. 

If  is checked, this transform is performed faster using a Fourier transform with a data length of an order of two.
The data are padded with zeros to get this length. This may introduce an error if the signal contains a DC-component. 

After the Fourier transform, a window may be applied to the complex frequency data before performing the inverse
transform. The following choices are possible:

19.21.1.1 Unwindowed

No frequency domain windowing is performed. All frequencies are given equal weight.

19.21.1.2 Half-Hanning

A Half-Hanning window is applied in frequency domain. This results in an attenuation of the higher frequencies. This
option is recommended for loudspeaker measurements.

19.21.1.3 Blackman-Harris (full)

A Blackman-Harris full window is applied in frequency domain. This results in an attenuation of both the lower and
higher frequencies, while the mid-band frequencies are not attenuated.

19.21.1.4 Filtering using Hamming

A Hamming window is applied in frequency domain. Note that if this is selected, the usual filtering controlled by
 will not be applied. However, the centre frequency and the bandwidth for the Hamming windowing



is taken from the filtering options, accessed by clicking . In the dialog box, the centre frequency and
bandwidth are set as shown below.

Using the settings above will give the most weight to the frequencies around 1000 Hz and filter out all frequencies
below 707 Hz and above 1414 Hz.

19.22Plot Type Settings: Schroeder Curve…

Displays the dialog box shown below.

Most of the Schroeder Curve settings are found and explained in the  Plot->Plot Type Settings->Time Data....
section. The Schroeder Curve vertical axis can only be displayed in dB. The vert. axis scaling is here set to

 which is the most common way to view the Schroeder Curve. The DC-component is automatically
removed for the Schroeder curve and it is computed from the last 50% of the measurement data. The

 button will open the Advanced Calculation Options. They are explained in the
Advanced Calculation Options section of the Calculate->Calculation Options... documentation.

19.23Axis range

Displays the sub-menu shown below.
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This is used to set the axis range. If you need to set the axis range often, we recommend that you use the arrow keys
that are also listed above. Alternatively you can use the axis range settings in the Plot Toolbar, they work exactly the
same way.

19.24Layout: Legend

Displays the legend list in the plot as shown below.

The legend list shows:
• the name of the measurement the curve is calculated from
• the color of the curve
• if the curve is currently displayed in the plot, or not. If you do not want to display a curve, just make sure it is

not checked in the legend list.

This and other legend settings are found in Plot->Layout->Edit..., select the Legend tab.

19.25Layout: Cursor

Displays a horizontal and a vertical line that follows the mouse pointer.

19.26Layout: Cursor Value

Displays a text box with the cursor value in the plot.



The FAQ section explains how to position and format this text box.

19.27Layout: Gridlines

Displays gridlines in the plot active plot.

For more detailed gridline settings, go to Plot->Layout->Edit..., select the Axis tab, then select the Ticks tab, or the
Minor tab for the minor gridlines.

19.28Layout: 3D

Displays the plot in three dimensions. If you have multiple measurements plotted, this may be a nice way to display
them as shown below.

This and other 3D settings are found in Plot->Layout->Edit..., select the 3D tab.

19.29Layout: Title

Display title in plot. For more detailed title settings, go to Plot->Layout->Edit..., select the Titles tab.
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19.30Layout: Footer

Display footer in plot. For more detailed footer settings, go to Plot->Layout->Edit..., select the Titles tab. Then select

 as shown in the figure below (the reason you must select SubFoot and not Foot is that Foot can be used
to add you own footer in addition to the footer that is automatically added by WinMLS).

19.31Layout: Axis Labeling

Display labels in plot. For more detailed label settings, go to Plot->Layout->Edit..., select the Axis tab. Then select
the Labels tab.

19.32Layout: Text Refreshing...

Displays the dialog box shown below.

The “Add to ....” settings shown in the upper part of the figure above determine if the plot title/footer/labels are to be
automatically updated after a measurement is plotted. If no check boxes are checked, the text is not changed in the
plot. 
This is useful if you want to use your own text, for example set ‘Reverberation Time’ as the plot vertical axis title
instead of the text that WinMLS automatically sets. 



How to set your own text will now be explained. Go to Plot->Layout->Edit... and select the Axis tab, then select the
Titles tab as shown in the figure below. 

Instead of ‘T30 [s]’, write ‘Reverberation Time’ in the figure above.

19.32.1Add to Title

If  is checked, the title of the plot type is added to the plot title. The title added is normally the name of
the plot type. E.g. the plot type Time Data gets “Time Data” as title. But the title may in some cases depend on the
plot type settings. E.g. if the plot type is Room ac. Parameters and RT-60 Reverberation Time (T30) is selected as
parameter type, the title is as shown below

If  is checked, the title of the measurement that is plotted is added to the last part of the plot title as
shown above. Note that this only works for files that has a title in the header (*.wmb and *.wav-files generated using
WinMLS). When saving a measurement, you can type the title.

Note: In order to actually display the title in the plot, Plot->Layout->Title must be checked.

19.32.1.1 Add to Axis Titles

If  is checked, axes units will be added according to the plot type settings and the plotted measurement data
header.

Note: In order to actually display the units in the plot, Plot->Layout->Axis Labeling must be checked.

19.32.1.2 Add to Footer
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If  is checked, the date of the plotted measurement is added.
If  is checked, the date when the last curve was plotted is added.
If  is checked, the name of the plotted measurement is added.
If  is checked, the comment of the plotted measurement is added.

This only works for files that has a this information in the file header (*.wmb and *.wav-files generated using
WinMLS). 

Note: In order to actually display the footer in the plot, Plot->Layout->Footer must be checked.

19.32.2Various (6) (2)

Displays the dialog shown below

19.32.2.1 Display legend inside axis

If  is checked, the legend list is displayed within the axis  as shown below.

If it is outside the plot, it looks like below.

19.32.2.2 Include folder in curve name

Includes the sub-folder name in the curve name. The curve name is displayed e.g. in the legend list shown below.
In the example figure below the sub-folder is named Measurements

19.32.2.3 Include file extension in curve name

Includes the file extension in the curve name. The curve name is displayed e.g. in the legend list as shown in the figure
below.

19.32.2.4 Initial curve name

The initial curve name determines what a performed measurement is named in the plots before it is saved. 



In the example below, the initial curve name is ‘Meas’ and it is the first measurement performed after WinMLS is run
because it is given 1 as number.

19.33Layout: Edit... 

Displays the dialog shown below (in this case 3 measurements are performed and the Time Window is displayed in the
plot). 

This dialog gives the user a wide range of possibilities and may seem complicated. Note that this dialog has context-
sensitive help functionality. Click the question mark button  in the upper right corner and then click the setting you
want explained.

The settings of this dialog are saved as chart files and are controlled by the post-processing setup. Each plot type has
chart files that are opened when the plot type is selected. The chart files are found in the Chart subfolder in the folder
where WinMLS is installed as shown below.
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Note that changes to the plotted curve, e.g. changing colors, will not be saved. Default curve styles are set in Plot-
>Layout->Curve Styles and Colors….

Now each tab page as shown in the figure below will be described, starting with the Chart page.

19.33.1Chart page

This is the page that is displayed when opening the dialog. It defines the overall display parameters for the active plot,
such as background, axis, titles and legend. An explanation of some of these parameters is given in the FAQ
document.

19.33.2Series page

Gives access to the settings that applies to each curve (here it is named series, in WinMLS it is also named curve) as
shown below.

The Series page will contain parameters dependent on the series type concerned, and the available parameters will
depend on the curve type chosen (in the figure above the curve type is Fast Line). The setting

 at the top of the Series tab page shows which curve you are editing.

19.33.3Data page

Gives access to the data (x- and y-values) of the active plot as shown in the figure below.



By clicking on the cells, the data may be deleted, changed or added. To modify a cell, first click on it to set it active.
To delete the cell, click the  button shown below. 

To modify the cell, click it once more and type the new number. Then click the  button or <Enter> to validate.

19.33.4Export tab

The Export tab gives access to exactly the same settings as Edit->Advanced Export....

19.33.5Print tab

The Print tab gives access to exactly the same settings as File->Print Preview….

19.34Layout: Start/Stop Animation

Starts a 3D animation in the active plot. Try the animation yourself as it is better than explaining it in words. Use this
same menu selection to stop the animation.

19.35Layout: Curve Styles and Colors...

Displays the dialog shown below.
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The upper part of the dialog shown above sets the default color, width and style for the curves plotted by WinMLS.
Curve 1 is the first curve plotted, and from the figure above we see that this has red color. The second curve to be
plotted will have blue color, etc...

Below “Curve 6” in the figure above, we see that the next is named . “Button 1” refers to the first
button in the Measurement Panel toolbar. This means this color is used for button 1 in the Measurement Panel toolbar
(as shown in the figure below) but also as the seventh curve in the plot.

 

19.35.1Selecting curve color

The color is selected by clicking the color field . This will open the dialog displayed below.



Any color may be selected from this dialog.

19.35.2Selecting curve width and style

The curve width and style is set from .

The choices are listed below. 

Note: If you select a curve width greater than ‘1’, the plotting may be slower.

19.35.3Active plot type curve styles

Select the curve type  for the active plot type. For more information see the
Curve type section under Plot->Layout->Advanced….

If  is checked, the curve belonging to the active measurement will be displayed with a
width different from the other curves. If curves from several measurements are plotted, this may be useful to
emphasize the active curve as shown below.
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Note: If a curve width greater than 1 is used, the plotting speed is decreased. So as a faster alternative to this option is
to use Plot->Solo Curve.

19.35.4Apply color changes to all windows

This   setting is only of interest if your setup has more than one window (a window is
not the same as a plot, sine a single window can have multiple pots).
If  is checked, changes in the color settings will be applied to all window. If it is not
checked, the changes will be applied to the plots in the active window.

19.35.5Repeat curve styles

This is useful if several curves are plotted and you want the colors to repeat.

If the wrap index is e.g. set to 4 and 8 curves are plotted, the first 4 curves will get colors as selected from the Default
Curve Styles list. But the 5th curve will get the same color as the first curve; the 6th curve will get the same color as the
second curve, etc.

19.36Layout: Advanced...

Displays the dialog shown below consisting of a Various part and a part that associates curve type and chart file with
a plot type.



19.36.1Various (7) (3)

These settings apply to all plot types.

19.36.1.1 Set cursor to max value on new measurement

If  is checked, the cursor (if displayed in the plot) will be set to the maximum
value in the plot when a new measurement is performed or opened from file. 

19.36.1.2 Display only name of post-proc. setup as window title

If  is checked, only the name of the post-processing setup will be
displayed as window title. An example is shown below.

If  is not checked, the name of the active plot type and active
measurement curve will also be displayed as shown below.

19.36.1.3 Leave out points from a curve

If a curve contains a large amount of points, the plotting may be slow. To increase the speed, this option can be used

In the example above, it will only apply to curves that have more than 70000 points.

19.36.1.4 Limit plotting range

The plotting range can also be limited as shown below

It can be useful if you only want to plot e.g. low frequencies.

19.36.1.5 Save chart-file when saving post-processing setup

If  is checked, the chart-file (containing the layout settings for the
active plot) is saved when the post-processing setup is saved. Also when the temporary post-processing setup is saved,
a temporary chart-file is saved. A chart-file contains all the settings found in the Plot->Layout->Edit... dialog.

19.36.2Associate plot type with curve type and chart-file

19.36.2.1 Plot type (2)

The Curve type and Chart-file that corresponds to the selected Plot type is displayed. 

387



The user may select a new Curve type and Chart-file for the specific plot type. All the available plot types are
present in the list. 
Note: Changing the plot type will not affect the current plot when exiting the dialog.

19.36.2.2 Curve type

In the initially installed setups, the default curve type for most plot types is set to Fast Line as shown in the figure
below.

This means that the curves are drawn using the Fast Line curve type. The available curve types are shown in the
figure below.

Examples on what the curve types look like are found in Plot->Layout->Edit …. From this dialog the curve type in
the current plot can be set.

In the dialog obtained from Plot->Layout->Edit Layout…, click on  shown in the figure above. 
A new dialog will be displayed showing curve types to select from, some of which are shown in the figure below.

By clicking on the small arrow in the lower left corner of Fast Line , the possibilities for this line type is
displayed as shown in the figure below. 

For the curve type Line, the following choices are possible.



19.36.2.3 Chart-file

A Chart-file (*.tee) contains all the settings in the Plot->Chart Settings for Active Plot... dialog (when no curves are
plotted). 

A new chart-file may be selected from the list of available files. Use the  button to save the current chart

file, use the  button to save the current chart file with a new name and the  button to delete
the current chart file. If you delete a chart-file and you must get it back, you can restore it by reinstalling WinMLS.

20Calculate Menu
Room acoustics parameters can be calculated from the Calculate menu as shown below.

20.1 Last Choice again   Alt+L

Is a quick way to repeat the last menu selection for calculating results. It is even faster when using the  button on
the standard toolbar or the shortcut <Shift> + <Ctrl> + <C>.

20.2 Speech: Calculate

Calculates the results for the speech parameters selected in Calculate->Speech->Settings.... An example is shown
below.
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In the example above, we see that STI is displayed in red which means that the result is questionable. This is because
the edr number is slightly less than 30 dB in the octave band 250 Hz. We have set the edr limit to 30 dB. This means
that the measurement should be of higher quality than 30 dB and you should be careful with using the results, but not
that the result must be wrong. The results are “questionable”.

20.3 Speech: Settings...

Displays the dialog shown below.

20.3.1 Speech parameters

Any of the speech parameters shown below can be selected.



The various speech transmission indices STI, RASTI, STIrMal, STIrFem, are single number measures based on
modulation reduction and signal-to-noise ratio in the room or speech transmission system. The modulation transfer
function (MTF) and index (MTI) form the basis of calculation of the indices. In WinMLS these are calculated based
on impulse response measurements.

The standard IEC-60268-16 3.ed. [2003, Sound system equipment – Part 16: Objective rating of speech intelligibility
by speech transmission index.] describes the measures.

20.3.1.1 STI and RASTI

STI and RASTI, the original versions, which are based on weighted sums of modulation transfer function (MTF)
values [T. Houtgast and H.J.M. Steeneken, "A review of the MTF concept in room acoustics and its use for estimating
speech intelligibility in auditoria," J. Acoust. Soc. Am., vol. 77, pp. 1069-1077 (1985), and IEC-60268-16 1.ed].

RASTI is included in WinMLS only for historic reasons. It was developed to reduce measurement time for room
acoustic use. Using WinMLS, the measurement time will be the same for STI and RASTI. STI is the better measure,
and should therefore be the choice of preference between the two unless the RASTI value is required.

20.3.1.2 STIrMal and STIrFem

The revised STI indices (STIrMale, STIrFem) are based on MTFr calculations as described in IEC-60268-16 3.ed.
with auditory masking and gender specific weight factors taken into account. If the impulse response measurement is
calibrated, modulation reduction due to the hearing threshold is also taken into account.

20.3.1.3 MTF and MTI

In the calculation of the MTF the impulse response may be truncated. This follows the same rule as for the
reverberation time calculation. For details, see the Advanced calculation options... section.

However, there is one important exception. If  is selected in the dialog
box as shown below, the impulse response will not be truncated. This is because if truncating the impulse response,
the background noise influence would not be correctly considered (for more information see the Influence calculated
from calibrated measurement section below).
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The MTF is determined by FFT of the filtered and truncated impulse response, and the values at the exact 1/3-octave
modulation frequencies specified are found by linear interpolation. This is a fast and very accurate method for all but
extraordinary short impulse responses, and for these the modulation reduction for speech transmission is negligible
anyway.

If MTF is checked in the check box, it will be displayed for the various octave bands and modulation frequencies in
the table shown below.

Note that the MTF values are linear. In order to convert to dB you have to compute 20*log10, even though it is in the
intensity domain.

MTI is a transmission index specific for each octave band, calculated based on MTF values in that octave band as
described in in IEC-60268-16. The calculation of the speech transmission indices are subsequently based on the MTI.

The standard MTF and MTI  output shown above in WinMLS are according to the original
definitions [IEC-60268-16 1.ed], the basis for STI and RASTI calculations. No auditory masking , gender specific
weighting or hearing threshold is taken into account. They are, however, noise corrected if specified.

The revised MTF and MTI  output shown above are computed according to IEC-60268-16 3.ed.
with auditory masking, gender specific weight factors and hearing threshold (if the measurement is calibrated) taken
into account.



20.3.1.4 %ALcons

%ALcons is in WinMLS calculated solely from the STI based on an empirical formula.

20.3.1.5 EDT and D50

Early decay time (EDT) and Deutlichkeit (D50) are also commonly used for evaluating room acoustic conditions for
speech. EDT is described in the Reverb times (RT-60) section. The EDT and D50 are not influenced by the choice of
Background noise and speech level influence explained in the next section.

20.3.2 Background noise and speech level influence

If the background noise is low, the background noise it will not affect the speech intelligibility. However, the
background noise should be taken into account if the speech-to-noise ratio is less than 15 dB in the octave bands of
interest. The available methods for taking the background noise into account are explained below.

20.3.2.1 No influence

This option does not take the background noise into account, and can be used to assess the detrimental effects of
reverberation on speech intelligibility separated from the effects of noise. It only requires a reasonably high quality
impulse response measurement. No calibration of either source or microphone is needed.

The calculations are based solely on modulation reduction caused by the impulse response, thereby assuming that the
normal speech-to-noise ratio in the space is greater than 15 dB in the octave bands of interest. This happens in rooms
where the effects of reverberation and reflections usually dominate.

For maximum accuracy the impulse response should not be noise contaminated, and the calculation should be
performed with  turned on. This setting is found in Calculate->Calculation

Options… by clicking the  button.

Note: If  is turned off, and no other truncation and no averaging is performed, the
calculation will be the similar to using the option Correction using background noise in measurement.

20.3.2.2 Level given in table below

This option takes the background noise and assumed speech spectrum into account. 

This option lets the user specify the background noise and the assumed speech level on the measurement microphone,
both expressed as octave band sound pressure levels in dB. 

393



Note: These are total levels, including both direct sound and reverberation. 
Data must be entered for the octave bands that are included in the STI calculation. For RASTI calculation, only data
from the 500 Hz band and 2 kHz band are used. 

The background noise in octave bands can be measured with WinMLS if the input chain (including the microphone) is
calibrated. To measure background noise, go to Setup->Load... and load the setup named Level and follow the
instructions in the wizard (the input must be calibrated). Alternatively a sound level meter may be used to measure the
background noise in octave bands with no weighting.

Using this setting, speech transmission indices can be measured without any calibrated source and microphone used
with WinMLS, assuming a sound level meter is at hand. It also makes possible simulation of results, for instance when
expected background noise levels cannot be experienced in a measurement situation, or effects of varying speech level
and spectrum is sought.

When using this setting, it is assumed that the impulse response is of high quality, just as in the previous choice No
correction (valid if background noise is very low). If the effective decay range (edr) is less than 30 dB, the result of
Calculate->Speech->Calculate will be printed with red color as shown in the figure below. This indicates that the
data are questionable.

If the setting described in the next section is selected, the ‘Data Questionable’ red color will not be turned on based on
an insufficient decay range. The reason for this is that the decay range will not be calculated.

20.3.2.3 Influence calculated from calibrated measurement

If this setting is selected and the measurement is performed using MLS, the background noise in the actual
measurement is automatically taken into account when computing the MTF, MTI and speech transmission indices [D.
Rife, “Modulation Transfer Function Measurement with Maximum-Length Sequences”, (JAES), vol. 40, No. 10, pp
779-790, 1992 October]. Modulation effects of both reverberation and background noise are taken into account in a
single measurement. For the results to be accurate, the speech and noise levels at the measurement microphone must
be representative, and no noise-reducing averaging must be employed. The speech spectrum and level can be obtained
by using a calibrated source.

In addition to selecting MLS as output signal, it is important that pre-emphasis is turned on. Set this from
Measurement->Settings... as shown below.

We see from the figure above that MLS is selected and emphasis Pre, output only is selected. As emphasis filter
STI/RASTI is selected. This will give correct results for STI and RASTI. Select the filter options STIrMale to get
correct results for STIrMal and select STIrFemale to get correct results for STIrFem.
Note: If truncation of the impulse response is set in the Advanced Calculation Options, it is not used when
Correction using background noise in measurement is selected because the whole impulse response must be
included to get correct result.



Note: In this case the computation of other room acoustics parameters (including EDT and D50 in the speech
parameter option) must be treated with outmost care, since the directivity of the speech source is different from a
normal room acoustics measurement loudspeaker, and the pre-filtering that is supposed to be applied changes the
impulse response.

20.4 Reverb times (RT-60)

Calculates the reverberation times EDT, T30 and T20. An example of result is shown below.

EDT(s) is the 60 dB decay time calculated by a line fit to the portion of the decay curve between 0 and -10dB. 

T30(s) is the 60 dB decay time calculated by a line fit to the portion of the decay curve between -5 and -35 dB. If the
decay range is less than 35 dB, T30 is in WinMLS calculated using the decay range available. It is therefore important
when using the T30, to keep an eye on the edr number to evaluate the quality. To be a valid T30 measurement
according to the ISO 3382 standard, the edr should be displayed as 35dB or larger. If not, the number is displayed
with red color in the table in the figure above.

T20(s) is the 60 dB decay time calculated by a line fit to the portion of the decay curve between -5 and -25 dB. If the
decay range is less than 25 dB, the T20 is in WinMLS calculated using the range available and is displayed with red
color in the table as shown in the figure above.

The decay time parameters are given in seconds.
Note: EDT is not displayed if the bandwidth 1/3-octave band is selected.

20.4.1 snr - Signal to noise and edr - effective decay ranges

The signal-to-noise-range (snr) and the effective-decay-range (edr) are important parameters providing information
about the quality of the measurement and parameter calculations. For the default settings they are always the first
parameters given in the results table as shown below.

They are not included in the Calculate->User Defined->Settings… dialog, but will also be calculated and displayed
if Calculate->User Defined->Settings… is selected.

The edr can also be displayed as marks above each value in the room acoustics plots as shown below. 
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The actual signal to noise ratio of an impulse response measurement is estimated from the resulting response itself,
and presented as the snr. The estimation of the background noise level is done using the last 10% of the impulse
response, and the accuracy thereby depends on that the last 10 % of the impulse response is actually being a flat noise
floor. This snr number is, however, not of much practical use in room acoustical analysis. 

Of much more interest is the so-called effective decay range, edr, which directly describes the range of the decay
curve which is available for analysis. For an explanation of the decay curve, see the  Advanced Calculation Options
section. 

The effective decay range is taken as the level of the decay curve at the point where the response is truncated before
forming the decay curve. The resulting decay range is therefore, in addition to the physical signal-to-noise ratio in the
measurement, dependent on the type and shape of the room impulse response and the chosen noise margin in the
response truncation.

The decay range can be used directly to evaluate the quality of the room acoustical parameter calculations, especially
the reverberation time T30. It should be noted, and is illustrated clearly in the examples in the More theory about
integration section, that if no compensation for energy removed by truncation has been done, the decay range as
calculated here is meaningless. It will therefore not be displayed in the results grid unless both truncation and
compensation are checked in  Advanced Calculation Options.

If you are evaluating a room acoustics parameter that requires two impulse responses, e.g. IACC or LF, two rows of
snr and edr will appear in the table, one row for each impulse response.

20.4.2 corr - Correlation

The computation of decay time parameters are made by a least-squares fit of a straight line to the chosen level range of
the decay curve. For the decay times to be meaningful descriptors of the reverberation, the decay curve should
approximate a straight line. To provide an indication of the linearity of the decay curve, the decay time parameters are
accompanied by a correlation coefficient describing how well the straight line fits the decay curve. If the coefficient is
close to –1.0 the decay curve is linear in the chosen range and frequency band.

The early decay time (EDT) will not be accompanied by a corresponding correlation coefficient, because it is always
computed from the uppermost part of the decay curve which normally displays some curvature due to the influence of
the direct sound.

The calculation is described in [2003: ISO/CD 3382-2 Acoustics – Measurement of the reverberation time – Part 2:
Ordinary rooms, Appendix B.2].

20.4.3 r(m) – Direct sound distance

When computing room acoustics parameters as default the the direct sound distance r(m) is computed. Shown below is
how this is displayed when the parameters are calculated from the Calculate menu.

If the Time Data plot type is displayed, the time window lower limit is also updated as shown in the figure below.



To compute the distance in meters, the speed of sound is needed. The formula for computing the speed of sound is
given below:

Speed of sound = 343.3 + 0.6*(temperature – 20);

The temperature used in the formula below is specified in Calculate->Strength->Strength Settings…. In this dialog,
select the setting shown below

Then click the  button to open the dialog shown below where the temperature can be
specified.

20.5 ISO 3382

Calculates the parameters defined in [1997: ISO 3382 2.ed Acoustics – Measurement of the reverberation time of
rooms with reference to other acoustical parameters]. An example is given below
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The parameters EDT, T30, T20, edr and corr are defined in the Reverb Times section above.

For a more thorough introduction to the room acoustical parameters, see the ISO 3382 standard, or any good textbook
on room acoustics.

20.5.1 Tc(ms) – Centre time

The centre time is the first moment of the impulse response h(t):
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The upper integration limits are taken as the truncation point determined in the decay curve formation, or the end of
the impulse response, according to the integration option specified. If compensation for truncated energy is calculated,
this is taken into account as well to increase accuracy.

Due to the time-weighting in calculating the first moment, the centre time is more sensitive to the influence of noise,
and will therefore be particularly inaccurately calculated if the edr is low. To compensate for this, an analytical
compensation for the truncation of the first moment is also calculated in the truncation and compensation integration
option.

20.5.2 C80(dB) - Clarity

The early to late index, or clarity, is
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where te is the early time. When the early time is 80 ms it is referred to as C80 which is typical for music application.
C50 (50 ms early time) is used for speech or stage evaluation. 



20.5.3 D50(%) -  Definition

The early to total index, or definition, is
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Definition is mostly used for speech signals, and the early time is usually taken as 50 ms.

The upper integration limits are taken as the truncation point determined in the decay curve formation, or the end of
the impulse response, according to the integration option specified. If compensation for truncated energy is calculated,
this is taken into account as well to increase accuracy.

20.6 Stage

Calculates the stage parameters. An example is given below.

EDT is explained in the Reverb Times section and Clarity (C50) is explained in the ISO3382 section.

Support is defined in [A. C. Gade, "Investigations on musicians room acoustic conditions in concert halls, II: Field
experiments and synthesis of results," Acustica, vol. 69, pp. 249-62 (1989)] as:
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where it is assumed that the response is measured with an omni-directional microphone at a distance of 1m from the
source. The time limits are td, the direct time, te, the early time, and tl, the late time. ST1 is defined with direct time 10
ms, early time 20 ms and late time 100 ms.

20.7 Strength: Calculate

Calculates the strength G parameter. An example is given below.
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For information about the G parameter see the next section.

20.8 Strength: Settings...

The sound strength, or level, is defined as
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where h10(t) is the free-field response of the (assumed omni-directional) source at a distance of 10 m, filtered in the
same way as the impulse response itself. 

The upper integration limit in the numerator is taken as the truncation point determined in the decay curve formation,
or the end of the impulse response, according to the integration option specified. If compensation for truncated energy
is calculated, this is taken into account as well to increase accuracy.

The reference level is:
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There are various ways of specifying or estimating the reference level, and this is governed by the choices in the direct
energy options dialog. The method is common for strength (G) and late lateral strength (LG).

The dialog shown below is displayed.



First select what type of strength you wish to compute. Select in the list shown below

Each selection will display an explanation as shown in the dialog above. It should be noted that the ISO 3382 standard
requires a fairly elaborate calibration measurement of the sound source to provide the reference energy at 10 m. Only
the option ISO3382 Strength gives the possibility of obtaining G-values according to the ISO 3382 recommendations.

20.8.1 SPL-level only

No calibration is needed for this option. Lref is assumed to be 0 dB in all frequency bands, which means no correction
is made on the level calculated from the primary impulse response. This can be used for instance if the source level is
unknown or of no interest, but the level difference at various measurement positions shall be compared. To find the
absolute level in SPL, the input must be calibrated (from Measurement->Calibration...).
In this case no other options are available in the dialog. But for standard strength measurements, do not select this
option.

20.8.2 Strength – direct sound as reference

No calibration is needed for this option. h10(t) is estimated by windowing the actual impulse response we want to
compute Strength from. And Lref is calculated subsequently. In this case it is possible to set the Direct sound window
length and Temperature shown below.

Set the Direct sound window length so the first reflection is not included. If you are unsure, you can use 5 ms.

This option is incorporated to provide a simple to use reference level calculation, without the use of separate reference
response measurement or time-consuming reference level measurements. The reference free-field impulse response is
estimated from the measured impulse response as:
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where r is the estimated source to receiver distance and w(t) is a half-Hamming window starting on the arrival of the
direct sound in the impulse response. After windowing, the reference response is filtered, and the reference levels are
calculated.

The window length can be specified in the dialog, in milliseconds. A recommended value is 5 ms, which provides a
useful trade-off between incorporating the impulse response of the loudspeaker while windowing out reflections from
the surroundings. In normal concert hall measurements especially the stage floor reflection can be bothersome in this
respect, it will in most cases fall inside the 5 ms window.

The source-to-receiver distance is estimated based on the detected initial time delay of the direct sound, which requires
that the measurement must have been performed in a way that the initial time delay is correct. The temperature on the
measurement site can also be specified, in degrees Celsius, as this influences the speed of sound and thereby the
estimated distance. No great accuracy is required, and in most room measurements 20°C, normal room temperature,
can be used. It should also be noted that the initial time delay detected from the impulse response will provide the
distance to the nearest face of the loudspeaker, not necessarily to the acoustic center of the source.

Comparison with properly calibrated measurements have demonstrated that this method will normally provide too
high G values at low frequencies due to insufficient window length, fairly good G values at mid frequencies (500-
1000Hz), and too low G values at high frequencies due to the influence of the immediate surroundings of the
transducers. Because of this G cannot be said to be calculated according to the ISO 3382 requirements.

20.8.3 ISO 3382 Strength

Lref is given directly by the user, or calculated based on reference measurements specified by the user.

If user specified reference level is used, open a new dialog by clicking the  button. In
this dialog Lref can be specified directly or calculated from reference measurements, all assuming calculation in octave
bands.



Direct specification of Lref is done in dB. This is useful in the case where the source and measurement equipment has
been pre-measured in an anechoic room or otherwise, the reference level calculated, and the actual room measurement
performed with exactly the same equipment and level settings. Alternatively known level changes can be used and
corrected for. The calculation procedure described in the following subsection can be used to find reference levels for
later use.

20.8.3.1 Source distance

Source distance options are shown and explained below.

                      

20.8.3.1.1 Compute from measurement (using initial time delay)

For this option the distance is detected and computed separately from the various reference responses. This option
requires that the delay is measured correctly with your sound card. If you are not sure about that, see the section
below.

It should be noted that the distance to the acoustic centre of the source will be somewhat longer than the distance
detected to the nearest loudspeaker face, which might influence close measurements. 

20.8.3.1.2 Specify in meters (meas. initial time delay is not used)

This option should be chosen when the reference measurement distance is known, and the distance is the same for all
the measurements used for the calibration.

20.8.3.2 Window type (3)

The windowing options are shown and explained below.

                          

20.8.3.2.1 Whole response (anechoic)

This option assumes an actual free-field, or anechoic, measurement of high quality. If this is the case, it provides
accurate reference levels across a wide frequency range.

20.8.3.2.2 50 ms rectangular (anechoic)

This option is similar to the option above in that it is suitable for free-field measurements. The windowing improves
accuracy for most measurements, as in most bands the data beyond 50 ms will be noise anyway, and the window is
sufficiently long to extend to very low frequencies (down to 20 Hz). It is the recommended method for free-field
reference measurements.

20.8.3.2.3 5 ms Half-Hamming (in-situ, non-standard)

This option is similar to the strength-option that uses windowing of the active response. It can be used for in-situ
measurements where a reference impulse response is measured separately. This can typically be done in concert hall
measurements where a close range measurement across an empty stage or to a front seat row can provide a better
reference than the actual measurement positions.

20.8.3.3 Temperature

Specify the temperature used during the calibration
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The temperature influences the speed of sound and thereby the distance.

20.8.3.4 Select calibration measurements

After you have performed your calibration measurements, you can compute the correction in octave bands to obtain
calibrated strength values.
The procedure for using the measured data to get calibrated strength values is initiated by clicking the

 button, which opens up a browser window shown below. 

Now mark the reference impulse response files you wish to include, 29 measurements is standard (use the Shift button
to mark several files)

These responses must have the same length and sampling frequency. The responses are windowed according to the
choice in Window type shown below

and scaled according to the choice in Source distance shown below

Thereafter the energy of each is calculated in bands, and the reference level is found by averaging the energy across all
the specified responses. The results are displayed in the Direct energy corrections dialog

The results should be stored for later use and reference. Store the results using Setup->Store... (you might want to
save under a new name) and make sure  is checked.



20.9 Spaciousness

Calculates spaciousness as lateral parameters or interaural crosscorrelation explained in the sections below.

You can measure spatial parameters using two 1-channel measurements or a single 2-channel measurement.
Note: If doing two 1-channel measurements, the two measurements should be done immediately after each other. This
is because the time variance in the room may influence the measurement.

20.9.1 Lateral parameters

Lateral parameters will be calculated if the microphone type is set to  in Calculate-
>Calculation Options... as shown below

An example of computation is shown below.

Calculation of lateral parameters requires microphone option omni-directional and figure-of-8. It is further assumed
that the omni-directional and the figure-of-8 microphones have the same sensitivities (or alternatively the sensitivities
are calibrated in WinMLS) and are properly equalized with respect to each other, in the direction of maximum
sensitivity. The two impulse responses should be measured in the same position, if possible simultaneously. The
figure-of-8 should have one of the null-directions pointing either towards the source or along the long axis of the
room, see ISO 3382. It is also extremely important that they are mutually synchronized, with matching absolute time
scales. This can for instance be accomplished measuring the two channels simultaneously. If they are not measured
simultaneously, make sure that WinMLS is set to include the system delay (initial time delay) in the measurement.
This can be done from Measurement->System Delay.... It can also be done from Measurement->Settings... if you in
step 6 set the reference to right channel input as shown in the figure below. If this is done, it will override the settings
you have selected in Measurement->Settings....
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20.9.1.1 Detecting the start of the impulse responses for lateral parameters

In a lateral calculation based on omni and figure-of-8 microphones, the start is detected from the primary (omni)
impulse response before filtering. It is further assumed that the two channels are synchronized and the same sample
number is taken as the start of the figure-of-8 mike. Automatic detection of the start of such a figure-of-8 mike is
virtually impossible, especially when its null is pointed towards the source (because the reflections may be strong
compared to the direct sound).

It is not recommended to use any spacing between the microphones. Even 15 cm (6 inches) can mean a significant
difference in the impulse responses due to reflection interference. If scattering from mike housing is a concern, remove
one mike while measuring with the other. In other words, do not measure both channels simultaneously. But make sure
that you are measuring the correct system delay (initial time delay) if measuring two 1 channel measurements instead
of one 2 channel measurement.

A time difference of ~0.5 ms will probably in itself not mean much, in general. But there may be cases with strong
reflections close to the early window boundary where it will lead to an additional bias in the results. Therefore avoid
this difference if possible.

20.9.1.2 LG – Late lateral strength

The late lateral strength is
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This is a fairly new parameter, not mentioned in the standards so far, but it is believed to correlate well with subjective
envelopment [J.S. Bradley and G.A. Soulodre, "Objective measures of listener envelopment," J. Acoust. Soc. Am., vol.
98, pp. 2590-2597 (1995)].

The upper integration limit in the numerator is taken as the truncation point determined in the decay curve formation
for the lateral impulse response, or the end of the impulse response, according to the integration option specified. If
compensation for truncated energy is calculated, this is taken into account as well to increase accuracy.

The reference energy in the denominator is calculated just as for strength, the same options govern the calculation, and
similar comments on accuracy apply, see the Strength: Settings... section. The time limits for the late lateral strength
parameter can be changed if the parameter is calculated from the Calculate->User Defined menu.

20.9.1.3 LF –Lateral fraction

The early lateral energy fraction is
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where hL(t) is the impulse response measured with a figure-of-eight microphone with one of its nulls pointed towards
the source. The time limits are td, the direct time, and te, the early time. LF is normally used for music application, with
direct time 5 ms and early time 80 ms. The limit 5 ms is introduced to make sure the direct sound is totally suppressed.
The time limits can be changed if the parameter is calculated from Room Acoustics->User Defined.

20.9.1.4 LFC – Lateral Fraction Cosine

The early lateral energy fraction cosine is 



∫

∫
=

e

e

d

t

t

t
L

dtth

dtthth

0

2 )(

)()(
LFC (0)

where the impulse responses are the same as those for LF. This provides an approximation of a weighting of lateral
reflections according to the cosine of the angle of incidence, which is thought to be better correlated with the
subjective impression than the cosine-squared weighting of the LF.

20.9.2 Interaural crosscorrelation

Interaural crosscorrelation will be calculated if the microphone type is set to  in Calculate-
>Calculation Options... as shown below

An example of computation is shown below.

Calculation of the binaural interaural crosscorrelation parameters are normally done from a binaural pair of impulse
responses, measured either with a dummy head or microphones in or close to the ears on a real person. It requires
microphone option Binaural pair. It is not important that the responses are mutually synchronized (for more
information see the section below). The primary response is taken as the left side and the secondary as the right side.

The interaural crosscorrelation function is defined as
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where hL(t) and hR(t) are the left and right ear impulse responses respectively. The interaural crosscorrelation
coefficient is taken as:

( ) ms 1τms 1,maxI <<−= τIACFACC (0)
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WinMLS calculates three versions of the IACC; total with time limits t1 = 0 and t 2= ∞, early with time limits t1 = 0 and
t2= 80 ms, and late with time limits t1 = 80 ms and t2 = ∞. The time limits t2 for IACC early (early time) and t1 for IACC
late (late time) can be changed if the parameter is calculated from Calculate->User Defined.

The upper integration limit t2=∞ for IACC total and late is taken as the truncation point determined in the decay curve
formation for the two impulse responses separately, or the end of the impulse responses, according to the integration
option specified.

The calculation of IACC is substantially more time consuming than the other parameters, even if it is implemented
using a fast frequency domain algorithm. This is especially true for the late and the total versions. If you are
calculating parameters using Calculate->User Defined and if not explicitly needed, these parameters should therefore
be excluded from the calculations.

20.9.2.1 Detecting the start of the impulse responses for IACC

In IACC calculation, there is supposed to be a spacing between the mikes on the order of an ear-to-ear distance
(approx. 15cm). We have chosen to detect the start separately for the two measurements, as the time lag is not
important for the result, only the maximum value of the interaural crosscorrelation function. 

If the automatic detection of the start of the impulse responses should fail, the start point may be set manually, see the
How to set manual start of the impulse response? section. 
In this case there might be a problem not being able to specify two different starting points manually (both impulse
responses may not start at the same point because they are spaced 15 cm from each other. And the manual starting
point must be the same for both impulse responses). However, based on tests we have done during implementation this
measure should not be much sensitive to start point deviations. Therefore, doing a manual start detection should work
fine if you make sure to include the start of both impulse responses.

20.10User defined: Calculate

Calculates user defined parameters. The parameters and individual time limits and other settings are taken from
Calculate->User defined: Settings....
The advantage is that you can define your own time limits and also define what parameters you want to include.

20.11User defined: Settings...

Display the dialog determining which parameters are to be calculated, using check boxes. For some of the parameters
the calculation can be controlled by specifying level and time limits, or even more advanced settings. All settings are
saved in the setup file. Note that only reverberation time (except EDT) and strength parameters are calculated for 1/3-
octave. 



20.11.1Decay times

The first three parameters are decay times as shown below

RT-60 Reverberation time (T30) and Early Decay Time (EDT) are defined in the Reverb Times section above.

The RT-60 User defined reverberation time (Txx), is the 60 dB decay time calculated by a line fit to the portion of
the decay curve in an interval specified in the level limit boxes, remembering the minus signs in front. It is often used
as a T15 (-5 to –20dB) or T20 (-5 to –25dB) parameter, giving a well defined decay time measure for responses with
inferior decay range, or providing an indication of double sloping of the decay if it is significantly different from the
T30. Double sloping occurs if one room is coupled with another room with a different reverb time. The coupling may
be a large opening between the rooms.

The T30 and Txx will in the display of the results grid both be accompanied by a correlation coefficient for each
octave band, as described in the Correlation section.

20.11.2Early energy ratios
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These parameters are defined in the Calculate->ISO 3382 section.
The early limits can be changed to numbers other than recommended in the standard. For Clarity, it is also possible to
get two values as output of the calculation if two numbers are typed, separated by a ‘&’. For example, ‘50&80’, which
is the default setting, gives the two clarity values C50 and C80 as output. Note that this applies when writing
parameters to grid or text file. When using the Room Ac. Parameters plot type, only one parameter is plotted, and the
lowest early time is used, in this example C50.

20.11.3Centre time

The centre time,  is defined in the Calculate->ISO 3382 section.

20.11.4Stage parameter

Support is defined the Calculate->Stage section.

The time limits can be changed in the boxes shown in the figure above to provide other versions of the parameter.

20.11.5Spaciousness 1 (Interaural crosscorrelation)

The binaural interaural crosscorrelation parameters are defined in the Calculate->Spaciousness section.

The time limits t2 for IACC early (early time) and t1 for IACC late (late time) can be changed in the boxes shown in the
figure above.

The calculation of IACC is substantially more time consuming than the other parameters, even if it is implemented
using a fast frequency domain algorithm. This is especially true for the late and the total versions. If not explicitly
needed, these parameters should therefore be excluded from the calculations.

20.11.6Spaciousness 2 (lateral parameters)

The binaural interaural crosscorrelation parameters are defined in the Calculate->Spaciousness section.

The lateral parameters are defined in the Lateral parameters section above.



The time limits for both the LF and LFC parameters can be changed in the boxes shown in the figure above.

20.11.7Level and envelopment (strength)

The sound strength, or level, is defined in the Calculate->Strength->Settings… section above.

The time limits for both the LG parameter can be changed in the box shown in the figure above.

20.11.7.1 Strength options

There are various ways of specifying or estimating the reference level, and this is governed by the choices in the direct
energy options dialog. The method is common for strength (G) and late lateral strength (LG). See the Calculate-
>Strength->Settings… section.

20.12Calculation Options...

Display the dialog controlling the settings for the room acoustics calculations. The dialog can also be reached via a
button in Plot->Plot Type Settings->Room Acoustics....

20.12.1Microphone type(s)

Choose the processing mode by indicating the constellation of microphone(s) used during the measurements. 
The different microphone types make possible different parameter calculations.

The options are as shown and explained below
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20.12.1.1 Single omni-directional

Single microphone. This is the most common situation.

20.12.1.2 Dual omni-directional

Two independent microphones. This option is provided for independent measurements but where simultaneous
calculation can be an advantage, when measuring using the 2-channel capability of WinMLS. Two separate
calculations will be carried out, and results will be presented two separate tables.

20.12.1.3 Omni-directional and figure-of-8

Combination of an omni-directional (primary) and a figure-of-8 (secondary) microphone. This option is used for
calculation of lateral parameters, see the stage section. The figure-of-8 impulse response will only be used for these
parameters, other parameters are calculated from the omni-directional impulse response.

20.12.1.4 Closely spaced omni-directional pair

A pair of impulse responses from either two matched microphones measured simultaneously, or from a single
microphone measured in two locations. In the present version of WinMLS the processing is exactly like that carried
out for the binaural pair setting. This option is included for future extension, for instance calculation of lateral
parameters without using a figure-of-8 microphone.

20.12.1.5 Binaural pair

A pair of impulse responses from either two matched microphones measured simultaneously, or from a single
microphone measured in two locations. This option is used for calculation of binaural parameters, see the Interaural
crosscorrelation section. The microphones are normally placed in or at the ear canal of a dummy head or a real
person. The lower impulse response (in the figure below named Position2) will only be used for these parameters,
other parameters are calculated from the upper impulse response.

20.12.2Parameters

Selects what parameters to be computed

Some parameters have special settings. If this is the case, the  button will be enabled and is used to open
the settings dialog.

The parameters are shown below



In fact, the parameters are the same as can be selected from the Calculate menu. So for information about the
parameters, see the Calculate menu documentation.

20.12.3Measurements (2)

The measurement(s) the parameters are computed from can be selected below. Either one or two measurements are
used, dependent on what parameter is to be computed.

The  button can be used to open a measurement from file, if it is not available in the list.
When this dialog is opened, the upper measurement is set to the active measurement. If the window contains two plots,
the upper measurement is set to the active measurement in the upper plot. The lower measurement is set to the active
measurement in the lower plot.

20.12.4Bandwidth

The impulse responses are filtered in bands according to the settings in this list box. The options are shown and
explained below.

20.12.4.1 Octave

Octave band filters, responses corresponding to the requirements in [IEC 1260 1.ed.: 1995, Electroacoustics – Octave-
band and fractional-octave-band filters]. The lowest octave where octave band calculation is attempted is 63 Hz. The
highest octave depends on the sampling frequency of the measured impulse response.

20.12.4.2 Low-Mid-High

Double-octave band filters, responses corresponding to the requirements in IEC 1260. Centre frequencies of 176.8 Hz,
707.1 Hz and 2828.4 Hz provides three double octave filters corresponding to a low-mid-high combination of octave
bands: 125 Hz and 250 Hz, 500 Hz and 1 kHz, 2 kHz and 4 kHz.

20.12.4.3 Broadband

No filtering is performed.

20.12.4.4 1/3 Octave (Reverberation times only)

Third-octave band filters, responses corresponding to the requirements in IEC1260. Lowest 1/3-octave where
calculation is attempted is 40 Hz, highest band depends on the sampling frequency of the measured impulse response.
For this bandwidth only reverberation times and strength is generally of interest, and therefore only the reverberation
time parameters T30, user defined reverberation time (Tu) and strength (G) can be calculated.
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To minimize the influence of the filter response on the reverberation time calculation, the impulse responses are
filtered backwards. This greatly improves the accuracy for short decay times at low frequencies.

20.12.5Advanced calculation options...

Click the  button to display the dialog shown below.

20.12.5.1 Start of impulse response

For some room acoustics parameters such as Clarity and Definition it is very important that the start of the impulse
response is correctly determined.

WinMLS can either do this automatically or it the user can do it by setting the time window as shown below.

The time window is found in the Time Data plot type and is displayed in yellow in the figure below. Use the mouse to
adjust the limits.



20.12.5.2 Limit using Time Window upper limit

The user can also select how much of the impulse response should be included for the calculations.

The time window is also used for this purpose if  is checked. If it is not checked, the
whole impulse response will be used.

If your noise floor is not stationary, like in the figure above, it is strongly recommended to limit the end of the impulse
response using the Upper limit of the time window.

20.12.5.3 Automatic truncation of impulse response

If  is checked, the impulse response can be automatically truncated based on an
automatic detection of the noise floor as shown below.

With the Noise floor margin setting the user can specify in dB how far above the noise level at the estimated
crosspoint the truncation point is chosen and integration shall start. 

Typical values are 5-10 dB, the recommended value is 5 dB. Higher margins should be used only with responses with
extraordinary high signal-to-noise ratios.

The ISO 3382 standard recommends a certain safety margin to the noise floor. It should be noted that this safety
margin is provided if the noise floor margin is used.

20.12.5.4 Truncation compensation

If  is checked, the truncated energy is estimated and taken into consideration. See
the section below for more information.

20.12.5.5 Theory about integration 

After filtering, backwards integration of the impulse response to form a decay curve, or Schroeder curve, is done as
further preparation to the parameter calculations. If h(t) is the filtered impulse response, the decay curve is:
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This provides a monotonically falling decay. The curve is usually normalized to start at 0 dB. In practice the impulse
response record is finite, and the integration becomes finite as well:
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Also, a measured response tends to contain some noise. Due to the properties of the deconvolution, additive noise of
any kind in the measurement will normally give rise to a stationary noise floor, see the example below. This is
advantageous as a combined noise-decay analysis of the filtered impulse response record can reveal the location of the
cross-point between the response and the stationary noise floor, the response can be truncated at or above this point to
lessen the influence of the noise on the results, and finally the truncated energy can be estimated and taken into
consideration.
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If compensation for truncated energy is incorporated, and the estimated correction is denoted C, the decay curve is:
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20.12.5.6 More theory about Integration

The noise analysis, truncation and compensation are done after filtering, separately for each frequency band. Option 1
is the most accurate, and therefore recommended for most room impulse response measurements. However, it requires
a measurement of reasonably high quality to give good results.

The crosspoint between the decaying response and the stationary noise floor is detected using an iterative algorithm
[A. Lundeby, T.E. Vigran, H. Bietz and M. Vorländer, "Uncertainties of Measurements in Room Acoustics," Acustica,
vol. 81, pp. 344-355 (1995)]. Subsequently, a truncation point is determined using a safety margin above the
crosspoint. With the Noise floor margin parameter the user can specify in dB how far above the noise level at the
estimated crosspoint the truncation point is chosen and integration shall start. Typical values are in the range 5 - 10
dB, the recommended value is 5 dB. Higher margins should be used only with responses with extraordinary high
signal-to-noise ratios. The late slope of the truncated response is calculated by a line fit, and a compensation for the
energy lost by truncation is estimated assuming exponential decay to infinity.



The decay curve forms the basis for calculation of the various decay time parameters, and it can be plotted using the
Schroeder plot-type. The plots below give examples of the three options. If truncation is chosen, all room acoustical
parameters involving the late part of the response is calculated based on a similarly truncated impulse response. If
compensation is chosen and the truncated energy can be successfully estimated, all room acoustical parameters
involving the late part of the response are corrected for the truncated energy.

If the truncation point cannot be determined due to too much noise or an odd shape of the response after filtering, no
parameters will be calculated for that particular frequency band. If a response produces trouble, turning off truncation
and compensation and inspecting the filtered impulse response and Schroeder curve might reveal the source of the
problem.

The figure below gives an example of the three available options.
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20.12.6Send result to

The check boxes shown below specify how to present and/or save results when the calculation is initiated through the
Calculate menu.

Room acoustics parameters can be presented in a text table , sent to clipboard , printed
directly , or saved to a text file .
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21Window Menu
This menu contains standard windows settings and a list of the windows. In addition, post-processing setup can be
loaded and stored.

21.1 New Window

Opens a new window where data can be plotted.
Since it is possible to have as much as 8 plots in a single window (this can be done from Plot->Plot
Type/Routing/Test...), one can ask what the purpose is of adding a new window.
The answer is that the post-processing/plot settings in a window is independent on the other windows.
For example, you want to plot the frequency response smoothed and unsmoothed simultaneously. This cannot be done
by selecting two frequency response plots in the same window like shown below, since the settings will be set equal. 

In the picture below, we are using two windows. This makes it possible to have different plot settings (the lower
window has a smoothed curve).



In other words, the settings are independent in each window, but they may be dependent when using several plots in
the same window.

After you have selected Window->New Window…, you will be asked what post-processing setup you want to load in
this new window as shown in the figure below.

If you click the  button, the new window will contain the same settings as the plot window that was active
when you selected Window->New Window….

21.2 Load Post-processing...

Displays the dialog below for loading post-processing settings. The post-processing setup defines as all the WinMLS
settings related to post-processing and plotting. The settings for performing the measurement is set from the Setup
menu.
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21.2.1 Select post-processing setup

Displays the selected post-processing setup as shown below.

Setups are chosen from a list as shown in the figure below.

21.2.2 Delete setup

Click the  button to delete the selected setup. The button is disabled when only one setup file is left to make
sure not all setups are deleted. To recovered initial setups that are deleted you must reinstall WinMLS.

21.2.3 Setup description (3)

The setup description should be written so it gives a short description of what the setup meant to be used for.

21.2.4  Load setup

Loads the selected setup and then closes the Post-processing Setup… dialog. 
Note: The current post-processing settings will be overwritten if you have not already stored the setup.

21.3 Store Post-processing As...

Displays the dialog shown below for storing the current post-processing settings.



21.3.1 Setup name (2)

Gives the name of the setup. 

Type a new name if you do not wish to overwrite the current setup.

21.3.2 Setup description (4)

The setups descriptions should describe the selected setup. The description may contain
• What kind of measurement setups is this post-processing setup suited for
• How should it be used
• How can it be adjusted

21.4 Cascade

Arrange the windows so they overlap.

21.5 Title Horizontal

Arrange window horizontally as non-overlapping tiles.

21.6 Title Vertical

Arrange window vertically as non-overlapping tiles.

21.7 Arrange Icons

Arrange icons (windows that are minimized) at the bottom of the window.
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21.8 List of Windows

Displays the name of the windows that exist.

22Help Menu
This menu contains Help, About and License information. About contains information about the software, e.g.
version number.

22.1 Help Topics...

The help-file will be displayed. If you cannot find the help-file, the latest version of it can be downloaded from the
Download section of www.winmls.com.

22.2 Shortcut Keys...

Shortcut keys and operations are found below. In addition to these shortcut keys, shortcut keys for opening setups can
be assigned from Setup->Shortcuts....

All license levels:
ESCAPE Measurement->Cancel
F1 Help->Help Topics...
F2 Measurement->Start
F3 Measurement->Test Levels
F5 Plot->Plot Type Settings->Active Plot...
F7 Measurement-> Settings...
F8 Measurement->Sound Card...
Ctrl+Alt+L Setup->Load…
Ctrl+Alt+S Setup->Store…
Ctrl+H Measurement->Calibration...
Ctrl+O File->Open...
Ctrl+P File->Print
Ctrl+X Plot->Erase Curves…
Ctrl+L Toolbars->Level (and Mixer)
Ctrl+A File->Export Plot…
Ctrl+INSERT Edit->Copy Plot
Ctrl+C Edit->Copy Plot
Ctrl+ Shift+W Measurement->Wizard->Start...
Ctrl+Alt+W Measurement->Wizard->Editor...
Ctrl+Alt+C File->Advanced Save-> Measurement As System Correction



Measurement Panel:
Ctrl + Alt + 1 Assign (save) active measurement to Button 1
Ctrl + 1 Plot/erase (assign if not already) measurement in Button 1
Ctrl + Alt + 2 Assign (save) active measurement to Button 2
Ctrl + 2 Plot/erase (assign if not already) measurement in Button 2
etc... for all ten buttons

License level 3 and above:
Ctrl+S File->Save As…
Shift+Ctrl+S File->Save All Unsaved…
Shift+Ctrl+C Edit->Copy Data
Alt+3 Plot->Overlay
Alt+4 Plot->Overlay Settings...
Ctrl+Shift+L Plot->Layout->Legend
Ctrl+Shift+Y Plot->Laout->Curve Styles and Colors…
Ctrl+F Plot->Plot Type Settings->General Frequency

Domain…
Ctrl+W Plot->Plot Type Settings->Time Window…
Shift+Ctrl+ArrowRight Plot->Axis Range->Autoscale All...
Alt+ ArrowRight Plot->Axis Range->Increase Right...
Alt+ArrowLeft Plot->Axis Range->Decrease Right...
Shift+ArrowRight Plot->Axis Range->Autoscale Right
Ctrl+ ArrowRight Plot->Axis Range->Increase Left...
Ctrl+ArrowLeft Plot->Axis Range->Decrease Left...
Shift+ArrowLeft Plot->Axis Range->Autoscale Left
Alt+ ArrowUp Plot->Axis Range->Increase Upper...
Alt+ArrowDown Plot->Axis Range->Decrease Upper...
Shift+ArrowUp Plot->Axis Range->Autoscale Upper
Ctrl+ ArrowDown Plot->Axis Range->Increase Lower...
Ctrl+ArrowUp Plot->Axis Range->Decrease Lower...
Shift+ArrowDown Plot->Axis Range->Autoscale Lower

License level 4 and above:
Ctrl+L Calculate->Last Choice Again
F6 Plot->Layout->Edit...
Ctrl+T Measurement->Measurement Tasks...
Ctrl+D Measuremetnt->Saving Defaults...
Ctrl+ N Open new instance of WinMLS
Alt+A Edit->Advanced Export...
Ctrl+M File->Advanced Save ->Measurement With

Filename <_ActiveMeas_>
Ctrl+Shift+M Plot->Layout-> Start/Stop Animation

License level 5 and above:
Alt+1 Plot->Solo Curve…
Alt+2 Plot->Add Curve(s)…
Shift+Ctrl+H Plot->Plot Type Settings->Harmonic

Distortion...
Ctrl+ Shift+N Window->New Window
Alt+R Plot->Text Refreshing...

License level 7:
Ctrl+Alt+T File->Advanced Save->Curve(s) as Tolerance

Reference(s)
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Shift+Ctrl+A Plot->Plot Type Settings->Airborne Sound
Insulation...

22.3 Walk-through...

Opens the WinMLS help-file at the walk-through section.

22.4 Startup Help...

Displays the dialog that is optionally displayed when WinMLS is started as shown below.

If you do not want this dialog to be displayed when opening WinMLS, make sure

 is not checked.

Click  to select the settings for the type of measurement you want to perform. If you want to load the same

settings as the last time you exited WinMLS, close the dialog by clicking . 

22.4.1 Recommended help sections

Click the button or in the list below to get help on how to use WinMLS.

22.4.2 Quick-guide

Gives a very short description on how to get started for those that do not wish to read any documentation.



22.5 About WinMLS...

Displays the WinMLS About dialog.

If the  button is clicked, the default Internet browser is opened and the homepage www.winmls.com is
visited.

22.6 License Options...

Displays the dialog for transferring or upgrading the WinMLS license as shown below.
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For an explanation on how to register and transfer the license, see the Registering WinMLS section in the help-file
(or in the User’s Guide document).

22.6.1 Transfer License

Click on  and enter the serial number of the unregistered copy of the software on the
target PC. You have to install WinMLS on the target PC to obtain this number.

Once the target serial number has been entered, click the  button. A message will be displayed
confirming the transfer. WinMLS will then invalidate the license on the source PC (i.e. preventing the software from
running), and generate the unlock code for the target PC. 
By entering the unlock code on the Register License screen of the evaluation version on the target pc, the license
transfer process will be complete and the software fully functional.

23Airborne Sound Insulation Measurement
This document is an instruction on how to use WinMLS for measuring airborne sound reduction. This document may
seem long, but you should only need to go through the Get started measuring airborne sound insulation section below.

It is an advantage that the reader has knowledge of the ISO 140-4:1997 and ISO 717-1:1997 since we will follow these
standards. We also explain how to measure according to the new proposed standard ISO/WD 18233 that allows the
use of the sine sweep (or MLS) signal to increase accuracy. This new method is better, and in cases where you have
problems with not being able to get enough sound level using the tradition pink noise method, this new method may
solve this problem.



23.1 Remark about type approval

If you do not wish to use the sound card for such measurements, you may use a sound level meter that has the
capabilities to measure 1/3 octave bands to do the level and background noise measurements. If you compare this to
the same measurements done with one of the sound cards we recommend you will find that the sound card based
measurements are as good. We have also done several comparison measurements with the most expensive analyzers
for such kind of measurements and the results have been the same.

23.2 Get started measuring airborne sound insulation

If this is done correctly, it only needs to be done once.
When you have opened WinMLS, go to Setup->Load... on the menu and load the setup named Insulation_Airborne.

Click the  button to load the setup.

WinMLS should now look similar to the figure below.

If the windows do not fill the screen you can move the windows using the mouse. You may also use Window->Tile
Horizontal, but then the windows may change position relative to one another. This will not affect the calculation in
any way.
We have selected to use different colors to make it easier to separate between the various windows, but the colors can
be changed by the user.
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23.2.1 Shortcut key preparation to measure as easy and fast as possible

If you do not have a need to save the intermediate raw data results, you may follow the procedure below and skip the
other sections.

This will not work if you want to automatically save your intermediate raw data because the auto-name counter will be
reset when you use a shortcut key to load a new setup.

Go to Setup->Shortcuts… to open the dialog shown below.

You may set it up as shown below.

In the example above, use the F12 key to load the setup that is needed to load all the settings needed (this may not be
needed since it should be automatically loaded when starting WinMLS).

We will now give a description on how these shortcuts can be used to do all the required measurements. Before
following this description, you should have calibrated the input as explained in the next section.

To measure the level in the sending room, click in the window named Airborne_Level Sending Room (LS) to make
it active. Then push the F9 key to perform the measurement using pink noise which is according to the traditional
standard. (Note: If you want to measure using the new standard, make sure you select the setup named
Insulation_Airborne Sine Sweep shortcut key F11 shown in the figure above.)

To measure the level in the receiving room, click in the window named Airborne_Level Reveiving Room (LS) to
make it active. Then push the F9 (or F11) key to perform the measurement.

To measure the background noise in the receiving room, click in the window named Airborne_Backgr. Noise
Receiving Room (BR) to make it active. Then push the F10 key to perform the measurement.

To measure reverberation time in the receiving room, click in the window named Airborne_Reverb Time Receiving
Room (TR) to make it active. If you want to perform the measurement using a loudspeaker and the recommended sine
sweep signal, push the F11 key to perform the measurement. (If you want to perform the measurement using a pistol
or balloon, you need to add the setup named Insulation_Airborne Pistol to the list of shortcuts).

When all the measurements are finished, see the Calculating the final result section on how to to calculate the results.

Go to the Exporting measurement results as text section below for info on how to export the values in the plot.



23.3 Preparation before measuring

23.3.1 Calibrate the input

Calibration is needed to measure the correct sound pressure level (SPL). To do the calibration, please go through the
calibration procedure found in the help file. (In principle calibration to obtain absolute levels is not required since the
main result is found as a difference between levels. But according to the standard the input chain must be calibrated.)

According to ISO 140-4:1997, the accuracy of the sound level measurement equipment shall comply with the
requirements of accuracy class 0 or 1 defined in IEC60651 and IEC60804. Use a sound calibrator to adjust the
complete measuring system including the microphone before each measurement unless otherwise stated. The sound
calibrator must comply with the requirements of accuracy class 1 defined in IEC60942.

We sell a complete solution that includes such equipment, contact us for pricing.

23.3.2 Prepare for saving intermediate raw data results

You should make a new folder to store the results (raw data) of each construction (wall) you are measuring.

Note: If you do not wish to keep any intermediate results you should turn off the ‘Do you want to save’ message. Go
to Measurement->Settings.... In the bottom of the dialog, select

After doing this, you may skip the rest of this section.

Go to Measurement->Saving Defaults... to open the dialog box shown below

Click the  button to open the dialog shown below
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Important! It is strongly recommended that you save the measurements in a subfolder under the directory where
WinMLS is installed or the directory you have selected in Setup->Folder.... If you do not do this, you will not be able
to save all your settings and measurements together in a zip-file from WinMLS as will be described in a section
below.

When you have found the WinMLS sub-folder, then click the  button to add a new folder as shown
in the figure above. Type a folder name.

Click  to exit the dialog and set this folder as the default folder for saving as shown below

Select a filename to be used for the intermediate results (raw data files). In the figure above we have selected Wall1 as
filename.

Make sure  is checked as shown above. Select  in order to start with measuring Level in
Sending room.

The bottom of this dialog is shown below

Your settings should look the same. Set the current counter to ‘1’ 



In the figure above, it is set to measure 10 measurements (which is the minimum according to ISO 140-4:1997). You

can change this by typing another number than 10 here: 

Click  to exit the dialog.

23.3.3 Sound source power

According to ISO 140-4:1997 we have to make sure that the sound power is high enough. The sound pressure level in
the receiving room should be at least 10 dB higher than the background noise level in any frequency band. If the level
is only 6-10 dB higher than the background noise, WinMLS applies a correction for the background noise level. If the
level is 6 dB higher or less, the results should not be used and WinMLS will give a warning about this when the final
result is calculated.

Note: These corrections shall not be used if using the new impulse response based method since the impulse response
method automatically adjusts for the background noise. If using the new method it is therefore not required to measure
the background noise (in the current version it has to be measured, but it should not be used if the measurements are
performed according to the new standard (using sine sweep). If  you need very low background noise, you can perform
the background noise measurement with the microphone disconnected to get a result with very low background noise.)

23.3.4 Microphones and sound source

According to ISO 140-4:1997 the following are minimum separating distances:
• 0,7 m between microphone positions
• 0,7 m between loudspeaker positions
• 0,5 m between any microphone position and room boundaries or diffusers
• 0,5 m between any loudspeaker position and room boundaries (small irregularities of the room boundaries can

be ignored)
• Different loudspeaker positions should not be located in parallel to the room boundaries
• 1,0 m between any microphone position and the sound source

A minimum of five fixed microphone positions shall be used. They shall be evenly distributed within the space
permitted for measurement in the room.

This method is based on using a single sound source. In this case at least two sound source positions must be used.

The loudspeaker should be positioned to give an as diffuse sound field as possible and as far away from the flanking
elements influencing the sound transmission so that the direct radiation is not dominant.
Note: For small rooms you may place the loudspeaker in the corner of the source room. But note that this may
influence the flanking transmission and may give an increase of level fluctuations in the source room.

23.3.5 If your rooms are identical and empty

According to ISO 140-4:1997: 
“Measurements between empty rooms with identical shape and equal dimensions should preferably be made with
diffusers in each room (e.g. pieces of furniture, building boards). The area of a diffuser should be at least 1,0 m^2,
three or four objects will be normally sufficient.”

23.3.6 Room measurement order

We will follow a specific order for measuring the rooms in this document. The first time you go through this
document, we recommend that you follow the procedure in this document.
If you want to measure the rooms in a different order, some modifications in auto-saving the results are required.
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If you would like to measure using two microphones, one microphone in sending room and one in receiving room for
the level measurements, this is also possible but requires a little more manual action.

23.4 Performing the measurements

Place the loudspeaker in the sending room, except when measuring reverberation time in receiving room, then the
loudspeaker must be placed in the sending room.

Three types of measurements are to be performed in the receiving room:
1. Level
2. Background noise
3. Reverberation time

Only level measurement is to be performed in the sending room.

23.4.1 Level in Sending Room

Place the loudspeaker at the first position in the sending room.
Place your microphone(s) at the first position(s) in the sending room.

Note: Before starting a measurement you should be sure that the level will not damage your loudspeaker or your
hearing.

23.4.1.1 Measurement settings for traditional standard (ISO 140-4)

If you are measuring according to the traditional standard, go to Measurement->Settings... and make sure the settings
look like below.

As default, the recording duration is set to approximately 6 seconds as shown below (click the  button in the
dialog above to display this setting).

To increase measurement accuracy, you can increase this number. Alternatively you may perform more measurements
(since the average result is used).

23.4.1.2 Measurement settings for new standard (ISO/WD 18233)

The new standard is based on measuring impulse response and will give more accurate results. If you are doing a
measurement according to the new standard, in Measurement->Settings... select settings as shown below. 



The max. decay time + system delay is here set to 1.5 seconds as shown below.

If you estimate (or measure) your room to have a much different maximum reverberation time than 1.5 seconds, use
this value instead.
You can also increase the duration of the measurement to get a more accurate result, the default is 10 seconds as
shown below.

Note: When measuring in the receiving room you may increase the total duration to get optimal results. The signal-to-
noise ratio is lower in the receiving room since the loudspeaker is placed in the sending room.

23.4.1.3 Performing measurement and plotting data

Click in the window named Airborne_Level Sending Room (LS) as shown below to set it active. WinMLS is set so
the measurement you are going to perform will be plotted only in the active window.

Click  to start the measurement. The calculation may take a few seconds.

Note: The dialog box shown below may be displayed before adding new curves to the plot.
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We do not want this dialog box to be displayed, so make sure  found at the bottom of
the dialog is not checked.

23.4.1.4 Saving intermediate raw data results

This is optional and can be turned off as described in the Measurement preparation section above.
After the measurement is performed and the level is plotted, the Save dialog box shown below will be displayed as
shown below.

Check that the file name is correct. If not, you may click the  button to change the default naming. Note
that after changing the defaults you need to close and reopen the Save dialog box for this to have effect. Reopen the

Save dialog using File->Save As... or the  button.

Click the  button to save if you are satisfied with the measurement. If you are not satisfied with the result,

click the  button. Note that even though you save the measurement, you can remove it from the final result
later.



23.4.1.5 Start a new measurement

Move the microphone to the next position and perform a new measurement clicking the  button and save the
measurement. Repeat this procedure till you have saved 5 measurements (or another number if you did not set the total
number to 10 measurements during the preparation). 
Now move the loudspeaker to a new position and perform measurements in the same 5 microphone positions.

Note: If you do not save exactly the number of measurements that is set in Measurement->Saving Defaults... during
the preparation, the saving default naming will be difficult to follow. (If you want to perform extra measurements for
testing/comparison you can wait with saving these until you have finished all measurements)

23.4.1.6 Results for sending room

The results should look something like below.

 (Fixme: replace picture because title is
wrong)
The green thick curve gives the mean value and is used for the computation of the final result. Note that it is
automatically updated when a curve is added. If you do not wish to include a curve in calculating the mean, you can
uncheck it in the legend (as we have done with Wall1_LS2 and Wall1_LS1 in the figure above).

23.4.1.6.1 How to erase a curve from the plot

If you have performed a measurement that you are not satisfied with, you can click  if you are asked to
save this measurement. Uncheck the curve you want to erase from the legend list by clicking at it. In the example
below Meas. 9 is unchecked.

To erase the curve from the plot, go to Plot->Erase Curves..... Now make sure  is selected as shown
below.

Click  in the dialog to erase the curve.
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23.4.2 Level in Receiving Room

Place the loudspeaker in the sending room.
Place your microphone(s) in the receiving room.

Click in the window named LR – LevelInReceivingRoom shown below to set it active

Click  to start the measurement.

23.4.2.1 Saving intermediate raw data results

If you have chosen to save the raw data, after the measurement is plotted, the Save Defaults dialog box should be
displayed as shown below.

Now  should be set as shown above to indicate that you are now measuring the Level in the
Receiving room. Click the button to exit this dialog box.

Move the microphone to the next position and perform a new measurement clicking the  button and save the
measurement. Repeat this procedure till you have saved 5 measurements (or another number if you did not set the total
number to 10 measurements during the preparation).
Now move the loudspeaker to a new position and perform measurements in the same 5 microphone positions.

Save the number of measurements that you have specified.

23.4.3 Background noise in Receiving Room

The loudspeaker will not be used for this measurement.
Place your microphone(s) in the receiving room.
To measure background noise the excitation signal must be turned off in the measurement settings.

To do this, go to Measurement->Settings... and select  as shown

below. Make also sure that  is not checked (turned off) and that Input signal type is set to 



After doing this, close the dialog box clicking the  button found at the bottom. A faster way of doing this is to
use the F10 shortcut key as described in the shortcut key section. But not that if using this method, the other
measurement settings are also loaded. This means that you may have to reset 

Click in the window named Airborne_Backgr. Noise ReceivingRoom as shown below to route the measurement to
this plot. 

Then click  to start the measurement. It should take about 6 seconds.
After performing the first measurement, the Saving Defaults dialog should pop up. Type in the number of background
measurements you wish to perform, e.g. 6 measurements as shown below.

Now move the microphone and perform a new measurement. Repeat this procedure until you have performed the
desired number of measurements.

Note: You may store these settings so you do not have to set them manually the next time. To do this, go to Setup-

>Store... and click the  button. Make sure  is not checked. Now change the

name to Insulation_Airborne Backg. Noise AutoSave and click the  button. You may also include this
setup in the shortcut list from Setup->Shortcuts.... 

23.4.3.1 When finished measuring background noise

When the measurement of background noise is finished, you should change the measurement settings or load a new
setup. For the traditional standard (ISO 140-4), Measurement->Settings... should be set as shown below.

437



But if you are using the new standard (ISO/WD 18233), Measurement->Settings... should be set as shown below.

23.4.4 Reverberation time in Receiving Room

Place your microphone(s) in the receiving room. Place the loudspeaker in the receiving room. You may want to use an
extra loudspeaker for this measurement so you don’t have to carry the loudspeaker from the sending room. 
The reverberation time is to be measured according to ISO 345 where a loudspeaker is to be used as sound source. But
another method that is used by consultants and supported by WinMLS is to use a starting pistol or balloon (the
measurement can be done without using any loudspeaker).

How to do this for the two possible methods is explained below.

23.4.4.1 Measure using loudspeaker as source

This method should give the most reliable results and is according to ISO 345.
Open Measurement->Settings... and make sure it looks like below if you are measuring with 1 microphone.

If the maximum reverberation time in the room you are measuring is longer than 1.5 seconds, you should type in this
new number instead of 1.5 shown in the figure above. To estimate the maximum reverberation time you can clap your
hands and listen to the decay.

23.4.4.2 Measure using pistol/balloon as sound source

This method is not according to the ISO 345 standard, but is still used because it is faster. Open Measurement-
>Settings... and make sure it looks like below



When you start a measurement, WinMLS will now wait until the input level exceeds –30 dBFs (30 dB below digital
clipping). When the signal exceeds this level, the pistol shot/balloon burst will be recorded in 5.94 seconds and the
reverberation time will be computed.

23.4.4.3 Perform the reverberation time measurement

Click in the window named Airborne_Reverb Time Receiving Room (TR) as shown below to route the
measurement to this plot.

Click  to start the measurement.

After the measurement is plotted, the Save Defaults dialog box should be displayed as shown below

Now  should be set as shown above to indicate that you are now measuring the T30 reverberation
time in the Receiving room. Before closing the dialog box, we also should change the number of measurements.

According to ISO 140-4:1997, the minimum number of decay measurements required for each frequency band is six.
At least three microphone positions with two readings in each case are required in at least one loudspeaker position.

So if measuring according to the standard, you need to use three microphone positions and perform two measurements
in each microphone position. Thus the total number of measurements is 6 and should be set as shown below.
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Now click OK to exit the Saving Defaults dialog box.

Perform a new measurement using the same microphone position. Move the microphone and perform two
measurements. Finally move the microphone once more and perform two measurements. You should now be ready to
calculate the final result.

23.4.4.3.1 Quality check of reverberation time measurements

To check the quality of a measurement, go to Calculate->Reverb Times (RT-60) and you will see a table as shown
below.

In the table above, you can check that the T20 and T30 numbers are similar. 
The corr number indicates how linear the reverberation curve is and should be as close to –1 as possible.
The ‘edr’ gives the effective range of the decay curves and based on this value the numbers are either given a green
(Data Acceptable) or red (Data Questionable) color.
You may set WinMLS not to include the reverberation time number that have a too low edr value. To do this, click in
the Reverberation Time plot, then click the F5 key to open the plot settings. In the figure below we see that the default
edr value is set to 15 dB and the T30 is plotted. You may also set WinMLS to plot T20 instead of T30 if that is
desired.

23.5 Calculating the final result

When you have performed measurements in all windows, except window named Airborne_Result as shown in the
figure below, the final results can be calculated.



Note! The order of the windows and titles may be slightly changed.

Before calculating, you must set the volume and area. To enter these data, you need to open the settings for
computation. First click in the empty window named Airborne_Result shown below to make it active.

Then go to Plot->Plot Type Settings->Airborne Sound Insulation… (or push Shift+Ctrl+A) to open the Airborne
Settings. The dialog box that will be displayed is shown below.
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Here you can type the volume and area and select what parameter you want to plot. The reference reverberation time is
usually set to 0.5 s; normally this number should not be changed by the user. This reference reverberation time will
affect the D (D, Dn, DnTw) parameters only – not the R parameter (R).

Click  to close both of the two dialog boxes.

First click in the window named AirborneResult. Then click on the  button or use Plot->Add Curve(s)... to
calculate and plot the result. Note: The refreshing of this plot behaves somewhat different than the normal plot types
since the result depends on the content of the other windows.

Then the result should look something like below

You can perform more measurements or select which ones you want to include in the computation by using the
checkboxes in the windows shown below.

To update the curves in the plot shown above, click in the plot to make it active and then click the  button (you

may have to first delete using the  button for this to work).

23.6 Saving the measurement data and plots for later usage

It is possible to save everything (all the plots and the measurements present in memory) in one operation to a zip-file
that you can later open in WinMLS.

Go to Setup->Store... to open the dialog shown below.



The measurements are included if the checkbox shown below is checked in Setup->Store....

Click  to store the setup. Note that only the saved measurements are included and they must be saved
under the WinMLS sub-folder. If you have followed the instructions given in this documentation, this has already been
done.
Note also that when you restart WinMLS, old measurements will be included. You can remove these measurements by
storing the setup without including the measurements and then reloading the setup.

Go to Setup->Export.... The dialog box shown below will be displayed.

n

Select the folder where you want to save your data. Type the desired name and click the  button to
complete the saving.

23.7 Opening an exported setup zip-file

If you want to open the exported setup (see section above on how to export a setup), you have to unzip the file to a
folder. If you unzip to the folder where WinMLS is installed the current setup files will be overwritten.
It is therefore recommended that you select a new folder from Setup->Folder.... 

In the example below, we will use the folder name C:\data.
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Now extract the zip-file containing the setup you want to open to the folder C:\data.
Then go to Setup->Folder.... as shown below, select the folder name C:\data.

Then go to Setup->Load... and select the name of the setup you want to load. The name will be the name as the setup
name when you exported it.

Now you should have restored the settings you had when you stored the setup including the measurements.

After doing this, you must reset the setup folder to the original folder, e.g. to C:\winMLS2004, following the
procedure given in this section.

23.8 Print/copy measurement results

The measurement results can be copied or printed.
First click in the window where the curves you want to export belong to make it active.
To copy the plot to clipboard use Edit->Copy Plot.... Then you can easily paste the plot in programs such as MS
Word.
To print the plot, use File->Print....
Note that if you want to print all plots, use File->Print All....

23.9 Exporting measurement results as text

All measurement results (intermediate as well as final) can be exported in text format.

23.9.1 Export values in plot(s)

To write the values of the curves to a text-file, use File->Export Data.... In this dialog, you may select different
options, they should be set as shown below:

If you only want to export the data in one of the plots, make sure that  is not checked and
before exporting, click in the window where the curves you want to export belong to make it active.

To copy the values of the curves in the plot(s) to the clipboard, use Edit->Copy Data.



23.9.2 Export correction factors in footer

To export only the correction factor data in the footer, click in the AirborneResult window to make it active. Then click F6 (same
as Plot->Layout->Edit...) to open the dialog box shown below.

Set the tabs as shown in the figure above (Chart tab, Titles tab, select Foot in list box). 
Mark all data shown in the bottom of the dialog.
Type <Ctrl> + <C> to copy the data to clipboard.
Then paste the data, an example of the pasted data is shown below:

MaxDev: 5, C=-1, Ctr=-1, C50-3150=-1, C50-5k=0, C100-5k=0, Ctr50-3150=-1, Ctr50-5k=-1, Ctr100-5k=-1

23.10Troubleshooting and FAQ

23.10.1I don’t like the sound of the sine sweep. Can a noise-like signal be used instead with the new
standard?

Yes, in most cases you can use the noise-like signal MLS instead of the sine sweep. This MLS-method has been used
for commercial sound insulation measurements in difficult noisy situations for several years.

Go to Measurement->Settings.... If you select the settings shown below (MLS and Emphasis: Pre + De) the
excitation will sound like pink noise, but the accuracy will be better.

Note: Using the MLS signal is not recommended if you have time variance (wind, temperature gradients) during the
measurement. MLS is not robust against distortion either, so if using the sweep method you can use a higher output
level.
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Because of these two weaknesses we have selected to use sweep as default and allow MLS as an option.

23.10.2How to increase the accuracy of the measurement in cases with very high sound insulation?

To get the best results, three things are important

4. Use sine sweep as excitation signal if you are using the new proposed standard (why will be in sections
explained below)

5. Use as long measurement duration as possible.
6. Make sure you have as high output volume as possible from the loudspeaker. If you are using a sine sweep as

excitation signal, be careful so you don’t burn up the loudspeaker. If you are using MLS-noise as excitation
signal, a too high output level should be avoided to prevent artifacts from the distortion. Experiment with
different levels to see what gives the best results.

This can all be done from Measurement->Settings....

23.11Remarks on the new proposed ISO/WD 18233 standard

Note that using the impulse response methods of the new standard, the source must be fixed. The source should not be
moved during a measurement.

The new standard draft can be obtained by contacting us. We are also interested in feedback on the new proposed
standard. If you plan to perform measurements using both the new and the old standard, we are interested in hearing
what your experience is.

23.11.1Level measurement based on the impulse response.

For a discussion about this, see chapter 5.3.5 Limits for the time integration in the ISO/WD 18233 proposed
standard document. WinMLS may detect the background noise automatically and compensates for it. However, this
method may fail in some cases, especially in the low frequency bands.

Background noise correction should not be used if using the new proposed standard ISO/WD 18233. Therefore we
recommend opening a measurement that has very low background noise levels.
This is because, according to ISO/WD 18233: “The new measurement methods may be used to measure the effective
signal to noise level and thus compensate for influence from the noise automatically and as a part of the method. If the
noise compensation is a part of the method, no further noise compensations shall be applied, even if stated in the
description of the classical method.”

If you are interested in experimenting with the level measurement, you may change the length of the time window.
According to the new proposed standard, the time window could be set to half the reverberation time. In this setup it is
set to include the whole impulse response. To change this, go to Plot->Plot Type Settings->Time Window…. In this
dialog, make sure that  is not checked. Then set the upper limit to the number you desire

.

WinMLS is also capable of automatically detecting the noise floor for each third octave band for the level
measurement. This method is the same as used as default when computing room acoustical parameters.
To set this, click in one of the Level plot windows to make it active. Then at the bottom of WinMLS, find the list box
shown in the figure below.



In this list, select the plot type named Room Acoustics. WinMLS is set up so that then the parameter Strength will be
displayed, which gives the level in each third octave band. The Strength parameter is set to display the level and
automatically detect the noise floor.
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