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1 File Menu Reference

Several file operations are accessed via the File menu as shown below.
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1.1 New Group [image: image83.bmp]
Creates a new window displaying one or two plots. It is named group, since the window may contain a group of measurements.

1.2 Insert in Active Group... [image: image84.bmp]
Inserts measurement file(s) to the active measurement group window. Text-file(s) containing data that is to be plotted may also be inserted. A browser is displayed where one or several files may be selected. File types to be displayed in the browser are:
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Information about the file formats is given in the Open Group... section below.

1.3 Open Group... (Ctrl+O)
Opens a measurement, text or plot file in new measurement group window.

Open Group... does the same as Insert in Active..., except:

1. Open Group… will open a new window using the settings in the current plot window while Insert in Active Group… will insert the data in the active plot.

2. Plot chart file type (*.tee) may only be selected from Open Group..., because it is a new plot and can not be inserted to a current plot window.

1.3.1 Browser: Open

A browser is displayed. File types to be displayed in the browser are:
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The file types are described below

1.3.1.1.1 Measurement Files (*.wmb, *.wmt, *.wav, *.tim)

Lists the measurement file types described below.

1.3.1.1.2 WinMLS Binary Files (*.wmb)

The recommended file type, binary file including header. The header contains information about the sound card and other measurement settings. The header has been extended since WinMLS ver. 2, but the old file format may still be read.

1.3.1.1.3 Measurement Text Files (*.wmt)

File type in text format. It has a header containing some measurement settings. Note that the scaling may not be correct when using this format.

1.3.1.1.4 Mono 16-bit WAV Files (*.wav)

Wave-file, the common binary format for PC audio. If the .wav-file was generated using WinMLS it contains the same header as the *.wmb-format is using. Note that the scaling will not be correct when the .wav-file is saved in WinMLS using the normalization option. Since the format is 16-bits, it is recommended that it is normalized when saving to obtain the best possible resolution.

1.3.1.1.5 Measurement MLSSA files (*.tim)

File type used by the software MLSSA. Note that the scaling may not be correct when using this format.

1.3.1.1.6 Plot Chart Files (*.tee)
File type containing the chart settings used in the plots. These are the settings found in Plot->Chart Settings for Active Plot, e.g. background gradient color, mouse zooming and axis settings.

If such a file type is opened, it is done in a new window.

1.3.1.1.7 TAB-separated Data (*.txt)

Not supported in the current version!!! Text-file containing data that is to be plotted. The data must be grouped in columns and separated using TAB. One column of data plots one curve using 0,1,2,3.... as x-axis. Several columns of data will use the first column as x-axis and plots the remaining as curves. All columns must be the same size.

1.4 Close 
Closes the active window. If there are any unsaved measurements in the window, the user is asked to save or not.

1.5 Save Active Measurement As... [image: image87.bmp]
Saves the measurement that is active in the plot window in time domain (e.g. the result of a MLS measurement is an impulse response). The file formats are described in the Open Group... chapter above.

If the active measurement is a performed 1-channel measurement or opened from file, the 1-channel browser is displayed. If a 2-channel performed measurement is active, the 2-channel browser is displayed. If a > 2-channel performed measurement is active, the multi-channel browser is displayed. These three browsers are shown below. Note that it is possible to increase the size of the browsers by dragging in the lower left corner.

1.5.1 Browser for saving 1-channel measurement
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The usage should be quite intuitive. The defaults and other settings for saving are set by clicking the button [image: image89.png]Defaits for saving.



 which is the same as Measurement->Defaults for Saving….

1.5.2 Browser for saving 2-channel Measurement

Note that a 2-channel measurement is saved as two separate files.
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The usage should be quite intuitive. The defaults and other settings for saving are set by clicking the button [image: image91.png]Defaits for saving.



 which is the same as Measurement->Defaults for Saving….

1.5.3 Browser for saving multi-channel (>2 channels) Measurement

Note that a N-channel measurement is saved as N separate files.
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The usage should be quite intuitive. The defaults and other settings for saving, such as the multi-channel tag are set in Measurement->Defaults for Saving….

1.6 Save Active Measurement

Displays sub-menus for saving the active measurement shown below.
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Each item is explained below.

1.6.1 As Measurement System Correction File

Saves the active measurement as measurement system correction files and sets it as active in the measurement system correction part of Measurement->Hardware Calibration.... It is named activemeas. If the active measurement is a multi-channel measurement, each channel will be corrected.

In order to turn on the measurement system correction feature, click the [image: image94.bmp] button on the Measurement Settings Toolbar.
1.6.2 With Filename <_ActiveMeas_>

Saves the using the filename '_ActiveMeas_'. The folder and extension is taken from Measurement->Defaults for Saving.... Note that if a measurement with the same name already exists, it will be overwritten.

If the active measurement is multi-channel, channel 2 get the name '_ActiveMeas_2', channel 3 gets '_ActiveMeas_3' and so on.

This is the fastest way of saving a measurement and is well suited if another application, e.g. MLSSA, is used to export measurements while measuring with WinMLS.

1.7 Save Data in Active Plot As...

Saves the curves in the plot as columns in a .txt-file.

All curves belonging to a measurement in the plot are saved as columns using tab as separator. A one-line header contains the title of the columns. The first column of the header is named ”x-axis”, the next column(s) are given the name of the series title (maximum 30 characters). The character Tab is used as column separators in the header also.

If the x-axis is not the same for all curves in the plot, a x-axis is constructed that contains all the x-axis values for all the curves. This is the case e.g. if the sampling frequency is not the same, e.g. if a value is missing e.g. when plotting reverberation time and the signal-to-noise ratio si not good enough to compute a value. If a y-value does not exsist at a certain x-value, the text “NaN” is written to indicate that it is not a number.

Note that an alternative method that gives access to advanced settings is found in Plot->Chart Settings for Active Plot..., click the Export tab, then click the Data tab. The dialog box will then show the settings below.
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These writing procedures are slow if data with more than 10000 poins are to be saved. Therefore, if you want to save the time data (impulse response) we recommend that you use the File->Save Active Measurement As... procedure and use the .wmt format. That will save the time data as a text file with a short header.

If you have problems exporting the data to a spreadsheet, e.g Excel, see the FAQ: Room Acoustics section for more information.

1.8 Save Active Plot As...

Saves the active plot in one of the formats shown below
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A method giving access to more advanced settings is found in Plot->Chart Settings for Active Plot..., click the Export tab. The dialog box will then show the settings below.
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From the example in the figure above, we see that it is possible to set the quality and size when saving as .jpg-file.

1.9 Print Active Plot [image: image98.bmp]
Prints active plot in active window.

1.10 Print Preview Active Plot... [image: image99.bmp]
Print previews active plot in active window.

As we see in the figure below, this dialog box can be used to determine printer, set orientation, margins and amount of details in the plot.
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1.11 Convert Measurement(s)... 

Converts a measurement file of one of the supported formats to one of the other supported formats.
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The dialog box above shows an example on how to convert three files of the format .wmb to .wav. The .wav-files are put under in the Target path.

Note that it is recommended that you normalize if converting to .wav-file by making sure [image: image102.png]V' Normalize if saving as .wav-file



 is checked.

When clicking [image: image103.png]Convert




 the files will be converted and a progress dialog will appear as shown below. This may be hidden behind the Convert Measurement(s) dialog box, but if there is errors in the conversion it will be displayed. It will also be displayed if you exit the Convert Measurement(s) dialog box
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Please note that if you have a *.tim or *.wav file, you can insert/open it directly in WinMLS and do not have to do this conversion first.

When converting from *.wmb to *.tim, the MLSSA setup file ‘MLSSAsetupFile.set’ is used to determine the parameters that cannot be determined from the *.wmb file. The file ‘MLSSAsetupFile.set’ is found in the WinMLS folder and may be replaced if you wish to use other parameters.

If you have a *.wmb file and convert it to *.tim and then convert it back to *.wmb, some measurement information will be lost since the headers of these file formats do not contain the same settings. 

1.12 Exit

Closes all windows and quits WinMLS. 

Measurement and post-processing setups are saved to temporary files so the settings are the same the next time WinMLS is opened.

2 Edit Menu Reference
2.1 Copy to clipboard [image: image105.bmp]
Copies the active plot to the clipboard so that it may easily be pasted to other software, such as Word.

3 View Menu Reference
From this menu you can select which resources you wish to view on your screen. The ones which are viewed are check-marked as shown in the figure below. 
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Note that the toolbars can be moved around and the positions are saved in the post-processing setup file.

3.1 Volume and Input Level(s) Dialog

Displays a dialog box for setting volume and input level(s).

The content of the dialog box to be displayed depends on the settings. If the WinMLS mixer is used and if measuring in sync. loop-back mode (see Measurement->Sound Card Settings...), it will look like the figure below.
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If sync. loop-back mode is not used, the controls Sync.Out and Sync. Input are not needed and will not be displayed in the dialog box. The horizontal waitbar at the bottom of the dialog box informs the user about the measurement progress.

The level indicator lamp shown to the right in the figure above is colored red if there has been clipping during a measurement. If this is the case, the measurement is probably wrong.

The sliders are used to set the volumes. If the mixer is not calibrated, Uncal. will be written above the volume which may be given a value in the range 0-65535. Changing the volume from e.g. 20000 to 20001 will usually not make any difference. How much it has to be changed to actually change the volume is sound card dependent. 

The calibration procedure will determine the volume in dB, and if calibration is turned on (Measurement->Hardware Calibration) the last part of the dialog box shown in the figure above will look as shown below.
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It is now possible to see how much the volume is changed in dB, and this information is used to determine the absolute gain of the systems to be measured.

If the sound card does not support the WinMLS mixer, WinMLS is not able to set the volumes and the dialog shown below will be displayed.
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3.2 Measurement Selection Toolbar

The Measurement Selection Toolbar is used for selecting measurement mode and measurements for post-processing.
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3.2.1 [image: image113.png]ML




 Measurement mode

The measurement modes are shown in the figure below.
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3.2.1.1 MLS

This is the default measurement mode and should be used for measurements of impulse/frequency response. The MLS-specific settings are found in the Measurement Settings Toolbar.

3.2.1.2 MLS (scope)

This mode is similar to the MLS mode, except that no post-processing (Hadamar transform) of the recorded signal is performed. This may be useful for detecting errors.

3.2.1.3 No excitation (scope)

In this mode, no signal is played. It is intended for analyzing a signal, such as finding the background noise level. The length of the recorded signal is also given hereby the sequence order in the Measurement Settings Toolbar.

3.2.1.4 Trigged, no excitation (scope)

This mode is intended for analyzing impulsive signals. It is similar to the No excitation (scope) mode except that the maximum of the signal is automatically detected and the signal shifted so the maximum is found after 150 samples.

3.2.1.5 Sinusoid (scope)

A sinusoid is used for excitation, otherwise the mode is similar to No excitation (scope).

Measurement->Sinusoid Settings sets the frequency and level of the output signal.

3.2.1.6 Excitation from file

In this mode, any 1-channel excitation signal may be specified as a file. The file must be put in the WinMLS folder and be named WinMLSExcitation.wav (currently only wav-files are supported). An example file is found in the WinMLS folder. The output is normalized.

The number of sample played is set from the Measurement Settings Toolbar. In the figure below, using a sequence order of 14, 2^14 samples are played at a sampling rate of 48000 Hz. This gives a length of the recorded data of 0.341 sec. as shown below.
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Note that the number of averages and number of averages to pre-send found on this toolbar, will also apply in this mode.

3.2.2 [image: image116.bmp] Delete unplotted measurements from memory 

Same as File->Delete unplotted measurements.

3.2.3 [image: image117.png]\Studios!Studiol . wmb.




 Active measurement in upper plot

From the combo box to the right of the[image: image118.bmp] icon, the active measurement in the plot is selected (if two plots are displayed in the window, it selects the active measurement in the upper plot). All the performed and inserted measurements are available from the combo box list. 

3.2.4 [image: image119.bmp] Update both plots with the same measurement 

If the active window contains two plots and if [image: image120.bmp] is toggled, the combo box to the left of the button will determine the active measurement for both plots. If it is not toggled, the combo box to the right of the button will determine the active measurement in the lower plot, given that [image: image121.bmp] is toggled (see two chapters below).

3.2.5 [image: image122.png]\ConcertHallfig.way




 Measurement in lower plot or reference measurement

This combo box displays the active measurement in the lower plot if [image: image123.bmp] is toggled. If [image: image124.bmp] is toggled, it displays the reference measurement (the reference measurement is used for division).
3.2.6 [image: image125.png]


 Select “lower plot measurement” or “reference measurement” in combo box

As explained in the chapter above, the status of these two toggles, determines what the combo box to the left of the toggles will display, the active measurement in the lower plot or the reference measurement.

3.3 Measurement Settings Toolbar

As different from the other toolbars, none of the settings in this toolbar can be found in any dialog box. If you intend to use WinMLS for advanced MLS measurements, this toolbar should be useful. It is, however, hidden in the default setup since new users may find it confusing.

[image: image126.png]]

[tcn. ~|fsoo0 |15 ~lpawsen | =lprsen [+ =]~ =] 82 b Jollioweoostzooris =]





3.3.1 [image: image127.png]


 Number of Channels to Measure

From this combo box choose the number of channels you want to measure. If this is set to 1 ch., one impulse response is the result of a MLS measurement. If it is set to 2 ch., two impulse responses will be the result and so on. WinMLS is capable of measuring up to 24 separate channels. In the standard versions 1 or 2 channels are offered, if you need more please contact us.

3.3.2 [image: image128.png]


 Sampling Frequency

The sampling frequency determines how many samples per second the sound card transmits and receives. It determines the frequency range of your measurements. Theoretically the frequency range is half the sampling frequency (Nyquist criterion). You may get close to this limit if you correct for the influence of the measurement system. 

The supported sampling frequencies is sound card-dependent, most sound cards support 11025, 22050 and 44100 Hz. The newer cards support 48000 Hz, and some new cards 96000 Hz. A sound card that supports 192000 Hz should soon be available. 

You may select the sampling frequency from the list of the most usual sampling frequencies, but you can also write the number directly in the window. If the sound card does not support the selected sampling rate, an error message will appear when trying to start a measurement.

3.3.3 [image: image129.png]14



 Sequence Order

Range: Typically 11-20 using PC with 16 MB RAM, or even higher order with more RAM.

The important thing to know about the Sequence Order is that it determines the number of samples of the measured data. See Length of Measured Data, which is discussed below.

The sequence order determines the number of samples in the maximum length sequence (MLS). The number of samples in the MLS is given as 2^ (Sequence Order) – 1. When the MLS measurement method was first introduced, the maximum length sequence was generated using shift registers. By connecting the shift registers in a special way it was found that a Maximum Length Sequence could be generated. This was the longest sequence that could be made before it repeated itself, and the length was given as 2^(# of shift registers) - 1. The Sequence Order is the same as the number of shift registers used to generate the sequence. It was found that this sequence had very useful properties for measurements. 

3.3.4 [image: image130.png]D.341 sec.



 Length of Measured Data

The Sequence Order and the Sampling Frequency gives the length of the measured data. Increasing the sequence order increases the length of the measured data, while increasing the sampling frequency decreases it. When measuring systems with long delays, such as a room, this number should be increased. If it is too low, the measured impulse response may have time aliasing. This is because the impulse response has not finished its decay. 

3.3.5 [image: image131.png]16



 Number of Averages

The number of averages determines how many times the MLS signal is repeated during the measurement. The desired number of coherent averages (pre-averages) can be typed in the edit window or chosen from the list. Up to 256 averages can be done if the sound card resolution is 24 bits, and 65536 averages if it is 16 bits.

The reason for averaging is that it will decrease uncorrelated noise and thus increase the quality of the measurements. For doubling of the number of averages, the signal-to-noise ratio is theoretically increased with 3 dB. 

The total measurement time increases when the number of averages increases. Note that if the system you are measuring is somewhat time-variant, a long measurement time can decrease the quality of the measurement. An example of a time-variant system is a concert hall where people are running around. Try to avoid measuring during such situations. In any case, for room acoustical measurements, a measurement time of more than 60 seconds is not recommended. Electrical or mechanical systems are usually very little time-invariant, so for those long measurement times seldom is a problem.

3.3.6 [image: image132.png]


 Total Meas. Time

The total measurement time is displayed here. It is approximately given as Length of Measured Data multiplied by the number of averages plus pre-sent sequences (explained below). If measuring in loop-back mode, add approximately two seconds.
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 Number of sequences to pre-send

This parameter decides how many times the excitation signal is to be played before the input signal is recorded and the measurement actually takes place.

When measuring using the MLS method, the excitation signal must be played at least once before recording the result. This is because the system to be measured has a transient immediately after the excitation that must be suppressed. After playing one sequence, this should have died out if the other parameters are correctly set. Therefore, the number of sequences to pre-send should be set to 1 or more when using MLS as excitation signal. If no excitation signal is used, this parameter is ignored.

3.3.8 [image: image134.png]


 Sequence Type

Two different types of sequences for MLS measurements are available, A or B. This feature is meant for distortion/non-linearity checking. Non-linearity causes spurious peaks in the impulse response. The peaks are replications of the true impulse response. For measurements using a different sequence, these peaks are situated at different places in the impulse response. By visually inspecting two impulse responses measured with different sequences, the amount of non-linearity may be determined. Distortion/non-linearity is usually caused by the transducers (either microphone or loudspeaker) and may in some cases be reduced by reducing the volume.

3.3.9 [image: image135.bmp] Measurement System Correction

Using this option will correct your measurements for the influence of the measurement system. But in order to do this, your measurement system first has to be measured. The procedure for this is described in the FAQ. Measurement System Correction is not recommended if you measure without using synchronization loop-back because a linear phase shift is added since the start of the impulse response may not be correctly determined. Also the magnitude frequency response may in some cases be incorrect because of this shift of the impulse response.

If you measure using synchronization loop-back, you might experience a small tail at the very end of the impulse response. This is a result of the correction filtering procedure. If this tail is more than –50 dB below the maximum of the impulse response, it should be nothing to worry about for most applications.

When the Measurement System Correction is turned on, the relative amplification will be measured, even if no level calibration has been performed. If the amplification of the system you are measuring has increased 5 dB after you performed the reference measurement, the peak of the impulse response will be at 5 dB. The linear amplification may be displayed by plotting for example the first part (it is given by the maximum) of the impulse response using linear axis. To plot the amplification in dB, do the same using logarithmic x-axis, or plot the magnitude frequency response.

3.3.10 [image: image136.bmp] Pre-emphasis

This option will pre-filter the excitation signal using the filter found in the Type of Emphasis combo box described below. 

3.3.11 [image: image137.bmp] De-emphasis

This option will post-filter the recorded signal using the inverted filter found in the Type of Emphasis combo box described below. 

3.3.12 [image: image138.png]|LowBoost200HzS ¥



 Type of emphasis

This combo box contains the filter(s) used for pre- and de-emphasis. The MLS signal is initially white, which means that it contains an equal amount of all frequencies. For most acoustics measurements it gives a better result to use a signal that gives more power to the lower frequencies. Selecting LowBoost200HzShelvingFirstOrder it will boost the frequencies below 200 Hz with 20 dB using a first order filter. For more information read How to add pre-filtering (emphasis) to the excitation signal (MLS)? in the FAQ.

3.4 List of Curves Toolbar

This toolbar gives immediate access to the curves in the active plot.
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The operations described below can be done from this toolbar. Note that if two plots are displayed in the window, the operations will only affect the active plot.

3.4.1 Deleting curve(s) from the plot

A curve may be deleted by first marking it, then pushing the Delete key. In the figure above, the curve named CurveMeas. 2 is marked since it has a blue background. Note that if several curves are marked, they may all be deleted.

3.4.2 Dragging curves to change the order 

If a curve in the toolbar is marked (CurveMeas. 2 in the example above), the curve may be dragged up or down using the mouse. Note that the curve at the end of the list is displayed as the top curve in the plot. In the figure above, CurveMeas. 3 will be displayed on top, while CurveMeas. 1 will be below all the other curves.

Note that if several curves are marked, they may all be dragged.

3.4.3 [image: image140.bmp] Change curve type

Clicking on this icon, will display a dialog box where a new curve type may be selected.

3.4.4 [image: image141.bmp] Display the curve

If [image: image142.bmp] is checked, the curve will be displayed in the plot. If not it will not be displayed but is present in memory and may be displayed later.

3.4.5 [image: image143.bmp] Change the curve color

The color of a curve may be changed by clicking [image: image144.bmp] (found to the left of Curve Meas. 1 in the figure of the toolbar above). A dialog box will be displayed from where a new color may be selected.

3.5 Plot Toolbar

This toolbar should be found very useful. It contains settings for zooming in x- and y-direction, selecting one or two plots, which plot type(s) to be displayed and finally a button for accessing the settings of the active plot type. In the figure below we see a plot with the toolbar on top.
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Note that if two plots are plotted in the current window, the settings for the active plot will be displayed in the toolbar. It is a good exercise to click in the other plot to set it active and see how the toolbar settings will change.

3.5.1 [image: image146.png]=10




 Setting the lower x-axis limit

The controls shown above are used to set the lower x-axis limit. 

If auto-scale lower x-limit [image: image147.bmp] is toggled, the minimum x-value of any of the curves in the plot will be used as minimum value. The edit window [image: image148.png]


 shows the current value, 10 Hz in this example. It is possible to type a new value, but remember to validate it by clicking Enter.

The controls [image: image149.bmp] are used for moving the limit in either left or right direction.

3.5.2 [image: image150.png][—=] [24000




 Setting the upper x-axis limit

The controls shown above are used to set the upper x-axis limit. 

If auto-scale upper x-limit [image: image151.bmp] is toggled, the maximum x-value of any of the curves in the plot will be used as maximum value. The edit window [image: image152.png]| 24000



 shows the current value, 24000 Hz in this example, which is the maximum in x-direction since [image: image153.bmp] is toggled. It is possible to type a new value, but remember to validate it by clicking Enter.

The controls [image: image154.bmp] are used for moving the limit in either left or right direction.

3.5.3 [image: image155.png]


 Setting the lower y-axis limit

The controls shown above are used to set the lower y-axis limit. 

If auto-scale lower y-limit [image: image156.bmp] is toggled, the minimum y-value of any of the curves in the plot will be used as minimum value. The edit window [image: image157.png]


 shows the current value. It is possible to type a new value, but remember to validate it by clicking Enter.

The controls [image: image158.bmp] are used for moving the limit either up or down.

3.5.4 [image: image159.png]-84




 Setting the upper y-axis limit

The controls shown above are used to set the upper y-axis limit. 

If auto-scale upper y-limit [image: image160.bmp] is toggled, the maximum x-value of any of the curves in the plot will be used as maximum value. The edit window [image: image161.png]ENE



 shows the current value. It is possible to type a new value, but remember to validate it by clicking Enter.

The controls [image: image162.bmp] are used for moving the limit either up or down.

3.5.5 [image: image163.bmp] Auto-scale the plot in all directions

This is a very method of auto-scaling a plot.

If [image: image164.bmp] is toggled, the plot is auto-scaled in all x- and y-direction. As a result of this, all the four buttons [image: image165.bmp], [image: image166.bmp], [image: image167.bmp] and [image: image168.bmp] will be toggled. So clicking [image: image169.bmp] has the same effect as clicking all these four buttons.
3.5.6 [image: image170.bmp] Display one or two plots in the window

If [image: image171.bmp] is not togged, one plot is displayed in the active window as shown in the left part of the figure below. If [image: image172.bmp] is toggled, two plots are displayed in the active window as shown in the right part of the figure below. 
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3.5.7 [image: image175.png]|Frequency Response - 5 ¥



 Plot Type in Active Plot

This combo box contains the plots shown in the figure below and lets the user select which plot type the active plot should contain.
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3.5.8 [image: image177.bmp] Settings for the Active Plot

Clicking on this button will display a dialog box containing the settings for the active plot. An alternative method is to double click in the active plot.

3.6 Frequency Plots Toolbar

This toolbar gives quick access to settings useful for all the general frequency domain plot types (magnitude, phase, group delay and waterfall).
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Note that if two plots are displayed in a window, the toggles will affect only the active plot. An exception is the toggles involving the “global” Plot->General Frequency Domain Settings….

[image: image179.bmp]
Logarithmic x-axis. Same as [image: image180.png]Kebis: ~



 found in the plot type settings. In case WinMLS is displaying two plots, only the active plot will be refreshed when the button is clicked.
[image: image181.bmp]
Smooth curve. Same as [image: image182.png][ Use Smoothing



 found in the plot type settings. In case WinMLS is displaying two plots, only the active plot will be refreshed when the button is clicked.
[image: image183.bmp]
Invert curve. Same as [image: image184.png][ Invert resulting response [complex]



 in Plot->General Frequency Domain Settings…

[image: image185.bmp]
Microphone compensation. Same as [image: image186.png][ Microphaone:



 found in settings for the Frequency Response/Spectrum plot type
[image: image187.bmp]
Display guidelines on frequency response. Same as [image: image188.png][ Add Guidelines



 found only in settings for Frequency Response/Spectrum plot type
[image: image189.bmp]
Perform division using reference measurement. Same as [image: image190.png][ Divide [complex] active meas. with reference measurement



 in Plot->General Frequency Domain Settings…

[image: image191.bmp]
Update reference measurement on new measurement. Same as [image: image192.png][ Update after new measurement



 in Plot->General Frequency Domain Settings…

[image: image193.bmp]
Display time window settings for the reference measurement. Same as [image: image194.png]Time

indow settings for Reference Measurement,



 in Reference measurement group in Plot->General Frequency Domain Settings…

[image: image195.bmp]
Display time window settings for the active measurement. Same as [image: image196.png]Time Data plot type settings.



 in Active measurement group in Plot->General Frequency Domain Settings…

[image: image197.bmp]
File->General Frequency Domain Settings…

[image: image198.bmp]
Waterfall slice scrolling downwards, used to set the active slice, for reading cursor values displayed at the Status Bar. The active slice gets a green color. This button is enabled only if the waterfall layout mode in the waterfall plot type settings is Separate lines waterfall as shown in the figure below.
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[image: image200.bmp]
Waterfall slice scrolling upwards, used to set the active slice, for reading cursor values displayed at the Status Bar. The active slice gets a green color. This button is enabled only if the waterfall layout mode in the waterfall plot type settings is Separate lines waterfall as shown in the figure above.
3.7 Time Window Toolbar

This toolbar will set the time window used for FFT-calculation for the frequency domain plot types. Below the toolbar is displayed together with the Time Data plot type. The time data window is displayed in yellow.
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3.7.1 [image: image202.png]= g




 Setting the lower window limit

The controls shown above are used to set the lower window limit. 

The button [image: image203.bmp] will move the time window to the lowest possible value. 

The edit window [image: image204.png]|2.979



 shows the current value in the unit displayed in [image: image205.bmp] as will be explained below. It is possible to type a new value, but remember to validate it by clicking Enter.

The controls [image: image206.bmp] will move the window one sample in each direction and is thus to be used only if very small moves are required.

3.7.2 [image: image207.png]


 Setting the upper window limit

The controls shown above are used to set the upper window limit. They work similar to those described in the chapter above, so no further explanation should be needed.

3.7.3 [image: image208.png]


 Window length

This control shows the total window length in the unit displayed in [image: image209.bmp] as will be explained below.
3.7.4 [image: image210.bmp] Window x-axis unit

This control displays the unit of the x-axis. In the figure above it is set to ms, which means that the unit is milliseconds. The unit is always the same as the x-axis unit for the Time Data plot type.

3.7.5 [image: image211.png][Rectangular




 Time data window type

The possible window types are shown below.
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Note that when windowing transient signals such as impulse responses, a rectangular or half window should be used. A full window is usually used for stationary signals.

3.7.6 [image: image213.bmp] Display time window in time data plot type

If this is toggled, the selected time window will be displayed when plotting Time data.

3.8 Setups Toolbar

Using this toolbar is a convenient way of loading and saving the measurement and post-processing setups.

[image: image214.png]£





The purpose of this dialog bar is to make it easier for the user who wants to work with setup files. All the WinMLS settings are saved in setup files. From this toolbar most things can be done, except deleting a setup file which can be done from Measurement->Save/Load Measurement Setup… or Plot->Save/Load Post-proc Setup….

The save diskette-icon would change appearance when the setup is changed, e.g. it is disabled when it is not changed. This is the way for the user to see if the settings have been changed, this I think will be useful!!!

3.8.1 [image: image215.png][MasterSetup



 Select a new Measurement Setup

From this combo box a new measurement setup may be loaded. In addition to the measurement settings, post-processing settings will also be loaded, since the measurement setup contains a link to the post-processing setup. This measurement setup combo box thus is able to load all WinMLS settings.

3.8.2 [image: image216.bmp] Save Measurement Setup

Click this button to save the measurement setup, the Save As dialog box will be displayed, this will be described under Measurement->Save/Load Measurement Setup….

If any of the measurement settings are changed, the icon turns red [image: image217.bmp]. This way the user will be notified that the settings have been changed since the last setup was loaded.

3.8.3 [image: image218.bmp] Save link to post-processing setup

If this is toggled, a link to the post-processing setup will be saved when the measurement setup is saved. This means that when the measurement setup is loaded, the linked post-processing setup will also be loaded. The toggle is the same as the [image: image219.png][ Save link to post-processing setup



 setting in Plot->Post-processing Setup….

3.8.4 [image: image220.png][PostProcSetup




 Select a new Post-processing Setup

From this combo box a new post-processing setup may be loaded.

3.8.5 [image: image221.bmp] Save Post-processing Setup

Click this button to save the post-processing setup, the Save As dialog box will be displayed. This will be described under Measurement->Measurement Setup….

 If any of the post-processing settings are changed, the icon turns red [image: image222.bmp]. This way the user will be notified that the settings have been changed since the last setup was loaded.

3.9 Standard Toolbar

The standard toolbar contains the most frequently used buttons.
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[image: image224.bmp]
File->New…
[image: image225.bmp]
File->Insert…

[image: image226.bmp]
File->Save Active Measurement As…

[image: image227.bmp]
File->Print

[image: image228.bmp]
File->Print Preview…

[image: image229.bmp]
Edit->Copy to Clipboard


[image: image230.bmp]
Measurement->Start Measurement

[image: image231.bmp]
Measurement->Cancel Measurement

[image: image232.bmp]
View->Volume and Input Level(s) Dialog


[image: image233.bmp]
Plot->Hold Plotted Curves

[image: image234.bmp]
Plot->Solo Active Measurement Curve

[image: image235.bmp]
Plot->Auto Refresh

Determines if auto refresh is turned on or off. If it is turned on, it can be in two modes as seen from the Plot->Auto Refresh sub-menu. Either Active Measurement or All Measurements.


[image: image236.bmp]
Plot->Refresh All

[image: image237.bmp]
Plot->Add Curve(s)

[image: image238.bmp]
Plot->Delete All Curves

[image: image239.bmp]
Plot->Chart Settings for Active Plot...

[image: image240.bmp]
Add legend to active plot. This and other legend settings are found in Plot->Chart Settings for Active Plot..., select the Legend tab.

[image: image241.bmp]
Add gridlines to active plot. This and other gridlines settings are found in Plot->Chart Settings for Active Plot..., select the Axis tab, then select the Ticks tab, or the Minor tab for the minor gridlines.

[image: image242.bmp] 
Display title to active plot. This and other title settings are found in Plot->Chart Settings for Active Plot..., select the Titles tab.

[image: image243.bmp] 
Display footer  to active plot. This and other comment settings are found in Plot->Chart Settings for Active Plot..., select the Titles tab. Then select SubFoot as shown in the figure below.
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[image: image245.bmp] 
Display axis title to active plot. This and other axis title settings are found in Plot->Chart Settings for Active Plot..., select the Title tab.

3.10 Status Bar

The status bar is displayed at the bottom line of the software. The left part is used to display the help text when the mouse cursor is placed at a control. For example, if the mouse cursor is placed at the [image: image246.bmp] button, the text [image: image247.png]Print Preview active plat



 will be displayed.
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To the right of the help text, the cursor values (x,y) in the plot is displayed, as shown above. This is the position of the mouse pointer relative to the curve of the active measurement. Using this you can read out the values of the active measurement curve. Note that if you have plotted several measurements it is the cursor values of the active measurement that will be displayed.

If a frequency domain plot type is displayed, the wavelength, half- and quarter-wavelength will be displayed to the right of the cursor values as shown in the figure below.
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3.10.1 Status bar during a measurement

When performing a measurement, the current average and its input level(s) are displayed in the status bar. In the figure below the levels for average 8 for a 2 channel measurement is displayed.
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4 Measurement Menu Reference
This menu contains the measurement settings
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4.1 Start Measurement [image: image252.bmp]
Starts a measurement using the current settings.

A too high output volume may damage your equipment, so consider adjusting down the output volume before selecting this option. The levels cannot be adjusted during a MLS measurement since it will give a wrong result.

4.2 Cancel Measurement [image: image253.bmp]
Cancels a measurement if one is being performed. 

4.3 Test Current Levels

Recording (and playback) is started so the user may see the current input (and output) level(s). This is useful for setting optimal levels before performing a measurement. 

Note that a too high output volume may damage your equipment, so consider turning down the output volume before selecting this option. 

4.4 Set Input Volume(s)

Sets the input volume, starting from the lowest possible level and gradually increasing. The volume is adjusted so the input level is set in the range –1.5 dB to –5 dB. These limits may be set in Measurement->Advanced Settings….

The procedure works only if the WinMLS mixer is supported, and it works for 1- and 2-channel measurements.

If the procedure is slow, adjusting the volume sliders manually will help increasing the speed.

4.5 Set Output Volume

Sets the output volume. This procedure is similar to setting the input volume as discussed above. 

4.6 Measurement Information…

Displays information on the active measurement as shown in the figure below.
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Note that the measurement file formats .wmb and .wav will contain all information, while the formats .wmt and .tim contain less information. However, note that if the .wav-file is normalized when saved, its level information will not be correct.

4.7 Delete Unplotted Measurements [image: image255.bmp]
Deletes all the measurements that are present in the memory (of the active window), except the measurements that are plotted. 

Even the unsaved measurements will be deleted. Since WinMLS stores all the performed and inserted measurements in memory as default, it may be needed to clear the memory.

4.8 Sound Card Settings

Opens the Sound Card Settings dialog as shown below. 
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4.8.1 Mixer and Synchronization Settings
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[image: image258.png][V Use the WinMLS Mixer



 should be checked to make use of the WinMLS internal mixer. If it cannot be checked, this may be because your sound card does not have a software mixer, or it is not compatible with the Windows® sound system. If not checked, several settings in this dialog box will be disabled.

4.8.1.1 Synchronization Mode – Measuring initial time delay, or not.

The initial time delay is the same as the time a pulse takes to travel through the system we are measuring, if it is a loudspeaker and a microphone, it is the time delay caused by the distance between the loudspeaker and the microphone and is also called time of flight. The inital time delay can be measured in several ways when measuring transfer functions with WinMLS. It can also be plotted if it is selected in the plot types Room Ac. Parameters and Levels.

The settings below apply only when measuring transfer functions and not when measuring in scope mode.
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Each of the items in the list shown in the figure above is explained in the chapters below.

4.8.1.1.1 Only if my sound card ‘is synched’

‘Is synched’ means that the sound card is able to start record and playback at the same time, or with a delay that is constant. This must be fulfilled to be able to measure the initial time delay correctly.

Note that the constant time delay for the sound cards may be of importance. If this is the case, use the mode Yes, my sound card ‘is synched’ explained below.

WinMLS checks the sound card type. If it is one of the types we have tested and found to be ‘synched’ then the measurement is performed so that the initial time delay will be found.

Based on our previous tests with WinMLS, the Digigram VX sound cards, Siena, Card Deluxe and Delta 1010LT was found to be synched and is on the “list”. Please note that the Digigram VX pocket and Delta 1010LT has a deviation of 1 sample when using this method of determining initial time delay.

If the sound card is not found in our list, then the measurement is performed in the No, detect start of measurement mode explained below. If you have found that your sound card is synchronized but not any of the sound cards mentioned above, then you should select the mode Yes, my sound card ‘is synched’.
4.8.1.1.2 No, detect start of measurement

This mode does not measure the initial time delay. The initial time delay is removed so the impulse starts from the very beginning. A special algorithm is used to detect the start of the impulse response.

Multi-channel measurement note: The start detection will not work properly if a multi-channel transfer function measurement is performed and one of the channels contains a non-impulsive signal. This is because all channels are searched to find the start of the first pulse.

4.8.1.1.3 Yes, my sound card ‘is synched’

You can select this mode if you know that your sound card is able to start record and playback at the same time, or with a delay that is constant. The constant delay can be corrected for in the 
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 setting explained below.

The initial time delay will be measured if this is set properly. Do this by connecting the sound card input to the output, then perform measurements while adjusting the delay. Make sure that the maximum of the sound card impulse response is at 20-60 samples to make sure the left-side tail of the sound card is considered. Below is an example of a response that could be shifted to the left. 

[image: image262.wmf]Time [samples]

150

140

130

120

110

100

90

80

70

60

50

40

30

20

10

0

uncal. [volts] / uncal. [volts], Linear

800

700

600

500

400

300

200

100

0

-100


By changing the y-axis to dB, it is easier to see the noise floor as shown below. 
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In this case the sound card delay should be set to about 50 samples. Do note that if the delay is set to more than 105 samples (where the maximum is found), you will find the maximum at the end of the measurement.

4.8.1.1.4 Yes, with loop-back and end-check

The measurement is performed using a physical loop-back, usually connected from output right channel to input right channel. 

A pulse is sent through the loop-back before the measurement is performed and it makes it possible to determine the initial time delay correctly.

Also after the measurement is finished, a pulse is sent through the loop-back. The time delay between this pulse and the pulse sent before the measurement was started is checked. This end-check is used to detect errors in the measurement caused by gaps or errors in play or record (this may happen e.g. if the PC is used for other things while the measurement is performed). The loop-back settings (see below) must be properly set.

For a more detailed explanation see Measurement 3: Measuring using loop-back in the section The first measurements walk-through.

4.8.1.1.5 Yes, with loop-back, no end-check

Same as the mode above, except that the end-check is not performed. This means that this mode measures the initial time delay exact, but errors in the measurement caused by non-continuous play or record are not detected. The loop-back settings (see below) must be properly set.

gives the delay of the sound card in samples. This is found by doing a MLS measurement of the sound card with its input connected to the output using a cable. Plotting the first part of the resulting impulse response using Time Data as plot-type and Samples as x-axis, will show the delay.

4.8.1.2 Loop-back settings
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 gives the delay of the sound card in samples. The delay is found by doing a MLS measurement of the sound card with its input connected to the output using a cable. Plotting the first part of the resulting impulse response using Time Data as plot-type and Samples as x-axis, will show the delay. In addition to being used for the loop-back, this setting is also used for the Yes, my sound card ‘is synched’ mode.
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 gives the input line used when performing a loop-back measurement. For the Digigram® cards, Analog Input should be selected, but for other sound cards it is usually Mic or Line.
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 gives the channel that the loop-back is to be connected to. If the loop-back input is stereo, it is usually connected to Right channel. But if it is mono (e.g. the Mic input), it must be set to Left.

[image: image267.png][~ Use advanced loop-back signal



 should be checked if problems occur when measuring in loop-back mode. A short MLS signal is used for the synchronization instead of the standard pulse. This signal is less prone to noise, but may demands a fast PC since will need more processing. If you are using a sound card capable of measuring DC offset (e.g. TB Tahiti/Monterey) it is strongly recommended to use this setting.

4.8.2 Input Settings
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[image: image269.png]Input device (for 1 and 2 ch. meas.)

V222 in w1 <



 gives the sound card input device. Note that the combo box list may contain devices that cannot be used for measurements.
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 gives the input line. For the Digigram® cards, Analog Input should be selected, but for other sound cards it is usually Line, or Mic. Note that the combo box list may contain lines that cannot be used for measurements, e.g. CD player and Aux.
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 gives the bit depth used for recording. You may choose either 16 or 24 bits. 24 bits usually gives a slightly better measurement result and allows a larger dynamic range, but your sound card may not support 24 bits.
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 opens the dialog box for setting input devices if a multi-channel (>2 channels) measurement is to be performed.

4.8.3 Output Settings
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 gives the sound card output device. Note that the combo box list may contain devices that cannot be used for measurements.
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 gives the input line. It is usually called Wave Output or Wave, or a translation if your operative system is not English.
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 gives the channel for the excitation signal. You may select Left, Right , Left&Right or Alternate. Left is recommended and used in the standard setup files, which means that the output source must be connected to the left channel. If Alternate is selected, the first measurement is performed using right channel output, the second with the right channel output, the third with the left channel output again, and so on...

[image: image277.png]Output number of bits: 16 7



 gives the bit depth used for playback. You may choose either 16 or 24 bits. Your sound card may only support 16 bits. Bit depth makes no difference to the MLS signal if emphasis is not used, but 24 bits usually gives slightly better measurement results if pre-emphasis is used.
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 gives the master volume for all output lines and can be given a value from 0 to 65535. We recommend that you set it to 65000 (or exactly the maximum value 65535). If you have problems with distortion on your sound card output, then setting a lower value might reduce this.

4.8.4 Sound Card Specific Settings
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The sound card specific settings are sound card dependent. On some sound cards you may set Treble and Bass, 3-D sound and other settings, but for other sound cards no such settings are supported. In that case all settings will be ghosted as shown in the figure above. 

If your sound card has such special settings, it is likely that they will influence the result of your MLS measurements. Therefore, WinMLS will extract these settings and allow you to set them. These settings will be saved in the measurement setup file as the other measurement settings. This way you are sure to have exactly the same settings each time you do a measurement. 

The output tone controls Treble and Bass found on the left side of the figure above can be set to a number from 0 to 100. This setting will greatly affect the frequency response of your sound card. You may use this as an equalizer to boost either the high or the low frequency region.

If any of the Other settings are supported, they will be listed and turned off as default. You may turn them on by checking them. We recommend that you do not check the controls unless you know exactly what the control does. For more information about this, consult your sound card hardware documentation. A way of testing it would be to compare a measurement with the control turned off with a measurement with the control turned on. 

Note that it is possible that a sound card has settings that is not displayed in the Sound card specific settings, e.g. the Digigram sound cards volume settings Advanced Input and Advanced Output.

4.8.5 Advanced settings
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[image: image281.png][ Save measurement for diagnosis:



 should be checked if you want to save everything that is recorded during the whole measurement to a .wav file. This can be useful if you need to see what has happened during your measurement. Then you can simply play the file and listen to it, or open the file in a sound editor. For 1 channel measurements, a mono .wav file is generated, for multi-channel measurements a stereo .wav file is generated.
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 gives the name and path of the diagnosis file to be saved.
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 determines if unwanted feedback that may occur between the measurements should be turned off. If this is not checked, feedback may occur between the measurements because then the original sound card volume is being restored. If checked, it will make sure that the volume setting causing feedback is turned off.
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 gives if input/output is mono or stereo when performing a 1-channel measurement. In most cases this should be set to Stereo. However, if you have a sound card that is mono full duplex (probably an older card), you may set it to Mono.

4.9 Hardware Calibration…

Displays the dialog box shown below.
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4.9.1 Input Absolute Level Calibration
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 determines if the input is to be absolute calibrated.

[image: image288.png]


 displays the input absolute calibration settings  dialog box as described below.
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 determines which channel the Settings… are displayed for. For a 1-channel measurement, this number should be set to 1.
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For more information, see How to perform relative calibration of mixer input levels? in the FAQ: Measurement section of the help-file.

4.9.1.1 General settings
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 is used to choose between Detailed calibration and Total calibration. These will be discussed below.
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 should be checked if you are having a transducer (e.g. a microphone) connected to the input. It makes sure the units are correctly set and allows you to specify the transducer sensitivity if Detailed calibration is selected.
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chooses the unit of your transducer. If you are using a microphone, select Pres [Pa].

4.9.1.2 Total calibration

Total calibration can be performed if it is selected in the General settings as shown below.
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The purpose of this type of calibration is to calibrate the whole input chain in one operation without having to calibrate the sound card first. This Total Calibration is fast and simple and very suited if you have a microphone calibrator. However, we recommend that you instead use the Detailed Calibration (see below) if you are using WinMLS both for electrical measurements and measurements where you are using a transducer (e.g. a microphone), or a pre-amplifier with changeable gain.
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[image: image295.png]


 gives the number WinMLS uses to calibrate the input. This number will automatically be set when clicking the [image: image296.png]


 button, but it may be manually set.
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 performs the calibration procedure.
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 opens the calibration settings shown below.
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 displays the date of the last calibration. It is set by clicking [image: image300.png]


.

4.9.1.2.1 Calibration Settings
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In the dialog box above you can set the level and frequency for the calibration, and choose if you want to use an external signal generator or use the sound card output as signal generator. Using the sound card output should be fine as long as you have something to measure the signal level with (the measured level is used as the reference level), e.g. a voltage meter if you are doing an electrical calibration. The Test level button should be clicked to test the levels. 

Note that you may have to adjust the input or output volumes to get a reasonable level. If the level is too high, an error message is given.

4.9.1.3 Detailed Calibration

Detailed calibration can be performed if it is selected in the General settings as shown below.
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The purpose of this type of calibration is to calibrate each part of the input chain (sound card, pre-amplifier, transducer). We recommend this method of calibration if you are using WinMLS both for electrical measurements and measurements where you are using a transducer (e.g. a microphone), or a pre-amplifier with changeable gain. The settings for detailed calibration are shown below.
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[image: image304.png]Sound card conversion [d8]: [5.295 _Calbrate | Settings... | Last cal: 23:09:48, 15May2001



 is for calibrating the sound card input sensitivity. This must be done before calibrating the Transducer sensitivity.
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 should be turned on if you are using an external pre-amplifier. Type the amplifier gain in the edit box. If you want to determine the amplification of the pre-amplifier, we suggest that you do this manually by plotting the frequency response of the measurement system with and without the pre-amplifier. Note that the sound card calibration and the pre-amplifier gain and status (checked/unchecked) must be correct in order to get a correct calibration of the transducer sensitivity.
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 the transducer sensitivity of your transducer may be given by the manufacturer, then you may type this value in the edit box. You may also measured the transducer sensitivity by clicking the [image: image307.png]


 button. However, you should first click the [image: image308.png]ttings.



 button to set the correct calibration settings. You must also make sure the Amplifier Gain and Sound card conversion settings are correct.

4.9.2 Output Absolute level calibration

The purpose of the absolute output level calibration is to be able to measure the gain of the impulse response/transfer function with the correct units.
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[image: image310.png][V Output calibration



 Determines if the output is to be absolute calibrated.
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 Displays the output absolute calibration settings  dialog box as described below.
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The useage of dialog box is very similar to the Input Absolute Level Calibration dialog box. See the Input Absolute Level Calibration section for more information.

4.9.3 Relative calibration of mixer input

The WinMLS mixer controls the analog input amplifier of the sound card (some sound cards do not have a mixer, and some cards have a mixer that can not be controlled by WinMLS). The relative calibration uses a file containing the gain steps of the mixer for correction when the mixer gain is changed. So when a relative calibration has been done for the WinMLS mixer, changing the volume of the WinMLS mixer input will not affect the level of the measured transfer function. See FAQ for more information.
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[image: image314.png][V Use co. file:



 If checked, the relative calibration is performed using the correction file described below.
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 For selecting the correction file. If your sound card has two input lines, e.g. a microphone and line input, they will probably not have the same gain steps. Therefore, if you plan to switch measurement input line, the calibration file must be switched. How a correction file is generated is described below.
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 Click to generate a new input mixer correction file for the inputs and outputs selected in Measurement->Sound Card Settings. A dialog box will be displayed giving directions on how to perform the mixer input calibration. The procedure may take a few minutes. You will be notified when the calibration is finished.
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 Determines in what way the input levels are displayed. In the current version of WinMLS, it can only be displayed relatively with 0 dB as maximum (Full scale input). The maximum value of the input is found (within each average).

4.9.4 Relative calibration of mixer output

The relative calibration of mixer output is very similar to the relative calibration of mixer input. Please see chapter above for explanation. 
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4.9.5 Measurement System Correction File

The influence of the measurement system can be corrected as described in the FAQ: Measurement section How to correct for the influence of the measurement system?
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 Selects the measurement system correction. 
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 If this is checked, the full name of the measurement system correction files shown in the combo box above will be displayed.

4.10 Measurement Settings Toolbar 

This toolbar is also found in View menu, but is added here since the settings are not available in any dialog box. The Measurement Settings Toolbar is displayed if this is checked. The toolbar may also be turned on/off from the View menu. The reason for having this toolbar here is that the settings in this particular toolbar cannot be set from a dialog box, which is normal. And these settings should be found from the Measurement menu.

4.11 Sinusoid Settings…

Displays the dialog box shown below used to set the frequency and level if sinusoid is selected as output signal.
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The Frequency can be set no higher than half the sampling frequency. Note that if you close the dialog box and open it again, the frequency will have changed slightly from the value you have typed. This is because it has switched to the nearest possible exact frequency. The frequency resolution is increased by increasing the sequence order in the Measurement Settings Toolbar.

The Level [dB FS] is the full scale level given in Decibels. Its maximum value is 0, which is the maximum amplitude for the Digital-to-Analog converter. The output level may be further adjusted using the volume settings.

4.12 Advanced Settings

Displays the dialog box shown below.
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4.12.1 Pre-D/A sound card output amplitude

These settings will set output: 

[image: image323.png][ Invert measurement amplitude



 Inverts the output signal if it is checked. If the measured impulse response has a negative peak, toggling this will invert the peak.

[image: image324.png]Measurement pre-D/4 ampl. [dB FS] [13



 The edit box [image: image325.bmp] gives the full-scale amplitude in Decibels of the measurement output signal (and for the relative sound card mixer calibration). Its maximum value is 0, which is the maximal amplitude for the Digital-to-Analog converter.
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 The edit box [image: image327.bmp] gives the full-scale amplitude in Decibels of the signal used for absolute calibration of the sound card.

4.12.2 Emphasis offset

[image: image328.png]Pre-emphasis offset [dB]



 The pre-emphasis output amplitude is determined from this setting in combination with the [image: image329.png]Measurement pre-D/4 ampl. [dB FS] [13



 (this is why we have called it offset). Depending on the selected type of pre-filtering, a too high value may cause the amplitude to exceed the maximal amplitude. If this causes clipping of the signal, an error message will be displayed.

[image: image330.png]Post-emphasis offset [dB 10



 This is used to scale the recorded signal when measuring using post-emphasis.

4.12.3 Limits for automatic setting of volume

These settings will determine the limits when using Measurement->Set Input Volume and Measurement->Set Input Volume.
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 The volume is set so that the level is above this limit when using Measurement->Set Input Volume.
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 The volume is set so that the level is below this limit when using Measurement->Set Input Volume.
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 The volume is set so that the level is above this limit when using Measurement->Set Output Volume.

[image: image334.png]Output level maximum limit [dB] 15



 The volume is set so that the level is below this limit when using Measurement->Set Output Volume.

4.13 Measurement Tasks…

Displays the dialog box shown below used to determine what tasks are to be performed when a measurement is performed, inserted or opened.
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4.13.1 Tasks when performing a measurement

[image: image336.png]Perform measurement in active gioup (window)




 determines if a new measurement is to be performed in the active window or if a new window is to be opened. If Perform measurement in new group (windows) is selected, a new window will be opened when a new measurement is performed. This is similar to the two options you have when opening a measurement file. You may then choose between Insert… and Open…. Insert… will open the measurement file in the existing window, while Open… will open it in a new window
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 will add a delay after you start the measurement before it is actually performed. If you have to do something before each measurement and you don’t have anyone to start the measurement for you, this delay after starting the measurement may be useful.

[image: image338.png][V Display "Volume and Input Level(s)" dialog box



 determines if the dialog box found in View->Volume and Input Levels(s) dialog is to be displayed when a measurement is performed.

[image: image339.png][ Automatic save after measurement using default filename



 determines if the measurement should be saved automatically using the filename and other parameters from Measurement->Defaults for Saving….

[image: image340.png][~ Automatic start of new measurement after successful measurement



 determines if a new measurement is to be started after performing a successful measurement. It makes it possible to perform several measurements without user interaction.

[image: image341.png][ RBun executable after measurement:



 determines if an executable file is to be run after a measurement is performed. The name of the executable must be specified in the field below the check box. This may be used for controlling a turntable of type B&K®. For information about this, run the file BKturntable.exe found in the WinMLS folder.
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 adds a delay after the measurement has been performed. This may be useful when several measurements are performed in automatic mode.

4.13.2 Tasks when performing or inserting a new measurement from file
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 determines if a message box should pop up asking the user if the previous measurement is to be saved when performing or inserting a new measurement. 
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 determines if the unplotted measurements should be kept in memory or not. If you are to perform several hundred measurements, you should be aware of that it might fill up the memory if they are not removed. Measurements are deleted by using File->Delete Unplotted Measurements, alternatively Delete unplotted measurements from memory will delete all measurements as long as they are not set as active or plotted. This prevents the memory to run full. It is useful if a repeated measurement is to be done and each measurement is never supposed to be stored. E.g. when calibrating a sound system, repeated measurements are needed but the results are not to be kept in memory. To sum up, this option deletes the previous unplotted measurements from memory after a new measurement has been performed and plotted.
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 determines if plotting is to be performed when a measurement is performed or inserted.

[image: image346.png][~ Save datain active plot



 determines if the data in the active plot is to be saved after a measurement is performed or inserted. The filename of the text file depends on if the measurement has a file name or not. If the measurement does not have a filename, it is saved under the default folder given in Measurement->Defaults for Saving. The filename is “PlotMeasFromMem<Measurement number>.txt”. If the measurement has a filename, it is saved using the measurement filename but with the extension .txt.

This is useful for batch-processing, e.g. if you want to compute the smoothed magnitude frequency response of several measurement files and send the data to a text files. This is done automatically by using File->Insert, then mark the measurements files you want to process and insert them.

[image: image347.png][ Calculate room acoustics parameters



 determines if room acoustics parameters are to be displayed and/or saved after a measurement is performed or inserted. The setting telling if it is displayed or saved to file or both is found in the bottom of the Room Acoustics->Calculation Options… dialog box. 

The Send to Text file option is useful for calculating the room acoustics parameters of several files and saving the results in one operation. First check this option, then make sure Send to Text-file is checked in Room Acoustics->Calculation Options…. In File->Insert, select all the files that you want to process. If the measurement has a filename, it is saved using the measurement filename(s) but with the extension .txt. The filename of the text file depends on if the measurement has a file name or not. If the measurement does not have a filename, it is saved under the default folder given in Measurement->Defaults for Saving. The filename is “RoomAcMeasFromMem<Measurement number>.txt”.
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 If this is turned off both channels in a 2-channel measurement are plotted in each plot. If you for example, view the impulse response in the upper plot and the magnitude frequency response in the lower plot, you normally want to do it this way.

If the option is turned on and a 2-channel measurement is performed, channel 1 is plotted in the upper plot and channel 2 is plotted in the lower plot (if the window has two plots). This option is useful if you wish to view two plots having the same plot type. This is done in the room acoustics measurement setup file RoomAcMeasurement. Here the time-data plot type is displayed in both plots. When a two-channel measurement is performed, channel 1 is plotted in the upper plot and channel 2 is plotted in the lower plot. It makes it easy to compute room acoustics parameters that need two impulse responses, a primary and a secondary. The primary impulse response is taken from the upper plot, while the secondary is taken from the lower plot.

This also applies if two measurements are inserted using File->Insert. See the FAQ for more information.

4.14 Defaults for Saving...

Displays the dialog box containing the defaults for saving measurements shown in the figure below. After a file is saved the default folder, format, title, comment(s) and current counter is updated.
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4.14.1 Default file-parameters

From here the default file folder, name and extension is set. Note that the default filename for saving will in addition contain a number given by the Autoname generator as will be described below. A single channel measurement using the settings above would get the suggested filename with full path: c:\winmls2000\measurements\Meas_1.wmb
[image: image350.png][V Normalize if .wav-file



 should be checked if you want to normalize when saving to .wav-file. This should be done to ensure maximum quality. However, note that if the .wav-file is normalized when saved, its level information will not be correct.

[image: image351.png]Multi-channel measurement tag: [Ch



 gives the tab used for determining the filenames for a multi-channel measurement. A 2-channel measurement would, using the settings shown in the figure above, get the following two suggested filenames: MeasCh1_1 and MeasCh2_1.

A multi-channel file will get the default name:

<default filename> + <multi-channel tab> + <channel number> + <_> + <measurement auto-numbering>

The reason for doing it in this order is to ensure flexible listing of the measurements in the Windows® file explorer. If you list the measurements using date, the multi-channel measurements will be listed after measurement number. If you list the measurements using filename, they will be listed after channel number since the channel is added before the measurement number.

4.14.2 Title and comments

Title and comments will be saved to the file header except for the .wmt format, which only saves the comment. The title has a maximum of 80 characters and the comment 60 characters.

The title will appear in the plot title if [image: image352.png][V Measurement title



 is checked in Plot->Advanced Plot Settings… and if [image: image353.bmp] is checked on the Standard Toolbar.

The comment will appear in the plot title if [image: image354.png][V Measurement comment



 is checked in Plot->Advanced Plot Settings… and if [image: image355.bmp] is toggled on the Standard Toolbar.

For a multi-channel measurement, comments may be given for each channel by clicking [image: image356.png]Multi-channel commerts.



.

4.14.3 Autoname generator

The autoname generator is used to automatically assign a number to the suggested measurement filename.
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The first edit box [image: image358.png]


 gives the start number of the auto-numbering. The second edit box [image: image359.png]1000



 gives the number where the auto-numbering ends. When this end-number is reached, the auto-numbering starts at the start number again. If you for example, are to perform 8 measurements that should have the same name, but numbered 1 to 8, you should set this to 8. Then when saving measurement number 9 the Defaults for Saving dialog box will be displayed and you may change the name.

[image: image360.png]Curent counter:



 displays the current value of the counter. E.g. after saving 5 measurements, the counter will have the value 5.

4.15 Measurement Setup...

Measurement setup defines as all the settings in the measurement menu. 
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When WinMLS is exited, the setup filename is saved in registry and all the current settings are saved to a temporary setup. The next time WinMLS is run, this setup file is opened and the settings restored.

To prevent the user from accidentally deleting or overwriting a setup file, the setup files may be write-protected.

4.15.1 [image: image362.png]MasterSetup




 Select setup

Displays the selected measurement setup. Setups are chosen from a list as shown in the figure below.
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4.15.2 Setup description

The setups descriptions describes the selected setup. The description should contain

· What kind of measurement(s) is the setup suited for.

· How should it be used (hardware setup)

· How can it be adjusted

· Is hardware calibration needed

· Are calibration settings loaded, only notify if they are loaded

· Is there anything else that needs to be done (e.g. initial time delay)?

· What post-processing setups are suited and is the post processing linked?

Not all information can be covered in the measurement setups, the most important information is given below.

4.15.2.1 General information about measurement settings

· If you want to be asked to save a measurement, add delay before or after the measurement, turn on automatic display of room acoustics parameters and similar things, see Measurement->Measurement Tasks....

· You can remove or add toolbars from the View menu. Note that you have to save the post-processing setup to maintain the settings when switching from one setup to another.

· You can select if you want to plot curves on top of each other, or not, using Plot->Hold Plotted Curves.

· The maximum length recorded for the setups is often 1.3 seconds, if you need to change the measurement time, it can be increased from the Measurement Settings Toolbar.

· See the FAQ: Measurement section for further information.

4.15.2.2 ImpulseExcitation

Used if you want to measure an external impulsive signal, for example a pistol-shot, or a violin body by hitting it with a hammer. Connect the microphone to left channel if it is a stereo input, no output is used. The recording starts immediately after the measurement is started (dependent on the speed of the soundcard and PC). A delay before the measurement can be set in Measurement->Measurement Tasks... The length recorded is 1.3 seconds, if you are not able to capture the impulse response, it can be increased from the Measurement Settings Toolbar. The post-processing setup EnergySpectrum is selected as default. If you are doing a room acoustics measurements, one of the room acoustics post-processing setups should be selected. If the input is calibrated, the SPL is displayed and e.g. dBA if the Levels plot-type is chosen.

4.15.2.3 QuasiRealTimeAnalyzer

Performs repeated measurements without saving the data. Connect the microphone to left channel if it is a stereo input, the output is not used. The length recorded is 0.34 seconds, it can be changed from the Measurement Settings Toolbar. The post-processing setup PowerSpectrum is selected as default.

4.15.2.4 MasterSetup

This setup is automatically loaded if the selected or temporary setup cannot be loaded. The settings are very similar to the to the setup Sound SystemMeas. The sound card and hardware settings are also loaded, so these probably must be updated when the setup is loaded. The post-processing setup PostProcSetup is loaded as default.

4.15.2.5 RoomAc2Channel

Uses the MLS method (with emphasis) to measure two channels. Connect two microphones, one to the left and one to the right channel of your stereo input, connect the loudspeaker to left output channel. The length recorded is 1.3 seconds, if your room has a higher reverberation time, it must be increased from the Measurement Settings Toolbar. When a new measurement is started, the user is asked to save old measurements. The post-processing setup RoomAc2Channel is selected as default. If you are measuring lateral fraction, make sure you have connected a omni microphone to the left input and a Fig8 microphone to the right input. and select the post-processing setup RoomAcLateralFraction. If you are measuring IACC, use a dummy head and select the post-processing setup RoomAcIACC.

4.15.2.6 RoomAcoustics

Uses the MLS method (with emphasis) to measure room acoustics. Connect the microphone to left channel if it is a stereo input, connect the loudspeaker to left output channel. The length recorded is 1.3 seconds, if your room has a higher reverberation time, it must be increased. This is done from the Measurement Settings Toolbar. When a new measurement is started, the user is asked to save old measurements. The post-processing setup RoomAcOctaveRT is selected as default.

4.15.2.7 SoundSystemMeas

It can be used to measure loudspeakers or any other similar system. The impulse response is the result, but the frequency response and other relevant parameters can be plotted. Connect the microphone to left channel if it is a stereo input, connect the loudspeaker to left output channel. The post-processing setup SoundSystemCalibration is selected as default. If the input is calibrated, the frequency response is scaled to display SPL if the post-processing setup ScopeMode (LoudspeakerSPL) is selected.

4.15.2.8 THD + Noise (1 kHz sinusoid)

Uses 1 kHz sinusoidal excitation to measure total harmonic distortion (THD) and noise. Connect the microphone to the left channel if it is a stereo input, connect the loudspeaker to left output channel. The length recorded is 1.3 seconds, if you need longer measurement time, it must be increased from the Measurement Settings Toolbar. The post-processing setup THD + Noise (1kHz sinusoid) is selected as default.

4.15.2.9 VX222-VXpocket

This is intended only for loading sound card and calibration settings if you have a Digigram VX222 and VXpocket sound card. After you have loaded this setup, go to Measurement->Sound Card Settings... and make sure that the VX222 or VXpocket is selected as input and output devices. Also make sure ‘Use the WinMLS Mixer’ is checked in Measurement->Sound Card Settings. This will allow you to use the internal WinMLS mixer (and still maintain the absolute calibration). Please note that the sound card input absolute calibration values are valid only if the input is set up to line sensitivity. If you are setting the input to microphone sensitivity, you will need to calibrate.

4.15.2.10 ViolinAcoustics

The setup is very similar to the setup SoundSystemMeas. Connect the microphone or accellerometer to the left channel if it is a stereo input, connect the loudspeaker or the magnet coil system (you may purchase from us) to left output channel. The post-processing setup ViolinAcoustics is selected as default.

4.15.3 Save link to post-processing setup

If [image: image364.png]IV Save link to post-processing setup



 is checked, the post-processing setup is also saved when saving the measurement setup. Note that when a measurement setup is loaded, if this setting is turned on in the measurement setup file, the post-processing setup will also be loaded.

This means that this check-box can be used to determine if you want to load the post-processing setup when loading the measurement setup. But it is read from the measurement setup file, so it is not enough just to check the check-box. So to change this setting, the measurement setup must be saved before it is active.

4.15.4 [image: image365.png]


 Save setup as

Opens a dialog box for saving the current measurement settings.
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If [image: image367.png]IV Save link to post-processing setup



 is not checked, the post-processing setup will not be saved and the dialog box will look like in the figure below.

[image: image368.png][Save current measurement settings as setuf





4.15.5 [image: image369.png]


 Delete setup

Deletes the selected setup.

The button is disabled when only one setup file is left to make sure not all setups are deleted.

4.15.6 Load soundcard/hardware calibration settings

If [image: image370.png][ Load soundcard/hardware calibration settings



 is checked, the sound card and hardware calibration settings are loaded when loading the measurement setup. 

If it is not checked, you can load measurement setups without changing the sound card and hardware settings. This makes it much easier to switch between measurement settings (you don’t have to select the hardware settings when you switch). 
Note that the measurement setup has to be saved in order for this settings to be changed. This is because when a new measurement setup is loaded, this setting is reset to the setting in the specified measurement setup.

All the default setups that come with the installation of WinMLS, should have this setting turned off, except for the setups that contain sound card and calibration settings (e.g. the setup VX222-Vxpocket). After loading a setup with soundcard/hardware settings, please note that you may have to reselect the Input Settings and Output Settings in Measurement->Sound Card Settings....

Be aware of that if you have opened several windows in WinMLS and if you change one of the soundcard/hardware settings in one window, it will affect all the windows if [image: image371.png][ Load soundcard/hardware calibration settings



 is not checked in the measurement setup.
4.15.7 [image: image372.png]


 Load setup

Loads the selected setup and then closes the Measurement Setup… dialog box. Note that you will not be asked to save the previous settings.

4.15.8 [image: image373.png]Close




 Close dialog

Closes the dialog box. No new setup will be loaded.

5 Plot Menu Reference
This menu contains all post-processing features, except for the room acoustics. The first part of the menu, as shown below, contains commands and settings for manipulating the plot(s).
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The next part allows the user to select which plot type(s) to display and what measurement(s) to plot. It also contains chart settings that apply for the active plot only and settings that are specific for each plot type.
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The last part contains various settings that applies to all plots, except for General Frequency Domain Settings... that applies for the frequency domain plot types only.
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Each item is explained in detail below.

5.1 Add Curve(s) [image: image379.bmp]
Adds new curves(s) to the active plot. The data is taken from the active measurement and normally one single curve is added. If a multi-channel measurement has been performed and is active, curves for all the channels are added. The curves are always added to the current plot independent on the Plot->Hold Plotted Curves setting. If it is desired to remove the old curves before adding new curve(s), then this can be done as described below by using Plot->Delete All Curves.

5.2 Delete All Curves [image: image380.bmp]
Deletes all curves in the active or both plots. The dialog box shown below is displayed.
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You may choose to delete the curves in the active plot or in both plots (if two plots are present in the window).

[image: image382.png]Both plote?




5.3 Hold plotted curves [image: image383.bmp]
If this menu-item is checked, the existing curves in the plot(s) will remain in the plot when a new curve is plotted. If it is unchecked, the existing curves in the plot(s) will be deleted when a new curve is plotted. In the software MLSSA® and some other software holding plotted curves is called Overplot. Note that in WinMLS you may change the settings for the curves you have already plotted. 

5.4 Menu: Solo Active Measurement Curve [image: image384.bmp]
If you have several curves in the plot and want to view only one curve temporarily, this “solo” setting can be used. If ”solo” is turned on, it hides all curves that do not belong to the active measurement. 

If there are several curves of the same active measurement, only the last plotted curve is visible. The other curves are not deleted from the plot, but are set invisible. They may easily be set visible again by turning “solo” off. If ”solo” is turned off, the curves that were visible before ”solo” was turned on are set visible again.

When Plot->Refresh All is selected or if auto-refresh is performed in refresh all mode, all the curves that are refreshed are set visible. This is because when refreshing all, it is likely that the user wants to display all the refreshed curves.

5.5 Auto Refresh

Auto-refresh will refresh the curve(s) if any settings influencing the viewed plot(s) are changed. 

Examples of settings that will cause auto refresh are the settings in the dialog box that pops up by clicking in the active plot, the toolbar buttons influencing the plotting and changing the time window size clicking and dragging the mouse.

Note that the settings in Plot->Chart Settings for Active Plot... are not controlled by the auto-refresh, as these settings are always immediately updated. E.g. if you change the plot background gradient colors in the Plot->Chart Settings for Active Plot... dialog box, this will be done immediately, even before closing the dialog box.

The type of refresh depends on what is checked in the sub-menu as shown below 
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Each of these is described below.

5.5.1 Active Measurement

If this is checked, the most recent curve of the active measurement is refreshed when changes in the settings are made. If the active window has two plots, both plots are refreshed. For details see documentation for Plot->Refresh Active.

5.5.2 All Measurements

If this is checked, the most recent curves of all measurements in the active window are refreshed when changes in the settings are made. If the active window has two plots, both plots are refreshed. For details see documentation for Plot->Refresh All.

5.5.3 Off

If this is checked, no auto-refreshing is performed. But if a measurement is performed or inserted, it will be plotted. Refreshing must be done manually using Plot->Refresh Active or Plot->Refresh All. Set auto-refresh in Off modus if you wish to perform manual refreshing as will be described below. But note that if the settings in Plot->Chart Settings for Active Plot... are changed, this will immediately change the settings in the active plot.

5.6 Refresh Active

Refreshes the most recent curve of the active measurement in the active plot. Refresh Active is meant for use only when auto-refresh is turned off, see above. It is a “manual” refresh and gives the user somewhat more control. If the active window has two plots, only the active plot is refreshed. If no curve of the active measurement exists in the active plot, it will be added.

5.7 Refresh All

Refreshes the most recent curves of all measurements in the active plot. Refresh All is meant for use when auto-refresh is turned off or set in Refresh Active mode, see above. It is then useful if you change a setting and you want all curves to be updated with this setting. Note that if you are plotting in frequency domain, the current time data window size is used when refreshing, even if [image: image386.png][V Set end as maximum limit on new measurement



 is checked (found by clicking [image: image387.png]Time window settings for Active Measurement.



 in Plot->General Frequency Domain Settings…)
Note also that if several curves of a measurement are present in the plot, only the most recent curve will be updated. If the active window has two plots, only the active plot is refreshed. If no curve of the active measurement exists in the active plot, it will be added.

5.8 Select Plot Type(s)/Measurement(s)...

Displays the dialog box shown below for setting the plot type and active measurement in upper and lower plot.
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The settings in this dialog box, may also be set from the Plot Toolbar and the Measurement Selection Toolbar.
5.8.1 Number of plots [image: image389.bmp]
Select if a single plot or two (double) plots are to be viewed as showed below.

[image: image390.png]



5.8.2 Plot Type in Primary (upper) Plot

Selects the plot type from a list of all the available plot types. If two plots are displayed, this is for selecting the plot type in the upper plot.

[image: image391.png]| Time Data (Impulse Response)




5.8.3 Active measurement in Primary (upper) Plot

Selects the active measurement from a list of all the performed or inserted measurements in the active window. If two plots are displayed, this is for selecting the active measurement in the upper plot.

[image: image392.png]Meas.2 =]




5.8.4 Plot Type in Secondary (lower) Plot

Selects the plot type in the lower plot from a list of all the available plot types.

[image: image393.png]



5.8.5 Active measurement in Secondary (lower) Plot

Selects the active measurement in the lower plot from a list of all the performed or inserted measurements in the active window. 

[image: image394.png]Meas.2 =]




5.9 Chart Settings for Active Plot... [image: image395.bmp]
Displays the dialog box shown below.
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This dialog box gives many possibilities and may seem complicated. Note that it has context-sensitive help functionallity. Click on the question mark button [image: image397.bmp] in the upper right corner, then click on the setting you want to have explained.

The settings of this dialog box are saved to chart files for each plot type and are restored when the plot type is displayed. The chart files are found in the Chart subfolder in the folder where WinMLS is installed.

Note that changes in the plotted curve, e.g. changing colors, will not be saved. Default curve styles are set in Plot->Default Curve Styles....

Now each tab page as shown in the figure below will be described, starting with the Chart page.

[image: image398.png]Chart | Series | Data | Tools | Export| Print |




5.9.1 Chart page

This is the page that is displayed when opening the dialog box. It defines the overall display parameters for the active plot, such as background, axis, titles and legend. An explanation of some of these parameters is given in the FAQ document.

5.9.2 Series page

Gives access to the settings that applies to each curve (here it is called series) as shown below.
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The Series page will contain parameters dependent on the series type concerned, and the available parameters will depend on the curve type chosen (in the figure above the curve type is Fast Line). The setting [image: image400.png]CurveMeas. 1



 at the top of the Series tab page shows which curve you are editing.

5.9.3 Data page

Gives access to the data (x- and y-values) of the active plot as shown in the figure below.
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By clicking on the cells, the data may be deleted, changed or added.

5.9.4 Export tab

Displays advanced setting for exporting the data in the active plot to picture formats.
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Use the [image: image403.png]


 button for saving.

If the Data tab is selected, advanced settings for exporting data is available as shown in the figure below.
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5.9.5 Print tab

The Print tab gives access to the same settings as File->Print Preview… and we recommend using that instead.

5.10 Plot Type Settings: Overview

The plot type settings gives access to all the plot type settings as shown in the figure below.
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Note that double-clicking in the plot is a faster way to access the plot type settings for the active plot. The [image: image406.bmp] button on the Plot Toolbar may also be used.

The settings for each plot type will be explained below.

5.11 Plot Type Settings: Time Data…

Displays the dialog box shown below.
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5.11.1 X-axis settings

Selects the unit of the x-axis from one of the units displayed in the list shown below.

[image: image408.png]Time [=amples

Distance [meter]
Distance [feet]





The chosen unit is also used in the user interface, e.g. as unit for the time window.

When the x-axis is changed, the upper and lower limits are will be properly scaled so the same segment of the curve(s) will be displayed. If several curves are plotted and the x-axis setting is changed e.g. from Time [samples] to Time [ms], the curves will be updated using the Plot->Refresh All procedure.

5.11.2 Y-axis settings

Selects the unit of the y-axis and the processing of the data from one of the choices displayed in the list shown below.
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When the y-axis is changed, the upper and lower limits will be auto-scaled to make sure the curve(s) are appropriately viewed. If several curves are plotted and the y-axis setting is changed, the curves will be updated using the Plot->Refresh All procedure.

5.11.3 Y-axis scaling

[image: image410.png]


 Three types of scaling of the time data is supported as shown below.
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No scaling – no scaling of the measurement.

Normalize – the measurement is normalized.

The amplitude of the absolute value of the time data is set to 1 if the y-axis is Linear or Squared (Energy). It is set to 0 dB if the y-axis is dB. If performing a 2-channel measurement, do not use this normalization setting if it is desired to see the difference in levels between the impulse responses.

Scale by: [image: image412.png]


 - scales the measurement with the given factor. If the y-axis is Linear, the measurement is multiplied with the factor. If the y-axis is Squared (Energy), the measurement is first squared and then multiplied with the factor. If the Y-axis is dB, the measurement is shifted (not scaled) with the factor.

5.11.4 Velocity of sound [image: image413.png]344 imys] =




Gives the velocity of sound and the unit.

Two units may be chosen:

[image: image414.png]



The velocity of sound is used to compute the x-axis unit if Distance [meter] or Distance [feet] is chosen for the time domain plot types. It is also used to compute the quarter, half and whole wavelengths displayed in the Status Toolbar for the frequency domain plot types.

Note that if you are performing vibrational measurements, e.g. using an accelerometer instead of a microphone, it is the velocity of propagation in the structure that is to be typed, not the sound velocity.

Note that changing the velocity of sound in this dialog box will also affect the other time domain plot types, such as energy-time-curve.

The speed of sound, denoted c, may be found if the temperature is known using the formula

c = (331.4 + 0.6*T)

where T is the temperature in centigrade.

5.11.5 Show time window for active measurement

[image: image415.png][V Show time-window for active measurement



 If checked, the time data window is displayed in the Time Data plot type as shown below. The time data window consists of the three yellow straight lines and it is valid for the active measurement. (there may be more than one measurement in the window and these may have different time data windows).
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The window start and end points can be set directly by clicking and dragging with the mouse. In order to do this, the mouse pointer has to be exactly on top of the vertical line that is to be moved. The mouse pointer changes shape when it comes close to the limit.

In order to make sure auto-scaling of the y-axis can be effectively used, the vertical start and end lines are kept within the curve area. (The length is 10% larger than the minimum of the curve with the smallest y-value, and 10% less than the maximum of the curve with the greatest y-value.) The whole window is thus visible if auto-scaling is used.

5.11.6 Remove DC-component (0 Hz)

[image: image417.png][V Remove DC-component (0 Hz)



 If checked, the DC-component will be removed when plotting. 

The DC-component is removed by subtracting the DC-component of the last half of the measurement data.

5.11.7 Processing Type

[image: image418.png][No processing



 This contains the processing options showed below
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5.11.7.1 No processing

No extra processing is done on the measurement data.

5.11.7.2 Integral (Step response)

Integrates the measurement data. This is useful for example if you are measuring velocity but want to display displacement. If the measurement is an impulse response, the result is a step response. This is because the integral of an impulse response is a step response.

When performing integration, the DC-component should be removed, so make sure [image: image420.png][V Remove DC-component (0 Hz)



 is checked.

Instead of using this integration option, you may use the plot type named Integrated Time Data (Step Response).

The numerical integration is performed by cumulative summing of the elements. This gives a time shift error of one half sample which gives a linear phase shift. No correction for this is performed, but it may be done using the Subtract delay check box in the phase response/function plot type settings. 

5.11.7.3 Double integral

Computes the double integral of the measurement data. This is useful for example if you are measuring acceleration but want to display displacement. 

When performing the double integration, the DC-component should be removed, so make sure [image: image421.png][V Remove DC-component (0 Hz)



 is checked.

The numerical double integration is performed by twice cumulative summing of the elements.

5.11.7.4 Derivative

Computes the derivative of the measurement data. This is useful for example if you are measuring displacement but want to display velocity. 

The numerical derivation is performed by taking forward differences on the left and right edges and taking cantered differences on interior points.

5.11.7.5 Double derivative

Computes the double derivative of the measurement data. This is useful for example if you are measuring displacement but want to display acceleration. 

The numerical double derivation is performed by computing the derivative as described above twice.

5.11.7.6 Cumulative energy

Computes the cumulative energy of the measurement data.

The computation is performed by first computing the energy, then cumulative summing of the energy elements.

5.11.8 Filtering

If [image: image422.png][~ Perform Filtering



 is checked, filtering of the measurement is performed according to the filtering options [image: image423.png]Options.



 as shown below.
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5.11.8.1 Type of filtering

Selects the type of filtering from the list below
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A BandPass filter lets the frequencies within a band pass and suppresses the other. A BandStop filter suppresses the frequencies within a band and lets the other frequencies pass. A LowPass filter lets low frequencies pass and suppresses the high frequencies. A HighPass filter does the opposite.

5.11.8.2 LowPass/HighPass filter settings

This group contains the settings if the type LowPass or HighPass has been selected.

[image: image426.png]Cutoff hequency Mz} [1000 ~ |



 Specifies the cut-off frequency of the filter. The frequency may be typed or selected from the list of standard 1/3-octave frequencies.

[image: image427.png]Filter order: 5 =



 Specifies the filter order. The order is selected from the list and has the range 1-14.

[image: image428.png]Filtr type: Butter



 Specifies the filter type. In the current version of WinMLS, only the type Butter is supported.

5.11.8.3 BandPass/BandStop filter settings

This group contains the settings if the type BandPass or BandStop has been selected.

[image: image429.png][V Filter several bands [BandPass only]



 If BandPass is the filter type and this is checked, several bands may be filtered and thus several curves are plotted depending on the start and stop frequency and the octave fraction bandwidth. How to determine the bands is explained below. 

Note that if Filter several bands is checked, it is strongly recommended to make sure Plot->Hold plotted curves is unchecked. This is because many curves will be generated, and the refreshing does not handle this special case with several curves of one measurement. Plot->Refresh Active and Plot->Refresh All, will add new curves and not replace the old ones.

[image: image430.png]Center frequency [Hzl [100 ~



 Determines the centre frequency. Any frequency may be typed or it may be selected from the list of standard 1/3-octave frequencies. If [image: image431.png][V Filter several bands [BandPass only]



 is checked and the filter type is BandPass, two frequency values are to be selected, the start and end centre frequencies. The number of curves to be plotted within this frequency range is given by the Bandwidth described below. If the bandwidth is set to 1 octave or 1/3 octave, the standard frequencies within the specified frequency range is used. For other bandwidth settings the centre frequencies are calculated beginning at the start centre frequency.

[image: image432.png]Bandwidth: [ =



 Determines the filter octave bandwidth. Any bandwidth may be typed or it may be selected from the list. A bandwidth of 1 octave is according to the ISO 3382 standard.

[image: image433.png]Filter order: 6(standard] ¥



 Specifies the filter order. The order is selected from the list and has the range 2-14, only even numbers. Filter order 6 is according to the ISO 3382 standard. If the order is greater than 6 it does not give a stable result for low frequencies, e.g. filter order 8 and bandwidth 1/3-octave will not give a stable filter below a centre frequency of 350 Hz.

[image: image434.png]Filtr type: Butter



 Specifies the filter type. In the current version of WinMLS, only the filter type Butter is supported which complies with the ISO 3382 standard.

5.12 Plot Type Settings: Integrated Time Data (Step Response)...

Displays the dialog box shown below.
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All the settings of this dialog box are explained in the Plot Type Settings: Time Data… section.

5.13 Plot Type Settings: Energy-time Curve

Displays the dialog box shown below
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Most of the Energy-time Curve settings are found and explained in the Plot Type Settings: Time Data… section. But for the Energy-time Curve the y-axis can only be plotted in dB (the y-axis scaling is set to [image: image437.png]


 which is the most common way to view the Energy-time Curve). The Frequency Domain Windowing settings are also unique for this plot type and are explained below.

5.13.1 Frequency domain windowing

The Energy-time Curve is computed by first transforming from time domain to frequency domain. 

[image: image438.png]Frequency domain windowing
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If [image: image439.bmp] is checked, this transform is performed faster using a Fourier transform with a data length of an order of two. The data are padded with zeros to get this length. This may introduce an error if a DC-component exists. 

After the Fourier transform, a window may be applied to the complex frequency data before performing the inverse transform. The following choices are possible:
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5.13.1.1 Unwindowed

No frequency domain windowing is performed. All frequencies are given equal weight.

5.13.1.2 Half-Hanning

A Half-Hanning window is applied in frequency domain. This results in an attenuation of the higher frequencies. This option is recommended for loudspeaker measurements.

5.13.1.3 Blackman-Harris (full)

A Blackman-Harris full window is applied in frequency domain. This results in an attenuation of both the lower and higher frequencies, while the mid-band frequencies are not attenuated.

5.13.1.4 Filtering using Hamming

A Hamming window is applied in frequency domain. Note that if this is selected, the usual filtering controlled by [image: image441.png][V Perform Filtering



 will not be applied. However, the centre frequency and the bandwidth for the Hamming windowing is taken from the filtering options, accessed by clicking [image: image442.png]Options.



. In the dialog box, the centre frequency and bandwidth are set as shown below.
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Using the settings above will give the most weight to the frequencies around 1000 Hz and filter out all frequencies below 707 Hz and above 1414 Hz.

5.14 Plot Type Settings: Schroeder Curve…

Displays the dialog box shown below.
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Most of the Schroeder Curve settings are found and explained in the Plot Type Settings: Time Data… section. But the Schroeder Curve y-axis can only be plotted in dB (the y-axis scaling is set to [image: image445.png]


 which is the most common way to view the Schroeder Curve). The DC-component is automatically removed for the Schroeder curve and it is computed from the last 50% of the measurement data. The Integration Options settings are also unique for this plot type and are explained in the Integration options section of the room acoustics documentation.

5.15 Plot Type Settings: Frequency Response/Spectrum...

Displays the dialog box shown below.
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5.15.1 X-axis settings

Selects the unit of the x-axis from one of the units displayed in the list shown below.
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5.15.2 Y-axis settings

Selects the unit of the y-axis and the processing of the data from one of the choices displayed in the list shown below.
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If several curves are plotted and the y-axis setting is changed, the curves will be updated using the Plot->Refresh All procedure.

5.15.3 General Frequency Domain Settings

Click the button [image: image449.png]General Frequency Domain Settings.



 to open the dialog box also accessed from Plot->General Frequency Domain Settings….

5.15.4 Type

Select the type of frequency response/spectrum. 

[image: image450.png]Type:




In the current version of WinMLS, only Magnitude is supported.

5.15.5 Smoothing or Integration

If the check box shown below is checked, frequency domain smoothing or integration is performed.

[image: image451.png]I~ Use Smoothing or Integration  Settings.




The type of smoothing or integration is set from the [image: image452.png]ettings.



 button and is described below.

5.15.5.1 Smoothing Settings

The smoothing settings dialog is used for all the frequency domain plot-types (magnitude, phase, group delay, waterfall). Each plot type has its own smoothing settings dialog box to keep the smoothing settings independent. The smoothing settings dialog boxes are exactly the same for the plot types, except that the plot type Frequency Response/Spectrum has some extra integration settings added as described below.
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Smoothing calculates the mean of frequency response magnitude values over a sliding frequency band. The band is usually set in octaves (e.g. 1/3 octave wide) to give an equal distribution along a logarithmic frequency axis. A linear band may also be used and may be useful if a linear frequency axis is used to display the data.

Smoothing in power is the standard method of smoothing if it is applied on magnitude frequency response or spectrum. The mean of the squared amplitude values are computed. But you may also smooth to get the mean in magnitude instead of the mean in power, by setting the smoothing type to Octave – magnitude mean/interpolation. Another feature of this setting is the interpolation, that means that it finally interpolates the calculated smoothed values to the frequency points used if no smoothing was applied. Smoothing may increase the calculation time.

If the dialog box is opened from the Frequency Response/Spectrum plot type settings dialog box, integration may be chosen instead of smoothing.

5.15.5.1.1 Smoothing type

The types of smoothing are shown in the list below. The two integration options at the bottom of the list shown below are only available if the Smoothing settings dialog box is opened from the Frequency Response/Spectrum settings dialog box.
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5.15.5.1.1.1 Octave – magnitude mean/interpolation

Smoothing in magnitude mean. After smoothing, the calculated smoothed values are interpolated to the frequency points used if no smoothing was applied. In Smoothing parameters described below, the bandwidth is set. Because of the interpolation, this is the slowest method of smoothing.
This smoothing algorithm has been contributed by Dr. Aki Mäkivirta, Genelec Oy.
5.15.5.1.1.2 Octave - low frequency correction

Octave smoothing with a correction for low frequencies. If the number of points within the smoothing window is less than 3, then the data is plotted without being smoothed. This will avoid the stair-like shapes for low frequencies sometimes seen if using the option Octave – no correction. If magnitude frequency response or spectrum is plotted, the energy is smoothed, not the mean or Decibel. In Smoothing parameters described below, the parameters for this smoothing type are selected.

For high frequencies, the smoothing is stopped when there is not enough bandwidth for a full smoothing. E.g. if 1 octave is chosen and Fs=48000, the highest frequency would be (Fs/2) *2^(-1/2)= 16.9 kHz. For 1/3 ovtave it would be(Fs/2) *2^(-1/6) = 21.4 kHz.

5.15.5.1.1.3 Octave - no correction

This option is the same as above, except that no low frequency correction is performed.

5.15.5.1.1.4 Constant

Constant bandwidth smoothing. Suited if the data it plotted using a linear frequency axis. Note that the starting frequency is at half the constant bandwidth. E.g. if Smooth over [Hz] in Smoothing parameters is set to 100, the first frequency plotted is at 50 Hz.

5.15.5.1.1.5 Constant (low freq.) - Octave (high freq.)

This method does Constant bandwidth smoothing up to Start frequency [Hz] (see below). Above this frequency it is Octave smoothing.
5.15.5.1.1.6 1-octave IEC Integrated (energy)

Plots the energy in octave bands.

This option is available only if the Smoothing settings dialog box is opened from the Frequency Response/Spectrum settings dialog box.

5.15.5.1.1.7 1/3-octave IEC Integrated (energy)

Plots the energy in 1/3-octave bands.

This option is available only if the Smoothing settings dialog box is opened from the Frequency Response/Spectrum settings dialog box.

5.15.5.1.2 Smoothing parameters

Contains the parameters for the various types of smoothing described above. Parameters that are not used for the chosen smoothing type are disabled.
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5.15.5.1.2.1 [image: image456.png]Start frequency [Hz]: 0 -




Determines the frequency where the smoothing starts. Below this frequency, nothing is plotted if the smoothing type is Octave - low frequency correction, Octave - no correction or Constant. If the smoothing type is Constant (low freq.) - Octave (high freq.), then constant bandwidth smoothing is performed below this “start frequency” and octave smoothing is performed above.

5.15.5.1.2.2 [image: image457.png]‘Smooth over [points per division]: [1 -




Determines how many points are to be computed and plotted within each division. The value may be typed or chosen from the list. If the smoothing type Octave - low frequency correction or Octave - no correction is selected, it gives the number of points within the octave fraction band specified (see Smooth over [octaves]). There are more points at high frequency when plotting on a logarithmic x-axis, but using this method we end up with a constant number of points over the whole frequency range. The software SMAART® uses the term Fixed Points Per Octave (FPPO).
If the smoothing type Constant is selected, it gives the number of points within the constant band specified (see Smooth over [Hz]).

If the number is larger than 1, it is the same as doing a sliding window smoothing because the windows will overlap.

5.15.5.1.2.3 [image: image458.png]Smooth over [octaves]: 16 =]




Determines the smoothing bandwidth in octaves. The value may be typed or chosen from the list. This is used if the smoothing type is Octave - magnitude mean/interpolation, Octave - low frequency correction, Octave - no correction and for the octave smoothing part of Constant (low freq.) - Octave (high freq.).

5.15.5.1.2.4 [image: image459.png]Smoath aver [Hz} 100 =]




Determines the constant smoothing bandwidth in Hertz. The value may be typed or chosen from the list. This is used if the smoothing type is Constant and for the constant bandwidth smoothing part of Constant (low freq.) - Octave (high freq.).

5.15.6 Guidelines
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If [image: image461.png]vV Add Guidelines



 is checked, guidelines are added to the active measurement. If it is unchecked, guidelines that are in the plot will be deleted.

The type of guidelines is set from the [image: image462.png]Settings.



 button and is described below.
5.15.6.1 Guidelines settings

Guidelines for displaying maximum gain, minimum gain, average gain, and up to four different average gain offsets are supported.
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5.15.6.2 Frequency range

Sets the frequency range where the guidelines are to be displayed. The maximum guideline frequency is truncated if it is greater than the maximum frequency of the active plot. 
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5.15.6.3 Display numerical values

Determines if numerical values are to be displayed on the guidelines and if they are to be transparent or have a yellow field around the value.
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5.15.6.4 Guideline

5.15.6.5 [image: image466.png]¥ Maximum gain



 Maximum Gain

If checked, a horizontal line is drawn where the maximum of the active measurement magnitude frequency response curve is found within the frequency range given by the minimum and maximum frequency.

5.15.6.6 [image: image467.png]¥ Minimum gain



 Minimum Gain

If checked, a horizontal line is drawn where the minimum of the active measurement magnitude frequency response is found within the frequency range given by the minimum and maximum frequency.

5.15.6.7 [image: image468.png]IV average gain



 Average Gain

If checked, a horizontal line is drawn where the average of the active measurement magnitude frequency response is found within the frequency range given by the minimum and maximum frequency.

Note that the average is computed from the plotted data (e.g. if the data are plotted in Decibels, the average will be computed from the Decibels data).
5.15.6.8 [image: image469.png]IV Average gain offset 1 [dB]:



 Average gain offset.

Four average gain offsets are available.

If [image: image470.png]IV Average gain offset 1 [dB]:



 is checked, a horizontal line will be drawn at the average value added an offset given by the [image: image471.png]


 setting to the right of the check box.

5.15.6.9 Guideline style

[image: image472.png](Color [ Line width | Line style
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The color of the guidelines is set by clicking at the color field [image: image473.png]


. The line width is selected from the line width [image: image474.png]


 list box. The line style is selected from the line style list box [image: image475.png]


. Note that if the line width is greater than the smallest width, which is 1, the line style can only be Solid.

5.15.7 Compensation of Magnitude

Compensation of the magnitude frequency response is possible. In the current version of WinMLS, one compensation is possible and it is called microphone compensation, but any other compensation may be done instead. Note that the Equalizer compensation is always disabled).
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In order to do the compensation [image: image477.png][ Microphaone:



 must be checked, then the file containing the compensation data must be selected from [image: image478.png]Gen AG Neutrik 3382 RG2: ¥



.

If no such file exists, it can be made. 

An example of the format of the file is shown below. First a line containing the title, then a line with the title of each of the two columns, then the data columns, frequency column first followed by the magnitude frequency response data.

"Transfer Function Mag - dB volts/volts (0.33 oct)"

      "Hz"      "Data"

  13.81928,   5.60038

  18.42571,   5.60038

  23.03213,   5.60038

  32.24499,     5.60038

….

The frequency separation has no restrictions, spline interpolation is used to get the needed frequencies.

5.15.8 Shift/Normalization

Makes it possible to shift or normalize the curve.
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[image: image480.png][No Correction




 determines the type of shift/normalization and has the possibilities shown and explained below.
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5.15.8.1 No Correction

No shifting/normalization is performed.

5.15.8.2 Normalize to 0 dB

The curve is shifted so largest value is 0 dB.

5.15.8.3 Fix to Frequency Value

The curve is shifted so that at a specified frequency it is given a specified value. In the figure below, the specified frequency is 1000 Hz and at this frequency the curve is shifted so the value is 0 dB.

[image: image482.png]Fix at Freq. [Hz]: [1000 with shift [dB): [0




Note that if the y-axis is set to Linear or Squared (energy), the shift will still be given in dB, so a shift of 0 dB will give the value 1.

5.15.8.4 Shift

The curve is shifted, and the amount of shifting in dB is given below.

[image: image483.png]Shift [dB]: 20




Note that if the y-axis is set to Linear or Squared (energy), the shift will still be given in dB, so a shift of 20 dB is the same as multiplying the Linear value by 10 and the Squared (energy) by 100.

5.16 Plot Type Settings: Phase Frequency Response/Function...

Displays the dialog box shown below.
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Note that the phase is influenced by the sound card response. This may be removed by using the measurement system correction feature. Most sound cards have a delay of some samples that give a linear phase shift. It is possible to remove a pure delay by using the delay removal and subtraction features of this dialog box.

The microphone will also influence the phase, to get an accurate phase, use a precision microphone with as high a bandwidth (higher than the measurement frequency range) and flat frequency response as possible.

5.16.1 X-axis settings

Selects the unit of the x-axis from one of the units displayed in the list shown below.

[image: image485.png]Hz - Lin
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5.16.2 Y-axis settings

Selects the unit of the y-axis and the processing of the data from one of the choices displayed in the list shown below.

[image: image486.png]Denrees.




If several curves are plotted and the y-axis setting is changed, the curves will be updated using the Plot->Refresh All procedure.

5.16.3 General Frequency Domain Settings

Click the button [image: image487.png]General frequency domain settings.



 to open the dialog box also accessed from Plot->General Frequency Domain Settings….

5.16.4 Phase type

Selects the type of phase from the list below.

[image: image488.png]i
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Minimum and excess phase are viewed unwrapped and smoothing (explained below) is performed as the last computation if it is checked.
Wrapped phase

Restricts the phase range to –180 to +180 degrees, or –π to + π if radians is chosen as y-axis. The phase of a measurement will usually exceed this range, which results in jumps in the phase.

5.16.4.1 Unwrapped phase

The unwrapped phase is not restricted to the wrapped range, and has no jumps. The unwrapped phase is computed from the wrapped phase by changing absolute jumps greater than 180 degrees to their 2*180 degrees complement. Note that if the phase curve is not smooth, the computation of unwrapped phase may give a wrong result. Because of this, it is not recommended to select unwrapped phase when displaying the phase of a room measurement. View the phase as wrapped instead.

5.16.4.2 Minimum phase

The minimum phase is computed by taking the Hilbert transform of the log magnitude frequency response. If a system is minimum phase this means that for a given frequency response, the input energy will be transferred to the output in the least amount of time.
5.16.4.3 Excess phase

The excess phase is the difference between the actual phase and the minimum phase, the phase shift in excess of the minimum phase shift. 

For excess phase measurements the phase influence of the microphone can usually be ignored since a microphone usually has a nearly minimum phase response.

5.16.5 Smoothing

If the check box shown below is checked, frequency domain smoothing is performed.

[image: image489.png]I~ Use smoothing Settings.




The type of smoothing or integration is set from the [image: image490.png]ettings.



 button and is described in the frequency response/spectrum plot type Smoothing Settings.

5.16.6 Remove delay in frequency range

If [image: image491.png][~ Remoave delay in frequency range [Hz]:



 is checked, the delay is removed in the frequency range specified below the check box:

[image: image492.png]50 10000




If the settings above are used, the delay is removed in the range 50-10000 Hz. If Subtract delay as described below is used together with this option, the delay is first removed in the specified frequency range, then the delay is subtracted.

5.16.7 Subtract delay

If [image: image493.png][ Subtract delay [ms]:



 is checked, the specified delay [image: image494.png]


 is removed. If Subtract delay and Remove delay in frequency range (described above) is used together, the delay is first removed in the specified frequency range and finally the delay is subtracted.
5.17 Plot Type Settings: Group Delay...

Displays the dialog box shown below.
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Group delay is the derivative of the phase with respect to frequency. The numerical derivation is performed by taking forward differences on left and right edges and taking cantered differences on interior points.

5.17.1 X-axis settings

Selects the unit of the x-axis from one of the units displayed in the list shown below.

[image: image496.png]Hz - Lin
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5.17.2 Y-axis settings

Selects the unit of the y-axis and the processing of the data from one of the choices displayed in the list shown below.

[image: image497.png]Miliceconde L Linear
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If Milliseconds – Logarithmic is selected, note that the logarithm of negative group delay values cannot be computed. If negative values exist, they are not plotted.

If several curves are plotted and the y-axis setting is changed, the curves will be updated using the Plot->Refresh All procedure.

5.17.3 General Frequency Domain Settings

Click the button [image: image498.png]General frequency domain settings.



 to open the dialog box also accessed from Plot->General Frequency Domain Settings….

5.17.4 Type

Selects the type of phase from the list below

[image: image499.png]Minimum
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5.17.4.1 No processing

No processing of the group delay is performed.

5.17.4.2 Minimum group delay
The minimum group delay is computed as the derivative of the minimum phase frequency response.

5.17.4.3 Excess group delay

The excess group delay can be used to check time alignment in speaker system. It is computed as the derivative of the excess phase frequency response.

5.17.5 Smoothing

If the check box shown below is checked, frequency domain smoothing is performed.

[image: image500.png]I~ Use smoothing Settings.




The type of smoothing or integration is set from the [image: image501.png]Settings.



 button and is described in the frequency response/spectrum plot type Smoothing Settings.

5.18 Plot Type Settings: Waterfall...

Displays the dialog box shown below.
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5.18.1 X-axis settings

Selects the unit of the x-axis from one of the units displayed in the list shown below.

[image: image503.png]Hz - Lin
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5.18.2 Y-axis settings

Displays the unit of the y-axis. Only Decibels is supported.

[image: image504.png]-anis:




5.18.3 Z-axis settings

Selects the unit of the z-axis from one of the units displayed in the list shown below.
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If several curves are plotted and the x-axis setting is changed e.g. from Time [samples] to Time [ms], the curves will be updated using the Plot->Refresh All procedure.

5.18.4 Waterfall layout

Settings for determining some of the waterfall layout properties.
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Note that other layout settings such as zooming, rotation, elevation, offset are found in Plot->Chart Settings for Active Plot... under the 3D tab as shown below.
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In order to set the Rotation and Elevation, [image: image508.png][~ Orthogonal



 must be unchecked.
5.18.4.1 Mode

Selects how the waterfall is viewed.

[image: image509.png]Mode:  [waterfall ~




Three choices are possible as shown below.
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5.18.4.1.1 Separate lines waterfall

The waterfall plotted as separate lines.

[image: image511.png]EE =
\CES

| 5

i o

o g

i 8

N 5

R £

y

& « |B

. ol

El &

[

= &

7 g

g ]

3 &

[a] E4

E

G n

3 |8

2 ¥

o a

o g

2 g

& £

3 g ke

E =

s =

Qo L%





The first advantage of this mode is that slices containing more than 2000 points can be plotted. This is not possible with the other two modes, so if more than 2000 points are tried to be plotted WinMLS automatically switches to this mode.

The second advantage of this mode is that the [image: image512.bmp] and [image: image513.bmp] buttons on the Frequency Plots toolbar can be used to set the active slice for reading cursor values on the Status Bar (displayed at the bottom of the WinMLS area as shown in the figure above).
5.18.4.1.2 Waterfall

The waterfall is plotted using horizontal slices as shown in the figure below. The figure is made using File->Copy to Clipboard with Plot->White background on Copy/Print checked.
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The mode waterfall has a limit of 2000 points in each slice. To get within this limit we recommend using smoothing.

5.18.4.1.3 Surface

The waterfall is plotted using lines from all the neighbouring data-points as shown in the figure below. The figure is made using File->Copy to Clipboard with Plot->White background on Copy/Print checked.
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The mode surface has a limit of 2000 points in each slice. To get within this limit we recommend using smoothing.

5.18.4.2 Perspective

If [image: image516.png][~ Increasing z-axis [perspective]



 is checked, the backside of the waterfall plot is displayed.

5.18.4.3 Display plotting of each slice

If [image: image517.png][~ Display plotting of each slice



 is checked, each slice will be plotted right after it has been computed. Note that if it is checked, the plotting will take more time since if it is unchecked, all slices will be computed and then plotted in one operation.

5.18.5 Energy-Time-Frequency (ETF) calculation settings

Determines the special settings for the Energy-Time-Frequency mode. The special settings determine size of the data used for computing each slice (FFT size) and the window type applied on each of the slices. Note that no zero-padding is applied in computing Energy-Time-Frequency mode. The DC-component, if any, is not removed from each slice.
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5.18.5.1 Window type

Select the window type to be used for computing each of the slices. The choices are displayed below.
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5.18.5.2 FFT size

Select the length of the data to be used for computing each of the slices using the Fourier transform. The number must be specified in samples, it can be typed or chosen from the list. The resulting length in milliseconds is also displayed.
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5.18.6 Mode

Sets what type of waterfall plot is to be displayed.

[image: image521.png]



The choices are displayed and explained below.
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5.18.6.1 Energy-Time-Frequency (ETC)

The Energy-Time-Frequency mode is the same as a spectrogram. The data used for computing the waterfall is the windowed measurement data. The time window on the data in General Frequency Domain Settings (the time window is found clicking the button [image: image523.png]Time window settings for Active Measurement.



) determines the part of the time data the ETF is calculated from. It also determines if the time data is to be windowed before computing the ETF. 

The windowed measurement data are divided into slices and the Fourier transform is computed for each slice. Special settings for this mode are found in the bottom right of this dialog box under Energy-Time-Frequency (ETF) calculation settings. The special settings determine the size of the data used for computing each slice (FFT size) and the window type applied on each of the slices. Note that no zero-padding is applied in computing Energy-Time-Frequency mode. The DC-component, if any, is not removed from each slice.

5.18.6.2 Cumulative Spectral Decay (CSD)

This mode is generated by computing the FFT of successively left-shifted versions of the windowed measurement data. The first slice is exactly the same as plotting the magnitude frequency response (Frequency Response/Spectrum plot type). This is because the FFT size and time window on the data is the same in General Frequency Domain Settings ( the time window is found clicking the button [image: image524.png]Time window settings for Active Measurement.



). The next slices are computed by shifting this window (successive slices are shifted). The size of the shift is specified in FFT Shift. The number of slices is determined by Cycles (number of slices). The computation does not stop if the end of the measurement is reached. The DC-component is removed from each slice. This is done by subtracting the DC-component of the last half of each slice.

5.18.7 Cycles

Determines the number of slices to be displayed.

[image: image525.png]Cyeles (number of sices):




If Cumulative Spectral Decay (CSD) is selected as waterfall mode, the number of slices to be plotted is set here. 

If Energy-Time-Frequency (ETC) is selected as waterfall mode, the number of slices to be displayed is set by the time data window ( the button [image: image526.png]Time window settings for Active Measurement.



 in General Frequency Domain Settings). However, the number of slices is displayed, but is disabled.

5.18.8 FFT shift

Sets how many samples the slices are to be shifted before computing the magnitude frequency response on the measurement data. The number is also displayed in milliseconds as shown below. 
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5.18.9 Floor

Determines if a floor is to be used and where to set the floor. The purpose of the floor is to make the waterfall plot look nicer. The waterfall data having values lower than the floor limit, e.g. –60 dB will be given this value. The floor is thus not the same as the y-axis minimum value.

[image: image528.png]Floor: [aue =] [5 P60 [dB)




Three choices are available as shown below.

[image: image529.png]No floor
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5.18.9.1 No floor

The waterfall is displayed without any floor. 

5.18.9.2 Use floor:

Floor is used and the floor limit is determined using the dB setting [image: image530.png]60 [dB]



. 

5.18.9.3 Auto

Floor is used and the floor limit is determined automatically so that a percentage of the last part (20 percent) of the measurement data, given by [image: image531.png]


, will be a part of the floor.

5.18.10 General Frequency Domain Settings

Click the button [image: image532.png]General frequency domain settings.



 to open the dialog box also accessed from Plot->General Frequency Domain Settings….

Note that the settings that do not apply to the waterfall plot type are disabled.

If complex division using the reference measurement is selected in Plot->General Frequency Domain Settings…, the resulting complex frequency response is inverse Fourier thus performing deconvolution. The deconvolved measurement is used for the waterfall computation. The window limits for the deconvolution are set by the window settings in the dialog box [image: image533.png]Time window settings for Active Measurement.



 and [image: image534.png]Time

indow settings for Reference Measurement,



. But if Cumulative Spectral Decay is chosen as mode, the end window limit for the active measurement is set as the end of the measurement.

5.18.11 Smoothing

If the check box shown below is checked, frequency domain smoothing is performed on each slice.

[image: image535.png]I~ Use smoothing Settings.




The type of smoothing or integration is set from the [image: image536.png]Settings.



 button and is described in the Frequency response/Spectrum plot type Smoothing Settings.

5.18.12 Waterfall microphone compensation

If [image: image537.png][~ Apply magn. freq. response mic. compensation



 is checked, the microphone compensation specified in the Frequency response/Spectrum settings (Plot->Plot Type Settings->Frequency Response/Spectrum…) is used for the waterfall plot also.

Note that each frame is compensated for the microphone magnitude response.

5.18.13 Reference to slice

If [image: image538.png][~ Reference to slice:



 is checked, the selected slice (in the figure below slice number 1) is used as reference. All slices will be viewed as differences to the reference slice. The reference slice will therefore be flat.

[image: image539.png]I Beferencetosice: [1 = [ms]




5.18.14 Shift magnitude

If [image: image540.png][~ Shift magnitude:



 is checked, the magnitude is shifted in dB given by [image: image541.png]o [dB]
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5.19 Plot Type Settings: Room Ac. Parameters...

Displays the dialog box shown below.
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Room acoustics parameters, such as reverberation time and speech transmission index can be displayed.

5.19.1 Type

The types of acoustical parameters that may be computed and displayed are shown below. 
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The parameters are explained in the documentation for the menu item Room Acoustics->Parameter Settings....

When plotting a single value parameter (e.g. STI), the x-axis is linear. When plotting a multiple value parameter (e.g. T30), the x-axis is set to logarithmic. As default the x-axis displays the octave band values, but it is possible to change the axis labels and gridlines, see the FAQ: Room Acoustics section of the help file on how to do this.

5.19.2 Plotting dependency on SNR

If the check box shown below is checked, values of parameters that have a worse signal-to-noise ratio than the number specified below will not be displayed.

[image: image546.png]™ Do not plot if SNR is lower than [dB]: 15




5.19.3 Calculation Options

Clicking [image: image547.png]Calculation Options.



 opens the same dialog box as Room Acoustics->Calculation Options…. An explanation of the dialog box is given in the Room Acoustics Users Guide.

5.19.4 Parameter Settings

Clicking [image: image548.png]Parameter Settings.



 opens the same dialog box as Room Acoustics->Parameter Settings…. An explanation of the dialog box is given in the Room Acoustics Users Guide. The settings in the dialog box that are not used for the plot type are disabled.

5.19.5 Display Signal to Noise Ratio (SNR)
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The signal-to-noise ratio can be displayed in the plot as numbers in the plots as shown in the figure below.
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If [image: image551.png][V Display numerical value of SNR



 is checked, the SNR is added as marks above the plot points as shown in the figure below. If [image: image552.png][ Transparent numerical value



 is checked, the mark is transparent and not yellow.


5.20 Plot Type Settings: Levels...

Displays the dialog box shown below.

[image: image553.png]evel Plot Settings

Type of level to display

Time Data processing

™ Use Time Data plot ype processing
Time Data pot type setings.

General Time Window seltings.

1/3 octave fequency range.

st 15 =] En [0 5]

W] cwed |





Note that this plot type may not be automatically refreshed for all kinds of changes in settings.

5.20.1 Type of level

The type of level is selected as shown below.

[image: image554.png]Type of level to display





The choices are displayed below. 
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Note that in order to give for example the RMS of the sound card input signal, the input must be calibrated (Measurement->Hardware Calibration) and the measurement must not be in transfer function mode (e.g. a MLS measurement will consider the output at well).

5.20.1.1 RMS 

The RMS value of the windowed measurement data is computed and displayed. The window settings are found in Time Data processing described below. 

5.20.1.2 Energy

The RMS value of the windowed measurement data is computed and displayed. The window settings are found in Time Data processing described below. 

5.20.1.3 Linear sum (1/3 oct., scope mode)

The linear sum of 1/3-octave frequency bands is computed and displayed. The frequency range is determined in the 1/3 octave frequency rang settings.

If the measured data is a transfer function (for example measured with MLS output signal), the data are corrected for the output signal so that the value for the input only is computed. This makes it possible to plot the input level and is why it is called scope mode. Two types of scope mode is supported, either Stationary signal (power) or Transient signal (energy). The scope mode settings are found in the lower right of the dialog box displayed after clicking [image: image556.png]General requency domain setiings.



 as shown in the figure below.

[image: image557.png]Scope mode: | Stationary signal (power] .




If you are measuring impulse responses, Transient signal (energy) should be selected.

Note that the correct absolute value is given only if the absolute level of the input is calibrated. In Measurement->Hardware Calibration...., click the Settings... button as shown below.
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Note also that if Microphone compensation is turned on in Plot->Plot Type Settings->Frequency Response/Spectrum... as shown below,
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then microphone compensation will also be used in when computing the frequency response for the Levels plot type.

5.20.1.4 dBA

The dBA-weighed sum of 1/3 octave frequency bands is computed and displayed. The computation is done as explained in the chapter above Linear sum (1/3 oct., scope mode).
5.20.1.5 dBB

The dBB-weighed sum of 1/3 octave frequency bands is computed and displayed. The computation is done as explained in the chapter above Linear sum (1/3 oct., scope mode).
5.20.1.6 dBC

The dBC-weighed sum of 1/3 octave frequency bands is computed and displayed. The computation is done as explained in the chapter above Linear sum (1/3 oct., scope mode).
5.20.2 Time Data processing

Determines how the measurement data is processed before computing RMS or Energy.
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If [image: image561.png][ Use Time Data plot type processing



 is checked, the measurement data will be processed according to the settings obtained by clicking [image: image562.png]Time Dats plot type settings.



. These settings are described under Plot->Plot Type Settings->Time Data….

Clicking [image: image563.png]General Time Window settings.



 gives access to the time window settings determining what part of the measurement data to be used for the computation and the window applied to the measurement data.

5.20.3 1/3 octave frequency range

Determines the frequency range used for computing the Linear sum, dBA, dBB and dBC.

[image: image564.png]173 octave frequency range-

stat [i0 v] End [20000 ]
neal fequency domain setings.





Clicking [image: image565.png]General requency domain setiings.



 gives access to the settings for computing the octave bands. The frequency response data are integrated to obtain the energy in each band.

5.21 General Frequency Domain Settings...

Displays the dialog box shown below containing settings that apply to all frequency domain plot types.

[image: image566.png]General Frequency Domain Settings

Active measurement selfings Fouer tansfom size-

e window setings for Active Measuremer. & Zeropad o lowest possible order of two

€ Lseexoctszeof Tine Data Window
¥ Use Time Data lt lype pracessingbefors Fouer ansform £ Use ired sie lsamplost [131072 &1
Tine Data pot ype selings.

Freguency separation: 2.93 Hz

Riference measurement (used as divisor i division i perfomed) Various

7 Divide (comples) active measurement with eference measurement I Invett resuling response (complex)

o W~ B ficgiensy essiioning

& Memary: [Meas. 3 || scope mads:

7 Update aier new messurement

Time window setings for Reference Messurement

5] cwed |





5.21.1 Active measurement settings

Gives the settings for the active measurement in the upper plot (and lower plot, if there are two plots). However, if Plot->Refresh All is selected, all the most recent curves for each measurement will be refreshed using the current settings.
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5.21.1.1 Time window settings 

Clicking the [image: image568.png]Time window settings for Active Measurement.



 button in Plot->Frequency Domain Settings... or the buttons [image: image569.bmp] or [image: image570.bmp] from the Frequency Plots Toolbar will open the dialog box displayed below for setting the window size and type.
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5.21.1.1.1 Measurement name

Displays the measurement the window is applied to.
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5.21.1.1.2 Window type

Selects the type of window to be used.

[image: image573.png]‘window type





The possible choices are shown in the figure below. Note that if an impulse response is to be windowed, it is not recommended to use a full window.
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5.21.1.1.3 Window size

Sets the start and end of the window. The corresponding y-values are also shown.

The unit [image: image575.png]


 determines the units of the window limits to be displayed in the dialog box. The following may be selected:
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The button [image: image577.png]End as max



 is used to set the end of the measurement to the end window limit.

If [image: image578.png][V Set end as maximum limit on new measurement



 is checked, the X-max is set to the maximum value possible when a new measurement is performed or inserted.
5.21.1.2 [image: image579.png]¥ Use Time Data plot type processing before Fourier transform




Determines if the processing of the Time Data plot type is to be applied before computing the frequency response. Note that if this is not checked, the DC-component is automatically removed.

5.21.1.3 [image: image580.png]Time Dats piot type setiings.




Opens the settings for the Time Data plot type shown below.
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Only the Time Data Processing settings are enabled since the other settings have no effect in the frequency domain. This dialog box is explained in Plot Type Settings: Time Data…
5.21.2 Reference measurement

Contains the settings for the reference measurement.

5.21.2.1 [image: image582.png][V Divide [complex] active measurement with reference measurement



 Perform division

If checked, the active measurement is divided complex with the reference measurement. If the sampling frequency is not the same for the active and the reference measurement, no division is performed and an error message is displayed.

The zero-padding size has to be the same for the two measurements or else the division will not work, also the zero-padding size must be larger than the window size for both measurements to prevent truncation. Therefore the longest Time Data Window of the two measurements is used as basis of finding the zero-pad size.

5.21.2.2 Select reference measurement

The reference measurement can be selected either from file or from the measurements available in memory.
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If you want to select the measurement from file, first check [image: image584.png]{+ File:



, then click the [image: image585.bmp] button to open the browser. Note that the selected file is not added to the memory measurement file list.

If the measurement is selected from memory as shown in the figure above, it is possible to update the reference measurement when a new measurement is performed by checking [image: image586.png][V Update after new measurement



. Then if a new measurement is performed or inserted, the reference measurement is set to the current active measurement, for example if the active measurement is Meas. 3 and a 1-channel measurement is performed. The new active measurement will get the name Meas. 4, while the reference measurement will be updated to Meas. 3, since Meas. 3 was the active measurement before the measurement was performed. This feature is useful if you want to monitor the difference between the current and the previous measurement. For example if. 3 measurements are inserted in one operation (using File->Insert), the reference measurement will be updated 3 times. When the first measurement is plotted the current active measurement will be used as reference measurement- When the second measurement is plotted, the first measurement will be used as reference measurement. When the third measurement is plotted, the second measurement will be used as reference measurement. This is useful to monitor the difference between the measurements taken after one another.

If a multi-channel measurement is performed and [image: image587.png][V Update after new measurement



 is checked, channel 2 of the performed or inserted measurement will be set as the reference measurement. E.g. if a 2-channel measurement is performed and has the name Meas. 4, ch. 1, the reference measurement will be updated to Meas. 4, ch 2. If two or more measurements are inserted and [image: image588.png][V Update after new measurement



 is checked

This feature is useful if you want to monitor the difference between the two channels.

5.21.2.3 [image: image589.png]Time

indow settings for Reference Measurement,




Clicking this button opens the dialog box for setting the window size and type for the reference measurement. This dialog box is similar to the button for setting the time window for the active measurement [image: image590.png]Time window settings for Active Measurement.



, and refer to this to get more information.

5.21.3 Fourier transform size

Selects the size of the Fourier transform for the active measurement and for the reference measurement if division is to be performed. The choices shown in the figure below will be discussed.
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5.21.3.1 [image: image592.png](¥ Zeropad to lowest possible order of two




This is the setting that gives the greatest speed since the Fourier transform is executed fastest when the length of the data is order of two, e.g. 1024 which is 2^10. If the windowed data does not have a order of two length, the data must be padded. E.g. if the length of the windowed data is 700 samples, the data are padded to obtain the length 1024. Usually zeros are used for this padding, therefore the name Zeropadding, but WinMLS does not pad zeros, instead it pads the last value of the windowed data. This is done to prevent from errors in case the data has a DC-component. Note that because this method is applied, this setting should not be used with a Rectangular window on non-transient data (this is not recommended anyway).

5.21.3.2 [image: image593.png]™ Use exact size of Time Data Window




Used to get a Fourier size equal to the exact size of the time data window.

5.21.3.3 [image: image594.png]" Use fixed size [samples]: [131072 =]




Used to determine the exact size of the Fourier transform. Any number may be typed in the [image: image595.png]131072 7|



 box. But the numbers on the list gives the best computational speed since they are an order of two.

[image: image596.png]



An error message is given if the selected Fourier transform size is less than the size of the time data window and reference measurement time data window if division is to be performed.

5.21.3.4 [image: image597.png]Frequency separation: 293 Hz




Gives the frequency separation in Hertz, which is the distance between each point along the frequency axis. The frequency separation is equal to the Fourier transform size divided by the sampling frequency. 

5.21.4 Various

Contains frequency domain various settings.

If [image: image598.png][ Invert resulting response [complex]



 is checked, the complex frequency response (after division, if division is selected) is inverted. 

If [image: image599.png][ Add frequency resolution line



 is checked, a vertical line is added to the frequency domain plot types as shown in the figure below.
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The “Frequency resolution line” will indicate graphically where the data should not be trusted. At the thick part of the line, the results should not at all be trusted. At the thin part of the line (which is twice the size of the thick line), the result is not certain.

The color of the line is set in Plot->Default Curve Styles…. The line refers to the active measurement curve.

 The scope mode setting [image: image601.png]Scope made: [Stationary signal (power) ¥



 has no effect if the measurement is a transfer function (a MLS measurement). If the measurement is performed in scope mode, the choices shown in the figure below are available. 

[image: image602.png]Sl




The settings will affect the scaling of the frequency response. If Stationary signal (power) is selected and the plot type is Frequency Response/Spectrum, the power will be plotted. If the signal is a transient signal, this should not be selected since the level will depend on the window and zero-padding length. To prevent this, select Transient signal (energy).

5.22 Default Curve Styles

Displays the dialog box shown below.
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In the upper left of the dialog box shown above, the styles for the time data window and the frequency resolution line is set. After that the styles for curve 1-16 is set. Curve 1 is the first curve plotted, and from the figure above we see that this has a red color. The next has a blue color and so on.
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5.22.1 Selecting curve color

The color is selected by clicking on the color field [image: image605.png]


. This will open the dialog box displayed below. (The language of the dialog box will set to the language of your operative system, this is why the text in the figure below is not in English).
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Any color may now be selected by clicking somewhere in the field to the upper right of the dialog box displayed above. The color may also be selected by clicking in any of the [image: image607.bmp] fields. 

5.22.2 Selecting curve width and style

The curve width and style is set from [image: image608.png]1 (Solid)




.

The choices are listed below. 
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If the curve width is 1, which is the smallest possible, it is possible to plot the line with dashes and/or dots. Note that if the curve contains many data points, the dashes and dots may get so close in the plot that the line looks like it is Solid. But if the plot is saved in a picture format, this should not be the case.

Note that if a curve width greater than 1 is selected, the plotting speed is much decreased.

5.22.3 Display curve belonging to active measurement with different width

The curve (most recent) belonging to the active measurement may be displayed with a width different from the other curves as shown below. If curves from several measurements are plotted, this is useful for finding the curve belonging to the active measurement.

[image: image610.png][In neither plot | display active curve with width: [2
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If In neither plot is selected, this option is turned off. This is recommended, since if a curve width greater than 1 is used, the plotting speed is decreased. We recommend using Plot->Solo Active Measurement Curve instead.

5.22.4 Wrap index

This is useful if several curves are plotted and you want the colors to repeat.

[image: image612.png]Wirap index: [16 )




If the wrap index is e.g. set to 4 and 8 curves are plotted, the first 4 curves will get colors as selected from the Default Curve Styles list. But the 5th curve will get the same color as the first curve, the 6th curve will get the same color as the second curve, and so on.

5.23 White background on copy/print

If this is checked, when copying or printing the background is set to white. This may be useful for saving ink.

5.24 Advanced Plot Settings…

Displays the dialog box shown below.
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5.24.1 Add text to Plot

These settings determine if the plot title/footer/labels are to be updated and what is written after a measurement is plotted. 
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If no check boxes are checked, the text is not changed. This is useful if you want to use your own text. The axis labels is set in Plot->Chart Settings for Active Plot... under the Axis tab, then under the Titles tab as shown in the figure below. 
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The title is set in Plot->Chart Settings for Active Plot... under the Titles tab. The footer is also set there by selecting [image: image616.png]SubFoot



 as shown below.
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5.24.1.1 Add to Title
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If [image: image619.png][V Plot type Title



 is checked, the title of the plot type is added to the plot title. The title added is normally the name of the plot type. E.g. the plot type Time Data gets “Time Data” as title. But the title may in some cases depend on the plot type settings. E.g. if the plot type is Room ac. Parameters and Reverberation Time (T30) is selected as parameter type, the title is “Reverberation Time (T30)”.
If [image: image620.png][V Measurement Title



 is checked, the title of the measurement that is plotted is added to the plot title. Note that if the measurement is a .wmt-file or .wav-file not generated using WinMLS 2000, the measurement header will not contain any title.

In order to actually view the title in the plot, the button [image: image621.bmp] on the Standard Toolbar must be toggled.

5.24.1.2 Add to Axis Titles
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If [image: image623.png]V' Units



 is checked, axes units will be added according to the plot type settings and the plotted measurement data header.

In order to actually view the title in the plot, the button [image: image624.bmp] on the Standard Toolbar must be toggled.

5.24.1.3 Add to Footer
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If [image: image626.png][V Measurement Date



 is checked, the date of the plotted measurement is added.

If [image: image627.png][V Measurement Name



 is checked, the name of the plotted measurement is added.

If [image: image628.png][V Measurement Comment



 is checked, the comment of the plotted measurement is added.

If [image: image629.png][V Date when last curve was plotted



 is checked, the date when the last curve was plotted is added.

Note that if the measurement is a .wmt-file or .wav-file not generated using WinMLS 2000, the measurement header will not contain any measurement date or comment.

In order to actually view the title in the plot, the button [image: image630.bmp] on the Standard Toolbar must be toggled.

5.24.2 Various
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These settings apply to all plot types.

If [image: image632.png][ Ask user to save active plot when closing active window



 is checked, a message box is displayed when closing the active window asking if the plot is to be saved. 
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If Yes is chosen, the browser for saving the active plot as picture format is displayed (same as File->Save Active Plot As…).
If [image: image634.png][V Save current Chart-file when saving post-processing setup



 is checked, the chart-file is saved when the post-processing setup is saved. Also when the temporary post-processing setup is saved, a temporary Chart-file is saved. A Chart-file contains all the settings in the Plot->Chart Settings for Active Plot... dialog box except for the settings of the plotted curves.

Note that when it is unchecked, the curves in the plot are not deleted automatically. This means that when a new Group window is opened or when the software is run, the previous curves are not deleted.

By checking [image: image635.png][~ Plot only each



 only every nth point will be plotted if the total length of the data is below as certain limit. This may be useful to make the plotting faster if a large file is to be plotted, e.g. a large .wav-file.

By checking [image: image636.png][~ Plot paints only in the range:



, it is possible to plot just a certain range of the data points. This may be useful for plotting a part of a large file.

If [image: image637.png][~ Plot transfer Function in



 is checked, a transfer function measurement (a MLS measurement) is plotted in scope mode. This means that only the scaling of the input is considered, and not the output scaling.

5.24.3 Curve Type and corresponding Chart-file
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5.24.3.1 Plot type

The Curve type and Chart-file that corresponds to the selected Plot type is displayed. The user may select a new Curve type and Chart-file for the specific plot type. All the available plot types are present in the list.

5.24.3.2 Curve type

In the post-processing setups found when installing WinMLS, the default curve type for most plot types is set to FastLine as shown in the figure below.

[image: image639.png]Curve type: [FastLine




This means that the curves are drawn using the FastLine type. Please note that for the Room Ac. Parameters plot type, single-valued parameters are plotted with the plot type Bar independent of the curve type chosen here.

Some of the available curve types are shown in the figure below.
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Note that not all the curve types from the list will make sense for all plot types. Some useful items are: Line (it has more features than FastLine and is used for the RoomAc Parameters plot type), Bar, Area, Point, FastLine, Histogram (useful e.g. for plotting octave bands).

Examples on how the curve types look like are found in Plot->Plot Layout…. From this dialog box the curve type in the current plot can be set.

[image: image641.png]



In the dialog box obtained from Plot->Plot Layout…, click on [image: image642.bmp] shown in the figure above. 

A new dialog box will be displayed showing curve types to select from, some of which are shown in the figure below.
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By clicking on the small arrow in the lower left corner of Fast Line [image: image644.png]


, the possibilities for this line type is displayed as shown in the figure below.
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For the curve type Line, the following choices are possible.
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5.24.3.3 Chart-file

A Chart-file (*.tee) contains all the settings in the Plot->Chart Settings for Active Plot... dialog box, except for the curve style settings. 
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A new Chart-file may be selected from the list of available files. Note that the check box [image: image648.png][V Save current * tee-file when saving post-processing setup



 must be unchecked, or it will not work properly in this version of WinMLS.

Use the Save button to save the current Chart file, the Save As... button to save the current Chart file with a new name and the Delete button to delete the current Chart file.

5.25 Post-Processing Setup...

Post-processing setup defines as all the WinMLS settings, except for the measurement settings which are defined in the measurement setup found in the measurement menu. 
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When WinMLS is exited, the setup filename is saved in registry and all the current settings are saved to a temporary setup. The next time WinMLS is run, this setup file is opened and the settings restored.

To prevent the user from accidentally deleting or overwriting a setup file, the setup files may be write-protected.

5.25.1 [image: image650.png]


 Select setup

Displays the selected post-processing setup. Setups are chosen from a list as shown in the figure below.
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5.25.2 Setup description

The setups descriptions describes the selected setup. The description should contain

· What kind of measurement setups is this post-processing setup suited for

· How should it be used

· How can it be adjusted

Not all information can be covered in the measurement setups, the most important information is given below.

5.25.2.1 General information about post-processing settings

· Remove or add toolbars from the View menu.

· Choose if you want to delete existing curves from Plot->Hold Plotted Curves
· See the FAQ: Plotting and Post-processing section for further information.

5.25.2.2 BlackNWhite

This setup does not allow any colors in the plots and the curve styles are dashed and dotted to separate the curves from each other. It is intended for exporting plots that has to be black and white only, e.g. for an article.

5.25.2.3 EnergySpectrum

The energy spectrum is displayed as bars in third octave bands in the upper plot, the lower plot displays the time data. This setup is meant to be used with the measurement setup ImpulseExcitation. Otherwise the settings are the same as the PostProcSetup.

5.25.2.4 NoBackgroundColors

This setup has no background colors in the plots, some find the background colors confusing. Otherwise the settings are the same as PostProcSetup.

5.25.2.5 PostProcSetup

Standard post-processing setup. As default, the upper plot displays the frequency response and the lower plot displays the time data. The time window is rectangular with a size of 50 millisec.The Levels plot type displays the time of flight and the Room Ac. Parameters plot type displays the reverberation time in third octave bands.

5.25.2.6 PowerSpectrum

The power spectrum is displayed as bars in third octave bands. This setup is meant to be used with the measurement setup QuasiRealTimeAnalyzer.

5.25.3 RoomAc2Channel

Setup showing the impulse responses in two plots plotted with y-axis in dB. It is intended for calculating room acousitcs parameters from 2 channels measurements. To be used with the measurement setup RoomAc2Channel. since it sends measurement channel 1 to the upper plot and channel 2 to the lower plot. When Room Acoustics->Calculate is selected, two sets of room acoustical parameters are computed from the active measurements in the upper and the lower plot.

5.25.4 RoomAcIACC

Setup showing the impulse responses in two plots and intended for computing inter-aural cross correlation (IACC) from a dummy head measurement. To be used with the measurement setup RoomAc2Channel. since it sends measurement channel 1 to the upper plot and channel 2 to the lower plot. When Room Acoustics->Calculate is selected, the IACC parameters are computed together with other parameters.

5.25.5 RoomAcLateralFraction

Setup showing the impulse responses in two plots and intended for computing lateral fraction (LF) and late lateral strength (LG). To be used with the measurement setup RoomAc2Channel. This setup sends measurement channel 1, which has to be connected to a omni-directional microphone, to the upper plot. Channel 2 is sent to the lower plot and must be connected to a fig-8 microphone. When Room Acoustics->Calculate is selected, the IACC parameters are computed together with other parameters.

5.25.6 RoomAcOctaveRT

The reverberation time is displayed in octave bands in the upper plot, the numbers in the plot show the signal-to-noise ratio (SNR). For T20 the SNR should be better than 25, else the RT value should not be trusted. The lower plot displays the time data plotted on a dB y-axis which makes it possible to see the decay as a function of time.

5.25.7 RoomAcOneThirdOctRt

The reverberation time is displayed in third octave bands in the upper plot, the lower plot displays the time data. Otherwise the settings are the same as the setup RoomAcOctaveRT.

5.25.7.1 ScopeMode (LoudspeakerSPL)

This setup allows for plotting the SPL of the loudspeaker as a function of frequency. To get the correct scaling, only the input signal is considered (the output is ignored). To do this, scope mode is turned on in Plot->Advanced Plot Settings.... To get the SPL, the input has to be properly calibrated.

5.25.7.2 SoundSystemCalibration

This setup is meant for calibrating sound systems. The upper plot displays the 1/6-octave smoothed frequency response. There is also 3 guidelines showing the average gain and the +-5 dB offset in the frequency range 0.1-10 kHz. These can be changed and new guidelines can be added.The lower plot displays the impulse response in time domain. The time window is half-cosine and it is set so when a new measurement is performed or inserted, the upper limit is set to the end of the impulse response. Otherwise the settings are the same as PostProcSetup.

5.25.7.3 THD + N (1kHz sinusoid)

The upper plot displays the THD + N using the curve type Bar. The lower plot displays the first milliseconds of the sinusoid. You might want to replace the sinusoid plot with the harmonic distortion. To do this, select the Frequency Response – Spectrum plot type. The spectrum is normalized and it is easy to read the harmonic component. A Blackman-Harris full window is applied.

5.25.7.4 ViolinAcoustics

Used for plotting resonances of a violin body. The frequency range is set from 100 Hz to 10 kHz. Example measurements is found in the Violins folder of the example measurements. Contact us if you are interested in purchasing transducers for measuring the input admittance.

5.25.8 [image: image652.png]


 Save setup as

Opens a dialog box for saving the current measurement settings.
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5.25.9 [image: image654.png]


 Delete setup

Deletes the selected setup. The button is disabled when only one setup file is left to make sure not all setups are deleted.

5.25.10 [image: image655.png]


 Load setup

Loads the selected setup and then closes the Post-processing Setup… dialog box. Note that you will not be asked to save the previous settings.

5.25.11 [image: image656.png]Close




 Close dialog

Closes the dialog box. No new setup will be loaded.

6 Room Acoustics Menu Reference
6.1 Calculate

The room acoustics calculations can be initiated in three ways:

1. From the main menu, item Room Acoustics->Calculate.
2. Choosing Room Acoustics Parameters as plot type, either from Plot->Select Plot Type(s) and Active Measurement or the Plot Toolbar.

3. Checking Display selected room acoustics parameters at the bottom part of Measurement->Measurement Tasks.
z

In case 1, calculations are carried out when choosing Calculate, and results for the selected parameters are displayed in a text grid window and/or saved a text file according to the settings in Calculation Options. 

In case 2 calculations are carried out each time plots are refreshed, and the result for the single selected parameter is plotted (the settings dialog box is displayed by double clicking in the plot). In both cases input responses are taken as active measurements as described above, and calculations are made according to the settings under the items Calculation Options and Parameter Settings in the Room Acoustics menu.

In case 3 room acoustics parameters are being computed and displayed to a grid when measurement files are inserted using File->Insert. If Room Ac. Parameters is selected as plot type, the selected parameter will be displayed in the plot as well according to case 2. Note that this will reduce the speed, since the computation will be performed twice.

Before parameter calculation, WinMLS automatically detects the start of the impulse response. This creates a reference for all subsequent time windowing and alignment of the response. Some parameters require impulse response energy to be calculated in time windows. All windowing is done before filtering to avoid energy leakage across window borders, even if this may increase the processing burden considerably. Then the impulse response is filtered in the specified frequency bands, the noise floor is optionally analyzed and compensated for, and a decay curve is calculated by backwards integration. The algorithms for the decay curve formation and parameter calculation are further described in the following subsections.

Errors leading to calculation abortion will prevent results from being presented and produce error messages explaining the situation.

6.1.1 Presenting results

Room acoustics parameters can be presented in a text grid, saved to a text file, or plotted directly in a graphics window. The check boxes Display in text grid and Send to text file specifies how to present and/or save results when the calculation is initiated through Room Acoustics->Calculate. All chosen parameters are displayed in the grid or saved to the file.

If the text grid box is checked, a result window will open after the calculation is finished. The data in the grid can be copied to the Windows clipboard for export to spreadsheets or word processing software.

An example of output data is shown below, the contents are: 

1. The name of the primary measurement, or impulse response file

2. Octave band center frequencies in Hz

3. SNR in dB, for primary and (optional) secondary input response

4. Parameters as function of frequency

5. Parameters independent of frequency

6. Estimated source to receiver distance in m
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(This example incidentally shows a typical anomaly, the combination of a low frequency octave band filter, a short time window, windowing before filtering and a high noise floor creates transient effects that can produce odd looking results, like the 63Hz D(%) value. Calculations are according to recommendations, but the practitioner must use his common sense in interpretation of the data.)

Blank fields indicate calculation errors, which are most often caused by noisy impulse responses and thereby insufficient decay range, or that time ranges are insufficient for a particular parameter. In these cases only particular parameters will be missing.

In some cases all parameters can be missing for a particular frequency band. The most common reason is when truncation of the impulse response at or above the noise floor is chosen in Calculation Options->Integration options, and the truncation point cannot be determined due to too much noise or an odd shape of the response after filtering in this band. See the 6.2.3 section for more information about this situation. 

If output to a text file box is chosen, results will be saved to a text file with a similar format as the grid. Saving directly to text file can only be done if the room impulse response itself is saved in a file prior to calculation. The text file ends up having the same name as the impulse response file, with the extension .txt. 

For calculations using a secondary impulse response as well, the name of the resulting text file will be composed using both filenames, for instance:

Primary: C:\WinMLS\Debug\Measurements\Studio1.wmb

Secondary: C:\WinMLS\Debug\Measurements\Studio2.wmb

Result: C:\WinMLS\Debug\Measurements\Studio1Studio2.txt
Results can also be plotted directly in a plot window. Only a single parameter at a time can be displayed as function of frequency, but it is possible to plot the same parameter calculated from several impulse responses for easy comparison. Choose the Room Ac. Parameters plot type (can be done from the Plot Toolbar or Plot->Select Plot Type(s) and Active Meas.). The parameter to be plotted is chosen by double-clicking in the plot or from Plot->Plot Type Settings->Room Acoustics. An example of plotting reverberation time in octave bands for three different responses is shown below.
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6.2 Calculation Options...

Room Acoustics->Calculation Options will display the dialog box controlling the fundamental setup of the room acoustics calculations. All settings are saved in the post-processing setup file. The dialog can also be reached via Plot->Plot Type Settings->Room Acoustics.
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6.2.1 Microphone type(s)

Choose the processing mode by indicating the constellation of microphone(s) used during the measurements. 

The different microphone types make possible different parameter calculations. For a description of the various parameters, see the Parameter Settings... section.

The options are as shown and explained below
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6.2.1.1 Single omni-directiona
Single microphone, most common situation.

6.2.1.2 Dual omni-directional
Two independent microphones. This option is provided for independent measurements but where simultaneous calculation can be an advantage, when measuring using the 2-channel capability of WinMLS. Two separate calculations will be carried out, and results will be presented in separate windows or files.

6.2.1.3 Omni-directional and figure-of-8
Combination of an omni-directional (primary) and a figure-of-8 (secondary) microphone. This option is used for calculation of lateral parameters, see the Lateral parameters section. The secondary response will only be used for these parameters, other parameters are calculated from the primary response.

6.2.1.4 Closely spaced omni-directional pair

A pair of impulse responses from either two identical microphones measured simultaneously, or from a single microphone measured in two locations. In the present version of WinMLS the processing is exactly like that carried out for option 5. This option is included for future extension, for instance calculation of lateral parameters without using a figure-of-8 microphone.

6.2.1.5 Binaural pair
A pair of impulse responses from either two identical microphones measured simultaneously, or from a single microphone measured in two locations. This option is used for calculation of binaural parameters, see the Interaural crosscorrelation section. The microphones are normally placed in or at the ear canal of a dummy head or a real person. The secondary response will only be used for these parameters, other parameters are calculated from the primary response.

6.2.2 Bandwidth

After being loaded to the room acoustics module, the impulse responses are filtered in bands according to the settings in this box. The options are shown and explained below.

[image: image661.png]Lowid High
Broadband
1/3 Octave [Reverberation time only]





6.2.2.1 Octave

Octave band filters, responses corresponding to the requirements in IEC 1260 [IEC 1260: 1995, Electroacoustics – Octave-band and fractional-octave-band filters]. Lowest octave where calculation is attempted is 63Hz, highest octave depends on the sampling frequency of the measured impulse response.
6.2.2.2 Low-Mid-High

Double-octave band filters, responses corresponding to the requirements in IEC 1260. Centre frequencies of 176.8Hz, 707.1Hz and 2828.4Hz provides three double octave filters corresponding to a low-mid-high combination of octave bands: 125Hz and 250Hz, 500Hz and 1kHz, 2kHz and 4kHz.

6.2.2.3 Broadband

No filtering is performed.
6.2.2.4 1/3 Octave (Reverberation times only)

Third-octave band filters, responses corresponding to the requirements in IEC1260 [IEC 1260: 1995, Electroacoustics – Octave-band and fractional-octave-band filters]. Lowest 1/3-octave where calculation is attempted is 40Hz, highest band depends on the sampling frequency of the measured impulse response. For this bandwidth only reverberation times is generally of interest, and therefore only the reverberation time parameters T30, early decay time (EDT) and user defined reverberation time (Tu) can be calculated.

To minimize the influence of the filter response on the reverberation time calculation, the impulse responses are filtered backwards. This greatly improves the accuracy for short decay times at low frequencies.

6.2.3 Integration options

After filtering, backwards integration of the impulse response to form a decay curve, or Schroeder curve, is done as further preparation to the parameter calculations. If h(t) is the filtered impulse response, the decay curve is:
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This provides a monotonically falling decay. The curve is usually normalized to start at 0dB. In practice the impulse response record is finite, and the integration becomes finite as well:
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Also, a measured response tends to contain some noise. Due to the phase randomizing property of the MLS deconvolution, additive noise of any kind in the measurement will give rise to a stationary noise floor, see the example below. This is advantageous as a combined noise-decay analysis of the filtered impulse response record can reveal the location of the cross-point between the response and the stationary noise floor, the response can be truncated at or above this point to lessen the influence of the noise on the results, and finally the truncated energy can be estimated and taken into consideration.
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If compensation for truncated energy is incorporated, and the estimated correction is denoted C, the decay curve is:
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The integration options are shown and explained below.
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6.2.3.1 Truncation and compensation

Integration of the impulse response, after truncation at or above the crosspoint between the response and the stationary noise floor, compensated for the truncated energy.
6.2.3.2 Truncation

Integration of the impulse response, truncated at or above the crosspoint between the response and the stationary noise floor.
6.2.3.3 Whole response

Integration using the whole impulse response, no noise analysis carried out.
6.2.3.4 More about Integration Options

The noise analysis, truncation and compensation are done after filtering, separately for each frequency band. Option 1 is the most accurate, and therefore recommended for most room impulse response measurements. However, it requires a measurement of reasonably high quality to give good results.

The crosspoint between the decaying response and the stationary noise floor is detected using an iterative algorithm [A. Lundeby, T.E. Vigran, H. Bietz and M. Vorländer, "Uncertainties of Measurements in Room Acoustics," Acustica, vol. 81, pp. 344-355 (1995)]. Subsequently, a truncation point is determined using a safety margin above the crosspoint. With the Noise margin parameter the user can specify in dB how far above the noise level at the estimated crosspoint the truncation point is chosen and integration shall start. Typical values are 5-10dB, the recommended value is 5dB. Higher margins should be used only with responses with extraordinary high signal-to-noise ratios. The late slope of the truncated response is calculated by a line fit, and a compensation for the energy lost by truncation is estimated assuming exponential decay to infinity.

The decay curve forms the basis for calculation of the various decay time parameters, and it can be plotted using the Schroeder plot-type. The plots below give examples of the three options. If truncation is chosen, all room acoustical parameters involving the late part of the response is calculated based on a similarly truncated impulse response. If compensation is chosen and the truncated energy can be successfully estimated, all room acoustical parameters involving the late part of the response are corrected for the truncated energy.

If the truncation point cannot be determined due to too much noise or an odd shape of the response after filtering, no parameters will be calculated for that particular frequency band. If a response produces trouble, turning off truncation and compensation and inspecting the filtered impulse response and Schroeder curve might reveal the source of the problem.

The figure below gives an example of the three options.
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6.2.4 Result of calculation

Room acoustics parameters can be presented in a text grid, saved to a text file, or plotted directly in a graphics window. The check boxes Display in text grid and Send to text file specifies how to present and/or save results when the calculation is initiated through Room Acoustics->Calculate. More information can be found in the Presenting results section.
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6.3 Parameter Settings...

Room Acoustics->Parameter Settings will display the dialog controlling which parameters are to be calculated, using check boxes. For some of the parameters the calculation can be controlled by specifying level and time limits, or even more advanced settings. All settings are saved in the post-processing setup file. The dialog will not be available if 1/3-octave bandwidth is chosen in Room Acoustics->Calculation options->Bandwidth, since only reverberation time is calculated for the 1/3-octave. The dialog can also be reached via Plot->Plot Type Settings->Room Acoustics.

For a more thorough introduction to the room acoustical parameters, see the ISO 3382 standard, or any good textbook on room acoustics.
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6.3.1 Decay range (SNR)

The signal-to-noise ratio (SNR) is not included in the Parameter Settings dialog, it is however an important parameter, and for the default settings it is always the first parameter given in the results grid and can be displayed as marks in the room acoustics plots. It is therefore discussed here.

Utilizing the phase randomizing property of the MLS deconvolution, the actual signal to noise ratio in the impulse response measurement can be estimated from the resulting response itself. This ratio is, however, not of much practical use in room acoustical analysis. Of much more interest is the so-called decay range, which directly describes the range of the decay curve which is available for analysis. For an explanation of the decay curve, see the Integration options
 section. 

The SNR in dB as displayed by WinMLS is actually the decay range. It is taken as the level of the decay curve at the point where the response is truncated before forming the decay curve. The resulting decay range is therefore, in addition to the physical signal-to-noise ratio in the measurement, dependent on the type and shape of the room impulse response and the chosen noise margin in the response truncation.

The decay range can be used directly to evaluate the quality of the room acoustical parameter calculations, especially the reverberation time T30. It should be noted, and is illustrated clearly in the examples in the Integration options section, that if no compensation for energy removed by truncation has been done, the decay range as calculated here is meaningless. It will therefore not be displayed in the results grid unless Truncation and compensation is chosen in Room Acoustics->Calculation Options->Integration Options.

If a secondary impulse response is used due to the chosen microphone option, a second row of SNRs will appear in the result grid. This is calculated separately for the secondary response.

6.3.2 Decay times
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The reverberation time (T30), is the 60dB decay time calculated by a line fit to the portion of the decay curve between ‑5 and ‑35dB. If the decay range is less than 35dB, the T30 is in WinMLS calculated using the range available. It is therefore important when using the T30, to keep an eye on the SNR to evaluate the quality. To be a valid measurement according to the ISO 3382 standard, the SNR should be displayed as 35dB or larger. 

The standard recommends a certain safety margin to the noise floor. It should be noted that the Noise margin parameter taken into account before forming the decay curve and calculating the decay range provides this safety margin. It is user changeable and described in the Integration options
 section.

The early decay time (EDT), is the 60dB decay time calculated by a line fit to the portion of the decay curve between 0 and ‑10dB.

The user defined reverberation time (Tu), is the 60dB decay time calculated by a line fit to the portion of the decay curve in an interval specified in the level limit boxes, remembering the minus signs in front. It is often used as a T15 (-5 to –20dB) or T20 (-5 to –25dB) parameter, giving a well defined decay time measure for responses with inferior decay range, or providing an indication of double sloping of the decay if it is significantly different from the T30.

All the decay time parameters are given in seconds. If the decay range in a particular frequency band is insufficient for EDT or Tu measurement, no calculation will be carried out.

6.3.3 Early energy ratios
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The early to late index, or clarity, is
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where te is the early time, typically 80ms for music application and 50ms for speech or stage evaluation. 

The early to total index, or definition, is
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Definition is mostly used for speech signals, and the early time is usually taken as 50ms.

The upper integration limits are taken as the truncation point determined in the decay curve formation, or the end of the impulse response, according to the integration option specified. If compensation for truncated energy is calculated, this is taken into account as well to increase accuracy.

The early limits can be changed to numbers other than recommended in the standard. For Clarity, it is also possible to get two values as output of the calculation if two numbers are typed, separated by a ‘&’. For example, ‘50&80’, which is the default setting, gives the two clarity values C50 and C80 as output. Note that this applies when writing parameters to grid or text file, when using the Room Ac. Parameters plot type, only one parameter is plotted, and the lowest early time is used, in this example C50.

6.3.4 Centre time

The centre time, [image: image674.png]vV Centre Time [Tc]



, is the first moment of the impulse response h(t):
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The upper integration limits are taken as the truncation point determined in the decay curve formation, or the end of the impulse response, according to the integration option specified. If compensation for truncated energy is calculated, this is taken into account as well to increase accuracy. 

Due to the time-weighting in calculating the first moment, the centre time is more sensitive to the influence of noise, and will therefore be particularly inaccurately calculated if the SNR is low. To compensate for this, an analytical compensation for the truncation of the first moment is also calculated in the truncation and compensation integration option.

6.3.5 Strength
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The sound strength, or level, is defined as
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(7)

where h10(t) is the free-field response of the (assumed omni-directional) source at a distance of 10m, filtered in the same way as the impulse response itself. 

The upper integration limit in the numerator is taken as the truncation point determined in the decay curve formation, or the end of the impulse response, according to the integration option specified. If compensation for truncated energy is calculated, this is taken into account as well to increase accuracy.

The reference level is:
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There are various ways of specifying or estimating the reference level, and this is governed by the choices in the direct energy options dialog box. The method is common for strength (G) and late lateral strength (LG).

6.3.5.1 Direct energy options

Pushing the Options… button opens up the direct energy options dialog box, where it is specified how to calculate the reference level. 
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The main options are shown and explained below. The last two options will be explained further in the following subsections. It should be noted that the standard requires a fairly elaborate calibration measurement of the sound source to provide the reference energy at 10m. Only option 3 gives the possibility of obtaining G-values according to the ISO 3382 recommendations.
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6.3.5.1.1 No reference energy

Lref is assumed to be 0dB in all frequency bands, which means no correction is made on the level calculated from the primary impulse response. This can be used for instance if the source level is unknown or of no interest, but the level difference at various measurement positions shall be compared. In this case no other options are available in the dialog.

6.3.5.1.2 Window active response

h10(t) is estimated by windowing the primary impulse response, and Lref is calculated subsequently. In this case the window length and temperature is available for change.
6.3.5.1.3 User specified

Lref is given directly by the user, or calculated based on reference measurements speficied by the user.
6.3.5.2 Window active response

This option is incorporated to provide a simple to use reference level calculation, without the use of separate reference response measurement or time-consuming reference level measurements. The reference free-field impulse response is estimated from the measured (primary) impulse response as:
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where r is the estimated source to receiver distance and w(t) is a half-Hamming window starting on the arrival of the direct sound in the impulse response. After windowing, the reference response is filtered, and the reference levels are calculated.

The window length can be specified in the dialog box, in ms. A recommended value is 5ms, which provides a useful trade-off between incorporating the impulse response of the loudspeaker while windowing out reflections from the surroundings. In normal concert hall measurements especially the stage floor reflection can be bothersome in this respect, it will in most cases fall inside the 5ms window.

The source-to-receiver distance is estimated based on the detected initial time delay of the direct sound, which requires that the measurement must have been performed with a feedback loop in place. The temperature on the measurement site can also be specified, in degrees Celsius, as this influences the speed of sound and thereby the estimated distance. No great accuracy is required, and in most room measurements 20(C, normal room temperature, can be used. It should also be noted that the initial time delay detected from the impulse response will provide the distance to the face of the loudspeaker, not necessarily to the acoustic center of the source.

Comparison with properly calibrated measurements have demonstrated that this method will normally provide too high G values at low frequencies due to insufficient window length, fairly good G values at mid frequencies (500-1000Hz), and too low G values at high frequencies due to the influence of the immediate surroundings of the transducers. Because of this G cannot be said to be calculated according to the ISO 3382 requirements.

6.3.5.3 User specified reference level

If user specified reference level is used, yet another dialog box can be opened with the button User specified settings. In this dialog Lref can be specified directly or calculated from reference measurements, all assuming calculation in octave bands are used.
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Direct specification of Lref is done in dB. This is useful in the case where the source and measurement equipment has been pre-measured in an anechoic room or otherwise, the reference level calculated, and the actual room measurement performed with exactly the same equipment and level settings. Alternatively known level changes can be used and corrected for. The calculation procedure described in the following subsection can be used to find reference levels for later use.

6.3.5.4 Reference level calculation procedure

A reference level calculation procedure is implemented for use with various reference measurement situations. The procedure is initiated by pressing the Perform computation… button, which opens up a browser window and the user can specify a set of reference impulse response files. These responses must have the same length and sampling frequency. The responses are windowed according to the choice in Window type, and scaled according to the choice in Source distance. Thereafter the energy of each is calculated in bands, and the reference level is found by averaging the energy across all the specified responses. The results are displayed in the Direct energy corrections dialog box, and should be saved for later use and reference. The calculation might take a while.

For a true omni-directional sound source a reference measurement in a single direction would be sufficient. Most practical sources are 12-faced speakers that start to show lobes in the polar pattern around 1kHz. The ISO 3382 standard therefore specifies that a proper reference level measurement shall be made in a free-field, and data from at least 29 directions shall be energy averaged. WinMLS can handle such a reference measurement, as well as any other less accurate reference that might be chosen.

Alternatives may range from the full set measured in a free-field, via fewer directions, increasingly reflective environments, to actual in-situ single direction responses. The user must choose a reference from what is practically possible, and be aware of the resulting accuracy.

The windowing options are shown and explained below.
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6.3.5.4.1 Whole response (anechoic)

This option assumes an actual free-field, or anechoic, measurement of high quality. If this is the case, it provides accurate reference levels across a wide frequency range.
6.3.5.4.2 50ms rectangular (anechoic)

This option is similar to option 1 in that it is suitable for free-field measurements. The windowing improves accuracy for most measurements, as in most bands data beyond 50ms will be noise anyway, and the window is sufficiently long to extend to very low frequencies. It is the recommended method for free-field reference measurements.
6.3.5.4.3 5ms Half-Hamming (in-situ, non-standard)

This option is similar to the windowing of the active response as described in the Window active response section, and can be used for in-situ measurements where a reference impulse response is measured separately. This can typically be done in concert hall measurements where a close range measurement across an empty stage or to a front seat row can provide a better reference than the actual measurement positions.
Source distance options shown and explained below.
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6.3.5.4.3.1 Compute from measurement (using initial time delay)

For this option the distance is detected and computed separately from the various reference responses, in the same way as described in the Window active response section. The temperature can be changed in the dialog as well, and will influence the speed of sound and thereby the distance. It should be noted that the distance to the acoustic centre of the source will be somewhat longer than the distance detected to the nearest loudspeaker face, which might influence close measurements. It is required that the initial time delay is correct, and the measurements must have been made with a feedback loop.
6.3.5.4.3.2 Specify in meters (meas. initial time delay is not used)

This option should be chosen when the reference measurement distance is known, and the same for all reference responses in the set.
6.3.6 Lateral parameters
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Calculation of lateral parameters requires microphone option omni-directional and figure-of-8, and both primary and secondary impulse response specified. It is further assumed that the omni-directional and the figure-of-8 microphones have the same sensitivities and are properly equalized with respect to each other, in the direction of maximum sensitivity. The two impulse responses should be measured in the same position, if possible simultaneously. The figure-of-8 should have one of the null-directions pointing either towards the source or along the long axis of the room, see ISO 3382. It is also extremely important that they are mutually synchronized, with matching absolute time scales. This can for instance be accomplished measuring with a feedback loop, providing responses with a true initial time delay.

The early lateral energy fraction is
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(10)

where hL(t) is the impulse response measured with a figure-of-eight microphone with one of its nulls pointed towards the source. The time limits are td, the direct time, and te, the early time. LF is normally used for music application, with direct time 5ms and early time 80ms. The limit 5ms is introduced to make sure the direct sound is totally suppressed. The time limits can be changed in the boxes.

The late lateral strength is
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(11)

This is a fairly new parameter, not mentioned in the standards so far, but it is believed to correlate well with subjective envelopment [J.S. Bradley and G.A. Soulodre, "Objective measures of listener envelopment," J. Acoust. Soc. Am., vol. 98, pp. 2590-2597 (1995)].

The upper integration limit in the numerator is taken as the truncation point determined in the decay curve formation for the lateral impulse response, or the end of the impulse response, according to the integration option specified. If compensation for truncated energy is calculated, this is taken into account as well to increase accuracy.

The reference energy in the denominator is calculated just as for strength, the same options govern the calculation, and similar comments on accuracy apply, see the Strength section.

6.3.7 Interaural crosscorrelation
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Calculation of the binaural interaural crosscorrelation parameters are normally done from a binaural pair of impulse responses, measured either with a dummy head or microphones in or close to the ears on a real person. It requires microphone option Binaural pair. (The microphone option Closely spaced omni-directional pair can also be used in the current version of WinMLS, it provides exactly the same processing.) It is not important that the responses are mutually synchronized. The primary response is taken as the left side and the secondary as the right side.

The interaural crosscorrelation function is defined as
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where hL(t) and hR(t) are the left and right ear impulse responses respectively. The interaural crosscorrelation coefficient is taken as:
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WinMLS calculates three versions of the IACC; total with time limits t1=0 and t2=(, early with time limits t1=0 and t2=80ms, and late with time limits t1=80ms and t2=(. The time limits t2 for IACC early (early time) and t1 for IACC late (late time) can be changed in the boxes.

The upper integration limit t2=( for IACC total and late is taken as the truncation point determined in the decay curve formation for the two impulse responses separately, or the end of the impulse responses, according to the integration option specified.

The calculation of IACC is substantially more time consuming than the other parameters, even if it is implemented using a fast frequency domain algorithm. This is especially true for the late and the total versions. If not explicitly needed, these parameters should therefore be excluded from the calculations.

6.3.8 Stage parameter
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Support is defined  in [A. C. Gade, "Investigations on musicians room acoustic conditions in concert halls, II: Field experiments and synthesis of results," Acustica, vol. 69, pp. 249-62 (1989)] as:
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where it is assumed that the response is measured with an omni-directional microphone at a distance of 1m from the source. The time limits are td, the direct time, te, the early time, and tl, the late time. ST1 is defined with direct time 10ms, early time 20ms and late time 100ms. The time limits can be changed in the boxes to provide other versions of the parameter.

6.3.9 Speech transmission indices and modulation transfer function
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The speech transmission index (STI) and the rapid version (RASTI) are single number measures based on both impulse response and signal-to-noise ratio in the room or speech transmission system. The standard IEC-60268-16 [1998, Sound system equipment – Part 16: Objective rating of speech intelligibility by speech transmission index.] describes the measures, which are based on weighted sums of modulation transfer function (MTF) values. The weights currently used in WinMLS are from the original definitions of STI and RASTI [T. Houtgast and H.J.M. Steeneken, "A review of the MTF concept in room acoustics and its use for estimating speech intelligibility in auditoria," J. Acoust. Soc. Am., vol. 77, pp. 1069-1077 (1985)]. The calculations are performed on the primary impulse response.

In the calculation of the MTF the impulse response is taken up to the truncation point determined in the decay curve formation, or the end of the impulse response, according to the integration option specified. The MTF is determined by FFT of the filtered and truncated impulse response, and the values at the exact 1/3-octave modulation frequencies specified are found by linear interpolation. This is a fast and very accurate method for all but extraordinary short impulse responses, and for these the modulation reduction for speech transmission is negligible anyway.

If the MTF is selected, it will be displayed in the grid as shown below. Note that the MTF values are linear. In order to convert to dB you have to compute 20*log10, even though it is in the intensity domain.
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If the background noise is low it will not affect the speech intelligibility. However, the background noise should be taken into account if the speech-to-noise ratio is less than 15 dB in the octave bands of interest. This is done in the compensation settings fond in Room Acoustics->Parameter Settings... and explained below
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6.3.9.1 No noise/speech correction
For this option the background noise is not taken into account. The calculations are based solely on modulation reduction caused by the impulse response, thereby assuming that the speech-to-noise ratio is less than 15 dB in the octave bands of interest. This is most common in room acoustics where the effects of reverberation and reflections usually dominate.

6.3.9.2 Correction, fixed noise/speech
This options takes the background noise and assumed speech spectrum into account. The [image: image696.png]Opions.



 button opens up a new dialog box where the necessary data can be entered as shown below.
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This includes the background noise and the assumed speech level on the microphone, both expressed as octave band sound pressure levels in dB, for the octave bands that are included in the STI calculation. For RASTI only data from the 500Hz and 2kHz bands are used. The background noise can be measured with WinMLS if the input chain (including the microphone) is calibrated. Alternatively a sound level meter may be used to measure the background noise.

6.3.9.3 Correction, noise updated automatically

This option is similar to the above, except that the Noise octave band corrections shown in the figure above are computed and updated automatically from the tail of the measured impulse response. In order to do this, the input chain (including the microphone) must be calibrated. The background noise is computed from the last 10000 samples of the tail. Make sure that the measured impulse response has decayed sufficiently.
Please note that this option should not be used on measurements performed using averaging since the averaging will reduce the effect of the background noise. Therefore use 1 averaging, and an impulse response length larger than 1 second (in a reverberant room, larger than 2 seconds).
The MTF itself can be displayed by selecting it in Room Acoustics->Parameter Settings....

6.3.10 Source to receiver distance

The source to receiver distance is estimated based on the initial time delay detected from the primary impulse response, and the speed of sound, as described in the Window active response section. For the initial time delay, and thereby the source to receiver distance estimation, to be correct, the measurement must be performed with loop-back or a synchronized sound card. Even if this is the case, there will be an extra delay because of the sound card delay. This is set as 40 samples as default (set in Measurement->Sound Card Settings...). However, if measurement system correction is used, this delay will be corrected for (set with the [image: image698.bmp] button in the Measurement Settings Toolbar).

The source to receiver distance is always output in the result grid or file, and is used in some of the reference level calculation procedures described in the Strength section.

6.4 Window Menu Reference

This menu contains standard windows settings and a list of the measurement groups as shown below.
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6.5 Cascade

Arrange the windows so they overlap.

6.6 Title Horizontal

Arrange window vertically as non-overlapping tiles.

6.7 Title Vertical

Arrange window vertically as non-overlapping tiles.

6.8 Arrange Icons

Arrange icons (windows that are minimized) at the bottom of the window.

6.9 List of Windows

Displays the name of the windows that exist.

7 Help Menu Reference
This menu contains Help, About and License information. About contains information about the software, e.g. version number. Help and License is not yet properly implemented.

[image: image700.png]Help Topics.
About WinLS.
License Options.





7.1 Help Topics...

The help-file will be displayed. If you do not have it, the latest version of it can be downloaded from the Download section of www.winmls.com.

7.2 Startup Dialog...

Displays the dialog box that is optionally displayed when WinMLS is started and when a new measurement group is opened.

Click [image: image701.png]


 to select the settings for the type of measurement you want to perform. If you want to load the same settings as the last time you exited WinMLS, click [image: image702.png]Cancel



.

7.3 About WinMLS...
Displays the About dialog box.
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If the [image: image704.png]Support.



 button is clicked the default Internet browser is opened and the homepage www.winmls.com is visited.

7.4 License Options...

Displays the dialog box for registering WinMLS as shown below.
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For an explanation on how to register and transfer the license, see the Registering WinMLS section in the help-file (or in the User’s Guide)..
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